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NUS School of Computing 
AY 2015/16 Semester 2 

CS4340 Digital Special Effects: Lab 1 
 

In this lab you will learn the following: 
1. Green screen setup 
2. Video capture 
3. Background replacement 

Please review the material in these lecture notes before doing this lab: compositing.zip. 

Required Equipment 
Each group requires a camera, a tripod, a green cloth, (and a light if possible).  You may use your own 
equipment if you have them, or else borrow from the School. Please make arrangements with Mr. Chow 
Chin Ming (chowcm@comp.nus.edu.sg) to borrow the equipment before coming to the lab. 

To avoid conflicts, each group should book the Sensors Lab (AS6-05-23) using the following link.  Please book 
only what you need, and not use up all the slots to the exclusion of other lab groups. (There are 4 slots 
marked in the Sensors Lab, so that multiple groups can shoot at the same time.) 

https://docs.google.com/spreadsheets/d/1juMakbi4OOU3WLkDQQ3_zlQ2S_EIbFJhs84JVnS431Y/edit?usp=sharing 

Grading and Submission Deadline 
All captured footages and your composite videos for Parts 1, 2 and 3 should be shown and described to the 
Lab Instructor (Mr. Denny Iskandar, dennyisk@gmail.com) during official lab hours on Tues, 26 Jan, 4pm – 
6pm, in Media Teaching Lab 1 (AS6-04-21). The grades are either “satisfactory” or “unsatisfactory”, based on 
how well each part is completed.  If you receive an “unsatisfactory” grade, please redo that task again until 
the Lab Instructor passes you. Parts 1 and 2 are group activities; so each group should submit one result.  
Part 3 is an individual activity, and thus each student should submit his/her own result.  The deadline for 
submission is 26 Jan. 2016.   

Please start your lab assignment early; do not wait until 26 Jan because you won’t be able to complete the 
assignment in 2 hours. 

Lab Venue 
• Part 1 of this lab may be done in the Sensors Lab (a.k.a. Media Research Lab 12), AS6-05-23. 
• Parts 2 and 3 of this lab may be done in the Media Teaching Lab 1, AS6-04-21. 

Note: Sensors Lab is a shared space. Do NOT remove anything from the lab if it doesn’t belong to you. Do not 
open any boxes or containers without seeking permission. You may move things around the lab to clear a 

 space for your work, but please be careful not to damage anything.

https://docs.google.com/spreadsheets/d/1juMakbi4OOU3WLkDQQ3_zlQ2S_EIbFJhs84JVnS431Y/edit?usp=sharing
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Instructions 

Part 1: The scene setup and capture (Group Activity) 
Each group should have a camera, a tripod, some green (or blue, it does not matter) cloth, a light (and a 
stand for the light, if possible).  Note that the Sensors Lab has 2 small desk lamps (one yellow, one black) 
kept in a green basket that you may use. Return them to the basket after use. 

You will set up the green screen in different ways to see its effects during compositing. 

1. Attach the green cloth to the wall section assigned to you (based on the slot number) using the 
clothes pegs provided, so that the middle part is relatively smooth and crease-free, but at least one 
of the sides has significant creases (Figure 1 (Left)).  

            
Figure 1: (Left) An example of a creased green screen.  (Centre) Leaning against the screen to create 

shadows.  (Right) Creating a bright, non-uniform spot. 
 

2. Position the light to face the wall, and far enough so that your screen is uniformly illuminated (as 
best as you can manage). 

3. Use the tripod to record videos of your teammate. (Note: the actor should not wear any green 
clothing): 

• (Video 1) 10 sec. video: A top-half body shot; with the actor standing about 0.5m away from 
the screen, on the creased part, talking, without much body movement. 

• (Video 2) 10 sec. video: A top-half body shot. The actor leans back onto the screen on the 
non-creased part, talking, without much body movement. Make sure that you capture the 
shadows of the actor.  (Figure 1 (Centre)) 
 

4. Increase the light intensity on the screen by moving the light closer to the green screen, so as to 
create a bright light spot on the green screen (Figure 1 (Right)).  Now attach a smaller piece of green 
cloth to your teammate’s shirt using clothes pegs or safety pins, so that a part of the actor’s clothing 
is the same color as the background. 

5. Shoot a clip of your teammate using this new setup: 
• (Video 3) 10 sec. clip: A top-half body shot. The actor with a shirt with green parts, standing 

0.5m away from the screen, on a very creased part. Make sure to capture the uneven 
illumination and the creased part. 
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6. Show these three videos to the Lab Instructor.  This completes Part 1 of this lab. 

Part 2: Background Removal (Group Activity) 
In this part, you will replace the background of the videos from Part 1 with a static image. 

1. Log in to any PC in the Media Teaching Lab 1 (AS6-04-21) using your NUSNET id. 
2. Create a folder in drive D; call this folder, say, LabOne. 
3. Connect the camera to the PC using the USB cable and copy all three videos into your folder.  

Alternatively, find a way to transfer the videos you recorded in Part 1 to the folder LabOne. 
4. Rename the videos as Video1.avi, Video2.avi, and Video3.avi 
5. Unzip Lab1BG.zip and copy the background images videobg1.jpg to videobg5.jpg to the same folder. 
6. Start Adobe After Effects and create a new project: By default, a new project window is 

automatically opened when After Effects has started up. You can also use File → New → New 
Project to create a new project. 

Basic Background Removal 
7. Import Video1: 

• Use File → Import → Multiple Files to import Video 1 and any of the background images. Select 
the files in the open dialog and click Done to close the window after importing. 

8. Create new composition: 
• You can create a new composition using Composition → New Composition. In this case, you 

may need to set the image size, duration, and other parameters according to the input footages. 
Create a comp by dragging the background image from the Project window to the timeline. Now 
drag and drop the Video1 on the top of the background image in timeline panel.  

• Another more convenient method is to first select the foreground footage in the Project Panel 
window (see Figure 2) by clicking on it, and then choose File → New Comp from Selection. The 
foreground footage is automatically included into the new composition 

• You may change the name of the new composition as follows. In the Project Panel select the 
composition (the Type should be “composition”), click right mouse button, select Rename, enter 
a new name, comp1, and click OK. 

9. Perform keying with Keylight 
• Select the foreground footage in the timeline. Then, select Effect → Keying → Keylight. 
• Set Screen Color by using the dropper to select a color in the green screen background away 

from the actor’s hair. 
• Display Status view to see the transparency values of foreground. 

10. Improve background using Screen Gain and Screen Balance 
• Increase Screen Gain to about 105. This will make the foreground transparent and thus clean up 

the background from crease effects. 
• Decrease Screen Balance to about 0. This step is a bit subjective but improves the green spill a 

little. 
11. Use Screen Despot Black and Screen Despot White to remove the spots in the status display. 
12. Save the project as “Basic BG” 

• Select File Save. 

13. To generate the comp video, do the following:  
• Set the comp resolution of After Effects to FULL.  
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• Select Comp → Make Movie…. Enter a file name for the comp movie. Then, click the Render 
button. Keylight performs a lot of computation. So, the comp rendering can take several 
minutes.  Please be patient. 

• Submit the resulting comp video to the Lab Instructor. 

Dealing With Shadows 
14. Import Video2 with the same background 

• Either replace Video1 with Video 2 or create a new composite. 
15. Remove green spill 

• Turn off Lock Biases Together. 
• Set Despill Bias by using the dropper to select a skin color. 
• The final comp should have no green spill now. 

16. Save the project as “Shadows” 
• Select File Save. 

17. To generate the comp video, do the following:  
• Set the comp resolution of After Effects to FULL.  
• Select Comp → Make Movie…. Enter a file name for the comp movie. Then, click the Render 

button. Keylight performs a lot of computation. So, comp rendering can take several minutes. 
• Submit the resulting comp video to the Lab Instructor. 

Green Shirt Problem 
18. Import Video 3 with the same background 

19. Perform keying with Keylight: 
• Select the foreground footage in the timeline. Then, select Effect → Keying → Keylight.  
• Set the Screen Colour to a color in the dark green screen background.  
• The foreground looks transparent also because the green on the shirt is also removed  
• Look at the Status view 

 
20. To remove the garbage around the subject we will use an outside mask. Using After Effects’ masks, 

draw a spline around the person. This will be called Mask 1 by default. 
21. In Keylight, check that the Outside Mask to Mask 1 and switch on Invert or you’ll be removing the 

person rather than the unwanted pixels at the screen edges 
22. Draw a rough mask (Mask 2) around just the green parts of the shirt. Set the Inside Mask to Mask 2 

and the Replace Method to Source to pull back the original colors. 
23. Save the project as “Green Shirt” 

• Select File Save. 

24. To generate the comp video, do the following:  
• Set the comp resolution of After Effects to FULL.  
• Select Comp → Make Movie…. Enter a file name for the comp movie. Then, click the Render 

button. Keylight performs a lot of computation. So, comp rendering can take several minutes. 
• Submit the resulting comp video to the Lab Instructor. 
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Part 3: Use Your Skills on External Videos (Individual Activity) 

Preparation:  
1. Copy test footages. Create a working folder in drive D. Download Test Set 1 (compositing-test1.zip) 

from www.comp.nus.edu.sg/~cs4340/labs.html into your working folder.  
2. The file compositing-test1.zip contains image sequences in two sub-folders:  

• Girl0000.jpg to Girl0150.jpg in foreground sub-folder: foreground footage over blue screen.  
• T_bg0000.jpg to T_bg0150.jpg in background sub-folder: background footage  

Compositing Exercise 
1. Create a new comp and import footages. 

• Use File → Import → Multiple Files to import all the files in foreground sub-folder. In the Import 
Multiple Files window, select all the foreground images, click on the JPEG Sequence box (Figure 
3 (left)) and then click Open.  Import all the files in background sub-folder in the same manner. 

2. In the Project Panel (Figure 3 (Right)), select the “Girl{00..}.jpg” row, right-click, and select “New 
Comp from Selection”.  The foreground sequence is shown in the Timeline window.  Now drag and 
drop the background sequence from the Project Panel to the Timeline window. 

3. Perform keying with Keylight. 
4. Remove blue spill using Despill Bias.  

• Turn off Lock Biases Together.  
• Set Despill Bias by using the dropper to suelect a skin color. 

5. Improve transparency of the gauze.  
• Switch the view to Status (in the Effects Control Panel).  
• Increase and decrease the Clip Black to make the gauze more or less transparent.  
• Increase or decrease Clip White to make the girl more opaque. 
• Make sure that the hands and legs are opaque. Reduce fringes around the foreground. Use 

Screen Gain, Screen Balance, Clip Black, Clip White, and Screen Shrink appropriately. 
6. Remove spots in foreground and background  

• There are some spots in the foreground and background.  
• Increase Screen Despot Black and Screen Despot White to about 2.  
• The resulting comp should look ok now, like the following:  

2. Save project as “Girl” 
25. To generate the comp video, do the following:  

• Set the comp resolution of After Effects to FULL.  
• Select Comp → Make Movie…. Enter a file name for the comp movie. Then, click the Render 

button. Keylight performs a lot of computation. So, comp rendering can take several minutes. 
• Submit the resulting comp video to the Lab Instructor. 

 

Submission Checklist 
• Video 1 (captured video) 
• Video 2 (captured video) 
• Video 3 (captured video) 
• Basic BG (comp video) 
• Shadows (comp video) 
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• Green Shirt (comp video) 
• Girl (comp video) 

 
Notes:  
 

1. At any time, you can preview your comp as follows:  
• Use the Preview Panel to check whether the settings are ok for every frame. Make further 

adjustments if necessary.  
• By clicking the Next Frame or Previous Frame button, you can forward or reverse the comp one 

frame at a time.  
• By sliding the Time Indicator button, you can quickly go through each frame to see whether they 

are ok. This procedure is called “scrubbing the video”.  
• If your computer is not fast enough or does not have enough memory, you can set the comp 

resolution to Half, Third, or Quarter. Resolution setting is located at the bottom of the 
Composition window.  

• You can also click the Play button to see the rendered composition. To stop, click the Play 
button or anywhere in the Preview Panel or Composition window.  

• To see how the rendered composition looks like in real-time, click the RAM Preview button. 
After Effects will render the comp in RAM and then show the video in real-time. Rendering the 
comp in Full resolution can take some time. To stop, click anywhere in the Preview Panel or 
Composition window.  

• If your computer is not fast enough or does not have enough memory, you can set the comp 
resolution to Half, 1/3 or 1/4.  

2. To generate the comp video, do the following:  
• Set the comp resolution of After Effects to FULL.  
• Select Comp → Make Movie…. Enter a file name for the comp movie. Then, click the Render 

button. Keylight performs a lot of computation. So, comp rendering can take several 
minutes. 

3. For extra practice, you may wish to use the materials at Hollywood Camera Work: 
http://www.hollywoodcamerawork.com/greenscreenplates.html 

http://www.hollywoodcamerawork.com/greenscreenplates.html
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Figure 2: AE window 

 

   
Figure 3: Importing jpeg files as a sequence (Left); Project Panel (Right) 
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