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Chapter 1: Getting started

Installation and registration

To install
1 Close any Adobe® applications that are open.

2 Insert the product disc into your computer’s DVD drive.

3 Double-click the disc icon, and then follow the on-screen instructions.

After installing the product for the first time on a computer, you will be prompted to activate your copy of the

product. (See “To activate” on page 1.)

For more detailed instructions for installing or uninstalling the product, see the ReadMe file on the product disc.

To activate
Activation is a simple, anonymous process that you must complete within 30 days of installing the product.

Activation allows you to continue using the product, and it helps prevent casual copying of the product onto more

computers than the license agreement allows. After you have installed the product for the first time on a computer,

the Activation dialog box opens, prompting you to activate your copy of the product.

1 If the Activation dialog box is not already open, start the product and choose Help > Activate.

2 Follow the on-screen instructions.

Important: If you want to install the product on a different computer, you must first transfer the activation to that

computer. To transfer an activation, choose Help > Transfer Activation.

To learn more about activation, visit the Adobe website at www.adobe.com/activation/main.html.

To register
Register your Adobe product to receive complimentary support on installation and product defects and notifications

about product updates.

Registering your product also gives you access to the wealth of tips, tricks, and tutorials in Adobe Studio® and access

to Adobe Studio Exchange, an online community where users download and share thousands of free actions,

plug-ins, and other content for use with Adobe products.

Note: An active Internet connection is required for registration.

The Registration dialog box may open after activation, prompting you to register your copy of the product.

1 If the Registration dialog box is not already open, start the product and choose Help > Registration.

2 Follow the on-screen instructions.

See also

“Adobe Studio” on page 6

http://www.adobe.com/activation/main.html
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Adobe Help Center

About Adobe Help Center
Adobe® Help Center is a free, downloadable application that includes three primary features.

Product Help Provides Help for Adobe desktop products installed on your system. (If no Adobe desktop products

are installed, topics for them aren’t available.) Help topics are updated periodically and can be downloaded through

Adobe Help Center preferences. For the products you’ve installed, Product Help also provides dynamic listings of

the top support issues and the most recent support documents published on Adobe.com.

Expert Support Provides information about Adobe Expert Support plans and lets you store details about plans

you’ve purchased. If you have an active support plan, you can also use the Expert Support section to submit web

cases—questions sent to Adobe support professionals over the web. To access links in the Expert Support section,

you must have an active Internet connection.

More Resources Provides easy access to the extensive resources on Adobe.com, including support pages, user

forums, tips and tutorials, and training. You can also use this area to store contact information for friends, colleagues,

or support professionals, or even websites you turn to for inspiration or troubleshooting information.

See also

“Using Help” on page 3

“To search Help topics” on page 4

“To navigate Help” on page 4

“To view support documents” on page 3

To check for updates
Adobe periodically provides updates to software and to topics in Adobe Help Center. You can easily obtain these

updates through Adobe Help Center. An active Internet connection is required.

1 Click the Preferences button in the top-right corner.

2 In the Preferences dialog box, click Check For Updates. If updates are available, follow the on-screen directions to

download and save them.

You can also check for updates from within many Adobe applications by choosing Help > Updates.

To set Adobe Help Center preferences
1 Click the Preferences button in the top-right corner.

2 Set any of the following options, and click OK.

Region Specifies your geographical location. Changing this option may affect which services are available to you.

Language Specifies the language in which Expert Support content is displayed.

Display Renewal Reminders For Expert Support Contracts Displays reminder screens when your Expert Support

plan has almost expired. Deselect this option if you’d like to turn off these reminders.

Enable Auto Login For Web Case Submission Allows you to submit support questions over the web. This option is

available only if you have an active Expert Support plan.
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User Interface Language Specifies the language in which Adobe Help Center interface text is displayed.

Check For Updates Searches for new updates to software and Help topics as they become available from Adobe. This

option also lets you specify notification options and choose which applications to update.

Network Administrators Displays options for network administration.

To view support documents
From within Adobe Help Center, you can get up-to-the-minute listings of the top support issues and the most recent

documents added to the support knowledgebase. Each time you start Adobe Help Center, it uses RSS (Really Simple

Syndication) technology to gather this information from the Adobe website and update the listings dynamically.

1 In Adobe Help Center, click Product Help and select a product from the For menu.

2 Click the Contents tab in the navigation pane, and do either of the following:

• Click Recent Documents to display a summary of the most recent documents for the selected product.

• Click Top Issues to display a summary of the top issues documents for the selected product.

3 To view a document in full on the Adobe website, click its link. (An active Internet connection is required.)

To display More Resources
The More Resources section in Adobe Help Center provides easy access to some of the content and services available

from the Adobe website, including support, training, tutorials, and forums.

❖ To display this section, click More Resources.

To add contact information in More Resources
1 Click More Resources, and then click Personal Contacts.

2 Do any of the following:

• To add a contact, click New, type the contact information you want to save, and click OK.

• To edit a contact, click a contact in the list, click Edit, make changes to the information, and click OK.

• To delete a contact, click a contact in the list, and then click Delete. To confirm the deletion, click Yes.

Using Help

Using Help
The complete documentation for using your Adobe product is available in Help, a browser-based system you can

access through Adobe Help Center. Help topics are updated periodically, so you can always be sure to have the most

recent information available. For details, see “To check for updates” on page 2.

Important: Adobe Help systems include all of the information in the printed user guides, plus additional information

not included in print. A PDF version of the complete Help content, optimized for printing, is also provided on the CD or

DVD in the product box.
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See also

“To navigate Help” on page 4

“To search Help topics” on page 4

To navigate Help
❖ Do any of the following:

• To view Help for a product, choose the product name from the For menu.

• To expand or collapse a section, click the blue triangle to the left of the section name.

• To display a topic, click its title.

See also

“To use bookmarks” on page 5

To search Help topics
Search using words or phrases to quickly find topics. You can search Help for one product or for all Adobe products

you’ve installed. If you find a topic that you may want to view again, bookmark it for quick retrieval.

1 In Adobe Help Center, click Product Help, and choose a product from the For menu.

2 Type one or more words in the Search For box, and choose an option from the In menu:

This Product Searches Help for the selected product.

All Products Searches Help for all Adobe products you have installed.

3 Click Search. Topics matching the search words appear in the navigation pane, grouped by product and listed in

order of relevance.

4 To view a topic, click its title.

5 To return to the navigation pane, do one of the following:

• Click the Home button.

• Click the Back button.

• Click Next Topic or Previous Topic.

See also

“To print a topic from Help” on page 5

“To use bookmarks” on page 5

Search tips
The search feature in Adobe Help Center works by searching the entire Help text for topics that contain any of the

words typed in the Search For box. These tips can help you improve your search results in Help:

• If you search using a phrase, such as “shape tool,” put quotation marks around the phrase. The search returns only

those topics containing all words in the phrase.

• Make sure that the search terms are spelled correctly.
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• If a search term doesn’t yield results, try using a synonym, such as “web” instead of “Internet.”

To print a topic from Help
1 Select the topic you want to print, and click the Print button.

2 Choose the printer you’d like to use, and then click Print.

To change the view
By default, Adobe Help Center opens in Full view. Full view gives you access to the Product Help, Expert Support,

and More Resources sections. Switch to Compact view when you want to see only the selected Help topic and you

want to keep the Help window on top of your product workspace.

❖ Click the view icon  to switch between Full and Compact views.

To use bookmarks
You can bookmark especially helpful topics for easy access, just as you bookmark pages in a web browser, and reread

them at another time.

• To view bookmarks, click the Bookmarks tab in the navigation pane.

• To create a bookmark, select the topic you want to mark, and click the Bookmark button . When the New

Bookmark dialog box appears, type a new name in the text box if desired, and then click OK.

• To delete a bookmark, select it in the Bookmarks pane, and click the Delete button. Click Yes to confirm the

deletion.

• To rename a bookmark, select it in the Bookmarks pane, and then click the Rename Bookmark button . In the

dialog box, type a new name for the bookmark and then click OK.

• To move a bookmark, select it in the Bookmarks pane, and then click the Move Up button or the Move Down

button .

Tips, training, and other resources

Learning resources
Adobe provides a wide range of resources to help you learn and use Adobe products.

• “Total Training Video Workshop DVD” on page 6: Professional training videos from experts.

• “Adobe Studio” on page 6: Videos, tips and tricks, and other learning material on Adobe products.

• “Other resources” on page 7: Training, books, user forums, product certification, and more.

• Support: Complimentary and paid technical support options from Adobe.

• “Extras and other downloads” on page 7: Other software and content.

See also

“About Adobe Help Center” on page 2

“Using Help” on page 3



ADOBE AFTER EFFECTS 7.0
User Guide

6

Total Training Video Workshop DVD
Presented by experts in their fields, Total Training videos provide overviews, demonstrations of key new features,

and many useful tips and techniques for beginning and advanced users. Look for accompanying step-by-step

instructions to selected Total Training videos in monthly updates to Adobe Studio.

In addition to the Total Training Video Workshop DVD included with your software, short Total Training web

videos on a variety of products and topics are also available in Adobe Studio, and complete Total Training courseware

can be purchased online from the Adobe Store.

See also

“Adobe Studio” on page 6

Adobe Studio
Adobe Studio provides a wealth of tips, tricks, tutorials, and instructional content in video, PDF, and HTML formats,

authored by experts from Adobe and its publishing partners. You can search the entire collection or sort by product,

topic, date, and type of content; new content is added monthly. Adobe Studio is available in English, French, German,

and Japanese. Find it from the home page of the Adobe website.

Tips and tutorials in Adobe Studio

For free content and add-ons, visit Adobe Studio Exchange, an online community where users download and share

thousands of free actions, plug-ins, and other content for use with Adobe products. To visit Adobe Studio Exchange,

go to Adobe Studio from the home page of the Adobe website.
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See also

“Total Training Video Workshop DVD” on page 6

“Other resources” on page 7

Other resources
Additional sources of information and help are available for Adobe products.

• Visit the Training area of the Adobe website for access to Adobe Press books; online, video, and instructor-led

training resources; Adobe software certification programs; and more.

• Visit the Adobe user forums, where users share tips, ask questions, and find out how others are getting the most

out of their software. User forums are available in English, French, German, and Japanese from the main Support

page of your local Adobe website.

• Visit the Support area of the Adobe website for additional information about free and paid technical support

options. Top issues are listed by product on the Adobe U.S. and Adobe Japan websites.

• Click More Resources in Adobe Help Center to access many of the resources on the Adobe website and to create

your own list of frequently visited user groups and websites and valuable contacts.

• For complete developer documentation and resources, visit the Developers area of the Adobe website at

http://partners.adobe.com/public/developer/main.html. For additional backgrounders and instructional content,

visit Adobe Studio.

Extras and other downloads
Your product includes Adobe Stock Photos, an integrated service available within Adobe Bridge that lets you search,

view, try, and buy royalty-free stock photography from leading stock libraries. Because of the tight integration

between Stock Photos and Adobe products, you can download images directly into your projects.

The Downloads area of the Adobe website includes free updates, tryouts, and other useful software. In addition, the

Plug-ins section of the Adobe Store provides access to thousands of plug-ins from third-party developers, helping

you automate tasks, customize workflows, create specialized professional effects, and more.

Adobe periodically provides downloadable updates to topics in Adobe Help Center and to Adobe Help Center

software itself.

See also

“About Adobe Bridge” on page 24

“About Adobe Stock Photos” on page 40

“Adobe Studio” on page 6

“Other resources” on page 7

“About Adobe Help Center” on page 2

http://partners.adobe.com/public/developer/main.html
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New features

What’s new
Redesigned, unified user interface Work within an elegantly redesigned interface featuring dockable panels that

eliminate overlapping windows and let you rearrange your workspace quickly and easily. Save custom workspaces,

control user interface brightness, and more. (See “About the Adobe workspace” on page 14.)

Graph Editor Create precise animations with the new Graph Editor, which offers complete visual control over

keyframe editing and easy synchronization of animated properties across layers. (See “About the Graph Editor” on

page 188.)

High dynamic range (HDR) color (Pro only) Match the behavior of color and light in the real world with new 32-bit-

per-channel floating-point HDR color support. (See “High dynamic range footage (Pro only)” on page 62.)

Animation presets and project templates Produce great-looking animations quickly using hundreds of fully

customizable behaviors and other animation presets, including presets for animating text, effects, transitions,

background movies, and expressions. Save your own animation properties as reusable presets. (See “About animation

presets” on page 202.)

High-fidelity OpenGL support Experience better, faster previewing and rendering with OpenGL 2.0 capabilities,

including support for blending modes, motion blur on 2D layers, anti-aliasing, track mattes, shadows, and accel-

erated rendering of common effects. (See “Supported OpenGL features” on page 140.)

Timewarp (Pro only) Slow down and speed up footage with smooth, crisp results and minimal artifacts. (See “To

apply the Timewarp effect (Pro only)” on page 239.)

Adobe Bridge Simplify the everyday tasks of asset management with Adobe Bridge, which offers powerful ways to

browse and search digital assets, preview and apply presets, work with metadata, manage files, and run batch

processes. (See “About Adobe Bridge” on page 24.)

Expanded file format support Take advantage of new support for HDV, Camera Raw, OpenEXR, AAF, 10-bpc YUV

(v210), and 32-bpc TIFF and PSD formats. Support for some file formats is available only in the Professional edition.

(See “Supported file formats for import” on page 69 and “Supported file formats for output” on page 590.)

Unmatched integration with Adobe Photoshop CS2 and Adobe Production Studio Experience tighter integration

with Adobe graphics and video tools: Create Photoshop® layers within After Effects®, export After Effects projects as

Adobe Premiere® Pro projects (Windows only), use Adobe Dynamic Link to update After Effects compositions

without rendering, and more. (See “To create a new Photoshop layer” on page 152, “Working with After Effects and

Adobe Premiere Pro” on page 94, and “About Adobe Dynamic Link (Adobe Production Studio only)” on page 632.)

Creative blur effects Recreate the effect of a defocused camera lens more easily and realistically with the new Lens

Blur, and use the new Smart Blur to create soft color without destroying fine detail. Use a variety of other blur effects

for specific situations, including Fast Blur, Box Blur, and Compound Blur. (See “Blur & Sharpen effects gallery” on

page 369.)
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Chapter 2: Workflow and workspace

Workflow and workspace basics

Workflow overview
Whether you use Adobe After Effects to animate a simple title or create complex special effects, you generally follow

the same basic workflow. The After Effects 7.0 interface facilitates your work and adapts to each stage of the process.

After Effects workflow
1 Import and organize footage 2 Create compositions and arrange layers 3 Add effects and modify layer properties 4 Animate 5 Preview your
work 6 Export

Import and organize footage

After you start a project, add your footage to the Project panel. After Effects automatically interprets many common

media formats, but you may also specify how you want After Effects to interpret attributes such as frame rate and

pixel aspect ratio. You can open and view each item in a Footage panel and set its start and end times to fit your

composition. For more information, see “Working with imported files” on page 68.

Imported footage initially appears in Project panel

Create compositions and arrange layers

abcabc

1 2 3 4 5 6

abcabc

abcabc
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Create one or more compositions. Any footage item can become one or more layers in a composition. You can

arrange the layers spatially in the Composition panel or arrange them in time using the Timeline panel. You can stack

layers in two dimensions or arrange them in three, using 3D light sources and camera views. You can use masks,

blending modes, and keying tools, to composite, or combine the images of multiple layers. For more information, see

“About compositions” on page 109 and “About layers” on page 149.

Work with layers in Timeline panel

Add effects and modify layer properties

You can add any combination of effects and modify any of a layer’s properties, such as size, placement, and opacity.

Using effects, you can alter a layer’s appearance or sound, and even generate visual elements from scratch. You can

apply any of the hundreds of effects included with After Effects, or create and reuse your own. For more information,

see “About effects” on page 348.

abcabc
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Add effects to layers

Animate

You can make any combination of a layer’s properties change over time, using conventional keyframing, expressions,

or even keyframe assistants. With the Graph Editor, you can add, delete, and modify keyframes, and specify inter-

polation methods. With the powerful expression feature, you can animate and link properties using preset or

customized scripts instead of keyframes. You can apply any of the hundreds of preset animations included with After

Effects, or create and reuse your own. Use the Tracker Controls panel to stabilize motion or to animate one layer so

that it follows the motion in another layer. For more information, see “About animation and layer properties” on

page 188, “About animation presets” on page 202, “About motion tracking (Pro only)” on page 329, and “About

expressions” on page 555.

abcabc
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Use keyframes to animate layers

Preview your work

Previewing compositions is fast and convenient, even for complex projects, especially if you use OpenGL technology

to accelerate previews. You can change the speed and quality of previews by specifying their resolution and frame

rate, and by limiting the area and duration of the composition that you preview. For more information, see “Methods

for previewing compositions” on page 134.

abcabc
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Previewing methods
A. RAM preview in Time Controls panel B. Cache indicator in Timeline panel C. Fast Previews

Export

Add one or more compositions to the render queue to render them at the quality settings you choose, and create

movies in the formats that you specify. For more information, see “About rendering” on page 590.

B CA
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Dragging compositions to Render Queue panel

About the Adobe workspace
Adobe video and audio applications provide a consistent, customizable workspace. Although each application has its

own set of panels (such as Tools, Properties, Timeline, and so on), you move and group panels on your computer

screen in the same way across products.

The main window of a program is the application window. The various panels are organized in this window in an

arrangement called a workspace. The default workspace contains groups of panels as well as panels that stand alone.

You customize a workspace by arranging the panels, usually by dragging them, in the layout that best suits your style

of working. You can create and save several custom workspaces for different tasks—for example, one for editing and

one for previewing.

You can drag panels to new locations, move panels into or out of a group, place panels alongside each other, and

undock a panel so that it floats in a new window above the application window. As you rearrange panels, the other

panels resize automatically to fit the window.

You can use floating windows to create a workspace more like those in previous versions of Adobe applications, or to

place panels on multiple monitors.
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Example of workspace
A. Application window B. Grouped panels C. Panels

To scroll or zoom in panels
If your mouse has a wheel for scrolling, you can zoom in the Timeline, Project, Render Queue, Composition, Layer,

Footage, Flowchart, Effect Controls, and Effects & Presets panels, and scroll in the Timeline, Project, Render Queue,

Flowchart, Effect Controls, and Effects & Presets panels.

❖ Do any of the following:

• To zoom into the center of the panel, or into the feature region when tracking, roll the mouse wheel forward.

• To zoom out of the center of the panel, or out of the feature region when tracking, roll the mouse wheel backward.

• To zoom into the area under the pointer, hold down Alt (Windows) or Option (Mac OS) as you roll the mouse

wheel forward.

• To zoom out of the area under the pointer, hold down Alt (Windows) or Option (Mac OS) as you roll the mouse

wheel backward.

• To scroll vertically, roll the mouse wheel forward or backward.

• To scroll horizontally, hold down Shift as you roll the mouse wheel backward or forward. When you are in the

Timeline panel, rolling backward moves you forward in time and vice versa.

You can scroll in a panel even if it is not currently active, as long as you move the pointer over it. For instance, you

can scroll in the Composition panel even if the Effect Controls panel is currently active.

B C
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To display menus
In addition to choosing from the menus at the top of your screen, you can choose from context menus, which display

commands relative to the active tool or selected item. Panel menus display commands relative to the active panel.

• To display panel menus, click the triangle in the upper right corner of the panel.

Displaying panel menu by clicking triangle

• To display context menus, right-click (Windows) or press Control and hold down the mouse button (Mac OS).

Customizing the workspace

Drop zones
Drop zones are areas onto which you can drop or move panels. As you drag a panel, the drop zones become

highlighted. The drop zone determines where and how the panel is inserted into the workspace. Dragging a panel to

a drop zone results in one of two behaviors: docking or grouping.

Docking

Drop zones along the edges of a panel, group, or window are docking zones. Docking a panel places it adjacent to the

existing group, resizing all groups to accommodate the new panel.

Dragging panel (A) onto docking zone (B) to dock it (C)

Grouping

The drop zone in the middle of a panel or group, as well as the zone along the tab area of a panel, are grouping zones.

Grouping a panel adds it to an existing group, placing it at the top of the stacking order. Grouping a panel does not

resize other groups.

C 
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Dragging panel (A) onto grouping zone (B) to group it with existing panels (C)

To dock or group panels
You dock and group panels by dragging them onto drop zones. As you drag a panel over a drop zone, the zone

becomes highlighted to provide a visual reference for the drop.

Drag the gripper area in the upper left corner of a panel’s tab to move an individual panel. Drag the group gripper at

the upper right corner to move an entire group.

Dragging panel gripper (A) to move one panel; dragging group gripper (B) to move entire group

1 Select the panel you want to dock or group by clicking its tab. If the panel is not visible, choose it from the Window

menu to open it.

2 Drag the panel by its tab onto the desired drop zone. The application docks or groups the panel, according to the

type of drop zone.

See also

“Drop zones” on page 16

To open a panel in a floating window
You can open a panel in a floating window. You can add panels to the floating window or otherwise modify it, as you

do the application window. You can use floating windows to create a workspace like those in earlier versions of

Adobe applications, or to make use of a secondary monitor.

❖ Select the panel you want to open (if it’s not visible, choose it from the Window menu), and then do one of the

following:

• Choose Undock Panel or Undock Frame from the panel menu. Undock Frame undocks the panel group.
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• Ctrl-click (Windows) or Command-click (Mac OS) and drag the panel or group from its current location. When

you release the mouse, the panel or group appears in a new floating window.

• Drag the panel or group outside the application window. (If the application window is maximized, drag the panel

to the Windows task bar.)

To close a panel or window
When you close a panel group in the application window, the other groups are resized to make use of the newly

available space. When you close a floating window, the panels within it close, too.

❖ Click the Close button  on the panel or window that you want to close.

To resize panel groups
The dividers between panel groups have resize handles. You resize a group in one direction at a time, either vertically

or horizontally. When you drag a divider between panel groups, all groups that share the divider are resized. For

example, suppose your workspace contains three panel groups stacked vertically. If you drag the divider between the

bottom two, they are resized, but the topmost group doesn’t change.

You can quickly maximize a panel beneath the pointer by pressing the tilde (~) key. (Do not press the Shift key.) Press

the tilde key again to return the panel to its original size.

1 Position the pointer over the divider between the panel groups that you want to resize. The pointer changes

shape .

2 Hold down the mouse button, and drag to resize the panel groups.

Dragging divider between panel groups to resize them
A. Original group with divider selected B. Resized groups

Working with multiple monitors
You can use multiple monitors to increase the available screen space. When you work with multiple monitors, the

application window appears on the main monitor, and you place a floating window on the second monitor. Monitor

configurations are stored in the workspace.

To show or hide a panel
You can use the Window menu to show and hide panels. Even if a panel is open, it may be out of sight, beneath other

open panels. Choosing a panel from the Window menu opens it and brings it to the front.

❖ From the Window menu, choose the panel you want to show or hide.

A B
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To brighten or darken the user interface
You can brighten or darken the After Effects user interface. Changing the brightness preference affects panels,

windows, and dialog boxes.

1 Choose Edit > Preferences > User Interface Colors (Windows) or After Effects > Preferences > User Interface

Colors (Mac OS).

2 Drag the User Interface Brightness slider to the left or right. Click Default to restore the default brightness level.

Note: After Effects for Windows supports ClearType text anti-aliasing. ClearType sharpens the outlines of system text,

such as menus and dialog boxes, making it easier to read. See Windows Help for information on how to enable ClearType

text anti-aliasing.

Predefined workspaces

To use an Adobe workspace
Each Adobe video and audio application includes several workspaces for various tasks. For example, Adobe Encore®

DVD has workspaces for editing in the Timeline and for designing slideshows, menus, and navigation. You can

choose a workspace at any time. When you choose one of these workspaces, the current workspace is redrawn

accordingly.

❖ With the project you want to work on open, choose Window > Workspace, and select the desired workspace.

To create or modify a workspace
As you modify a workspace, the application tracks changes, saving any modifications with the project. The next time

you open the project, the most recent version of the workspace is used. You can also choose to restore the original

layout of the workspace.

You can save any workspace, at any time, as a custom workspace. Once saved, new and edited workspaces appear in

the Workspace menu on the local computer. If a project with a custom workspace is opened on a system other than

the one on which it was created, the application looks for a workspace with a matching name. If the application finds

a match (and the monitor configuration matches), it uses that workspace; if it can’t find a match (or the monitor

configuration doesn’t match), it opens the project using the current local workspace.

❖ Arrange the frames and panels as desired, then choose Window > Workspace > New Workspace, and enter a name

for the workspace. Click OK.

To restore a workspace
You can remove changes made to a workspace, restoring its original layout.

❖ With the workspace you want to restore active, choose Window > Workspace > Reset [workspace name], and then

click Discard Changes.

To delete a workspace
1 Choose Window > Workspace > Delete Workspace.

2 Choose the workspace you want to delete, and then click Delete.
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Working with panels

About panels
By default, After Effects organizes panels in the Standard workspace configuration. You can choose from a number

of preconfigured workspaces, customize these workspaces, or create new workspaces. Workspaces remember panel

locations even if the panels aren’t open. The Standard workspace displays the Project, Composition, Timeline, Info,

Audio, Time Controls, and Effects & Presets panels.

For information about specific panels, search for the panel name in Help.

You can assign keyboard shortcuts to workspaces: Choose Window > Assign Shortcut To [Workspace Name]

Workspace.

Standard workspace
A. Menus of preconfigured workspaces B. Effects & Presets panel

Note: If After Effects displays more grouped panels than can be displayed at once, drag the slider bar that appears above

the tabs.

Dragging slider bar to display other tabs.

See also

“To dock or group panels” on page 17
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To work with panel columns

You can work with columns in the Project, Timeline, and Render Queue panels.

❖ Do any of the following:

• To display or hide a column, choose Columns from the panel menu and select the column you want to display or

hide. A check mark indicates that the column is visible.

• To resize a column, drag the bar to the right of a column name. Drag to the left to make the column smaller and

to the right to make it larger. You can’t change the size of the Duration column in the Project panel.

• To change the order of columns, select the column name and drag it to a new location.

To expand collapsed items

You can expand collapsed items in a panel. For example, you can expand collapsed items in the Timeline panel or

the Effects & Presets panel.

❖ Ctrl+Shift-click (Windows) or Command+Shift-click (Mac OS) the item.

About the Layer and Footage panels
Use the Layer and Footage panels to preview and edit different parts of a project. These panels share a set of controls

that you can use to view safe zones (the visible areas of a television screen), identify RGB and alpha channels, and

change the magnification. These controls function the same way in both panels. Although the Layer and Footage

panels share some controls, you typically perform different tasks in each panel. Use the Layer panel to create or edit

masks, animate anchor points, and paint. Use the Footage panel to evaluate, trim, and insert movies.

In addition to the shared controls, the Layer panel also contains the View menu and the Render check box. After

Effects switches the view according to your actions. For example, if you select the Pen tool, After Effects switches to

Masks view so that you can create or edit a mask. Select Render to view any changes to the layer (such as masks or

effects), and deselect it to view the original, unaltered layer.

To choose a view in the Layer panel

1 Open a Layer panel by double-clicking the layer in the Timeline panel.

2 Choose a view from the View menu in the Layer panel:

Masks Displays existing masks.

Anchor Point Path Displays existing anchor points.

Motion Tracker Points Displays existing tracking points.

Effects Displays the effect when Render is selected. (The effects are identified by name, for instance, Paint.)

To display footage

The standard Footage panel displays viewing and editing controls (the trimming tools and so forth) that are also

found in the Layer and Composition panels. The default Footage panel for movie files, however, displays movie

controls instead. Use these movie controls (either QuickTime or Video For Windows controls, depending on the

footage type) to play the movie and any included audio. To use the After Effects viewing and editing controls for

movie files, you must open movie files in the standard Footage panel.

Note: AVI files larger than 2 GB appear in the standard Footage panel, not the default movie file Footage panel.

❖ Do one of the following:

• To display a footage item in the default Footage panel, double-click a footage item in the Project panel.
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• To display MOV or AVI movies in the standard Footage panel, Alt-double-click (Windows) or Option-double-

click (Mac OS) the footage item in the Project panel.

About the Tools panel

Tool panel
A. Selection B. Hand C. Zoom D. Rotation E. Orbit Camera, Track XY Camera, Track Z Camera F. Pan Behind G. Rectangular Mask,
Elliptical Mask H. Pen, Add Vertex, Delete Vertex, Convert Vertex I. Horizontal Type, Vertical Type J. Brush K. Clone Stamp L. Eraser
M. Axis Mode buttons

Note: Related options for some tools appear when the tool is selected.

To select a tool

❖ Do one of the following:

• Click the tool’s icon. If the icon has a small triangle at its lower right corner, hold down the mouse button to view

the hidden tools. Then, click the tool you want to select.

• Press the tool’s keyboard shortcut. Positioning the pointer over a tool displays a tool tip with the tool’s name and

keyboard shortcut.

• To cycle through hidden tools, hold down Shift and press the tool’s shortcut key.

• To momentarily change from one tool to another tool, hold down the shortcut key for the desired tool; release the

shortcut key to return to the previous tool. (This technique works with most tools.)

To view optional panels for a tool, click the desired tool icon, and then click the panel icon  if available.

See also

“Keys for selecting tools” on page 642

To show or hide tool tips

1 Choose Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS).

2 Select or deselect Show Tool Tips.

About the Info panel
The Info panel provides context-sensitive information, such as the progress of rendering a preview. As you drag

across a footage frame in the Composition, Layer, or Footage panel, the Info panel describes the area under the

pointer. This panel displays values for the pixel color (R,G,B), alpha channel (A), and coordinates of the current

position. When you modify a layer property graphically, the bottom portion of this panel displays precise values that

relate to the layer instead of the pointer. For example, when you drag a layer, the Info panel displays the coordinates

of the layer’s center point and the offset from its last position. This makes it easy to move a layer by a specific number

of pixels in either direction. If a keyframe is selected, the Info panel displays the keyframe’s spatial and temporal state

as well as its position in time. Alt-click (Windows) or Option-click (Mac OS) two markers or keyframes to display

the duration between them in the Info panel.
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To change the Info panel RGBA display, choose an option such as Percent or Web from the Info panel menu. Selecting

Auto Color Display automatically switches between 8 bits per channel, 16 bits per channel, and 32 bits per channel

depending on the project’s color depth. This setting also affects the units displayed on some Effects sliders.

The X coordinate represents position in the horizontal axis, and the Y coordinate represents position in the vertical

axis. Values for these coordinates are in pixels. The X and Y coordinates are relative to the origin (0,0), which is fixed

at the upper left corner of the image area. The upper right portion of the Info panel displays the X and Y coordinates

of the pointer. As you drag a layer, the lower portion of the Info panel displays the X and Y coordinates of the layer’s

anchor point. The lower portion of the Info panel also displays Z coordinates if the layer includes 3D animation.

If the zero point differs from the origin, X' and Y' coordinates appear in the Info panel below the X and Y coordinates.

These values measure the distance from the zero point or the ruler.

Note: The origin of the image area is different than the origin, or zero point, of the rulers. You can set the ruler’s zero

point to match the origin of the image area, but you cannot change the origin of the image area.

See also

“About color depth” on page 61
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Chapter 3: Adobe Bridge and Stock
Photos

The basics of Bridge

About Adobe Bridge
You can use Adobe Bridge to organize, browse, and locate the assets you need to create content for print, the web,

television, DVD, film, and mobile devices. Adobe Bridge keeps native Adobe files (such as PSD and PDF) as well as

non-Adobe application files available for easy access. You can drag assets into your layouts, projects, and composi-

tions as needed, preview them, and even add metadata (file information), making the files easier to locate. Bridge is

available independently, as well as from within many Adobe applications.

File browsing From Bridge you can view, search, sort, manage, and process image files. You can use Bridge to create

new folders; rename, move, and delete files; edit metadata; rotate images; and run batch commands. You can also

view information about files and data imported from your digital or DV camera.

Version Cue If you have Adobe Creative Suite 2, you can use Bridge as a central location from which to use Adobe

Version Cue®. From Bridge, you can browse all the files in a project in one place without having to start the native

application for each file, including non-Adobe application files. Also, you can create new Version Cue projects, delete

projects, create versions, save alternates, and set access privileges in Bridge.

Note: Adobe Version Cue is not included with Production Studio.

Bridge Center If you have Adobe Creative Suite 2, Adobe Bridge includes Bridge Center, where you can view news

readers in your web browser, see your most recent activity, read about tips and tricks for using Adobe products, save

groups of files, and more. Adobe Creative Suite 2 users can also use Bridge to specify color management settings and

access scripts that help automate your workflow.

Note: Bridge Center is not included with Production Studio.

Camera Raw If you have Adobe Photoshop® or Adobe After Effects installed, you can open or import camera raw

files from Bridge, edit them, and save them in a Photoshop-compatible format. You can edit the image settings

directly in the Camera Raw dialog box without starting Photoshop. If you don’t have Photoshop or After Effects

installed, you can still preview the camera raw files in Bridge.

Stock Photos Click Adobe Stock Photos from the Favorites pane in Bridge to search leading stock libraries for

royalty-free images. You can download low-resolution, complimentary versions of the images and try them out in

your projects before purchasing them.

Color management You can use Bridge to synchronize color settings across Adobe Creative Suite 2 applications.

This synchronization ensures that colors look the same no matter which Creative Suite application you view them in.

See also

“About Adobe Stock Photos” on page 40
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The Bridge work area
These are the main components of the Adobe Bridge window:

The Look In menu Lists the folder hierarchy, as well as favorite and recent folders. This menu gives you a quick way

to find folders containing the items you want to display. The menu is at the top of the Bridge window.

The Favorites panel Gives you quick access to folders as well as to Adobe Stock Photos and collections. If you have

Adobe Creative Suite 2, you also have access to Version Cue and Bridge Center.

The Folders panel Shows the folder hierarchy. Use it to navigate to the correct folder.

The Preview panel Displays a preview of the selected file. The preview is separate from, and typically larger than, the

thumbnail image displayed in the content area. You can reduce or enlarge the preview.

The Metadata panel Contains metadata information for the selected file. If multiple files are selected, shared data

(such as keywords, date created, and exposure setting) is listed.

The Keywords panel Helps you organize your images by attaching keywords to them.

To start and quit Bridge, and to return to an application
Do any of the following:

• To open Bridge from an application, choose File > Browse from your application.

• (Windows) To open Bridge directly, choose Adobe Bridge from the Start menu.

• (Mac OS) To open Bridge directly, double-click the Adobe Bridge icon . By default, this is located in the Appli-

cations/Adobe Bridge folder.

• To quit Bridge, choose File > Exit (Windows) or Bridge > Quit Bridge (Mac OS).

• To return to the last open application that started Bridge, choose File > Return To [Application].

If Production Studio is installed, using File > Browse to launch Bridge within a Production Studio application lets

you double-click a file to open or import it within that application. For example, if you choose File > Browse from

within Adobe Premiere and then double-click a Photoshop file, the file is added to the Premiere Project panel, not opened

in Photoshop.

See also

“To manage files with Bridge” on page 31

To create and close Bridge windows
❖ Do one of the following:

• Choose File > New Window to create a full-size Bridge window.

• Choose File > Close Window. In Windows, this command quits Bridge as well.

See also

“The Bridge work area” on page 25
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To use Bridge in Compact mode
Switch to Compact mode when you want to shrink the Bridge window. In Compact mode, the panels are hidden and

the content area is simplified. A subset of common Bridge commands remains available from the pop-up menu at

the upper right portion of the window.

By default, the Compact mode Bridge window floats on top of all windows. (In Full mode, the Bridge window can

move behind application windows.) This floating window is useful because it is always visible and usable as you work

in different applications. For instance, you might use Compact mode after you select the files you plan to use, and

then drag them into the application as needed.

1 Click the Switch To Compact Mode button .

2 Do any of the following:

• Choose commands from the menu at the top right of the Bridge window.

• Click the Switch To Ultra Compact Mode button  to hide the content area, further minimizing the Bridge

window. You can click the button again to return to Compact mode.

• Click the Switch To Full Mode button to return to Full mode, displaying the content area and the panels, and

letting Bridge move behind the current application window.

See also

“The Bridge work area” on page 25

To adjust the Bridge window
You can adjust the Bridge window by moving and resizing the panels. For example, you can enlarge the Preview panel

to display bigger thumbnails. However, you can’t move panels outside the Bridge window.

❖ Do any of the following:

• Drag a panel by its tab up or down into another panel area.

• Drag the horizontal divider bar between panels to make them larger or smaller.

• Drag the vertical divider bar between the panels and the content area right or left to resize the panels or content

area.

• Click the Show/Hide Panes button  at the lower left of the Bridge window to display or hide the panels.

• Choose View, followed by the name of the panel you want to display or hide.

See also

“The Bridge work area” on page 25

To select Bridge workspaces
A Bridge workspace is a certain configuration or layout of the work area. You can select either a premade workspace

or a custom workspace that you have previously saved.

❖ Choose Window, followed by the name of the workspace you want, or choose Window > Workspace, followed by

one of the following commands:

Lightbox Displays just the content area of Bridge, so that you can concentrate on viewing the files.

File Navigator Displays the content area in Thumbnails view, along with the Favorites panel and Folder panel.
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Metadata Focus Displays the content area in Thumbnails view, along with the Metadata panel prominently shown.

Filmstrip Focus Displays just the content area, in Filmstrip view.

To save and delete Bridge workspaces
You can save the current Bridge layout (that is, the work area configuration) as a workspace and reuse it later. By

saving Bridge in various configurations, you can work in (and quickly switch between) different layouts of the work

area. For instance, you might use one workspace to sort new photos and another to work with Adobe InDesign® files.

❖ Choose Window > Workspace, followed by one of these commands:

Save Workspace Saves the current Bridge layout as a workspace so that you can reuse it later, even if you move a

panel or change the view in the content area. If you choose this command, enter a name for the workspace and click

Save. You can also assign a keyboard shortcut to the workspace and specify whether to save the location of the Bridge

window as part of the workspace.

Delete Workspace Deletes the saved workspace. If you choose this command, choose the workspace from the menu,

and click Delete.

Reset To Default Workspace Restores the workspace to the default configuration.

To set Bridge preferences
1 Choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS).

2 Select any of the preferences categories on the left:

General Controls the general appearance settings.

Metadata Controls which sections and fields are displayed in the Metadata panel.

Labels Assigns names to each color label and specifies whether you need to press Ctrl as part of the keyboard

shortcut combination to apply labels and ratings to files.

File Type Associations Specifies which application to use from Bridge to open files of the named type. For any file

type, you can click the name of the application (or None) and click Browse to locate an application to use. You can

also reset the file type associations to their default settings as well as hide any file types that don’t have an associated

application. This affects only those files that you open with Bridge, and overrides the Explorer (Windows) and Finder

(Mac OS) settings.

Adobe Stock Photos Specifies Adobe Stock Photos settings.

Advanced Specifies advanced settings, including cache options and language options.

3 Click OK.

See also

“Bridge General preferences” on page 28

“Bridge Advanced preferences” on page 28

“To set Adobe Stock Photos preferences” on page 48
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Bridge General preferences
Set any of the following General preferences and click OK:

Background Specifies the darkness of the content area in which thumbnails are shown.

Show Tooltips Specifies whether to display Bridge help information when you position the pointer over an item.

(This preference does not affect settings for Version Cue tool tips, which display metadata for items.)

Additional Lines Of Thumbnail Metadata Specifies whether to show additional metadata information with thumb-

nails in the content area. If you select this option, you can choose the type of metadata to show from the associated

menu. You can display up to three extra lines of information.

Favorites Items Specifies what items to show in the Favorites panel. Certain options are dimmed if you do not have

those items.

Reveal Scripts In Explorer/Finder Opens the folder that contains scripts (the commands available in the Tools

menu).

Reset All Warning Dialogs Resets warning notices in Bridge to their default settings.

Bridge Advanced preferences
Set any of the following Advanced preferences and click OK:

Do Not Process Files Larger Than Specifies the maximum file size of documents for which Bridge automatically

creates thumbnails. Displaying large files can slow performance.

Number Of Recently Visited Folders To Display In The Look In Popup Sets the number of most recently viewed

folders that appear in the Look In menu.

Language Sets the language used in the Bridge interface.

Double-Click Edits Camera Raw Settings In Bridge Opens camera raw files in the Adobe Camera Raw dialog box in

Bridge.

Use A Centralized Cache File Places the two cache files created for each folder you view in a centralized folder. A

centralized cache is generally easier to use than a distributed cache. For instance, when the cache is centralized, you

don’t have to search in multiple, distributed locations if you want to remove the cache. To specify a new name or

location for this centralized cache folder, click Choose.

Use Distributed Cache Files When Possible Places the two cache files created for each folder displayed in the viewed

folder, if possible. For instance, it’s not possible to place the cache files in the viewed folder if that folder is on a burned

CD. In that case, Bridge places the cache files in the centralized folder instead. However, if you are burning a CD,

using a distributed cache means that you don’t have to export the cache to the CD, because it is already in the folder

being burned to the CD.

Note: Cache files are hidden files. To view them in Bridge, choose View > Show Hidden Files.

To work with the cache in Bridge
The cache stores thumbnail, metadata, and file information to shorten loading times when you return to a previously

viewed folder. However, storing the cache takes up disk space.
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Note: Purging the cache deletes the metadata cache and thumbnail cache. If the metadata can’t be written to a file, label

and rating information is lost as well.

❖ Choose any of the following commands from the Tools > Cache submenu:

Build Cache For Subfolders Builds, as a background process, a cache for the selected folder and all the folders within

it (except aliases/shortcuts to other folders). This shortens the time spent waiting for the cache to be displayed as you

look in subfolders.

Purge Cache For This Folder Clears the cache for the selected folder. This command is useful if you suspect that the

cache for a folder is old and needs to be regenerated.

Purge Central Cache Clears the entire centralized cache and any distributed cache in the currently viewed folder,

freeing room on the hard drive. The command does not otherwise clear local caches.

Export Cache Exports the cache, allowing you to burn a CD with the cache already generated. Because the folder

cache is written into the folder, the thumbnail cache and metadata cache are available after you burn the CD. This

option is active only if you chose Use A Centralized Cache File in the Preferences dialog box.

Files and folders in Bridge

To view file and folder thumbnails in Bridge
The content area of Bridge displays thumbnails of the files and folders of the selected folder, along with information

about them. You can specify how you want files and folders to be displayed in the content area.

❖ Do any of the following:

• Drag the Thumbnail slider  at the bottom of the Bridge window to adjust the size of thumbnails.

• Choose View > As Thumbnails to display items in a grid.

• Choose View > As Filmstrip to display thumbnails in a scrolling list along with an extra-large thumbnail of the

currently selected item. Click the Back button or Forward button directly below the extra-large thumbnail to go

to the previous or next thumbnail. Click the Switch Filmstrip Orientation button to change from a horizontal

slide show to a vertical one. Note that you can page through a PDF preview in Filmstrip view.

• Choose View > As Details to display a scrollable list of thumbnails along with information about the selected file.

• Choose View > As Versions And Alternates to display a scrollable list of thumbnails, including thumbnails of any

Version Cue alternates and versions for each item (Adobe Creative Suite 2 only). Only the current file appears

unless you have created an alternates group containing the file or created previous versions of the file. Click Alter-

nates View or Versions View at the top right of the content area to display thumbnails of alternates or versions. In

Alternates View, you can also create alternates groups containing files that are not in the current folder.

• Choose View > Show Thumbnail Only to view thumbnails without any text information listed. However, Version

Cue tool tips still display Version Cue information when you position the pointer over the thumbnail.

• Choose View > Slideshow to view thumbnails as a slide show that takes over the entire screen. This is a quick and

easy way to display and work with large versions of all the graphics files in a folder. Instructions on how to use the

slide show are displayed on the screen when you choose this command.

Depending on the view you’re in, you can display extra file information by positioning the pointer over a thumbnail

in the content area. For files in Version Cue projects (Adobe Creative Suite 2 only), you can also choose File >

Versions or File Alternates. This command opens a dialog box that lets you work with the file’s versions or alternates

without having to select that view in the Bridge content area.
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To specify how files and folders are shown in Bridge
You can specify what type of files and folders you want to display as thumbnails in the content area, as well as the

order in which to display them.

❖ Choose any of the following commands from the View menu:

• Sort, followed by the order in which you want to sort files. Choose Ascending to sort in ascending rather than

descending order. Choose Manually to sort by the last order in which you dragged the files.

• Show Hidden Files to display hidden files, such as cache files and Version Cue files that have been provisionally

removed (not permanently deleted) from Version Cue projects.

• Show Folders to display folders as well as individual files.

• Show All Files to display all files regardless of type, even non-Adobe files that Bridge doesn’t normally display.

• Show Graphic Files Only to display only files in graphic file formats, such as EPS, JPEG, BMP, PS, TIFF, and GIF.

• Show Camera Raw Files Only to display only camera raw files.

• Show Vector Files Only to display only files created with drawing programs such as Adobe Illustrator®, and EPS

and PS files.

• Refresh (or choose Refresh from the Folders panel menu) to update the content area. This is useful, for instance,

when you perform certain Version Cue actions that don’t automatically refresh the view in the content area.

Closing and reopening Bridge also refreshes the view.

You can also click Unfiltered at the top right of the Bridge window and choose the files you want to display based on

their rating or label. The Unfiltered menu operates independently of the View > Sort commands.

To navigate folders and files with Bridge
❖ Do any of the following:

• Select the Folders panel and click to select the folder you want. Click the plus sign (Windows) or triangle (Mac OS)

next to a folder or double-click the folder to open subfolders within it.

• Select the Favorites panel and click to select the folder you want.

• Choose a folder from the Look In menu. You can click the Go Back button, Go Forward button, or Go Up button

next to the menu to navigate within the current folder listed in the menu.

See also

“To specify how files and folders are shown in Bridge” on page 30

To select files in Bridge
Before you can work with a file, you need to select it. You can select more than one file at a time.

❖ Do one of the following in the current folder:

• Click the thumbnail of a file.

• To select contiguous files, Shift-click them.

• To select noncontiguous files, Ctrl-click (Windows) or Command-click (Mac OS) them.

• To select all labeled or unlabeled files, choose Edit > Select Labeled or Edit > Select Unlabeled.

• To select the opposite of the current selection, choose Edit > Invert Selection.
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To open files in Bridge
You can open files in Bridge, even files that were not made with Adobe applications.

1 Select the file in the current folder.

2 Do one of the following:

• Choose File > Open.

• Press Enter (Windows) or Return (Mac OS).

• Double-click the file in the content area or Preview panel.

• Choose File > Open With, followed by the name of the application with which to open the file.

• Drag the file into the working area of an application, such as an open Illustrator document.

• Drag the file onto the application icon.

• Choose File > Open In Camera Raw to edit the Adobe camera raw settings for the file.

• Choose File > Open In Adobe Encore DVD As, followed by the file type (Asset, Menu, Timeline, or Slideshow)

you want to use (Windows only).

If you choose File > Browse to launch Bridge within a Production Studio application, double-clicking a file opens or

imports that file within the application.

To manage files with Bridge
Adobe Bridge makes it easy to drag and drop files, move them between folders, copy and duplicate them, and

otherwise manipulate them.

Note: If you have Adobe Creative Suite 2, you can also use Adobe Version Cue from Bridge to manage files you author.

You can create and manage revisions to files kept in Version Cue projects. Version Cue is also a convenient environment

for collaborative file management in workgroups. You can manage not only Adobe Creative Suite files but also other

Adobe and non-Adobe files.

❖ Do any of the following:

To delete files Select the files and click the Delete button  or press Delete.

To copy files and folders Select the files or folders and choose Edit > Copy, or Ctrl-drag (Windows) or Option-drag

(Mac OS) the file or folders to a different folder.

To move files to another folder Select the files and drag them to a different folder. (When you search for Adobe

Stock Photos, you can’t drag images to other areas, because some images may be comp thumbnails. To drag a comp

image, first download it and then drag it from the downloaded comp’s folder.)

To quickly attach an image to an e-mail message, drag the image from Bridge and drop it into the e-mail message.

To display the location of a file in the operating system Select the file and choose File > Reveal In Explorer

(Windows) or File > Reveal In Finder (Mac OS).

To find the location of a file in a collection Select a file and choose File > Reveal In Bridge. A collection is a saved

search. By default, if you select a file in a collection, the file is listed as being located in the folder “File Results.”

Selecting Reveal In Bridge moves you to the folder in which the file is located.

To place files into an application Select the files and choose File > Place, followed by the name of the application. For

instance, you can use this command to place a JPEG image into Illustrator. You can also drag files from Bridge into

an application. Depending on the file, the document into which you want to place it may need to be opened first.
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To drag files out of Bridge Select the files and drag them onto the desktop or into another folder. This action moves

the file onto the desktop or folder.

To drag files into Bridge Select one or more files on the desktop, in a folder, or in another application that supports

drag and drop, and drag them into the content area in Bridge. The files are moved from their current folder into the

one displayed in Bridge. (If the file you are dragging is in a different mounted volume than Bridge, the file is copied

into Bridge.)

Drag a file or folder onto the Preview panel to display the contents of the folder in Bridge.

To manage folders with Bridge
❖ Do any of the following:

To create new folders Choose File > New Folder. Then, enter a name when the folder appears in the content area.

To delete folders Select the folder and press Delete.

To add folders to Favorites Choose a folder from the Look In menu or Folders panel or select it in the content area.

Then choose File > Add To Favorites. You can also drag the folder from the content area to the Favorites panel.

To remove folders from Favorites In the Favorites panel, select the folder you want to remove. Then choose File >

Remove From Favorites.

To reorganize folders in the Favorites panel Drag the folder to the desired location in the panel.

To rotate images with Bridge
You can rotate the view of JPEG, PSD, TIFF, and camera raw file images in Bridge. Rotating an image in Bridge may

rotate it in the application in which it was created as well. Rotating does not affect the data in the image file.

1 Select one or more images in the content area.

2 Choose Edit > Rotate 90˚ Clockwise, Rotate 90˚ Counterclockwise, or Rotate 180˚.

To label files with Bridge
Labeling files with a certain color is a flexible way to mark a large number of files quickly. Using the View > Sort

menu or Unfilter button, you can choose to view files according to their color label.

For example, suppose you’ve just imported a large number of images and are viewing them in Bridge. As you review

each new image, you can label those you want to keep. After this initial pass, you can use the Unfilter button to

display and work on files that you’ve labeled with a particular color.

You can assign names to labels through the Preferences dialog box. The name is then added to the file’s metadata

when you apply the label.

Note: When you view folders, Bridge shows both labeled and unlabeled files until you choose another option. Also,

purging the cache deletes labels from files that don’t support XMP write (such as BMP, DCS, Pict, PS6 PDF, and PSB

files), locked files, or read-only files (such as files on CDs).

1 Select one or more files.

2 Do one of the following:

• To label files, choose a color from the Label menu.

• To remove labels from files, choose Label > No Label.
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See also

“To specify how files and folders are shown in Bridge” on page 30

To rate files with Bridge
When assigning ratings to files, you can award from zero to five stars. Using the View > Sort menu or Unfilter button,

you can choose to view files according to their rating.

For example, suppose you’ve just imported a large number of images and are viewing them in Bridge. As you review

each new image, you can rate them from best to worst. After this initial pass, you can view only files you’ve rated with

four or five stars and work on those.

1 Select one or more files.

2 Do any of the following:

• In Thumbnail view, click the dot representing the number of stars you want to give the file. (Dots do not appear

in very small thumbnail views. If necessary, rescale the thumbnail view until the dots appear.)

• Choose a rating from the Label menu.

• To add or remove one star, choose Label > Increase Rating or Label > Decrease Rating.

• To remove all stars, choose Label > No Rating.

See also

“To specify how files and folders are shown in Bridge” on page 30

To search for files and folders with Bridge
You can perform searches with Bridge. You can narrow your search by adding multiple search criteria. You can even

save your search criteria as a collection, so that you can perform the same search again later.

1 Choose Edit > Find.

2 In the Find dialog box, choose a source folder from the Look In menu. By default, the menu displays the currently

active folder. Click the Browse button to navigate to another folder.

3 (Optional) Select Include All Subfolders to expand the search to any subfolders in the source folder.

4 (Optional) Select Search Past Versions Of Version Cue Files to include past versions of Adobe Version Cue files,

as well as current ones, in the search (Adobe Creative Suite 2 only).

5 (Optional) Select Show Find Results In A New Browser Window to display the search results in a new Bridge

window. If left unselected, the search results appear in the content area of the current window.

6 Choose a criterion for your search by selecting an option from the leftmost Criteria menu.

7 Select a limiter from the center Criteria menu.

8 Enter the search text in the text box at the right, if needed. You can enter basic search terms such as AND, OR,

and * (for wild cards).

9 To add search criteria, click the plus sign button. To remove search criteria, click the minus sign button.

10 Click Find. Bridge displays the files that match the search criteria, and you can navigate through the files.

11 (Optional) To save the search criteria to perform the same search again, click Save As Collection. Enter a name

for the collection. Select Start Search From Current Folder to search from the same folder in the future. Then, click

Save. The search criteria are saved in the Collections folder listed in the Favorites panel.
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See also

“To search with criteria saved as collections” on page 34

To search with criteria saved as collections
If you saved search criteria by using the Save As Collection option in the Find dialog box, you can run that search

again by using that collection.

1 Select Collections in the Favorites panel or Look In menu.

2 Double-click the collection you want.

A new Bridge window appears containing the results of the search.

See also

“To search for files and folders with Bridge” on page 33

Running automated tasks with Bridge

To run automated tasks with Bridge
The Tools menu contains submenus for various commands available in the different Adobe applications. For

instance, if you have Adobe Photoshop installed, you can use the commands under the Tools > Photoshop submenu

to make picture packages and create Photomerge panoramas using photos you select in Bridge. Running these tasks

from Bridge saves time because you don’t have to open each file individually.

Note: Third parties can also create and add their own items to the Tools menu for added functionality in Bridge. For

information about creating your own scripts, see Bridge JavaScript Scripting Reference.

1 Select the files or folders you want to use. If you select a folder, the command is applied where possible to all files

in the folder.

2 Choose Tools > [Application], followed by the command you want. (If your application doesn’t have any

automated tasks available, no application name appears in the menu.)

For information about a particular command, see the documentation for that application.

To batch-rename files with Bridge
You can rename files and folders in a group, or batch. When you batch-rename files, you can choose the same settings

for all the selected files.

1 Do one of the following:

• Select the files that you want to rename.

• Select a folder in the Folders panel. The new setting will apply to all the files in the folder.

2 Choose Tools > Batch Rename.

3 Set the following options and click Rename:

• For Destination Folder, select whether you want to place the renamed files in the same folder or in a different

folder, move them to another folder, or place a copy in another folder. If you select Move To Other Folder or Copy

To Other Folder, click Browse to select the folder.
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• For New Filenames, choose elements from the menus or enter text into the text boxes. The specified elements and

text are combined to create the new file name. You can click the + button or - button to add or delete elements. A

preview of the new file name appears at the bottom of the dialog box.

Note: If you choose Sequence Number, enter a number. The number is automatically incremented for each file named.

• Select Preserve Current File Name In XMP Metadata if you want to retain the original file name in the metadata.

• For Compatibility, select the operating systems with which you want renamed files to be compatible. The current

operating system is selected by default, and cannot be deselected.

Metadata in Bridge

About metadata
Metadata is information about the file, such as the author’s name, resolution, color space, copyright, and keywords

applied to it. You can use metadata to streamline your workflow and organize your files. This information is stored

in a standardized way using the Extensible Metadata Platform (XMP) standard on which Adobe Bridge and the

Adobe Creative Suite applications are built. XMP is built on XML, and in most cases the information is stored in the

file so that it cannot be lost. If it is not possible to store the information in the file itself, XMP metadata is stored in

a separate file called a sidecar file.

Many of the powerful Bridge features that allow you to organize, search, and keep track of your files and versions

depend on XMP metadata in your files. Bridge provides two ways of working with metadata: through the Bridge

Metadata panel and through the File Info dialog box. These methods provide different views into the XMP metadata

stored in the file. In some cases, multiple views may exist for the same property. For example, a property may be

labeled Author in one view and Creator in another, but both refer to the same underlying property. Even if you

customize these views for specific workflows, they remain standardized through XMP. The Advanced view in the

File Info dialog box displays the fundamental values being stored.

Metadata that is stored in other formats, such as EXIF, IPTC (IIM), GPS, and TIFF, is synchronized and described

with XMP so that it can be more easily viewed and managed. Other applications and features (for example, Adobe

Version Cue) also use XMP to communicate and store information such as version comments. For instance, when

you save a file in Version Cue, you might add the comment that you rotated the file when you worked on it. Later on,

you could use Bridge to navigate to that Version Cue project and search for the term “rotate” to locate that file.

In most cases the metadata remains with the file even when the file format changes, for example, from PSD to JPG.

Metadata is also retained when those files are placed in an Adobe InDesign layout.

You can use the XMP Software Development Kit to customize the creation, processing, and interchange of metadata.

For example, you can use the XMP SDK to add fields to the File Info dialog box. More information on XMP and the

XMP SDK is available from the Adobe Solutions Network on the Adobe Website.

About the Metadata panel in Bridge
From the Metadata panel, you can view and edit the metadata for selected files, use metadata to search for files, and

use templates to append and replace metadata. Metadata preserves information about the contents, copyright status,

origin, and history of documents. Version Cue uses metadata to manage files.

You can specify the types of metadata displayed in the Metadata panel.

Note: If you have applied metadata to an Adobe Acrobat® PDF file, some keywords may not appear; however, these

keywords are still attached to the PDF file.
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Depending on the selected file, the following types of metadata appear in the Bridge Metadata panel:

File Properties Describes the characteristics of the file, including the size, creation date, and modification date.

IPTC Core Displays editable metadata. You can add captions to your files as well as copyright information. IPTC

Core is a new specification that was approved by IPTC (International Press Telecommunications Council) in

October 2004. It differs from the older IPTC (IIM, legacy) in that new properties have been added, some property

names have changed, and some properties have been deleted. You can display the older IPTC (IIM, legacy) metadata

by selecting it from the Metadata options in the Preferences dialog box.

IPTC (IIM, legacy) Displays editable metadata. As with IPTC Core, you can add captions to your files as well as

copyright information.This set of metadata is hidden by default, because it has been superseded by IPTC Core.

However, you can choose it by selecting it from the Metadata options in the Preferences dialog box.

Fonts Lists the fonts used in Adobe InDesign files.

Swatches List the swatches used in Adobe InDesign files.

Camera Data (Exif) Displays information assigned by digital cameras. EXIF information includes the camera

settings used when the image was taken.

GPS Displays navigational information from a global positioning system (GPS) available in some digital cameras.

Photos without GPS information don’t have GPS metadata.

Camera Raw Displays settings applied by the Camera Raw plug-in.

Edit History Keeps a log of changes made to images with Photoshop.

Adobe Stock Photos Lists information about images obtained from Adobe Stock Photos.

Version Cue Lists any Version Cue version information about the file.

Note: Depending on the applications you are using, custom panels for various properties may appear here as well.

To view metadata with Bridge
❖ Do any of the following:

• Select one or more files and view the information in the Metadata panel. If you select multiple files, only metadata

that is common to the files appears. Use the scroll bars to view hidden categories. Click the triangle to display

everything within a category.

You can change the font size in the panel by choosing Increase Font Size or Decrease Font Size from the panel menu.

• Select one or more files and choose File > File Info. Then, select any of the categories listed on the left.

• Choose View > As Details or View > As Versions And Alternates to display the metadata next to the thumbnails

in the content area. This is especially useful for viewing Version Cue files.

• Position the pointer over a thumbnail in the content area. (Metadata appears in a tool tip only if Show Tooltips is

selected in General preferences.)

To edit metadata with Bridge
1 Click the pencil icon to the far right of the metadata field you want to edit.

2 Type in the text box to edit or add metadata.

3 Press Tab to move through metadata fields.
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4 When you have finished editing the metadata, click the Apply button at the bottom of the Metadata panel. To

cancel any changes you’ve made, click the Cancel button  at the bottom of the panel.

To specify the metadata displayed in the Metadata panel
1 Do one of the following:

• Choose Preferences from the Metadata panel menu.

• Choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS), and then click Metadata from the list on

the left side of the dialog box.

2 Select the metadata fields that you want to display in the Metadata panel.

3 Select the Hide Empty Fields option if you don’t want to view fields with no information in them.

4 Click OK.

To add metadata using the File Info dialog box
The File Info dialog box displays camera data, other file properties, an edit history, copyright and authorship infor-

mation (if any), and custom metadata panels (if the application has installed them). You can add metadata directly

from the File Info dialog box. If you select multiple files, the dialog box shows where different values exist for a text

field. Any information you add to a field is applied to all selected files.

Note:You can also view metadata in the Metadata panel, in certain views in the content area, and by placing the pointer

over the thumbnail in the content area.

1 Select one or more files.

2 Choose File > File Info.

3 Select any of the following from the list on the left side of the dialog box:

Description Lets you enter document information about the file, such as document title, author, description, and

keywords that can be used to search for the document. You can also choose text from the menu to the right of the

text fields. To specify copyright information, select Copyrighted from the Copyright Status pop-up menu. Then

enter the copyright notice string and the URL of the person or company holding the copyright.

Audio Data 1 Lets you enter information about the audio file, including the title, artist, and album.

Audio Data 2 Lists information about the audio file, including bit rate, duration, and loop settings.

Categories Lets you enter information based on Associated Press categories. You can also choose text from the menu

to the right of the text fields. The Categories option appears only if Adobe Photoshop is installed.

History Displays Adobe Photoshop history log information for images saved with Photoshop. The History option

appears only if Adobe Photoshop is installed.

Camera Data 1 Displays read-only information about the camera and settings used to take the photo, such as make,

model, shutter speed, and f-stop. The Camera Data 1 option appears only if Adobe Photoshop or Production Studio

is installed.

Camera Data 2 Lists read-only file information about the photo, including pixel dimensions and resolution. The

Camera Data 2 option appears only if Adobe Photoshop or Production Studio is installed.

Adobe Stock Photos Lists read-only information about images obtained from Adobe Stock Photos.

Video Data 1 Lists information about the video file, including video frame width and height; and lets you enter

information about the video file, including tape name and scene name.
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Video Data 2 Lists information about the video, including alternate tape name and timecode values.

Origin Lets you enter file information that is useful for news outlets, including when and where the file was created,

transmission information, special instructions for handling the file, and headline information. You can also choose

text from the menu to the right of the text fields.

Advanced Displays fields and structures for storing metadata using namespaces and properties, such as file format

and XMP, EXIF, and PDF properties. You can do any of the following with the information listed:

• Click Save to export the metadata to a text file (with the .xmp file-name extension).

• Click Replace to replace the metadata in the existing files with metadata saved in an XMP file. Values in existing

properties are replaced with the new values.

• Click Append to add the metadata in the existing files to metadata saved in an XMP file. Values in existing

properties are not replaced, and new values are appended or inserted where appropriate.

• Click Delete to remove the currently selected Advanced property. You can Shift-click to select multiple properties.

Note:Hold down the Alt key (Windows) or Option key (Mac OS) to change these commands to Replace All, Append All,

and Delete All. These commands then affect all information in the file; that is, EXIF information that is not modifiable

by the user, such as the f-stop and the Photoshop file ID information, as well as user-modifiable information, such as

document title and keywords. Holding down Alt (Windows) or Option (Mac OS) also displays the Reset button to restore

the previous settings.

4 Click OK to apply the changes.

To work with metadata templates in Bridge
You can modify the metadata in the File Info dialog box and save it as a template for use with other files.

1 Create a new file using an Adobe Creative Suite or Production Studio application. This creates a file without

metadata from any other source.

2 Select the file.

3 Choose File > Info.

4 Enter the desired information in the File Info dialog box.

5 Choose any of the following from the menu at the upper right of the File Info dialog box:

• To save the metadata in the File Info dialog box as a template for use with other files, choose Save Metadata

Template. Enter a name for the template and click Save.

• To delete an existing metadata template, choose Delete Metadata Template. Choose the template you want to

delete from the menu in the dialog box and click Delete.

• To open the folder containing metadata templates, choose Show Templates.

6 Click OK. You can now also apply metadata templates to files with the Append Metadata and Replace Metadata

commands in the Tools menu and in the Metadata panel menu.

To apply metadata templates to files in Bridge
After you have saved metadata for one file, you can apply it to others.

1 Select one or more files.
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2 Choose either of the following commands from the Metadata panel menu or the Tools menu:

• Append Metadata, followed by the name of the template. This command applies the template metadata only where

no metadata value or property currently exists in the file.

• Replace Metadata, followed by the name of the template. This command completely replaces any existing

metadata in the file with the metadata in the template.

To apply keywords to files with Bridge
The Keyword panel lets you create and apply Bridge keywords to files. Keywords can be organized into categories

called keyword sets. Using keywords, you identify files based on their content. Later, you can view all files with shared

keywords as a group.

Note: Bridge keywords are distinct from XMP keywords created with the File Info dialog box. The latter are displayed

in Version Cue files in the “Other Metadata” section of the File Info dialog box.

❖ Do any of the following:

• To add a keyword to files, select one or more files. In the Keywords panel, click the box next to the name of the

keyword you want to add. A check mark appears in the box next to the keyword when it’s added to a file.

• To add a set of keywords to files, select one or more files. In the Keywords panel, click the box next to the name of

the keyword set. A check mark appears in the box next to the keyword set when it’s added to a file.

Create a group of frequently used keywords so that you can apply them as a group.

• To remove keywords from a file, select the file, and then click the box next to the name of the keyword or keyword

set that you want to remove.

• To create a new keyword, click the New Keyword button at the bottom of the panel or choose New Keyword

from the panel menu. A new default keyword name appears in the panel. To create the new keyword, type over

the default name and press Enter (Windows) or Return (Mac OS).

• To create a new keyword set, click the New Keyword Set button  at the bottom of the panel or choose New

Keyword Set from the panel menu. A new default keyword set name appears in the panel. To create the new

keyword set, type over the default name and press Enter (Windows) or Return (Mac OS).

• To rename a keyword or keyword set, select the keyword or keyword set and choose Rename from the panel menu.

Then, type over the name in the panel and press Enter (Windows) or Return (Mac OS).

Note: When you rename a keyword, the keyword’s name isn’t changed in files that currently contain it. The original

name stays in the file.

• To move a keyword to a different keyword set, drag the keyword from one set to another.

• To delete a keyword, select the keyword by clicking its name, and then click the Delete Keyword button at the

bottom of the panel or choose Delete from the panel menu.

Note: Keywords that you get from other users appear in the Other Keywords category until you recategorize them. To

make these keywords permanent in Bridge, select the keyword and then choose Persistent from the context menu.

• To find a file using the keyword, choose Find from the panel menu.

Note: You can’t modify keywords in search results for Adobe Stock Photos.

See also

“To search for files and folders with Bridge” on page 33
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Adobe Stock Photos

About Adobe Stock Photos
Adobe Stock Photos lets you view, try, and buy royalty-free images from leading stock libraries. With Adobe Stock

Photos, you won’t have to interrupt your design process to find quality images. Instead, from inside your favorite

applications, you can use the powerful search capabilities of Adobe Stock Photos to find and download images.

From Bridge, the Favorites pane gives you quick access to these stock images. With your computer connected to the

Internet, simply click the Adobe Stock Photos icon to start browsing thousands of available images. Because of the

tight integration between Stock Photos and Adobe applications, you can download images from Adobe Stock Photos

directly into many Adobe applications.

In the design process, you need the flexibility to try different images before deciding which one you want. Adobe

Stock Photos gives you the option to download low-resolution, complimentary (comp) versions of images you’re

considering. You can work with the comps until you make your final decision, at which point you can purchase and

download a high-resolution image.

For maximum convenience, you can open an account with Adobe. The benefit of opening an account is that you

enter your personal information only once, greatly simplifying the checkout process. You can also look back at

previous purchases, and even download photos again after you purchase them.

See also

“About comp images” on page 43

“Benefits of Stock Photos accounts” on page 45

“Buying stock photos” on page 43

Searching for images in Adobe Stock Photos
There are a few ways to search for images in Stock Photos. If you need help getting a project started, a broad search

may yield a fund of possibilities and suggest areas to explore. If you have a clear idea of what you need, then you can

use Advanced Search to narrow the field.

Related keywords also help you find photos. After you find photos, you can start a new search by selecting one or

more related keywords. Each image is associated with keywords that help you find similar images. The more

keywords you select, the narrower the search results.

Photos matching the search criteria appear as thumbnails in the main Bridge window. You can resize the thumbnail

by dragging the Thumbnail slider at the bottom of the screen. When you click an image in search results, a low-

resolution comp image appears in the Preview pane (it may take several seconds for the image to appear in the pane).

To enlarge the comp, simply resize the Preview pane. You can view metadata information about the image in the

Metadata pane under Adobe Stock Photos Metadata.

Your previous searches are automatically saved in Previous Photos in the Favorites pane. Click Previous Searches to

display the list. To see the search results, double-click a search. To delete a search, select it and press the Delete key

(Windows), right-click the search and then choose Send To Recycle Bin (Windows), or Control-click the search and

choose Move To Trash (Mac OS).
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All thumbnails from recent searches are saved on your computer. Having the thumbnails available offline is helpful

if you want to browse through the images when your computer isn’t connected to the Internet. However, the thumb-

nails do take up some space on your hard drive. At some point, if you want to delete these thumbnails, delete the

searches (as described above), or remove them manually from the default file location: My Documents/AdobeStock-

Photos/Previous Searches (Windows), or Documents/AdobeStockPhotos/Previous Searches (Mac OS).

See also

“To adjust the Bridge window” on page 26

“To view file and folder thumbnails in Bridge” on page 29

To search for stock photos
1 In Bridge, click Adobe Stock Photos in the Favorites pane.

2 In the text box at the top of the screen, type the word or phrase that describes the subject of the photos you want

to search for.

3 Click the Search button  or press Enter.

Images matching the search criteria are displayed in batches. (There is a preference for changing the number of

images displayed in a batch.) To view more images, click More Results.

See also

“Search tips for stock photos” on page 42

“To view image price and keywords” on page 42

To use Advanced Search
Advanced Search is a powerful tool that helps you find exactly the right photo. You can combine several search

criteria to narrow your results.

1 In Bridge, click Adobe Stock Photos in the Favorites pane.

2 Click the Advanced Search button .

3 Search using any combination of the following options:

• Type a descriptive keyword or keywords in the text box to find related images. Alternatively, type an image ID, if

you know the ID of the photo you want to use.

• To restrict searches to a specific media type, choose one or more options under Media Types.

• To search by the orientation of the photo, select the acceptable shapes under Orientation.

• Select the name of one or more providers to limit the search.

4 Click the Search button to display images matching the search criteria.

See also

“Search tips for stock photos” on page 42

To search with related keywords
1 In Bridge, click Adobe Stock Photos from the Favorites pane.
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2 In the text box at the top of the screen, type the word or phrase that describes the subject of the photos you want

to search for.

3 In the search results, click a photo to select it.

4 Do one of the following:

• Click the Get Price & Keywords button.

• Right-click the image (Windows) and choose Get Price & Keywords from the menu.

5 When the Price & Keywords dialog box appears, select keywords under Keywords For This Image. The more

keywords you select, the narrower the search.

6 When you finish selecting keywords, click the Search Again button to begin a new search using the keywords.

To view image price and keywords
You can view size and price information, as well as related keywords, in the Image Detail dialog box.

1 In the search results window, click an image to select it.

2 Do one of the following:

• Click the Get Price & Keywords button.

• Right-click the image (Windows) and choose Get Price & Keywords from the menu.

3 To close the dialog box, click the Close button.

Note:The currency displayed in the Price & Keywords dialog box may not be the native currency of your billing country;

it is the supported currency for purchases made from your country. When you purchase photos from Adobe Stock Photos,

your credit card will be billed in the supported currency.

Search tips for stock photos
Here are some helpful pointers for refining your searches:

Misspelled words Double-check your search entries to make sure they’re spelled correctly.

Trademarked names Brand names may not return full search results. Instead, search for the item by its general

name.

Exact phrase searches To view images that exactly match a phrase, type the whole phrase in the Search text box. You

can enter Boolean operators such AND, OR, or NOT to narrow your search.

Search by subject To search for a specific subject, use nouns that describe the main subject of a photo, such as

“bicycle” or “house,” as well as adjectives that modify the nouns, such as “vintage” or “red.” To narrow the search

further, use verbs that describe an action in the photo.

Search by concept Try searching with concepts, or perceptions, such as “romance,” “vitality,” “frustration,” or

“excitement,” to find an inspiring image.

Search by style To find photos that reflect a specific photographic or artistic technique, try searching on terms such

as “profile”, “studio shot,” or “clipping path.”
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Comp images

About comp images
Comp images are free, nonwatermarked, low-resolution versions of stock photos that you can download. You can

use comps to capture a feeling, idea, or concept before choosing the final image for a project. Comps are not licensed

for production, but you can use them in mock-ups or other preliminary work. Because comps are low-resolution

images, they’re not suitable for printing or publishing. After an evaluation period, you can purchase a high-

resolution version of the image to continue working with the photo.

Metadata is bundled with comp images. This metadata is used in Adobe applications to recognize images as stock

photos, even if you rename them. You can purchase high-resolution versions of the images later, even after you move

a comp to a project folder or create other versions of the image.

You can view your downloaded comps by clicking Downloaded Comps in the Favorites pane, or you can navigate to

the default folder where comps are saved: My Documents/AdobeStockPhotos (Windows) or Documents/Adobe-

StockPhotos (Mac OS). You can move downloaded comps to any folder you want. To delete a comp in the Stock

Photos window, right-click it and then choose Send To Recycle Bin (Windows) or Control-click it and choose Move

To Trash (Mac OS).

For more information on using comps, see the terms of service (TOS), which describe when and for how long you

can use a comp. A Terms Of Service link is available on the main Adobe Stock Photos screen.

To download comps from Adobe Stock Photos
1 In the search results, click a photo to select it.

2 Do one of the following:

• Click the Download Comp button.

• Right-click the photo (Windows) and select Download Comp from the menu.

• Click Get Prices & Keywords and select Free Comp Image in the dialog box. Click the icon to download the comp.

To view saved comps in Stock Photos
To help you keep track of downloaded comps, you can view them in Bridge. If you decide to purchase a comp, put

the comp in your shopping cart.

1 In the Favorites pane, click Adobe Stock Photos.

2 Click Downloaded Comps to see the comps.

Buying stock photos

Buying stock photos
It’s simple to buy images through Adobe Stock Photos. When you find the photos you want to buy, put them in your

shopping cart. The photos remain in your cart until you’re ready to complete your purchase. When you finish

browsing, you can check out and have your images automatically downloaded to your computer.

Having an account with Adobe speeds the checkout process. Because your contact and billing information is saved,

you can complete your purchase with just a few clicks.
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Adobe Stock Photos maintains a secure site, and you can rest assured that your personal information is kept in strict

confidence. Any information you enter is used only for Adobe Stock Photos purposes.

To view your photos, click Purchased Images in the Favorites pane, or navigate to the default Stock Photos folder:

My Documents/AdobeStockPhotos (Windows) or Documents/AdobeStockPhotos (Mac OS).

See also

“To buy photos” on page 44

To place photos in the shopping cart
As you find photos you want to purchase, add them to the shopping cart until you’re ready to check out.

1 In the search results window, right-click (Windows) or Control-click (Mac OS) a photo, and then choose Add To

Cart from the context menu. You see a dialog box confirming that the photo is your shopping cart.

2 Click OK to continue, or click View Shopping Cart to see the contents of your cart.

If you want to disable this dialog box, select Don’t Show Again.

To buy photos
1 To access your shopping cart, click the Shopping Cart icon.

2 Choose a resolution for the photos you want to buy. (You can remove an item from the shopping cart at any time

by clicking the Delete icon .)

3 Click Check Out.

4 Do one of the following:

• If you have an Adobe account, enter your ID and password.

• If you want to open an Adobe account, click Set Up An Account. You are prompted to enter your billing and

account information.

• If you want to buy the images without an account, click Continue As Guest. You are prompted to enter your billing

information. Click Continue.

5 Do one of the following:

• If you have an Adobe account, confirm your billing information and click Continue.

• If you don’t have an Adobe account, enter your billing information and click Continue.

6 In the Order Summary page, confirm your choices. To delete a photo from the shopping cart, click the Delete icon.

7 If you have a promotion code, enter it in the Promotion Code text box and click Apply. You see any changes made

to your order as a result of applying the promotion code.

8 Click the check box to accept the terms of the Adobe Stock Photos License Agreement (click the blue text to read

the agreement).

9 Finally, click the Purchase Now button to complete the checkout process. Your purchase is processed, then you’re

prompted to download your photos.

10 Click Start Download. After the photos are saved, click View Purchased Images if you want to start working with

them right away.
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11 To view the receipt for your purchase, in the Thank You page click View Receipt. You can also monitor the

progress of the download by clicking Open Download Status. When you finish, click Find More Images if you want

to find new photos, or click Go To Your Account.

If you have been working with a comp version of the image you purchased, you need to replace the comp with the

high-resolution image in your art.

Note: To delete the list of high-resolution images waiting for download from the Download Status screen, choose Edit >

Preferences (Windows) or Bridge > Preferences (Mac OS). Select Adobe Stock Photos, and then click the Clear Now

button.

See also

“To create a Stock Photos account” on page 46

“To set Adobe Stock Photos preferences” on page 48

To view order details
A benefit of having an Adobe account is that you can go back and view your previous orders.

1 In Adobe Stock Photos, click the Your Account button .

2 In the Your Account page, click View Order History.

3 The Your Order History page shows all of your previous orders. To view details about a particular order, click the

order number (highlighted in blue).

4 In the Order Detail page, you can see the billing information, as well as a description of the photos you purchased.

Click Return To Your Account if you’re done, or click Return To Order History if you want to review other orders.

You can also redownload the photos you purchased.

Stock Photos Accounts

Benefits of Stock Photos accounts
Creating an Adobe account makes purchasing photos quick and easy. When you log in with your e-mail address and

password, you can work with your account in several ways:

Manage your profile After you complete the registration process, modify your account information anytime by

clicking the Your Account link in the navigation bar.

See your order history Track orders made through Adobe Creative Suite Stock Photos to check the specific items

ordered, the total cost of the purchase, or the order date.

Download previously purchased items again Access your order history and click Re-download to replace a lost or

corrupted file for up to one year from the original purchase date.

Shop with ease Purchase photos without providing profile information. Adobe Stock Photos automatically enters

your name and address when you make any purchases. All your personal information is securely stored.
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To create a Stock Photos account
1 In Adobe Stock Photos, do one of the following:

• Click the Your Account button , and then click the Continue button under Set Up An Account.

• If you have photos in the shopping cart, click the Shopping Cart icon, and then click Checkout. Click Set Up An

Account.

2 If you haven’t chosen your billing country, you see a dialog box with a list of countries. Choose the country of your

billing address and click Continue.

3 In the text boxes, type your e-mail address and choose a password (at least six characters long and containing a

mix of letters and numbers).

4 Enter your billing address, and then type your payment information. The billing address must exactly match the

address where your credit card statements are mailed.

5 When you finish, click Continue.

After you create your account, Adobe Stock Photos sends a confirmation e-mail to the address you entered.

To log into your Stock Photos Account
1 In Adobe Stock Photos, click the Your Account button .

2 When prompted, type your e-mail address and password, and then click Continue. If your login is successful, the

Your Account page appears.

If you’re having trouble logging into your account, make sure that you have spelled your e-mail address and password

correctly. Also make sure that you haven’t pressed the Caps Lock or Number Lock keys.

To edit your Stock Photos account profile
Your account profile includes your name and password settings.

1 Click the Your Account button .

2 Log into your account.

3 In the Your Account page, click Edit Your Profile. Do any of the following:

• To change your password, type a new word in the Password text box. Passwords can contain only letters and

numbers and must be at least six characters long.

• To sign up to get e-mail from Adobe Stock Photos about promotions or other special information, select the check

box.

4 To confirm your changes, click Save. To go back to the main Your Account page without saving changes, click

Return To Your Account.

To change Stock Photos account address information
You can change your default billing address or add other addresses. Make sure that any new addresses match the

address on your credit card billing statements exactly to avoid any problems.

1 Click the Your Account button .

2 Log into your account.

3 In the Your Account page, click Edit Your Address.
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4 Do any of the following:

• To change the nickname associated with the default address, type a new name in the Billing Address Nickname

text box.

• Type any changes to the default address in the text boxes.

• To add a new address to your account, click Add New Address, and then enter the information in the text boxes.

• To edit a non-default address, click Edit under the address, and make any changes.

• To make an address the default, click Set Default under the address.

• To delete an address, click Delete under the address.

5 To confirm your changes, click Save. To go back to the main Your Account page without saving changes, click

Return To Your Account.

To change Stock Photos account payment information
You can change your saved credit card information or add additional credit cards. Enter your credit card number

without spaces or dashes. You can give each credit card a nickname to keep track of which card you’re using.

1 Click the Your Account button .

2 Log into your account.

3 In the Your Account page, click Edit Your Payment Information.

4 Do any of the following:

• To change the nickname of the default credit card, type a new name in the Payment Nickname text box.

• To change the default credit card number, type the new number in the Credit Card Number text box, and then

choose the expiration date for the new card from the month and year menus.

• To add a new card to your account, click Add New Payment Method, and then type a nickname and the card

number. Enter the expiration date.

• To delete a payment method, click Delete under the payment nickname.

5 To confirm your changes, click Save. To go back to the main Your Account page without saving changes, click

Return To Your Account.

To download previously purchased images from Stock Photos
To download previously purchased images, you need to have a Stock Photos Account. You can download images

onto a different computer than the one you used to purchase the photos originally (see the license agreement for

information about restrictions).

1 Click the Your Account button .

2 In the Your Account page, click View Order History.

3 In the Your Order History page, click the order number (highlighted in blue) of the photo you want to download

again.

4 In the Order Detail page, click the arrow under Download. The photo is downloaded. By default, purchased

images are located at My Documents/AdobeStockPhotos/Purchased Images (Windows) or Documents/Adobe-

StockPhotos/Purchased Images (Mac OS).
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To set Adobe Stock Photos preferences
1 In Adobe Bridge, choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS).

2 Select Adobe Stock Photos from the list on the left.

3 Set any of the following preferences, and then click OK:

Thumbnails Per Search Group To set how many thumbnail images are displayed in a search group, choose an option

from the Thumbnails Per Search Group menu.

Search language To search using a different language, select the language from the Search Language menu. Note

that you get the best results from most providers if you search in English. This setting doesn’t affect the interface

display language.

Destination folder for downloads To select a new default folder in which to store photos, downloaded comps, and

purchased photos, click Change Location. Click Reset to restore the default location.

Billing Country Or Region To change your default billing country, choose the name of the country from the Billing

Country menu. The currency displayed next to the Billing Country menu may not be the native currency of that

country (not all currencies are supported). Instead, it’s the currency Adobe allows for that country. Your credit card

is billed in the supported currency.

Alert messages To enable or disable the messages that appear when you download a comp or add a photo to your

shopping cart, select or deselect Display Message After Downloading Comp or Display Message After Adding Image

To Shopping Cart.

Automatic downloading to default folder To save your photos automatically to your default folder, select Auto-

Download Images After Purchasing Them. Deselect this option if you want to choose a location in which to save the

photos (for example, in a Version Cue project or other project-specific folder on your computer).

Downloading after lost connection To resume downloading automatically after a connection is lost, select Resume

Interrupted Downloads When Bridge Starts.
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Chapter 4: Planning and managing
projects

Planning projects

About projects
An After Effects project is a single file that stores references to all the footage you use in that project. It also contains

compositions, which are the individual containers used to combine footage, apply effects, and, ultimately, drive the

output.

Starting a project involves two tasks: (1) planning your project based on the formats of the final output and (2)

creating a project file. Once you have planned your project and learned how to perform some basic tasks related to

working in After Effects, you’ll be ready to start importing footage. You then create a composition and begin working

with your source footage.

As you create large or intricate After Effects projects, use After Effects management tools to meet the challenges of

organizing projects, speeding up previews, and working efficiently. Using the Flowchart panel, nesting compositions,

and prerendering movies are some of the ways you can control a complex project.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for upates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“Working with imported files” on page 68

Project planning considerations
Careful planning before you start working on a project can help you avoid unexpected results. Correct initial config-

uration of footage, composition settings, and render or export settings helps you to avoid rendering errors and

unexpected rendering results. If you’re working with large compositions, taking steps to improve performance in

Adobe After Effects results in improved rendering and screen redraw speed.

Rendering order and nesting may also be part of project planning.

See also

“About nesting” on page 130

“Default rendering order” on page 593

“Improving performance by simplifying your project” on page 639

Footage considerations

Before importing footage, first decide which media you'll use for your finished movies, and then determine the best

settings for your source material. In many cases, it’s best to prepare footage before importing it into After Effects.
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For example, if you want an image to fill the screen at 100% scale, you can configure the image in Adobe Photoshop

so that the image size and pixel aspect ratio match the composition size and pixel aspect ratio. If the image is too large

when you import it into After Effects, you’ll increase the memory requirements of your project. If the image is too

small, you’ll lose image quality when you scale it to the desired size.

If possible, use uncompressed footage: less compression means better quality. Don’t use footage whose frame rate is

less than the frame rate of your output: you’ll lose quality here, too.

After Effects uses a set of internal rules to automatically interpret footage that you import. Generally, you don’t need

to change these settings. However, if your footage isn’t standard, After Effects may interpret it incorrectly. In this case,

you can use the settings in the Interpret Footage dialog box to reinterpret your footage. The settings in the Interpret

Footage dialog box should match your source footage settings; don’t use it to specify settings for your final rendered

output.

You can ensure that different footage items use the same settings by copying Interpret Footage settings from one item

and applying them to others.

If you’ll be mixing source footage with different pixel aspect ratios, specify this ratio for each footage item in the

Interpret Footage dialog box. For more information, see “About pixel aspect ratio” on page 96.

See also

“To specify interpretation rules” on page 71

“To apply Interpret Footage settings to multiple footage items” on page 125

Composition considerations

After you prepare and import footage items, you add them to a composition, where you create animation, layering,

and effects. When you create a composition, specify composition settings such as resolution, frame size, and pixel

aspect ratio for your final rendered output. Although you can change composition settings at any time, it’s best to set

them correctly as you create each new composition to avoid unexpected results in your final rendered output.

You can save composition settings and apply them to other compositions.

If you’ll be rendering a project to more than one media format, always match the resolution setting for your compo-

sition to the highest resolution setting used for your output. Then set up the Render Queue panel to render a separate

version of the project for each format.

See also

“Specifying composition settings” on page 111

“Setting pixel aspect ratio for compositions” on page 113

“Setting resolution” on page 114

“Setting frame size” on page 112

Rendering and exporting considerations

Because render settings and output settings determine how After Effects processes your composition and saves the

rendered file, it’s important to consider these settings, based on your final output, while planning your project.
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Render settings, such as frame rate, resolution, and quality, determine how After Effects processes your composition

during rendering. Output settings, such as format and video and audio settings, determine how After Effects saves

your rendered file. When choosing an output module, click the module name to customize settings in the Output

Module Settings dialog box.

In Mac OS and in Windows with QuickTime installed, you can render QuickTime formats through the Render

Queue panel. However, some QuickTime options, such as Fast Start and Hinted Streaming, are available only

through the QuickTime exporter (choose File > Export). For more information, see “Exporting using QuickTime” on

page 622.

You can create templates that contain commonly used render or output module settings.

See also

“To create and use render settings templates” on page 607

“To create and use output module templates” on page 609

Performance considerations

If you work with large compositions, make sure that you configure After Effects settings to improve performance.

Lowering the bit depth of a project, substituting proxies for source items, applying processor-intensive effects later

in the process, making sure that you use RAM effectively, and other performance-enhancing measures can improve

rendering and screen redraw speed.

See also

“Improving performance when using effects” on page 638

“Improving performance by simplifying your project” on page 639

“Improving performance by modifying screen output” on page 640

“To work with low-resolution proxies for footage” on page 129

“To choose a project color depth” on page 62

Output type considerations
The suggestions that follow can help you select composition settings for specific media. However, the best way to

ensure that your project is suitable for a specific medium is to make a test composition and view it using the same

type of equipment that your audience will use to view it.

Film or videotape

If you’ll be rendering for film, consider both the aspect ratio of the frame size you select for your composition and

the frame rate of your source footage. For footage that was transferred from film to video using the 3:2 pulldown

telecine method, you must remove 3:2 pulldown before adding effects. (See “To remove 3:2 or 24Pa pulldown from

video” on page 102.)

For film and video, try to match import and composition settings with settings in the output module used to render

a movie. In some cases, you may want to conform footage to a frame rate different than the frame rate of the source

footage. For example, you may want to conform 25 fps PAL to 24 fps for film.

The composition frame size should be determined by the image size in the playback medium.
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If your final output will be videotape, set up your composition to match the requirements of your capture card, or, if

you use an IEEE 1394 (FireWire) port, choose the appropriate DV preset in the Composition Settings dialog box and

in the Render Queue panel. Using broadcast-safe colors and maintaining frame size and compression ratios are also

important considerations.

See also

“Specifying composition settings” on page 111

“To change render settings” on page 604

CD-ROM or DVD

When you create a movie that you plan to render for playback from a CD-ROM or DVD, you must specify import

and composition settings that take into account the wide range of hardware that your audience may be using,

possibly including older, lower-speed drives.

To make your final output compatible with older drives, try to reduce the data rate of your final output by specifying

certain settings for footage items:

• Lower the frame rate as far as you can in the Composition Settings dialog box without making motion seem too

jerky. Start at 15 frames per second (fps).

• When rendering your final composition, choose a file type and codec appropriate for the final media. For example,

for a cross-platform CD-ROM, you might specify a QuickTime codec or a codec designed for low data rates, such

as Sorenson Video. Regardless of which codec you select, it must be available on the system used by your intended

audience to ensure successful playback (common codecs include Sorenson, MPEG-4 video, and codecs installed

with media players such as RealPlayer and Windows Media Player). Also consider the keyframe rate of the codec

you have selected.

For more information about compression and about preparing output for DVD, search for the Adobe DV

Compression Primer (English only) on the Adobe website.

Animated GIF

When you render an animated GIF file, colors are dithered to an 8-bit palette. Before rendering your final project,

render a test composition so that you can adjust colors if the results are not what you expected. If any source footage

includes an alpha channel, be sure that you know how it affects your final project before you start rendering.

Streaming or downloaded video

Streaming video resembles a conventional television signal in that video is sent to the viewer frame by frame, instead

of by downloading a large file to the hard disk. Streaming video on the web is constrained by factors such as available

bandwidth, connection speed, and network congestion. You can export streaming QuickTime or MPEG video

directly from After Effects (see “Exporting using QuickTime” on page 622), or use the Render Queue panel to

generate streaming Real Media and Windows Media video.

For more information about streaming video and tips on reducing data rate, search for the Adobe DV Compression

Primer (English only) on the Adobe website.

If your final output will be downloaded as a file from the web, the main concern is the size of the file, which directly

affects how long it takes to download. QuickTime and Microsoft Windows Media are formats often used when

rendering final output that will be downloaded. When you render a QuickTime, Windows Media, RealMedia,

MPEG-4, or Flash movie, After Effects automatically creates a movie that can play on both Windows and Mac OS

without modification.
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Cross-platform project considerations
After Effects project files are compatible with Mac OS and Windows platforms. You can do several things to ease the

process of exchanging projects between platforms.

File systems

If you want to transfer a project that contains footage stored on a server from Mac OS to Windows, be sure to mount

the server by using AppleShare (AFP). If you mount the volume in Mac OS by using Samba (SMB), After Effects can’t

reestablish links to footage files stored on the server when you open the project in Windows.

Project path names

When you move a project to a different computer and open it, After Effects attempts to locate the project’s footage

files as follows: After Effects first looks in the folder in which the project file is located; second, it searches the file’s

original path or folder location; finally, it searches the root of the directory where the project is located.

If you are building cross-platform projects, it’s best if the full paths have the same names on Mac OS and Windows

systems. If the footage and the project are on different volumes, make sure that the appropriate volume is mounted

before opening the project and that network volume names are the same on both systems.

It helps to store footage in the same folder as the project file or in another folder within that folder. Here’s a sample

hierarchy:

c:/newproject/project_file.aep

c:/newproject/source/footage1.psd

c:/newproject/source/footage2.avi

You can then copy the newproject folder in its entirety across platforms, and After Effects will properly locate all of

the footage.

Note: Use the Collect Files feature to gather copies of all the files in a project into a single folder. You can then move the

folder containing the copied project to the other platform. See “Collecting files in one location” on page 598

File-naming conventions

Name your footage and project files with the appropriate file-name extensions, such as .mov for QuickTime movies

and .aep for After Effects projects. Don’t use high-ASCII or other extended characters in file names to be used cross-

platform. If files will be used on the web, be sure that file names adhere to applicable conventions for extensions and

paths.

Resources

Ensure that all resources are available on both systems. Resources can include fonts, effects, and codecs. Such

resources are often plug-ins.

See also

“Plug-ins” on page 66
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Project basics

To create and open projects
You can have only one project open at a time. If you try to open another project or create a new one while a project

is open, After Effects prompts you to save changes in the first project (and then closes it).

You can create a new project from a preconfigured project template: choose File > Browse Project Templates. See

“Working with Adobe Bridge” on page 56.

• To create a new project, choose File > New > New Project. After you create a new project, you import footage into

the project.

• To open a project, choose File > Open Project, locate the project, and then click Open.

• To open the most recently opened project, press Ctrl+Alt+Shift+P (Windows), or Shift+Option+Command+P

(Mac OS).

See also

“To import footage into a Project panel” on page 71

About timecode and duration
The primary concept related to time is duration, or length. Each footage item, layer, and composition in a project has

its own duration, which is reflected in the beginning and ending times displayed in the timelines in the Composition,

Layer, and Timeline panels.

The way you view and specify time in After Effects depends on the display style, or unit of measure, that you use to

describe time. By default, After Effects displays time in Society of Motion Picture and Television Engineers (SMPTE)

timecode: hours, minutes, seconds, and frames. You can change to another system of time display, such as film

frames, or feet and frames of 16mm or 35mm film. (See “To change timecode display” on page 55.)

Video-editing workstations often use SMPTE timecode that is recorded onto videotape for reference. If you are

creating video that will be synchronized with video that uses SMPTE timecode, use the default timecode display

style.

Timecode display
You can choose the format your project uses to display time. You may want to see the project’s timecode in a film

format, for example, if you are preparing a movie for eventual output to film, or in simple frame numbers if you plan

to edit it further in an animation program. The format you choose applies to the current project only. Changing the

display format does not alter the frame rate of your assets or output—it changes only how frames are numbered. You

can choose from among several timecode-display options:

Auto Uses the rounded frame rate of the footage item or composition. If an item doesn’t have timecode (such as an

audio file), After Effects uses a default value (30 fps for English and Japanese versions of After Effects, or 25 fps for

French, German, Spanish, and Italian versions), or the last non-auto value you specified in the Project Settings dialog

box. You can also specify that After Effects uses a specific frame rate.

30 fps drop-frame timecode Reports time in hours, minutes, seconds, and frames, separating units with semicolons.

Drop-frame timecode skips some numbers by design: To accommodate the NTSC actual frame rate of 29.97 fps
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drop-frame timecode skips, or drops, two frame numbers (not the actual frames of video) each minute except every

tenth minute. Use for output to NTSC videotape.

30 fps drop-frame timecode as indicated by semicolons

Note: When working with NTSC DV assets, you should usually use 30 fps drop-frame timecode. This format conforms

with the timecode base inherent in NTSC DV footage and displays its duration most accurately.

30 fps non drop-frame timecode Reports time in hours, minutes, seconds, and frames, separating units with colons.

It does not drop frame numbers. Use for output to computer displays via the web or CD-ROM.

30 fps non drop-frame timecode as indicated by colons

Feet + frames 16mm Reports time in feet and frames, assuming the frame rate of 16mm film: 40 frames per foot. Use

for output to 16mm film.

Feet + frames 16mm timecode showing 39 as the highest possible number of frames before the next foot.

Feet + frames 35mm Reports time in feet and frames, assuming the frame rate of 35mm film: 16 frames per foot. Use

for output to 35mm film.

Feet + frames 35mm timecode showing 15 as the highest possible number of frames before the next foot.

Frames Reports time solely in a running count of frames. Does not assign measurements of either time or spatial

length. Use to output sequential stills such as those generated for an animation or DPX film editor.

Frames timecode simply numbers each frame in sequential order.

To change timecode display
1 Open the project and choose File > Project Settings.

2 Select a time display style:

Timecode Base To use timecode for the display style, select Timecode Base, and then choose Auto from the

Timecode Base menu. If you’re using footage or a composition with a frame rate of 29.97 fps, choose Drop Frame or

Non-Drop Frame from the NTSC menu.

Note: You can specify specific frame rates in the Timecode Base menu; however, in most cases, you should leave the

timecode base set to Auto.

Frames To use frames for the display style, select Frames.

Feet + Frames To use Feet + Frames for the display style, select Feet + Frames, and then choose a film type from the

Feet + Frames menu.
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To cycle through Timecode Base, Frames, and Feet + Frames, Ctrl-click (Windows) or Command-click (Mac OS) the

timecode display at the bottom of the Composition panel or at the top of the Timeline panel.

3 If desired, type a value in the Start Numbering Frames At option. This value applies only when you have chosen

Frames or Feet + Frames.

Note: The Project Settings command also enables you to choose color options: See“To choose a project color depth” on

page 62, “To choose a working color space” on page 65 and “To enable linear blending” on page 66.

Working with Adobe Bridge
Adobe Bridge is the control center for Adobe Production Studio. Use Bridge to browse for project templates and

animation presets; to view and manage files and folders; organize your files by assigning keywords, labels, and ratings

to them; search for file and folders; view, edit, and add metadata; and find and purchase Adobe Stock Photos. For

more information about Adobe Bridge, search for Bridge in After Effects Help.

Note: When working in Adobe Bridge, you’ll notice references to Version Cue. Version Cue is a set of features that help

manage design workflow and collaboration in Adobe Creative Suite.

• To open Bridge from After Effects, choose File > Browse.

• To reveal a file in Bridge, select a file in the Project panel and choose File > Reveal in Bridge.

• To use Bridge to browse for project templates, choose File > Browse Template Projects. You can choose from

several project templates located in the Adobe After Effects 7.0/Templates folder.

• To use Bridge to browse for animation presets, choose Animation > Browse Presets.

See also

“About animation presets” on page 202

To close a project
❖ Choose File > Close Project.

To undo changes
You can undo actions using the Undo, History, or Revert commands. You can undo only those actions that alter the

project; for example, you can undo an edit, but you cannot undo the scrolling of a panel. You can sequentially undo

as many as 99 of the most recent changes made to the project in any After Effects panel, depending on how many

undo levels are set in Preferences; the default is 35. Specifying more levels increases memory requirements but does

not significantly affect performance. To set the number of undo levels, choose Edit > Preferences > General

(Windows) or After Effects > Preferences > General (Mac OS), specify a number for Levels Of Undo, and then click

OK.

Note: The Vector Paint effect (Pro only) supports only one level of undo, regardless of the number of levels you set.

You can also discard changes by reverting to the last saved version of the project. Note that when you revert to the

last saved version, all editing and footage imported since you last saved are lost. You cannot undo this action.

To avoid wasting time undoing accidental modifications, lock a layer when you want to see it but do not want to

modify it. (See “To lock or unlock a layer” on page 160.)

❖ Do one of the following:

• Choose Edit > Undo [action].
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• Choose Edit > History, and select the change you want to undo.

Note: Using the History command to undo an action reverses all actions back to that point in time. You lose not only the

undone action but all actions completed after it.

• Choose File > Revert to revert to the last saved version.

Saving projects

To save a project
• To retain all changes to an After Effects project, choose File > Save.

• To save a project with a new automatically generated name, chose File > Increment And Save. A copy of the

currently opened file is saved in the same folder as the original file, named with the original name followed by a

number. (If the project name already ends with a number, that number is increased by 1.)

• To save a project to a different name or location, choose File > Save As, specify a file name and location, and click

Save. The project currently open takes the new name and location; the original file remains unchanged.

• To save a copy of the project using a different name or location, choose File > Save A Copy, specify a file name and

location, and click Save. The project currently open retains its original name and location, and a copy is created

but not opened.

You can use the Collect Files feature to gather copies of all files in a project into a single folder. See “Collecting files

in one location” on page 598

To automatically save a project
The Auto-Save feature saves the current project file at regular intervals, either to the same file, or to a new file. Auto-

saved files are saved in a folder called “Adobe After Effects Auto-Save” located in the same folder as the project file.

Auto-saved file names are based on the project name: After Effects adds “auto-save n” (where n is the number of the

file in the auto-save series) to the end of the file name.

1 Choose Edit > Preferences > Auto-Save (Windows) or After Effects > Preferences > Auto-Save (Mac OS).

2 Do any of the following, and then click OK:

• Select Automatically Save Projects, and type the number of minutes between saves.

• Type a number for the Maximum Project Versions to specify how many versions of each project file you want to

save. For example, if you type 5, After Effects saves five versions of each project you open. When the number of

files saved reaches the maximum you specify, the Auto-Save feature overwrites them starting with the oldest file.

To open an Auto Save project

1 Close the project.

2 Choose File > Open Project.

3 Locate and open the file in the folder Adobe After Effects Auto-Save, which is in the same folder as the project

file. (If no files are available, the Auto-Save preference may be deselected.)
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Naming of copies
You can use the Duplicate command or the Copy and Paste commands to duplicate items selected in the Project,

Composition, Timeline, Layer, or Footage panel. You can use the Increment And Save command to save a copy of a

project. All of these commands automatically name the resulting duplicate and follow a set of enhanced naming

rules. The duplicate receives the same name as the original item followed by a number. For example, if you duplicate

a layer with “animism” as its name, the duplicate automatically receives “animism 2” as its name. If you duplicate the

original layer again or its duplicate, the new duplicate receives “animism 3” as its name.

If there are multiple items that use the same base name followed by a number, the item with the most digits deter-

mines how many digits are given to the duplicate’s name. The number assigned to the duplicate is determined by the

item with the greatest number. For example, if a composition contains layers with “cloud 0004” and “cloud 22” as

names, then duplicating either layer results in a layer with “cloud 0023” as its name.

Note: If a layer hasn’t been named, the Timeline panel displays its source name in brackets in the Layer Names column,

for example, [foliage]. If you duplicate such a layer, the duplicate also has no name, so After Effects displays the same

bracketed name used for the original layer.

Organizing projects

Organizing footage in the Project panel
You can organize footage and compositions in the Project panel using folders. Solids are automatically placed in the

Solids folder. The folders you create in the Project panel exist only in the Project panel. You can expand a folder to

reveal its contents, or put folders inside other folders.

You can also use the Cut, Copy, Paste, and Duplicate commands on all items in the Project panel.

To organize footage items using folders

• To create a folder in the Project panel, choose File > New > New Folder, or click the Create Folder icon at the

bottom of the Project panel.

• To move a file or folder into a Project folder, drag the file or folder from the Project panel list into a folder.

• To move a file or folder from a folder to the top level of the Project panel, drag the file or folder to the gray infor-

mation area at the top of the panel.

• To show or hide the contents of a folder, click the triangle to the left of the folder icon.

To manage footage items in the Project panel

• To display information about a footage item or composition, select it. Information is displayed at the top of the

Project panel next to the thumbnail image.

• To sort footage items by any column, click the column name in the Project panel. For example, click Type to sort

items by footage type.

• To rename a composition or folder, select the composition name or folder, press Enter (Windows) or Return (Mac

OS), type the new name, and then press Enter or Return again.

• To find footage items in the Project panel, choose File > Find, or click the binoculars , type the name of the

footage item, and click OK. Select Find Missing Footage to locate all footage items that refer to a file that has been

moved, deleted, or renamed.

• To duplicate an item in the Project panel, select it and choose Edit > Duplicate.
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• To delete an item from the project, select it and choose Edit > Clear.

You can copy footage items from After Effects and paste them into an Adobe Premiere Pro sequence, as well as copy

track items from Adobe Premiere Pro and paste them into an After Effects composition.

See also

“Copying between After Effects and Adobe Premiere Pro (Windows only)” on page 126

To remove footage from a project

• To eliminate an item from a project, select the item in the Project panel and press Delete.

• To remove all unused footage items from a project, choose File > Remove Unused Footage.

• To remove all duplicate footage items from a project, Choose File > Consolidate All Footage. Note that After

Effects considers footage items to be duplicates only if they use the same Interpret Footage settings.

• To remove unselected compositions and unused footage items from selected compositions in the Project panel,

choose File > Reduce Project. This command is available only when the Project panel is active, and removes both

unused footage items and all other compositions that are not included within a selected composition as nested

(subordinate) compositions.

If the selected composition includes items that are turned off (that is, the Video or Audio switch is deselected in the

Timeline panel), the Reduce Project command does not remove those items.

Note: If an expression in a selected composition refers to an element in a nonsubordinate composition, Reduce Project

removes the nonsubordinate composition and the applied expression. The message that appears after you choose Reduce

Project reminds you of this possibility, so you can undo the command if needed. To avoid removing the expressions from

a nonsubordinate composition, drag the nonsubordinate composition into the composition that refers to it. Then deselect

the Audio and Video switches for the composition that you added.

To set the thumbnail view for a composition

The Set Poster Time command lets you specify which frame is used for the thumbnail that’s displayed for a compo-

sition in the Project panel. By default, a composition’s thumbnail shows the first frame of the composition.

1 Double-click the composition in the Project panel.

2 In the Timeline panel, move the current time marker to the desired spot.

3 Make the Composition panel active, and choose Composition > Set Poster Time.

Note: To hide the thumbnail view, choose Edit > Preferences > Display (Windows) or After Effects > Preferences >

Display (Mac OS) and select Disable Thumbnails In The Project Window.

To add a transparency grid to the thumbnail view

❖ Choose Thumbnail Transparency Grid from the Project panel menu. A check mark indicates that the grid is

turned on.

About the Flowchart panel
After Effects provides a separate Flowchart panel for each composition and for the overall project to help you keep

a big-picture perspective on complex projects. In the Flowchart panel, individual boxes (or tiles) represent each

composition, layer, and footage item, including any applied effects. Directional arrows represent the relationships

between components.
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Note: The Flowchart panel shows you only the existing relationships. You cannot use it to change relationships between

project elements.

The elements included in the Flowchart panel depend on what is selected and on whether the compositions are

nested compositions (used by other compositions as the source for a layer) or root compositions (not nested). The

flowchart of a project displays only root compositions. Nested compositions and other elements that make up the

composition appear when you expand a composition tile.

To open the Flowchart panel

❖ Do one of the following:

• To open the Flowchart panel for a project, choose Window > Flowchart.

• To open the Flowchart panel for a composition, select the composition in the Project panel, and choose

Composition > Comp Flowchart View.

When you click a tile in the flowchart, that element becomes active (selected) in the Project panel. If the tile repre-

sents a layer, that layer also becomes active in the Timeline panel.

Note: Gray lines between tiles in the flowchart indicate that the Video or Audio switch for those items is turned off in

the Timeline panel. Black lines indicate that the switch is turned on.

Customizing flowcharts

You can customize flowcharts using the Flowchart menu. Specify the type of lines between elements (angled or

straight), justification, whether tiles appear with effects, and flow direction. The menu also includes a Cleanup

command to reorganize elements in aligned flowcharts.

You can also use the four buttons along the bottom of the Flowchart panel, which are shortcuts for many of these

menu commands.

For tool tips identifying the buttons in the Flowchart panel, let your pointer hover over a button until the tool tip

appears.

To make changes with the Flowchart panel

You can make some changes to your project from within the Flowchart panel.

• To delete elements, select them and press Delete. If the selected element is a footage item or composition, it is

deleted from the project and no longer appears in the Timeline and Project panels. If the selected element is a layer,

it is deleted from the composition in which it appears.

• To change the layer properties for a selected element, right-click (Windows) or Control-click (Mac OS) the icon

to the left of the name in the element tile. The icons have various appearances, depending on the element type,

such as layers , compositions , and audio footage . For example, you can use the icon context menu to

work with masks and effects or to change switches, apply transformations, and adjust quality.

Note: When you change element properties in the Flowchart panel, be careful to click the icon in the tile, not the name

of the element. The context menu associated with the element icon is different from the one that opens from the element

name.

Organizing a project using nesting
When you nest compositions, you organize your project into a hierarchy. In its simplest form, nesting means that

you combine two or more compositions into one main composition from which you render the final movie. A

composition inside a parent composition becomes a layer within the parent composition.
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Use composition nesting to save time working and rendering. With composition nesting, you can do the following:

Apply complex changes to an entire composition You can create a composition containing multiple still images,

nest the composition within the overall composition, and animate the nested composition so that all the still images

change in the same ways over the same time period.

Reuse anything you build You can build an animation in its own composition and then drag that composition into

other compositions as many times as you want. This can save large amounts of storage space, especially for compli-

cated effects, such as 3D layers.

Update in one step Update many composition copies in one step by editing the original animated composition.

Alter the default rendering order of a layer You can specify that After Effects render a transformation (such as

rotation) before rendering effects, so the effect applies to the rotated footage.

Note: Parenting is another way to apply complex changes to an entire composition. For information, see “About parent

and child layers” on page 208.

See also

“Default rendering order” on page 593

Color

About color depth
Color depth is the number of bits per channel (bpc) used to represent the color of a pixel. Channels contain color

information: RGB images have channels for red, green, and blue. The more bits per channel, the more colors can be

represented.

In After Effects, you can work in 8-bpc, 16-bpc or 32-bpc color mode for each project; 16-bpc and 32-bpc color

modes are available only in After Effects Professional. Many effects support 16 and 32 bits per channel (see “Color

depth and effects” on page 351).

Even if your output is 8-bpc (Millions Of Colors), you can obtain better rendering quality by having the project (or

render) color depth set at 16-bpc or 32-bpc because of the added precision achieved by calculating color values at

higher bit depths.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for upates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

32-bpc color mode (Pro only) Use 32-bpc mode to work with HDR (high dynamic range) images (see “High

dynamic range footage (Pro only)” on page 62).

After Effects assumes that all HDR footage represents color linearly—in linear light. When you import HDR images,

After Effects converts floating-point 32-bit values from linear light to the project’s working color space (see “To

choose a working color space” on page 65).

If you haven't chosen a working color space for your project, After Effects converts HDR footage from linear light

using a gamma value of 2.2; this value represents the gamma for a typical monitor. Gamma is the exponent used in

converting RGB levels. When you render to a 32-bpc output format, After Effects removes the gamma applied on

import, converting 32-bit values back to linear light.
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For more information about file formats that support a 32-bpc workflow, see “Supported file formats for import” on

page 69. For more information about working in 32-bpc color mode, see “High dynamic range footage (Pro only)”

on page 62.

16-bpc color mode (Pro only) 16-bpc frames require half the memory of 32-bpc frames and offer advantages in

terms of speed and storage. Use 16-bpc mode when you work with high-resolution images that contain a narrow

range of colors, such as when you’re creating subtle gradients for film effects or HDTV output. Transitions between

colors are smoother with less visible banding, and more detail is preserved than with 8-bpc color (though less than

with 32-bpc color). You can import 16-bpc images, including those from Adobe Photoshop, and composite and

color-correct footage in 16-bpc mode. Take advantage of 16-bpc color when performing most After Effects tasks,

including layer adjustment, frame blending, 3D compositing, and Cineon file import. The Info panel displays 16-bpc

color values with exact precision.

When rendering to output module depths of Trillions Of Colors, set the project to 16-bpc color depth to take

advantage of the output file’s extra color precision.

You can override the project color depth when you render. See “To change render settings” on page 604

To choose a project color depth
❖ Do one of the following:

• Choose File > Project Settings, and choose a color depth from the Color Depth menu.

• In the Project panel, Alt-click (Windows) or Option-click (Mac OS) the Project Color Depth button.

Project Color Depth button in the Project panel

High dynamic range footage (Pro only)

About high dynamic range (HDR) footage

The dynamic range (ratio between dark and bright regions) in the physical world far exceeds the range of human

vision and of images that are printed or displayed on a monitor. But whereas human eyes can adapt to very different

brightness levels, most cameras and computer monitors can capture and reproduce only a limited dynamic range.

Photographers, motion picture artists, and others working with digital images must be selective about what’s

important in a scene because they are working with a limited dynamic range.

High dynamic range (HDR) images open up a world of possibilities because they can represent a very wide dynamic

range through the use of 32-bit floating-point numeric values. Floating-point numeric representations allow the

same number of bits to describe a much larger range of values than integer (fixed-point) values. HDR values can

contain brightness levels, including objects as bright as a candle flame or the sun, that far exceed those in 8-bpc or

16-bpc (non-floating-point) mode. Lower dynamic range 8-bpc and 16-bpc modes can represent RGB levels only

from black to white; this represents an extremely small segment of the dynamic range in the real world.

Currently, HDR images are used mostly in motion pictures, special effects, 3D work, and some high-end photog-

raphy.
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Because we can see only a subset of the luminance values in a real-world scene in an HDR image on a monitor, it is

sometimes necessary to adjust the exposure, or the amount of light captured in an image, when working with an HDR

image. Adjusting the exposure of an HDR image is like adjusting the exposure when photographing a scene in the

real world. You can adjust the exposure of HDR footage by modifying the Exposure control. The Exposure control

doesn’t affect how footage will render, only how it appears in previews; see “To adjust exposure of HDR footage (Pro

only)” on page 145. Use the Exposure effect to make tone adjustments to HDR footage. For more information about

the Exposure effect, see “Exposure effect” on page 414.

32-bpc projects and effects

Create 32-bpc projects in After Effects to work with HDR footage, or to work with over-range values—values above

one (white) that aren’t supported in 8- or 16-bpc mode. Over-range values preserve the details in shadows and the

intensity of highlights.

Because HDR extends dynamic range into shadows as well as highlights, you can bring detail out of dark areas as

well as light areas. Blending operations give more photographic results if linear blending is enabled (see “To enable

linear blending” on page 66). You can create lights in 3D space or apply one of the 32-bpc blur effects, such as Fast

Blur, Gaussian Blur, Channel Blur, Directional Blur, and Box Blur, to HDR footage. You can also apply blending

modes to create interesting interactions between layers.

You can use the HDR Compander effect to compress the dynamic range of HDR footage. In this way, you can use

tools that don’t support HDR, such as 8-bpc and 16-bit effects. When you’re done, use the HDR Compander to undo

the dynamic range compression. The HDR Highlight Compression effect lets you compress the highlight values in

an HDR image so that they fall within the value range of a low dynamic range image. For more information about

these effects, see “HDR Compander effect” on page 553 and “HDR Highlight Compression effect” on page 554.

Use the Color Profile Converter effect to convert to or from linear light. For more information about this effect, see

“Color Profile Converter effect” on page 551.

See also

“About color depth” on page 61

“Color depth and effects” on page 351

To expand the range of luma levels
Some file format modules convert 8-bpc luma from certain hardware, such as cameras, to RGB levels within the

range of 16 to 235. In 8-bpc mode, After Effects works with RGB levels from 0 to 255. If blacks or whites appear either

crushed or faded, there may be a luma range mismatch that you can correct by expanding the range of luma levels.

You can expand the range of the luma levels to 0 to 255 without having to apply a Levels effect. Luma expansion also

works with 16-bpc footage and projects.

❖ Select the footage in the Project panel and choose File > Interpret Footage > Main, and select Expand ITU-R 601

Luma Levels.

Note: In 32-bpc projects, After Effects can generate over-range values that let you work with whiter-than-white, or over-

bright, values (for example, values above 235 in an 8-bpc file).
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Color management
Color images can look different when viewed with different display devices and in different contexts. For example,

an image displayed on a computer monitor may look different from the same image displayed on a video monitor or

projected onto a movie screen. Colors shift because different devices use different methods to create color and

produce different ranges of colors.

In After Effects, you can compensate for color output between different display devices by first calibrating and

profiling your monitor and then selecting an RGB working color space, an intermediate color space used to define

and edit color, which After Effects uses for all pixel color calculations. Each project can have its own working color

space, which is saved with all other project settings in the project (.aep) file. When After Effects displays pixels, it

converts from the working color space (which characterizes the space colors are in) to the monitor profile (which

defines how the monitor reproduces color) to produce predictable, consistent color.

Because After Effects doesn’t honor ICC profiles assigned to images such as those from Adobe Photoshop and

doesn’t assign profiles to files on output, it doesn’t provide a complete color management system. However, if you

calibrate and profile your monitor and set an RGB working color space for the project, colors in your images will

look the same on any calibrated monitor.

To calibrate and profile your monitor

When you calibrate your monitor, you’re adjusting it so that it conforms to a known specification. After your monitor

is calibrated, the profiling utility lets you save a color profile. The profile describes the color behavior of the

monitor—what colors can be reproduced on the monitor and how the color values in an image must be converted

so that colors are displayed accurately.

Before you calibrate and profile your monitor, make sure that your work environment provides a consistent light

level and color temperature. For example, the color characteristics of sunlight change throughout the day and alter

the way colors appear on your screen, so keep shades closed or work in a windowless room.

1 Make sure your monitor has been turned on for at least half an hour. This gives it sufficient time to warm up and

produce more consistent output.

2 Make sure your monitor is displaying millions of colors or 24-bits-per-pixel or higher.

3 Remove colorful background patterns on your monitor desktop and set your desktop to display neutral grays.

Busy patterns or bright colors surrounding a document interfere with accurate color perception.

4 Do one of the following to calibrate and profile your monitor:

• In Windows, use the Adobe Gamma utility, located in the Control Panel.

Note:Don’t use Adobe Gamma to calibrate an LCD (flat panel) monitor—it doesn’t produce reliable results. Instead, use

a hardware calibrator.

• In Mac OS, use the Calibrate utility, located in the System Preferences/Displays/Color tab.

• For best results, use third-party software and measuring devices. In general, using a measuring device such as a

colorimeter along with software can create more accurate profiles because an instrument can measure the colors

displayed on a monitor far more accurately than the human eye can.

Note: Monitor performance changes and declines over time; recalibrate and profile your monitor every month or so. If

you find it difficult or impossible to calibrate your monitor to a standard, it may be too old and faded.

Most profiling software automatically assigns the new profile as the default monitor profile. For instructions on how

to manually assign the monitor profile, refer to the Help system for your operating system.
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To choose a working color space

If you don’t choose a working color space for a project, After Effects uses the color space of the monitor. For best

results, choose a working color space that matches your output color space. For example, choose SDTV (Rec 601

NTSC) if you’re preparing footage for broadcast video, or choose sRGB IEC61966-2.1 if you’re preparing footage for

the web. A good match between working and output color spaces not only lets you take advantage of the After Effects

color management feature but also gives more accurate previews and somewhat more accurate results when linear

blending is used (see “To enable linear blending” on page 66). Setting a working color space, however, can signifi-

cantly slow RAM previews.

The color spaces available in After Effects vary based on the color profiles installed on your computer.

1 Choose File > Project Settings.

2 Choose a working color space from the Working Space menu.

Use the Color Profile Converter effect to convert a layer from one color space to another. For example, apply the Color

Profile Converter effect to an adjustment layer at the top of a composition to convert output to a different color space.

(See “Color Profile Converter effect” on page 551.)

To proof colors

If you’ve chosen a working color space, you can choose to proof your colors as they’d appear without the working

color space applied; that is, as raw color values in the color space of the monitor.

1 Choose View > Proof Setup > Unmanaged.

2 Choose View > Proof Colors to toggle the proof display on and off. When proofing is enabled, a check mark

appears next to the Proof Colors command.

To see a theater preview

You can preview footage in After Effects as it would appear on-screen in a theater (film-out) using Kodak 2383 film

stock and standard projector illumination.

Note: If you’re using theater preview with Cineon files, first apply Kodak 5218 ICC Profile. See “To set options for Cineon

files” on page 105

1 Choose View > Proof Setup > Kodak 2383 Theater.

2 Choose View > Proof Colors to toggle the theater preview on and off. When theater preview is on, a check mark

appears next to the Proof Colors command.

Note: Theater preview works only for previews. If desired, you can render the project, maintaining the theater preview,

to display the expected output on non-film devices. To render with theater preview, apply two instances of the Color

Profile Converter effect to an adjustment layer at the top of the composition. For the first instance, set Input Profile to

Project Working Space, Output Profile to DPX Theater Preview-Standard Camera Film, and Intent to Absolute Colori-

metric. For the second instance, set Input Profile to DPX Theater Preview-Standard Print Film, Ouput Profile to the

targeted color space, and leave Intent at the default Relative Color. For more information, see “Color Profile Converter

effect” on page 551.
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To enable linear blending
Linear blending emulates the combination of colors in a way that more accurately reflects how colors blend in real

life. For example, it corrects dark halos and fringing when high-contrast, saturated colors are blended together. If

linear blending isn’t enabled, RGB colors are blended in the project working color space, which in some cases can

result in edge or halo artifacts. When you enable linear blending, After Effects blends RGB colors in a color space

with a gamma of 1.0, which is considered colorimetrically correct and results in the fewest artifacts. Linear blending

affects layer, text, paint, and 3D blending.

To see the dramatic effects linear blending can produce, try painting with a soft green brush on a red solid and then

applying linear blending.

Compositions render more slowly when linear blending is enabled, so enable it only if necessary.

❖ Choose File > Project Settings, and choose Linear Blending.

Plug-ins and scripts

Plug-ins
Plug-ins are small software programs that work with another program to add functionality. A number of plug-ins

come with After Effects and are automatically installed in folders inside the Adobe After Effects 7.0 folder. You can

otain other plug-ins for After Effects from Adobe or third-party vendors.

Many third-party effects are available in the form of plug-ins. Some plug-ins can also speed rendering and perform

such tasks as format conversion.

You can find information about third-party plug-ins available for After Effects in the Support area of the Adobe

website.

For plug-ins to work with After Effects, they must be in the Plug-ins folder, which is in the Adobe After Effects

7.0\Support Files (Windows) or Adobe After Effects 7.0 (Mac OS) folder by default. For specific instructions about

installing a plug-in, refer to its documentation.

Note: (Mac OS) Some third-party plug-in installers incorrectly install their plug-ins into the Mac OS X Package for After

Effects. To reveal these plug-ins, Control-click the After Effects application icon in the Finder and choose Show Package

Contents. You can then move the plug-ins into the After Effects Plug-ins folder.

See also

“About 3D rendering” on page 625

“To set the rendering plug-in” on page 116

Scripts (Pro only)
A script is a series of commands that tells your computer to perform a sequence of operations. You can use scripts

to automate many tasks in After Effects Professional. For example, you can direct After Effects to import multiple

footage files.
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After Effects provides prewritten scripts to assist you in performing common tasks. Prewritten scripts appear in the

File > Scripts menu. You can also write your own scripts for use in After Effects by using the Script Editor. After

Effects recognizes JavaScript files (with the .jsx file-name extension). For a complete description of the scripting

capabilities available with After Effects, see the Scripting Guide on the After Effects disc.

Writing scripts (Pro only)

The Script Editor provides a convenient interface for creating, debugging, and testing your own scripts.

To start the Script Editor, choose File > Scripts > Open Script Editor.

For more information about the Script Editor, see the Scripting Guide on the After Effects disc.

To execute a script (Pro only)

❖ Do one of the following:

• Choose File > Scripts > [script name]

• Choose File > Scripts > Run Script File, locate and select a script, and click Open.

Note: Scripts created in After Effects 6.5 or earlier that use an index to access a property may not work as expected in

After Effects 7.0. To resolve this issue, modify your scripts so that they contain equivalent expressions accessing properties

by name.

To install a script (Pro only)

❖ Copy the script to your computer’s hard disk. If you want the script to appear in the Scripts menu, place the script

in the Scripts folder inside the After Effects folder.

Note: If you edit a script while After Effects is running, you must save your changes for the changes to be applied. If you

place a script in the Scripts folder while After Effects is open, you must restart After Effects for the script to appear in the

Scripts menu.
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Chapter 5: Preparing and importing
footage

Importing basics

Working with imported files
A footage item is the basic unit in an After Effects project. Before you begin animating, you need to import footage

into After Effects. You then work with footage items in compositions, collections of layers in which you create all

animation, layering, and effects. You can import moving image files, still-image files, still-image sequences, audio

files, layered files from Adobe Photoshop and Adobe Illustrator, and other After Effects projects and projects created

in Adobe Premiere Pro. As you build a project, you can import footage items at any time.

When you import files, After Effects does not copy the footage item itself into your project but creates a reference link

in the Project panel to the footage item. This saves disk space.

If you delete, rename, or move an imported source file, you break the reference link to that file. When a link is broken,

the name of the source file appears in italics in the Project panel, and the File Path column lists it as missing. If the

footage item is available, you can reestablish the link—usually just by double-clicking the item and selecting the file

again.

To save time and minimize the size and complexity of a project, import a footage item once and then use it multiple

times in a composition. It is occasionally useful, however, to import a footage item more than once, such as when

you want to use it at two different frame rates.

If you use another application to modify footage that is used in a project, the changes appear in After Effects the next

time you open the project.

When you add a footage item to an After Effects composition, you create a new layer, and the footage item becomes

the source for the new layer. You can replace the source without affecting any edits you make to the layer properties.

You can import a variety of audio file formats directly into After Effects. When you add audio-only files to a compo-

sition, they appear as layers in the Timeline panel. You can adjust the audio preview settings, such as sample rate, in

the Previews section of the Preferences dialog box. These settings change the quality of audio playback when you

preview the composition, not when you render it.

See also

“About placeholders and proxies” on page 128

“To edit footage in its original application” on page 124

“Previewing audio” on page 136

“To create a new Photoshop layer” on page 152
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Supported file formats for import
All versions of After Effects can import 8-bpc (bits per channel), 16-bpc, and 32-bpc files in RGB, grayscale, and

black-and-white color modes, including 24-bpp (bits per pixel) and 32-bpp files; however, After Effects Standard

edition reduces 16-bpc and 32-bpc files to 8-bpc (After Effects Professional edition supports 16-bpc and 32-bpc

color). For more information on 16-bpc and 32-bpc color, see “About color depth” on page 61.

Note: File formats that use Adobe Photoshop plug-ins include BMP, OpenEXR, PBM, PCX, Pixar, and Radiance.

Supported audio file formats

You can import any of the following types of audio files:

• Advanced Audio Coding (AAC)

• AU (Requires QuickTime)

• Audio Interchange File Format (AIFF; requires QuickTime)

• MP3 (Requires QuickTime)

• Video for Windows (AVI, WAV)

• WAVE (WAV)

Supported still-image file formats

You can import any of the following types of still-image files:

• Adobe Illustrator (AI, AI4, AI5, EPS, PS)

• Adobe PDF (PDF; first page only)

• Adobe Photoshop (PSD; 16 and 32 bpc)

• Bitmap (BMP, RLE)

• Camera raw (TIF, CRW, NEF, RAF, ORF, MRW, DCR, MOS, RAW, PEF, SRF, DNG, X3F, CR2, ERF; 16 bpc)

• Cineon (CIN, DPX; converts to 8, 16, or 32 bpc, per Project Settings)

• Discreet RLA/RPF (RLA, RPF; 16 bpc, imports camera data)

• EPS

• JPEG (JPG, JPE)

• Maya camera data (MA; Professional edition only)

• Maya IFF (IFF; 16 bpc)

• OpenEXR (EXR; 32 bpc)

• PBM (8, 16, and 32 bpc)

• PCX

• Pict (PCT, PICT)

• Pixar (PXR)

• Portable Network Graphics (PNG; 16 bpc)

• Radiance (HDR, RGBE, XYZE; 32 bpc)

• SGI (SGI, RGB; 16 bpc)

• Softimage (PIC)
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• Targa (TGA, VDA, ICB, VST)

• TIFF (TIF; 16 bpc in Standard, 16 and 32 bpc in Professional)

You can import files of any still-image format as a sequence. See “About still-image sequences” on page 75.

Supported video and animation file formats

You can import any of the following types of video and animation files:

• Animated GIF (GIF; requires QuickTime)

• ElectricImage (IMG, EIZ)

• FLC/FLI

• Filmstrip (FLM)

• Macromedia Flash (SWF; requires QuickTime)

• MPEG-1, MPEG-2 (Windows only), MPEG-4 (requires QuickTime) (MPG)

• Open Media Framework (OMF; raw media [or essence] only)

• QuickTime (MOV; 16 bpc, requires QuickTime)

• Video for Windows (AVI, WAV)

You can import 10-bpc uncompressed YUV AVI files created in Adobe Premiere Pro into 16-bpc RGB After Effects

projects. You can also render with 10-bpc YUV compression; see “Video for Windows compression options” on

page 622.

• Windows Media File (WMV; Windows only)

Supported video project file formats

• Advanced Authoring Format (AAF)

• Adobe Premiere 6.0 and 6.5 (PPJ)

• Adobe Premiere Pro 1.0, 1.5, and 2.0 (PRPROJ)

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“Supported file formats for output” on page 590

Preparing files
To reduce rendering time and increase performance, you may want to prepare footage before you import it into After

Effects. First decide which media to use for your finished movies, and then determine the best settings with which

to create your source material. For example, if you are rendering your project to videotape, create footage at an image

size, color bit-depth, and frame rate that produce the best image quality on videotape. Likewise, if your project is

intended for streaming video on the Web, the image size, color bit-depth, and frame rate may need to be reduced to

work with the data-rate limits of streaming video on the Web. However, any footage item that can be imported can

be used in any composition.
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See also

“Output type considerations” on page 51

“Preparing still-image files for importing” on page 73

To specify interpretation rules
The interpretation rules file (interpretation rules.txt) specifies how After Effects interprets field order, alpha channel,

frame rate, and pixel aspect ratio when importing footage. In most cases, you won’t need to customize this file; do so

only if you want to adjust the parameters that define how After Effects interprets imported footage. When you

import footage, After Effects looks for a match in the interpretation rules file, and then sets field order, frame rate,

alpha channel interpretation, and pixel aspect ratio for the footage. You can override these settings after importing.

1 Quit After Effects.

2 As a precaution, make a backup copy of interpretation rules.txt. By default, this file is in the same location as the

After Effects application.

3 Open interpretation rules.txt in a text editor.

4 Modify the settings according to the instructions in the file.

Note: You must supply a four-character file-type code for each footage type or codec. If you don’t know the code for a file

or codec in a project, press Alt (Windows) or Option (Mac OS) as you select the file in the Project panel. The file-type

code and codec code (if the file is compressed) appear in the last line of the file description at the top of the Project panel.

5 Save interpretation rules.txt in the same folder as the After Effects application.

See also

“To determine the original field order” on page 100

“To set the alpha channel interpretation method” on page 72

“To change the frame rate of video and film footage” on page 96

“About pixel aspect ratio” on page 96

To import footage into a Project panel
1 Open a project or choose File > New > New Project.

2 With the Project panel active, choose File > Import > File.

You can also double-click an empty area of the Project panel to open the Import File dialog box.

Note: Choose All Footage Files from the Files Of Type (Windows) or Enable (Mac OS) menu to display only supported

footage files--project files are not shown.

3 Do one of the following:

• Select a file and then click Open.

• Hold down Ctrl (Windows) or Command (Mac OS), select the items you want, and then click Open.

• Select an entire folder, and then click Import Folder.

The imported footage appears in the Project panel.
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Note: If the Interpret Footage dialog box appears instead, the imported footage item contains an unlabeled alpha

channel. You need to select a type or click Guess to let After Effects determine the type. See “Interpretation methods” on

page 73.

For more information about importing folder contents, see “About still-image sequences” on page 75.

Note: To search for a file from the Import File dialog box in Mac OS, click Find, type the name of a file or folder, and

click OK. After Effects finds the first file or folder that matches the text.

To import footage by dragging
❖ From the desktop or a folder, select one or more items you want to import and drag them to the After Effects appli-

cation icon (in Windows Explorer or Mac OS Finder) or to the Project panel (in After Effects).

If you import a folder by dragging it from the desktop, the contents of that folder are imported as a sequence. To

import the contents as individual footage files, press Alt (Windows) or Option (Mac OS) as you drag. (This is the

equivalent of clicking the Import Folder button when importing footage into a Project panel.) If you always want the

layered footage that you drag into After Effects to be imported as a composition, you can specify this in your Import

Preferences: Choose Comp from the Default Drag Import As menu.

See also

“About still-image sequences” on page 75

To import footage with an alpha channel
The alpha channel contains transparency information for a footage item. Many file formats can include an alpha

channel, including Adobe Photoshop, ElectricImage, TGA, TIFF, EPS, PDF, QuickTime (saved at a bit depth of

Millions of Colors+), and Adobe Illustrator.

1 Choose File > Import > File.

2 Select the name of the file you want to open. If the file does not appear, select the option for showing all files from

the Files Of Type (Windows) or Enable (Mac OS) menu.

3 Click Open.

4 If the Interpret Footage dialog box appears, select an option for the alpha channel. If you select Guess, After Effects

determines the interpretation method.

Correctly identifying the type of alpha channel when you import a file can prevent problems, such as undesirable

colors at the edge of an image or a loss of image quality at the edges of the alpha channel. If a color inaccuracy, such

as a halo, appears along the edges of an alpha channel in a composition, try changing the interpretation method. See

“Interpretation methods” on page 73.

See also

“To view masks” on page 250

“About alpha channels and mattes” on page 242

To set the alpha channel interpretation method
You can change the interpretation method for a file after you import the file.

1 In the Project panel, select a footage item that includes an alpha channel.
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2 Choose File > Interpret Footage > Main.

3 In the Alpha section, select an interpretation method.

4 If you want to switch the opaque and transparent areas of the image, select Invert Alpha.

5 Click OK.

You can also change the default alpha channel interpretation by changing Import Preferences, in the Interpret

Unlabeled Alpha As menu. This is especially useful for importing footage from an application that consistently uses

one type of unlabeled alpha channel.

A footage file with a premultiplied alpha channel (left) appears with a black halo (center) when interpreted as Straight-Unmatted, or Premul-
tiplied-Matted with Color (white selected). When the footage file is interpreted as Premultiplied-Matted with Color (black selected) the halo
does not appear (right).

See also

“About straight and premultiplied channels” on page 242

Interpretation methods
Ask User Displays a dialog box containing interpretation options each time you import an unlabeled alpha channel.

Guess Attempts to determine the type of alpha channel used in the image. If After Effects cannot guess confidently,

it beeps.

Ignore Alpha Disregards all transparency data in the file.

Straight (Unmatted) Interprets the alpha channel as straight alpha. If the application you used to create the footage

does not premultiply the alpha channel, select this option.

Premultiplied (Matted With Black) Interprets the alpha channel as premultiplied with black.

Premultiplied (Matted With White) Interprets the alpha channel as premultiplied with white.

See also

“About straight and premultiplied channels” on page 242

Importing still images

Preparing still-image files for importing
You can import individual still images into After Effects or import a numbered sequence of still images as a sequence.

You can import still images from Adobe applications such as Photoshop and Illustrator, or import Adobe Stock

Photos from Adobe Bridge. For information about the still-image formats that After Effects imports, see “Supported

file formats for import” on page 69.
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Before you import a still image into After Effects, prepare it as completely as possible to reduce rendering time. It is

usually easier and faster to prepare a file in its original application. Consider doing the following:

• Make sure that the file format is supported by the operating system you plan to use.

• Set the pixel dimensions to the resolution you will use in After Effects. If you plan to scale the image over time, set

image dimensions that provide enough detail at the largest size the image has in the project. The maximum

resolution you can use in After Effects is 30,000 x 30,000 pixels.

• Crop the parts of the image that you do not want to be visible in After Effects.

• If you want to designate areas as transparent, create an alpha channel or use the transparency tools in applications

such as Photoshop or Illustrator.

• If final output will be broadcast video, avoid using thin horizontal lines (such as 1-pixel lines) for images or text

because they may flicker as a result of interlacing. If you must use thin lines, add a slight blur so that the image or

text appears in both video fields instead of flickering between them. See “About interlaced and noninterlaced

video” on page 98.

• Save the file using the correct naming convention. For example, if you plan to import the file into After Effects on

Windows, use a three-character file-name extension.

Working with higher image resolutions
After Effects supports a maximum image resolution of 30,000 x 30,000 pixels for importing and rendering files,

except for PICT (4,000 x 4,000 pixels), BMP (16,000 x 30,000 pixels), and PXR (30,000 x 16,000 pixels). Resolution

refers to the dimensions (width and height) of an image measured in pixels. When you work with higher resolutions,

you can use a wider variety of formats, such as IMAX frames (4096 x 3002 pixels), full-aperture/silent frames (4096

x 3112 pixels), and other large-format media.

The maximum resolution you can import or export can be reduced by the amount of physical RAM available to After

Effects.

See also

“Memory usage” on page 636

To change the duration of still footage
When you add a still image to a composition, its default duration is the duration of the composition. You can

manually trim the duration of a still image and change the default duration of still footage in the Import Preferences

dialog box.

1 Choose Edit > Preferences > Import (Windows) or After Effects > Preferences > Import (Mac OS).

2 Under Still Footage, do one of the following, and then click OK:

• Select Length Of Composition to set the same duration for the still image as the composition into which it is

placed.

• Type numbers in the text box for the duration you want to use.

See also

“About trimming” on page 162
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About still-image sequences
After Effects can import a sequence of still images if they all reside within one folder and use the same numeric or

alphabetic file name pattern (such as Sequence1, Sequence2, Sequence3, and so forth). You can import them by using

any of the following methods:

• As a sequence file where the layers in the file, if any, are merged.

• As a sequence file (Adobe Photoshop and Adobe Illustrator files with layers only) where the same layer in each

file—for example, layer 3—is imported and used in the sequence.

• As a composition (Adobe Photoshop and Adobe Illustrator files with layers only) where every layer across the

group of files is imported as a separate sequence and appears as a separate layer in the Timeline panel.

After Effects uses the dimensions and bit depth of the first image in the sequence. It then imports (in numeric or

alphabetic order) all still images in the folder that have the same file name pattern and file type as the one you

selected. Each image, once imported into the sequence, represents one frame.

Note: When you render a composition that contains a numbered sequence, the output module uses the start frame

number as the first frame number. For example, if you start to render on frame 25, the name of the file is 00025. (See

“To work in the Render Queue panel” on page 602.)

A sequence of still-image files (left) becomes one image sequence when imported into After Effects (right).

To import a still-image sequence as a sequence file
1 Choose File > Import > File.

2 Locate and select any file in the sequence. To import a subset of files in a sequence, select the first file, hold down

Shift, and then select the last file you want to include.

3 Choose Footage from the Import As menu.

4 Select the [file format name] Sequence option.

5 If you want to import alphabetically, select Force Alphabetical Order.

6 Click Open (Windows) or Import (Mac OS).

7 In the [file name] dialog box, choose one of the following from the Choose Layer menu:

Merged Layers Merges all the layers in each individual file to one layer.
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Layer Name Imports only a specific layer from each file in the sequence.

8 Click OK.

Note: To import a still-image sequence by dragging, drag the folder from the desktop to the After Effects Project panel.

After Effects imports the first sequence of files that is listed in the folder, based on the file name.

To import a still-image sequence as a composition
1 Choose File > Import > File.

2 Locate and select any file in the sequence. To import a subset of files in a sequence, select the first file, hold down

Shift, and then select the last file you want to include.

3 Choose one of the following from the Import As menu:

Composition - Cropped Layers Import the layers with their original dimensions. This option makes it easier to

manipulate layers and speeds their rendering time.

Composition Import layers and have them match the dimensions of the composition. This option is helpful when

you need to align layers manually.

4 Select the [file format name] Sequence option.

5 If you want to import alphabetically, select Force Alphabetical Order.

6 Click Open.

To import a sequence of files as individual footage items
❖ Do either of the following:

• Choose File > Import > File to open the Import File dialog box, locate and select the folder, and then click the

Import Folder button.

• On the desktop, hold down Alt (Windows) or Option (Mac OS) and drag the folder into either the After Effects

icon on the desktop or into the Project panel. Release the mouse before you release Alt (Windows) or Option (Mac

OS).

To change the frame rate of a sequence
When you import a sequence of still images, they assume the frame rate specified in Preferences. The default rate is

30 frames per second (fps). You can change the frame rate for the sequence either before or after importing.

• To change the frame rate before importing, type a new default frame rate under Sequence Footage in Import

Preferences.

• To change the frame rate after importing, select the sequence of still images in the Project panel. Then choose

File > Interpret Footage > Main, select Assume This Frame Rate, type the frame rate you want, and then click OK.
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Importing camera raw files

About camera raw files
A camera raw file contains unprocessed picture data from a digital camera’s image sensor. Many digital cameras can

save image files in camera raw format. In this way, photographers can interpret the image data rather than having

the camera make the adjustments and conversions automatically.

Camera raw images contain the actual data captured by the sensor without any in-camera processing; these are the

only files containing “pure” data. Working with camera raw files gives you maximum control; you can set the white

balance, tonal range, contrast, color saturation, and sharpening. Think of camera raw files as your photo negative.

You can reprocess the file at any time to achieve the results you want.

When you open a camera raw image file, you can quickly apply adjustments, such as exposure compensation or tonal

adjustments, without compressing the image or losing any of the original image data (when you make adjustments

to a camera raw image file, the original camera raw file data is preserved). You can also make adjustments to the

camera raw file after you import it. In After Effects, camera raw converts to 8 or 16 bits per channel based on the

After Effects project setting.

Note: Camera raw files are uncompressed. Their large size may increase rendering time.

See also

“Supported file formats for import” on page 69

To work with the Camera Raw cache in Bridge
You can use Adobe Bridge to preview camera raw images using the default image settings and to apply settings

without opening the Camera Raw dialog box. You can also copy and paste the settings from one camera raw image

to another in Bridge.

When you view camera raw files in Bridge, the thumbnails and previews use either the camera raw default settings

or your adjusted settings. The cache in Bridge and the Camera Raw cache store data for the file thumbnails, metadata,

and file information. Caching this data shortens the loading time when you return to a previously viewed folder.

The Camera Raw cache speeds loading of the Camera Raw dialog box and the recalculation of preview in Bridge after

changes are made to the Camera Raw settings. The Camera Raw cache holds preparsed raw image data for the most

recently accessed camera raw files.

Because the caches can become very large, you may want to purge the cache or limit its size. You can also purge and

regenerate the cache if you suspect that it is corrupted or old. Purging the cache deletes thumbnail information and

metadata added since the camera raw file was opened in Bridge.

Note:The Camera Raw cache holds data for about 200 images for each gigabyte of disk storage allocated to it. By default,

the Camera Raw cache is set to a maximum size of 1 GB. You can increase its limit in the Camera Raw preferences.

1 In Bridge, choose one of the following:

• (Windows) Edit > Camera Raw Preferences.

• (Mac OS) Bridge > Camera Raw Preferences.

2 Do any of the following, and click OK:

• To change the cache size, type a value in the Maximum Size box.

• To purge the Camera Raw cache, click the Purge Cache button.
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• To change the location of the Camera Raw cache, click Select Location, browse to the new location, and click

Select.

To import a camera raw file

The Camera Raw dialog box
A. Tools B. Rotate buttons C. Camera, file name, and EXIF information D. View options E. RGB values F. Histogram G. Camera Raw
menu H. Zoom levels I. Adjustment sliders

1 Choose File > Import > File.

2 Select the camera raw file, and click Open.

The Camera Raw dialog box opens with a histogram and image preview. See “Using the histogram and RGB levels

in Camera Raw” on page 80.

You can import sequences of camera raw files in the same way you import sequences of still image files. Note that

After Effects applies the settings for the first camera raw image in the sequence to the rest of the images in the

sequence if those images don’t have specific settings.

3 (Optional) Make one or more of the following adjustments:

• Adjust the image view using controls and options such as zoom, shadows, and highlights. See “Camera Raw view

controls” on page 80.

Note: Selecting the Preview check box displays a preview of any setting changes made to the current tab (Adjust, Detail,

Lens, Curve, or Calibrate) combined with the settings in the hidden tabs. Deselecting the Preview check box displays the

camera raw image with the original settings of the current tab combined with the settings in the hidden tabs.

• Rotate the image. See “To rotate images in Camera Raw” on page 83.

• Select the Color Sampler tool to place up to nine color samplers in the preview image. See “Using the

histogram and RGB levels in Camera Raw” on page 80.

A
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• Apply the settings used in the previous camera raw image, or apply the default settings for your camera: Choose

an option from the Settings menu. See “Working with Camera Raw settings” on page 86.

• Adjust the white balance. See “White balance controls for camera raw files” on page 81.

You can monitor the RGB values of pixels as you adjust your image in the Camera Raw dialog box. Position the Hand

tool, Zoom tool, White Balance tool, Color Sampler tool, or Crop tool over the preview image to display the RGB

values directly beneath the pointer. You can also place up to nine color samplers in the preview image. The RGB values

of each color sampler appear beneath the preview image.

• Make tonal adjustments using the Exposure, Shadow, Brightness, Contrast, and Saturation sliders, or select Auto

to make these adjustments automatically. (There is no Auto option for Saturation.) Deselect an Auto option to

undo your manual adjustments and make the adjustments automatically.

Note:By default, the Auto options are always selected in the Camera Raw dialog box. You change this default by choosing

Use Auto Adjustments from the Camera Raw menu.

• Make further adjustments using the Detail, Lens, Curve, and Calibrate tabs. See “Detail, Lens, Curve, and

Calibrate tabs” on page 79.

• Crop or straighten the image. See “To crop images in Camera Raw” on page 83 and “To straighten images in

Camera Raw” on page 83.

If you don’t want to keep your adjustments, Alt-click (Windows) or Option-click (Mac OS) Reset to reset all options

to their default settings.

Detail, Lens, Curve, and Calibrate tabs

These tabs contain options to adjust camera raw files.

Detail Adjusts sharpening, or applies luminance smoothing or color noise reduction. See “To adjust sharpening in

camera raw files” on page 83 and “Reducing noise in camera raw files” on page 84.

Lens Compensates for chromatic aberration and vignetting introduced by a digital camera. See “To compensate for

chromatic aberration in Camera Raw” on page 85 and “To compensate for lens vignetting” on page 85.

Curve Adjusts tonality using a Curves adjustment. Use the Tone Curve menu to choose a preset adjustment.

Calibrate Corrects a color cast in the shadows and adjusts non-neutral colors to compensate for the difference

between the behavior of your camera and Camera Raw’s built-in profile for your camera model. To save adjustments

as the default settings for a specific camera, click the triangle next to the Settings menu. Then, from the Camera Raw

dialog box menu, choose Save New Camera Raw Defaults. See “To remove a shadow color cast in camera raw files”

on page 85 and “To adjust the rendering of non-neutral colors in Camera Raw” on page 86.

To adjust camera raw files after importing
1 Select the file in the Project panel.

2 Choose File > Interpret Footage > Main.

3 Click More Options, and make adjustments in the Camera Raw dialog box.

See also

“To import a camera raw file” on page 78
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Using the histogram and RGB levels in Camera Raw
The Camera Raw histogram shows all three channels (red, green, and blue) of the image simultaneously. The

histogram changes automatically as you adjust the settings in the Camera Raw dialog box.

As you move the Zoom tool, Hand tool, White Balance tool, Color Sampler tool, Crop tool, or Straighten tool over

the preview image, the RGB values of the area appear in the upper right corner of the dialog box.

You can also use the Color Sampler tool to place up to nine color samplers in the preview image. The RGB values

appear above the preview image. To clear the color samplers, click Clear Samplers.

The Camera Raw dialog box displays the RGB values of the area below the pointer.

Camera Raw view controls
Zoom tool Sets the preview zoom to the next preset value when you click the preview image. Alt-click

(Windows) or Option-click (Mac OS) to set the next lower zoom value. Drag the Zoom tool in the preview image to

zoom in on a selected area. To return to 100%, double-click the Zoom tool.

Hand tool Moves the image in the preview panel if the preview image is set at a zoom level higher than 100%.

Hold down the spacebar to use the Hand tool while using another tool. Double-click the Hand tool to fit the preview

image to the panel.

Select Zoom Level Sets the magnification of the preview image. Choose a zoom setting from the menu or click the

Select Zoom Level buttons.

Preview Displays a preview reflecting the changes to the current tab (Adjust, Detail, Lens, Curve, or Calibrate)

combined with the settings in the hidden tabs. Deselect Preview to view the camera raw image with the original

settings for the current tab combined with the settings in the hidden tabs.

RGB Indicates the red, green, and blue values of the area directly below the pointer in the preview image. The values

appear when you use the Zoom tool, Hand tool, White Balance tool, Color Sampler tool, Crop tool, or Straighten

tool.

Shadows and Highlights Displays shadow and highlight clipping. Clipped shadows appear in blue, and clipped

highlights appear in red. Highlight clipping is shown if any one of the three RGB channels is clipped (fully saturated

with no detail). Shadow clipping is shown if all three RGB channels are clipped (black with no detail).
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Transforming images in Camera Raw

White balance controls for camera raw files
A digital camera records the white balance at the time of exposure as a metadata entry. After Effects can read the

white balance settings of some cameras and makes it the initial setting when you open the file in the Camera Raw

dialog box. This setting usually yields the correct color temperature. You can adjust it if the white balance is not quite

right.

The Adjust tab in the Camera Raw dialog box has three controls for correcting a color cast in your image. The

Calibrate tab also has a control for correcting a shadow color cast (a color cast that remains in the shadows even after

the white balance is adjusted).

White Balance Sets the color balance to reflect the lighting conditions under which the photo was taken. In some

cases, choosing a white balance from the White Balance menu provides satisfactory results. In many cases, you may

want to customize the white balance using the Temperature and Tint adjustments.

Note: Leave White Balance set to As Shot to use the camera’s white balance settings. For cameras whose white balance

settings are not recognized by After Effects, As Shot is the same as Auto; After Effects reads the image data and automat-

ically adjusts the white balance.

Temperature Fine-tunes the white balance to a custom color temperature. Set the color temperature using the Kelvin

color temperature scale. Move the slider to the left to correct a photo taken with a lower color temperature of light;

the Camera Raw plug-in makes the image colors bluer to compensate for the lower color temperature (yellowish) of

the ambient light. Conversely, move the slider to the right to correct a photo taken with a higher color temperature

of light; the image colors become warmer (yellowish) to compensate for the higher color temperature (bluish) of the

ambient light.

Correcting the white balance
A. Moving the Temperature slider to the right corrects a photo taken with a higher color temperature of light. B. Moving the Temperature slider
to the left corrects a photo taken with a lower color temperature of light. C. Photo after color temperature adjustment

A

C

B
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Tint Fine-tunes the white balance to compensate for a green or magenta tint. Move the slider to the left (negative

values) to add green to the photo; move it to the right (positive values) to add magenta.

To adjust the white balance quickly, select the White Balance tool, and then click an area in the preview image that

should be a neutral gray or white. The Temperature and Tint sliders automatically adjust to make the selected color

exactly neutral (if possible). If you’re clicking whites, choose a highlight area that contains significant white detail rather

than a specular highlight.

Clicking a neutral white area with the White Balance tool (left) and resulting correction (right)

Tonal adjustment controls for camera raw files
Exposure Adjusts the brightness or darkness of the image. Move the slider to the left to darken the image; move it

to the right to brighten the image. The values are in increments equivalent to f-stops. An adjustment of +1.50 is

similar to widening the aperture one and one-half stops. Similarly, an adjustment of –1.50 is similar to reducing the

aperture one and one-half stops.

Hold down Alt (Windows) or Option (Mac OS) while moving the Exposure slider to preview where the highlights are

clipped. (Clipping is the shifting of pixel values to either the highest highlight value or the lowest shadow value.

Clipped areas are either completely white or completely black and have no image detail.) Move the slider until the

highlights (not specular highlights) are completely clipped, and then reverse the adjustment slightly. Black indicates

unclipped areas, and color indicates areas clipped in only one or two channels.

Hold down Alt (Windows) or Option (Mac OS) while moving the Exposure slider to show clipped highlights.

Shadows Specifies which input levels are mapped to black in the final image. Moving the slider to the right increases

the areas that are mapped to black. This sometimes creates the impression of increased contrast in the image. Using

the Shadows slider is similar to using the black point slider for input levels in the Auto Levels effect.

Hold down Alt (Windows) or Option (Mac OS) while moving the Shadows slider to preview where the shadows are

clipped. Move the slider until the shadows begin to get clipped, and then reverse the adjustment slightly. Color

indicates areas that are being clipped in one or two channels, and white indicates unclipped areas.
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Brightness Adjusts the brightness or darkness of the image, much as the Exposure slider does. However, instead of

clipping the image in the highlights (areas that are completely white, no detail) or shadows (areas that are completely

black, no detail), Brightness compresses the highlights and expands the shadows when you move the slider to the

right. In general, use the Brightness slider after you set the white and black clipping points with the Exposure and

Shadow sliders.

Contrast Adjusts the midtones in an image. Higher values increase the midtone contrast, and lower values decrease

it. Generally, you use the Contrast slider to adjust the contrast of the midtones after setting the Exposure, Shadows,

and Brightness values.

Saturation Adjusts the color saturation of the image from –100 (pure monochrome) to +100 (double the saturation).

To rotate images in Camera Raw
❖ Click a Rotate Image button  to rotate the image 90˚ counterclockwise or 90˚ clockwise.

To straighten images in Camera Raw
1 In the Camera Raw dialog box, select the Straighten tool .

2 Drag the Straighten tool in the preview image to establish what’s horizontal or vertical.

To crop images in Camera Raw
1 In the Camera Raw dialog box, select the Crop tool .

2 (Optional) If you want the crop area constrained to specific proportions, click the Crop tool icon and choose a

proportion from the pop-up menu. Choosing Custom opens the Custom Crop dialog box, where you can specify the

proportions or the dimensions of the crop. Click OK.

3 Drag the Crop tool over the image.

4 (Optional) Adjust the crop area:

• To scale or rotate the crop area, drag just outside the bounding box handles.

• To move the crop area, drag in the bounding box.

If you selected several images in the Camera Raw dialog box, they are all cropped to the same size, with the crop

applied in the same position.

Note: To cancel the crop operation, press Esc with the Crop tool selected or click the Crop tool and choose Clear Crop

from the pop-up menu. To cancel the crop and close the Camera Raw dialog box without processing the camera raw

image file, click the Cancel button or deselect the Crop tool and press Esc.

5 Click OK to apply the crop and process the camera raw image file.

To adjust sharpening in camera raw files
The Sharpness slider lets you adjust the edge definition. The Sharpness adjustment is a variation of the Unsharp

Mask effect, which locates pixels that differ from surrounding pixels based on the threshold you specify and increases

the pixels’ contrast by the amount you specify. When opening a camera raw image file, After Effects calculates the

threshold to use based on camera model, ISO, and exposure compensation. You can choose whether sharpening is

applied to all images or just to previews.

1 Zoom the preview image to at least 100%.
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2 In the Detail tab, move the sharpness slider to the right to increase sharpening and to the left to decrease it. A value

of zero turns off sharpening. In general, set the Sharpness slider to a lower value for cleaner images.

To specify whether the image or preview is sharpened
1 Do one of the following:

• In the Camera Raw dialog box, click the triangle next to the Settings menu and choose Preferences from the

Camera Raw menu.

• (Windows) In Adobe Bridge, choose Edit > Camera Raw Preferences.

• (Mac OS) In Bridge, choose Bridge > Camera Raw Preferences.

2 In the Camera Raw Preferences dialog box, choose one of the following:

All Images Applies sharpening to the camera raw image.

Preview Images Only Applies sharpening only to the preview image and not the actual camera raw image. Use this

option if don’t want to apply sharpening with the Camera Raw plug-in.

Reducing noise in camera raw files
The Detail tab of the Camera Raw dialog box has controls for reducing image noise, the extraneous visible artifacts

that degrade image quality. Image noise includes luminance (grayscale) noise, which makes an image look grainy,

and chroma (color) noise, which is usually visible as colored artifacts in the image. Photos taken with high ISO

speeds or less-sophisticated digital cameras can have noticeable noise.

The Luminance Smoothing slider reduces grayscale noise, and the Color Noise Reduction slider reduces chroma

noise. Moving a slider to zero turns off noise reduction.

When making Luminance Smoothing or Color Noise Reduction adjustments, first zoom in on the preview image for

a better view.

Moving the Luminance Smoothing slider to the right reduces grayscale noise (above right), and moving the Color Noise Reduction slider to the
right reduces chroma noise (below right).



ADOBE AFTER EFFECTS 7.0
User Guide

85

To compensate for chromatic aberration in Camera Raw
Chromatic aberration is a common defect caused by the failure of the lens to focus different frequencies (colors) to

the same spot. In one type of chromatic aberration, the image from each color of light is in focus, but each image is

a slightly different size. This type of aberration is seen as a complementary color fringing in areas away from the

center of the image. For example, you may see a red fringe on the side of an object toward the center of the image,

and cyan fringe on the side of the object away from the center of the image.

Original image (top), and after fixing chromatic aberration (bottom)

1 Zoom into an area near the corner of the preview image. For the best results, the area should contain very dark or

black detail against a very light or white background. Look for the color fringing.

2 In the Lens tab, move one or more of the following sliders:

Fix Red/Cyan Fringe Adjusts the size of the red channel relative to the green channel. This compensates for red/cyan

color fringing.

Fix Blue/Yellow Fringe Adjusts the size of the blue channel relative to the green channel. This compensates for

blue/yellow color fringing. Look at the preview image as you move the slider left or right. If you’re adjusting red/cyan

color fringing, you can hold down Alt (Windows) or Option (Mac OS) to hide the blue/yellow color fringing.

Similarly, hold down Alt (Windows) or Option (Mac OS) while adjusting the blue/yellow color fringing to hide the

red/cyan color fringing. The goal is to reduce the color fringing as much as possible.

To compensate for lens vignetting
Vignetting is a lens defect that causes the edges, especially the corners, of an image to be darker than the center.

1 In the Lens tab, move the Vignetting Amount slider to the right (positive values) to lighten the corners of the

image or to the left (negative values) to darken them. You can also enter a value in the Vignetting Amount box.

2 Move the Vignetting Midpoint slider to the left (lower value) to apply the Vignetting Amount adjustment to a

larger area away from the corners, or move the slider to the right (higher value) to restrict the adjustment to an area

closer to the corners. You can also enter a value in the Vignetting Midpoint box.

To remove a shadow color cast in camera raw files
Sometimes a color cast remains in the shadow areas after you adjust the highlight white balance using the Temper-

ature and Tint sliders. The Calibrate tab has a Shadow Tint slider to correct this remaining shadow color cast.

❖ In the Calibrate tab, move the Shadow Tint slider to remove the color cast in the shadows. The camera’s sensor and

the white balance affect which colors are adjusted. Usually, moving the slider to the left (negative values) adds green

to the shadow areas, and moving the slider to the right (positive values) adds magenta.
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To adjust the rendering of non-neutral colors in Camera Raw
Sometimes colors rendered by Camera Raw do not look as expected. The cause may be a difference between a

camera’s profile and Camera Raw’s built-in profile for that camera model. Alternatively, the photo may have been

taken under nonstandard lighting conditions beyond the compensating range of Camera Raw. The Calibrate tab has

Hue and Saturation sliders to adjust the settings for Camera Raw’s built-in camera profile to render non-neutral

colors differently. You can also specify whether to use the profiles built into Camera Raw or a profile built into the

file itself.

1 In the Calibrate tab, choose a profile from the Camera Profile menu:

Important: The options that appear in the Camera Profile menu depend on whether a camera raw file has a profile

embedded or whether it has been processed with a previous version of Camera Raw. Often, the Camera Profile menu

only contains the ACR 3.0 option.

ACR 3.0 Uses the built-in camera profile of Camera Raw 3.0.

Embedded Uses the profile embedded in the camera raw file.

ACR 2.4 Uses the built-in camera profile of Camera Raw 2.4. This option is available for only certain cameras. If

you’ve fine-tuned your settings for the older Camera Raw built-in profile, you can select this option to use that profile

instead.

2 Use the Hue and Saturation sliders to adjust the red, green, and blue in the image. Look at the preview image as

you make adjustments until the image looks correct. In general, adjust the hue first and then adjust its saturation.

Moving the Hue slider to the left (negative value) is like a counterclockwise move on the color wheel, and moving it

to the right (positive value) is like a clockwise move. Moving the Saturation slider to the left (negative value) desat-

urates the color, and moving it to the right (positive value) increases saturation.

Adjustments made in the Calibrate tab affect the selected image in the Camera Raw dialog box. If you want to save

the adjustments and make them the default image settings for the files from a specific camera, click the triangle next

to the Settings menu and choose Save New Camera Raw Defaults from the Camera Raw menu.

Camera Raw settings

Working with Camera Raw settings
In the Camera Raw dialog box, you can change the default image settings and save the adjusted settings as the new

camera default. You can always restore the original Camera Raw default settings for the specific camera (click the

triangle to the right of the Settings pop-up menu and choose Reset Camera Default from the Camera Raw menu).

Because Camera Raw can identify which camera was used to take an image, you can save different default image

settings for different cameras.

You can also save Camera Raw settings for a specific lighting condition and reapply them to images taken under

similar conditions. Alternatively, you can save only a subset of the Camera Raw settings. This lets you create presets

for custom white balances, specific lens settings, and so forth. In Adobe Bridge, you can also update all settings or a

subset.

When a camera raw image file is processed with Camera Raw, the image settings are stored in one of two places: the

Camera Raw database file or a sidecar XMP file. You can set a preference to determine where settings are stored.

After Effects and Bridge remember the settings for each camera raw image file. When you reopen a camera raw

image, all the settings sliders default to the values used when the file was last opened. Image attributes (target color

space profile, bit depth, pixel size, and resolution) are not stored with the settings.
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To specify where Camera Raw settings are stored
When After Effects processes a camera raw image file, it stores the image settings in one of two places: the Camera

Raw database file or a sidecar XMP file (a file that accompanies the original camera raw image file in the same folder).

You can specify where the settings are stored using the Camera Raw preferences.

Note: When you reopen a camera raw image, all the settings sliders default to the values used when the file was last

opened. Image attributes (target color space profile, bit depth, pixel size, and resolution) are not stored with the settings.

1 Click the triangle to the right of the Settings menu and choose Preferences.

2 In the Camera Raw Preferences dialog box, choose one of the following from the Save Image Settings In menu:

Camera Raw Database Stores the settings in a Camera Raw database file in the folder Document and Settings\[user

name]\Application Data\Adobe\CameraRaw (Windows) or Users/[user name]/Library/Preferences (Mac OS). This

database is indexed by file content, so the image retains camera raw settings even if the camera raw image file is

renamed or moved.

Sidecar .xmp Files Stores the settings in an XMP file in the same folder as the camera raw file. This option is useful

for long-term archiving of raw files with their associated settings, and exchanging raw files with associated settings

in multi-user workflows. These same sidecar XMP files can be used to store IPTC (International Press Telecommu-

nications Council) data or other metadata associated with a camera raw image file.

If you open camera raw files from a read-only volume like a CD or DVD, be sure to copy the files to your hard drive

first. After Effects cannot write an XMP file to a read-only volume and will default to writing the settings to the

Camera Raw database file.

Saving, applying, and updating Camera Raw settings
In the Camera Raw dialog box, you can change the default image settings and save the adjusted settings as the new

camera default. You can always restore the original Camera Raw default settings for the specific camera (click the

triangle to the right of the Settings menu and choose Reset Camera Default). Because Camera Raw can identify

which camera was used to take an image, you can save different default image settings for different cameras.

You can also save Camera Raw settings for a specific lighting condition and reapply them to images taken under

similar conditions. Alternatively, you can save only a subset of the Camera Raw settings. In this way, you can create

presets for custom white balances, specific lens settings, and so on.

To save or reset Camera Raw settings
1 In the Camera Raw dialog box, adjust the settings that you want to save.

2 Click the triangle next to the Settings menu and choose one of the following from the Camera Raw menu:

Save Settings Saves the current settings and adds them to the Settings menu if you save them in the Camera Raw

settings folder. (To locate settings saved elsewhere, use the Load Settings command in the Camera Raw menu and

browse to find the setting.)

Save New Camera Raw Defaults Saves the current settings as the new default settings for other images taken with the

same camera.

Reset Camera Default Restores the original default settings for a specific camera.

To save a subset of settings
1 Click the triangle next to the Settings menu to display the Camera Raw menu, and choose Save Settings Subset.
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2 Specify the settings to save by doing one of the following:

• Choose an option from the Subset menu.

• Select or deselect settings in the Settings list.

3 Click Save.

4 In the Save Raw Conversion Settings dialog box, name the subset and save it to the Camera Raw settings folder.

This saved subset appears at the bottom of the Settings menu.

To apply saved Camera Raw settings
1 Open a camera raw image in the Camera Raw dialog box, and click the triangle next to the Settings box.

2 From the Settings menu, choose a saved setting or one of the following:

Image Settings Uses the settings from the selected camera raw image.

Camera Raw Defaults Uses the saved default settings for a specific camera.

Previous Conversion Uses the settings from the previous image of the same camera.

Note: You can also open the Camera Raw menu, choose Load Settings, and then browse to select a saved setting.

To load Camera Raw settings
Saved settings are not listed in the Settings menu unless you save them in the Camera Raw settings folder. However,

you can use the Load Settings command to browse for and apply settings saved elsewhere.

1 In the Camera Raw dialog box, click the triangle next to the Settings menu and choose Load Settings from the

Camera Raw menu.

2 In the Load Raw Conversion Settings dialog box, browse to the settings file, select it, and click Open.

To delete Camera Raw settings
1 In the Camera Raw dialog box, choose a saved setting from the Settings menu.

2 Click the triangle next to the Settings menu to display the Camera Raw menu.

3 Choose Delete Current Settings from the menu. The setting is deleted from the Camera Raw settings folder.

To export Camera Raw settings
If you store file settings in the camera raw database, you can use the Export Settings command to copy the settings

to sidecar XMP files. This is useful for preserving the image settings with your camera raw files when you move

them.

1 Open the Camera Raw dialog box with the camera raw files whose settings you want to export.

2 Click the triangle next to the Settings menu and choose Export Settings from the Camera Raw menu.

The sidecar XMP files are created in the same folder as the camera raw image files.
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Importing Photoshop, Illustrator, PDF, and EPS files

Layered files
You can import Adobe Photoshop, Adobe Illustrator, EPS, and many PDF files directly into an After Effects project.

After Effects imports attributes that were applied in Photoshop, including position, blending modes, opacity,

visibility, transparency (alpha channel), layer masks, layer groups (imported as nested compositions), adjustment

layers, common layer styles (Drop Shadow, Inner Shadow, Outer Glow, Inner Glow, Bevel and Emboss, and Color

Fill), layer clipping paths, vector masks, image guides, and clipping groups.

You can also create a new Photoshop file and add it as the top layer in a composition from within After Effects, or

use After Effects to create a new Photoshop file without adding it to a specific composition. See “To create a new

Photoshop layer” on page 152.

When you import an Illustrator file, After Effects makes all empty areas transparent by converting them into an alpha

channel.

After Effects can import Illustrator CMYK files. However, to maintain accurate color, convert your CMYK images

to RGB images in Illustrator.

You can import a multilayered Photoshop or Illustrator file in the following ways:

• As a new composition, with each layer in the Photoshop or Illustrator file becoming a separate layer in the compo-

sition that keeps its original dimensions. This option, Composition - Cropped, makes it easier to manipulate layers

and speeds their rendering time.

• As a new composition, with each layer in the Photoshop or Illustrator file becoming a separate layer in the compo-

sition and changing dimensions to match the composition size. This option, Composition, is helpful when you

need to align layers manually.

• As a single still-footage item imported from any one layer in the Photoshop or Illustrator file.

• As a single still-footage item merged as you import multiple Photoshop or Illustrator layers.

See also

“To import an Adobe Illustrator path as a mask” on page 249

Preparing layered Photoshop files
Importing layers into After Effects makes it possible to prearrange a composition in Adobe Photoshop using layers

and preserve those layers in After Effects so that they are ready for animation. Preserving layers is also useful if you

want to use a single Photoshop file as a source for both print and dynamic media.

Before you import a layered  Photoshop file, prepare it thoroughly to reduce preview and rendering time. Avoid

problems importing and updating Photoshop layers by naming them properly. Before you import them into After

Effects, do the following:

• Organize and name layers. If you change a layer name in a Photoshop file after you have imported it into After

Effects, After Effects retains the link to the original layer. However, if you delete a layer, After Effects is unable to

find the original layer and lists it as Missing in the Project panel.

• Make sure that each layer has a unique name to avoid confusion.

If you want to import a composited version of a layered Photoshop file along with a layered version, select Always

Maximize Compatibility For Photoshop (PSD) Files in the Photoshop File Handling Preferences dialog box.
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Preparing Illustrator files
Before you save an Illustrator file for importing into After Effects, consider doing the following:

• To ensure that Illustrator files appear correctly in After Effects, select Create PDF Compatible File in the Illustrator

Options dialog box.

• To copy paths between Illustrator and After Effects, make sure that that the AICB and Preserve Paths options are

selected in the Files & Clipboard section of the Illustrator Preferences dialog box. If you don’t select AICB in

Illustrator, After Effects prompts you when you attempt to paste the path.

• To ensure that files rasterize most faithfully in After Effects, save your file in AI format instead of Illustrator 8.x or

9.x EPS format.

Importing layered files as a composition
When you import a layered file as a composition, After Effects gives you access to the individual layers, adjustment

layers, masks, guides, and other features created in Photoshop or Illustrator. When you choose this option, you must

choose to make the dimensions of each layer either match the layer’s contents or match the dimensions of the refer-

enced file. Layers that match the original layer’s own dimensions render faster and are easier to manipulate in After

Effects; layers that match the original document’s dimensions are helpful when you need to align layers manually or

to get desirable results with some third-party plug-ins.

When you import a layered Photoshop or Illustrator file as a composition, the original file name is used twice in the

Project panel: for the file as a composition and for the folder containing each Photoshop or Illustrator layer as

separate footage items.

Note: When you import a layered Adobe Photoshop file as a composition, all the layers contained in the composition

retain their original positions as set in Adobe Photoshop. You can open the composition in After Effects and animate the

layers. When you import an Adobe Photoshop file as a composition, guides in the file are imported as well. When you

import a multilayered Adobe Illustrator file as a composition, the Adobe Illustrator layer blending modes are preserved.

To import a layered file as a composition by dragging

1 Drag the file to the Project panel.

2 In the [file name] dialog box, choose Composition from the Import Kind menu.

3 Choose one of the following from the Footage Dimensions menu:

Layer Size Makes the dimensions of each layer match the layer’s content.

Document Size Makes the dimensions of each layer match the original document’s size.

To import a layered file as a composition by using commands

1 Choose File > Import > File or Multiple Files.

2 In the Import File or Import Multiple Files dialog box, select the file. (If the file doesn’t appear, select the option

for showing all files from the Files of Type (Windows) or the Enable (Mac OS) menu.)

3 Choose one of the following from the Import As menu, and then click Open:

Composition - Cropped Layers Makes the dimensions of each layer match the layer’s content.

Composition Makes the dimensions of each layer match the original document’s size.
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Importing layered files as single footage items
When you import a layered Photoshop or Illustrator file as a single footage item, you choose to either merge the layers

or import only a single specified layer. Choosing to merge the layers makes After Effects treat the layers as a single

merged layer, without flattening the layers in the original file referenced by the project. Choose this option if you

don’t need to animate, reposition, or edit the individual Illustrator or Photoshop layers in After Effects. If you subse-

quently change your mind, the Convert To Layered File command lets you instantly convert the merged footage to

a layered composition.

Note: If the Default Drag Import As option in the Import preferences is set to Composition, the layered file is automati-

cally imported as a composition with the dimensions of each layer matching each layer’s content; you aren’t prompted to

set any options. Set this option to Footage to always be prompted.

To import layers as a single footage item by dragging

1 Drag the file to the Project panel.

2 In the [file name] dialog box, choose Footage from the Import Kind menu.

3 Do one of the following:

• Select Choose Layer to add only one layer from the file. Choose the layer’s name from the adjacent menu. From

the Footage Dimensions menu, choose Layer Size to make the dimensions of the layer match the layer’s content

or Document Size to make the dimensions of the layer match the original document’s size.

• Select Merged Layers to merge all the layers into a single After Effects layer. (The layers in the referenced file don’t

merge.)

To import layers as a single footage item by using commands

1 In After Effects, choose File > Import > File or Multiple Files.

2 In the Import File or Import Multiple Files dialog box, select the file (If the file doesn’t appear, select the option

for showing all files from the Files of Type (Windows) or the Enable menu (Mac OS).).

3 Choose Footage from the Import As menu and click Open.

4 In the [file name] dialog box, do one of the following:

• Select Choose Layer to add only one layer from the file. Then choose the layer’s name from the adjacent menu.

From the Footage Dimensions menu, choose Layer Size to make the dimensions of the layer match the layer’s

content or Document Size to make the dimensions of the layer match the original document’s size.

• Select Merged Layers to merge all the layers into a single After Effects layer.

Note: You can convert a merged layered file to a composition at any time. See “To convert a merged layered file to a

composition” on page 161.

Transparency in Photoshop files
Adobe Photoshop supports a transparent area and one optional layer mask (alpha channel) for each layer in a file.

You can use these layer masks to specify how different areas within a layer are hidden or revealed. If you import one

layer, After Effects combines the layer mask (if present) with the transparent area and imports the layer mask as a

straight alpha channel.

If you import a layered Photoshop file as a merged file, After Effects merges the transparent areas and layer masks of

all the layers into one alpha channel that is premultiplied with white.
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If the layered Photoshop file contains clipping groups, After Effects imports each clipping group as a composition

nested within the main composition. After Effects automatically applies its Preserve Underlying Transparency

option to each layer in the clipping-group composition, maintaining transparency settings.

When you import a Photoshop file as a composition, any vector masks convert to After Effects masks. You can then

modify and animate these masks within After Effects.

After Effects also supports any blending modes applied to the file.

For more details about how After Effects works with transparency in Photoshop files, visit the support area of the

Adobe website.

See also

“Preparing layered Photoshop files” on page 89

“To preserve underlying transparency during compositing” on page 280

“About transparency” on page 242

“About alpha channels and mattes” on page 242

To use adjustment layers from Photoshop
Adjustment layers in Adobe Photoshop change the color and tonal qualities of an image without permanently

modifying the original image. Adobe Photoshop adjustment layers affect the appearance of all layers below them.

When you import an Adobe Photoshop file containing one or more adjustment layers as a composition, After Effects

directly converts the Adobe Photoshop adjustment layers to After Effects adjustment layers.

• To remove the effect and display the layer as a white solid, turn off the Adjustment Layer switch in After Effects.

• To remove the effect and the white solid, either delete the adjustment layer or turn off the Video switch for the

layer.

See also

“Audio/Video and Layer switches” on page 167

To continuously rasterize an Illustrator file
When you import a vector file, After Effects automatically rasterizes it. However, if you want to scale a vector file

above 100%, you need to continuously rasterize it to maintain image quality. You can continuously rasterize an

Illustrator file (or any other vector file) at any time while designing your project. Continuously rasterizing causes

After Effects to rasterize the file as needed based on the transformation for each frame. A continuously rasterized

file generally produces higher quality results, but it may preview and render slower than a rasterized image.

When you apply an effect to a continuously rasterized layer, the results may be different than when you apply the

effect to a nonrasterized layer. This is because the default rendering order for the layer changes. The default rendering

order for a nonrasterized layer is masks, effects, and then geometrics (transformations), whereas the default

rendering order for a continuously rasterized layer is masks, geometrics (transformations), and then effects. You can

change the default rendering order; see “Changing the rendering order” on page 594.

For example, if an Illustrator file pictures a dog and if you want to animate the scale of the dog and apply the Bulge

effect to the dog's nose, turn off continuous rasterization so that the bulge stays on the dog's nose as the picture scales

larger and smaller. Make sure to check the results of the effect before continuing to work on your project.
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Whether or not you continuously rasterize, if you view and render a composition using Best Quality, After Effects

anti-aliases (smooths) the art. For general information about rasterizing, see Illustrator Help.

Note:You cannot paint interactively on a continuously rasterized layer. However, you can apply a paint effect by copying

and pasting or using the Favorites menu.

 Illustrator file imported and rasterized in After Effects
A. Original B. Enlarged with Continuously Rasterize switch turned off C. Enlarged with Continuously Rasterize switch turned on

1 Select the layer containing the Illustrator file in the Timeline panel.

2 Click the Collapse Transformations/Continuously Rasterize switch so that the On icon  appears for that layer.

Note: When you turn on Collapse Transformations/Continuously Rasterize, the Layer panel closes. You can open it if

you turn the switch off.

See also

“Improving performance by simplifying your project” on page 639

Importing After Effects and Adobe Premiere Pro
projects

To import an After Effects project
You can import one After Effects project into another. Everything from the imported project, including footage files,

compositions, and folders, appears inside a new folder in the current Project panel. When you want to repeat a

complicated mask, effect, or animation in a different project, you can import the project containing the effect and

simply replace the source footage, keeping all the effect, composition, and layer settings intact.

You can import an After Effects project from a different operating system as long as you maintain the file names,

folder names, and either full or relative paths (folder locations) for all files in the project. To maintain relative paths,

the source footage must reside on the same volume as the project file. Use the Collect Files command to gather copies

of all files in a project or composition into a single location.

If a file format is not supported by the operating system you are using, if the file is missing, or if the reference link is

broken, After Effects substitutes a placeholder item containing color bars. You can reconnect the placeholder to the

appropriate file. You can use the same process to connect a footage item in the Project panel to a different source file.

1 Choose File > Import > File.

2 Select the After Effects project you want to import, and click Open.

A B C
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3 (Optional) To relink a reference, select the placeholder or footage file in the Project panel, and choose File >

Replace Footage > File. In the Replace Footage File dialog box, select the footage file you want to use. (You can also

open this dialog box by double-clicking the placeholder.) In most cases, you need to relink only one footage file. After

Effects locates other missing items if they’re in the same location.

See also

“Collecting files in one location” on page 598

Working with After Effects and Adobe Premiere Pro
Adobe Premiere Pro is designed to capture, import, and edit film and video. After Effects is designed to produce

motion graphics and visual effects for film, broadcast, DVD, and the web. You can easily exchange projects, compo-

sitions, tracks, and layers between After Effects and Adobe Premiere Pro. You can import an Adobe Premiere Pro

project into After Effects, or export an After Effects project as an Adobe Premiere Pro project. You can also import

Adobe Premiere 6.0 and 6.5 projects into After Effects.

You can copy and paste layers and tracks between After Effects and Adobe Premiere Pro. If you have Adobe

Production Studio, you can use Adobe Dynamic Link to export After Effects compositions into Adobe Premiere Pro

or Adobe Encore DVD without first rendering them, or you can start Adobe Premiere Pro from within After Effects

and capture footage for use in After Effects.

See also

“Copying between After Effects and Adobe Premiere Pro (Windows only)” on page 126

“About Adobe Dynamic Link (Adobe Production Studio only)” on page 632

“To export an After Effects project to Adobe Premiere Pro (Windows only)” on page 631

To import an Adobe Premiere Pro project
The ability to import Adobe Premiere Pro projects into After Effects for Windows eliminates the need to render the

project before applying visual effects and animations in After Effects. When you import an Adobe Premiere Pro

project, After Effects imports it into the Project panel as both a new composition containing each Adobe Premiere

Pro clip as a layer, and as a folder containing each clip as an individual footage item. If your Adobe Premiere Pro

project contains bins, After Effects converts them to folders within the Adobe Premiere Pro project folder. After

Effects converts nested sequences to nested compositions. You can also import Adobe Premiere projects into After

Effects.

After Effects preserves the order of clips in the Timeline, the footage duration (including all trimmed In and Out

points), and marker and transition locations. After Effects bases the arrangement of layers in the Timeline panel on

the arrangement of clips in the Adobe Premiere Pro Timeline. After Effects adds Adobe Premiere Pro clips to the

Timeline panel as layers in the order they appeared—from the bottom up and from left to right—in the Adobe

Premiere Pro Timeline. After Effects preserves changes made to the speed of a clip, for example, with the Clip >

Speed command, and these changes appear as a value in the Stretch column in the After Effects Timeline panel.

After Effects imports effects common to both Adobe Premiere Pro and After Effects, and preserves keyframes for

these effects. If you’re working in Adobe Premiere Pro, an After Effects icon in the Effects panel denotes common

effects used by both applications.
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Transitions and titles (except for dissolves) included in your Adobe Premiere Pro project appear in the After Effects

composition as solid layers with their original location and duration.

1 Choose File > Import > File.

2 Select an Adobe Premiere Pro or Adobe Premiere project, and click OK.

3 Do any of the following:

• To import only one sequence, choose a sequence from the menu.

• To import audio, select Import Audio.

To add a single item from a track in an Adobe Premiere Pro project, copy the item in Adobe Premiere Pro, and choose

Edit > Paste in the Timeline panel of After Effects.

See also

“Copying between After Effects and Adobe Premiere Pro (Windows only)” on page 126

To use Adobe Premiere Pro for capture (Adobe Production Studio only)
If you use Adobe Production Studio, you can start Adobe Premiere Pro from inside After Effects and use it to capture

footage for use in your After Effects project.

❖ Choose File > Import > Capture in Adobe Premiere Pro.

Preparing and importing video and film

About high-definition (HD) video
High-definition video refers to any video format with higher resolution than standard-definition (SD) video formats,

such as NTSC and PAL. There are many competing HD video formats, but the most common have a resolution of

1280 x 720 or 1920 x 1080, with a widescreen aspect ratio of 16:9.

HD video formats include interlaced and noninterlaced varieties. Typically, the highest-resolution formats are inter-

laced at the higher frame rates, because noninterlaced video at this resolution would require a prohibitively high data

rate.

HD video formats are designated by their vertical resolution, scan mode, and frame or field rate (depending on the

scan mode). For example, 1080i60 denotes interlaced scanning of 60 interlaced 1920 x 1080 fields per second,

whereas 720p30 denotes progressive scanning of 30 noninterlaced 1280 x 720 frames per second. In both cases, the

frame rate is approximately 30 frames per second.

Each program in Adobe Production Studio (Adobe Premiere Pro, Adobe After Effects, Adobe Audition, and Adobe

Encore DVD) includes preset settings that are designed for working with various HD formats. Some of the most

common HD video formats you may encounter include the following:

DVCPRO HD Panasonic’s high-definition variant of its DVCPRO format, which also includes DVCPRO25 and

DVCPRO50. Whereas DVCPRO25 and DVCPRO50 support data rates of 25Mbit/s and 50Mbit/s, respectively,

DVCPRO HD supports a data rate of 100Mbit/s, from which it gets its other name, DVCPRO100.

HDCAM Sony’s high-definition version of their Digital Betacam format. A variant called HDCAM SR uses a tape

with a higher particle density to record video with greater color sampling and at higher bit rates. However, HDCAM

SR is supported by decks only, and not camcorders.
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HDV Developed jointly by several companies, HDV employs a form of MPEG-2 compression to enable high-

definition video to be encoded on standard miniDV cassette media.

H.264 Also known as MPEG-4 part 10 and AVC (Advanced Video Coding), H.264 can deliver video over a range of

bitrates more efficiently than previous standards. For example, H.264 can deliver the same quality as MPEG-2 at half

the data rate. H.264 is built into the Apple QuickTime 7 multimedia architecture, and will be supported by both of

the rival next-generation DVD formats, HD-DVD and Blu-ray Disc.

Uncompressed HD Refers to high-definition video in an uncompressed format. Without compression to reduce the

video’s data rate, uncompressed video requires relatively fast computer processors, hard disks, and a specialized

capture device.

WM9 HDTV Microsoft’s high-definition delivery format is among numerous formats included in the Windows

Media 9 (WM9) framework. By employing an aggressive compression scheme, WM9 HDTV permits high-

definition video encoding and playback at relatively low data rates.

To change the frame rate of video and film footage
When you import video or film into After Effects, the file’s frame rate does not change. If you output footage to a

different frame rate, After Effects compensates for the difference. The difference between the frame rates determines

how smoothly the layer plays.

Ideally, use source footage that matches the final output frame rate. This way, After Effects renders each frame, and

the final output does not omit or duplicate frames. If, however, the source footage has a frame rate slightly different

from what you want to output to (for example, 30-fps footage and 29.97-fps final output), you can make the footage

frame rate match the composition frame rate by conforming it.

Conforming the frame rate does not alter the original footage, only the reference that After Effects uses. When

conforming, After Effects changes the internal duration of frames but not the frame content. Afterward, the footage

plays back at a different speed. For example, if you conform the frame rate from 15 fps to 30 fps, the footage plays

back twice as fast. In most cases, conform the frame rate only when the difference between the footage frame rate

and the output frame rate is small.

1 Select the footage file in the Project panel.

2 Choose File > Interpret Footage > Main.

3 Select Conform To Frame Rate, type a new frame rate for Frames Per Second, and then click OK.

Note:Conforming can change the synchronization of visual footage that has an audio track, because changing the frame

rate changes the duration of the video but leaves the audio unchanged. If you want to stretch both audio and video, use

the Time Stretch command. (See “Time-stretching” on page 231.) Keyframes applied to the source footage remain at their

original locations (which retains their synchronization within the composition but not the visual content of the layer).

Be sure to check your files and make any necessary adjustments.

About pixel aspect ratio
Pixel aspect ratio is the ratio of width to height of one pixel in an image. Frame aspect ratio is the ratio of width to

height of the frame dimensions of an image. For example, D1 NTSC has a pixel aspect ratio of 0.9 (or 0.9 width by

1.0 height). It also has a frame aspect ratio of 4:3 (or 4.0 width by 3.0 height).
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A 4:3 frame aspect ratio (left), and a wider 16:9 frame aspect ratio (right)

Some video formats output the same frame aspect ratio but use a different pixel aspect ratio. For example, some

NTSC digitizers produce a 4:3 frame aspect ratio, with square pixels (1.0 pixel aspect ratio), and a resolution of 640

x 480. D1 NTSC produces the same 4:3 frame aspect ratio but uses nonsquare pixels (0.9 pixel aspect ratio) and a

resolution of 720 x 486. D1 pixels, which are always nonsquare, are vertically oriented in systems producing NTSC

video and horizontally oriented in systems producing PAL video.

If you display nonsquare pixels on a square-pixel monitor without alteration, images and motion appear distorted;

for example, circles distort into ovals. However, when displayed on a broadcast monitor, the images are correct.

To view nonsquare pixels on a square pixel monitor, choose View Options from the Composition panel options menu

and then select Pixel Aspect Ratio Correction. Because it slows performance, this is recommended for viewing only.

Square and nonsquare pixels
A. Square pixels and 4:3 frame aspect ratio B. Nonsquare pixels and 4:3 frame aspect ratio C. Nonsquare pixels displayed on a square-pixel
monitor

When you import D1 NTSC or DV source footage into After Effects, the image looks slightly wider than it does on

a D1 or DV system. (D1 PAL footage looks slightly narrower.) The opposite effect occurs when you import

anamorphic footage using D1/DV NTSC Widescreen or D1/DV PAL Widescreen. Widescreen video formats have a

frame aspect ratio of 16:9.

If a file uses nonsquare pixels, After Effects displays the pixel aspect ratio next to the file’s image thumbnail in the

Project panel. You can change the pixel aspect ratio interpretation for individual files in the Interpret Footage dialog

box. By ensuring that all footage files are interpreted correctly, you can combine footage with different ratios in the

same project or composition and generate output that plays correctly.

When you import footage with either the D1 resolution of 720 x 486, or the DV resolution of 720 x 480, After Effects

automatically sets the pixel aspect ratio for that file to D1/DV NTSC. When you import footage with the D1 or DV

resolution of 720 x 576, After Effects automatically sets the pixel aspect ratio for that file to D1/DV PAL. However,

it is always a good idea to make sure that all files are interpreted correctly by looking in the Project panel or the

Interpret Footage dialog box. For information about using interpretation rules to automate the import process, see

“To specify interpretation rules” on page 71.

Note: Make sure to reset the pixel aspect ratio to Square Pixels when you import a square-pixel file that happens to have

a D1 or DV resolution—for example, a non-DV image that happens to have a resolution of 720 x 480.

3

4 16

9

A B C
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It is important to set the pixel aspect ratio for a footage file to its original ratio, not the ratio of the final output.

After Effects reads and writes pixel aspect ratios directly from QuickTime movies. For example, if you import a

movie captured as widescreen (16:9 DV), After Effects automatically tags it correctly.

See also

“Setting pixel aspect ratio for compositions” on page 113

Common pixel aspect ratios for assets

To set the pixel aspect ratio for imported footage
1 Select the footage in the Project panel.

2 Choose File > Interpret Footage > Main.

3 Choose a ratio from the Pixel Aspect Ratio menu and click OK.

If you are planning to render to the same pixel aspect ratio as your footage, you also need to set the pixel aspect ratio

for the composition.

About interlaced and noninterlaced video
Video can be either interlaced or noninterlaced.

Asset Pixel aspect ratio When to use

Square pixels 1.0 Your footage has a 640 x 480 or 648 x 486 frame size, is
1920 x 1080 HD (not HDV or DVCPRO HD), is 1280 x 720
HD or HDV, or was exported from an application that
doesn’t support nonsquare pixels. This setting can also
be appropriate for footage that was transferred from film
or for customized projects.

D1/DV NTSC 0.9 Your footage has a 720 x 486 or 720 x 480 frame size, and
your desired result is a 4:3 frame aspect ratio.This setting
can also be appropriate for footage that was exported
from an application that works with nonsquare pixels,
such as a 3D animation application.

D1/DV NTSC Wide-
screen

1.2 Your footage has a 720 x 486 or 720 x 480 frame size, and
your desired result is a 16:9 frame aspect ratio.

D1/DV PAL 1.0666 Your footage has a 720 x 576 frame size, and your desired
result is a 4:3 frame aspect ratio.

D1/DV PAL Widescreen 1.422 Your footage has a 720 x 576 frame size, and your desired
result is a 16:9 frame aspect ratio.

Anamorphic 2:1 2.0 Your footage was shot using an anamorphic film lens, or
was anamorphically transferred from a film frame with a
2:1 aspect ratio.

HDV 1080/DVCPRO HD
720 (After Effects), HD
Anamorphic 1080
(Adobe Premiere Pro)

1.33 Your footage has a 1440 x 1080 or 960 x 720 frame size
and your desired result is a 16:9 frame aspect ratio.

DVCPRO HD 1080 (After
Effects only)

1.5 Your footage has a 1280 x 1080 frame size and your
desired result is a 16:9 frame aspect ratio.
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Each interlaced video frame consists of two fields. Each field contains half the number of horizontal lines in the

frame; the upper field (or Field 1) contains all of the odd-numbered lines, and the lower field (or Field 2) contains all

of the even-numbered lines. An interlaced video monitor displays each frame by first drawing all of the lines in one

field and then drawing all of the lines in the other field. Field order specifies which field is drawn first. In NTSC video,

new fields are drawn to the screen approximately 60 times per second, which corresponds to a frame rate of approx-

imately 30 frames per second.

Interlaced scanning of interlaced video fields compared with progressive scanning of a noninterlaced video frame.
A. For interlaced video, first, the entire upper field is drawn to the screen, from top to bottom, in one pass. B. Next, the entire lower field is
drawn to the screen, from top to bottom, in one pass. C. For noninterlaced video, the entire frame is drawn to the screen, from top to bottom,
in one pass.

Most broadcast video is interlaced, though emerging high-definition television standards have interlaced and nonin-

terlaced variants.

Noninterlaced video frames are not separated into fields. A progressive-scan monitor will display a noninterlaced

video frame by drawing all of the horizontal lines, from top to bottom, in one pass. Computer monitors are almost

all progressive-scan monitors, and most video displayed on computer monitors is noninterlaced.

The terms progressive and noninterlaced are thus closely related and are often used interchangeably, but progressive

refers to the recording or drawing of the scan lines by a camera or monitor, whereas noninterlaced refers to the fact

that the video data itself is not separated into fields. For example, it is possible with some modern cameras to use

progressive scanning to record two simultaneous fields per frame of interlaced video.

About field separation and pulldown
If you want to use interlaced or field-rendered footage (such as from NTSC video) in an After Effects project, you

will get the best results if you separate the video fields when you import the footage. After Effects separates video

fields by creating a full frame from each field, preserving all of the image data from the original footage.

When importing interlaced video that was originally transferred from film, you can remove the 3:2 pulldown that

was applied during the transfer from film to video as you separate fields so that effects you apply in After Effects don’t

appear distorted.

A 

B 

C 
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See also

“To remove 3:2 or 24Pa pulldown from video” on page 102

“To test field-rendering order” on page 597

To separate video fields in imported footage
Separating fields is critical if you plan to make significant changes to the footage. When you scale, rotate, or apply

effects to interlaced video, unwanted artifacts, such as crossed fields, are often introduced. By separating fields, After

Effects accurately converts the two interlaced frames in the video to noninterlaced frames, while preserving the

maximum amount of image quality. Using noninterlaced frames allows After Effects to apply edits and effects consis-

tently and at the highest quality.

After Effects creates field-separated footage from a single formerly interlaced field by splitting fields into two

independent frames. Each new frame has only half the information of the original frame, so some frames may appear

to have a lower resolution than others when viewed at Draft quality. When you render the final composition, After

Effects reproduces high-quality interlaced frames for videotape. When you render a movie at Best quality, After

Effects interpolates between the scan lines of a field to produce maximum image quality.

When you render a composition containing separated footage, set the Field Rendering option to the same field order

as your video equipment. If you don’t field-render the composition, or if you field-render with the incorrect settings,

the final movie may appear too soft, jerky, or distorted.

Note:After Effects automatically separates fields for D1 and DV video footage files. You can manually separate fields for

all other types of video footage in the Interpret Footage dialog box. (See “Interpretation methods” on page 73.)

1 Select the footage item in the Project panel.

2 Choose File > Interpret Footage > Main.

3 Choose an option from the Separate Fields menu.

4 Click Preserve Edges (Best Quality Only) to increase image quality in nonmoving areas when the image is

rendered at Best quality. Then click OK.

Note: If the field settings in the Interpret Footage dialog box are correct for the input footage and the field settings in the

Render Settings dialog box are correct for the output device, you can mix footage items of different field orders in a

composition. If either of these settings is incorrect, however, the frames will be in the correct order, but the field order

may be reversed, resulting in jerky, unacceptable images.

To determine the original field order
Interlaced video has a field order defining the order in which the two video fields (upper and lower) are displayed. A

system that draws the upper lines before the lower lines is called upper-field first; one that draws the lower lines before

the upper lines is called lower-field first. The order in which the fields are displayed is important, especially when the

fields contain motion. If you separate video fields using the wrong field order, motion will not appear smooth.

Note: Upper-field first corresponds to Even Field First in an ElectricImage file.

Some programs, including After Effects, label the field order when rendering interlaced video files. When you

import a labeled video file, After Effects honors the field order label automatically. You can override the field order

using the interpretation rules file. For more information about field order, see “About field separation and pulldown”

on page 99.
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If a file does not contain a field order label, you can match the original field order of your footage. If you are not sure

which field order was used to interlace a footage item, use the procedure below to find out.

1 Select the item in the Project panel.

2 Choose File > Interpret Footage > Main.

3 In the Interpret Footage dialog box, select Upper Field First from the Separate Fields menu, and then click OK.

4 In the Project panel, press Alt (Windows) or Option (Mac OS) as you double-click the footage to open it in a

Footage panel.

5 If the Time Controls panel is not visible, choose Window > Time Controls.

6 In the Footage panel, find a segment that contains one or more moving areas.

7 Using the Frame Advance button  in Time Controls, step forward at least five frames in the Footage panel.

Moving areas should move consistently in one direction. If the moving areas move backward every other frame, the

wrong field-separation option has been applied to the footage.

Note: Analog capture cards can vary. DV or footage captures from IEEE 1394 (FireWire/i.Link) are always lower-field

first.

About 3:2 and 24Pa pulldown
When you transfer 24-fps film to 29.97-fps video, you use a process called 3:2 pulldown, in which the film frames are

distributed across video fields in a repeating 3:2 pattern. The first frame of film is copied to fields 1 and 2 of the first

frame of video, and also to field 1 of the second video frame. The second frame of film is then spread across the next

two fields of video—field 2 of the second video frame and field 1 of the third frame of video. This 3:2 pattern is

repeated until four frames of film are spread over five frames of video, and then the pattern is repeated.

The 3:2 pulldown process results in whole frames (represented by a W) and split-field frames (represented by an S).

The three whole video frames contain two fields from the same film frame. The remaining two split-field frames

contain a video frame from two different film frames. The two split-field frames are always adjacent to each other.

The phase of 3:2 pulldown refers to the point at which the two split-field frames fall within the first five frames of the

footage.

Phase occurs as a result of two conversions that happen during 3:2 pulldown: 24-fps film is redistributed through

30-fps video, so each of four frames of 24-fps film is spread out over five frames of 30(29.97)-fps video. First, the film

is slowed down 0.1% to match the speed difference between 29.97 fps and 30 fps. Next, each film frame is repeated

in a special pattern and mated to fields of video.

When you apply 3:2 pulldown to footage, one frame of the film (A) is separated into two or three interlaced video fields (B) which are grouped
into video frames containing two fields each.

23 23

A

B

W S S W W
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It’s important to remove 3:2 pulldown from video footage that was originally film so that effects you add in After

Effects synchronize perfectly with the original frame rate of film. Removing 3:2 pulldown reduces the frame rate by

1/5: from 30 to 24 fps or from 29.97 to 23.976 fps, which also reduces the number of frames you have to change. To

remove 3:2 pulldown, you must also indicate the phase of the 3:2 pulldown.

After Effects also supports Panasonic DVX100 24p DV camera pulldown, called 24P Advance (24Pa). This format is

used by some cameras to capture 23.976 progressive-scan imagery using standard DV tapes.

To remove 3:2 or 24Pa pulldown from video
Before you remove 3:2 pulldown, separate the fields as either upper-field first or lower-field first. Once the fields are

separated, After Effects can analyze the footage and determine the correct 3:2 pulldown phase and field order. If you

already know the phase and field order, choose them from the Separate Fields and the Remove Pulldown menus in

the Interpret Footage dialog box.

1 In the Project panel, select the footage from which you want to remove 3:2 pulldown.

2 Choose File > Interpret Footage > Main.

3 In the Fields and Pulldown section, select Upper Field First or Lower Field First from the Separate Fields menu.

4 Do one of the following and click OK:

• If you know the phase of the 3:2 or 24Pa pulldown, choose it from the Remove Pulldown menu.

• To have After Effects determine the correct settings, click Guess 3:2 Pulldown or Guess 24Pa Pulldown.

Note: If your footage file contains frames from different sources, the phase may not be consistent. If this is the case, import

the footage once for each phase. Then, add the footage to your composition as many times as there are phases and trim

each layer to use only the appropriate frames for each phase.

Importing DDR-based footage
To find out if After Effects plug-ins are available for your digital disk recorder (DDR), contact your DDR manufac-

turer.

You can bring DDR-based footage into an After Effects project in two ways. First, you can work with the footage

while it remains on the DDR, essentially treating the DDR as a remote hard disk. You can also transfer the footage

to your hard disk and import it into an After Effects project as you would any other file.

For information on using your specific DDR with After Effects, refer to your DDR manufacturer’s plug-in documen-

tation.

When working with DDR-based footage in After Effects, make sure that your Composition Settings, Render

Settings, and the Interpret Footage dialog boxes for the footage files are all set to the frame rate used by your DDR.

If the frame rate in the Interpret Footage dialog box is 29.97 fps and the Composition Settings frame rate is 30 fps,

the footage will appear with duplicate frames.

Make sure that the field settings in the Interpret Footage and Render Settings dialog boxes are the same; otherwise,

the footage will preview and render with the wrong field order, causing the footage to play back with a jerky

appearance.

To convert footage
There are many different formats for viewing video in the world today. NTSC, for example, is the main broadcast

standard in North and South America and parts of Asia, while PAL is the standard in Great Britain and much of

Europe and Africa. There are also numerous emerging standards for high-definition (HD) video.
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You can use After Effects to convert one type of footage to another. When converting footage, keep the following in

mind:

• Changes in resolution may result in a loss of picture clarity, especially when up-converting from a standard-

definition format to an HD format.

• Changes in frame rate may require the use of frame blending to smooth out the interpolated frames. For longer

footage items, this can result in very long render times.

1 Import the footage you’re converting into a composition using the preset of the format you’re converting to.

Example: if you’re converting NTSC to PAL, import your NTSC footage into a composition with the appropriate PAL

preset.

2 Select the layer with the footage to be converted and choose Layer > Transform > Fit To Comp Width (or Fit To

Comp Height).

Note: For converting between two formats with the same frame aspect ratio, either of these two Fit commands will do

the same thing; if the frame aspect ratios differ (e.g., going from 4:3 to 16:9), fitting to width or height will choose between

cropping or letterboxing the resulting image.

3 Do one of the following:

• If there are no scene cuts in your footage, choose Layer > Frame Blending > Pixel Motion. This will provide the

best results, but may require long rendering times.

• If there are scene cuts in your footage, or if you want to sacrifice quality for shorter rendering times, choose

Layer > Frame Blending > Frame Mix.

4 Select Composition > Make Movie.

5 In the Render Queue panel, next to Render Settings, select the appropriate preset from the menu. For example, if

you’re converting to DV footage, select DV Settings from the menu.

6 In the Render Queue panel, next to Output Module, select the appropriate preset from the menu, or select Custom

to enter custom settings. For example, if you’re converting to DV PAL, select the D1/DV-PAL preset with the audio

sampling rate that you require.

7 Click the name of the preset you chose in step 6 to select additional Format Options.

8 Click the Render button to render your movie.

To convert DV footage from PAL to NTSC using pulldown

Because After Effects can easily convert film (24 fps) to video (29.97 fps) using 3:2 pulldown, you can perform a clean

PAL-to-NTSC transfer by setting up 25-fps PAL video to act like 24-fps film. This lets you apply 3:2 pulldown to the

footage when converting to 29.97 fps. This technique works particularly well for progressive (noninterlaced) PAL

video.

1 Create a new composition with the DV NTSC or DV NTSC Widescreen preset.

2 Import your DV PAL footage into the new composition.

3 Select the layer with the DV PAL footage, and choose Layer > Transform > Fit To Comp Width (or Fit To Comp

Height).

4 Do one of the following:

• To preserve audio synchronization but slightly lower the pitch, choose Layer > Time > Time Stretch, and then

enter 95.904 in the Stretch Factor box.
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• To preserve audio pitch but not synchronization, or for clips without audio, right-click (Windows) or Control-

click (Mac OS) the footage in the Project panel, select Interpret Footage > Main, select Conform To Frame Rate,

and then enter 23.976 into the Conform To Frame Rate box.

5 Select Composition > Make Movie.

6 Choose Custom from the Render Settings menu.

7 In the Render Settings pane, enable Field Rendering (choose the field order required by your output type), select

any option from the 3:2 Pulldown menu, and then click OK.

8 Choose the output type from the Render Queue Output Module menu (for example, Microsoft DV NTSC 32kHz).

9 Click the Render button to render your movie.

Importing Cineon files

About Cineon files
You can import Cineon 4.5 or Digital Picture Exchange (DPX) files directly into an After Effects project as individual

frames or as a sequence of numbered stills. Once you have imported a Cineon file, you can use it in a composition

and then render the composition as a Cineon sequence. (See “About still-image sequences” on page 75.)

Cineon files are commonly used to transfer motion-picture film to a digital format. To preserve the full dynamic

range of motion-picture film, Cineon files are stored using logarithmic 10-bpc color. However, After Effects inter-

nally uses 8-bpc color (or 16-bpc or 32-bpc color for the After Effects Professional Edition only). Work with Cineon

files in a 16- or 32-bpc project (Pro only)—by default, After Effects stretches the logarithmic values to the full range

of values available. You can then use the Cineon Settings dialog box to control the conversion. If you are working

with a film sequence in which exposure conditions vary over time, you can vary the conversion over time by setting

keyframes or using expressions.

See also

“About color depth” on page 61

“Color management” on page 64

“Cineon Converter effect” on page 550

To import a Cineon sequence
1 Choose File > Import > File.

2 For the file type, select Cineon, and then select Cineon Sequence.

3 Locate and select the first numbered Cineon sequence file.

4 Select the Cineon Sequence option, and then click Open.

The Cineon file or sequence appears in the Project panel.
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To set options for Cineon files
When you import Cineon or DPX files into an After Effects project, you can set Interpret Footage options that

specify how After Effects converts the Cineon code values into color values.

1 Select the Cineon or DPX file in the Project panel, and choose File > Interpret Footage > Main.

2 Click More Options.

3 To apply an ICC profile that represents scene lighting, choose Kodak 5218 ICC Profile from the Conversion

Method menu.

4 In the Manual section of the Cineon Settings dialog box, choose a preset from the Preset menu. If desired,

manually adjust the options set by your choice:

Converted Black Point Specifies the black point used for the layer in After Effects.

Converted White Point Specifies the white point used for the layer in After Effects.

10 Bit Black Point Specifies the black level (minimum density) for converting a 10-bit Cineon layer.

10 Bit White Point Specifies the white level (maximum density) for converting a 10-bit Cineon layer.

Current Gamma Specifies the target gamma value.

Highlight Rolloff Specifies the rolloff value used to correct bright highlights. To get over range values when working

in 32 bpc, set the value to 0.

Logarithmic Conversion Converts the Cineon sequence from log color space to the target gamma specified by the

Current Gamma setting. When you’re ready to produce output from the Cineon file, it is important that you reverse

the conversion. (To convert from logarithmic to linear, set Current Gamma to 1.)

Units Specifies the units After Effects uses to display dialog values.

Importing OMF and AAF files

Importing OMF files
After Effects can read and write native OMF video media essence, as used in Avid OMF essence files. You can import

OMF files as you would other footage types. When you import an AAF file that references an OMF file, the OMF

footage is also imported.

Note: You can also output to OMF. (See “To render a composition to OMF (Pro only)” on page 618.)

The following OMF codecs are supported for importing and outputting to OMF: Uncompressed, Avid AVR, Avid

JPEG, JFIF, and DV.

The OMF file format supports video only. Avid editing systems store audio files as separate .wav files, which you can

import into After Effects if desired. Depending on the resolution and codec, each frame may be composed of a full

noninterlaced frame, two interlaced fields, or a single line-doubled field (for single-field media). The codec used to

encode the media is displayed in the footage information area in the Project panel.

Importing AAF files
AAF (Advanced Authoring Format) is a multimedia file format that allows you to exchange digital media and

metadata between platforms, systems, and applications. Authoring applications that support AAF, such as Avid

editing systems, read and write the data in AAF files to the extent that they support the format.
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Issues specific to importing AAF files
To ensure that the project that you want to import conforms to general AAF specifications and is compatible with

After Effects, consider the following:

Character limits for names The folder name (based on the AAF file name) created in the Project panel is truncated

to 31 characters, the maximum limit in After Effects. Names for footage and composition items in the Project panel

and for layers in the Timeline panel are also truncated to 31 characters.

Platform-specific footage references Footage references are saved with platform-specific paths and file names in the

AAF file. Therefore, if you export an AAF file from Windows, for example, and try to import it into After Effects in

Mac OS, the footage references are unresolved and appear as placeholder footage. You must use the Replace Footage

command on the placeholders to relink the footage.

Separate video and audio tracks An AAF file can have separate clips for audio and video. When the AAF file is

imported into After Effects, each clip is converted into a layer. For an audio clip, only the audio switch is enabled for

the layer. For a video clip, only the video switch is enabled for the layer.

Clips on the same track Clips that appear on the same track in Avid appear as separate layers in After Effects.

Depth order of video and audio tracks During AAF import, video tracks are processed before audio tracks, so

converted audio layers will appear above video layers in the After Effects Timeline panel.

Different image dimensions and pixel aspect ratios When an Avid editing system imports footage, it is scaled to the

dimensions of the project regardless of the original dimensions of the footage. When the AAF file is imported into

After Effects, footage appears with its original dimensions and pixel aspect, which may be different from the dimen-

sions of the project. You can use the Interpret Footage command in After Effects to make pixel aspect adjustments.

Missing media Referenced media that is not accessible during the import operation appears as placeholder footage

in After Effects.

Empty sequences If a sequence contains no tracks, the composition created when it is imported is set at DV

resolution (720 x 480; 0.9 pixel aspect ratio) with a length of 10 seconds.

Cuts-only video and audio clips Supported.

Audio Audio gain (level) changes are supported, but audio pan is not. Mono and stereo audio are supported, 5.1

audio is not supported. Separate audio channel tracks (even if out of sync) are imported into After Effects as a single

audio layer.

Clip Speed Clips with a Motion Effect are converted to the corresponding layer Stretch value (for slow or fast

motion) or layer Time Remap keyframes (for reverse motion).

Empty tracks Ignored.

Muted tracks Avid does not save muted track information in an exported AAF file, so muted tracks cannot be

preserved in After Effects.

Locators Ignored.

Composition size and pixel aspect ratio Created based on the StoredWidth and StoredHeight values for the first

media file in the first sequence found.

For more information on how video effects, audio effects, and transitions are converted when After Effects imports

an AAF file, visit the support area of the Adobe website.
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Importing 3D image files

How After Effects works with 3D image files
After Effects can import 3D-image files saved in Softimage PIC, RLA, RPF, and Electric Image EI format. These 3D-

image files contain red, green, blue, and alpha (RGBA) channels, as well as auxiliary channels with optional infor-

mation, such as z depth, object IDs, texture coordinates, and more.

With RLA and RPF files, all of the auxiliary channels are included in a single file. Softimage PIC files have a corre-

sponding ZPIC file that contains the z-depth channel information. Although you can’t import a ZPIC file, you can

access the additional channel information as long as the ZPIC file is stored in the same folder as the imported PIC

file.

Similarly, Electric Image (EI) files can now have associated EIZ files with z-depth channel data. Just as with ZPIC

files, you cannot import EIZ files into After Effects; instead, you simply store them in the same folder as the EI files.

For information about creating EIZ files, see your Electric Image documentation.

After Effects can also import baked camera data, including focal length, film size, and transformation data, from

Maya project files as a single composition or two compositions.

See also

“About 3D layers” on page 173

“About 3D rendering” on page 179

To import RLA or RPF data into a camera layer (Pro only)
After Effects imports camera data saved with RLA or RPF sequence files. That data is incorporated into a camera

layer that After Effects creates in the Timeline panel. You can access the camera data of an imported RLA or RPF

sequence and create a camera layer containing that data.

1 Place the imported sequence in the Timeline panel, and then select the sequence.

2 Choose Animation > Keyframe Assistant > RPF Camera Import.

Note: To create an RLA or RPF file with the camera data in 3D Studio Max, save your rendering in RPF format with

Coverage, Z Depth, and Alpha Channels enabled.

Baking Maya data (Pro only)
After Effects (Pro only) imports camera data from Maya project files. Before importing Maya camera information,

you need to bake it. This makes keyframing easier later in your project. Baking places a keyframe at each frame of

the animation. You can have 0, 1, or a fixed number of keyframes for each camera or transform property. For

example, if a property is not animated in Maya, either no keyframes are set for this property or one keyframe is set

at the start of the animation. If a property has more than one keyframe, it must have the same number as all of the

other animation properties with more than one keyframe.

Reduce import time by creating or saving the simplest Maya file possible. In Maya, reduce keyframes by deleting

static channels before baking, and save a version of the Maya project that contains the camera animation only.
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Note: The following transformation flags are not supported: query, relative, euler, objectSpace, worldSpace, worldSpace-

Distance, preserve, shear, scaleTranslation, rotatePivot, rotateOrder, rotateTranslation, matrix, boundingBox, bound-

ingBoxInvisible, pivots, CenterPivots, and zeroTransformPivots. After Effects skips these unsupported flags, and no

warnings or error messages appear.

Importing Maya data (Pro only)
By default, After Effects treats linear units specified in the Maya file as pixels.

You can import camera data from Maya project files (.ma) and work with the data as a single composition or two

compositions.

For each Maya file you import, After Effects creates either one or two compositions:

• If the Maya project has a square pixel aspect ratio, After Effects creates a single, square-pixel composition

containing the camera data and transformations.

• If the Maya project has a nonsquare pixel aspect ratio, After Effects creates two compositions. The first compo-

sition, which has a file name prefixed by Square, is a square-pixel composition containing the camera data. The

second, or parent, composition is a nonsquare-pixel composition that retains the dimensions of the original file

and contains the square-pixel composition.

When you import a Maya file with a 1-node camera, After Effects creates a camera in the square-pixel composition

that carries the camera's focal length, film size, and transformation data. When you import a Maya file with a 2-node

or targeted camera, After Effects creates a camera and an additional parent node in the square-pixel composition.

The parent node contains only the camera’s transformation data. After Effects doesn’t read 3-node cameras.

When working with imported camera data, use 3D layers and square-pixel footage in the square-pixel composition,

and use all nonsquare footage in the parent composition.

Note:After Effects reads only the rendering cameras in Maya files and ignores the orthographic and perspective cameras.

Therefore, always generate a rendering camera from Maya, even if it’s the same as the perspective camera. If you apply

the FilmFit camera setting, make sure to use either horizontal or vertical FilmFit, not fill.

After Effects can read Maya locator nodes, which enable you to track objects from the Maya scene as it is translated

into After Effects. After Effects creates a Null layer and applies the relevant transformations to it if a Maya locator

node’s name contains the word Null, NULL, or null. Avoid parenting locator notes to each other in Maya; instead,

parent the locator notes to geometry.

Note: After Effects doesn’t read World or Underworld coordinates in the LocatorShape. Use a transform node to place

them.
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Chapter 6: Compositions

Creating compositions

About compositions
To create a movie with the footage items in your project, set up a composition. A composition includes one or more

footage items—video, audio, still images—arranged in a Composition panel and in the Timeline panel. Simple

projects may include only one composition, while elaborate projects may include several compositions to organize

large amounts of footage or intricate effects sequences.

A composition includes at least one layer. When you add a footage item to a composition, the footage becomes the

source for a new layer. A composition can have any number of layers, and you can also include a composition as a

layer in another composition, which is called nesting.

A composition is the work space in which you create all animation, layering, and effects. Like other graphic program

work spaces, a composition has specific spatial dimensions. In addition to these spatial dimensions, compositions

also have a temporal dimension called duration. Each composition has an overall duration, or length in time.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

Creating a new composition and changing settings
When you first create a new project, you must create a composition before you can start working with your footage

items.

Once you have created a composition, you can change its settings at any time. Remember, however, that changing

frame size or pixel aspect ratio can affect your final movie, so set these as early in the project as possible. Use

Flowchart View to get a big-picture perspective of complex projects; see “About the Flowchart panel” on page 59 for

more information.

When you create a composition without changing settings in the Composition Settings dialog box, the new compo-

sition uses the same settings as the previous composition.

Note: When creating an elaborate composition, you may find it easier to organize the layers that make up the compo-

sition by using a technique called nesting—putting one or more compositions into another composition. You can create

many levels of nesting. For more information, see “About nesting” on page 130.)

See also

“Organizing footage in the Project panel” on page 58

To create a composition
1 Choose Composition > New Composition.

2 Type a Composition Name.
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3 Either choose a preset from the Preset menu or specify basic composition settings as follows:

Width and Height Type values for frame size in the text boxes. As a general rule, frame size and aspect ratio should

match your intended output media. This is set automatically if you choose a preset.

Lock Aspect Ratio Select this if you want to type a width or height not included in the menu and if you want After

Effects to ensure that the composition dimensions conform to the aspect ratio for the current values.

Pixel Aspect Ratio Choose a ratio from the menu. This is set automatically if you choose a preset.

Frame Rate Type a value for frames per second in the Frame Rate text box. This is set automatically if you choose a

preset.

Resolution Choose Full, Half, Third, or Quarter from the menu, or select Custom to designate the number of pixels

to render horizontally and vertically.

Start Timecode Type a value in this text box to set the time value for the first frame of the composition. This value

does not affect rendering.

Duration Type a duration for your composition in the text box.

4 Click the Advanced tab to specify advanced settings:

Anchor Click one of the arrows if you want to anchor the layers to a corner or edge of the composition as it is resized.

Shutter Angle and Shutter Phase Specify settings for motion blur.

Rendering Plug-In Select a 3D Rendering Plug-in from the menu.

Preserve Frame Rate Click this option to lock compositions to a specific frame rate.

Preserve Resolution Click this option to force nested compositions to retain their resolution settings.

5 Click OK.

Note: To change an existing composition’s settings, choose Composition > Composition Settings and follow steps 3-5.

See also

“About nesting” on page 130

“Specifying composition settings” on page 111

To create a composition from Project panel footage
You can create new compositions from multiple footage items stored in the Project panel. You can create single or

multiple compositions, and specify composition options for each new composition in the New Composition From

Selection dialog box.

1 In the Project panel, select one or more footage items.

2 Do one of the following:

• Drag the selected footage to the Create A New Composition button at the bottom of the Project panel.

• Choose File > New Comp From Selection.

3 If you have selected multiple footage items, select either Single Composition or Multiple Composition in the New

Composition From Selection dialog box, select settings as desired, and then click OK:

Use Dimensions From Choose a footage item from which to specify the dimensions for the new composition.

Still Duration Specify a value to set the duration of the stills in the new composition or compositions.
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Add To Render Queue Add the new composition to the render queue.

Sequence Layers Arrange layers in a sequence.

Overlap Overlap layers from the footage.

Duration and Transition Control how layers in the footage overlap.

Composition settings

Specifying composition settings
When you create a new composition, it appears as a new item in the Project panel. Before you set up a new compo-

sition, determine the specifications of the final output. These specifications influence the composition settings you

choose for frame size, duration, frame rate, and pixel aspect ratio. Four factors determine composition settings:

• The type of output you are producing

• The specifications of the footage you will be working with

• The requirements of any systems that will process the output that After Effects renders

• The final delivery medium of the output

For best results, specify the composition settings at the beginning of your design process. After Effects bases certain

calculations on the composition settings, so changing settings such as frame size and pixel aspect ratio late in the

project can affect your final output. (However, you can override some composition settings when rendering. For

example, you might change the composition-frame size to a smaller image size when rendering.)

When you click the Advanced tab in the Composition Settings dialog box, you can change the anchor setting, adjust

the shutter angle for motion blur, specify when the shutter opens relative to the frame start, set precompose options,

and specify a rendering plug-in.

See also

“To change the frame rate of a sequence” on page 76

“To set the pixel aspect ratio for imported footage” on page 98

“About projects” on page 49

To undo composition settings
• To undo composition settings immediately after closing the Composition Settings dialog box, choose Edit > Undo

Composition Settings.

• To undo the settings after you’ve made other changes to the project, choose Edit > History > Undo Composition

Settings, and then choose Edit > History > Redo [action] for all changes you want to add back to the composition.

Note: You can sequentially undo as many as 99 of the most recent changes made, depending on how many undo levels

are set in Preferences. To set the number or undo levels, choose Edit > Preferences > General (Windows) or After

Effects > Preferences > General (Mac OS).

If you change the Composition Settings and then undo the changes to the Composition Settings, use the Redo

command to add back all of your changes.
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See also

“To undo changes” on page 56

Setting frame size
The Composition panel in After Effects contains the viewing frame and an area outside the frame that you can use

to move layers into and out of the frame. For your convenience, After Effects includes a variety of presets, each

containing settings for frame size, pixel aspect ratio, and frame rate. You can also create a custom preset and save it

for later use.

Because After Effects can position footage items outside the frame, specify a frame size no larger than the actual size

of the final viewing screen. After Effects previews and renders only the footage items within the frame.

The viewing frame occupies the center of the frame’s pixel area, which is centered in a larger work area. You can

position items outside the frame if, for example, you want a layer to enter the frame from one side, cross the screen,

and leave the frame on the other side.

The viewing frame within a composition panel
A. Composition work area B. Viewing frame C. Footage item partially outside the frame

To set the anchor
When you change the frame size of a composition, by default the layers are centered within the new dimensions. Use

the Anchor control to anchor the layers to a corner or edge of the composition as it is resized.

❖ Click the arrow button in the Anchor diagram (in the Advanced column of the Composition Settings dialog box)

to indicate where to position the existing layers.

To work with composition settings presets
You can save values you set in the Composition Settings dialog box so that you can reapply them to other composi-

tions. Settings for the Width, Height, Pixel Aspect Ratio, and Frame Rate options are saved with the presets. However,

the Resolution, Start Timecode, Duration, and Advanced composition options are not saved.

• To save custom preset values, in the Composition Settings dialog box specify the Width, Height, Pixel Aspect

Ratio, and Frame Rate values, and then click the Save button . Type a name for the preset and then click OK.

• To reuse custom preset values, in the Composition Settings dialog box select the custom name from the Preset

menu.

• To delete presets, choose the custom name from the Preset menu and click the Delete icon .

A B C
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Setting pixel aspect ratio for compositions
While most computer monitors use square pixels, ITU-R 601 (D1) and DV video use non-square rectangular pixels.

The Pixel Aspect Ratio option compensates for the non-square pixels of D1 video format. Set the pixel aspect ratio

that corresponds to your final output format.

Note that the pixel aspect ratio is identical between D1 and DV, but there is a slight difference in composition frame

size.

In some circumstances, you may need to work on a monitor that doesn’t match the pixel aspect ratio, so your working

view may not match the final output.

To correct pixel aspect ratio for previewing

❖ Click the Toggle Pixel Aspect Ratio Correction button  at the bottom of the Composition panel.

To set the pixel aspect ratio for a composition

1 Open the composition.

2 Choose Composition > Composition Settings.

3 Choose a ratio from the Pixel Aspect Ratio menu and click OK.

To use square-pixel footage for output to D1/DV NTSC

If you intend to create a movie for the D1 output format, choose D1 NTSC or D1 PAL. The correct pixel aspect ratio

for D1 NTSC or D1 PAL is chosen automatically when you choose the corresponding preset item.

1 Prepare square-pixel footage that fills the entire frame for any of the following final output formats:

DV NTSC Create and save it at a 720 x 534 frame size.

D1 NTSC Create and save it at a 720 x 540 frame size.

D1/DV PAL Create and save it at a 768 x 576 frame size.

2 Import the file into After Effects.

3 (Optional) If your square-pixel footage was created and saved at 720 x 486 or 720 x 480, select it and choose File >

Interpret Footage > Main. Then choose Square Pixels from the Pixel Aspect Ratio menu and click OK.

4 Choose Composition > New Composition, and then do one of the following:

• If your final output is DV, choose NTSC DV, 720 x 480 for Preset, and D1/DV NTSC (0.9) for Pixel Aspect Ratio.

• If your final output is D1, choose NTSC D1, 720 x 486 for Preset, and D1/DV NTSC (0.9) for Pixel Aspect Ratio.

5 Select your other Composition settings as desired, and then click OK.

6 Add your footage to the new composition.

7 Select the layer containing the square-pixel footage and apply the Fit To Comp command: press Ctrl+Alt+F

(Windows) or Command+Option+F (Mac OS).

Note: If your footage was created and saved at a frame size other than those noted in step 1, skip step 6.

See also

“To set the pixel aspect ratio for imported footage” on page 98
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Setting frame rate
The composition frame rate determines the number of frames displayed per second. Frame rate is usually deter-

mined by the type of output you produce. NTSC video has a frame rate of 29.97 frames per second (fps), PAL video

has a frame rate of 25 fps, and motion picture film has a frame rate of 24fps. Depending on the broadcast system,

DVD video can have the same frame rate as NTSC video or PAL video, or a frame rate of 23.976. Video intended for

CD-ROM or the web is often 10 to 15 fps.

Each motion-footage item in a composition can also have a frame rate, and the relationship between the footage-

item frame rate and the composition frame rate determines how smoothly the layer plays. For example, if the

footage-item frame rate is 30 fps and the composition frame rate is 30fps, whenever the layer advances one frame,

the next composition frame is displayed. If the footage-item frame rate is 15 fps and the composition frame rate is

30 fps, then two composition frames are displayed before the current layer advances one frame, unless frame

blending is enabled.

When you use footage that was shot or rendered at the NTSC-standard rate of 29.97 fps and the composition frame

rate is 30fps, approximately two footage frames will be repeated every minute to compensate for the differing rates.

To avoid repeated frames, make sure that your composition frame rate matches your source footage, or enable frame

blending for the layer.

Setting the composition frame rate to twice the rate of the output format causes After Effects to display each field of

interlaced source footage as its own, separate frame in the Composition panel. This process lets you set keyframes on

individual fields and gain precision when animating masks.

Setting resolution
Resolution determines the dimensions of the image in pixels, which affects the image quality of the rendered compo-

sition. Setting a low resolution significantly increases frame-rendering speed and decreases the amount of memory

required to render. You can use a low-resolution setting when animating or previewing a movie, and then increase

the resolution before rendering your final movie.

Select one of the following resolution settings in the Composition Settings dialog box:

Full Renders each pixel in a composition. This setting gives you the best image quality, but takes the longest to

render.

Half Renders one-quarter of the pixels contained in the full-resolution image—half the columns and half the rows.

This results in a rendering time approximately one-fourth of the time required to render the entire image at full

resolution.

Third Renders one-ninth of the pixels contained in the full-resolution image. This results in a rendering time

approximately one-ninth of the time required to render the entire image at full resolution.

Quarter Renders one-sixteenth of the pixels contained in the full-resolution image. This results in a rendering time

approximately one-sixteenth of the time required to render the entire image at full resolution.

Custom Renders the image at the resolution you specify.
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Example of an image at composition resolution and half resolution
A. Original composition resolution B. Half resolution with same clarity but with reduction in screen size C. Half resolution with same screen
size but with reduction in clarity

To determine appearance of lower-resolution compositions
When setting resolution, you can determine the size and appearance of the composition. When you lower the

resolution of a composition, you can maintain image clarity by reducing the composition’s size. You can also

maintain its size but reduce image clarity, with the layers appearing blockier and more pixelated. The smaller on-

screen image will update faster than the original-size image with a lower resolution.

1 Choose Edit > Preferences > Display (Windows) or After Effects > Preferences > Display (Mac OS).

2 Select Auto-Zoom When Resolution Changes to reduce the size of the composition while maintaining image

clarity. Deselect this option to maintain the composition size in the Composition panel but display layers with less

clarity.

3 Click OK.

You can also set the magnification using the menu in the Composition panel.

Setting start timecode or start frame
Use the Composition Settings dialog box to determine when the composition will begin. The name of the option in

the Composition Settings dialog box is determined by whether Timecode, Frames, or Feet + Frames is selected in

the Project Settings dialog box. For example, if Timecode Base is specified, you can use the Start Timecode option

to specify when the composition will begin; if Frames is selected, you can use the Start Frame option to specify the

frame number where the composition will begin.

See also

“About timecode and duration” on page 54

To set duration
The duration is the overall length of the composition.

❖ Set duration by typing values in the Duration box in the Composition Settings dialog box.

When you preview or render a movie, you can choose to preview or render only a portion of the total duration.

See also

“To set a work area” on page 121
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To set the rendering plug-in
You can animate layers in 3D space. This 3D environment includes shadows, specular highlights, rack focus, and an

automatic method of compositing layers based on depth. The default 3D rendering plug-in is Advanced 3D. You can

use the Advanced tab of the Composition Settings dialog box to specify the Standard 3D or Advanced 3D rendering

plug-in. You can also specify third-party rendering plug-ins as they become available. Note that the Standard 3D

rendering plug-in does not support intersecting 3D layers.

Example of 3D file with intersecting layers rendered with Standard 3D rendering plug-in (left) and Advanced 3D rendering plug-in (right)

1 Choose Composition > Composition Settings, and click on the Advanced tab in the Composition Settings dialog

box.

2 Choose Standard 3D, Advanced 3D, OpenGL Hardware, or a third-party plug-in (if available) from the Rendering

Plug-in menu.

3 Click Options and specify the following settings in either the Standard 3D Options, or the Advanced 3D Options

dialog box, and then click OK:

Standard 3D Choose an option from the Antialiasing menu.

Advanced 3D Choose an option from the Shadow Map Resolution menu.

Composition panel

About the Composition panel
Use the Composition panel to preview the composition and animate its contents manually. For example, you can

move a layer by dragging it, scale a layer by dragging its handle, and scroll with the Hand tool. You can also change

the background color of the composition. The Composition panel contains a number of features and controls to help

you work with layers.

Always Preview This View button Toggles the current view as the default view for previews.

Magnification Ratio menu Specify a magnification from the menu.

Title-Action Safe menu Toggle Title/Action Safe Zone, Proportional Grid, Grid, Guides, Rulers, and 3D

Reference Axis. See “To view and use safe zones and grids” on page 142.

Toggle View Masks button Toggles between viewing masks in a composition and viewing the image without

masks.

Current Time button Opens the Go To Time dialog box. Specify a new frame or time in the text box.

Take Snapshot and Show Last Snapshot buttons Captures or shows an image of the contents of the panel.

Snapshots are not saved to disk. Click and hold the Show Last Snapshot button to view the most recent snapshot

instead of the active composition.
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Show Channel menu Toggles RGB, Red, Green, Blue, and Alpha settings, and offers RGB Straight and Colorize

modifiers. RGB is the default setting, which displays the complete, full-color RGB picture. Red, Green, and Blue

settings display the indicated color channel, with high color values displayed as white. The Alpha setting displays

transparent and opaque areas as black and white, respectively, with degrees of opacity as shades of gray. RGB Straight

toggles between premultiplied and RGB straight alpha channel interpretation modes. Colorize displays the Red,

Green, and Blue channels in their respective colors instead of black and white.

Resolution/Down Sample Factor menu Specifies the resolution for the current composition.

Region Of Interest button Narrows the composition area for previewing. See “Changing the region of interest”

on page 118.

Toggle Transparency Grid button Toggles between viewing a checkerboard background to display transparency

and viewing the background color.

3D View menu Specify a view for a 3D layer from the menu. See “About 3D views” on page 177.

Select View Layout menu Toggles between 1-view, 2-view, and 4-view layout options. By default, viewer options

(grids, rulers, etc.) affect only the currently selected view; choosing Share View Options from this menu applies

changes to all viewers in the current layout. Holding down Ctrl (Windows) or Command (Mac OS) momentarily

reverses this option.

Turning the mouse wheel with the pointer over the Select View Layout menu button scrolls through the available

view layouts.

Toggle Pixel Aspect Ratio Correction button Toggles between turning on and off pixel aspect ratio correction.

Turn on Pixel Aspect Correction to squash or stretch an image and correct a non-square pixel aspect ratio. Pixel

Aspect Correction has no effect on square-pixel compositions, layers, or footage. It also has no effect when you create

files with the Make Move or Export command. Because the scaling is not of high quality, use Pixel Aspect Correction

to evaluate shapes, not fine pixel details.

Fast Previews button Specify a preview option from the menu, or choose Fast Previews Preferences to access the

Previews Preferences dialog box.

Timeline button Brings forward the Timeline panel for the current composition.

Comp Flowchart button Brings forward the Flowchart View for the current composition. See “About the

Flowchart panel” on page 59.

To set background or pasteboard color
The default background color for the Composition panel is black, but you can change the color at any time. When

you add one composition to a second composition (nesting), the second composition’s background color is

preserved, and the first composition’s background becomes transparent. If you want to preserve the first compo-

sition’s solid background color, then create a new, colored solid to use as a background layer in the first composition.

You can also change the color of the pasteboard in the Composition panel.

1 Do one of the following:

• To set the background color of a composition, choose Composition > Background Color.

• To set the pasteboard color of all After Effects compositions, choose Edit > Preferences > User Interface Colors

(Windows) or After Effects > Preferences > User Interface Colors (Mac OS).

2 Click the color swatch to select a color, or click the eyedropper to sample a color from anywhere on the screen.

Then click OK.
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See also

“To create a solid-color layer” on page 150

“Organizing a project using nesting” on page 60

To turn the transparency grid on or off
You can toggle a transparency grid on or off (like the grid that Adobe Photoshop uses to indicate transparency).

❖ Choose Transparency Grid from the Composition panel menu, or click the Toggle Transparency Grid button

at the bottom of the Composition panel.

Changing the region of interest
Use the Region Of Interest button to create a rectangular preview of the Composition panel. Reducing the region of

interest requires less memory when previewing, thereby improving interaction speed and increasing RAM preview

duration. Changing the region of interest does not affect file output.

You can permanently change the size of your composition by cropping it to the region of interest.

To change the region of interest

❖ In the Composition panel, do any of the following:

• To draw a region of interest, click the Region Of Interest button , and then drag the marquee tool across the

area of the Composition panel where you want images to appear.

• To toggle between viewing the region of interest and the full composition area, click the Region Of Interest button

again.

• To start over with the marquee tool, hold down Alt (Windows) or Option (Mac OS) and click the Region Of

Interest button.

To crop to the region of interest

1 Click the Region Of Interest button , and then drag the marquee tool across the area of the Composition panel

where you want images to appear.

2 Choose Composition > Crop Comp To Region Of Interest.

Timeline panel

About the Timeline panel
Use the Timeline panel to animate layer properties and set In and Out points for a layer. Many of the Timeline panel

controls are organized in columns of related functions.

By default, the Timeline panel contains a number of columns and controls. Optional columns are also available.

Note: All layer switches move together—you can move the entire switches column to a different position between other

columns, but you can’t rearrange the switches within the column.
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Default controls and columns in the Timeline panel
A. Timeline tab B. Current time C. Switches/Modes column D. Layer Bar/Graph Editor area E. Audio/Video Switches column F. Source
Name/Layer Name column G. Timeline panel switches H. Composition button

Timeline tab Displays the composition name associated with the timeline. Drag the tab to move the timeline to a

different area, or to dock it with another panel.

Current time Displays the current time in the project. Click to open the Go To Time dialog box.

Switches/Modes column Contains options for controlling a number of display and performance features for a layer.

Includes the Graph Editor button, which toggles between Graph Editor mode and layer bar mode.

Layer bar/Graph Editor area Displays layer bars in layer bar mode, or the Graph Editor in Graph Editor mode.

Audio/Video Switches column Contains switches for enabling and disabling audio and video. This column also

includes a lock switch for locking layers and a solo switch for displaying only selected layers.

Source Name/Layer Name column Includes a label, a number (assigned by After Effects), and a source name or layer

name for each layer. Click on the column heading to alternate between viewing the source name and viewing the

layer name. Click the triangle to the left of a layer to examine and set properties for the masks, effects, and transform

functions.

Timeline panel switches Contains the Live Previews, Draft 3D, Shy Layers, Frame Blending, Motion Blur, and Graph

Editor switches.

Composition button Brings forward the corresponding Composition panel.

To work with columns in the Timeline panel
• To change the width of a column, drag the raised vertical bar left or right to set the new width. If the column does

not have a raised vertical bar at its right edge, it cannot be resized.

• To rearrange columns, drag the column heading to a different location along the Timeline panel. When the green

ghost appears where you want the column to appear, release the mouse.

• To display or hide optional columns in the Timeline panel, right-click (Windows) or Control-click (Mac OS) a

Timeline panel column heading, and then in the Columns submenu choose the column that you want to display

or hide.

A green ghost appears when you drag a column (left); when you release, the column appears in a new position (right).
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About the time graph
The time graph portion of the Timeline panel contains a time ruler, markers to indicate specific times, duration bars

for the layers in your composition while in layer bar mode, and the Graph Editor while in Graph Editor mode. Use

the time graph to adjust the range of time shown in the Timeline panel, and to specify a range of time to render when

creating or previewing a movie.

The time graph also contains controls for adjusting time for layers and controlling motion and changes over time.

Time graph portion of Timeline panel
A. Time navigator start and end brackets B. Work area start and end brackets C. Time ruler D. Timeline options E. Navigator view F. Comp
marker bin G. Comp button H. Zoom slider

Time Navigator start and end brackets Drag to magnify or shrink a section of the time ruler. These markers are part

of the navigator view, described below. Drag to view a specific area.

Time ruler Indicates the part of the composition duration currently displayed in the time graph.

Navigator view Contains the absolute work area and the absolute current-time indicator.

Work area start and end brackets Indicates the part of the composition that will be rendered or previewed.

Timeline Options Displays the Timeline Options menu, which includes functions affecting layers and keyframes, as

well as providing access to the Composition Settings dialog box.

Comp marker bin Add composition-time markers to the time ruler. Drag the marker to a point on the time ruler.

Drag the marker back to the bin to remove the marker.

Comp button Click to bring forward the composition related to the active Timeline panel.

Zoom slider Drag to magnify a portion of the time graph or to see more of the time graph. You can also use the Zoom

In button  or the Zoom Out button .

Viewing and setting the current time
A composition’s current time is indicated by the current-time indicator. A composition’s current time also appears

in the current time display in the upper left corner of the Timeline panel.

To move the current-time indicator

❖ Do one of the following:

• To move the current-time indicator by dragging, in the navigator view or on the time ruler, drag the current-time

indicator to a new location on the time graph, or click on the time ruler.

• To move the current-time indicator numerically, click the current time in the Timeline or Composition panel, type

a new time, and click OK.
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To magnify a portion of the time graph

Do one of the following:

• In the Timeline panel, click the Zoom In button  or drag the zoom slider.

• Press the = (equal sign) key on the main keyboard.

• In the navigator view, drag the Time Navigator Start, or Time Navigator End, or both brackets until the time ruler

displays the portion you want.

Dragging Time Navigator Start and End brackets to magnify or shrink the part of the time ruler displayed

To see more of the time graph

Do one of the following:

• In the Timeline panel, click the Zoom Out button .

• Press the – (minus) key on the main keyboard.

• In the navigator view, drag the left and right time view brackets until the time ruler displays the portion you want.

To set a work area
When you work on a composition, you may want to preview or render only part of the duration of a composition.

Do this by specifying a part of the composition time ruler as a work area. In the Timeline panel, the work area appears

in a lighter shade of gray.

Set the work area start or end point to the current time by pressing B (begin) or N (end), respectively.

• To set a work area, move the start and end work-area markers in the time ruler until they mark the start and end

of the part of the composition you want to use as a work area.

Work-area markers indicate the part of the composition displayed when previewing or rendering.

• To move the work area, drag the center of the work area bar left or right.
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Center of work area bar.

• To expand the work area to the size of the composition, double-click the center of the work area bar.

See also

“About rendering” on page 590

Working with footage

Adding and revealing footage
Once you have created a new composition and imported footage into the project, you can add footage items or

another composition to it. You can use individual items in the Project panel any number of times in one or more

compositions.

Items added to a composition by dragging them onto the Composition panel (or onto a composition in the Project

panel) will snap to the beginning of the timeline (0.00s) by default. (To change this setting, choose Edit >

Preferences > General (Windows) or After Effects > Preferences > General (Mac OS), and then deselect Create

Layers At Composition Start Time. This will cause footage items to appear at the current-time indicator.) After you

add a layer, you can move it to any position within the Composition panel. When you add multiple footage items,

they appear in the composition in the order selected.

In the Composition panel, layers are visible only if they are active at the time currently displayed. For example, if you

have three layers in a composition, with two of the layers starting at the beginning of the composition and one layer

starting at 6 seconds, only two of the layers appear in the Composition panel when the current-time indicator is set

to the beginning of the composition.

Note: Although you cannot directly add a composition to itself, you can duplicate a composition and add the copy to the

original.

See also

“Viewing and setting the current time” on page 120

“About trimming” on page 162

To add one or more footage items to a composition

1 Click the tab of the Timeline panel for the composition to which you want to add an item.

2 Select one or more footage items in the Project panel.

3 Drag the footage items, the footage-item thumbnails, or a folder from the Project panel to one of three places:

• The Composition panel.
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• The Timeline panel. When you drag the item into the Timeline, a highlight bar indicates where the layer will

appear when you release the mouse button. If you drag the item over the time graph area, a time marker indicates

where the layer’s In point will be when you release the mouse button.

• The composition name or icon in the Project panel.

Note: When you click on a footage item in the Timeline panel, the Info panel displays the item’s name, duration, and In

and Out points.

While dragging an item into the Timeline panel, you can specify the layer order and In point.

You can also add a footage item to a composition by selecting the name of the footage item in the Project panel and

pressing Ctrl+/ (Windows) or Command+/ (Mac OS).

To reveal footage in the Timeline or Project panel

In large or complex projects it can be difficult to locate specific instances of footage used, especially if you use items

more than once. Using the Reveal In Composition command, you can easily locate and select an instance of a footage

item in any of its locations in the Timeline panel.

Do any of the following:

• To reveal footage in a composition, right-click (Windows) or Control-click (Mac OS) the footage item in the

Project panel and choose Reveal In Composition; then select the specific instance you want to reveal (composition

name, layer name).

• To reveal footage in the Project panel, right-click (Windows) or Control-click (Mac OS) a layer in the Timeline

Panel and then choose Reveal Layer Source In Project.

Viewing and editing footage in a Footage panel
After you have imported footage, you can view, edit, and change settings for your imported footage without using a

Composition panel.

You can view any movie or graphic item listed in a Project panel at full size by opening it in a Footage panel. You can

also view the footage at different magnifications and examine individual frames.

When you double-click a movie in the Project panel, it opens by default in the appropriate type of Footage panel:

QuickTime (.mov) files open in a QuickTime Footage panel; Video for Windows (.avi) files open in a Video For

Windows Footage panel. Still images always appear in an After Effects Footage panel.

Note: Certain AVI files are not supported by the AVI Footage panel, and will open in the After Effects Footage panel.

These include files created with Microsoft’s DirectX DV codec and all files over 2 GB. If the AVI Footage panel is empty,

Alt-double-click to open the footage in the After Effects Footage panel.
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The QuickTime and Video For Windows Footage panels do not display the results of settings made in the Interpret

Footage dialog box, such as the alpha channel interpretation method. However, for any footage item that includes

audio, the QuickTime and Video For Windows Footage panels play the audio, while the After Effects Footage panel

does not. For more information on alpha channel interpretation methods, see “About straight and premultiplied

channels” on page 242. For more information on how to interpret footage, see “To specify interpretation rules” on

page 71.

To view the footage with more controls and information but without audio, view it in an After Effects Footage panel,

where you can trim the footage and insert it into the Timeline panel.

Using Footage panel to trim footage and insert it into Timeline panel

To open a movie in the Footage panel
1 To open a movie in the After Effects Footage panel, press Alt (Windows) or Option (Mac OS) as you double-click

a movie in the Project panel.

2 To open a movie in the Footage panel, double-click a movie in the Project panel, or press Alt (Windows) or Option

(Mac OS) and double-click either on the layer in the Timeline panel or on the movie in the Composition panel.

To edit footage in its original application
You can open and edit a footage item in the application in which it was created, directly from an After Effects project.

The original application must be installed on the computer you are using, and there must be enough unused RAM

for it to run. When you edit and save changes to the footage in the original application, the changes are applied to all

instances of the footage as soon as After Effects becomes the active application.

Note: If you’re editing footage that has an alpha channel, make sure that you’re viewing and editing all the channels,

including the alpha channel, in the other application. Otherwise, changes you make might not be applied to the alpha

channel, and it may become misaligned with the color channels.
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When you edit a still-image sequence selected in the Timeline or Composition panel, the individual image that is

currently displayed opens. When you edit a still-image sequence selected in the Project panel, the first image in the

sequence opens.

1 In the Project panel, Composition panel, or Timeline panel, select the footage or a layer containing the footage. If

you selected a still-image sequence from the Composition or Timeline panel, move the current-time indicator to the

frame displaying the still image you want to edit.

2 Choose Edit > Edit Original.

3 Edit the footage in its original application, and save the changes.

Note: If your project is open when you make a change to a footage file, After Effects can reload the new version of the file

while the project is open. To do this, select the footage file in the Project panel, then choose File > Reload Footage.

To set the frame rate for footage
You can change the frame rate for any movie or sequence of still images. For example, you can import a sequence of

ten still images and specify a frame rate of 5 frames per second (fps).

1 Select an item in the Project panel.

2 Choose File > Interpret Footage > Main.

3 Select Conform to Frame Rate, and enter a number in the Frames per Second text box.

Note: If you remove 3:2 pulldown from interlaced video footage, After Effects automatically sets the frame rate of the

resulting footage to four-fifths of the original frame rate. When removing 3:2 pulldown from NTSC video, the resulting

frame rate is 24 fps.

See also

“About 3:2 and 24Pa pulldown” on page 101

To loop footage
If you intend to loop visual footage continuously in your project, you need to create only one cycle of the footage in

After Effects.

1 In the Project panel, select the footage you want to loop.

2 Choose File > Interpret Footage > Main.

3 Type an integer value for Loop and click OK.

To apply Interpret Footage settings to multiple footage items
If you want to ensure that different footage items use the same Interpret Footage settings, copy settings from one item

and apply them to others.

1 In the Project panel, select the item whose footage interpretation settings you want to apply.

2 Choose File > Interpret Footage > Remember Interpretation.

3 Select one or more footage items.

4 Choose File > Interpret Footage > Apply Interpretation. After Effects applies the footage interpretation options to

the selected items.
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Copying between After Effects and Adobe Premiere Pro (Windows only)
You can copy and paste layers and assets between Adobe After Effects and Adobe Premiere Pro:

• From After Effects, you can copy footage or solid layers and paste them into an Adobe Premiere Pro sequence.

• From Adobe Premiere Pro, you can copy assets (any item in a track) and paste them into an After Effects compo-

sition.

• From either After Effects or Adobe Premiere Pro, you can copy and paste footage to the other’s Project panel.

Note: You can also paste assets from Adobe Premiere to an After Effects composition. You can’t, however, paste footage

from After Effects into an Adobe Premiere sequence.

If you want to work with all clips or a single sequence from an Adobe Premiere Pro project, use the Import command

to import the project into After Effects.

Use Adobe Dynamic Link to create dynamic links, without rendering, between new or existing compositions in After

Effects and Adobe Premiere Pro.

See also

“About Adobe Dynamic Link (Adobe Production Studio only)” on page 632

Copying from After Effects to Adobe Premiere Pro (Windows only)
You can copy a layer containing footage from an After Effects composition and paste it into an Adobe Premiere Pro

sequence. Adobe Premiere Pro converts footage layers to clips in the sequence and copies the source footage to the

Adobe Premiere Pro Project panel. If the layer contains an effect that is also used by Adobe Premiere Pro, Adobe

Premiere Pro converts the effect and all of its settings and keyframes.

You can also copy nested compositions, Photoshop layers, solid layers, and audio layers from After Effects to Adobe

Premiere Pro. Adobe Premiere Pro converts nested compositions to nested sequences, and converts solid layers to

color mattes. You cannot copy text, camera, light, or adjustment layers to Adobe Premiere Pro.

When you paste a layer into an Adobe Premiere Pro sequence, keyframes, effects, and other properties contained in

a copied layer are converted as follows:

After Effects item Converted to in Adobe Premiere
Pro

Notes

Transform property values and
keyframes

Motion or Opacity values and
keyframes

The keyframe type—Bezier, Auto
Bezier, Continuous Bezier, or
Hold—is retained.

Effect properties and keyframes Effect properties and keyframes,
as long as the effect also exists in
Adobe Premiere Pro

Adobe Premiere Pro lists unsup-
ported effects in the Effect
Controls panel as offline.

Audio volume property Channel Volume filter

Stereo Mixer effect Channel Volume filter

Masks and mattes Not converted
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To copy from After Effects to Adobe Premiere Pro (Windows only)
1 Start Adobe Premiere Pro (you must do this before you copy the layer in After Effects).

2 Select a layer from the After Effects Timeline panel.

3 Choose Edit > Copy.

4 In Adobe Premiere Pro, open a sequence in the Timeline panel.

5 Move the current-time indicator to the desired location, and choose either Edit > Paste or Edit > Paste Insert.

Note:You can copy multiple layers into Adobe Premiere Pro. Each layer is placed on a separate track. The order in which

Adobe Premiere Pro places the layers depends on the order in which you selected them in After Effects; the last-selected

layer appears on Track 1 of the Adobe Premiere Pro sequence. For example, if you select layers from top to bottom, the

layers appear in the reverse order in Adobe Premiere Pro, with the bottommost layer on Track 1.

Copying from Adobe Premiere Pro to After Effects (Windows only)
You can copy a video or audio asset from an Adobe Premiere Pro sequence and paste it into an After Effects compo-

sition. After Effects converts assets to composition layers and copies the source footage into the After Effects Project

panel. If the asset contains an effect that is also used by After Effects, After Effects converts the effect and all of its

settings and keyframes.

You can copy color mattes, stills, nested sequences, and offline files into After Effects. After Effects converts color

mattes into solid layers and nested sequences into nested compositions. When you copy a Photoshop still into After

Effects, After Effects retains the Photoshop layer information. After Effects converts titles to solid layers.

When you paste an asset into an After Effects composition, keyframes, effects, and other properties contained in a

copied asset are converted as follows:

Time Stretch property Speed property Speed and time stretch have an
inverse relationship. For example,
200% stretch in After Effects
converts to 50% speed in Adobe
Premiere Pro.

Layer-time markers Not converted

Blending modes Not converted

Adobe Premiere Pro asset Converted to in After Effects Notes

Motion or Opacity values and
keyframes

Transform property values and
keyframes

Keyframe type—Bezier, Auto
Bezier, Continuous Bezier, or
Hold—is retained.

Video filter properties and
keyframes

Effect properties and keyframes, as
long as the effect also exists in
After Effects

After Effects doesn’t display
unsupported effects in the Effect
Controls panel.

Crop filter Mask layer

Video and audio transitions Opacity keyframes (Cross dissolve
only) or solids

After Effects item Converted to in Adobe Premiere
Pro

Notes
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To copy from Adobe Premiere Pro to After Effects (Windows only)
1 Select an asset from the Adobe Premiere Pro Timeline panel.

2 Choose Edit > Copy.

3 In After Effects, open a composition in the Timeline panel.

4 With the Timeline panel active, choose Edit > Paste. The asset appears as the first layer in the Timeline.

Note: To paste the asset at the current-time indicator, position the current-time indicator and press Ctrl+Alt+V.

Replacing and substituting footage

About placeholders and proxies
When you want to temporarily use a substitute for footage, choose one of two alternatives: a placeholder or a proxy.

Placeholder A still image of color bars used to temporarily take the place of missing footage. Use a placeholder when

you are building a composition and want to try out ideas for footage that is not yet available. After Effects generates

placeholders automatically, so you do not have to provide any placeholder footage.

Proxy Most often a lower-resolution or still version of existing footage used to replace the original to save processing

time. Use a proxy when you have the actual footage but you want to speed up previewing or rendering of test movies.

You must have a file available to use as a proxy.

Using either method, any masks, attributes, expressions, effects, and keyframes that you apply to the placeholder or

proxy are transferred to the actual footage when you insert it. You can even set a proxy for a placeholder, so that you

use a low-resolution or still version of full-resolution footage that is not yet available.

If final footage is unavailable, and you simply want to substitute draft footage or a storyboard still image, you can

import the draft footage and replace it with final footage later.

Volume and Channel Volume
audio filters

Stereo mixer effect Other audio filters are not
converted.

Speed property Time Stretch property Speed and time stretch have an
inverse relationship. For example,
50% speed in Adobe Premiere Pro
is converted to 200% stretch in
After Effects.

Frame Hold Time Remap

Clip marker Layer-time marker

Sequence marker Markers on a new solid layer To copy sequence markers, you
must either copy the sequence
itself or import the entire Adobe
Premiere Pro project as a composi-
tion.

Audio track Audio layers Audio tracks that are either 5.1
surround or greater than 16-bit
aren’t supported. Mono and stereo
audio tracks are imported as one
or two layers.

Adobe Premiere Pro asset Converted to in After Effects Notes
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To work with placeholders and missing footage
In After Effects, a placeholder appears as a still image of color bars. You can apply attributes, expressions, effects, and

keyframes to a placeholder. When the actual footage item becomes available, you can replace the placeholder with

it, and the applied attributes are transferred to the actual footage.

For best results, set the placeholder to exactly the same size, duration, and frame rate as the actual footage.

If After Effects cannot find source footage when you open a project, the footage item appears in the Project panel

labeled Missing, and the name of the missing footage appears in italics. Any composition using that item as a layer

replaces it with a placeholder.

You can still work with the missing item in the project, and any effects you applied to the original footage remain

intact. When you replace the placeholder with the source footage, After Effects places the footage in its correct

location in all the compositions that use it.

❖ Do any of the following:

• To use a placeholder, choose File > Import > Placeholder or File > Replace Footage > Placeholder, specify the

placeholder’s name, size, frame rate, and duration, and then click OK.

• To replace a placeholder with actual footage, in the Project panel, double-click the placeholder you want to replace,

or choose File > Replace Footage > File, locate and select the actual footage, and then click OK (Windows) or

Import (Mac OS).

To work with low-resolution proxies for footage
Movies, images, and compositions used as layers can take up significant amounts of RAM and disk space when used

in compositions, and can slow down working and rendering in elaborate projects. Using low-resolution proxy items

in place of actual items is a way to lighten the burden on your computer and speed your work. Effects, masks, and

properties applied to the proxy are applied to the actual footage item when you replace the proxy with the actual

footage.

When you use a proxy, After Effects replaces the actual footage with the proxy in all compositions that use the actual

footage item. When you finish working, you can switch back to the actual footage item in the project list. After Effects

then replaces the proxy with the actual footage item in any composition.

When you render your composition as a movie, you may choose to use either all the actual high-resolution footage

items or their proxies. You might want to use the proxies for a rendered movie if, for example, you simply want to

test motion using a rough movie that renders quickly.

For best results, set a proxy so that it has the same aspect ratio as the actual footage item. For example, if the actual

footage item is a 640 x 480-pixel movie, create and use a 160 x 120-pixel proxy. When a proxy item is imported, After

Effects scales the item to the same size and duration as the actual footage. If you create a proxy with an aspect ratio

that is different from that of the actual footage item, scaling will take longer.

❖ In the Project panel, do any of the following:

• To locate and use a proxy, select a footage item, choose File > Set Proxy > File, locate and select the file you want

to use as a proxy, and click Open.

• To toggle between using the original footage and its proxy, click the proxy indicator to the left of the footage name.

• To stop using a proxy, select the original footage item, and choose File > Set Proxy > None.
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Identifying proxy items in the Project panel
In the Project panel, After Effects marks the footage name to indicate whether the actual footage item or its proxy is

currently in use:

• A box containing a black square indicates that a proxy item is currently in use throughout the project; the name

of the proxy appears in boldface in the project list.

• An empty box indicates that the actual footage item is in use throughout the project.

• No box indicates that no proxy is assigned to the footage item.

Proxy items in Project panel
A. Proxy assigned and in use B. Proxy assigned, but original in use C. No proxy assigned D. Proxy name

Nesting

About nesting
Nesting is useful when you want to apply a single transform property to a layer in more than one way. It adds another

opportunity to apply masks, effects, or transform changes.

For example, you could use nesting to make a planet both rotate and revolve (moving like the Earth, which spins on

its own axis and also travels around the sun). By nesting, you can apply rotation to the planet in one composition and

then move that composition into another composition containing the background. The planet composition becomes

a new layer in the composition containing the background. You can then apply rotation to this new layer to make it

revolve.

Another way to configure this example would be to use parenting. See “To work with parent and child layers” on

page 208.

When you change certain settings in the current composition, these propagate through to the nested compositions.

These settings include the Quality options under Layer > Quality, several options under Layer > Switches, and three

options on the Timeline panel menu: Enable Motion Blur, Enable Frame Blending, and Draft 3D. The Resolution

setting for the original composition also applies to nested compositions.

If you do not want these switch settings for the current composition to apply to the individual nested compositions,

you can change that at the preferences level.

A 

D 

B 

C 
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You nest compositions by dragging a composition icon from the Project panel into another composition in the

Timeline panel. If the target composition is currently active in the Composition panel, drag the composition icon

you want to nest directly into the Composition panel.

Nesting options
The Advanced tab of the Composition Settings dialog box includes two nesting options:

Preserve Resolution When Nested Retains the resolution setting of the nested composition. If this option is not

selected, the containing composition’s resolution overrides the nested composition’s resolution. You can use the

Preserve Resolution option, for example, to retain a low resolution for a nested composition and improve its preview

time.

Preserve Frame Rate When Nested Or In Render Queue Locks a composition to a specific frame rate, which should

improve performance in many cases as well as eliminate the need to use Posterize Time in creating reduced frame

rate effects. If this option is not selected, the containing composition’s frame rate overrides the nested composition’s

frame rate.

To synchronize time displays for nested compositions
When you open panels associated with a composition, such as the Timeline panel, the Layer panel, and Effect

Controls, changing the current time in one panel updates the other panels associated with that composition.

However, changing the current time in one composition does not change the current time in panels belonging to

other compositions, unless you are working with nested compositions.

You can synchronize the current-time indicators in open panels belonging to a nested composition. After Effects

provides a preference that updates all panels of nested compositions when you move the current-time indicator in

any nested composition.

❖ Choose Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS), click the

Synchronize Time of All Related Items option to add a check mark, and click OK.

To collapse transformations in a nested composition
There are two methods of calculating changes to transform properties (such as rotation or scale) while rendering a

nested composition. The default method is to apply transform properties and rasterize at every level of nested

compositions. The alternative method is to collapse transformations, which postpones the calculation of transform

properties and the rasterization of nested compositions until the rendering process reaches a layer you select. You

can increase image quality and significantly reduce rendering time by collapsing transformations.

Collapsing transformations can preserve resolution when a nested composition is scaled down and then scaled back

up in successive compositions. Without collapsed transformations, a nested composition that is scaled down loses

the resolution of its original larger size. When you collapse transformations, the original resolution of a nested

composition is preserved; its final resolution is determined by its size within the composition that uses collapsed

transformations.

When you collapse the transform properties of a layer, all compositions nested inside it combine their opacity setting

with the opacity setting of the layer that uses collapsed transform properties.

When a layer contains an Adobe Illustrator file instead of a nested composition, the Collapse Transformations switch

for that layer becomes the Continuously Rasterize switch, which you can use to improve the image quality of footage.
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Collapsing transformations also adds some flexibility when you work with 3D layers in nested compositions. If you

have a subordinate composition that has 3D objects within it without turning on Collapse Transformations, After

Effects renders the composition as a 2D image of the 3D arrangement in the next higher composition. However, if

you turn on Collapse Transformations, After Effects renders the 3D layers into the next higher composition so that

they retain their 3D relationships among themselves and with other 3D layers there. You can continue to manipulate

the relative positions of the 3D layers as a group from the lower composition.

❖ In the Layer Switches column of the Timeline panel, click the Collapse Transformations switch icon next to the

layer containing the nested composition.

Note: When you enable the Collapse Transformations switch for a nested composition, guide layers in the nested compo-

sition will no longer display.

Saving time by prerendering nested compositions
A complex nested composition can take a long time to preview and render. If you have a nested composition that you

do not expect to work on any further, render the nested composition into a movie and use it as a proxy for the actual

nested composition. As a rendered movie, it will require less calculation and will take less time to display and render

in the larger project. You can still make changes to the prerendered composition, because the original nested compo-

sition remains in the project list. If you make a significant change to the original nested composition, simply render

it again. Prerendering a nested composition is particularly beneficial when you use a nested composition multiple

times in a project.

Using a prerendered movie in place of a nested composition also saves time and memory when you render the final

version of the main composition. Just be sure to apply your final output settings when you prerender the nested

composition.

There are three phases to prerendering a composition: Creating a composition, rendering the composition you

created, and then creating a proxy from the rendered composition. Use the Pre-render command to automate the

last two phases.

See also

“To change render settings” on page 604

To use the Pre-render command
The Pre-render command provides an easy way to flatten nested compositions, greatly shortening preview times.

The command opens the render queue and creates a render item for the selected composition with Import and

Replace Usage selected as the Post-Render Action option.

1 Select the composition in the Project or Composition panel.

2 Choose Composition > Pre-render. Adjust the settings as necessary, and render the footage.

To edit a prerendered composition
1 In the Project panel, click the proxy indicator for the prerendered composition until it displays an empty box.

This turns off the proxy so that After Effects uses the actual composition in the project.

2 In the Project panel, double-click the composition from which the proxy movie was rendered.

3 Edit the composition.

4 Save the project.
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5 Render the composition into a movie again, using the same filename as the previous version of the movie.

6 After rendering is complete, set up the movie as a proxy for the composition. The next time you view the compo-

sition containing the movie, the new movie is displayed.

To precompose layers
Precomposing is an easy way to nest layers within an existing composition. Precomposing moves the layers to a new

composition. This new composition takes the place of the selected layers—something that does not occur in

ordinary nesting. When you want to change the order in which layer components are rendered, precomposing is a

quick way to create intermediate levels of nesting in an existing hierarchy.

Precomposing also places the new composition in the Project panel, available for use in any composition.

1 In the Timeline panel containing the layers you want to precompose, select the layers.

2 Choose Layer > Pre-compose.

3 Select Leave All Attributes In or Move All Attributes Into The New Composition, and then click OK.

Leave All Attributes In Leaves the selected layer properties and keyframes in the original composition. The frame

size of the new composition is the same as that of the selected layer. Select this option when you do not need to

change the rendering order, such as when you precompose layers only to simplify or reuse a composition, not to

change the rendering order of layer properties. This option is not available when you select more than one layer or

a text layer. When you use this option, changes you applied to the properties of the original layer are still applied to

that layer in the original composition.

Move All Attributes Into The New Composition Moves the properties and keyframes of one or more selected layers

one level further from the main composition in the composition hierarchy. The frame size of the new composition

is the same as that of the original composition. Choose this option when you want to change the rendering order in

the selected layers, such as when you want to rotate a layer but not its drop shadow.
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Chapter 7: Previewing

Previewing compositions

Methods for previewing compositions
Adobe After Effects provides several methods for previewing compositions, including standard preview, RAM

preview, and manual preview. All three methods are accessible through the Time Controls panel.

The duration of a composition, a layer, or a footage item is represented visually by the time ruler. On the time ruler,

the current-time indicator indicates the frame you are viewing or editing, and the frame appears in the corresponding

panel.

In a Layer or Footage panel, the time ruler appears near the bottom of the panel. For a Composition panel, the time

ruler appears in the corresponding Timeline panel. Keep in mind that the time rulers in different panels represent

different durations. The time ruler in Layer and Footage panels represents the duration of the contents of that panel,

in contrast to the time ruler in the Timeline panel, which represents the duration of the entire composition.

Current-time indicator in the Timeline panel (left) and in the Layer panel (right)

Similar to the absolute time navigator in the Timeline panel, the Layer and Footage panels include time-view

brackets that you can use to magnify or shrink the part of the time ruler displayed.

Note: To display the Time Controls panel, choose Window > Time Controls.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

To preview a composition using standard preview
Standard preview (commonly called spacebar play) plays your composition from the current-time indicator to the

end of the composition. Standard previews usually play more slowly than real time; they play at a speed as close to

real time as possible using the current settings of the layer switches, composition switches, Fast Preview options, and

composition resolution. Standard preview is useful when your composition is simple or in its early stages and doesn’t

require additional memory for displaying complex animations, effects, 3D layers, cameras, and lights.

1 In the Timeline panel, make sure that the video switch is selected for the layers you want to preview.

2 Do one of the following:

• Click the Play button  in Time Controls.

• Press the spacebar to start; press the spacebar again to stop.
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See also

“Caches” on page 637

To preview a composition using RAM Preview
RAM Preview allocates enough RAM to play the preview (with audio) as fast as the system allows, up to the frame

rate of the composition. Use RAM Preview to play the footage in the Timeline, Layer, or Footage panel. The number

of frames played depends on the amount of RAM available to the application.

In the Timeline panel, RAM Preview plays either the span of time you specify as the work area or from the beginning

of the Timeline. In the Layer and Footage panels, RAM Preview plays only untrimmed footage. Before you preview,

check which frames are designated as the work area.

1 Do one of the following:

• To preview footage in the Timeline panel, make sure that the Video switch is turned on for the layers you want to

preview, and set the work area to the time span you want to preview.

• To preview footage in a Layer or Footage panel, make sure that the layers you want to preview have not been

trimmed.

2 To preview audio with video, click the Audio button  in Time Controls.

3 In the Time Controls panel, choose RAM Preview Options or Shift+RAM Preview Options.

4 Set the Preview Options:

Frame Rate Either choose a desired frame rate from the list or type a frame rate in the box. Choose Auto to have

After Effects use the composition frame rate.

Skip Type the number of interim frames you want to remain unrendered. For example, if you type 2, After Effects

renders the first frame and then each third frame following.

Resolution Choose an option from the list. Choose Auto to use the current composition resolution.

From Current Time Start RAM Preview from the current time. If no work area is defined, the RAM Preview will start

from the beginning of the Timeline.

Full Screen Play RAM Preview on a black screen at the composition size.

5 Set the number of times the composition will play by clicking the Loop button until it displays the desired state:

Loop Preview loop continuously.

Play once Preview plays once.

Ping pong Preview plays forward and then backward continuously.

6 Do one of the following:

• To have RAM Preview play using the RAM Preview Options settings, click the RAM Preview button , or choose

Composition > Preview > RAM Preview.

• To have RAM Preview play using the Shift+RAM Preview Options settings, Shift-click the RAM Preview

button .

7 To stop RAM Preview, press the spacebar.
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Note: The more detail and precision you want to see, the more RAM is required for RAM Preview. You can control the

amount of detail shown in either the standard or RAM Preview by changing the resolution, magnification, and preview

quality of your composition. You can also limit the number of layers previewed by turning off the video switch for certain

layers, or limit the number of frames previewed by adjusting the composition’s work area.

Time Controls panel

See also

“Caches” on page 637

“To set a work area” on page 121

“Audio/Video and Layer switches” on page 167

“About trimming” on page 162

To preview a composition using manual preview
Do any of the following:

• To go forward one frame, click the Next Frame button .

• To go forward ten frames, Shift-click the Next Frame button.

• To go backward one frame, click the Previous Frame button .

• To go backward ten frames, Shift-click the Previous Frame button.

• To go to the beginning of the composition, layer, or footage item, click the First Frame button .

• To go to the end of the composition, layer, or footage, click the Last Frame button .

• To scrub the composition in the Timeline panel, drag the current-time indicator.

• To go to a specific frame, choose View > Go To Time, or click the current-time display in a Footage, Layer,

Composition, or Timeline panel. Type a new time and click OK.

Previewing audio
When you preview audio, you control the quality and length of the preview. The audio preview preferences you set

do not affect rendering; the quality of audio in rendered video is determined by the output module setting.

While previewing audio, After Effects displays clipping signals that indicate when the audio is clipping. Clipping is

a distortion that occurs when the audio signal exceeds the maximum level that the audio device allows.

After Effects also displays a volume unit (VU) meter that actively displays audio levels during playback. To view the

VU meter and levels controls in more detail, increase the height of the Audio panel.
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Audio panel
A. VU meter B. Level controls C. Level units D. Audio Options menu E. Level values

Note:After Effects does not support audio in Type1 DV AVI files. Attempting to scrub (manually preview) audio in these

files may cause a long delay.

See also

“To change output module settings” on page 607

To set display options for the Audio panel

1 In the Audio panel, click the triangle in the upper-right corner and choose Options.

2 In the Audio Options dialog box, select one of the following:

Decibels Displays audio levels as decibels.

Percentage Displays audio levels as a percentage, where 100% equals 0 dB.

3 From the Slider Minimum menu, select the minimum decibel level you want to display in the Audio panel, and

then click OK.

To set preferences for audio preview

1 Choose Edit > Preferences > Previews (Windows) or After Effects > Preferences > Previews (Mac OS).

2 In the Audio Preview section, type a duration for the audio preview. An audio preview begins at the current-time

indicator and continues for the duration you specify here. This option is useful when you are checking short passages

of a composition.

3 Choose an audio sample rate from the first menu.

4 Choose an audio sample size from the second menu.

5 Choose Stereo or Mono playback from the third menu.

6 Click OK.

CD-quality sound is 44.1 KHz, 16-bit stereo. However, to reduce the time and memory required to preview, you may

want to choose a lower bit depth and sample rate.

To preview audio

1 In the Composition or Timeline panel, move the current-time indicator to the time where you want the preview

to begin.

2 Choose Composition > Preview > Audio Preview (Here Forward), or press the period key (.) on the numeric

keypad.

A

CB

E

D
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Note: To preview audio in the work area, select the layer and press Alt+period (Windows) or Option+period (Mac OS).

To preview audio and rendered images

1 If the Time Controls panel is not open, choose Window > Time Controls. Select RAM Preview Options, and then

do one of the following:

• If From Current Time is selected, move the current-time indicator in the Timeline panel to the time at which you

want the preview to begin.

• If From Current Time is not selected, set the work area for the area you want to preview.

2 Click the Audio button .

3 If needed, click the Loop button repeatedly to select the preview direction you want: looping from start to

finish , single play (forward) , or cycling forward and backward .

4 Click the RAM Preview button  or press 0 on the numeric keypad.

See also

“To set a work area” on page 121

“To preview a composition using RAM Preview” on page 135

To preview composition audio

You can preview (scrub) audio by dragging the time marker in a composition. Use this technique to easily identify

and mark a location to synchronize audio and visual effects. Instead of using the audio waveform, you can identify

a location in the layer by moving the current-time indicator in the Timeline panel and listening to audio playback.

❖ In the Timeline panel, hold down Ctrl (Windows) or Command (Mac OS) while you move the current-time

indicator.

As you drag across time, After Effects plays segments of the audio. You can play the audio forward or backward. If

you stop moving the current-time indicator while keeping the mouse button depressed, a short section of audio will

loop.

Preview modes

About preview modes
The preview modes provide different balances between quality and speed. All of the preview modes are available for

standard, manual, or RAM previews, and are accessed by clicking the Fast Previews button  in the Composition

panel, by selecting menu options, or by clicking the various playback mode buttons in the Timeline.

To use OpenGL for previews
OpenGL is a set of standards for delivering high-performance 2D and 3D graphics for a wide variety of applications.

For After Effects users, OpenGL provides high-quality previews that require less rendering time than other playback

modes. OpenGL can also be used to speed up final render times for your project.

OpenGL provides fast screen previewing of a composition without degrading resolution. This makes OpenGL the

most desirable preview option for most situations.
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When OpenGL does not support a feature, it simply creates a preview without using that feature. For example, if your

layers contain shadows and your OpenGL hardware does not support shadows, the preview will not contain

shadows.

To get the full benefit of OpenGL in After Effects, you’ll need an OpenGL card that supports OpenGL 2.0 and has

Shader support and support for NPOT (Non Power of Two) textures. The minimum requirement for using OpenGL

with After Effects is a card that supports OpenGL 1.5. When you first start After Effects, it will attempt to determine

if your OpenGL card meets the requirements, and enables or disables OpenGL as appropriate.

You can view information about your OpenGL card, as well as enable or disable OpenGL, by choosing Edit >

Preferences > Previews (Windows) or After Effects > Preferences > Previews (Mac OS). Click the OpenGL Info

button to learn more about your card.

Note:When you choose Edit > Preferences > Memory & Cache, you’ll see a checkbox labeled Prevent DLL Address Space

Fragmentation, which is toggled on by default. This is to give After Effects access to more contiguous memory on systems

with large amounts of RAM; however, it may be incompatible with some OpenGL drivers, which cancause it to crash on

launch. Should this occur, this option will become unchecked automatically to prevent further crashes when you launch

After Effects.

OpenGL hardware supports layers up to 2048 x 2048 pixels. After Effects downsamples larger layers during OpenGL

preview. Complex effects can slow down OpenGL preview. If the preview is too slow, turn off OpenGL and use

another preview method.

Note: OpenGL works with 8 and 16 bpc projects only.

1 Choose Edit > Preferences > Previews (Windows) or After Effects > Preferences > Previews (Mac OS).

2 Select Enable OpenGL, and click OK.

3 Click the Fast Previews button  in the Composition panel.

4 Do one of the following:

• Select OpenGL—Interactive from the menu to use OpenGL only for interactions, such as manual previewing

(scrubbing) in the Timeline panel or dragging a layer in the Composition panel. You can tell that OpenGL is

engaging by looking at the Fast Previews icon, which will light up.

• Select OpenGL—Always On to use OpenGL for all previews. In this mode, “OpenGL” will appear in the upper left

corner of the Composition panel.

To adjust hardware settings for OpenGL previews

1 Choose Edit > Preferences > Previews (Windows) or After Effects > Preferences > Previews (Mac OS).

2 Click OpenGL Info.

3 Enter a value for Texture Memory of no more than 80% of the installed video RAM (VRAM) on your video card.

4 Choose one of the following items from the Quality menu:

Faster Reduces the quality of OpenGL previews to increase performance.

More Accurate Includes blending modes in the preview and improves the quality of lighting, shading, and blending.

In some cases—depending on your card and composition complexity—this mode can be faster than Faster mode.

Note: Mac OS provides the total amount of Texture Memory available on the display card in the OpenGL Info panel;

Windows does not.
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Supported OpenGL features

OpenGL preview in After Effects supports the following features:

• Shadows, except point light shadows (Colored shadows appear gray.)

• Lights (eight maximum)

• Masks

• Alpha channels

• Track mattes

• Intersecting layers

• Transformations for 2D and 3D layers

• GPU-accelerated effects, including Brightness & Contrast, Color Balance, Curves, Hue/Saturation, Levels,

Gaussian Blur, Fast Blur, Sharpen, Channel Blur, Directional Blur, Tint, Invert, Alpha Levels, and Noise.

OpenGL preview in After Effects also supports the following features when OpenGL Quality is set to More Accurate:

• All blending modes except Dissolve and Dancing Dissolve

• Metal property settings for 3D layers

• Cone feather settings for light layers

• 2D motion blur

• Adjustment layers

• Antialiasing

Feature support in After Effects is also dependent on the OpenGL hardware; contact the hardware manufacturer for

details. For information regarding specific OpenGL hardware, see the After Effects section of the Adobe website.

To use Wireframe for previews
Wireframe mode represents each layer as a simple rectangle, which increases playback speed and allows you to

reposition a high-resolution or data-intensive layer quickly. If a still-image layer has a mask or an alpha channel

created in another program, the layer is represented by the outline of the mask or alpha channel. You can apply

Wireframe mode to a single Composition view without affecting other views of the same composition.

❖ Click the Fast Previews button in the Composition panel and select Wireframe from the menu.

To use Adaptive Resolution for previews
The Adaptive Resolution setting decreases the preview resolution of layers when necessary to maintain playback

speed. Use this option when you want to preview complex or animated effects or when you want to preview movies

and layers that require extensive memory.

1 Choose Edit > Preferences > Previews (Windows) or After Effects > Preferences > Previews (Mac OS).

2 From the Adaptive Resolution Limit menu, choose the maximum reduction in size relative to the current compo-

sition resolution.

3 Click the Fast Previews button  in the Composition panel and select Adaptive Resolution from the menu.
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To use Freeze Layer Contents in the Composition panel
When OpenGL is enabled, layers that consist of moving images require significantly more memory on your OpenGL

card to preview than do still-image layers. Freeze Layer Contents speeds playback by showing only the first frame

encountered in a layer.

❖ Click the Fast Previews button in the Composition panel, and choose Freeze Layer Contents.

To enable or disable Live Update mode
When you disable Live Update mode, After Effects displays wireframe representations instead of the actual layer

while you move the layer in the Composition panel. The layer appears again after you stop moving it.

Do one of the following:

• To enable or disable Live Update mode, click the Live Update button  in the Timeline panel.

• To temporarily disable or enable Live Update mode, hold down Alt (Windows) or Option (Mac OS) as you move

a layer or as you drag the current-time indicator.

To enable or disable Draft 3D mode
Draft 3D mode disables all lights and shadows that fall on 3D layers. It also disables the camera’s depth-of-field blur.

❖ Click the Draft 3D mode button  in the Timeline.

See also

“About cameras” on page 180

“Camera settings” on page 181

Modifying views

Changing magnification in panels
The lower left corner of a Composition, Layer, or Footage panel shows the current magnification. By default, the

magnification is set to fit the current size of the Composition panel. When you change magnification, you change

the appearance of the pixels in the panel, not the actual resolution of the composition.

To zoom in

Do one of the following:

• Select the Zoom tool . Click the area in the panel you want to magnify. Each click additionally magnifies the

image, centering the display on the point you click. You can also drag the tool to magnify a specific area.

• Choose View > Zoom In. Choose this command again to additionally magnify the image. When the panel reaches

its maximum magnification level, the command has no effect.

• Choose a zoom level from the Magnification Ratio menu at the bottom left of the Footage, Layer, or Composition

panel. To change the magnification of all views in the Composition panel, hold down Ctrl (Windows) or

Command (Mac OS) while choosing a zoom level from the menu. Choose Fit to make the image fit the current

size of the Composition panel. Choose Fit Up To 100% to limit the zoom level to 100%.
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To zoom out

Do one of the following:

• Select the Zoom tool. Alt-click (Windows) or Option-click (Mac OS) the center of the area in the panel you want

to reduce. Each click additionally reduces the image. When the file has reached its maximum reduction level, the

command has no effect.

• Choose View > Zoom Out. Choose this command again to additionally reduce the image. When the panel reaches

its maximum reduction level, the command has no effect.

• Choose a zoom level from the Magnification Ratio menu at the bottom left of the Footage, Layer, or Composition

panel. To change the magnification of all views, hold down Ctrl (Windows) or Command (Mac OS) while

choosing a zoom level.

To zoom to preset magnifications

❖ To change the view to 100%, double-click the Zoom tool in the Tools panel.

To view and use safe zones and grids
In the Footage, Layer, and Composition panels, you can display safe zones for titles and actions as well as grids used

for aligning layers.

Television sets enlarge a video image and allow some portion of its outer edges to be cut off by the edge of the screen.

This is known as overscan. The amount of overscan is not consistent between television sets, so you should keep

important parts of a video image, such as action or titles, within margins known as safe zones. When you arrange

layers in a composition, keep in mind the following guidelines:

• Keep important scene elements, graphics, and actors within the action-safe zone.

• Keep titles and other text within the title-safe zone.

After Effects also provides grids that you can use to help arrange and align layers.

Composition panel’s zones and grids
A. Grid B. Title-safe zone C. Action-safe zone D. Overscan

❖ Do one of the following:

• To view safe zones in a Footage, Layer, or Composition panel, click the Title/Action Safe button  and select

Title/Action Safe from the menu.

• To view a standard grid, click the Title/Action Safe button and select Grid from the menu.

A

B

C

D
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• To view a proportional grid, click the Title/Action Safe button and select Proportional Grid from the menu.

• To snap a layer to a grid, with a Footage, Layer, or Composition panel active and the grid shown, choose View >

Snap To Grid, and then drag a layer until it snaps to the desired grid lines.

To change safe-zone margins and grid spacing
You can change the portion of the composition marked as title-safe or action-safe, and you can change the number

of grid cells. Safe-zone margins represent the percentage of image area not included in the safe area. You can set

spacing options for standard grids or proportional grids. The size of proportional grids increases or decreases when

the composition size changes; the size of standard grid squares remains the same regardless of composition size.

Note: By default, the title-safe and action-safe zones are set to conform with industry standards, so it’s probably best to

leave them at their default values.

❖ Choose Edit > Preferences > Grids & Guides (Windows) or After Effects > Preferences > Grids & Guides (Mac

OS), and then do any of the following:

• To change safe-zone margins, type values for Action-Safe and Title-Safe margins.

The title-safe or action safe percentage can be set to zero, which turns the margins off.

• To change grid spacing, type a value for Gridline Every, and then type a value for Subdivisions.

• To change proportional grid spacing, type Horizontal and Vertical values for Proportional Grid.

To work with rulers
You can display rulers along the sides of the Composition, Layer, and Footage panels to provide a visual guide for

positioning and editing your footage. You can change the origin, or zero point, in both rulers. By default, rulers are

hidden.

Note: Rulers and guide lines are only a reference in the Composition, Layer, and Footage panels. They do not appear in

your rendered movie.

• To show or hide rulers, choose View > Show Rulers or Hide Rulers.

• To set the zero point, drag the cross hair from the intersection of the two rulers (in the upper left corner) into the

image area.

Dragging the zero point cross hair

To create, reposition, lock, hide, or remove a guide line
For added precision in positioning objects, you can create guide lines. You can also lock guide lines to prevent them

from being repositioned.

Note: Rulers and guide lines are only a reference in the Composition, Layer, and Footage panels. They do not appear in

your rendered movie.

Do any of the following:

• Position the pointer inside either ruler and drag where you want to create a guide line.
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Dragging a guide from the ruler

• In the image area, drag a guide to reposition it.

• To lock or unlock guides, choose View > Lock Guides.

• In the image area, drag a guide line into a ruler to remove it.

• To show or hide all guide lines, choose View > Show Guides or Hide Guides.

• To remove all guide lines, choose View > Clear Guides.

To view a color channel or alpha channel
You can preview the red, green, blue, and alpha channels of a still image or movie in a Footage, Layer, or Composition

panel. When you view a color channel, areas with that color are displayed according to the color value of each pixel.

For example, if you view the red channel, areas with high red values are displayed as white.

To see the color values in a color channel displayed in the channel’s own color instead of white, choose the Colorize

option from the Show Channel menu.

When you preview the alpha channel, After Effects displays transparent and opaque areas as black and white to make

identification easier. Degrees of opacity appear as shades of gray.

1 Open the Composition, Layer, or Footage panel to view a channel for a composition, layer, or footage item, respec-

tively.

2 At the bottom of the panel, click the Show Channel button , then select RGB, Red, Green, Blue, or Alpha from

the menu.

3 To show the straight RGB values before being matted by the alpha channel, choose Show RGB Straight. In this

mode, areas with complete transparency are undefined and may contain random pixel colors.

Note: Alpha mode and RGB Straight mode do not show the checkerboard background.

All channels, color channels, and alpha channel

See also

“About alpha channels and mattes” on page 242

“About straight and premultiplied channels” on page 242
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To adjust exposure of HDR footage (Pro only)
You can adjust the exposure of HDR footage with the Exposure control . The Exposure control doesn’t affect how

footage will render when you export a movie, only how it appears in the Composition panel.

Note: The Exposure control is only available in a 32-bpc project.

Settings and tools for previewing

Taking and viewing a snapshot
When you want to compare one view to another in the Composition, Layer, or Footage panel, take a snapshot. For

example, you might want to compare two frames in different locations in a movie.

When working with snapshots, here are some tips to keep in mind:

• Snapshots taken in one kind of panel can be displayed in another kind. For example, you can take a snapshot of a

Layer panel and display the snapshot in the Composition or Footage panel.

• Displaying a snapshot does not replace the content of the panel.

• If the snapshot has a different size or aspect ratio than the panel in which you display it, the snapshot is resized to

fit the current view.

• Snapshots are for reference only and do not become part of the layer, composition, or rendered movie.

To take or view a snapshot

Do one of the following:

• To take a snapshot, click the Take Snapshot icon at the bottom of the panel. If you have a sound card installed,

a sound is generated when you take a snapshot.

• To view a snapshot, click and hold the Show Last Snapshot icon  at the bottom of the panel.

To take and view multiple snapshots

Do any of the following:

• Hold down Shift and press F5, F6, F7, or F8 to take separate snapshots.

• Press and hold F5, F6, F7, or F8 to view the corresponding snapshots.

• To purge a snapshot, hold down Ctrl + Shift (Windows) or Command + Shift (Mac OS) and press F5, F6, F7, or F8.

See also

“Keys for previewing” on page 646

To free memory used by all snapshots

❖ Choose Edit > Purge > Snapshot.
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Working with multiple viewers
In After Effects, you may need to work on multiple compositions or layers at once, or you may need to work with

multiple views of a single composition or layer. A type of panel called a viewer gives you added flexibility in arranging

your workspace to facilitate this kind of work. A viewer is a panel that can contain multiple compositions, layers, or

footage items. A menu in the viewer tab lets you switch between the open items. The Composition, Layer, Footage,

and Effect Controls panels all function as viewers.

Instead of housing multiple items in a single viewer and using the menu to switch between them, you can choose to

open a separate viewer for each open composition, layer, or footage item. When you have multiple viewers open, you

can arrange them by docking or grouping them together.

To create a new viewer

1 Click the tab at the top of a Composition, Layer, Footage, or Effect Controls panel.

2 Choose New Comp Viewer, New Layer Viewer, New Footage Viewer or New Effect Controls Viewer from the

menu.

To lock a viewer

Locking a viewer prevents the currently displayed item from being replaced when you open or select a new item.

Instead, when a viewer is locked and a new item is opened or selected, After Effects creates a new viewer panel for

that item.

1 Click the tab at the top of a Composition, Layer, Footage, or Effect Controls panel.

2 Choose Locked from the menu.

To edit one composition while viewing another, choose New Comp Viewer from the viewer tab menu to create a new

viewer that is locked to the current composition. Double-click other compositions to load your original viewer and

leave the new one unchanged. This procedure applies to Layer, Effect Controls, and Footage panels, as well.

To choose a viewer to preview
After Effects lets you designate any viewer as the default panel to preview. This is particularly useful when you have

a Composition viewer that represents your final output and you always want to preview that viewer even when you’re

changing settings in other panels.

When you start a RAM preview or standard preview, the viewer that’s set to always preview is the only one played.

When you preview to an external monitor, the external monitor displays only the viewer that’s set to always preview.

When you preview with tabbed Composition panels, the panel that’s set to always preview appears frontmost only

for the duration of the preview.

❖ Click the Always Preview This View button  in the bottom left corner of the viewer.

Note: When multiple views are open, previews use the frontmost composition view for 2D compositions and the Active

Camera view for 3D compositions. To turn off the Active Camera, deselect Previews Favor Active Camera in the Time

Controls menu.
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Previewing on an external video monitor
You can preview the contents of your Layer, Footage, or Composition panel on an external video monitor. This

requires additional hardware, such as a video digitizing card or a FireWire port. If you’re using a video digitizing card

to connect an external video monitor, follow the directions that came with your video digitizing card to connect the

monitor for viewing previews. If you’re using a FireWire port, first connect a digital camcorder or VCR to the port,

then connect the video monitor to the camcorder or VCR. For more information on setting up FireWire previews,

see the documentation that came with your digital camcorder or VCR.

1 Choose Edit > Preferences > Video Preview (Windows) or After Effects > Preferences > Video Preview (Mac OS).

2 Choose an external device from the Output Device menu. (If a device is available, it’s automatically listed in this

menu.)

3 Choose a mode from the Output Mode menu. The choices listed depend on the device you are using. The Frame

Size value that appears under the Output Mode menu is dependent on the value that you select from the Output

Mode menu, and is not dependent on any other After Effects settings.

4 Set any of the following options, and click OK:

Previews Displays RAM previews or standard previews only on the external monitor.

Mirror On Computer Monitor Displays RAM previews or standard previews simultaneously on the external monitor

and on the computer screen. This may slow down the previews.

Interactions Displays interactive previews, such as scrubbing in the Timeline panel or dragging in the Composition

panel, on the computer screen and simultaneously on the external monitor.

Renders Displays each frame on the computer screen and simultaneously on the external monitor as the frames

render in the render queue.

5 Select Scale And Letterbox Output To Fit Video Monitor if you are working with image sizes that don’t match your

preview device frame size, and you want to see the entire image scaled to fit.

After choosing an output device in the Video Preview preferences, you can preview the current frame on the output

device by pressing the forward slash (/) key on the numeric keypad. Hold down Ctrl (Windows) or Command (Mac

OS) and the forward slash (/) key on the numeric keypad to toggle the preference to Desktop Only or to the output device

you specified.

To view progress while previewing
While you preview a composition in a Composition or Layer panel, the Info panel displays the actual frame rate of

the current preview. When the preview’s actual frame rate is different from the Composition settings, the Info panel

displays “(NOT realtime)” after the reported frame rate; when it matches the Composition settings, the frame rate is

followed by “(realtime)”.

When previewing in a Composition panel, you can set a preference to display additional information in the Info

panel, including the name of the item being rendered at a given frame, and a report of what After Effects is doing,

such as retrieving a frame. In addition, the Project Flowchart View panel highlights items being rendered at each

frame during the preview. Once a frame has been rendered, After Effects instantly displays each frame from the

image cache, so the Info panel and Project Flowchart View panel only display the frame rate.

1 Choose Edit > Preferences > Display (Windows) or After Effects > Preferences > Display (Mac OS).

2 Select Show Rendering In Progress In Info Panel & Flowchart.
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See also

“Improving performance by modifying screen output” on page 640
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Chapter 8: Layers

Creating and adding layers

About layers
Layers are the components you use to build a composition. Any item that you add to a composition—such as a still

image, moving image file, audio file, light layers, camera layers, or even another composition—becomes a new layer.

Without layers, a composition consists only of an empty frame.

Using layers, you can work with specific footage items in a composition without affecting any other footage. For

example, you can move, rotate, and draw masks for one layer without disturbing any other layers in the composition,

or you can use the same footage in more than one layer and use it differently in each instance.

Four layers as viewed in the Timeline panel (left) and the Composition panel (right)

You can duplicate layers within a composition or even copy and paste layers from one composition to another. Use

as many layers as necessary to create your composition.

A layer can be any of the following:

• Any footage item in the Project panel list (including audio)

• Another composition in the project

• A text layer

• A solid, camera, or light layer

• An adjustment layer, which modifies all layers below it

• A duplicate of another existing layer

• A split layer

• A null object

After Effects automatically numbers all layers in a composition. By default, these numbers are visible in the Timeline

panel next to the layer name. The number reflects the position of that layer in the stacking order. When the stacking

order changes, After Effects changes all numbers accordingly.

Guide layers help you position or adjust the appearance of your other layers, but they don’t render to final output.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.
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See also

“About text layers” on page 283

“About 3D layers” on page 173

“About cameras” on page 180

“About lights and points of interest” on page 183

To create a layer from a footage item
Of the numerous ways to create layers in an After Effects composition, the most obvious is to begin with a footage

file that you want to use. You can create a new layer from any footage item in your Project panel, including audio

files. After you add a footage item to a composition, you can modify and animate the resulting layer.

To create multiple layers simultaneously, follow this procedure but hold down Ctrl (Windows) or Command (Mac

OS) and click to select footage files in step 3. When you drag them to the Timeline panel, the footage files form layers

in the order in which you selected them.

1 In the Project panel, double-click the composition you want to work on to open its Composition and Timeline

panels.

2 In the Timeline panel, move the current-time indicator to the time where you want the layer to begin.

3 Drag the footage item from the Project panel to the Composition panel.

Note: To position the new layer in a particular order among existing layers or at a specific starting time in the compo-

sition, drag the item to the Timeline panel and release it in that layer position and starting time instead of dragging it to

the Composition panel.

To create a layer from another composition
When you add a composition to another composition, it creates a new layer in a process called nesting. The compo-

sition you add becomes a layer in the other (target) composition. Nested compositions can change composition

structure, memory usage, and rendering order. (See “Organizing a project using nesting” on page 60.)

1 Display the Composition panel or Timeline panel for the target composition.

2 Drag a composition from the Project panel list to the target Composition panel or the Timeline panel.

See also

“About nesting” on page 130

To create a solid-color layer
You can create solid images of any color or size (up to 30,000 x 30,000 pixels) using After Effects. After Effects treats

solids as it does any other footage item: You can modify the mask, transform properties, and apply effects to the solid

layer. If you change settings for a solid that is used by more than one layer, you can apply the changes to all layers that

use the solid or to only the single occurrence of the solid. Use solid layers to color a background or create simple

graphic images.

1 Do one of the following:

• To add the layer to the Composition and Project panels, bring the Timeline or Composition panel forward, and

choose Layer > New > Solid.
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• To add the layer to just the Project panel, choose File > Import > Solid.

2 In the Solid Footage Settings dialog box, type a name for the layer or accept the color-based name supplied.

3 Under Size, do one of the following:

• Click the Make Comp Size button to make the layer’s dimensions the same as the composition’s dimensions. This

option isn’t available if you created the layer with the File > Import command.

• Type width and height dimensions for the layer. If necessary, choose new selections from the Units menu and the

Pixel Aspect Ratio menu.

4 Under Color, set the color of the layer in one of the following ways:

• Use the Color Picker: Click the color swatch, select the color you want, and click OK.

• Use any color visible on the screen: Click the Eyedropper , and then click the color you want.

5 Click OK.

6 In the Timeline panel, drag the new solid layer to any position above or below, as needed.

Note: After Effects stores all solids in the Solids folder in the Project panel. When you create a solid for the first time,

After Effects creates the Solids folder.

See also

“To change settings for a solid used by more than one layer” on page 161

To create a light or camera layer
You can use light and camera layers to create interesting results for the 3D layers in a composition.

1 With the Composition or Timeline panel active, choose Layer > New > Camera, or Layer > New > Light.

2 In the Camera or Light Settings dialog box, select the settings you want, and then click OK.

See also

“About cameras” on page 180

“About lights and points of interest” on page 183

“To select a color with the Color Picker” on page 327

About adjustment layers
When you apply an effect to an ordinary layer, the effect applies only to that layer and no others. However, an effect

can exist independently if you create an adjustment layer for it. Any effects applied to an adjustment layer affect all

layers below it in the composition stacking order. An adjustment layer at the bottom of the stacking order has no

visible result.

Because adjustment layer effects apply to all layers beneath them, they are useful for applying effects to many layers

at once. In all other aspects, an adjustment layer behaves exactly like other layers; for example, you can use keyframes

or expressions with any adjustment layer property. You can also create masks on adjustment layers.
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See also

“Applying and controlling effects” on page 348

“About expressions” on page 555

“About masks” on page 243

To create a new adjustment layer

1 Display the Composition or Timeline panel to which you want to add an adjustment layer.

2 Choose Layer > New > Adjustment Layer. A new adjustment layer appears at the top of the Timeline panel.

3 Apply one or more effects to the adjustment layer.

Note: Transformations on adjustment layers behave slightly differently; they transform only the matte but not the fill.

See also

“Applying and controlling effects” on page 348

To convert a layer to an adjustment layer

1 In the Timeline panel, select the name of the layer you want to convert to an adjustment layer. (Typically, this layer

already has effects applied to it, but you can add effects after making it an adjustment layer.)

2 Choose Layer > Switches > Adjustment Layer.

If you want to apply an effect to just part of an image, draw a mask on an adjustment layer. The mask restricts the

area to which the effect applies. You can animate the mask to follow a moving subject.

See also

“Creating masks” on page 244

To create a new Photoshop layer
1 Open the composition to which you want to add an Adobe Photoshop layer.

2 Choose Layer > New > Adobe Photoshop File.

3 Enter a name for the file, and click Save.

Photoshop starts and opens a new file with a blank layer that has the same dimensions as your composition, with the

appropriate title-safe and action-safe guides. The Photoshop layer is added as the top layer in your composition. Any

changes you make in Photoshop appear in your After Effects composition after you save the changes in Photoshop.

Note: You can also create a new Photoshop file with your composition’s dimensions without adding it to a composition

by choosing File > New > Adobe Photoshop File. The Photoshop file appears in the Project panel and has the dimensions

of the most recently opened composition.
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Selecting and arranging layers

To select one or more layers
Do any of the following:

• To select a layer, click the layer’s name or duration bar in the Timeline panel or the layer’s name in the Flowchart

panel.

• To select a layer, right-click (Windows) or Control-click (Mac OS) over the layer in the Composition panel, and

choose Select > [layer name].

• To select a layer if the layer is open in its own Layer panel, choose the layer name from the Window menu, or click

the tab of its Layer panel.

• To select a layer by position number, press the layer number on the numeric keypad. If the layer number has more

than one digit, type the numbers quickly so that After Effects can recognize them as a unit.

• To select all layers, choose Edit > Select All while the Timeline or Composition panel is in the foreground. To

deselect all layers, choose Edit > Deselect All.

• To deselect any currently selected layers and select all other layers; with at least one layer selected, choose Invert

Selection from the context menu in the Composition or Timeline panel.

• To select all layers that use the same color label, click the layer’s color label in the Timeline panel, and choose Select

Label Group, or select the layer and choose Edit > Label > Select Label Group.

• To select all child layers assigned to a parent layer, select the parent layer and choose Select Children from the

context menu in the Composition or Timeline panel. The child layers are added to the existing selection.

Note: Selected layers that also have properties selected are indicated with a hollow highlight; to deselect a layer's

properties, leaving only the layer itself selected, click on the layer. A selected layer that has no properties selected is

indicated with a solid highlight.

See also

“About parent and child layers” on page 208

To change the layer stacking order
The Timeline panel displays the layer stacking order. The uppermost layer in the composition appears at the top of

the layer outline list, the second layer is immediately below it, and so on. Changing the order of footage layers

modifies the appearance of your composition by repositioning footage in front of or behind other footage.

Changing the position of an adjustment layer in the stacking order changes which layers it affects, because an

adjustment layer affects only the layers below it.

Because of their depth properties, the stacking order of 3D layers in the Timeline panel does not necessarily reflect

their position in the Composition panel.

Do one of the following:

• In the Composition or Timeline panel, select the layer. Choose Layer and then choose Bring Layer Forward, Send

Layer Backward, Bring Layer To Front, or Send Layer To Back.

• In the Timeline panel, select the layers you want to move by name, and drag the name up or down the stacking

order.
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Note:As you drag a layer name up or down, a horizontal line appears between other layer names, indicating the position

to which the layer will move if you release the mouse.

See also

“About 3D layers” on page 173

“Default rendering order” on page 593

To align or distribute layers in 2D space
Use the Align panel to line up or evenly space selected layers across a composition. You can align or distribute layers

along the vertical or horizontal axes of selected objects.

1 Select the layers you want to align or distribute.

2 Choose Window > Align & Distribute.

3 In the Align panel, click the icon representing the type of alignment or distribution you want.

Note: To align, you must select two or more layers; to distribute, you must select three or more layers.

When you align and distribute selected layers, keep the following in mind:

• An alignment option aligns selected layers to the object that most closely represents the new alignment. For

example, for right-edge alignment, all selected layers align to the selected object that is farthest to the right.

• A distribution option evenly spaces selected layers between the two most extreme layers. For example, for a

vertical distribution option, the selected layers are distributed between the topmost and bottommost selected

objects.

• When you distribute layers of different sizes, the spaces between layers may not be uniform. For example, distrib-

uting layers by their centers will create equal space between the centers—but different-sized layers will extend by

different amounts into the space between layers.

• Locked layers cannot be moved by alignment or distribution options.

• Text alignment is not affected by the Align panel.

See also

“To align and justify text” on page 291

Placing a layer in time
Place a layer in time by changing its In or Out point in the Timeline panel. The In and Out columns represent the

layer duration numerically. The duration bar represents the layer duration visually.

To change the In and Out points of a layer numerically

1 Make the In and Out columns visible in the Timeline panel.

2 Click the number in the In or Out column of the layer you want to change.

3 In the Layer In Time or Layer Out Time dialog box, type a new time and click OK.

Note: Do not use this method to adjust the In and Out points in the Timeline panel if your aim is to trim, speed up, slow

down, or distort time within layer footage.
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See also

“About trimming” on page 162

“About time-remapping” on page 233

“About the Timeline panel” on page 118

To move a layer in time by dragging

❖ In the Timeline panel, drag the layer duration bar to the left or right. To snap the layer duration bar to significant

points in time (such as markers, or the start or end of the composition), Shift-drag the layer duration bar.

Note: When you drag a layer in the Timeline panel, the Info panel displays the name, duration, delta timecode, and In

and Out settings for the layer. To display the Info panel, choose Window > Info.

Before and after moving the duration bar

To move a layer in time by moving its In or Out point

1 In the Timeline panel, drag the current-time indicator to the time at which you want the layer to begin or stop

playing.

2 Make the In and Out columns visible in the Timeline panel.

3 In the In or Out column, Alt-click (Windows) or Option-click (Mac OS) the number that appears for that layer.

See also

“To work with columns in the Timeline panel” on page 119

To arrange a layer by dragging
You can change the spatial position of a layer in a composition by selecting and dragging the layer in the Compo-

sition panel. When you want to move a layer into or out of the frame, you can position it completely or partially

outside the frame.

When you arrange a layer in the Composition panel, you determine the position of the layer at the current time,

indicated by the current-time indicator in the Timeline panel. If no keyframes are set for a layer, the position values

you set will apply for the duration of the layer. The layer remains in position until you set up a change over time in

the Timeline panel.

1 Select the Selection tool from the Tools panel.

2 Click a layer in the Composition panel to select it or, if the layer is obscured by another layer, select the layer name

in the Timeline panel.

You can select layers behind other layers in a Composition panel. Using the Selection tool, right-click (Windows) or

Control-click (Mac OS) the top layer, choose Select, and then choose a layer name.

3 Position the pointer within the layer (but not on a handle) and drag the layer to a location within the Composition

panel.
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After you start dragging a layer, hold down Shift to constrain the dragging to horizontal or vertical movements, or

hold down Ctrl+Shift (Windows) or Command+Shift (Mac OS) to snap to the frame edges or center.

See also

“To change the layer stacking order” on page 153

“About the Composition panel” on page 116

“About keyframes” on page 192

To arrange layers as a sequence
Use the Sequence Layers keyframe assistant to automatically arrange layers in a sequence. When you apply the

keyframe assistant, the first layer you select remains in its initial time position, and the other selected layers move to

new positions in the Timeline panel based on the order in which you select them.

Layers selected in Timeline panel (left). Layers arranged in sequence after applying the Sequence Layers Keyframe Assistant (right).

You can specify whether the layers overlap or are arranged end to end. For overlapping layers, you determine how

long the layers overlap and whether they cut or cross-dissolve from one to the next. If you specify a cross-dissolve,

After Effects creates opacity keyframes that control how the layers dissolve into each other.

Overlapping layers can have opacity keyframes set automatically to create a cross-dissolve.

For a layer to be sequenced, its duration must be less than the length of the composition so that it leaves time for

other layers. If you’ve already imported still images that are the length of the composition, you can trim all of them

at once by selecting all of the still image layers, positioning the current-time indicator to set the duration you want

them to have, and pressing Alt+] (Windows) or Option+] (Mac OS).

1 In the Timeline panel, hold down Ctrl (Windows) or Command (Mac OS) and select layers in sequential order,

beginning with the layer you want to appear first.

2 Choose Animation > Keyframe Assistant > Sequence Layers.

3 In the Sequence Layers dialog box, do one of the following, and then click OK:

• To arrange the layers end to end, leave the Overlap option unselected.

• To overlap ends of layers, select the Overlap option and type a duration in timecode for how long the layers should

overlap.
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4 If you selected the Overlap option in step 3, select a Transition option to specify which layers’ opacity After Effects

adjusts to create cross-dissolves:

• If none of the selected layers uses an alpha channel or mask, select Dissolve Front Layer.

• If any of the selected layers uses an alpha channel or a mask, select Cross Dissolve Front And Back Layers.

Note: If you plan to sequence still-image footage that you haven’t imported yet, choose Edit > Preferences > Import

(Windows), or After Effects > Preferences > Import (Mac OS) before you import, and specify a short Still Footage

duration.

Copying and pasting layers and attributes
Through the copy and paste commands, you can manipulate and place layers and layer attributes. When copying and

pasting a layer in the Timeline panel, you can paste a layer’s In point to a specific time in the Timeline panel.

You can also copy keyframe attributes from one layer to multiple layers, or from one property to other properties on

a single layer—all in one operation.

See also

“Copying and pasting keyframes” on page 198

To copy a layer to the current time

1 In the Timeline panel, copy the layer or source footage.

2 Drag the current-time indicator to the time at which you want the layer to begin.

3 Press Ctrl+Alt+V (Windows) or Command+Option+V (Mac OS).

To duplicate a layer

When you duplicate a layer, After Effects copies all property keyframes, expressions, masks, and effects to the

duplicate. The duplicate is added above the original layer and automatically selected. If you want to duplicate a layer

without duplicating its keyframes, expressions, masks, and effects, add the original source footage file to the compo-

sition again.

❖ In the Project, Composition, or Timeline panel, select the layer and choose Edit > Duplicate.

Note: Track mattes retain their order, on top of the layer when you duplicate or split the layer.

Splitting layers
In the Timeline panel, you can split a layer at any point in time, creating two independent layers. This is a time-saving

alternative to duplicating and trimming the layer—something you might do when you want to change the stacking-

order position of the layer in the middle of the composition, such as an object revolving in front of and then behind

another object.

To split a layer

1 In the Timeline or Composition panel, select a layer.

2 In the Timeline panel, move the current-time indicator to the time where you want to split the layer.

3 Choose Edit > Split Layer.

When you split a layer, both resulting layers contain all the keyframes that were in the original layer in their original

positions. Any applied track mattes retain their order, on top of the layer.
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After you split a layer, the duration of the original layer ends at the point of the split, and the new layer starts at that

point in time.

To set the default stacking position of split layers

1 Choose Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS).

2 Select Create Split Layers Above Original Layer to make new split layers appear above the original layer in the

Timeline panel, or deselect this option to make them appear below the original layer.

Managing layers

To rename a layer
By default, the layer outline in the Timeline panel uses the source footage names for layers. You can rename any layer

at any time. Unique layer names can help you identify layers when you use the same source footage for more than

one layer.

1 In the Timeline panel’s layer outline, select the layer you want to rename.

2 Press Enter (Windows) or Return (Mac OS) and type a new name.

3 Press Enter or Return again to apply the new name.

Note: To switch between displaying the original file name and the layer name you’ve specified, click the Source Name or

Layer Name heading.

See also

“About the Timeline panel” on page 118

To see a layer source name in the Info panel
After Effects can display the source file name in the Info panel, which is useful when the source footage is a still-

image sequence, because each still image has a different file name.

1 Choose Window > Info if the Info panel is not already open.

2 In the Timeline panel, select the layer.

3 Press Ctrl+Alt+E (Windows) or Command+Option+E (Mac OS). The name of the source footage appears in the

Info panel.

See also

“About the Info panel” on page 22

Changing layer color labels
The Timeline panel uses different colored boxes as labels to indicate different kinds of layers, such as compositions

or source footage layers. Layer handles and motion paths display the label color of the layer. Use the Edit > Label

submenu to select all layers of a particular type, either by a specific label color or to match the current layer selection

(using the Select Label Group command).
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You can customize the label colors at any time for an individual layer, for all similarly labeled layers in a composition,

or at the default level.

To change the color of a label

1 In the Timeline panel, select a layer.

2 Choose Edit > Label > [color name].

To change the color of a label group

1 In the Timeline panel, select one of the layers belonging to the label group.

2 Choose Edit > Label > Select Label Group.

3 Choose Edit > Label > [color name].

To change the default color label and options for a source type

1 Choose Edit > Preferences > Label Colors (Windows), or After Effects > Preferences > Label Colors (Mac OS).

2 Click a color swatch or Eyedropper button, select new colors to replace the existing colors, and type new names

for the colors as needed.

3 Click Next, or click the Label Colors menu and choose Label Defaults.

4 Using the menus for each type of composition element (Composition, Video, Audio, and so forth), choose new

default colors. When you finish, click OK.

To show or hide layers in the Composition panel
Use the Video switch to exclude or include layers in the Composition panel. The Video switch is on by default, so the

layer appears in the Composition panel. When you want to speed up redrawing or exclude a layer from appearing in

both the preview and the final output, turn off the Video switch.

Do one of the following:

• To show or hide a layer, click the Video  switch for a layer in the Timeline panel.

• To show or hide a layer, select the layer, choose Layer > Switches, and make sure that the Video switch is selected

(to display the layer) or deselected (to hide the layer).

• To show all layers, choose Layer > Switches > Show All Video.

• To hide all layers that are not selected in the Composition panel, choose Layer > Switches > Hide Other Video.

See also

“About the Composition panel” on page 116

“Audio/Video and Layer switches” on page 167

To show and hide layers in the Timeline panel
You can mark a layer as shy, or hidden from display, and then use the Hide Shy Layers button in the Timeline panel

to hide all shy layers in the Timeline panel layer outline. Making layers shy is useful when you want to make room

in the Timeline panel to show the layers and layer properties that you want to adjust.

The icon in the Switches column indicates whether a layer is shy  or not shy .



ADOBE AFTER EFFECTS 7.0
User Guide

160

Shy layers still appear in the Composition panel. If you want to hide or show layers in the Composition panel, use

the Video switch.

Do any of the following:

• To toggle a layer between shy and not shy, click the Shy switch for the layer, or select the layer in the Timeline panel

and choose Layer > Switches > Shy.

• To toggle between hiding and showing all shy layers, click to select or deselect the Hide Shy Layers button at the

top of the Timeline panel, or choose Hide Shy Layers from the Timeline menu.

See also

“About the Timeline panel” on page 118

“Audio/Video and Layer switches” on page 167

To lock or unlock a layer
The Lock switch prevents layers from being edited accidentally. When a layer is locked, you cannot select it in either

the Composition or Timeline panels. If you try to select or modify a locked layer, the layer flashes in the Timeline

panel.

When a layer is locked, the Lock icon appears in the Features column, which appears by default to the left of the

layer name in the Timeline panel.

Do one of the following:

• In the Timeline panel, click the Lock switch for the layer to place (lock) or clear (unlock) the Lock icon .

• Select one or more layers in the Timeline panel and choose Layer > Switches > Lock.

• To unlock all layers in the active composition, choose Layer > Switches > Unlock All Layers.

See also

“Audio/Video and Layer switches” on page 167

To solo a layer
You can isolate one or more layers for animating, previewing, or rendering by soloing. Soloing excludes all other

layers of the same type from the Composition panel. For example, if you solo a video layer, any lights and audio layers

are unaffected, so they appear when you preview or render the composition. However, the other video layers do not

appear. Soloing is useful for speeding up redrawing, previewing, and rendering for final output.

Do one of the following:

• In the Timeline panel, select the layers you want to isolate, and choose Layer > Switches > Solo. A check mark

indicates that the command is selected.

• Click the Solo icon  in the Switches column to the left of the layer names in the Timeline panel.

See also

“Audio/Video and Layer switches” on page 167
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To change settings for a solid used by more than one layer
1 Select a solid layer.

2 Choose Layer > Solid Settings.

3 Enter the new settings, and then do one of the following:

• Select Affect All Layers That Use This Solid to apply the changes to all layers that use the solid.

• Deselect Affect All Layers That Use This Solid to create a new solid without applying the change to other layers

that use the solid.

To convert a merged layered file to a composition
Do one of the following:

• To convert all instances of the footage, select the file in the Project panel, and choose File > Replace Footage >

With Layered Comp.

• To convert only one instance of the footage, select the layer in the Timeline panel, and choose Layer > Convert To

Layered Comp.

Note: It may take a few moments to convert a merged file to a layered composition.

Guide layers

About guide layers
You can use rulers, guide lines, safe zones, and grids in your layers and compositions to help you position and edit

your footage. You can also create guide layers from existing layers to use for reference in the Composition panel. For

example, you can use guide layers for visual reference, for audio timing, for timecode reference, or for storing

comments to yourself.

By default, guide layers aren’t rendered when you create output but can be rendered when desired by changing the

composition’s render settings.

Note: Guide layers in nested compositions can’t be viewed in the parent composition.

See also

“About the Composition panel” on page 116

To convert a layer to a guide layer
1 Select the layer.

2 Choose Layer > Guide Layer. A guide layer icon  appears next to a guide layer’s source or layer name in the

Timeline panel.

To not render guide layers with a composition
1 In the Render Queue panel, click the Render Settings value to display the Render Settings dialog box.

2 Choose All Off from the Guide Layers menu.
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To render visible guide layers with a composition
❖ In the Render Queue panel, do one of the following:

• Choose Current Settings from the Render Settings menu to render the composition using the composition’s

settings.

• Choose Custom from the Render Settings menu to display the Render Settings dialog box, and then choose

Current Settings from the Guide Layers menu.

Trimming

About trimming
You can trim (hide) footage at the beginning or end of a layer, changing which frames are first or last in the compo-

sition. The first frame to appear is called the In point, and the last frame is called the Out point.

Trimming a layer
A. Original In point B. Original Out point C. Out point after trimming D. Underlying (trimmed) footage or composition E. Original Out
point reference

When you use a footage item as a source for different layers, you can trim it differently in each layer. Trimming does

not alter the original source file.

Note: Trimming a still image layer changes the length of time the image appears in the composition; it does not crop the

image (affect what portion of the image appears).

To trim layer footage
You can trim by changing the In and Out points in the Layer panel or the Timeline panel, depending on what you

want to change.

In the Layer panel, In and Out points relate to time positions within source files, not the time at which the layer

appears in the composition. For example, if you want to show only specific frames of a movie, trim the movie footage

in the Layer panel. However, if you want to begin the movie at the first frame in the source file and then cut it at some

point in the play time, trim the Out point in either the Layer panel or the Timeline panel.

The numbers below the layer image indicate the In point and Out point relative to running the source file, and

the duration  (the difference between the In point and the Out point).

In the Timeline panel, the In and Out columns tell you at what points in the composition the footage appears. For

example, if you want a still image to appear at a specific point in the composition and then disappear again, trim the

image In and Out points in the Timeline panel.

Note: If the In and Out columns do not appear in the Timeline panel, click the Expand/Collapse icon at the bottom of

the Timeline panel.

A B C D E
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Do one of the following:

• Drag either end of the layer duration bar in the Timeline panel.

• Move the current-time indicator in the Layer panel to the time at which you want the footage to begin or end, and

then click the In  or Out  button to set the In or Out point.

Dragging the Out point of a layer duration bar.

A pale rectangle behind the layer duration bar represents the footage you trimmed.

Move the current-time indicator precisely in either the Layer or Timeline panel by choosing View > Go To Time.

See also

“About the Timeline panel” on page 118

To move a trimmed layer in time
After you trim a layer by setting In and Out points, you can adjust the duration position in two ways that have

different results.

Do one of the following:

• Drag the duration bar. If you drag the colored area of the duration bar, the trimmed footage starts and finishes

playing at a different point in time. The length of the play time and the frames that appear remain unchanged.

• Drag the dimmed outline. If you drag the pale rectangle behind the duration bar, the footage starts and ends at the

same point in time as the original position, but different frames appear. For example, if you drag the pale rectangle

to the left, then the In and Out points shift to later frames in the footage. (This is similar to a slip edit in common

editing applications.)

To remove a section of a layer
1 In the Timeline panel, adjust the work area to include only the portion of the layer or layers that you want to

remove:

• Move the current-time indicator to the time at which you want the work area to begin and press B on your

keyboard.

• Move the current-time indicator to the point where you want the work area to end, and press N.

2 Select the layers you want to remove a section from or turn on the Lock switch for any layers you do not want

affected by the extraction.

3 Do one of the following:

• To remove the section from all unlocked layers and leave a gap of the same duration as the removed section,

choose Edit > Lift Work Area.
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• To remove the section from all unlocked layers, choose Edit > Extract Work Area. The gap is closed by ripple

deletion.

Markers

About markers
Use composition-time markers and layer-time markers to mark important points in a composition or in a specific

layer. Composition-time markers are numbered, whereas layer-time markers use specified text labels. Markers also

make it easier to align layers or the current-time indicator with specific points in time: You can snap items to markers

when you drag them in the Timeline panel by holding down Shift as you drag.

Layer-time markers can also include a comment, a web link, or a chapter link. Comments appear only in the Timeline

panel. Web links initiate a jump to a web page in your browser. Chapter links initiate a jump to a chapter in a

QuickTime movie or in other formats that support chapter markers.

Composition-time markers appear on the time ruler in the Timeline panel. After Effects automatically numbers

them with a single digit that reflects the order in which you add them. You can place up to ten composition-time

markers within a composition. If you remove a marker, the other markers remain numbered as they were.

You can use layer-time markers to mark important points in a specific layer, to display comments in the Timeline

panel, and to link to a movie chapter or web page. After Effects lets you set the marker’s position in time and retains

layer-time markers when you render output to the AVI or QuickTime format.

Layer-time markers appear as small triangles on a layer-duration bar. You can have any number of layer-time

markers in a layer. You can also drag existing markers to new time locations or remove them, as needed. You can

double-click the layer-time marker at any time to view or modify its attributes.

Adobe Encore DVD can read chapter references in After Effects layer-time markers when you export to the AVI or

MPEG-2 file format. To be compatible with DVDs, make sure that markers are at least 15 frames apart.

Layer-time marker

Note: To snap the current-time indicator or layer duration bars to a marker, Shift-drag the current-time indicator or a

layer duration bar.

To add a composition-time marker
Do one of the following:

• Drag a composition-time marker from the Comp marker bin  to the desired point in the composition.
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Dragging a composition time marker from the Comp marker bin.

• Move the current-time indicator to the position you want to mark and press Shift + a number key (0-9) on the

main keyboard.

Note: If the number you press is already used by another composition-time marker, After Effects does not create a new

marker. Instead, it moves the existing marker with that number to the new position.

To move a composition-time marker
Do one of the following:

• Drag the composition-time marker to another position in the Timeline panel.

• Move the current-time indicator to the position you want, and then press Shift + the number of the composition-

time marker you want to move.

To remove a composition-time marker
❖ Drag the marker onto the Comp marker bin  on the Timeline panel.

Note: To delete markers on a layer, right-click (Windows) or Command-click (Mac OS) on a marker and choose Delete

This Marker or Delete All Markers from the menu that appears.

To add a layer-time marker
1 With the appropriate layer selected, move the current-time indicator to the frame you want marked.

2 Choose Layer > Add Marker.

3 Double-click the layer-time marker.

4 In the Marker dialog box, type a name or comment in the Comment box and click OK.

To move a layer-time marker
Do one of the following in the Timeline panel:

• Drag the layer-time marker to the desired time.

• Double-click the layer-time marker, and enter the desired time in the Marker dialog box.

To remove a layer-time marker
1 Press Ctrl (Windows) or Command (Mac OS) and move the pointer near the marker you want to remove.

2 When the pointer appears as a pair of scissors, click the layer-time marker.

Note: To delete all markers on a layer, right-click (Windows) or Ctrl-click (Mac OS) on a marker and choose Delete All

Markers from the menu that appears.
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Nesting compositions containing layer-time markers
If you add one composition to another, the original composition becomes a layer in the composition. All the nested

composition’s composition-time markers become layer-time markers in the timeline of the parent composition.

These markers are not linked to the original composition-time markers. Changes you make to the composition-time

markers in the original composition do not affect layer-time markers in the nested composition. For example, if you

remove one of the original composition-time markers, the corresponding layer-time marker for the nested compo-

sition remains in place.

See also

“Organizing a project using nesting” on page 60

To create a web link from a marker
When you create a marker, you can type a Uniform Resource Locator (URL) under Web Links in the Marker dialog

box to create an automatic link to that site. After Effects embeds this information within movies. When these movies

are included in web pages created by programs such as Adobe GoLive®, the embedded URL is recognized at playback,

initiating a jump to the specified URL. You can even target a specific frame within the site.

Web link markers work only with layer-time markers and supported output formats, such as QuickTime,

Macromedia Flash (SWF), and others.

1 Create a layer-time marker and then double-click it to open the Marker dialog box.

2 For web links, type the URL for the site.

3 To activate a specific frame in a site, type the file name of the frame for Frame Target and click OK.

To create a chapter link
You can also create a layer-time marker as a chapter reference point, similar to chapters used in CD-ROM and DVD

discs. Like the chapters of a book, a chapter link divides a movie into segments. Chapter links are supported in

QuickTime movies.

1 Create a layer-time marker and then double-click it to open the Marker dialog box.

2 For Chapter Links, type the chapter name and number (if available), and click OK.

To synchronize markers to audio
After Effects provides a quick way to add and label markers for significant points in a layer’s audio track, such as a

rhythmic beat in music or spoken words in dialogue. Once markers are created, you can use them to synchronize

video or other effects.

1 In the Time Controls panel, click the Audio button  and then click the RAM preview button .

2 At the points in time where you want to add a marker, press the multiply key (*) on the numeric keypad to create

a layer-time marker.

3 When previewing is complete, double-click a marker you just created, type a descriptive label in the Comment

box (such as a word being spoken at that time), and click OK. Repeat for any other markers you added.

See also

“Previewing audio” on page 136
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Switches

Audio/Video and Layer switches
The Timeline panel contains two kinds of switches: Audio/Video Switches and Layer Switches. By default, these

columns appear to the left (Audio/Video Switches) and right (Layer Switches) sides of each layer name, but you can

hide a column or arrange columns in a different order.

The Audio/Video Switches column includes the following switches:

Video Toggles layer visuals on or off.

Audio Toggles layer sounds on or off.

Solo Selects only the current layer for previewing, ignoring all others.

Lock Locks layer contents, preventing all changes.

The Layer Switches column contains the following switches:

Shy Hides the current layer when the Hide Shy Layers button is pressed.

Collapse Transformations/Continuously Rasterize Collapses transformations if the layer is a composition; contin-

uously rasterizes if the layer contains vector graphics or masks.

Quality Toggles options for layer preview quality.

Effects Toggles layer effects on or off.

Frame Blending Toggles frame blending on or off.

Motion Blur Toggles motion blur on or off.

Adjustment Layer Identifies the layer as an adjustment layer, which modifies all layers below it.

3D Layer Identifies the layer as a 3D layer, enabling three-dimensional movement, lighting, and effects.

Quickly change switches for multiple layers by clicking the switch for one layer and dragging up or down that column

for the adjacent layers.

By default, the Layer Switches column shares space in the Timeline panel with the Modes column, so one or the other

is visible—but not both. You can toggle between the two columns or show both columns simultaneously.

See also

“To work with columns in the Timeline panel” on page 119

To toggle the Switches, Modes, and Trim columns
❖ Click one of the following:

• The Switches button  to toggle the Switches column on or off.

• The Modes button  to toggle the Modes column on or off.

• The Trim button  to toggle the Trim column on or off.
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To prevent switches from operating through nested compositions
When you set the layer quality, enable motion blur, or enable frame blending switches in a composition with other

compositions nested within it, After Effects also sets these switches in the subordinate compositions. (The per-layer

motion blur and per-layer frame blending switches are not affected in subordinate compositions.)

If you do not want the switch settings you add to parent compositions to apply to the compositions nested within

them, deselect the preference:

1 Choose Edit > Preferences > General (Windows), or After Effects > Preferences > General (Mac OS).

2 Deselect the Switches Affect Nested Comps option, and click OK.

See also

“Organizing a project using nesting” on page 60

Using the Collapse Transformations/Continuously Rasterize switch
The Collapse Transformations/Continuously Rasterize layer switch  in the Timeline panel affects nested compo-

sitions and Adobe Illustrator files. However, it affects these layers differently.

When the layer source is a composition, this switch acts as the Collapse Transformations switch. Selecting it may

improve image quality and decrease viewing and rendering time.

When the layer source is an Adobe Illustrator file, this switch acts as the Continuously Rasterize switch. Selecting

this switch causes After Effects to rerasterize the Adobe Illustrator file for each frame, which improves image quality,

but also increases the time required for previewing and rendering.

The Continuously Rasterize switch is also useful when applying a mask to a solid. When masks or effects are applied

to a nested composition that has this switch set, the layers in that nested composition are first rendered on their own,

then masks and effects are applied, and then the result is composited into the main composition. This rendering

order means that the blending modes of the nested layers are not applied to any underlying layers in the main compo-

sition, and that 3D layers above and below the collapsed layer cannot intersect or cast shadows on one another.

To toggle this switch, do one of the following:

• In the Timeline panel, click the Collapse Transformations/Continuously Rasterize switch.

• Select a layer, choose Layer > Switches, and make sure that the Collapse command is selected (to turn it on), or

deselected (to turn it off).

See also

“About 3D layers” on page 173

“About nesting” on page 130

“Frame blending” on page 238

To change the layer image quality
❖ Select the layer in the Timeline panel, and then do one of the following:

• Click the Layer Quality switch.
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• Choose Layer > Quality, and then choose an option:

Best Displays and renders a layer using subpixel positioning, anti-aliasing, 3D shading, and complete calculation of

any applied plug-in effects. Best provides the slowest display and rendering time.

Draft Displays a layer so that you can see it, but only at rough quality. It displays and renders a layer without anti-

aliasing and subpixel positioning, and some effects are not precisely calculated. Draft quality is often the most useful

setting for general work and for video layers (to avoid blurring when matching compositions to raw video footage).

Wireframe Displays a layer as a box with an X across it. Layer wireframes are displayed and rendered faster than

those rendered with Best or Draft settings. However, layer contents or masks are not visible—only position and size.

Because of this limitation, wireframe quality is available only from the Layer menu.

You can set the default quality of new layers in General preferences; select or deselect Create New Layers At Best

Quality. (If this option is deselected, the default quality is Draft.) Duplicated or split layers retain the Quality setting

of the original layer.

See also

“To use Wireframe for previews” on page 140

To show and hide effects
Using the Effect switch , you can control whether a layer’s effects appear in both previews and rendered versions.

When you deselect this switch, the layer is displayed and rendered without its effects, saving previewing and

rendering time. This switch is available only if a layer has effects applied to it.

Do one of the following:

• In the Timeline panel, click the Effect switch for a layer to toggle between showing and hiding effects.

• Select a layer, choose Layer > Switches, and make sure that the Effect command is selected (to show effects) or

deselected (to hide effects).

Note: You can temporarily turn on or off an individual effect applied to a layer.

See also

“About rendering” on page 590

Enhancing time-altered motion by blending frames
Use the Frame Blending switch to enhance the quality of time-altered motion in a layer that contains live-action

footage—video, for example. You can apply frame blending to a sequence of still images, but not to a single still

image. If you are animating a layer—for example, moving a layer of type across the screen—use the Motion Blur

switch .

See also

“To apply frame blending to a layer” on page 239

“To enable or disable Frame Blending for previewing and rendering” on page 239

“About motion blur” on page 214

“To change render settings” on page 604
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“Time-stretching” on page 231

“About time-remapping” on page 233

Using three dimensions
Use the 3D switch to turn a layer into a 3D layer that you can manipulate in three dimensions. When you select the

3D switch for a layer, you can add camera and light layers to take full advantage of the additional dimension.

See also

“About cameras” on page 180

“About lights and points of interest” on page 183

“About 3D layers” on page 173

Using motion blur
You can use motion blur when you animate a layer—for example, moving a layer of text across the screen. You cannot

add motion blur to motion that already exists within a layer, such as live-action video. If you want to smooth live-

action video where you assigned a frame rate much lower or higher than the original, use frame blending.

Note: Previous versions of After Effects included an effect called Motion Blur. That effect is now named Directional Blur,

to avoid confusion with motion blurring applied to layers.

See also

“About motion blur” on page 214

“To apply motion blur to a layer” on page 215

“To set the shutter angle and phase for motion blur” on page 215

Audio layers

To change volume levels of an audio layer
When you use footage containing audio, the audio level in the footage plays at 0 db, meaning that the level is

unadjusted in After Effects. Setting a positive decibel level increases volume, and setting a negative decibel level

decreases volume.

The VU meter in the Audio panel displays the volume range for the audio as it plays. The red blocks at the top of the

meter represent the limit of what your system can handle.

Adjust the audio level and set level keyframes by dragging the level sliders as you preview an audio layer.

1 Select the layer in the Composition or Timeline panel.

2 If the Audio panel is not visible, choose Window > Audio. For greater precision in setting levels, drag the resize

icon in the lower right corner of the Audio panel to increase its size.

3 In the Audio panel, adjust volume in one of the following ways:

• To set the level of the left and right channels together, drag the center slider up or down.
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• To set the level of the left channel, drag the left slider up or down, or type a new value in the levels box at the

bottom of the left slider.

• To set the level of the right channel, drag the right slider up or down, or type a new value in the levels box at the

bottom of the right slider.

See also

“Previewing audio” on page 136

To include or exclude audio
You can include or exclude audio in the preview or rendered version, applying this option at either the composition

or layer level. By default, audio is included.

❖ Choose Layer > Switches > Audio to enable or disable audio.

By default, a check mark appears by the Audio command to indicate that audio is included for previews and

rendering of the selected composition or layer. Audio icons  in the Features switches in the Timeline panel also

indicate whether or not audio is included.

To edit audio in Adobe Audition (Windows only)
While working in After Effects, you may wish to use the more comprehensive audio-editing capabilities of Adobe

Audition to fine-tune your audio layers. The Edit In Adobe Audition command lets you start Adobe Audition from

within After Effects.

If you edit an audio-only file (for example, a WAV file) in Adobe Audition, you make changes to the original file. If

you edit a layer that contains both audio and video (for example, an AVI file) in Adobe Audition, you edit a copy of

the layer’s audio file.

1 Select the audio footage item you wish to edit in Adobe Audition. The item must be of a type that is editable in

Adobe Audition.

2 Choose Edit > Edit In Adobe Audition.

3 Edit the file in Adobe Audition, and then do one of the following:

• If you’re editing an audio-only layer, choose File > Save to apply your edits to the original audio file, or choose

File > Save As to apply your edits to a copy of the audio file. If you choose File > Save As, you need to reimport the

copy of the file into After Effects.

• If you’re editing a layer that contains both audio and video, choose File > Save As. After you save the file, import

it into After Effects, add it to the Timeline, and mute the original audio in the audio-video clip by deselecting the

Audio switch in the Timeline panel.

Note: Any effects applied to audio in After Effects aren’t included in the copy that is sent to Adobe Audition.
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Creating Adobe Encore DVD buttons

About Adobe Encore DVD buttons
You can use Adobe After Effects to quickly create buttons and button layers for importing into Adobe Encore DVD.

Adobe Encore DVD uses a naming standard to define a button and the role of individual layers as subpicture

highlights and video thumbnails. When you select a group of layers to create as an Encore DVD button, Adobe After

Effects precomposes the layers and names the precomposition according to the naming standards for buttons. You

can assign individual layers within the precomposition as highlight layers or video thumbnails. Once a button is

created, you can save it for use in Adobe Encore DVD.

To create an Adobe Encore DVD button
1 In the Timeline panel, select the layers to be used in the button.

2 Choose Layer > Adobe Encore DVD > Create Button.

3 Enter a name for the button.

4 Use the menus to assign up to three highlight layers and one video thumbnail layer, and then click OK.

A new composition is created with the button name. In keeping with the Adobe Encore DVD naming standards, the

prefix (+) is added to the name of the composition to indicate that it is a button. Highlight layers receive the prefix

(=1), (=2), or (=3), and video thumbnails receive the prefix (%).

To assign a subpicture highlight and video thumbnail to a layer
1 Select the desired layer.

2 Choose a highlight option from the Layer > Adobe Encore DVD submenu. The layer name receives the appro-

priate Adobe Encore DVD prefix.

To export a button for use in Adobe Encore DVD
1 Open the composition that is your button, and navigate to the desired frame.

2 Choose Composition > Save Frame As > Photoshop Layers.

3 Enter a name and location, and click OK.

Important: If you rename the button, be sure to retain the (+) prefix. The prefix ensures that Adobe Encore DVD recog-

nizes the file as a button.



173

Chapter 9: 3D layers

3D layers overview

About 3D layers
After Effects can work with layers in two dimensions (x, y) or three dimensions (x, y, z). When you specify a layer as

three-dimensional (3D), After Effects adds the z axis, which provides control over the layer’s depth. After Effects 3D

layers are two-dimensional rectangles that you can move and rotate in three dimensions. By default, they are at 0 on

the z axis. As you increase the z value, the layer moves farther away in space; as you decrease it, the layer moves closer.

By combining this depth with a variation of lights and camera angles, you create projects that take advantage of the

full range of natural motion, lighting and shadows, perspective, and focusing effects.

You can add 3D properties to any layer. In addition to being able to adjust the depth variables that are added to the

layer transform properties, you can also add effects and masks to 3D layers and combine 3D with 2D layers. You can

also create and animate camera and light layers to view or illuminate 3D layers from any angle.

Conventional After Effects 2D image (left) and image with 3D properties (right)

You can specify any layer, except an adjustment layer, as 3D.

Though you can import composited files with 3D information into After Effects, you cannot manipulate the objects

of those files, nor can you create models within the program.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“About layers” on page 149

Using third-party 3D files
Though After Effects can import some third-party files with depth information and interpret the z-axis information

in those files, it cannot animate individual objects within those files. After Effects treats each composited third-party

3D file as a single layer. That layer, as a whole, can be given 3D attributes and treated like any After Effects 3D layer,

but the objects contained within that 3D file cannot be manipulated individually. To access the 3D depth information

in these files, use the 3D Channel effects.  For more information on 3D Channel effects, see “About 3D Channel

effects (Pro only)” on page 381.
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See also

“How After Effects works with 3D image files” on page 107

About z scale
Usually, scaling a layer’s z axis has no effect on the layer because the layer itself has no depth. To add depth, you can

change the position of the layer’s anchor point or establish a parenting relationship with other layers. Once you add

depth, scaling the layer’s z scale value appears to change the layer’s position.

See also

“Moving an anchor point” on page 207

“To work with parent and child layers” on page 208

About 3D layer order
When you move 3D layers behind or in front of each other in the Composition panel, their order in the Timeline

panel does not change. You can use additional views, available from the 3D View menu, to determine the actual

position of the 3D layers in the Composition panel.

Layer order in the Timeline panel specifies how After Effects applies track mattes—they always affect layers that are

adjacent in the Timeline panel. When you apply a shadow to a 3D layer that has a track matte, the shadow may not

appear as expected. To ensure that the shadow remains where expected, precompose (but don’t collapse) the 3D and

track matte layers, then apply the shadow to the composition.

Compositions can contain both 2D and 3D layers. However, lights and shadows cast by 3D layers do not affect 2D

layers. The position of 2D and 3D layers may affect how After Effects renders the composition.

See also

“About track mattes and traveling mattes” on page 279

“Default rendering order” on page 593

“To precompose layers” on page 133

Using effects with 3D layers
Though all After Effects effects are 2D effects, you can apply them to any 3D layer, except light layers and camera

layers.

With effects that have a Comp Camera attribute, you can use the active composition camera or lights to view or light

an effect from various angles in order to simulate more sophisticated 3D effects.

Note: Because effects are 2D, effects that appear to cause protrusions in a layer, such as Bulge or Wave Warp, don’t have

z space values and don’t let you view layers through a camera. So, when you rotate a layer with those effects applied and

view it from the side, the effect does not protrude out of the plane of the layer into 3D space.

See also

“Effects with a Comp Camera attribute” on page 351
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Using masks with 3D layers
You can draw a mask on any 3D layer in After Effects. The mask coordinates correspond to the layer coordinates in

2D space. However, the mask itself has no 3D properties except those of the layer itself, so you cannot draw a mask

along the z axis. However, once you’ve drawn the mask on the layer, the entire layer can be animated along the z axis.

Note: Applying masks or effects to a collapsed 3D composition may make it behave like a 2D layer. To avoid this, turn

off the Collapse Transformations switch in the Timeline panel.

Working with 3D layers

To designate a layer as 3D
Designating a layer as 3D activates the additional layer properties: Position (z), Anchor Point (z), Orientation, X

Rotation, Y Rotation, Z Rotation, and Material Options. Material Options specify how the layer interacts with light.

When you use the 3D switch for a layer, you can add camera and light layers to take full advantage of the additional

dimension.

Z-axis values highlighted

❖ Do one of the following:

• Select the layer, and choose Layer > 3D Layer.

• In the Timeline panel, click the 3D layer switch for the layer.

3D layer switch

To view a set of persistent 3D reference axes in the Composition panel, select 3D Reference Axis from the Grids And

Guides menu. This option is only available if the current composition contains a 3D layer.

See also

“Material Options properties” on page 185
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About 3D rotation
You can adjust 3D rotation two ways: by changing a layer’s Orientation values or changing its X, Y, and Z Rotation

values. You can use the rotation tool to change Orientation or X, Y, or Z Rotation values.

When you animate any of a 3D layer’s Orientation values, the layer moves along the shortest possible rotational path

in 3D space, creating natural and predictable rotations. You can smooth this path by changing the spatial keyframe

interpolation to Auto Bezier.

When you animate any of a 3D layer’s X, Y, or Z Rotation values, the layer rotates along each individual axis. You can

adjust the number of rotations, as well as the angle of rotation. You can also add keyframes to the layer’s rotation on

each axis individually. Animating using these properties allows for more alternatives for fine control with keyframes

and expressions than does animating with the Orientation property, but also may result in motion that is less

predictable. The individual rotation properties are useful for creating rotations with multiple revolutions along a

single axis.

See also

“Applying and changing interpolation methods” on page 222

Adjusting 3D layers
In the Composition panel, 3D layers appear with three axes. Axes are color coded: red arrows control the x axis, green

arrows control the y axis, and blue arrows control the z axis. You can control the layer’s location by dragging an axis

with either the selection or rotation tool. Changing the position moves the layer along an axis; changing the angle

(rotation) pivots the layer on its anchor point around the axis. The Info panel updates to show the coordinates of the

layer you are adjusting.

Note: The axis along which you can drag a layer depends on the composition 3D view.

3D layer rotated in Composition panel

You can also move 3D layers by dragging the layers in the Composition panel. Dragging from the center of a layer

using the Selection tool moves the layer within the camera’s plane of view. Dragging a layer handle using the Rotation

tool constrains the rotation to a particular axis.

To show a wireframe representation of the layer movement, click the Disable Live Update button in the Timeline

panel.

To show or hide the axes

1 Activate the Composition panel that contains the axes you want to show or hide.
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2 In the Timeline panel, select the layer whose axes you want to show or hide.

3 Choose View > Show Layer Controls or View > Hide Layer Controls.

Note:Hiding the axes also hides such layer controls as the camera and light wireframe icons, layer handles, and the point

of interest.

To adjust a 3D layer

1 Select the 3D layer you want to move.

2 In the Tools panel, do one of the following:

• To adjust position, click the Selection tool .

• To adjust orientation or rotation, click the Rotation tool , and choose either Orientation or Rotation from the

Set menu.

3 In the Composition panel, do one of the following:

• Using the Selection or Rotation tool, drag an axis or drag anywhere on the layer. You can drag the pointer outside

the Composition panel.

• Using the Rotation tool, drag a layer handle. If you drag a corner handle, the layer rotates along the z axis; if you

drag a left or right center handle, the layer rotates along the y axis; if you drag a top or bottom center handle, the

layer rotates along the x axis.

Note: To specify what values the Rotation tool affects, select the Rotation tool in the Tools panel, and choose either

Rotation or Orientation from the Set menu.

To quickly move a layer axis, or to rotate a layer in constrained, 45-degree increments, hold down Shift while

dragging.

To move the anchor point in 3D using the axes

1 Select a 3D layer.

2 In the Tools panel, click the Pan Behind tool .

3 In the Composition panel, position the pointer over the center of the axes, and drag.

Note: This procedure also adjusts the layer position relative to the composition so that the layer remains where it was

before you moved the anchor point. To move the layer relative only to the anchor point, hold down Alt (Windows) or

Option (Mac OS) while dragging the x, y, or z axis in the Composition panel.

Working with 3D views

About 3D views
You can view your 3D layers from several angles, using orthogonal views or custom views that employ perspective.

The orthogonal views (Front, Back, Left, Top, Right, and Bottom) show a layer’s position in the composition but do

not show perspective.
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3D views

The three custom views place you at a certain height and angle within the composition, depending on the view you

choose. Adjust your angle and height within custom views with the camera tools.

See also

“To create a camera” on page 181

Selecting and adjusting 3D views
You can change views as often as you want, to see the layers from different angles. You can also choose to look at

selected layers or all layers. When you do this, After Effects changes the point of view and direction of view to include

the layers you have selected.

To view the keyboard shortcuts for setting views and other After Effects features, see “Keys for viewing panels” on

page 644.

To select a 3D view

❖ Do one of the following:

• Choose a view from the 3D View menu at the bottom right of the Composition panel.

• Choose View > Switch 3D View, and choose a view from the menu.

• Choose View > Switch To Last 3D View.

• To select one of the three 3D view shortcuts in the View > Assign Shortcut menu, press F10, F11, or F12 to display

the first, second, or third view, respectively.

• To switch to the previous 3D view, press Esc.

• To see selected layers, choose View > Look At Selected Layers.

• To see layers that aren’t visible in the active view, choose View > Look At All Layers.
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To set or replace 3D view shortcuts

❖ Choose View > Assign Shortcut to n, where n is the currently selected view; then select F10, F11, or F12 from the

menu.

After Effects replaces the view shown in the menu with the current-composition 3D view.

See also

“Working with multiple viewers” on page 146

About 3D previews
You can speed up preview time for 3D layers by enabling Wireframe mode on the Fast Previews menu or by using

Draft 3D mode. These preview modes reduce the amount of data displayed in a 3D layer, so the screen redraws faster.

You can also use OpenGL for faster previews of 3D layers.

See also

“To enable or disable Draft 3D mode” on page 141

About 3D rendering
After Effects provides three 3D rendering plug-ins: Advanced 3D, Standard 3D, and OpenGL Hardware. These plug-

ins compute the motion blur, lighting, shadow, and depth-of-field information unique to 3D. OpenGL also provides

rendering support for a number of other 2D effects. After Effects can also use OpenGL—if the appropriate hardware

is available—during interactions like moving and rotating layers. After Effects can use the Advanced 3D rendering

plug-in to create both RAM previews and output files. The 3D rendering plug-in you specify becomes the default for

future compositions.

3D auto-orientation options
3D layers include auto-orientation options, which you apply to individual layers. When using footage layers, you can

use the Orient Toward Camera option to have the layer always face the active camera.

When using light and camera layers, you can specify any of the following Auto-Orientation options:

Off Specifies that the camera or light rotates freely, independent of the motion path or the point of interest.

Orient Along Path Specifies that the camera or light points only in the direction of the motion path. For example,

use this option to depict a driver’s perspective while looking at the road ahead while driving.

Orient Towards Point Of Interest Specifies that the camera or light continues to point at the point of interest as you

change the camera’s Position values. When you adjust a camera’s or light’s position by dragging the axes in the

Composition panel, the point of interest moves as well.

Note: When the camera has Auto-Orient enabled, setting a light as the camera’s parent will cause the camera to jump.

To change Auto-Orientation settings
1 In the Timeline panel, select the camera or light, and then choose Layer > Transform > Auto-Orient.

2 Select an option from the Auto-Orientation dialog box, and click OK.
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Note: If you specify Orient Towards Point Of Interest and then change a camera's Orientation or X, Y, or Z Rotation

properties, the camera is offset by the new values. For example, you could set a camera up this way to depict the

perspective of a passenger looking out the side window of a car as it moves.

Cameras, lights, and points of interest

About cameras
You can view After Effects 3D layers from any number of angles and distances using layers called cameras. When you

set a camera view for your composition, you look at the layers as though you were looking through that camera. You

can choose between viewing a composition through the active camera or through a named custom camera. The

active camera is the topmost camera in the Timeline panel at the current time. After Effects uses the active camera

view when creating final output and when nesting compositions. If you have not created a custom camera, then the

active camera is the same as the default composition view.

Though you can add multiple cameras to any composition, the camera’s views affect only 3D layers, or 2D layers to

which you’ve applied an effect with a Comp Camera attribute. A camera can be both a parent and a child of 2D and

3D layers.

Example of a camera
A. Point of interest B. Frame C. Camera

Note: If you import or open an After Effects 5.x project containing a 3D composition that used a default camera, After

Effects adds an AE 5.x Default Camera to the composition.

See also

“Effects with a Comp Camera attribute” on page 351

“About parent and child layers” on page 208

To change the camera used in a view
❖ Choose a camera from the 3D View menu at the bottom right of the Composition panel.

Before moving a camera, choose a view other than Active Camera so that you can see the point of interest icon and

the boundaries defining its angle.

B

A

C
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To create a camera
Each camera has a set of properties, which include focal length, aperture, and focus distance. Using these properties,

you can create custom cameras that simulate a large range of real cameras.

1 Select either the Timeline or Composition panel.

2 Choose Layer > New > Camera.

3 Adjust settings.

Note: You can include specific layers in a camera view by using the View commands. (See “Selecting and adjusting 3D

views” on page 178.) The Look At Selected Layers command changes the position of the camera view but does not change

the angle or direction of view.

All of the cameras that you create are listed in the View list, located at the bottom of the Composition panel, where

you can access them at any time.

See also

“Camera settings” on page 181

Camera settings
You can set up cameras in After Effects to simulate the capabilities of real-world cameras. Use camera settings to

configure the camera view to match the settings you use to record video footage or to look at the footage from a new

perspective. You can change camera settings at any time by selecting the camera layer and choosing Layer > Camera

Settings.

Name Specifies the name of the camera. By default, After Effects assigns the name Camera 1 to the first camera you

create in a composition, and all subsequent cameras are numbered in ascending order. If you delete a camera, and

are still using the After Effects default naming convention, After Effects names the next camera you create with the

lowest available number. You should choose distinctive names for multiple cameras to make it easier to distinguish

them.

Preset Specifies the type of camera settings you want to use. Cameras come with several presets. The presets are

named according to focal lengths. Each preset is meant to represent the behavior of a 35mm camera with a lens of a

certain focal length. Therefore, the preset also sets the Angle Of View, Zoom, Focus Distance, Focal Length, and

Aperture values. The default preset is 50mm. You can also create a custom camera by specifying new values for any

of the settings.

Zoom Specifies the distance from the position of the camera to the image plane.

Angle Of View Specifies the width of the scene captured in the image. The Focal Length, Film Size, and Zoom values

determine the angle of view. A wider angle of view creates the same effect as a wide-angle lens.

Enable Depth Of Field Applies custom variables to the Focus Distance, Aperture, F-Stop, and Blur Level settings.

Using these variables, you can manipulate the depth of field to create more realistic camera-focusing effects. (The

depth of field is the distance range within which the image is in focus. Images outside the distance range are blurred.)

Focus Distance Specifies the distance from the camera’s position to the plane that is in perfect focus.

Lock To Zoom Makes the Focus Distance value match the Zoom value.
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Note: If you change the settings of the Zoom or Focus Distance options in the Timeline panel, the Focus Distance value

becomes unlocked from the Zoom value. If you need to change the values and want the values to remain locked, then use

the Camera Settings dialog box instead of the Timeline panel. Alternatively, you can add an expression to the Focus

Distance property in the Timeline panel: Select the Focus Distance property, and choose Animation > Add Expression;

then drag the expression pick whip to the Zoom property.

Aperture Specifies the size of the lens opening. The Aperture setting also affects the depth of field—increasing the

aperture increases the depth of field blur. When you specify new values for Aperture, the values for F-Stop change

dynamically to match it.

F-Stop Represents the ratio of the focal length to aperture. Most cameras specify aperture size using the f-stop

measurement; thus, many photographers prefer to set the aperture size in f-stop units. When you specify new values

for F-stop, the values for Aperture change dynamically to match it.

Blur Level Controls the amount of depth-of-field blur in an image. A setting of 100% creates a natural blur as

dictated by the camera settings. Lower values reduce the blur.

Film Size Specifies the size of the exposed area of film, which is directly related to the composition size. When you

specify new values for Film Size, the Zoom value changes to match the perspective of a real camera.

Focal Length Specifies the distance from the film plane to the camera lens. In After Effects, the camera’s position

represents the center of the lens. When you specify new values for Focal Length, the Zoom value changes to match

the perspective of a real camera. In addition, the Preset, Angle of View, and Aperture values change accordingly.

Units Specifies the units of measurement in which the camera setting values are expressed.

Measure Film Size Specifies the dimensions used to depict the film size.

To adjust a view using the camera tools
Use the camera tools to adjust the camera view. Use the Orbit Camera tool to rotate the current 3D view around

the point of interest. Use the Track XY Camera tool to adjust the 3D view horizontally or vertically. Use the Track

Z Camera tool to adjust the 3D view along the line leading to and from the point of interest or, if you are using an

orthogonal view, to adjust the scale of the view. These tools are specifically for manipulating the 3D views and do not

become available until you create a 3D layer, a camera, or a light.

1 In the Tools panel, select the camera tool you want to use.

Hold down the mouse button on a camera tool to see all of the available tools.

2 In the 3D View menu, choose the camera view you want to adjust.

3 Drag in the Composition panel. You can drag outside the panel once you’ve begun dragging within it.

To change axis modes
Axis modes specify on which set of axes the layer, light, or camera is transformed.

❖ In the Tools panel, click the icon for one of the following modes: Local Axis mode , World Axis mode , or

the View Axis mode .

Local Axis mode Aligns the axes to the surface of a 3D layer.

World Axis mode Aligns the axes to the absolute coordinates of the composition. Regardless of the rotations you

perform on a layer, the axes always represent 3D space relative to the 3D world.
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View Axis mode Aligns the axes to the view you have selected. For example, suppose that a layer has been rotated

and the view changed to a custom view; any subsequent transformation made to that layer while in View Axis mode

happens along the axes corresponding to the direction from which you are looking at the layer.

Note: The camera tools always adjust along the view’s local axes, so their action is not affected by the axis modes.

About lights and points of interest
In After Effects, a light is a type of layer that shines light on other layers. You can choose among four different types

of lights—Parallel, Spot, Point, and Ambient—and modify them with varying settings. Lights, by default, point to the

point of interest.

You can specify which 3D layers a light affects by designating the light as an adjustment layer—place the light in the

Timeline panel above the layers on which you want it to shine. Layers that are above a light adjustment layer in the

Timeline panel do not receive the light, regardless of the light's position.

Parts of a light
A. Point of interest B. Spotlight cone C. Light

Cameras and lights include a property that specifies the point in the composition at which the camera or light points.

By default, the point of interest is set at the center of the composition, and the camera or light’s view is automatically

oriented toward it. You can move the point of interest at any time.

See also

“About adjustment layers” on page 151

To create a new light
You can create Parallel, Spot, Point, and Ambient lights. You can animate all of a light’s settings, except for Casts

Shadows.

Note: To make a layer display a shadow, select the Accepts Shadows layer material option.

1 From the Timeline or Composition panel, choose Layer > New > Light.

2 In the Light Settings dialog box, specify any of the following settings:

Light Type Parallel replicates directional, unconstrained light from an infinitely distant source. Spot emits light from

a source that is constrained by a cone, like the spotlight used in stage productions. Point emits unconstrained

omnidirectional light, like the rays from a bare light bulb. Ambient creates light that has no source but rather

contributes to the overall brightness of a scene and casts no shadows.

A

B

C
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Intensity Sets the brightness of the light. Negative values create nonlight. Nonlight subtracts color from a layer. For

example, if a layer is already lit, creating a directional light also pointing at that layer and employing negative values

creates an area of negative light, or a dark area, on the layer.

Cone Angle Sets the width of a spotlight by adjusting the angle of the cone surrounding the source. This option is

active only if Spot is selected for Light Type.

Cone Feather Adjusts the edge softness of a spotlight. This option is active only if Spot is selected for Light Type.

Color Sets the color of the light.

Casts Shadows Specifies whether the light source causes a layer to cast a shadow.

Shadow Darkness Sets the darkness level of the shadow. This option is active only if Casts Shadows is selected.

Shadow Diffusion Sets the softness of a shadow based on its apparent distance from the shadowing layer. Larger

values create softer shadows. This option is active only if Casts Shadows is selected.

To move a camera, light, or point of interest
1 In the Timeline or Composition panel, select a camera or light. To select a light, move the current-time indicator

to the point in time where the light is active.

Light settings examples

Light Type: Parallel Light Type: Spot Light Type: Point

Light Type: Ambient Intensity Cone Angle

Cone Feather Color Casts Shadows

Shadow Darkness Shadow Diffusion
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2 Using the Selection or Rotation tool, do one of the following:

• To move the camera, light, or the point of interest, position the pointer over the axis you want to adjust, and drag.

• To move the camera or light along a single axis without moving the point of interest, drag the axis while holding

down Ctrl (Windows) or Command (Mac OS).

• To move the camera or light freely without moving the point of interest, drag the camera icon .

• To move the point of interest, drag the point of interest icon .

Material Options properties
In the Timeline panel, 3D layers have an additional set of properties called Material Options. These determine how

a 3D layer interacts with light and shadow, both of which are important components of realism and perspective in

3D animation.

Shadows cast by continuously rasterized 3D layers (including text layers) are not affected by effects applied to that

layer. If you want the shadow to show the results of the effect, precompose the layer with the effect before adding the

shadow. (For more information on precomposing layers, see “To precompose layers” on page 133.)

3D layer material options
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Casts Shadows Casts a shadow on layers within the range of that shadow. The direction and angle of the shadows

are determined by the direction and angle of the light sources. Set Casts Shadows to Only if you want the layer to be

invisible but still cast a shadow. Use the Only setting along with Light Transmission to project the colors from the

invisible layer onto a visible layer.

Note: To cast a shadow, select the Casts Shadows option for both the shadow-casting layer and the corresponding light.

Light Transmission Specifies the percentage of light that shines through a layer. Use this option to make layers act

like transparencies and cast their color on another layer. You can also create the effect of light passing through stained

glass by placing a light behind a 3D layer and adjusting the light transmission. A light transmission value of 0 casts

a black shadow and specifies that no light passes through the layer. This setting renders faster; use it if you don’t want

to cast a colored shadow or if you want previews to render quickly. A value of 100 specifies that the full color value

of the shadow-casting layer is projected onto the layer accepting the shadow.

Accepts Shadows Shows the shadow cast on this layer by another layer.

Accepts Lights Specifies that the layer color is affected by the light that reaches it. Turn this off if you don’t want the

light to change the color of the layer. If you turn this off, the layer can still accept and cast shadows.

Ambient Specifies the level of ambient (nondirectional) reflectivity of the layer. A value of 100% creates the most

reflectivity; a value of 0% creates no ambient reflectivity.

Diffuse Specifies the level of diffuse (omnidirectional) reflectivity of the layer. Applying diffuse reflectivity to a layer

is like draping a dull, plastic sheet over it. Light that falls on this layer reflects equally in all directions. A value of

100% creates the most reflectivity; a value of 0% creates no diffuse reflectivity.

Specular Specifies the level of specular (directional) reflectivity of the layer. Specular light reflects from the layer as

if from a mirror. A value of 100% creates the most reflectivity; a value of 0% creates no specular reflectivity.

Material Options examples

Casts Shadows Light Transmission Accepts Shadows

Accepts Lights Ambient Diffuse

Specular Shininess Metal
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Shininess Specifies the size of the specular highlight. This value is active only if the Specular setting is greater than

zero. A value of 100% produces a reflection with a small specular highlight. A value of 0% produces a reflection with

a large specular highlight.

Metal Specifies the color of the specular highlight. A value of 100% specifies that the color is the color of the layer.

For example, with a Metal value of 100%, an image of a gold ring reflects golden light. A value of 0% specifies that

the color of the specular light is the color of the light source. For example, a layer with a Metal value of 0% under a

white light has a white highlight. (If you are using OpenGL, the Metal value is temporarily set to zero during an inter-

active preview.)
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Chapter 10: Animation

Animation and layer properties

About animation and layer properties
Animation is the creation of change over time. You can animate different layer properties, such as position, rotation,

masks, and effects, with endless possibilities for creativity. Each change can occur independently of, and yet simul-

taneously with, other changes.

Each layer can contain many sets of properties. Layers that contain video or still images have mask and transform

properties, such as mask shape and layer rotation. A layer can also include other properties, such as time remapping,

video effects, and audio effects.

Here are some examples of how you can animate layer properties:

• You can animate position by adding keyframes to the Position property and dragging the layer in the Composition

panel. For example, you can move a layer by selecting it at its existing position and then dragging it 10 pixels to

the left.

• You can animate a layer property by adding keyframes to the property and dragging the underlined property

value. For example, you can change a layer’s opacity by dragging its underlined Opacity value.

• You can animate a layer property by adding keyframes to the property and entering an absolute number for the

property’s value. For example, you can move a layer by typing new coordinate values for the Position property.

• You can animate layer properties by moving keyframe positions in the Graph Editor. For example, to decrease the

size of a layer, drag a keyframe for the Scale layer property to a lower position in the Graph Editor.

• You can animate a layer property by adding an expression to the property.

• You can animate a layer by applying an animation preset.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“About expressions” on page 555

“About animation presets” on page 202

About the Graph Editor
To view and manipulate all aspects of effects and animations, including effect property values, keyframes, and inter-

polation, use the Graph Editor. The Graph Editor represents changes in effects and animations as a two-dimensional

graph, with playback time represented horizontally (from left to right). In layer bar mode, on the other hand, the

time graph represents only the horizontal time element, without showing a visual representation of changing values.

There are two types of graphs available in the Graph Editor: value graphs, which show property values; and speed

graphs, which show rates of change of property values.
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To toggle between layer bar mode and Graph Editor mode, click the Graph Editor button in the Timeline panel.

Two animated properties (Position and Scale) displayed in the Graph Editor

Working with the Graph Editor
In the Graph Editor, each property is represented by its own graph. You can view and work on one property at a time,

or you can view multiple properties simultaneously. When more than one property is visible in the Graph Editor,

each property’s graph has the same color as the property’s value in the layer outline.

To select which properties are shown in the Graph Editor

❖ Click the Show Properties button  at the bottom of the Graph Editor, and select from the following options:

Show Selected Properties Displays selected properties in the Graph Editor.

Show Animated Properties Displays animated properties of selected layers in the Graph Editor.

Show Graph Editor Set Displays properties that have the Graph Editor toggle  selected.

To select Graph Options in the Graph Editor

❖ Click the Graph Options button  at the bottom of the Graph Editor, and select from the following options:

Auto-Select Graph Type Automatically selects the appropriate graph type for a property: speed graphs for spatial

properties (such as position), and value graphs for other properties.

Edit Value Graph Displays the value graph for all properties.

Edit Speed Graph Displays the speed graph for all properties.

Show Reference Graph Displays the unselected graph type in the background for viewing only. (The gray numbers

to the right of the Graph Editor indicate the values for the reference graph.)

Show Audio Waveforms Displays the audio waveform for any layer that has at least one property in the Graph Editor.

Show Layer In/Out Points Displays In and Out points of all layers that have a property in the Graph Editor.

Show Layer Markers Displays layer-time markers in the Graph Editor, if they exist.

Show Graph Tool Tips Toggles the graph tool tips on and off.

Show Expression Editor Shows or hides the expression editor field.

Allow Keyframes Between Frames Allows placement of keyframes between frames for fine-tuning animation.
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Using the Snap button

When you drag a keyframe in the Graph editor with the Snap button toggled, the keyframe snaps to the following

items:

• Keyframes (both vertically and horizontally)

• Current-time indicator

• In/Out points

• Markers

• Work area start/end

• Composition start/end

When the keyframe snaps to one of these items, an orange line appears in the Graph Editor to indicate the object

you’re snapping to. Ctrl-drag (Windows) or Command-drag (Mac OS) to temporarily toggle the Snap button.

Note: Shift-dragging the current-time indicator also snaps to the items in the list above.

To pan and zoom in the Graph Editor

• To pan vertically or horizontally, drag with the Hand tool .

To invoke the Hand tool momentarily, press and hold the spacebar.

• To pan vertically, spin the mouse scroll wheel.

• To pan horizontally, press the Shift key as you spin the mouse scroll wheel.

• To zoom in, click with the Zoom tool.

• To zoom out, Alt-click (Windows) or Option-click (Mac OS) with the Zoom tool.

• To zoom using the mouse scroll wheel, press Alt (Windows) or Option (Mac OS) while scrolling to zoom horizon-

tally; press Ctrl (Windows) or Command (Mac OS) to zoom vertically.

• To zoom horizontally, Alt-drag (Windows) or Option-drag (Mac OS) with the Zoom or Hand tool to the left to

zoom out or to the right to zoom in.

• To zoom vertically, Alt-drag (Windows) or Option-drag (Mac OS) with the Zoom or Hand tool up to zoom in or

down to zoom out.

Note: You cannot pan or zoom vertically when Auto Zoom Height is selected.

Auto Zoom Height and Fit

The Auto Zoom Height, Fit Selection, and Fit All buttons help you adjust the Graph Editor’s view to focus on relevant

portions of your animations.

Auto Zoom Height Toggles Auto Zoom Height mode, which automatically scales the height of the graph so that

it fits the height of the Graph Editor. The horizontal zoom must still be adjusted manually.

Fit Selection Adjusts the value (vertical) and time (horizontal) scale of the graph to fit the selected keyframes in

the Graph Editor.

Fit All Adjusts the value (vertical) and time (horizontal) scale of the graph to fit all of the graphs in the Graph

Editor.
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To view layer properties
As you add layers to a composition, they appear in the layer outline in the Timeline panel. The layer outline is visible

in the Timeline panel in either Graph Editor mode or in layer bar mode. You can expand the layer outline to display

layer properties and change property values. Keyboard shortcuts can help you quickly display a layer property, hide

others, and save space in the Timeline panel. For more information on these keyboard shortcuts, see “Keys for

viewing layer properties” on page 648.

Collapsed layer (left) compared to expanded layer (right)

• To expand a layer outline heading, click the triangle to the left of the layer name so that it points downward.

• To expand a property group, click the triangle to the left of a property group, such as Masks, Effects, or Transform.

• To collapse a layer outline heading, click the triangle to the left of the layer name so that it points to the right.

• To expand or collapse all layer outline headings, select the layer and then press Ctrl+~ (tilde).

To view modified properties in the layer outline
When working on a composition containing a mix of animated, modified, and unmodified properties, you can

choose to display only the modified properties in the layer outline. Viewing only modified properties lets you

concentrate on just the properties that you have been working with.

Select a layer and do one of the following:

• Press U twice in rapid succession.

• Choose Animation > Reveal Modified Properties.

See also

“Keys for viewing layer properties” on page 648

To set a layer property value in the layer outline
1 Select a layer.

2 Expand the layer outline to display the layer properties.

3 Do one of the following:

• Place the pointer over the underlined value and drag to the left or right to change the value.

• Click the underlined value that you want to change, type a new value, then press Enter (Windows) or Return (Mac

OS).

• Right-click (Windows) or Control-click (Mac OS) the underlined value you want to change and choose Edit Value.

Type a new value and click OK.
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Note: If you are changing Anchor Point values, note that the anchor point’s coordinates are relative to the Layer panel,

not the Composition panel.

To set a layer property value in the Graph Editor
A value graph in the Graph Editor displays the values for each keyframe and the interpolated values between

keyframes. When the value graph of a layer property is level, the value of the property is unchanged between

keyframes. When the value graph goes up or down, the value of a layer property increases or decreases between

keyframes.

Value graph
A. Keyframe B. A level value graph indicates unchanging values. C. A rising graph indicates increasing values. D. A falling graph indicates
decreasing values.

You can change layer property values by moving the points (keyframes) on the value graph up or down. For example,

you can increase a Rotation keyframe’s value by dragging a keyframe marker on the Rotation property’s value graph

higher up on the graph.

Note: Values for the Anchor Point, Mask Shape, Effect Point controls, 3D Orientation, and Position properties are

spatial, so they use speed graphs by default instead of value graphs.

1 In the Timeline panel, display a temporal property for a layer.

2 If necessary, click the Graph Editor button to enter Graph Editor mode.

3 If necessary, add a keyframe at the point in time you want the change to occur.

4 Drag the keyframe up or down to set a new value for the layer property.

Setting, selecting, and deleting keyframes

About keyframes
Keyframes are used to create and control animation, effects, audio properties, and many other kinds of change that

occur over time. A keyframe marks the point in time where you specify a value, such as spatial position, opacity, or

audio volume. Values between keyframes are interpolated. When you use keyframes to create a change over time, you

must use at least two keyframes—one for the state at the beginning of the change, and one for the new state at the

end of the change.

Using keyframes
To animate a property using keyframes, you must set at least two keyframes for that property. Otherwise, changes

that you make to the layer property remain in effect for the duration of the layer.

B C D A 
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Note: You can also animate layer properties using expressions. Expressions can operate on layer properties with or

without keyframes. (See “About expressions” on page 555.)

Each layer property has a time-vary Stopwatch icon  that you click to begin the process of animating with

keyframes. Once the stopwatch is active for a specific property, After Effects automatically sets new keyframes

whenever you change the current time and the property value. When the stopwatch is inactive for a property, the

property has no keyframes. If you type a value for a layer property while the stopwatch is inactive, the value remains

in effect for the duration of the layer. If you deselect the stopwatch, any existing keyframes for that layer property

disappear, so don’t deselect the stopwatch unless you’re sure that you want to permanently delete all of the keyframes

for that property.

Stopwatch icons
A. Active stopwatch B. Inactive stopwatch

See also

“About interpolation” on page 218

Keyframe icons
In layer bar mode, the appearance of a keyframe icon depends on the interpolation method you choose for the

interval between keyframes. When half of the icon is dark gray , the dark half indicates that there is no keyframe

adjacent to that side, or that its interpolation is overridden by the Hold interpolation applied to the preceding

keyframe. Selected keyframes have a yellow highlight.

Change the keyframe icons to numbers by choosing Use Keyframe Indices in the Timeline panel menu.

Keyframes as icons compared to keyframes as numbers

In Graph Editor mode, the appearance of a keyframe icon depends on whether the keyframe is selected, unselected,

or semi-selected (when another keyframe in the same property graph is selected). Selected keyframes are solid

yellow. Unselected keyframes retain the color of their corresponding graph. Semi-selected keyframes are represented

by a hollow yellow box.

Keyframes in Graph Editor mode may have direction handles attached to one or both sides. Direction handles are

used to control Bezier interpolation.

B
A
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Keyframes in the Graph Editor with direction handles

To move the current-time indicator to a keyframe
After you set the initial keyframe for a property, After Effects displays the keyframe navigator, which you can use to

move from keyframe to keyframe or to set or remove keyframes. When the keyframe navigator box is selected, the

current-time indicator lies precisely at a keyframe for that layer property. When the keyframe navigator box is

deselected, the current-time indicator lies between keyframes. When arrows appear on each side of the keyframe

navigator box, other keyframes for that property exist on both sides of the current time.

Detach the keyframe navigator from the A/V Features column to function as its own column by choosing Column >

Keys from the Timeline panel menu.

Keyframe navigator box in Timeline panel
A. Keyframe at current time B. No keyframe at current time C. No keyframes for layer property

• Click a keyframe navigator arrow. The arrow to the left moves the current-time indicator to the previous keyframe.

The arrow to the right moves the current-time indicator to the next keyframe.

• To snap the current-time indicator to a keyframe, Shift-drag it to a keyframe.

To select keyframes
• To select a keyframe, click the keyframe icon.

• To select multiple keyframes, Shift-click the keyframes or drag a marquee around the keyframes in the Graph

Editor to create a Free Transform bounding box.

Note: To toggle viewing of the Free Transform box, click the Show Transform Box button at the bottom of the Graph

Editor.

• To select all keyframes for a layer property, Alt-click (Windows) or Option-click (Mac OS) a segment between two

keyframes in the Graph Editor, or click the layer property name in the layer outline.

• To select all keyframes in a property that have the same value, right-click (Windows) or Control-click (Mac OS)

a keyframe, and choose Select Equal Keyframes.

A B

C
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• To select all keyframes that follow or precede a selected keyframe, right-click (Windows) or Control-click (Mac

OS) a keyframe, and choose Select Previous Keyframes or Select Following Keyframes.

Note: The Select Previous/Following Keyframes commands aren’t available if more than one keyframe is selected.

See also

“Using keyframes” on page 192

Determining where to add and modify keyframes
You can freely change any keyframe attribute. Because After Effects provides more than one view of a keyframe,

where you modify it depends on what you want to do as well as the type of keyframe and layer property. All layer

properties are temporal—they can change the layer over time. Some layer properties, such as Position, are also

spatial—they can move the layer across composition space. You modify some attributes of a spatial layer property in

different panels than you do temporal properties.

Before you make any changes to a keyframe, make sure that the current-time indicator is positioned at an existing

keyframe. If you change a property value when the current-time indicator is not at an existing keyframe, After Effects

adds a new keyframe. However, if you double-click a keyframe to modify it, the current-time indicator location is

not relevant, nor is it relevant when you change a keyframe’s interpolation method.

See also

“Interpolation methods” on page 220

To set keyframes for layer properties
1 In the Timeline panel, select the layer that you want to animate, and then select the layer property that you want

to animate.

2 In the Graph Editor, click the Show Properties menu  and select Show Selected Properties.

3 Move the current-time indicator to the time where you want to begin the animation.

4 Set the layer property to the value you want at that point in time; for example, move the layer to a new position.

5 Do one of the following:

• Click the Stopwatch icon next to the property name to activate it. After Effects creates a keyframe at the current

time for that property value.

• Choose Animation > Add [x] Keyframe, where [x] is the name of the property you are animating.

6 Move the current-time indicator to the time where you want to add an additional keyframe.

7 Change the value for the property in the layer outline, or Ctrl-click (Windows) or Command-click (Mac OS) in

the graph to insert a new keyframe.

8 Repeat steps 6 and 7 as many times as you want to add more keyframes.

To add a keyframe without changing a value

1 In the Timeline panel, select the layer you want to animate.

2 Display the layer property for which you want to add a keyframe. The property must already contain at least one

keyframe, and the stopwatch must be activated.
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3 Move the current-time indicator to the point where you want to add a new keyframe. If the current-time indicator

is after the last keyframe for that layer property, the new keyframe will have the same value as the preceding

keyframe. Otherwise, the new keyframe’s value will be an interpolated value based on the previous and next

keyframe values.

4 Do one of the following:

• Click the keyframe navigator button  for the layer property.

• Choose Animation > Add [x] Keyframe, where [x] is the name of the property you are keyframing.

• Click on a segment of the layer property’s graph in the Graph Editor with the Pen tool .

• Ctrl-click (Windows) or Command-click (Mac OS) a segment of the layer property’s graph in the Graph Editor.

(Drag to extend influence handles.)

To delete a keyframe
If you make a mistake while setting keyframes, or if you decide a keyframe is no longer needed, you can easily delete

one or more keyframes from a layer.

Do one of the following:

• Select one or more keyframes, and then press Delete on the keyboard.

• Ctrl-click (Windows) or Command-click (Mac OS) a keyframe with the Arrow tool.

• To delete all keyframes of one layer property, click the Stopwatch icon to the left of the name of the layer property

to deactivate it.

Note:When you deselect the Stopwatch icon, keyframes for that property are permanently removed and the value of that

property becomes the value at the current time. You cannot restore deleted keyframes by reselecting the stopwatch. If you

accidentally delete keyframes, choose Edit > Undo.

See also

“Using keyframes” on page 192

Keyframe menu commands
When you select one or more keyframes, the keyframe menu  becomes available at the bottom of the Graph

Editor.

To open the keyframe menu, right-click (Windows) or Control-click (Mac OS) a keyframe in the Graph Editor.

[Value] Displays the value of the selected keyframe. If more than one keyframe is selected, the Display Value

command is available, which displays the value of the highlighted keyframe in the selection.

Edit Value Displays a dialog box in which you can edit the value of the keyframe.

Select Equal Keyframes Selects all keyframes in a property that have the same value.

Select Previous Keyframes Selects all keyframes preceding the currently selected keyframe.

Select Following Keyframes Selects all keyframes following the currently selected keyframe.

Toggle Hold Keyframe Holds the property value at the value of the current keyframe until the next keyframe is

reached.
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Keyframe Interpolation Displays the Keyframe Interpolation dialog box.

Rove Across Time Toggles Rove Across Time for spatial attributes.

Keyframe Velocity Displays the Keyframe Velocity dialog box.

Keyframe Assistant Displays a submenu with the following options:

• Convert Audio to Keyframes Analyzes amplitude within the composition work area and creates keyframes to

represent the audio.

• Convert Expression to Keyframes Analyzes the current expression and creates keyframes to represent the

property changes it describes.

• Easy Ease Automatically adjusts the influence into and out of a keyframe to smooth out sudden changes.

• Easy Ease In Automatically adjusts the influence into a keyframe.

• Easy Ease Out Automatically adjusts the influence out of a keyframe.

• Exponential Scale Converts the rate of change in scale from linear to exponential.

• RPF Camera Import Imports RPF camera data from third-party 3D modeling applications.

• Sequence Layers Displays the Sequence Layers assistant.

• Time-Reverse Keyframes Reverses selected keyframes in time.

See also

“Interpolation methods” on page 220

“About expressions” on page 555

Editing, moving, and copying keyframes

To view or edit a keyframe value
1 Right-click (Windows) or Control-click (Mac OS) the keyframe. The keyframe value appears at the top of the

context menu that appears.

2 Choose Edit Value to edit the value, if desired.

To edit keyframes with the Pen tool
Using the Pen tool to edit a keyframe for a spatial property in the Composition or Layer panel is similar to modifying

a path in a drawing application such as Adobe Illustrator. (See “Creating masks with the Pen tool” on page 245.) For

best results with the Pen tool, you should understand how Bezier interpolation affects graphs and the paths. With

Bezier interpolation, you can control the shapes of curves at vertices, making them into smooth curves or angled

corners.

1 In the Timeline panel, select the property for the layer you want to edit.

2 Select the Pen tool  from the Tools panel.

3 In the Composition or Layer panel (depending on where the controls appear), do any of the following:

• Click the path to add a keyframe.
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• Drag an existing keyframe to a new location.

• Adjust the direction handles or change the interpolation method.

See also

“Applying and changing interpolation methods” on page 222

To move keyframes to another time
With multiple keyframes selected, you can copy or delete them simultaneously or move the keyframes together

without changing their positions relative to each other.

1 Select one or more keyframes.

2 Drag any of the selected keyframe icons to the desired time. If you selected multiple keyframes, then all of the

selected keyframes maintain their relative distance from the keyframe that you drag.

See also

“Using keyframes” on page 192

To expand or contract a group of keyframes in layer bar mode
1 Select at least three keyframes.

2 Hold down Alt (Windows) or Option (Mac OS) and drag the first or last selected keyframe to the desired time.

See also

“Using keyframes” on page 192

To move a keyframe to a specific time
1 Move the current-time indicator to the desired time.

2 Do one of the following:

• In layer bar mode, hold down Shift after you begin to drag a keyframe icon to the current-time indicator. When

you drag over the current-time indicator, the keyframe snaps to the current-time indicator.

• In Graph Editor mode, when you drag a keyframe, it snaps to the current-time indicator by default, without

holding down the Shift key.

See also

“About the Graph Editor” on page 188

Copying and pasting keyframes
You can copy keyframes between layers for the same property (such as Position) or between different properties that

use the same type of data. The keyframe properties you can copy include the following:

• Properties that have the same dimension: for example, Opacity and Rotation, which have adjustable parameters

in one dimension; or Mask Feather and 2D scale, which have adjustable parameters in two dimensions

• Rotation, effect angle control, and effect slider control properties
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• Effect color properties

• Mask properties and spatial properties (effect points, anchor points)

You can copy keyframes from only one layer at a time. When you paste keyframes into another layer, they appear in

the corresponding property in the destination layer. The earliest keyframe appears at the current time, and the other

keyframes follow in relative order. The keyframes remain selected after pasting, so you can immediately move them

in the destination layer.

Note: When copying and pasting between the same properties, you can copy from more than one property to more than

one property at a time. However, when copying and pasting to different properties, you can copy only from one property

to one property at a time.

See also

“To copy a value from a layer property that contains no keyframes” on page 200

“To duplicate a layer” on page 157

“About masks” on page 243

To copy and paste keyframes
1 In the Timeline panel, display the layer property containing the keyframes you want to copy.

2 Select one or more keyframes.

3 Choose Edit > Copy.

4 In the Timeline panel containing the destination layer, move the current-time indicator to the point in time where

you want the keyframes to appear.

5 Do one of the following:

• To paste to the same property of the copied keyframes, select the destination layer.

• To paste to a different property from the copied keyframes, select the destination property.

6 Choose Edit > Paste.

See also

“Using keyframes” on page 192

To move a layer duration bar but not its keyframes
1 Make a note of the time at which the first keyframe appears.

2 In the layer outline, click the name of one or more layer properties containing the keyframes you want to keep at

the same times.

3 Choose Edit > Cut.

4 Move or stretch the layer duration bar to its new In and Out points.

5 Move the current-time indicator to the time at which the first keyframe appeared before you cut the keyframes.

6 Choose Edit > Paste.
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To copy a value from a layer property that contains no keyframes
You can copy the current value of a layer property to another layer, even when the original layer contains no

keyframes. This can save you the time of having to set up a property the same way on various layers.

1 In the Timeline panel, display the layer property containing the value you want to copy.

2 Click the name of the layer property to select it.

Anchor Point property selected

3 Choose Edit > Copy.

4 Select the layer into which you want to paste the value.

5 If the target layer contains keyframes, move the current-time indicator to the time where you want to paste the

value. If the target layer does not contain keyframes, the new value applies to the entire duration of the layer.

6 Choose Edit > Paste.

To change multiple keyframe values at once
You can change the values of multiple keyframes on multiple layers at one time; however, all keyframes you select

must belong to the same layer property. The way the values change depends on the method you use to make the

change:

• If you change a value numerically, all selected keyframes use the new value exactly. In other words, you make an

absolute change. For example, if you select several Position keyframes on a motion path and numerically specify

a Position value for one of them, all selected keyframes change to the same position value.

• If you change a value by dragging the underlined value, all selected keyframes change by the same amount. In

other words, you make a relative change. For example, if you select several Position keyframes on a motion path

and drag the underlined value for one of them, all selected keyframe values change by the same amount.

• If you change a value graphically in the Composition or Layer panel, all selected keyframes change using the

difference between the old and new values, not the values themselves. In other words, you make a relative change.

For example, if you select several Position keyframes on a motion path and then drag one of them 10 pixels to the

left, they all move 10 pixels to the left of their original positions.

You can also change the value of several layers at once in layer bar mode by parenting them.

1 Select the keyframes you want to change. All keyframes you select must be for the same property.

2 Change the value of any selected keyframe by one of the methods above. All other selected keyframes change

accordingly.

See also

“About parent and child layers” on page 208

“Using keyframes” on page 192
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To edit multiple keyframes in the Graph Editor
You can edit and move multiple keyframes simultaneously using the Graph Editor. When you select multiple

keyframes with the Show Transform Box button toggled, a free-transform bounding box surrounds the selected

keyframes, and an anchor point appears in the center of the bounding box to mark the center point for the transfor-

mation. You can move the selected keyframes in time or value by dragging the bounding box or its handles. You can

also change the position of the anchor point.

Adjusting a free-transform bounding box in a value graph moves the selected keyframes in time and value. Adjusting

a free-transform bounding box in a speed graph moves the selected keyframes in time only.

When you select multiple keyframes in the Graph Editor, a Free Transform bounding box appears.

1 Switch to the Graph Editor view and display the keyframes you want to adjust.

2 Using the Selection tool, do one of the following:

• To select keyframes, Shift-click the keyframes or drag to draw a marquee around the keyframes.

• To select all keyframes for a property, Alt-click (Windows) or Option-click (Mac OS) a segment between two

keyframes.

3 Do any of the following:

• To move keyframes in time or value, position the pointer inside the bounding box and drag. Shift-drag to

constrain the move horizontally or vertically.

• To move keyframes in time or value by scaling the bounding box, position the pointer on a bounding box handle.

When the pointer changes to a straight, double-sided arrow , drag the bounding box to a new size. Shift-drag to

constrain the ratio of width to height. Ctrl-drag (Windows) or Command-drag (Mac OS) to scale around the

bounding box’s anchor point. When dragging a corner point, Alt-drag (Windows) or Option-drag (Mac OS) to

move only that point.

Scale by negative amounts to reverse the keyframes in time.

• To taper keyframe values vertically, Ctrl+Alt-drag (Windows) or Command+Option-drag (Mac OS). Tapering

keyframe values allows you to reduce or expand the amplitude of a repeated animation.

• To move one side of the bounding box up or down, Ctrl+Alt+Shift-drag (Windows) or Command+Option+Shift-

drag (Mac OS).

• To move the bounding box’s anchor point, position the Selection tool over the anchor point until the tool changes

to the Move Anchor Point tool , and then drag to position the anchor point.
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Animation presets

About animation presets
Animation presets let you save and reuse specific configurations of properties and animations, including keyframes,

effects, and expressions.

After Effects includes hundreds of animation presets that you can drop into your projects and then modify to suit

your needs.

You can apply an entire animation preset to a layer, or you can apply a single effect or property from an animation

preset. If a property or effect exists in the animation preset but not in the target layer, the property or effect is added

to the target layer.

See Gallery of animation presets for animated illustrations of animation presets included with After Effects.

Many animation presets don’t contain animation; rather, they contain combinations of effects, transform properties,

and so on. You can save one or more properties with all of the desired settings to an animation preset without

including keyframes. A particularly convenient category of animation presets is behaviors, which you can use to

quickly and easily animate without keyframes.

Animation presets can be saved as FFX files and transferred from one computer to another. By default, animation

presets are stored in the Presets directory.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“To apply an animation preset” on page 202

To apply an animation preset
1 Select one or more layers.

2 Do one of the following:

• Select the animation preset in the Effects & Presets panel, and then drag the preset to the selected layer in the

Timeline, Composition, or Effect Controls panel.

• To apply a recently used or saved animation preset, choose Animation > Recent Animation Presets, and then

choose the animation preset from the list.

• To apply selected effects from within an animation preset, press Ctrl (Windows) or Command (Mac OS), select

the effects in Effects & Presets, and then drag them to the Timeline, Composition, or Effect Controls panel. If the

individual effects and properties within an animation preset do not appear, choose Show Preset Contents from the

Effects & Presets panel menu.

• Choose Animation > Browse Presets, navigate to the animation preset you want, and then double-click the

animation preset to apply it to the selected layer.
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To apply one or more components of an animation preset
1 Make sure that Show Animation Presets and Show Preset Contents are selected in the Effects & Presets panel

menu.

2 Expand the preset in the Effects & Presets panel.

3 Do one of the following:

• Select the layer in which you want to use the preset component, and double-click the property you want to apply.

• Drag the property to a layer in the Composition panel or Timeline panel.

Saving animation presets
You can save settings of one or more effects as an animation preset. Saving an effect as an animation preset also saves

any set keyframes, as well as expressions used in the effect. For example, if you created an explosion using several

effects with complex parameter and animation settings within those effects, you can save all those settings as a single

animation preset. You can then apply that animation preset to any other footage, or you can apply any single effect

from that animation preset to any footage. The 20 most recently saved or applied animation presets appear under

Recent Animation Presets in the Animation menu.

Animation presets also appear in the Animation Presets menu in Effect Controls and in Effects & Presets. The

Animation Presets menu in the Effect Controls panel lists only those animation presets that contain the current

effect. For example, if the Mirror effect is selected, the menu will show only those presets that include the Mirror

effect. If the Animation Presets category in Effects & Presets does not appear, choose the Show Animation Presets

option from the Effects & Presets panel menu.

Note: When you apply an effect from the Animation Presets pop-up menu, only the current effect from the animation

preset is applied.

To save an animation preset
1 Select a layer in the Timeline or Composition panel, and apply one or more effects to it. Optionally, animate the

effect using keyframes.

2 Do one of the following:

• In the Effect Controls panel for that layer, select one or more effects to include as an animation preset.

• Select a layer property to save as an animation preset.

3 Choose Save Animation Preset from the Animation menu or from the Effects & Presets panel menu.

4 Specify a file name and location, and then click Save.

Note: If the preset does not appear in Effects & Presets, choose Refresh List from the Effects & Presets panel menu.

To remove an animation preset from the Effects & Presets panel
1 Select the animation preset in the Effects & Presets panel.

2 Choose Reveal In Explorer (Windows) or Reveal In Finder (Mac OS) from the panel menu.

3 Move the preset file (.ffx) out of the After Effects application folder.

4 Choose Refresh List from the Effects & Presets panel menu to update the panel.
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Animating layers

To scale a layer
By default, a layer appears at 100% of its original size in the Layer panel. Change the scale of a layer over time by

dragging the layer’s handles in the Composition panel or by changing the x, y, and z components of the Scale property

in the Timeline panel.

You can scale the layer partially or completely outside the frame. When you scale, the layer is scaled around its anchor

point.

• To scale a layer proportionally in the Composition panel, Shift-drag any layer handle.

• To scale a layer freely in the Composition panel, drag a corner layer handle.

• To scale one dimension only in the Composition panel, drag a side layer handle.

• To scale a layer by nudging it 1%, select a layer and then hold down Alt (Windows) or Option (Mac OS) as you

press + or – on the numeric keypad.

• To scale a layer by nudging it 10%, select a layer and then hold down Alt+Shift (Windows) or Option+Shift (Mac

OS) as you press + or – on the numeric keypad.

• To scale a layer proportionally in the Timeline panel, select the layer, press S to display the Scale property, click the

Constrain Proportions icon  to the left of the Scale values, and enter a new value for the x, y, or z scale.

Alt-click (Windows) or Option-click (Mac OS) the Constrain Proportions icon to activate it and match the height to

the width.

To flip a layer
A layer flips around its anchor point, so if you move the anchor point away from the center of the layer, it may move

when you flip it.

1 In the Timeline panel, select the layer you want to modify.

2 Expand the layer outline to display the Scale property (under Transform), or press S.

3 Right-click (Windows) or Control-click (Mac OS) the underlined Scale value and choose Edit Value from the pop-

up menu that appears.

4 In the Scale dialog box, choose None from the Preserve pop-up menu.

5 Do one of the following and then click OK:

• To flip horizontally, type a negative Width value.

• To flip vertically, type a negative Height value.

Layer flipped with varying height and width values
A. Width 100, Height 100 B. Width -100, Height 100 C. Width 100, Height -100 D. Width -100, Height -100

To flip a layer, drag a layer handle over and past the layer’s anchor point.

A B C D
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See also

“About anchor points” on page 206

To move a layer
Every layer appears at a specific position in the Composition panel. You determine the initial position when you add

a layer to a composition. You can move a layer by dragging it in the Composition panel, by changing the Position

property value in the Timeline panel, or by using keys on your keyboard.

• To move a layer in the Composition panel, drag the layer to a new location.

If you have difficulty selecting a layer in the Composition panel, first select it in the Timeline panel, and then drag it

in the Composition panel. Make sure that you do not drag the layer by its layer handle.

• To nudge a layer by 1 pixel at the current magnification, press the Left, Right, Up, or Down Arrow key.

• To nudge a layer by 10 pixels at the current magnification, hold down Shift as you press the Left, Right, Up, or

Down Arrow key.

• To constrain horizontal and vertical movement while dragging a layer, press Shift after you start dragging the layer

in the Composition panel.

• To snap the edge of the layer to the edge of the Composition panel frame, press Alt+Shift (Windows) or

Option+Shift (Mac OS) after you start dragging the layer in the Composition panel.

Rotating layers
A layer can rotate any number of degrees in relation to its original orientation. You can rotate a layer as many times

as you want, which is useful when you want to spin an object continuously over time. You can animate a layer’s

rotation in the Composition panel using the rotation tool, or in the Timeline panel by typing a revolution or degree

value. You can rotate a layer partially or completely outside the frame. Rotation in 3D adds other options for rotation.

When you rotate a layer, it rotates around its anchor point.

See also

“About anchor points” on page 206

“About z scale” on page 174

To change the angle of a layer by dragging in the Composition panel

1 Select the Rotation tool  from the Tools panel.

2 In the Composition panel, click anywhere on the layer and drag in an arc around the layer. For finer control over

rotation, drag in a wide arc away from the layer’s anchor point. To add multiple rotations, drag the rotation tool

around the layer continuously for the desired number of rotations. To constrain rotation to 45˚ increments, hold

down Shift as you drag.

To change the angle of a layer by entering rotation values in the Timeline panel

1 In the Timeline panel, select the layer you want to rotate.

2 Expand the layer outline to display the Rotation property (under Transform) or press R.

3 Do one of the following:

• Click the first underlined value and enter the number of times you want the layer to rotate completely.
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• Click the second underlined value and enter the number of degrees by which to rotate the layer.

To rotate a selected layer by nudging it 1 degree

❖ Press + or – on the numeric keypad.

To rotate a selected layer by nudging it 10 degrees

❖ Hold down Shift as you press + or – on the numeric keypad.

To rotate a layer along a motion path

You can make a layer rotate automatically as it moves along a motion path. For example, if you animate a toy airplane

careening through the sky, you can apply auto-orient rotation to make the plane turn and change direction.

1 Display the Timeline and Composition panels for a composition.

2 In the Timeline panel, select the layer you want to modify.

3 Choose Layer > Transform > Auto-Orient.

4 Do one of the following, and click OK:

• To activate Auto-Orient, choose Orient Along Path.

• To deactivate Auto-Orient, choose Off.

Before applying auto-orient rotation (left) and after (right)

About anchor points
After Effects rotates and scales from a layer’s anchor point. By default, the anchor point is at the center of a layer. You

can move the anchor point to change rotation into revolution, making the layer rotate from one end or the other. For

example, if you want to animate a maraca so it appears to be shaking, you first need to move the anchor point from

the center of the maraca to the end of the handle.

Anchor point in center of layer (left) compared to anchor point moved to the end of the handle (right)
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Moving an anchor point
Move an anchor point in the Layer panel. As you do so, the selected layer moves in the Composition panel, so you

can view its position in relation to other layers. If Snap To Guides or Snap To Grids is enabled, the anchor point will

snap to them.

You can also use the Pan Behind tool to move a layer’s anchor point without moving the layer’s relative position in

the Composition panel. When you select a layer in either the Composition or Timeline panel and then select the Pan

Behind tool, that layer’s anchor point becomes active and adjustable. The Pan Behind tool saves you steps, because

moving the layer’s anchor point with the Selection tool would shift its resulting position in the Composition panel;

the Pan Behind tool changes the layer’s position in order to compensate for your anchor point adjustment. As a result,

you can move the anchor point without disturbing the Composition panel.

When you use the Pan Behind tool to move the anchor point in the Composition panel (left), After Effects automatically compensates for the
move so that the layer maintains its position relative to the Composition panel (right).

Note: Because a layer’s Anchor Point and Position properties change when you drag the anchor point using the Pan

Behind tool, using the Pan Behind tool to change the anchor point of a moving layer alters the motion path. If your layer

contains a motion path, move the anchor point in the Layer panel, and then select the motion path and adjust it accord-

ingly. For more information on this, see “About anchor points” on page 206.

To move the anchor point by dragging in the Layer panel

1 In the Composition or Timeline panel, double-click the layer you want to modify or select the layer and choose

Layer > Open Layer.

2 Choose Anchor Point Path from the View menu at the bottom right of the Layer panel. The anchor point appears

as a circle with an X through it.

3 Use the Selection tool to drag the anchor point to a new location.

To move a layer anchor point by nudging it 1 pixel at the current magnification

1 In the Timeline panel, double-click the layer.

2 Choose Anchor Point Path from the View menu at the bottom right of the Layer panel.

3 Press the Left, Right, Up, or Down Arrow key.

To move a layer anchor point by nudging it 10 pixels at the current magnification

1 In the Timeline panel, double-click the layer.

2 Choose Anchor Point Path from the View menu at the bottom right of the Layer panel.

3 Hold down Shift as you press the Left, Right, Up, or Down Arrow key.

To move a layer’s anchor point using the Pan Behind tool

1 Select a layer in either the Composition or Timeline panel.
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2 Select the Pan Behind tool.

3 In the Composition panel, use the Pan Behind tool to drag the anchor point to a new location. Notice that the

Position and Anchor point values change for that layer.

To reset the anchor point

After moving the anchor point with the Pan Behind tool, you can quickly reset the anchor point to the center of the

layer. Dragging the anchor point with the Pan Behind tool repositions the layer’s anchor point and changes the layer’s

position value but does not visually move the layer. Resetting the anchor point places it back in the middle of the

layer, but when you do so, the layer moves, not the anchor point.

• To reset the anchor point, double-click the Pan Behind tool  in the Tools panel.

• To reset the anchor point and reset the position to the center of the composition, Alt-double-click (Windows) or

Option-double-click (Mac OS) the Pan Behind tool.

About parent and child layers
To assign one layer’s transformations to the transformations of another layer, use parenting. Parenting can affect all

transform properties except opacity. Assign parent layers in the Parent column in the Timeline panel. A layer can

have only one parent, but a layer can be a parent to any number of 2D or 3D layers within the same composition. You

cannot animate the act of assigning and removing the parent designation—that is, you cannot designate a layer as a

parent at one point in time and then designate it as a normal layer at a different point in time. Parenting layers is

useful for creating complex animations such as linking the movements of a marionette or depicting the orbits of

planets in the solar system.

Dragging the pick whip to designate the saucer layer as the parent to the planet layer

Once a layer is made a parent to another layer, the other layer is called the child layer. Creating a parenting

relationship between layers synchronizes the changes in the parent layer with the corresponding transformation

values of the child layers. For example, if a parent layer moves 5 pixels to the right of its starting position, then the

child layer will also move 5 pixels to the right of its position. You can animate child layers independent of their parent

layers. You can also parent using null objects, which are hidden layers.

Note: To show or hide the Parent column, choose Columns > Parent from the Timeline panel menu.

To work with parent and child layers
When you assign a parent, the child layer’s properties become relative to the parent layer instead of to the compo-

sition. By default, After Effects adjusts any keyframe values of the child layer so that its properties appear to remain

relative to the composition and, thereby, there is no visible alteration to the layer itself. However, you can choose to

have the child layer jump, or visibly alter its properties relative to the parent layer. For example, consider two layers

in a composition, where one of the layer’s Position property has been changed and the other has not. If you assign

the unchanged layer as the child of the changed layer and do not choose the jump option, then the child layer will

not move. If you do choose the jump option, then the child layer’s position shifts so that its position is now relative

to the parent layer.
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Alternately, when you remove a parent from a child layer, you can choose to have the child layer jump to show that

its transform properties are now relative to the composition.

Jumping a layer is useful to depict a change in focus for a particular layer or layers’ animation. For example, you could

animate one child layer to encircle a parent layer, then jump the child to another layer that may be positioned away

from the first parent layer. The child layer can then encircle the new parent at a position relative to the new parent.

Creating a parenting relationship between layers causes the transformation values of the child layers to inherit

changes to the corresponding transformation values in the parent layer.

• To parent a layer, in the Parent column, drag the pick whip of the layer that you want to be the child layer to the

layer that you want to be the parent layer.

• To parent a layer, in the Parent column, click the menu of the layer that you want to be the child, and choose a

parent layer name from the menu.

• To remove a parent from a layer, in the Parent column, click the menu of the layer you want to remove the parent

from, and choose None.

• To select all child layers of a selected parent layer, right-click (Windows) or Control-click (Mac OS) the layer in

the Composition or Timeline panel, and choose Select Children.

• To make a child layer jump when a parent is assigned or removed, hold down Alt (Windows) or Option (Mac OS)

as you assign or remove the parent.

To create a null object
If you want to assign a parent layer, but do not want that layer to be a visible element in your project, use a null object.

A null object is an invisible layer that has all the properties of a visible layer so it can be a parent to any layer in the

composition. Adjust and animate a null object as you would any other layer.

You can apply Expression Controls effects to null objects and then use the null object as a control layer for effects and

animations in other layers.

A composition can contain any number of null objects. A null object is visible only in the Composition and Layer

panels and appears in the Composition panel as a rectangular outline with layer handles. Effects are not visible on

null objects.

❖ Select the Timeline or Composition panel and choose Layer > New > Null Object.

Note: The anchor point of a new null object layer appears in the upper left corner of the layer, and the layer is anchored

in the center of the composition at its anchor point. Change the anchor point as you would for any other layer. For more

information on this, see “About anchor points” on page 206.

See also

“About expressions” on page 555

“To modify properties with Expression Controls effects” on page 561
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Creating and modifying motion paths

About motion paths
When you animate position values, After Effects displays the movement as a motion path. You can create a motion

path for the position of the layer or for the anchor point of a layer. A position motion path appears in the Compo-

sition panel; an anchor point motion path appears in the Layer panel. A motion path appears as a sequence of dots,

where each dot marks the position of the layer at each frame. An X in the path marks the position of a keyframe.

Note:The density of dots between the Xs in a motion path indicates the layer’s relative speed. Dots close together indicate

a lower speed; dots farther apart indicate a greater speed.

You can control the display of motion paths by setting View Options in the Composition panel menu or Display

preferences.

You can modify a motion path either by changing an existing keyframe or adding a new keyframe. A motion path is

less complex and generally easier to modify when you use fewer keyframes to describe the path.

To create a motion path
1 In the Composition panel, position the layer at the point where you want the motion to begin.

2 In the Timeline panel, Press P to display the Position property, and then click the Position stopwatch to create an

initial keyframe.

3 Move the current-time indicator to a point later in time.

4 In the Composition panel, drag the layer to a new position. After Effects automatically creates another keyframe.

5 Repeat steps 3 and 4 until the motion path is complete.

Keyframes and motion paths
If you want to add a new keyframe to a motion path, make sure that the current-time indicator is positioned at the

time at which you want the new keyframe to occur. If you want to change an existing keyframe, make sure that the

current-time indicator is positioned at the existing keyframe; otherwise, After Effects adds a new keyframe if you

move the layer instead of moving points on the motion path.

The motion-path controls that you see in the Composition panel depend on the options selected in the Composition

panel menu. For maximum control over the shape of a motion path, use the pen tools and the spatial interpolation

methods.
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Composition panel with spaceship layer selected
A. Layer handle B. Direction handle on direction line C. Layer keyframe D. Motion path E. Composition panel menu

See also

“About changes in speed” on page 224

“Interpolation methods” on page 220

To move a position keyframe

1 Display the Timeline and Composition panels for a composition.

2 In the Timeline panel, select the layer you want to modify.

3 Press P to display the Position property for the layer.

4 If you cannot see the keyframe you want to modify in the Composition panel, move the current-time indicator in

the Timeline panel to the keyframe.

5 In the Composition panel, use the Selection tool to drag a keyframe marker or its control handles on the motion

path to a new position.

Note: The current-time indicator does not need to be located on a keyframe before you drag it.

Drag a keyframe marker in the Composition panel to move a selected position keyframe.

To add a position keyframe by moving the layer

1 Display the Timeline and Composition panels for a composition.

2 In the Timeline panel, select the layer you want to modify.

3 Press P to display the Position property.

4 In the Timeline panel, move the current-time indicator to the time where you want to add a new keyframe.

B CA D E
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5 Move the layer by dragging it in the Composition panel or by changing its Position property value.

Drag a layer in the Composition panel to add a new position keyframe.

To add a keyframe to a motion path using the Pen tool

1 Display the Timeline and Composition panels for a composition.

2 Select the layer you want to modify.

3 Select the Pen tool  or Add Vertex tool  from the Tools panel.

4 In the Composition panel, move the Pen tool over the motion path where you want to add the new keyframe and

click to add the keyframe.

A new keyframe appears at the frame you clicked, on the motion path and in the Timeline panel. To move the

keyframe, use the Selection tool.

Note: Though the results are different, the tools for manipulating motion-path curves with the Pen tool work in much

the same way as those used to create masks. See “Creating masks with the Pen tool” on page 245.

To change the number of visible motion-path keyframes

By default, After Effects displays motion-path keyframes and dots in the Composition panel that fall within a 15-

second range from the current-time indicator. However, you can change this default. For greater precision when

extensively modifying a motion path, you can display more keyframes. If you want to speed up screen updates, you

can display fewer keyframes.

1 Choose Edit > Preferences > Display (Windows) or After Effects > Preferences > Display (Mac OS).

2 In the Motion Path section of the Display Preferences dialog box, select one of the following options, and then

click OK:

No Motion Path To prevent the display of a motion path and its keyframes.

All Keyframes To display every keyframe in the panel.

No More Than: __ Keyframes To specify a maximum number of keyframes to display, centered on the current-time

indicator.

No More Than: __ To specify a range of time within which keyframes display, centered on the current-time indicator.
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To move all points on a motion path in unison
1 Display the Composition and Timeline panels for a composition.

2 In the Timeline panel, select the layer containing the motion path you want to move.

3 Press P to open the Position property.

4 Click the word “Position” to select all Position keyframes.

5 In the Composition panel, click a keyframe with the Selection tool and drag the path to a new position.

Dragging the motion path by a keyframe

To sketch a motion path with Motion Sketch
You can draw a path for the motion of a selected layer using Motion Sketch, which records the position of the layer

and the speed at which you draw. As you create the path, After Effects generates a position keyframe at each frame,

using the frame rate specified in the composition.

Motion Sketch does not affect keyframes that you have set for other properties. For example, if you set rotation

keyframes for an image of a ball, you can use Motion Sketch to generate position keyframes, so that the ball appears

to roll along the path you created.

For a more fluid animation after you create a motion path using Motion Sketch, use the Smoother to eliminate

unnecessary keyframes.

1 In the Composition or Timeline panel, select the layer for which you want to sketch a motion path.

2 In the Timeline panel, set the work-area markers to the area in which you want to sketch motion.

3 Choose Window > Motion Sketch.

4 Select the appropriate Motion Sketch options:

Show Wireframe Displays a wireframe view of the layer as you sketch the motion path. In addition, you can see any

rotation or scaling that you have applied to the layer.

Show Background Displays the contents of the Composition panel while you sketch. This is useful if you want to

sketch motion relative to other images in your composition. After Effects does not show the animation of other

layers; however, while you sketch, After Effects displays only the first frame at the time you start sketching. If you do

not select this option, After Effects displays the motion path as a series of white dots on a black background.

5 If the composition contains audio, choose Window > Time Controls and click the Audio button to play all audio

in the composition as you sketch.

6 For Capture Speed At, set the capture speed of the motion by specifying a percentage for how fast the motion plays

back in relation to how fast you draw the path. Set the playback speed in one of the following ways:

• To set the playback speed to the exact speed at which you sketch, set the capture speed to 100%.

• To set the playback speed faster than the sketching speed, set the capture speed greater than 100%.



ADOBE AFTER EFFECTS 7.0
User Guide

214

• To set the playback speed slower than the sketching speed, set the capture speed less than 100%.

7 Click Start Capture and then, in the Composition panel, drag the layer to create the motion path. Release the

mouse button to end the path.

Note:After Effects automatically ends the motion path when the capture time reaches the end of either your composition

or the work area.

To create a motion path from a mask
You can instantly create a motion path from any mask that you draw in After Effects (or from a path that you copy

from Adobe Illustrator or Adobe Photoshop), by pasting the mask or path into a layer’s Position property, a layer’s

Anchor Point property, or the effect point property of an effect. The assigned keyframes are set to rove in time, except

for the first and last ones, to create a constant velocity along the mask or path. By default, After Effects assigns a

duration of 2 seconds to the motion path. Adjust the default duration by dragging the first or last keyframe to a new

point in time.

1 Do one of the following:

• Select a mask.

• Create and select a path from Adobe Illustrator or Adobe Photoshop. (For information on creating paths in those

products, see the respective product Help.)

2 Copy the mask or path to the clipboard.

3 In the Timeline panel, select the destination keyframe property.

4 Paste the mask or path.

See also

“To import an Adobe Illustrator path as a mask” on page 249

Assorted animation tools

About motion blur
When you view one frame of motion-picture film or video containing a moving object, the image is often blurred,

because a frame represents a sample of time (in film, a frame is 1/24 of a second long). In that time, a moving object

occupies more than one position as it travels across the frame, so it cannot be shown as a sharp, still object. The faster

the object moves, the more it blurs. The camera shutter angle also affects the appearance of the blur.

In contrast, in a single frame of a computer-generated animation, you may not be able to tell which objects are

moving because all moving objects may appear as sharp and clear as nonmoving objects. Without motion blur, layer

animation produces a strobe-like effect of distinct steps instead of an appearance of continuous change. Adding

motion blur to layers you animate in After Effects makes layer motion appear smoother and more natural.

You can use motion blur when you animate a layer—for example, moving a layer of text across the screen. You cannot

add motion blur to motion that already exists within a layer, such as live-action video. If you want to smooth live-

action video where you assigned a frame rate much lower or higher than the original, use frame blending.

Note: Previous versions of After Effects included an effect called Motion Blur. That effect is now named Directional Blur,

to avoid confusion with motion blurring applied to layers.
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See also

“Frame blending” on page 238

To apply motion blur to a layer

The Motion Blur switch creates a true motion blur based on the layer’s movement in a composition and what you

specify for the shutter angle and phase.

Motion Blur slows previewing and rendering, but you can apply motion blur without displaying it in the Compo-

sition panel. Use the Enable Motion Blur button  near the top of the Timeline panel to control whether layers that

use motion blur affect redraw and rendering. You can also enable motion blur for all compositions when you render

a movie.

❖ Select the layer or composition you want to blur in the Timeline panel, and choose Layer > Switches > Motion

Blur.

You can also apply motion blur by clicking the Motion Blur switch for that layer.

Note: A check mark next to the Motion Blur command in the Layer > Switches menu indicates that motion blurring is

turned on for the selected layer or composition. An icon also appears in the Motion Blur switch column for that layer

in the Timeline panel.

See also

“To set the shutter angle and phase for motion blur” on page 215

“To change render settings” on page 604

To set the shutter angle and phase for motion blur

You can adjust the intensity of motion blur by changing the setting. The shutter angle is measured in degrees,

simulating the exposure allowed by a rotating shutter. If you are not applying motion blur, shutter angle has no effect.

The shutter angle uses the footage frame rate to determine the simulated exposure. For example, entering 90˚ (25%

of 360˚) for 24-fps footage creates an effective exposure of 1/96 of a second (25% of 1/24 of a second). Entering 1˚

applies almost no motion blur, and entering 720˚ applies a high degree of blur. By default, the shutter angle is set to

180˚.

1 Choose Composition > Composition Settings.

2 In the Advanced tab, type a value for Shutter Angle.

3 For Shutter Phase, type a number (up to 360) specifying when you want the shutter to open relative to the frame

start, and then click OK.

Note: You can also change the shutter angle for a composition in the Render Queue panel. (See “To change render

settings” on page 604.)

Smoothing motion and velocity
Smooth motion paths, value curves, and velocity curves to eliminate bumpiness or excess keyframes using The

Smoother, which adds keyframes or removes unnecessary keyframes. You can also use the Smooth expression to

accomplish this.

Although you can smooth a curve for any property, The Smoother is most useful when applied to curves that have

been automatically generated by Motion Sketch, where you may have excess keyframes. Applying The Smoother to

keyframes that have been set manually may result in unexpected changes to the curve.
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When you apply The Smoother to properties that change spatially (such as position), you can smooth only the spatial

curve (the curve defined by the motion). When you apply The Smoother to properties that change only in time (such

as opacity), you can smooth only the value and velocity curves (the curve defined by the value or the velocity).

In addition to adding keyframes or eliminating unnecessary keyframes, The Smoother also applies Bezier interpo-

lation at each keyframe when smoothing the temporal curve.

To smooth a spatial or temporal curve

1 In the Timeline panel, either select all the keyframes for a property to smooth the entire curve, or select at least

three keyframes to smooth only a portion of a curve.

2 Choose Window > The Smoother. In the Apply To menu, The Smoother automatically selects Spatial Path or

Temporal Graph, depending on the type of property for which you selected keyframes in step 1.

3 Set a value for Tolerance. The units of Tolerance match those of the property you are smoothing. New keyframe

values will vary no more than the specified value from the original curve. Higher values produce smoother curves,

but too high a value may not preserve the original shape of the curve.

4 Click Apply and preview the results.

5 If necessary, choose Edit > Undo The Smoother to reset the keyframes, adjust the value for Tolerance, and then

reapply The Smoother.

About randomness and The Wiggler
You can add randomness to any property as it varies over time by using The Wiggler. You can also use the wiggle

expression to accomplish this. (See “Property attributes and methods” on page 584.) Depending on the property and

the options you specify, The Wiggler adds a certain number of deviations to a property by adding keyframes and

randomizing interpolations coming into or out of existing keyframes. You need at least two keyframes to use The

Wiggler.

Using The Wiggler, you can more closely simulate natural movement within specified limits. For example, add

randomness to an animated butterfly to produce fluttering. Add it to brightness or opacity to simulate the flicker of

an old projector.

To add randomness to a property

1 Select a range of keyframes for the property.

2 Choose Window > The Wiggler.

3 For Apply To, select the type of curve you want The Wiggler to change. If you selected keyframes for a property

that varies spatially, you can select Spatial Path to add deviations to the motion, or Temporal Graph to add deviations

to the velocity. If you selected keyframes for a property that does not vary spatially, you can select only Temporal

Graph.

4 Select a Noise Type option to specify the type of deviation due to randomly distributed pixel values (noise):

Smooth Noise Produces deviations that occur more gradually, without sudden changes.

Jagged Noise  Produces sudden changes.

5 Select the dimensions of the property you want to affect:

One Dimension Adds deviations to only one dimension of the selected property. Choose the dimension from the

menu.

All Dimensions Independently adds a different set of deviations to each dimension.
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All Dimensions The Same Adds the same set of deviations to all dimensions.

6 Set Frequency to specify how many deviations (keyframes) per second After Effects adds to the selected

keyframes. A low value produces only occasional deviations, while a high value produces more erratic results. A

value between 0 and 1 creates keyframes at intervals of less than one per second. For example, a value of 0.5 creates

one keyframe every 2 seconds.

7 Set Magnitude to specify the maximum size of the deviations. After Effects sets the specified magnitude to the

units of the selected property, so a value for one property may produce very different results in another property.

8 Click Apply and preview the results.

9 If necessary, choose Edit > Undo The Wiggler to reset the keyframes, adjust the values for Frequency and

Magnitude, and then reapply The Wiggler.

To convert audio to keyframes
The Convert Audio To Keyframes keyframe assistant analyzes amplitude within the composition work area and

creates keyframes to represent the audio. This keyframe assistant creates a new layer called “Audio Amplitude” repre-

senting all audio sources in the composition, with three Expressions effects that contain the keyframes: Left Channel,

Right Channel, and Both Channels.

You can use the Convert Audio To Keyframes keyframe assistant, along with expressions, to link the changes in audio

amplitude to other layer properties, such as Scale or Opacity. For example, link the audio keyframes to the Scale

property of a layer to make the layer grow and shrink as the amplitude increases and decreases.

❖ Select the Timeline panel, and then choose Animation > Keyframe Assistant > Convert Audio To Keyframes.



218

Chapter 11: Advanced animation

Interpolation

About interpolation
Interpolation is the process of filling in the unknown data between two known values. In digital video and film, this

usually means generating new values between two keyframes. For example, if you want a graphic element (such as a

title) to move fifty pixels across the screen to the left, and you want it to do so in 15 frames, you’d set the position of

the graphic in the first and 15th frames, and mark them both as keyframes. Then the software would complete the

work of interpolating the frames in between to make the movement appear smooth. Because interpolation generates

all the frames in between the two keyframes, interpolation is sometimes called tweening. Interpolation between

keyframes can be used to animate movement, effects, audio levels, image adjustments, transparency, color changes,

and many other visual and auditory elements.

The two most common types of interpolation are linear interpolation and Bezier interpolation.

Linear interpolation Creates an evenly-paced change from one keyframe to another, with each in-between frame

given an equal share of the changed value. Changes created with linear interpolation start and stop abruptly and

develop at a constant rate between each pair of keyframes.

Bezier interpolation Allows the rate of change to accelerate or decelerate based on the shape of a Bezier curve, such

as gently picking up speed at the first keyframe and then slowly decelerating into the second.

Controlling change with interpolation
After you create your keyframes and motion paths to change values over time, you may want to make more precise

adjustments to the way that change occurs. After Effects provides several interpolation methods that affect how

change occurs through and between keyframes. For example, if you are setting up motion, you can choose to make

a layer change direction abruptly or smoothly through a curve. After Effects interpolates values for a change using

the values of the keyframes on both ends of the change.

You can control interpolation between keyframe values over time for all layer properties. For layer properties that

involve movement, such as Position, Anchor Point, Effect Point, and 3D Orientation, you can also control interpo-

lation between motion-path keyframes through space.

Using different interpolation methods, you can specify how the keyframes for each layer property interact with each

other in a composition. For example, when creating a motion path, you can make a layer decelerate as it drifts from

the first keyframe to the second, and then make it quickly bounce off a third keyframe as it rounds a curve and speeds

toward the final keyframe. In addition, you can time-stretch and time-remap layers, and you can use the value and

speed graphs to fine-tune animation.

When you make a layer property vary over time, After Effects selects a default graph type to display in the Graph

Editor, based on the property type (temporal or spatial). For temporal properties, such as Opacity, After Effects

defaults to the value graph. For spatial properties, After Effects displays the interpolated values as a motion path in

the Composition or Layer panel, and by default displays the speed graph in the Graph Editor.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.
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See also

“About changes in speed” on page 224

“About the Graph Editor” on page 188

Spatial interpolation and the motion path
When you apply or change spatial interpolation for a property such as Position, you automatically adjust the motion

path in the Composition panel. The different keyframes on the motion path provide information about the type of

interpolation at any point in time. The Info panel displays the spatial interpolation method of a selected keyframe.

When you create spatial changes in a layer, After Effects uses Auto Bezier as the default spatial interpolation.

To change the default to linear interpolation, choose Edit > Preferences > General (Windows) or After Effects >

Preferences > General (Mac OS), and select Default Spatial Interpolation To Linear.

Motion path interpolation
A. Linear B. Auto Bezier C. Continuous Bezier D. Bezier E. Hold

Temporal interpolation and the value graph
Using the value graph in the Graph Editor, you can make precise adjustments to the temporal property keyframes

you’ve created for your animation. The value graph displays x values as red, y values as green, and z values (3D only)

as blue. The value graph provides complete information about the value of keyframes at any point in time in a

composition and allows you to control it. In addition, the Info panel displays the temporal interpolation method of

a selected keyframe.

See also

“Interpolation methods” on page 220

Mixing incoming and outgoing interpolation methods
By default, a keyframe uses one interpolation method, but you can apply two methods: the incoming method applies

to the property value as the current time approaches a keyframe, and the outgoing method applies to the property

value as the current time leaves a keyframe. When you set different incoming and outgoing interpolation methods,

the keyframe icon in Layer bar mode changes accordingly. It displays the left half of the incoming interpolation

method icon and the right half of the outgoing interpolation icon.

To toggle between keyframe icons and keyframe numbers, select Use Keyframe Icons or Use Keyframe Indices from

the Timeline panel menu.

A B C D E
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Timeline keyframe icons in layer bar mode
A. Linear B. Linear in, Hold out C. Auto Bezier D. Continuous Bezier or Bezier E. Linear in, Bezier out

See also

“About changes in speed” on page 224

Interpolation methods
All interpolation methods provided by After Effects are based on the Bezier interpolation method, which provides

direction handles so that you can control the transitions between keyframes. Interpolation methods that don’t use

direction handles are constrained versions of Bezier interpolation and are convenient for certain tasks.

To learn more about how different interpolation methods affect temporal properties, experiment by setting up at

least three keyframes with different values for a temporal layer property—such as Opacity— and change the inter-

polation methods as you view the value graph in the Graph Editor view of the Timeline panel.

To learn more about how different interpolation methods affect a motion path, experiment by setting up three

keyframes for a spatial property—such as Position—with different values on a motion path, and change the interpo-

lation methods as you preview the motion in the Composition panel.

In the following descriptions of interpolation methods, the result of each method is described as if you had applied

it to all of the keyframes for a layer property. This is done to clarify the examples. In practice, you can apply any

available interpolation method to any layer property keyframe.

No interpolation

No interpolation is the state in which there are no keyframes for a layer property—when the stopwatch is turned off

and the I-beam icon  appears in the Timeline panel under the current-time indicator. In this state, when you set

the value of a layer property, it maintains that value for the layer’s duration, unless overridden by an expression. By

default, no interpolation is applied to a layer property. If any keyframes are present for a layer property, some kind

of interpolation is in use. Removing all keyframes from a layer property also removes all interpolation methods from

the layer property.

Linear interpolation

Linear interpolation creates a uniform rate of change between keyframes, which can add a mechanical look to anima-

tions. After Effects interpolates the values between two adjacent keyframes as directly as possible without accounting

for the values of other keyframes.

If you apply Linear interpolation to all keyframes of a temporal layer property, change begins instantly at the first

keyframe and continues to the next keyframe at a constant speed. At the second keyframe, the rate of change switches

immediately to the rate between it and the third keyframe. When the layer reaches the final keyframe value, change

stops instantly. In the value graph, the segment connecting two Linear keyframes appears as a straight line.

If you apply Linear interpolation to all keyframes of a spatial property such as position via the motion path, After

Effects creates a straight line between each keyframe. At each Linear keyframe  where a change of direction

occurs, the motion path forms a corner. For example, you might use Linear interpolation on the position keyframes

of the motion path to create the path of a pinball.

A B C D E
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Auto Bezier interpolation

Auto Bezier interpolation creates a smooth rate of change through a keyframe. You might use Auto Bezier spatial

interpolation to create the path of a car turning on a curving road.

As you change an Auto Bezier keyframe  value, the positions of Auto Bezier direction handles change automati-

cally to maintain a smooth transition between keyframes. The automatic adjustments change the shape of the value

graph or motion path segments on either side of the keyframe. If the previous and next keyframes also use Auto

Bezier interpolation, the shape of the segments on the far side of the previous or next keyframes also changes. If you

adjust an Auto Bezier direction handle manually, you convert it to a Continuous Bezier keyframe .

Auto Bezier is the default spatial interpolation.

Continuous Bezier interpolation

Like Auto Bezier interpolation, Continuous Bezier interpolation creates a smooth rate of change through a keyframe.

However, you set the positions of Continuous Bezier direction handles manually. Adjustments you make change the

shape of the value graph or motion path segments on either side of the keyframe.

If you apply Continuous Bezier interpolation to all keyframes of a property, After Effects adjusts the values at each

keyframe to create smooth transitions. After Effects maintains these smooth transitions as you move a Continuous

Bezier keyframe  on either the motion path or the value graph.

Bezier interpolation

Bezier interpolation provides the most precise control because you manually adjust the shape of the value graph or

motion path segments on either side of the keyframe. Unlike Auto Bezier or Continuous Bezier, the two direction

handles on a Bezier keyframe operate independently in both the value graph and motion path.

If you apply Bezier interpolation to all keyframes of a layer property, After Effects creates a smooth transition

between keyframes. The initial position of the direction handles is calculated using the same method used in Auto

Bezier interpolation. After Effects maintains existing direction handle positions as you change a Bezier keyframe

value.

Unlike other interpolation methods, Bezier interpolation lets you create any combination of curves and straight lines

along the motion path. Because the two Bezier direction handles operate independently, a curving motion path can

suddenly turn into a sharp corner at a Bezier keyframe. Bezier spatial interpolation is ideal for drawing a motion

path that follows a complex shape, such as a map route or the outline of a logo.

Existing direction handle positions persist as you move a motion-path keyframe. The speed of motion along the path

is controlled by the temporal interpolation applied at each keyframe.

Hold interpolation

Hold interpolation is available only as a temporal interpolation method. Use it to change the value of a layer property

over time, but without a gradual transition. This method is useful for strobe effects, or when you want layers to

appear or disappear suddenly.

If you apply Hold temporal interpolation to all keyframes of a layer property, the value of the first keyframe holds

steady until the next keyframe, when the values change immediately. In the value graph, the graph segment following

a Hold keyframe  appears as a horizontal straight line.



ADOBE AFTER EFFECTS 7.0
User Guide

222

Even though Hold interpolation is available only as a temporal interpolation method, the keyframes on the motion

path are visible, but they are not connected by layer-position dots. For example, if you animate a layer’s Position

property using Hold interpolation, the layer holds at the position value of the previous keyframe until the current-

time indicator reaches the next keyframe, at which point the layer disappears from the old position and appears at

the new position.

You can easily freeze the current frame for the duration of the layer using the Freeze Frame command. To freeze a

frame, position the current time indicator at the frame you want to freeze. Make sure the layer is selected and then

choose Layer > Time > Freeze Frame. Time-remapping is enabled, and a Hold keyframe is placed at the position of

the current time indicator to freeze the frame.

Note: If you previously enabled time-remapping on the layer, any keyframes you created will be deleted when you apply

the Freeze Frame command.

You can use Hold interpolation only for outgoing temporal interpolation (for the frames following a keyframe). If

you create a new keyframe following a Hold keyframe, the new keyframe will use incoming Hold interpolation.

To apply or remove Hold interpolation as outgoing interpolation for a keyframe, select the keyframe in the Timeline

panel, and choose Animation > Toggle Hold Keyframe.

See also

“Applying and changing interpolation methods” on page 222

Applying and changing interpolation methods
You can apply and change the interpolation method for any property keyframe. You can apply changes using the

Keyframe Interpolation dialog box, or you can apply them directly to a keyframe in layer bar mode, in a motion path,

or in the Graph Editor. You can also change the default interpolation After Effects uses for spatial properties.

To change interpolation method with the Keyframe Interpolation dialog box

The Keyframe Interpolation dialog box provides options for setting temporal and spatial interpolation and, for

spatial properties only, roving settings.

1 In layer bar mode or in the Graph Editor, select the keyframes you want to change.

2 Choose Animation > Keyframe Interpolation.

3 For Temporal Interpolation, choose one of the following options:

Current Settings Preserves the interpolation values already applied to the selected keyframes. Choose this option

when multiple or manually adjusted keyframes are selected and you do not want to change the existing settings.

Linear, Bezier, Continuous Bezier, Auto Bezier, and Hold Apply a temporal interpolation method using default

values.

4 If you selected keyframes of a spatial layer property, choose one of the following options for Spatial Interpolation:

Current Settings Preserves the interpolation settings already applied to the selected keyframes.

Linear, Bezier, Continuous Bezier, and Auto Bezier Apply a spatial interpolation method using default values.

5 If you selected keyframes of a spatial layer property, use the Roving menu to choose how a keyframe determines

its position in time, and then click OK:

Current Settings Preserves the currently applied method of positioning the selected keyframes in time.
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Rove Across Time Smooths the rate of change through the selected keyframes by automatically varying their

position in time, based on the positions of the keyframes immediately before and after the selection.

Lock To Time keeps the selected keyframes at their current position in time. They stay in place unless you move them

manually.

For more information on smoothing the rate of change through selected keyframes, see “To smooth motion over

several keyframes” on page 230.

To change interpolation method by clicking

❖ Using the Selection tool, do one of the following:

• In layer bar mode, if the keyframe uses Linear interpolation, Ctrl-click (Windows) or Command-click (Mac OS)

the keyframe to change it to Auto Bezier .

• In layer bar mode, if the keyframe uses Bezier, Continuous Bezier, or Auto Bezier, Ctrl-click (Windows) or

Command-click (Mac OS) the keyframe to change it to Linear.

• In the Graph Editor, click the keyframe with the Convert Vertex tool to toggle between linear and Auto Bezier

interpolation.

• In the Graph Editor, select one or more keyframes, and then click the Hold, Linear, or Auto Bezier button at the

bottom of the screen to change the interpolation method.

Interpolation buttons in the Graph Editor
A. Hold B. Linear C. Auto-Bezier

To modify Bezier direction handles
In the Graph Editor, keyframes that use Bezier interpolation have direction handles attached to them. You can

retract, extend, or rotate the direction handles to fine-tune the Bezier interpolation curve.

Retracting a direction handle makes a tighter, sharper Bezier curve. Extending a direction handle makes a larger,

smoother Bezier curve. By default, when you retract or extend a direction handle, the opposite handle on the

keyframe moves with it. Splitting directional handles makes the two direction handles attached to a keyframe behave

independently.

• To retract or extend direction handles, drag the direction handle toward or away from the center of its keyframe

with the Selection tool.

• To split direction handles, Alt-drag (Windows) or Option-drag (Mac OS) a keyframe with the Selection tool. You

can also Alt-drag (Windows) or Option-drag (Mac OS) outside a keyframe to draw new handles, whether or not

there were existing handles.

• To manipulate the direction handles of two neighboring keyframes simultaneously, drag the value graph segment

between the keyframes.

A B C 
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Modifying a Bezier direction handle

See also

“Interpolation methods” on page 220

Speed

About speed graphs
You can fine-tune nearly all changes over time using the speed graph in the Graph Editor. The speed graph provides

information about and control of the value and rate of change for all spatial and temporal values at any frame in a

composition. To view the speed graph, choose Edit Speed Graph from the Choose Graph Type menu .

Speed graph controls
A. Value at the current-time indicator B. Speed graph C. Direction handle (controls speed)

See also

“About changes in speed” on page 224

About changes in speed
When you animate a property in the Graph Editor, you can view and adjust the rate of change of the property in the

speed graph or on the motion path in the Composition or Layer panel. As you adjust the rate in one panel, you can

view the changes in the other. In the speed graph, changes in the graph height indicate changes in speed. Level values

indicate constant speed; higher values indicate increased speed.

In the Composition or Layer panel, the spacing between dots in a motion path indicates speed. Each dot represents

a frame, based on the frame rate of the composition. Even spacing indicates a constant speed, and wider spacing

indicates a higher speed. Keyframes using Hold interpolation display no dots because there is no intermediate

transition between keyframe values; the layer simply appears at the next keyframe’s position.

A B C
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Motion path in Composition panel (left) compared to speed graph in Graph Editor (right)
A. Dots are close together, indicating lower speed (left); speed is constant (right). B. Dots are far apart, indicating greater speed (left); speed is
constant (right). C. Inconsistent spacing of dots indicates changing speed (left); speed decreases and then increases (right).

The change of speed over time is affected by the following factors:

• The time difference between keyframes in the Timeline panel. The shorter the time interval between keyframes,

the more quickly the layer has to change to reach the next keyframe value. If the interval is longer, the layer changes

more slowly, because it must make the change over a longer period of time. You can adjust the rate of change by

moving keyframes forward or backward along the timeline.

• The difference between the values of adjacent keyframes. A large difference between keyframe values, such as the

difference between 75% and 20% opacity, creates a faster rate of change than a smaller difference, such as the

difference between 30% and 20% opacity. You can adjust the rate of change by increasing or decreasing the value

of a layer property at a keyframe.

• The interpolation type applied for a keyframe. For example, it is difficult to make a value change smoothly through

a keyframe when the keyframe is set to Linear interpolation, but you can switch to Bezier interpolation at any time,

which provides a smooth change through a keyframe. If you use Bezier interpolation, you can adjust the rate of

change even more precisely using direction handles.

Linear interpolation (left) causes sharp changes; Bezier interpolation (right) creates smoother change.

To control speed between keyframes
Do any of the following:

• In the Composition or Layer panel, adjust the spatial distance between two keyframes on the motion path.

Increase speed by moving one keyframe position farther away from the other, or decrease speed by moving one

keyframe position closer to the other.

A B C A B C 
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More spatial distance between keyframes increases layer speed.

• In layer bar mode or in the Graph Editor, adjust the time difference between two keyframes. Decrease speed by

moving one keyframe farther away from the other, or increase speed by moving one keyframe closer to the other.

Shorter temporal distance between keyframes increases layer speed.

• Apply the Easy Ease keyframe assistant, which automatically adjusts the speed of change as motion advances

toward and retreats from a keyframe.

See also

“To automatically ease speed” on page 231

Adjusting rate of change with the speed graph
After you have set the shape of a motion path or created keyframes for a property, you may want to adjust the speed

to better simulate the natural world. Using the speed graph, you can adjust motion or the rate of change for a value

just before and just after a keyframe.

For example, you can change the motion of a layer so that it slows just before a keyframe and then speeds up just after

the keyframe, or so that it moves quickly over a certain distance and then slows down smoothly. By adjusting the rise

and fall of the speed graph, you can control how fast or slow a value changes from keyframe to keyframe.



ADOBE AFTER EFFECTS 7.0
User Guide

227

Note: Like the value graph, the speed graph displays x, y, and z (3D only) values in different colors: x values are red, y

values are green, and z values are blue.

You can control the values approaching and leaving a keyframe together, or you can control each value separately.

The incoming handle increases the speed or velocity when you drag it up, and decreases the speed or velocity when

you drag it down. The outgoing handle influences the next keyframe in the same way. You can also control the

influence on speed by dragging the handles left or right.

Direction handles in speed graphs
A. Incoming direction handle B. Speed control C. Outgoing direction handle

Note: If you want a handle to have influence over more than one keyframe, use roving keyframes.

See also

“To adjust influence of a direction handle on an adjacent keyframe” on page 229

To adjust incoming and outgoing rate changes

1 In the Timeline panel, expand the outline for the keyframe you want to adjust.

2 Click the Graph Editor button and select Edit Speed Graph from the Graph Options menu .

3 Using the Selection tool, click the keyframe you want to adjust.

4 (Optional) Do one of the following:

• To split the incoming and outgoing direction handles, Alt-drag (Windows) or Option-drag (Mac OS) a direction

handle.

• To join the direction handles, Alt-drag (Windows) or Option-drag (Mac OS) a split direction handle up or down

until it meets the other handle.

5 Do any of the following:

• Drag a keyframe with joined direction handles up to accelerate or down to decelerate entering and leaving the

keyframe.

• Drag a split direction handle up to accelerate or down to decelerate the speed entering or leaving a keyframe.

• To increase the influence of the keyframe, drag the direction handle away from the center of the keyframe. To

decrease the influence, drag the direction handle toward the center of the keyframe.

Note: When you drag a direction handle beyond the top or bottom of the Graph Editor with Auto Zoom Graph Height

 on, After Effects calculates a new minimum or maximum value based on how far you dragged outside the graph,

and it redraws the graph so that all the values you specify for that layer property are visible in the graph by default.

A B C 
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To create a bounce or peak

Use direction handles to simulate the type of acceleration seen in a bouncing ball. When you create this type of effect,

the speed graph appears to rise quickly and peak.

1 In the Timeline panel, expand the outline for the keyframe you want to adjust.

2 Click the Graph Editor button and display the speed graph for the property.

3 Make sure the interpolation method for the keyframe you want to peak is set to Continuous Bezier or Bezier.

4 Drag the desired keyframe (with joined direction handles) up until it is near the top of the graph.

5 Drag the direction handles on either side of the keyframe toward the center of the keyframe.

Dragging direction handle to create a peak

See also

“Applying and changing interpolation methods” on page 222

To start or stop change gradually

Direction handles can create gradual starts and stops, such as a boat slowing to a stop and then starting again. When

you use this technique, the speed graph resembles a smooth U shape.

1 In the Timeline panel, expand the outline for the keyframe you want to adjust.

2 Click the Graph Editor button and display the speed graph for the property.

3 Make sure the interpolation method for the keyframe you want to adjust is set to Continuous Bezier or Bezier.

4 At the desired keyframe, drag the direction handle down until it is near the bottom of the graph.

5 Drag the direction handles on either side of the keyframe away from the center of the keyframe.

Dragging the direction handle to make a gradual change

See also

“Applying and changing interpolation methods” on page 222
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To adjust influence of a direction handle on an adjacent keyframe

Along with controlling the level of acceleration and deceleration, you can also extend the influence of a keyframe

outward or inward in relation to an adjacent keyframe. Influence determines how quickly the speed graph reaches

the value you set at the keyframe, giving you an additional degree of control over the shape of the graph. The

direction handle increases the influence of a keyframe value in relation to the neighboring keyframe when you drag

it toward the neighboring keyframe, and it decreases the influence on the neighboring keyframe when you drag it

toward the center of its own keyframe.

1 In the Timeline panel, expand the outline for the keyframe you want to adjust.

2 Click the Graph Editor button and display the speed graph for the property.

3 Using the Selection tool, click a keyframe and drag the direction handle left or right.

Changing speed numerically
You may want to specify speed more precisely than you can by dragging direction handles. In such cases, specify

speed numerically in the Keyframe Velocity dialog box.

The exact options available in the dialog box vary depending on the layer property you are editing and may also vary

for plug-ins. For each, speed is expressed as described in the following table:

To specify speed numerically

1 Display the speed graph for the keyframe you want to adjust.

2 Do one of the following:

• Select the keyframe you want to edit, and then choose Animation > Keyframe Velocity.

• Double-click the speed keyframe.

3 Type values for Incoming and Outgoing Velocity Speed.

4 Type values for the following options, and then click OK:

Influence Specifies the amount of influence toward the previous keyframe (for incoming interpolation) or the next

keyframe (for outgoing interpolation).

Continuous Creates a smooth transition by maintaining equal incoming and outgoing velocities.

Note: By default, the proportions of the current Scale or Mask Feather values are preserved as you edit the values. If you

don’t want to preserve proportions, click the link icon next to the property values in the Timeline panel to remove the

icon.

Keyframe type Measurement of speed

Anchor Point and Position Pixels per second

Mask Shape Units per second

Mask Feather Pixels per second for both the x (horizontal) and y
(vertical) dimensions

Scale Percent per second for the x (horizontal), y (vertical),
and z (depth) dimensions

Rotation Degrees per second

Opacity Percentage per second
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To smooth motion over several keyframes
Using the roving keyframe option in After Effects, you can easily create smooth movement across several keyframes

at once. Roving keyframes are keyframes that are not linked to a specific time; their speed and timing are determined

by adjacent keyframes. When you change the position of a keyframe adjacent to a roving keyframe in a motion path,

the timing of the roving keyframe may change.

Roving keyframes are available only for spatial layer properties such as Position. In addition, a keyframe can rove

only if it is not the first or last keyframe in a layer, because a roving keyframe must interpolate its speed from the

previous and next keyframes.

The original motion path (left) indicates different velocities between keyframes. After the keyframes are set to rove (right), the motion path
displays consistent speed over the range of keyframes.

1 In layer bar mode or in the Graph Editor, set up the keyframes for the motion you will smooth.

2 Determine the beginning and ending keyframes for the range you want to smooth.

3 Do one of the following:

• For every keyframe in the range (except the beginning and ending keyframes), select Rove Across Time in the

keyframe menu .

• Select the keyframes you want to rove and choose Animation > Keyframe Interpolation. Then choose Rove Across

Time from the Roving menu.

The intermediate keyframes adjust their positions on the timeline to smooth the speed curve between the beginning

and ending keyframes.

For more information on setting up keyframes for a motion you want to smooth, see “To add a position keyframe

by moving the layer” on page 211.

To revert to a nonroving keyframe

❖ Do one of the following:

• Select the roving keyframe option from the keyframe menu, or drag the roving keyframe left or right.
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• Select the keyframes you want to change and choose Animation > Keyframe Interpolation. Then choose Lock To

Time from the Roving menu.

To automatically ease speed
Although you can manually adjust the speed of a keyframe by dragging direction handles, using Easy Ease automates

the work.

After you apply Easy Ease, each keyframe has a speed of 0 with an influence of 33.33% on either side. When you ease

the speed of an object, for example, the object slows down as it approaches a keyframe, and gradually accelerates as

it leaves. You can ease speed only when coming into or out of a keyframe, or both.

1 In the Graph Editor or in layer bar mode, select a range of keyframes.

2 Do one of the following:

• Choose Animation > Keyframe Assistant > Easy Ease (to ease speed coming both into and out of selected

keyframes), Easy Ease In (to ease speed coming into selected keyframes), or Easy Ease Out (to ease speed coming

out of selected keyframes).

• Click the Easy Ease , Easy Ease In , or Easy Ease Out button located at the bottom of the Graph Editor.

To use Exponential Scale (Pro only)
You can simulate a realistic acceleration of a zoom lens when working with 2D layers by using Exponential Scale,

which converts linear scaling of a layer to exponential scaling. This is useful for creating a cosmic zoom, for example.

Zooming optically with a lens is not linear—the rate of change of scaling increases as you zoom. To simulate this

acceleration, Exponential Scale converts the velocity of the scaling to an exponential curve.

1 In layer bar mode or in the Graph Editor, hold down the Shift key and select starting and ending keyframes for

the scale property.

2 Choose Animation > Keyframe Assistant > Exponential Scale.

Note: Exponential Scale replaces any existing keyframes between the selected starting and ending keyframes.

Time

Time-stretching
Speeding up or slowing down a layer is known as time-stretching. When you time-stretch a layer, the audio file or the

original frames in the footage (and all keyframes that belong to the layer) are redistributed along the new duration.

Use this command only when you want the layer and all layer keyframes to change to the new duration.

Time-stretching a layer redistributes keyframes along the new duration.

If you time-stretch a layer so that the resulting frame rate is significantly different from the original frame rate, the

quality of motion within the layer may suffer. For best results when time-remapping a layer, use the Timewarp effect.
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See also

“Enhancing time-altered motion by blending frames” on page 169

“To apply the Timewarp effect (Pro only)” on page 239

To time-stretch a layer from a specific time

1 In the Timeline or Composition panel, select the layer.

2 Choose Layer > Time > Time Stretch.

3 Type a new duration for the layer, or type a Stretch Factor.

4 To specify the point in time from which the layer will be time-stretched, click one of the Hold In Place options,

and then click OK:

Layer In-point Holds the layer’s current starting time, and time-stretches the layer by moving the Out point.

Current Frame Holds the layer at the position of the current-time indicator (also the frame displayed in the Compo-

sition panel), and time-stretches the layer by moving the In and Out points.

Layer Out-point Holds the layer’s current ending time and time-stretches the layer by moving the In point.

To time-stretch a layer to a specific time

1 In the Timeline panel, move the current-time indicator to the frame where you want the layer to begin or end.

2 Display the In and Out columns by choosing Columns > In and Columns > Out from the Timeline panel menu.

3 Do one of the following:

• To stretch the In point to the current time, press Ctrl (Windows) or Command (Mac OS) as you click the In time

for the layer in the In column.

• To stretch the Out point to the current time, press Ctrl (Windows) or Command (Mac OS) as you click the Out

time for the layer in the Out column.

To time-stretch a layer but not its keyframes

When you time-stretch a layer, the positions of its keyframes stretch with it by default. You can circumvent this

behavior by cutting and pasting keyframes.

1 Make a note of the time at which the first keyframe appears.

2 In the layer outline, click the name of one or more layer properties containing the keyframes you want to keep at

the same times.

3 Choose Edit > Cut.

4 Move or stretch the layer to its new In and Out points.

5 Move the current-time indicator to the time at which the first keyframe appeared before you cut the keyframes.

6 Choose Edit > Paste.

To reverse a layer’s playback direction
You can easily reverse a layer’s playback direction. When you do, all keyframes for all properties on the selected layer

also reverse position relative to the layer. The layer itself maintains its original In and Out points relative to the

composition.
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Note: For best results, replace the layer with a composition that has the same frame size as the layer, and reverse the layer

inside the composition. This is the most accurate way to reverse footage. For more information on this process, called

nesting, see “About nesting” on page 130.

1 In a Timeline panel, select the layer you want to reverse.

2 Do one of the following:

• Press Ctrl+Alt+R (Windows) or Command+Option+R (Mac OS).

• Choose Layer > Time > Time-Reverse Layer.

To reverse keyframes
For any property in a layer, you can select a range of keyframes and reverse their order without reversing the playback

direction of the layer. For example, you can reverse keyframes in the Position property to reverse the motion of an

object. You can select and reverse keyframes across multiple layers and properties, but each set of keyframes for a

property is reversed only within its original time range and not that of any other selected property. Markers in the

Timeline panel are not reversed, so you may need to move markers after reversing keyframes.

Original property values

Scale property values reversed using the Time-Reverse Keyframes keyframe assistant

1 In the Timeline panel, select a range of keyframes you want to reverse.

2 Choose Animation > Keyframe Assistant > Time-Reverse Keyframes.

About time-remapping
In After Effects, you can easily expand, compress, play backward, or freeze a portion of a layer’s duration using a

process known as time-remapping. For example, if you are using footage of a person walking, you can play footage

of the person moving forward, and then play a few frames backward to make the person retreat, and then play

forward again to have the person resume walking.
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Footage is usually displayed at a constant speed in one direction.

Time-remapping distorts time for a range of frames within a layer.

You can also time-remap layers containing audio or both audio and video. When you apply time-remap to a layer

containing audio and video, the audio and video remain synchronized. You can remap audio files to gradually

decrease or increase the pitch, play audio backwards, or create a warbled or scratchy sound. Still-image layers cannot

be time-remapped.

You can remap time in either the Layer panel or the Graph Editor. Remapping video in one panel displays the results

in both. Each provides a different view of the layer duration:

• The Layer panel provides a visual reference of the frames you change, as well as the frame number. The panel

displays the current-time indicator and a remap-time marker, which you move to select the frame you want to play

at the current time.

Layer panel for time remapping
A. Current-time indicator B. Time-remap value C. Remap-time marker D. Navigator bar

• The Graph Editor provides a view of the changes you specify over time by marking your changes with keyframes

and a graph similar to the one displayed for other layer properties. You must be familiar with using keyframes to

remap time in the Graph Editor.

A B C

D
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See also

“Using keyframes” on page 192

“About animation and layer properties” on page 188

Working with the Time Remap graph
When remapping time in the Graph Editor, use the values represented in the Time Remap graph to determine and

control which frame of the movie plays at which point in time. Each Time Remap keyframe has a time value

associated with it that corresponds to a specific frame in the layer; this value is represented vertically on the Time

Remap value graph. When you enable time remapping for a layer, After Effects adds a Time Remap keyframe at the

start and end points of the layer. These initial Time Remap keyframes have vertical time values equal to their

horizontal position on the timeline.

By setting additional Time Remap keyframes, you can create complex motion effects. Every time you add a Time

Remap keyframe, you create another point at which you can change the playback speed or direction. As you move

the keyframe up or down in the value graph, you adjust which frame of the video is set to play at the current time.

After Effects then interpolates intermediate frames and plays the footage forward or backward from that point to the

next Time Remap keyframe. In the value graph, reading from left to right, an upward angle indicates forward

playback, while a downward angle indicates reverse playback. The amount of the upward or downward angle corre-

sponds to the speed of playback.

Similarly, the value that appears in blue next to the Time Remap property name indicates which frame plays at the

current time. As you drag a value graph marker up or down, this value changes accordingly and a Time Remap

keyframe is set, if necessary. You can click this value and type a new one, or click and drag the value to adjust it.

The original duration of the source footage may no longer be valid when remapping time, because parts of the layer

no longer play at the original rate. If necessary, set a new duration for the layer before you remap time.

As with other layer properties, you can view the values of the Time Remap graph as either a value graph or a speed

graph.

If you remap time and the resulting frame rate is significantly different from the original, the quality of motion within

the layer may suffer. Apply frame blending to improve slow- or fast-motion effects.

See also

“Frame blending” on page 238

Time-remapping parts of a layer
There are limitless options for time-remapping in After Effects. For example, you can time-remap an entire layer,

making it play backwards. You can time-remap a frame at the beginning or end of the layer, creating a freeze-frame

effect. Or you can time-remap frames in the middle of the layer, creating a slow-motion effect that only lasts for a

few seconds.

To freeze the first frame without changing the speed

1 In a Composition or Timeline panel, select the layer you want to remap.

2 Choose Layer > Time > Enable Time Remapping.

3 In the Graph Editor, move the current-time indicator to where you want the movie to begin.

4 Click the Time Remap property name to select the start and end keyframes.
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5 Drag the first keyframe to the current-time indicator, which moves the start and end keyframes.

To freeze the last frame without changing the speed

1 In a Composition or Timeline panel, select the layer you want to remap.

2 Choose Layer > Time > Enable Time Remapping.

3 In the Graph Editor, click the Time Remap property name to select the start and end keyframes.

4 Click the final keyframe in the movie to select it.

5 Choose Animation > Toggle Hold Keyframe.

To remap time by dragging keyframes in the Graph Editor

1 In a Composition or Timeline panel, select the layer you want to remap.

2 Choose Layer > Time > Enable Time Remapping.

3 In the Graph Editor, move the current-time indicator to the frame where you want change to begin, and then click

the Add A Keyframe button.

4 On the Time Remap value graph, drag the keyframe marker up or down, watching the Time Remap value as you

drag. To prevent the graph from dropping below the dotted line, press Shift as you drag the graph marker:

Dragging the value graph marker down slows down the layer.

• To slow down the layer, drag the keyframe marker down. (If the layer is playing in reverse, drag up.)

• To speed up the layer, drag the keyframe marker up. (If the layer is playing in reverse, drag down.)

• To play frames backward, drag the keyframe marker down to a value below the previous keyframe value.

• To play frames forward, drag the keyframe marker up to a value above the previous keyframe value.

• To freeze the previous keyframe, drag the current keyframe marker to a value equal to the previous keyframe value

so that the graph line is flat. Another method is to select the keyframe and choose Animation > Toggle Hold

Keyframe, and then add another keyframe where you want the motion to start again.

Time remap graph
A. No change B. Fast motion C. Freeze frame D. Backward motion

C DBA
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To remap time in a Layer panel
1 Open the Layer panel for the layer you want to remap.

2 Choose Layer > Time > Enable Time Remapping. A second time ruler appears in the Layer panel above the default

time ruler and the navigator bar.

3 On the lower time ruler, move the current-time indicator to the first frame where you want the change to occur.

4 On the upper time ruler, the remap-time marker indicates the frame currently mapped to the time indicated on

the lower time ruler. To display a different frame at the time indicated on the lower time ruler, move the remap-time

marker accordingly.

Drag the remap-time marker to replace the frame at the current time marker.

5 Move the current-time indicator on the lower time ruler to the last frame where you want change to occur.

6 Move the remap-time marker on the upper time ruler to the frame you want to display at the time indicated on

the lower time ruler:

• To move the preceding portion of the layer forward, set the remap-time marker to a later time than the current-

time indicator.

• To move the preceding portion of the layer backward, set the remap-time marker to an earlier time than the

current-time indicator.

• To freeze a frame, set the remap-time marker to the frame you want frozen. Then, move the current-time indicator

(lower ruler) to the last point in time where the frame will appear frozen and move the remap-time marker again

to the frame you want frozen.

Before you move a time-remap keyframe, it’s a good idea to select all subsequent time-remap keyframes in the layer

first. This will preserve the timing of the rest of the layer when you remap time for the current keyframe.

Time-remapping audio pitch
The speed graph of the Time Remap property directly relates to the pitch of an audio file. By making subtle changes

to the speed graph, you can create a variety of interesting effects. To avoid screeching audio, you may want to keep

the Speed value below 200%. When the speed is too high, use the Levels controls, located under the Audio property,

to control the volume.

You may hear clicks at the beginning and end of an audio (or an audio and video) layer after setting new In and Out

points in the Time Remap graph. Use the Levels controls to remove these clicks.
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See also

“Previewing audio” on page 136

To change the pitch of an audio layer

1 In a Composition or Timeline panel, select the layer you want to remap.

2 Choose Layer > Time > Enable Time Remapping.

3 Click the Graph Editor button in the Timeline panel to display the Graph Editor, if necessary.

4 Click the Choose Graph Type And Options button at the bottom of the Graph Editor and choose Edit Speed

Graph.

5 Move the current-time indicator to the frame where you want change to begin, and then click the Add A Keyframe

button.

6 On the speed graph below the keyframe, drag a marker, watching the Speed value as you drag.

• To lower the pitch, drag the speed graph marker down.

• To increase the pitch, drag the speed graph marker up.

To remove clicks from new In and Out points

1 If necessary, choose panel > Audio.

2 In the Timeline panel, select the audio (or audio and video) layer to which you applied time-remapping.

3 Expand the layer outline to display the Audio property and then the Audio Levels property.

4 Move the current-time indicator to the new In point and choose Animation > Add Audio Levels Keyframe.

5 In the Audio palette, change the decibel value to 0.0.

6 Press the Page Up key on your keyboard to move the current-time indicator to the previous frame.

7 In the Audio palette, change the decibel level to -96.0.

8 Move the current time to the new Out point and set the decibel level to 0.

9 Press the Page Down key on your keyboard to move the current-time indicator to the next frame.

10 In the Audio palette, change the decibel level to -96.0.

You can change the decibel Slider Minimum value in the Audio Options dialog box, which is available from the

Audio panel menu.

Frame blending
When you time-stretch footage to a slower frame rate or to a rate lower than that of its composition, movement can

appear jerky. This jerky appearance results because the layer now has fewer frames per second than the composition.

Likewise, the same jerky appearance can occur when you time-stretch or time-remap footage to a frame rate that is

faster than that of its composition. To create smoother motion when you slow down or speed up a layer, use frame

blending.

After Effects provides two types of frame blending: Frame Mix and Pixel Motion. Frame Mix takes less time to

render, but Pixel Motion provides much better results, especially for footage that has been drastically slowed down.
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Frame blending slows previewing and rendering. To speed things up, you can apply frame blending without using it

to redraw or render. The Quality setting you select also affects frame blending. When the layer is set to Best quality,

frame blending results in smoother motion but may take longer to render than when set to Draft quality. You can

also enable frame blending for all compositions when you render a movie.

When working with a frame-blended layer in draft mode, After Effects will always use Frame Mix interpolation to

increase rendering speed.

See also

“Time-stretching” on page 231

“About time-remapping” on page 233

“Using motion blur” on page 170

“To change render settings” on page 604

To apply frame blending to a layer

1 Select the layer in the Timeline panel.

2 Do one of the following:

• Choose Layer > Frame Blending > Frame Mix.

• Choose Layer > Frame Blending > Pixel Motion.

A check mark by the appropriate Frame Blending command (Frame Mix or Pixel Motion) indicates that it is applied

to the selected layer. Also, the Frame Blending switch appears in the Switches column for the layer in the Timeline

panel. Remove frame blending either by clicking the Frame Blending switch or by choosing the appropriate Frame

Blending command again.

To enable or disable Frame Blending for previewing and rendering

❖ Select Enable Frame Blending from the Timeline panel menu, or click the Enable Frame Blending button  at

the top of the Timeline panel.

To apply the Timewarp effect (Pro only)
The Timewarp effect gives you precise control over a wide range of parameters when changing the playback speed

of a layer, including interpolation methods, motion blur, and source cropping to eliminate unwanted artifacts. The

Timewarp effect works independently of the Frame Blending switch in the Timeline panel.

1 In the Timeline or Composition panel, select a layer.

2 Choose Effect > Time > Timewarp.

3 In the Effect Controls panel, choose an interpolation method for Method:

Whole Frames Duplicates the last frame shown.

Frame Mix Creates a new frame by interpolating existing frames.

Pixel Motion Creates a new frame by analyzing the pixel movement in nearby frames and creating motion vectors.

4 For Adjust Time By, specify whether to adjust time by Speed or Source Frames. Choose Speed if you want to

specify a time adjustment as a percentage (for example, 200% or 25%). Choose Source Frame if you want to specify

a time adjustment by identifying which source frame is to play at which time (for example, frame 100 of the time-

remapped clip should play frame 50 of the original clip).
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5 Set a value for either Speed or Source Frame. If you are using Source Frame, set at least two keyframes to time-

remap the layer.

6 If you are using Pixel Motion as your interpolation method, adjust any of the following Tuning parameters:

Vector Details Specifies how many motion vectors are created during interpolation. The more vectors you select, the

longer the rendering time. A value of 100 produces one vector per pixel. If your layer has fast-moving motion, it may

look better with lower vector detail.

Smoothing These options let you control the sharpness of the image:

• Build From One Image Lets you generate the final output from the closest single frame as opposed to the closest

two frames. This will result in a sharper image, but jerkier motion.

• Correct Luminance Changes Lets you equalize the luminance between frames before calculating motion.

• Filtering Controls the quality of the filtering used to build the interpolated image.

Note: The Extreme Filtering mode significantly increases rendering time. Since the Filtering option only affects the

sharpness of the final image, the Normal mode is recommended until you are ready for final rendering.

Error Threshold Specifies the accuracy of pixel matching from one frame to the next. A higher value results in fewer

motion vectors and more blending.

Note: If you see edge tearing in your image, try increasing the Error Threshold for more blending. If your image has heavy

grain, try decreasing the Error Threshold so the low-level motion of the grain will be ignored.

Block Size Adjusts the size of the blocks used to calculate the vectors.

Weighting Controls the ratio of red, green, and blue channels used in analyzing an image. Since images are analyzed

based on brightness, changing the channel weight can affect the results. For example, setting the Red Weight and

Green Weight to zero means only the blue channel will be analyzed for motion.

7 To enable motion blur, select Enable Motion Blur and then adjust any of the following options:

Shutter Control Specifies whether you want to adjust the shutter angle manually or have After Effects do it automat-

ically.

Shutter Angle Adjusts the intensity of motion blur. The shutter angle is measured in degrees, simulating the

exposure allowed by a rotating shutter. The shutter angle uses the footage frame rate to determine the simulated

exposure. For example, typing 90˚ (25% of 360˚) for 24 fps footage creates an effective exposure of 1/96 of a second

(25% of 1/24 of a second). Typing 1˚ applies almost no motion blur, and typing 720˚ applies a high degree of blur. By

default, the shutter angle is set to 180˚.

Shutter Samples Controls the quality of the motion blur. A higher value results in a smoother motion blur.

8 To apply matte options, adjust any of the following:

Matte Layer Specifies a layer to use as a matte for defining the foreground and background areas of an image. White

areas in the matte represent the foreground, black represents the background, and gray attenuates between

foreground and background.

Matte Channel Specifies a color channel to use as a matte. Options are Luminance, Inverted Luminance, Alpha, and

Inverted Alpha.

Warp Layer Allows you to apply the motion vectors from the current layers onto a layer selected for Warp Layer.

Applying motion vectors from one layer to another essentially warps one image with the motion from another.

Show Controls the portion of the layer to be time-remapped.
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9 If your image contains unwanted pixels or artifacts at the edges, use the Source Crops option to specify image

boundaries. At the boundaries you specify, pixels will be repeated to eliminate unwanted artifacts.
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Chapter 12: Masks, transparency, and
keying

Transparency overview

About transparency
To create a composite from multiple images, parts of one or more of the images must be transparent. You can use

alpha channels, masks, mattes, and keying to define which parts of an image are transparent and which parts of an

image will be used to obscure parts of another image. By manipulating transparency and choosing blending modes,

you can create a variety of visual effects.

About alpha channels and mattes
Color information is contained in three channels: red, green, and blue. In addition, an image can include an invisible

fourth channel, called an alpha channel, that contains transparency information.

Channels at a glance
A. Separated color channels B. Alpha channel C. All channels viewed together

An alpha channel provides a way to store both images and their transparency information in a single file without

disturbing the color channels.

When you view the alpha channel in the After Effects Composition panel or the Adobe Premiere Pro Monitor panel,

white indicates complete opacity, black indicates complete transparency, and shades of gray indicate partial trans-

parency.

A matte is a layer (or any of its channels) that defines the transparent areas of that layer or another layer. White areas

define what is opaque, and black areas define what is transparent. An alpha channel is often used as a matte, but you

can use a matte other than the alpha channel when you have a channel or layer that defines the desired area of trans-

parency better than the alpha channel does, or in cases where the source image does not include an alpha channel.

Many file formats can include an alpha channel, including Adobe Photoshop, ElectricImage, TGA, TIFF, EPS, PDF,

QuickTime (saved at a bit depth of Millions Of Colors+), and Adobe Illustrator. For Adobe Illustrator EPS and PDF

files, After Effects automatically converts empty areas to an alpha channel.

About straight and premultiplied channels
Files with alpha channels fall into two categories: straight and premultiplied. Although the alpha channels are the

same, the color channels differ.

A B C
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With straight (or unmatted) channels, transparency information is only stored in the alpha channel, not in any of the

visible color channels. With straight channels, the effects of transparency are not visible until the image is displayed

in an application that supports straight channels.

With premultiplied (or matted) channels, transparency information is stored in the alpha channel and also in the

visible RGB channels, which are multiplied with a background color. The colors of semitransparent areas, such as

feathered edges, are shifted toward the background color in proportion to their degree of transparency.

Some software lets you specify the background color with which the channels are premultiplied; otherwise, the

background color is usually black or white.

Straight channels retain more accurate color information than premultiplied channels. Premultiplied channels are

compatible with a wider range of programs, such as Apple QuickTime Player. Often, the choice of whether to use

images with straight or premultiplied channels has been made for you when you receive the assets that you will be

editing and compositing. Fortunately, Adobe Premiere Pro and After Effects recognize both straight and premulti-

plied channels, so either type will produce satisfactory results for most projects.

About keying
Keying is defining transparency by a particular color value (with a color key or chroma key) or brightness value (with

a luminance key) in an image. When you key out a value, all pixels that have similar colors or luminance values

become transparent.

Keying makes it easy to replace a background of a consistent color or brightness with another image, which is

especially useful when working with objects too complex to mask easily. The technique of keying out a background

of a consistent color is often called bluescreening or greenscreening, although you do not have to use blue or green;

you can use any solid color for a background.

Difference keying defines transparency with respect to a particular baseline background image. Instead of keying out

a single-color screen, you can key out an arbitrary background.

About masks
A mask in After Effects is a path, or outline, that is used as a parameter to modify layer effects and properties. The

most common use of masks is the modification of a layer’s alpha channel.

A mask consists of segments and vertices. Segments are the lines or curves that connect vertices. Vertices define where

each segment of a path starts and ends.

A mask can be either an open or closed path. An open path has a beginning point that is not the same as its end point;

for example, a straight line is an open path. A closed path is continuous and has no beginning or end; for example, a

circle is a closed path. Closed-path masks can create transparent areas for a layer. Open paths cannot create trans-

parent areas for a layer but are useful as parameters for an effect; for example, creating a visible line or shape from

the mask using the Stroke effect.

A mask belongs to a specific layer. Each layer can contain multiple masks.

You can draw four types of masks:

Rectangular A rectangular mask can be square. This type of mask is previewed and rendered faster than any other

kind of drawn mask.

Elliptical An elliptical mask can be circular.

Bezier Create any shape of Bezier mask using the Pen tool.
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RotoBezier The main difference between RotoBezier and Bezier is that tangent handles are calculated automatically

with RotoBezier masks.

Types of masks
A. Rectangular mask B. Elliptical mask C. Bezier mask D. RotoBezier mask

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“Effects that you can apply to a mask” on page 258

Creating and importing masks

Creating masks
You can create one or more masks for each layer in a composition using any of the following methods:

• Draw a path using the tools from the Tools panel.

• Specify the dimensions of the mask shape numerically in the Mask Shape dialog box.

• Convert a motion path to a mask.

• Convert a channel to a mask using the Auto-trace command.

• Paste a path copied from another layer or from Adobe Illustrator or Adobe Photoshop.

• Convert a text layer to one or more editable masks using the Create Outlines command.

When you create masks in a layer, the mask names appear in the Timeline panel outline in the order in which you

create the masks. To organize and keep track of your masks, rename them as you would rename layers. When

creating additional masks for one layer in the Layer panel, make sure that the Target pop-up menu in the Layer panel

is set to None; otherwise, you will replace the targeted mask instead of creating a new mask.

A B

DC
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See also

“To rename a layer” on page 158

To create a mask by dragging
You can use this procedure with rectangular or elliptical masks only.

1 Select a layer in the Composition panel or display a layer in the Layer panel.

2 Select the Rectangular Mask tool  or the Elliptical Mask tool  in the Tools panel. If the Rectangular Mask

tool or Elliptical Mask tool is not visible, click and hold the visible Elliptical Mask tool or Rectangular Mask tool icon,

and choose the desired tool from the menu.

3 Position the cursor in the Composition or Layer panel at one corner of the mask you want to draw and drag to the

opposite corner.

4 Use either of the following techniques to alter the mask as you draw:

• Hold down Shift as you drag to create a square with the Rectangular Mask tool or a circle with the Elliptical Mask

tool.

• Begin dragging, and then hold down Ctrl (Windows) or Command (Mac OS) to create a mask that extends from

its center.

To create a mask the size of the layer
You can use this procedure with rectangular or elliptical masks only.

1 Select a layer in the Composition panel or display a layer in the Layer panel.

2 In the Tools panel, double-click either the Rectangular Mask tool or the Elliptical Mask tool.

To create a mask numerically
You can use this procedure with rectangular or elliptical masks only.

1 Select a layer in the Composition panel or display a layer in the Layer panel.

2 Choose Layer > Mask > New Mask. A new mask appears in the Composition or Layer panel with its handles at

the outer edges of the frame.

3 Choose Layer > Mask > Mask Shape.

4 Select Rectangle or Ellipse.

5 Optionally, specify the size and location of the mask’s bounding box.

6 Click OK.

Creating masks with the Pen tool
Using the Pen tool, you can create a Bezier mask of any shape, including straight lines at any angle or smooth, flowing

curves. The Pen tool provides the most precise control over straight lines and curves. You can use the Pen tool’s

RotoBezier option to create curved masks more quickly.
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On curved mask segments for Bezier masks, each selected vertex displays one or two direction lines, ending in

direction handles. The direction lines always touch the curve at the vertices. As a path exits one vertex, the angle and

length of that vertex’s direction line shapes the path. As the path approaches the next vertex, the shape of the path is

less influenced by the previous vertex’s direction line and more influenced by the next vertex’s direction line. Moving

these elements reshapes a Bezier path.

The RotoBezier option automatically calculates the curvature of the segments. RotoBezier masks do not display

direction lines.

Smooth curved paths are connected by vertices called smooth points. Nonsmooth curved paths are connected by

corner points. You can change a vertex to either a smooth or corner point as you draw.

When you move a direction line on a smooth point, the curves on both sides of the point adjust simultaneously. By

contrast, when you move a direction line on a corner point, only the curve on the same side of the point as the

direction line is adjusted.

Adjusting the direction lines on a smooth point (left) and a corner point (right)

To create a Bezier mask using the Pen tool

1 With the Pen tool selected and the RotoBezier option deselected, click in the Composition panel where you want

to place the first vertex.

2 Click where you want to place the next vertex. If you want to create a curved segment, drag the direction line

handle to create the curve that you want.

3 Repeat step 2 until you are ready to close the path.

4 To close the path, do one of the following:

• Position the pointer over the first vertex and, when a closed circle icon appears next to the pointer  , click the

vertex.

• Double-click the last vertex.

To create a RotoBezier mask using the Pen tool

1 With the Pen tool selected and the RotoBezier option selected, click in the Composition panel where you want to

place the first vertex.

2 Click where you want to place the next vertex. The curvature of the segment is determined automatically.

3 Repeat step 2 until you are ready to close the path.

4 To close the path, do one of the following:

• Position the pointer directly over the first vertex and, when a closed circle icon appears next to the pointer , click

the vertex.

• Double-click the last vertex.
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To convert a mask to a RotoBezier mask
You can convert any existing mask to a RotoBezier mask. However, Bezier masks that have adjusted direction lines

change shape when converted to RotoBezier because After Effects calculates RotoBezier segments automatically. You

can convert RotoBezier masks to Bezier without affecting the mask shape.

1 Select a mask in the Layer or Composition panel.

2 Choose Layer > Mask > RotoBezier.

See also

“Changing the shape of a mask” on page 254

To create a mask from a motion path
You can copy position keyframes, anchor point keyframes, or an effect’s point position keyframes and paste those

keyframes on a selected mask. This is useful for creating animations that follow the edges of a mask. When you create

masks from motion paths, make sure that you copy keyframes from a single position property only—do not copy the

keyframes of any other property.

The motion path of the spaceship (left) is copied to the background layer (center) and used by the Vegas effect (right).

1 In the Composition panel, display the motion path from which you want to create the mask.

2 In the Timeline panel, select the successive keyframes along the motion path you want to use as a mask. Click the

Position property name to select all the keyframes. Shift-click successive keyframes to select only a few keyframes.

3 Choose Edit > Copy.

4 In the Timeline panel, select the layer you want to apply the mask to and expand its properties, or open the layer

in its Layer panel.

5 Do one of the following:

• To use the motion path as a new mask, choose Layer > Mask > New Mask.

• To use the motion path as a replacement for an existing mask, select the mask you want to replace.

6 In the Timeline panel, expand the Mask property for the mask you want to create or replace, and select the Mask

Shape value name.

7 Choose Edit > Paste.

Selecting and copying Position keyframes (left); then pasting them in the selected Mask Shape property (right)
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See also

“About motion paths” on page 210

To create a mask from a channel with Auto-trace
You can convert the alpha, red, green, blue, or luminance channel of a layer to one or more masks by using the Auto-

trace command. Auto-trace creates as many Bezier masks as necessary to outline the selected area while leaving the

layer intact. After Effects creates masks with the smallest number of vertices possible while conforming to the

settings that you choose. You can modify a mask created with Auto-trace as you would any other mask.

When you apply Auto-trace, affected layers are automatically set to Best Quality to ensure accurate results.

You can reduce the number of masks created by Auto-trace: Apply a keying effect to the layer to isolate your subject

before applying Auto-trace.

1 In the Timeline panel, do one of the following:

• To create mask keyframes at a single frame, drag the current-time indicator to the desired frame.

• To create mask keyframes across a range of frames, set a work area that spans that range.

2 Select one or more layers.

3 Choose Layer > Auto-trace.

4 Select one of the following:

Current Frame Creates mask keyframes at only the current frame.

Work Area Creates mask keyframes for frames within the work area.

5 Set any of the following options:

Preview Select to preview the mask results and the results of the Auto-trace command’s various options.

Channel Specifies the channel to convert to masks. Choices include Alpha, Red, Green, Blue, and Luminance.

Invert Inverts the input layer prior to searching for edges. For example, if you apply Auto-trace to a square layer that

contains a circular alpha channel, Invert creates a mask for the circle only, instead of creating masks for both the

circle and the square outline.

Blur Blurs the original image before generating the tracing result. Select this option to reduce small artifacts and to

smooth jagged edges in the tracing result. Deselect this option to closely trace details in a high-contrast image.

Specify the radius, in pixels, of the area used for the blurring operation. Larger values result in more blur.

Tolerance Specifies, in pixels, how far the traced shape is allowed to deviate from the shape of the channel.

Threshold Specifies, as a percentage, the value that a pixel’s channel must have for that pixel to be considered part of

an edge. Pixels with channel values over the threshold are mapped to white and are opaque; pixels with values under

the threshold are mapped to black and are transparent.

Minimum Area Specifies the smallest feature in the original image that will be traced. For example, a value of 4

removes features smaller than 2 pixels wide by 2 pixels high from the tracing result.

Corner Roundness Specifies the roundness of the mask curve at vertices. Enter a higher value for smoother curves.

Apply To New Layer Applies the mask to a new solid the same size as the selected layer. This control is automatically

selected for layers that have Collapse Transformations enabled—it creates a new layer the same size as the compo-

sition that contains the layer.
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See also

“About keying” on page 270

“To set a work area” on page 121

“About alpha channels and mattes” on page 242

To import an Adobe Illustrator path as a mask
You can use an Adobe Illustrator path as a mask in an After Effects layer composition by copying the path in Adobe

Illustrator and pasting it directly into the Layer or Composition panel in After Effects. After Effects creates a mask

for each closed path copied from Adobe Illustrator.

Note: The AICB option in the Files & Clipboard section of the Adobe Illustrator Preferences dialog box must be selected.

1 In Adobe Illustrator, create your path, select all of the points along the path, and then choose Edit > Copy.

2 In After Effects, open the Layer panel for the layer into which you want to import the path.

3 Choose Edit > Paste.

Shape drawn in Adobe Illustrator (left) and pasted into After Effects as a mask (right)

Note: You can also use a copied Adobe Illustrator or Adobe Photoshop path as an After Effects motion path. See “To

create a motion path from a mask” on page 214 for more information.

See also

“Preparing Illustrator files” on page 90

To create masks from text characters
For each character in a text layer, you can create a separate mask. The Create Outlines command extracts the outlines

for each character, creates masks from the outlines, and puts the masks on a new solid layer. You can then use these

masks as you would any other mask; for example, you can apply effects such as Audio Waveform or Scribble Fill. By

default, all masks created using the Create Outlines command use the Difference mask mode.

If you want to export text layers to Macromedia Flash (SWF) format, use the Create Outlines command on all text

layers first.

1 Do one of the following:

• To create masks for all the characters in a text layer, select the text layer in the Timeline panel.

• To create masks for specific characters, select the characters in the Composition panel.

2 Choose Layer > Create Outlines.
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See also

“About text layers” on page 283

Working with masks

To view masks
❖ Do one of the following:

• To view masks in the Composition panel, choose View Options from the Composition panel menu, select Masks

in the Layer Controls section of the View Options dialog box, and then click OK.

• To view masks in the Layer panel, choose Masks or Anchor Point Path from the Layer panel View menu.

Selecting masks, segments, and vertices
Unlike layers, masks can have more than one level of selection. You can select a mask as a whole path, which is appro-

priate when you want to move or resize a mask. However, if you want to change the shape of a mask, select one or

more points on it. Selected points appear solid, and unselected points appear hollow.

To select or deselect masks in the Layer or Composition panel

• To select a vertex on a mask, click the vertex with the Selection tool . To add vertices to the selection, Shift-click

them.

• To select a mask segment, click the segment with the Selection tool. To add segments to the selection, Shift-click

them.

• To select an entire mask, Alt-click (Windows) or Option-click (Mac OS) a segment, vertex, or handle of a mask

with the Selection tool, or select any portion of the mask and choose Edit > Select All or press Crl+A (Windows)

or Command+A (Mac OS). To add masks to the selection, Alt+Shift-click (Windows) or Option+Shift-click (Mac

OS) them.

• To select masks by dragging, select a mask or portion of a mask to enter mask editing mode and then drag with

the Selection tool to draw a bounding box completely around the vertices or masks that you want to select. To add

masks or vertices to the selection, hold down the Shift key as you draw additional bounding boxes.

• To select all masks on a layer, select a mask on the layer, and choose Edit > Select All or press Ctrl+A (Windows)

or Command+A (Mac OS).

• To deselect all masks, press Ctrl+Shift+A (Windows) or Command+Shift+A (Mac OS).

• To select an adjacent mask on a layer, press Alt+Tilde (~) (Windows) or Option+Tilde (~) (Mac OS) to select the

next mask, or Shift+Alt+Tilde (~) (Windows) or Shift+Option+Tilde (~) (Mac OS) to select the previous mask.

• To deselect a mask, click anywhere other than on the mask.

• To remove a vertex or segment from a selection, Shift-click the vertex or segment.

To use the Selection tool when the Pen tool is selected, hold down Ctrl (Windows) or Command (Mac OS).

To select masks in the Timeline panel

1 Click the right arrow next to a layer name to expand it.

2 Click the right arrow next to the Masks heading to expand it, revealing all masks on that layer.
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3 Do any of the following:

• To select one mask, click its name.

• To select a contiguous range of masks, Shift-click the names of the first and last masks in the range.

• To select discontiguous masks together, Ctrl-click (Windows) or Command-click (Mac OS) the names of any

masks you want to include.

Note: You can select only whole masks in the Timeline panel. To select individual vertices on a mask, use the Compo-

sition or Layer panel.

To lock or unlock masks
Locking a mask prevents you from selecting it in the Timeline, Composition, and Layer panels or setting it as a target

in the Layer panel. Use this feature to avoid unwanted changes to the mask.

1 In the Timeline panel, expand the Mask property.

2 In the A/V Features column, click the box underneath the lock icon  next to the mask you want to lock or

unlock. A mask is locked and cannot be selected when the lock icon appears in the box.

Note: To unlock multiple masks at one time, select one or more layers and choose Layer > Mask > Unlock All Masks.

Saving and reusing masks
You can reuse masks in other layers and compositions. It is particularly useful to store Bezier masks you’ve spent a

long time perfecting. You can even create a project with compositions that exist just to store complex layer masks.

Mask shapes are stored inside a composition in a project file. When you want to use a mask from another project,

import that project into your current project.

To save a mask

1 In the Timeline panel for the composition containing the layer and mask you want to save, expand the layer and

its mask properties.

2 Do one of the following:

• To save an animated mask, select the mask keyframes you want to save.

• To save a nonanimated mask, select the mask.

3 Copy the mask or keyframes, and paste the mask or keyframes to a new layer. The new layer can be a simple solid.

To reuse a mask

1 Open the composition containing the mask you want to reuse. If you saved the mask in another project, import

the project and then open the mask’s composition.

2 In the Timeline panel, expand the saved mask’s layer and mask properties.

3 Select the mask or keyframes.

4 Copy the mask or keyframes, and paste the mask or keyframes to the layer to which you want to apply the mask.

To delete masks
❖ Do one of the following:

• To delete one mask, select the mask in the Timeline panel and press Delete.
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• To delete all masks, select the layer containing the masks you want to remove and choose Layer > Masks > Remove

All Masks.

To duplicate a mask
If you create a mask on one area of a layer and want to put a copy of it on another area of the layer, use the Duplicate

command.

1 Select the mask in the Composition, Layer, or Timeline panel, and then do one of the following:

• Choose Edit > Duplicate.

• Choose Edit > Copy, deselect the mask, and then choose Edit > Paste.

2 In the Composition or Layer panel, drag the duplicated mask to another location on the layer.

Controlling mask color
To help you identify and work with masks, the Composition and Layer panels outline a mask’s shape with color, and

the Timeline panel displays that same color next to the mask’s name. By default, After Effects uses the color yellow

for all masks. To make each mask more distinct, you can manually change a mask’s color using the Timeline panel,

or you can set After Effects to cycle mask colors.

To apply a new color to a mask outline

To make it easier to work with multiple masks in the Composition panel, you can apply different colors to each mask

outline.

1 Select the mask in the Timeline panel.

2 If necessary, expand the Mask properties by pressing the M key.

3 Click the color swatch just to the left of the mask name, pick a new color, and click OK.

To set After Effects to cycle mask colors

1 Choose Edit > Preferences > User Interface Colors.

2 Select Cycle Mask Colors.

After Effects cycles through eight different mask colors.

To specify a mask as target for new mask shapes
As soon as you draw the first point on your first mask for a layer, the Layer panel displays a Target menu, which you

use to specify a mask as the target for all new mask shapes.

❖ In the Layer panel, choose the mask name from the Target menu.

Menu selections to specify a mask in the Layer panel
A. View pop-up menu B. Target pop-up menu

A

B
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When you create a new mask shape while a mask is chosen in the Target menu, the targeted mask is replaced by the

new shape. You can change this behavior by choosing None from the Target menu so that any new mask shape you

create in the Layer panel creates a new mask instead of replacing an existing mask. You can also lock a mask to

prevent changes to it.

See also

“To lock or unlock masks” on page 251

To move, scale, and rotate masks or vertices
In one step, you can scale and rotate an entire mask (or selected vertices in one or more masks) using the Free

Transform Points command. When you use this command, a bounding box surrounds the selected vertices, and an

anchor point appears in the center of the bounding box to mark the effect point for the current transformation. You

can scale and rotate the selected vertices by dragging the bounding box or its handles. You can also change the point

from which the mask rotates or scales by moving the bounding box anchor point. The free-transform bounding box

handles and anchor point exist independently of the handles and anchor point for the layer.

Note: When you animate rotation using Free Transform Points, the vertices of the mask are interpolated in a straight

line from keyframe to keyframe. For this reason, the results may be different from what you expect.

Free Transform points
A. Bounding box handle B. Free Transform Points bounding box C. Bounding box anchor point D. Layer anchor point

1 Display the layer containing the mask or masks you want to transform in the Composition or Layer panel.

2 Using the Selection tool, do one of the following:

• To transform any number of vertices, select the vertices you want to transform and choose Layer > Mask > Free

Transform Points.

• To transform the entire mask, select it in the Timeline panel and choose Layer > Mask > Free Transform Points.

3 To move the bounding box’s anchor point, position the Selection tool over the bounding box anchor point

until the Selection tool changes to a move anchor point icon . Drag to position the anchor point.

4 Do any combination of the following:

• To move the mask or selected vertices, position the pointer inside the bounding box and drag.

• To scale the mask or selected vertices, position the pointer on a bounding box handle and, when the pointer

changes to a straight, double-sided arrow , drag to a new size. Hold down Shift as you drag to constrain the

scale. Hold down Ctrl (Windows) or Command (Mac OS) as you drag to scale around the bounding box’s anchor

point.

• To rotate the mask or selected vertices, position the pointer just outside the free-transform bounding box and,

when the pointer changes to a curved double-sided arrow , drag to rotate.

A

D

B

C
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5 To close the free-transform bounding box, double-click anywhere in the Composition or Layer panel.

Modifying masks

Changing the shape of a mask
In the Layer or Composition panel, you can freely change the shape of a mask. You can move, delete, or add vertices

to reshape a mask; create a flexible outline to accommodate any shape; and even change a mask shape over time.

Some changes require the use of tools grouped with the Pen tool in the Tools panel. To reveal these tools, click and

hold the Pen tool in the Tools panel. When modifying a mask, make sure that you click only existing vertices or

segments; otherwise, you may create a new mask instead.

To move, add, or delete a vertex

❖ Do one of the following:

• To move a vertex, drag the vertex with the Selection tool .

You can temporarily switch from the Pen tool to the Selection tool by pressing Ctrl (Windows) or Command (Mac

OS).

• To add a vertex to a mask, use the Add Vertex tool  to click the segment between two existing vertices.

• To delete a vertex from a mask, use the Delete Vertex tool  to click the vertex.

To adjust the shape of a path segment

❖ Do one of the following with the Selection tool:

• Drag a vertex.

• Drag the direction handles extending from an adjoining smooth vertex.

• Drag a curved segment.

Note: Dragging a curved segment on a RotoBezier mask also moves the vertices.

To toggle a vertex between a smooth point and a sharp corner point

❖ Click the vertex with the Convert Vertex tool .

Note: To select the Convert Vertex tool, with the Pen tool selected, hold down Alt (Windows) or Option (Mac OS). Alter-

natively, in the Tools panel, select the Convert Vertex tool. If the Convert Vertex tool is not visible, click and hold one of

the visible Pen tool icons and choose the Convert Vertex tool from the menu.

To adjust the tension of a RotoBezier mask

1 If you want to adjust the tension of more than one vertex simultaneously, select them.

2 Do any of the following:

• Using the Convert Vertex tool , drag a vertex.

• Using the Pen tool , Alt-drag (Windows) or Option-drag (Mac OS) a selected vertex.

• Using the Selection tool , Ctrl+Alt-drag (Windows) or Command+Option-drag (Mac OS) a selected vertex.

The Adjust Tension pointer  appears as you drag a vertex in the RotoBezier mask.
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Clicking a vertex instead of dragging sets the vertex to a corner point (100% tension); clicking again sets the vertex

to a smooth point (33% tension). Dragging up or to the right decreases the selection’s tension, increasing the curve

of adjacent path segments; dragging down or to the left increases the selection’s tension, decreasing the curve of

adjacent path segments.

Note: To view the tension value of a vertex, look in the Info panel as you adjust the tension.

To adjust the edges of a mask

To finely expand or contract all edges of a mask, use the Mask Expansion property. This property’s value represents,

in pixels, how far from the original mask edge you are expanding or contracting the adjusted edge.

1 In the Timeline panel, expand the Mask properties of the layer you want to adjust.

2 Drag the underlined value for Mask Expansion.

Note: To reset a mask to its default boundaries, select the mask in the Timeline panel and choose Layer > Mask > Reset

Mask.

To change a mask shape numerically

1 Select the mask.

2 In the Timeline panel, expand the Mask properties.

3 Next to the Mask Shape property, click the underlined word, and specify the changes in the Mask Shape dialog

box.

4 Click OK.

To replace one mask shape with another
1 In the Layer panel, select the mask you want to replace from the Target menu.

2 Draw a new mask shape.

Note: After you create the new mask shape in the Layer panel, select None from the Target menu; otherwise, all subse-

quent masks you create will replace the targeted mask.

To adjust feathering in the Timeline panel
Feathering softens the edges of a mask by fading it from more transparent to less transparent over a user-defined

distance. Using the Mask Feather property, you make mask edges hard-edged or soft-edged (feathered). By default,

the feather width straddles the mask edge, half inside and half outside. For example, if you set the feather width to

25, the feathering extends 12.5 pixels inside the mask edge and 12.5 pixels outside it. You can also extend or contract

the mask edges to control where the mask feathering appears.
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Setting the Mask Feather property
A. Masked layer with 5-pixel feather B. Masked layer with 40-pixel feather C. Result with 5-pixel feather D. Result with 40-pixel feather

Mask feathering takes place only within the dimensions of the layer frame area. Therefore, a feathered mask shape

should always be slightly smaller than the layer area and should never move to the very edge of the layer. If a mask

feather extends beyond the layer area, the feathered edge ends abruptly.

You can adjust the feathering of a layer’s mask by specifying precise values or by dragging in the Timeline panel.

1 Expand the desired layer and its Mask properties in the Timeline panel.

2  If you want to constrain the x and y values so that they are constrained to change proportionally, click the

Constrain Proportions switch next to the Mask Feather property so that the Constrain Proportions icon appears.

3 Do one of the following:

• Drag the underlined value for Mask Feather.

• Right-click (Windows) or Control-click (Mac OS) the underlined value for Mask Feather, and select Edit Value.

Specify an amount for horizontal or vertical feathering.

Note: You can apply only uniform feathers, that is, feathers that expand the mask horizontally and vertically, on layers

that have Continuously Rasterize enabled in the Timeline panel.

To adjust the opacity of a mask
Masks have an opacity property that you can use to adjust the transparency of any mask, or even to turn masks on

and off temporarily.

1 In the Timeline panel, expand the mask properties of the mask you want to adjust.

2 Drag the underlined value for Mask Opacity.

To apply motion blur to a mask
Motion blur creates a blur based on a mask’s movement in the composition. You can apply motion blur to any one

of the individual masks on a layer.

C D

BA
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Note: The mask must contain keyframes that create enough movement to result in a realistic motion blur.

1 Select one or more masks.

2 Choose Layer > Masks > Motion Blur, and choose one of the following options:

Same As Layer To control the mask’s blur using the Motion Blur button.

On To render the mask blur even if the Motion Blur button is not selected. (The Enable Motion Blur button must be

selected for this option to work.)

Off To apply no motion blur to the mask.

3 Click the Enable Motion Blur button in the Timeline panel to view the blur.

Motion blur settings for a layer and a composition
A. Enable Motion Blur button B. Motion Blur switch

See also

“About motion blur” on page 214

To invert a mask
The image area inside the mask outline is fully opaque, and the area outside the mask outline is transparent. If you

want to create the appearance of a hole in a video layer to reveal a layer underneath, switch the inside and outside

areas by inverting the mask. You cannot change the mask state using keyframes; a mask is either inverted or not

inverted for the entire duration of a composition.

Default behavior for a drawn mask (left); same mask inverted (right)

1 Select the mask you want to invert. (You can select multiple masks to simultaneously invert them all.)

2 In the Timeline panel, select the Inverted option next to the mask name.

If you have multiple masks in one layer, you can apply mask modes to create complex transparent shapes or varying

levels of transparency.

A

B
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Effects that you can apply to a mask
You can apply the following standard After Effects effects to a mask shape: Path Text, Audio Waveform, Audio

Spectrum, Stroke, Fill (closed paths only), Vegas, and Smear (closed paths only).

You can apply the following After Effects Professional edition effects to a mask shape: Reshape (closed paths only)

and the Inner/Outer Key (closed paths only).

The Particle Playground effect (Pro only) can also use a mask shape to define particle boundaries.

See also

“About effects” on page 348

“Path Text effect” on page 534

“Audio Spectrum effect” on page 442

“Audio Waveform effect” on page 443

“Stroke effect” on page 460

“Fill effect” on page 449

“Vegas effect” on page 460

“Smear effect” on page 433

“Reshape effect (Pro only)” on page 430

“Inner/Outer Key effect (Pro only)” on page 465

“Wall controls for Particle Playground (Pro only)” on page 508

To create a visible outline or solid shape from a mask
Each mask in a layer can have different fill and stroke settings. You can apply an outline to an open or closed mask

path, but if you want to fill a mask, it must be a closed path.

❖ Apply the Stroke effect or Fill effect to the mask.

Note: By default, the Fill effect will apply to all masks in the layer. To modify the effect, expand the effect property in the

Timeline panel and deselect All Masks, or choose a mask from the Fill Mask menu. The Stroke effect is applied to the first

mask in the layer by default. To modify the effect, expand the effect property in the Timeline panel and select All Masks,

or choose a mask from the Path menu.

See also

“About effects” on page 348

“Fill effect” on page 449

“Stroke effect” on page 460
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Blending modes and mask modes

About blending modes
Blending modes for layers control how each layer blends with or reacts to layers beneath it. The stencil and silhouette

blending modes affect the alpha channels of layers beneath them. Other blending modes for layers affect how colors

appear when blended with the colors from other layers. Blending modes for layers in After Effects (formerly referred

to as layer modes) are identical to blending modes in Adobe Photoshop.

You can’t animate blending modes by using keyframes. If you want a blending mode to change at a certain time, split

the layer at that time and apply the new blending mode to the part of the layer that continues. You can also use the

Compound Arithmetic effect, the results of which are similar to those for blending modes but can change over time.

For more information, see “Compound Arithmetic effect” on page 398.

You apply a blending mode to the layer above the layers you want it to interact with. When you specify blending

modes, it is helpful to think of the results in the following terms:

Underlying colors Colors of the layers located below the layer to which you want to apply the mode.

Layer colors Original colors in the layer where you set the blending mode.

Resulting colors Final colors of the composite.

Note: To blend colors with a gamma value of 1, choose File > Project Settings and select Linear Blending. Deselect this

option to blend colors in the project’s color space.

Blending modes for masks on the same layer are called mask modes.

Some effects include their own blending mode options. See the descriptions of the individual effects for details.

See also

“About mask modes” on page 264

“Splitting layers” on page 157

“To choose a working color space” on page 65

To apply a blending mode
1 If the Mode column is not visible in the Timeline panel, click the Switches/Modes button at the bottom of the

Timeline panel or choose Columns > Modes from the Timeline panel menu.

2 From menu in the layer’s Mode column, choose a mode.
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Gallery of blending modes

Normal Dissolve Dancing Dissolve

Darken Multiply Linear Burn

Color Burn Classic Color Burn Add

Lighten Screen Linear Dodge

Color Dodge Classic Color Dodge Overlay

Soft Light Hard Light Linear Light

Vivid Light Pin Light Hard Mix
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Normal Composites the layer on top of underlying layers.

Dissolve Randomly replaces layer colors with colors from underlying layers, based on layer transparency. (The

Advanced 3D rendering plug-in doesn’t support the Dissolve blending mode.)

Dancing Dissolve Functions the same as Dissolve, except that the placement of random color changes varies over

time. (The Advanced 3D rendering plug-in doesn’t support the Dancing Dissolve blending mode.)

Darken Compares the channel values of the underlying and layer colors and displays the darker of the two. Speci-

fying this mode can cause color shifts in layers with color.

Multiply Multiplies the color values in the layers and divides the result by the maximum pixel value of either 8-bpc,

16-bpc, or 32-bpc pixels depending on which mode you are in. The resulting color is never brighter than the original.

Linear Burn Looks at the color information in each layer and darkens the original layer color to reflect the under-

lying color by decreasing the brightness. Pure white produces no change.

Color Burn Looks at the color information in each layer and darkens the original layer color to reflect the underlying

layer color by increasing the contrast. Pure white in the original layer does not change the underlying color. This

mode is the same as the Color Burn blending mode in Photoshop.

Difference Classic Difference Exclusion

Hue Saturation Color

Luminosity Stencil Alpha Stencil Luma

Silhouette Alpha Silhouette Luma Alpha Add

Luminescent Premul
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Classic Color Burn The Color Burn mode from After Effects 5.0 and earlier, renamed Classic Color Burn. Use it to

preserve compatibility with older projects; otherwise, use Color Burn. Classic Color Burn darkens the resulting color

based on the original layer color. The darker the original layer color, the darker the resulting color. Pure white in the

original layer does not change the underlying color. Pure black in the original layer usually changes the underlying

color to black.

Add Combines the color values of the layer and underlying colors. The resulting color is lighter than the original.

This is a good way to combine nonoverlapping images in two layers. Pure black in a layer does not change the under-

lying color. Pure white in the underlying color is never changed.

Lighten Compares the channel values of the underlying and layer colors and displays the lighter of the two. Speci-

fying this mode can cause color shifts in layers with color.

Screen Multiplies the inverse brightness values of the colors in all layers. The resulting color is never darker than the

original. Using the Screen mode is similar to the traditional technique of superimposing two different film negatives

and printing the result.

Linear Dodge Looks at the color information in each layer and brightens the original layer color to reflect the under-

lying color by increasing the brightness. Pure black produces no change.

Color Dodge Looks at the color information in each layer and brightens the original layer color to reflect the under-

lying layer color by decreasing the contrast. Pure black in the original layer does not change the underlying color.

This mode is the same as the Color Dodge blending mode in Photoshop.

Classic Color Dodge The Color Dodge mode from After Effects 5.0 and earlier, renamed Classic Color Dodge. Use

it to preserve compatibility with older projects; otherwise, use Color Dodge. Classic Color Dodge brightens the

resulting color based on the original layer color. The lighter the original layer color, the brighter the resulting color.

Pure black in the original layer does not change the underlying color. Pure white in the original layer usually changes

the underlying color to white.

Overlay Mixes colors between layers, preserving highlights and shadows to reflect the light and dark areas of the

layer colors.

Soft Light Darkens or lightens resulting colors, depending on the layer color. The result is similar to shining a

diffused spotlight on the layer. If the underlying color is lighter than 50% gray, the layer lightens. If the underlying

color is darker than 50% gray, the layer darkens. A layer with pure black or white becomes markedly darker or lighter,

but does not become pure black or white.

Hard Light Multiplies or screens the resulting color depending on the original layer color. The result is similar to

shining a harsh spotlight on the layer. If the underlying color is lighter than 50% gray, the layer lightens as if it were

screened. If the underlying color is darker than 50% gray, the layer darkens as if it were multiplied. This mode is

useful for creating the appearance of shadows on a layer.

Linear Light Burns or dodges the colors by decreasing or increasing the brightness, depending on the underlying

color. If the underlying color is lighter than 50% gray, the layer is lightened because the brightness is increased. If the

underlying color is darker than 50% gray, the layer is darkened because the brightness is decreased.

Vivid Light Burns or dodges the colors by increasing or decreasing the contrast, depending on the underlying color.

If the underlying color is lighter than 50% gray, the layer is lightened because the contrast is decreased. If the under-

lying color is darker than 50% gray, the layer is darkened because the contrast is increased.

Pin Light Replaces the colors, depending on the underlying color. If the underlying color is lighter than 50% gray,

pixels darker than the underlying color are replaced, and pixels lighter than the underlying color do not change. If

the underlying color is darker than 50% gray, pixels lighter than the underlying color are replaced, and pixels darker

than the underlying color do not change.
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Hard Mix Enhances the contrast of the underlying layer that is visible beneath a mask on the source layer. The mask

size determines the contrasted area; the inverted source layer determines the center of the contrasted area.

Difference Looks at the color information in each layer and subtracts either the underlying color from the original

layer color or the original layer color from the underlying color, depending on which has the greater brightness value.

Pure white inverts the original layer color values; black produces no change. This mode is the same as the Difference

blending mode in Photoshop.

Classic Difference The Difference mode from After Effects 5.0 and earlier, renamed Classic Difference. Use it to

preserve compatibility with older projects; otherwise, use Difference. Classic Difference subtracts the channel values

of the layer and underlying colors and displays the absolute value of the result.

Exclusion Creates a result similar to but lower in contrast than the Difference mode. Blending with white inverts the

underlying color values. Blending with black produces no change.

Hue Creates resulting colors with the luminance and saturation of the underlying colors and the hue of the layer

colors.

Saturation Creates resulting colors with the luminance and hue of the underlying colors and the saturation of the

layer colors. If you use this mode with a layer having no saturation (gray), there is no change.

Color Creates resulting colors with the luminance of the underlying colors and the hue and saturation of the layer

colors. This preserves the gray levels in the image.

Luminosity Creates resulting colors with the hue and saturation of the underlying colors and the luminance of the

layer colors. This mode is the inverse of the Color mode.

Stencil Alpha Creates a stencil using the layer’s alpha channel.

Stencil Luma Creates a stencil using the layer’s luma values. The lighter pixels of the layer are more opaque than the

darker pixels.

Silhouette Alpha Creates a stencil using the layer’s alpha channel.

Silhouette Luma Creates a silhouette using the layer’s luma values. The lighter pixels of the layer are more trans-

parent than the darker pixels.

Alpha Add Composites layers normally, but adds complementary alpha channels together to create a seamless area

of transparency. Useful for removing visible edges from two alpha channels that are inverted relative to each other

or from the alpha channel edges of two touching layers that are being animated.

Luminescent Premul Prevents clipping of color values that exceed the alpha channel value after compositing by

adding them to the composition. Useful for compositing rendered lens or light effects (such as lens flare) from

footage with premultiplied alpha channels. May also improve results when compositing footage from other manufac-

turers’ matting software. When applying this mode, you may get the best results by changing interpretation of the

premultiplied-alpha source footage to straight alpha.

To use stencil and silhouette blending modes
The stencil and silhouette blending modes use either a layer’s alpha channel or its luma values to affect the alpha

channel of all layers beneath the layer. This differs from the track matte, which affects only one layer.

The stencil and silhouette blending modes affect all layers below the layer to which they are applied. Stencil mode

cuts through all layers, so you can show multiple layers through the frame of the stencil layer’s alpha channel.

Silhouette mode blocks out all layers below it, so you can cut a hole through several layers at once. To keep the

silhouette and stencil blending modes from cutting through or blocking all layers underneath, nest the layer in a

composition.
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Stencil (left) shows all layers below through the frame of the stencil layer’s alpha channel; silhouette (right) cuts a hole through all layers below.

1 Click Switches/Modes at the bottom of the Timeline panel.

2 Click Normal to open the Mode menu for the layer you want to use as a stencil or silhouette, and then choose one

of the following:

Stencil Alpha Creates a stencil using the layer’s alpha channel.

Stencil Luma Creates a stencil using the layer’s luma values. The lighter pixels of the layer are more opaque than the

darker pixels.

Silhouette Alpha Creates a silhouette using the layer’s alpha channel.

Silhouette Luma Creates a silhouette using the layer’s luma values. The lighter pixels of the layer are more trans-

parent than the darker pixels.

To cycle through blending modes
You can quickly cycle through all the blending modes for a selected layer, making it easy to experiment with the

results that each mode has on the layer.

1 Select a layer in the Timeline panel.

2 Do one of the following:

• Hold down Shift and press the plus key (+) to cycle forward through each blending mode.

• Hold down Shift and press the underscore key (_) to cycle backward through each blending mode.

About mask modes
Blending modes for masks (mask modes) control how masks within a layer interact with one another. By default, all

masks are set to Add, which combines the transparency values of any masks that overlap on the same layer. You can

apply one mode to each mask, but you cannot change a mask’s mode over time.

The first mask you create interacts with the layer’s alpha channel. If that channel doesn’t define the entire image as

opaque, then the mask interacts with the layer frame. Each additional mask you create interacts with masks located

above it in the Timeline panel outline. The results of mask modes vary depending on the modes set for the masks

higher up in the outline. You can use mask modes only between masks in the same layer.

Using mask modes, you can create complex mask shapes with multiple transparent areas. For example, you can set

a mask mode that combines two masks and sets the opaque area to the areas where the two masks intersect.
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Mask shapes that result when different modes are applied to the circle mask. The shapes in this illustration have different Mask Opacity values.
A. Original masks B.  None C. Add D. Subtract E. Intersect F. Lighten G. Darken H. Difference

To apply a mask mode
1 In the Timeline panel, select the layer containing the mask to which you want to apply a mode and press M.

2 Click the menu next to the mask name and choose a mask mode.

None After Effects treats the mask as if it does not exist. The mask has no impact on the layer or composition. This

option is useful when you want to use the mask’s path for an effect such as Stroke or Fill, but do not want it to create

transparent areas in the layer.

Add Adds the selected mask area to the other masks for that layer, displaying all mask contents in the Composition

panel. Where multiple masks intersect, the opacity of all intersecting masks is added together.

Subtract Subtracts the mask from all masks located above it in the Timeline panel. The contents of the subtracted

mask area appear as a hole in the Composition panel. This option is useful when you want to create the appearance

of a hole in the center of another mask.

Intersect Adds the mask to all masks above it, but displays in the Composition panel only the area where the selected

mask and any of the previous masks intersect. Where multiple masks intersect, the opacity of all intersecting masks

is added together.

Lighten Adds the mask to all the masks above it, displaying contents of all masked areas in the Composition panel.

Where multiple masks intersect, the highest opacity value is used, so opacity doesn’t build up.

Darken Adds the mask to all masks above it, but displays in the Composition panel only the area where the selected

mask and any of the others intersect. Where multiple masks intersect, the highest transparency value is used, so

transparency doesn’t build up.

Difference Adds the selected mask to the masks above it, and displays in the Composition panel the mask contents

of all masked areas except those areas where the masks intersect.

A B

C D E

F G H



ADOBE AFTER EFFECTS 7.0
User Guide

266

Animating masks

About mask animation
You can change all of a layer’s Mask property’s values—Mask Shape, Mask Feather, Mask Opacity, or Mask

Expansion—over time by using keyframes.

To animate a mask shape, After Effects designates the topmost vertex at the initial keyframe as the first vertex and

numbers each successive vertex in ascending order from the first vertex. After Effects then assigns the same numbers

to the corresponding vertices at all successive keyframes. After Effects interpolates the movement of each vertex

from its initial position at one keyframe to the position of the correspondingly numbered vertex at the next

keyframe. At any time during an animation, you can designate another vertex as the first vertex; this causes After

Effects to renumber the vertices of the shape you assigned a new first vertex, and the mask animates differently

because After Effects then maps the new vertex numbers to the corresponding old vertex numbers still saved at

successive keyframes.

See also

“About keyframes” on page 192

To create an initial mask shape keyframe
❖ Select one or more masks, and then do one of the following:

• Choose the Add Mask Shape Keyframe command.

• Click the stopwatch icon next to the Mask Shape property for each mask in the Timeline panel.

Note: You can quickly set an initial Mask Shape keyframe for all masks in selected layers by pressing Shift+Alt+M

(Windows) or Shift+Option+M (Mac OS).

To animate a mask property
1 In the Timeline or Composition panel, select the mask that you want to animate.

2 Move the current-time indicator to the time where you want to begin the animation.

3 Expand the Mask properties and locate the property that you want to change.

4 Set a value for the mask property.

5 Set an initial keyframe.

6 Move the current-time indicator to the time where you want to add the next keyframe.

7 Change the value for the mask property.

8 Repeat steps 6 and 7 for any other keyframes that you want to add.

Note: By default, when you add a vertex to a mask, the new vertex appears on the mask throughout the mask’s duration

but reshapes the mask only at the time it was added. When you delete a vertex from a mask at a specific point in time,

the vertex is deleted from the mask throughout the mask’s duration. Prevent After Effects from adding and deleting

vertices throughout the mask’s duration by choosing Edit > Preferences > General (Windows) or After Effects >

Preferences > General (Mac OS), and deselecting Preserve Constant Vertex Count When Editing Masks.
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To designate a vertex as the first vertex
1 Create an animated mask shape.

2 In the Timeline panel, move the current-time indicator to the point where you want to designate a new first vertex.

3 Select the vertex you want to designate as the first vertex.

4 Choose Layer > Mask > Set First Vertex.

Note: The vertex designated as the first vertex appears slightly larger than the other vertices in the Composition panel.

Using Smart Mask Interpolation (Pro only)
Smart Mask Interpolation provides a high level of control for creating mask shape keyframes and smooth, realistic

animation. Once you select the mask shape keyframes to interpolate, Smart Mask Interpolation creates intermediate

keyframes based on settings you provide. The Info panel displays the progress of the interpolation and the number

of keyframes created.

The Smart Mask Interpolation panel

See also

“About interpolation” on page 218

To use Smart Mask Interpolation

1 Choose Window > Smart Mask Interpolation.

2 Select at least two adjacent mask shape keyframes.

3 Set options in the Smart Mask Interpolation panel and click Apply.

Note:To interrupt the interpolation process, press Esc. The Info panel indicates that the process has been interrupted and

reports the number of keyframes created.

Smart Mask Interpolation options
Keyframe Rate Specifies the number of keyframes that Smart Mask Interpolation creates per second between the

selected keyframes. For example, a value of 10 creates a new keyframe every 1/10 of a second. Choose Auto to set the

keyframe rate equal to the composition frame rate, which appears in parentheses. Create more keyframes for

smoother animation; create fewer keyframes to reduce render time.



ADOBE AFTER EFFECTS 7.0
User Guide

268

Note: Regardless of the keyframe rate you choose, Smart Mask Interpolation always adds keyframes at the frame just

after the first mask shape keyframe and at the frame just before the second mask shape keyframe. For example, if you

interpolate between keyframes at 0 seconds and 1 second in a 30-fps composition with a keyframe rate of 10 per second,

mask shape keyframes are added at frame numbers 1, 3, 6, 9, 12, 15, 18, 21, 24, 27, and 29.

Keyframe Fields Doubles the keyframe rate. When this option is selected, and Keyframe Rate is set to the compo-

sition frame rate, a keyframe is added at each video field. Select this option for animated masking for interlaced

video. If this option is not selected, the mask may slip off the object that you are attempting to key out. For more

information about fields in interlaced video, see “About interlaced and noninterlaced video” on page 98.

Use Linear Vertex Paths Specifies that vertices in the first keyframe move along a straight path to their corre-

sponding vertices in the second keyframe. Leave this option unselected if you want some vertices to interpolate along

curved paths; for example, when the desired interpolation involves rotating parts. If this option is not selected, Smart

Mask Interpolation creates a natural path for the mask.

Bending Resistance Specifies how susceptible the interpolated mask shape is to bending instead of stretching. A

value of 0 specifies that, as the mask shape animates, it bends more than it stretches; a value of 100 specifies that the

mask shape stretches more than it bends.

Quality Specifies how strictly Smart Mask Interpolation matches vertices from one keyframe to another. A value of

0 specifies that a particular vertex in the first keyframe matches only the same-numbered vertex in the second

keyframe. For example, the tenth vertex in the first keyframe must match the tenth vertex in the second keyframe.

A value of 100 means that a vertex in the first keyframe can potentially match any vertex in the second keyframe.

Higher values usually yield better interpolations; however, the higher the value, the longer the processing time.

Add Mask Shape Vertices Specifies that Smart Mask Interpolation adds vertices to facilitate quality interpolations.

In general, Smart Mask Interpolation works best when the mask shapes have dense sets of vertices. Also, a vertex on

the first mask shape cannot match the middle of a curve or straight-line segment on the second mask shape, so

sometimes you must add vertices before matching to produce the desired result. Smart Mask Interpolation does not

modify the original keyframes. Only the new mask shape keyframes computed by Smart Mask Interpolation have

additional vertices.

The value you set specifies how finely the input mask shapes are subdivided. Pixels Between Vertices specifies the

distance, in pixels, between vertices on the larger perimeter mask shape after subdivision. Total Vertices specifies the

number of vertices on the interpolated mask shapes. Percentage Of Outline specifies that a vertex is added at each

indicated percent of the mask shape outline length. For example, a value of 5 means that a vertex is added at each

successive segment of the outline that represents 5% of the total perimeter. To use only the vertices that were there

at the first frame, do not select this option.

Note: Smart Mask Interpolation may add vertices at existing vertex locations even if Add Mask Shape Vertices is not

selected. If two vertices on one mask shape match a single vertex on the other, the single vertex is duplicated at the same

location so that the segment between the two vertices shrinks to that location.

Matching Method Specifies the algorithm that Smart Mask Interpolation uses to match vertices on one mask shape

to vertices on the other. Auto applies the matching algorithm for curves if either of the two selected keyframes has a

curved segment; otherwise, it applies the polylines algorithm. Curve applies the algorithm for mask shapes that have

curved segments. Polyline applies the algorithm for mask shapes that have only straight segments.

Note: The mask shape keyframes added by Smart Mask Interpolation are polylines when Polyline Matching Method is

selected, regardless of whether the input mask shapes contained curved segments.

Use 1:1 Vertex Matches Specifies that Smart Mask Interpolation creates a vertex on one mask shape that matches the

same-numbered vertex on the other mask shape. On each of the input mask shapes, Smart Mask Interpolation
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matches the first vertices, the second vertices, the third vertices, and so forth. If the two shapes have unequal

numbers of vertices, this action may produce undesirable results.

First Vertices Match Specifies that Smart Mask Interpolation matches the first vertices in the two mask shape

keyframes. If not selected, Smart Mask Interpolation searches for the best first-vertex match between the two input

mask shapes.

Note: To ensure good results, make sure that the first vertices of the input mask shapes match, and then select First

Vertices Match.

Adjusting a mask and panning a layer behind a mask
You can adjust the area that is visible through a mask by either moving the mask in the Layer or Composition panel

or panning (moving) the layer behind the mask in the Composition panel. When you move a mask, the mask layer’s

Position values remain constant, and the mask moves in relation to other objects in the Composition panel.

When you use the Pan Behind tool to pan a layer behind a mask, the mask’s position remains constant in the Compo-

sition panel but changes in the Layer panel. The masked layer’s Position values change in relation to the composition.

As you pan past the edges of the layer’s frame, the layer’s Mask Shape values also change. Using the Pan Behind tool

saves steps; without it, you would have to change the masked layer’s Position and Mask Shape properties manually.

You can animate a layer panning behind another layer by setting keyframes for the masked layer’s Position and Mask

Shape properties.

When you use the Pan Behind tool in the Composition panel, After Effects automatically makes two adjustments for you. In the Layer panel,
the mask is moved in relation to its layer (top), while in the Composition panel, the layer is moved in relation to the composition (bottom).

To move a mask

1 Select the mask or masks you want to move.

2 In the Composition panel, drag the mask or masks to a new location. To constrain the movement of the mask or

masks to horizontal or vertical, hold down Shift after you start dragging.

To pan a layer behind its mask

1 Select the Pan Behind tool in the Tools panel .
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2 Click inside the mask area in the Composition panel and drag the layer to a new position.

Keying

About keying
After Effects includes several effects that key out, or make transparent, parts of an image. Each effect is called a key,

and the color specified for transparency is called the key color. A key locates pixels in an image that match the

specified key color and makes them transparent or semitransparent, depending on the type of key. When you place

a layer over another layer using transparency, the result forms a composite, in which the background is visible

wherever the first layer is transparent.

After Effects uses an alpha channel for identifying areas in an image that are partially or completely transparent. The

view of an image in its alpha channel is often called the matte view. The matte represents opaque, transparent, and

partially transparent areas as white, black, and gray, respectively.

Once you have used a key to create transparency, use Matte effects (Pro only) to remove traces of key color and create

clean edges.

You often see composites made with keying techniques in movies, for example, when an actor appears to dangle from

a helicopter or float in outer space. To create this effect, the actor is filmed in an appropriate position against a color

screen. The color screen is then keyed out and the actor’s scene is composited over the background footage item.

For satisfactory keying results, start with the highest-quality materials you can gather, such as film that you scan and

digitize. If appropriate for your footage, strive for lighting that is constant for the duration of the color-screen scene.

Use footage files with the least amount of compression. Files with compression, especially DV and Motion JPEG files,

discard subtle differences in blue. These differences may be necessary to create a good matte from a bluescreen.

Adjusting keying controls on a single frame
For evenly lit bluescreen footage, adjust keying controls on only one frame. Choose the most intricate frame of the

scene, one involving fine detail such as hair and transparent or semitransparent objects, such as smoke or glass. If

the lighting is constant, the same settings you apply to the first frame are applied to all subsequent frames.

If lighting changes, you may need to adjust keying controls for other frames. Place keyframes for the first set of keying

properties at the start of the bluescreen scene. If you are setting keyframes for one property only, use Linear interpo-

lation. For footage that requires keyframes for multiple interacting properties, use Hold interpolation.

If you set keyframes for keying properties, you may want to check the results frame by frame. Intermediate keying

values may appear, producing unexpected results.

See also

“Using keyframes” on page 192

“Interpolation methods” on page 220

Using a background color
To help you view transparency, temporarily change the background color of the composition, or include a

background layer behind the layer you are keying out. As you apply the key to the layer in the foreground, the compo-

sition background (or a background layer) shows through, making it easy to view transparent areas.
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See also

“To set background or pasteboard color” on page 117

“To create a solid-color layer” on page 150

Recommendations for sequencing and combining keys
When creating transparency in footage, you may need to try different keys before you are satisfied with the results.

You can also combine two or more keys or Matte effects. Because keys are treated as effects, you can easily turn them

on or off by clicking the Effect switch to the left of the effect name in the Effect Controls panel or in the Timeline

panel. Use the following recommendations for combining keys for specific types of footage items:

• To create transparency in well-lit footage shot against a bluescreen or greenscreen, start with the Color Difference

Key. Add the Spill Suppressor to remove traces of the key color, and then use one or more of the other Matte effects,

if necessary. If you are not satisfied with the results, try starting again with the Linear Color Key.

• To create transparency in footage shot against multiple colors or to create transparency in unevenly lit footage shot

against a bluescreen or greenscreen, start with the Color Range key. Add the Spill Suppressor and other effects to

refine the matte. If you are not completely satisfied with the results, try starting with or adding the Linear Color

Key.

• To create transparency in dark areas or shadows, use the Extract Key on the Luminance channel.

• To make a static background scene transparent, use the Difference Matte Key. Add the Simple Choker and other

effects as needed to refine the matte.

See also

“Matte Choker effect (Pro only)” on page 466

“Simple Choker effect (Pro only)” on page 467

About binary keys
The simplest type of key is the binary key, which creates pixels that are either entirely transparent or entirely opaque.

Pixels that match the specified key color are made transparent; those that don’t match remain opaque. Because binary

keys do not create semitransparent pixels, they are best for solid objects with sharp, defined edges, such as titles or

credits, or for footage items with a solid color background and no changes in background lighting.

Using the Linear Color Key effect
Linear keys create a range of transparency across an image. A linear key compares each pixel in the image to the key

color you specify. If the color of a pixel closely matches the key color, it becomes completely transparent. Pixels that

don’t match as well are made less transparent, and pixels that don’t match at all remain opaque. The range of trans-

parency values, therefore, forms a linear progression.

To apply the Linear Color Key effect

In the Effect Controls panel, the Linear Color Key effect displays two thumbnail images; the left thumbnail image

represents the unaltered source image, and the right thumbnail image represents the view you’ve selected in the View

menu.

You can adjust the key color, the matching tolerance, and the matching softness. The matching tolerance specifies

how closely pixels must match the key color before they start becoming transparent. The matching softness controls

the softness of edges between the image and the key color.
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You can also reapply this key to preserve a color that was made transparent by the first application of the key. For

example, if you are keying out a medium-blue screen, you might lose some or all of a light-blue piece of clothing your

subject is wearing. You can bring back the light-blue color by applying another instance of the Linear Color Key and

choosing Keep This Color from the Key Operation menu.

1 Select a layer as the source layer, and then choose Effect > Keying > Linear Color Key.

2 In the Effect Controls panel, choose Key Colors from the Key Operation menu.

3 Choose a color space from the Match Colors menu. In most cases, use the default RGB setting. If you’re having

trouble isolating the subject using one color space, try using a different color space.

4 In the Effect Controls panel, choose Final Output from the View menu. The view you choose appears in the right

thumbnail and in the Composition panel. If you need to see other results, work in one of the other views:

Source Only Shows the original image without the key applied.

Matte Only Shows the alpha channel matte. Use this view to check for holes in the transparency. To fill undesired

holes after you complete the keying process, see “To close a hole in a matte (Pro only)” on page 282.

5 Select a key color in one of the following ways:

• Select the Thumbnail eyedropper, and then click an appropriate area in the Composition panel or the original

thumbnail image.

• Select the Key Color eyedropper, and then click an appropriate area in the Composition or Layer panel.

• To preview transparency for different colors, select the Key Color eyedropper, hold down the Alt key (Windows)

or Option key (Mac OS), and move the cursor to different areas in the Composition panel or the original

thumbnail image. The transparency of the image in the Composition panel changes as you move the cursor over

different colors or shades. Click to select the color.

• Click the Key Color swatch to select a color from the specified color space. The selected color becomes trans-

parent.

Note: The eyedropper tools move the sliders accordingly. Use the sliders in steps 6 and 7 to fine-tune the keying results.

To use eyedroppers in the Layer panel, choose Linear Color Key from the View menu in the Layer panel.

6 Adjust matching tolerance in one of the following ways:

• Select the Plus (+) or the Minus (-) eyedropper, and then click a color in the left thumbnail image. The Plus

eyedropper adds the specified color to the key color range, increasing the matching tolerance and the level of

transparency. The Minus eyedropper subtracts the specified color from the key color range, decreasing the

matching tolerance and the level of transparency.

• Drag the matching tolerance slider. A value of 0 makes the entire image opaque; a value of 100 makes the entire

image transparent.

7 Drag the Matching Softness slider bar to soften the matching tolerance by tapering the tolerance value. Typically,

values under 20% produce the best results.

8 Before closing the Effect Controls panel, make sure that you have selected Final Output from the View menu to

ensure that After Effects renders the transparency.

See also

“Linear Color Key effect” on page 465
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To preserve a color after applying Linear Color Key

1 In the Effect Controls panel or Timeline panel, turn off any current instances of keys or matte effects by

deselecting the Effect option to the left of the key name or tool name. This displays the original image in the Compo-

sition panel so that you can select a color to preserve.

2 Choose Effect > Keying > Linear Color Key. A second set of Linear Color Key controls appears in the Effect

Controls panel below the first set.

3 In the Effect Controls panel, choose Keep Colors from the Key Operation menu.

4 Select the color you want to keep.

5 In the first application of the Linear Color Key effect, choose Final Output from the View menu in the Effect

Controls panel, and then turn other instances of the Linear Color Key effect back on to examine the transparency.

You may need to adjust colors or reapply the key a third time to get the results you need.

See also

“Linear Color Key effect” on page 465

To use the Color Difference Key effect
1 Select the layer you want to make transparent, and then choose Effect > Keying > Color Difference Key.

Note: To use any of the eyedroppers in the Layer panel, choose Color Difference Key from the View pop-up menu in the

Layer panel.

2 In the Effect Controls panel, choose Matte Corrected from the View menu. To view and compare the source

image, both partial mattes, and the final matte at the same time, choose [A, B, Matte] Corrected, Final from the View

menu. Other views available in the View menu are described in step 10.

3 Select the appropriate key color: To key out a bluescreen, use the default blue color. To key out a non-blue screen,

select a key color in one of the following ways:

• Thumbnail eyedropper: Select and then click in the Composition panel or the original thumbnail image on an

appropriate area.

• Key Color eyedropper: Select and then click in the Composition or Layer panel on an appropriate area.

• Key Color swatch: Click to select a color from the specified color space.

Note: The eyedropper tools move the sliders accordingly. Use the sliders in step 9 to fine-tune the keying results.

4 Click the  matte button to display the final combined matte in the matte thumbnail.

5 Select the Black eyedropper, and then click inside the matte thumbnail on the lightest area of black to specify

transparent regions. The transparency values in the thumbnail and Composition panel are adjusted.

6 Select the White eyedropper, and then click inside the matte thumbnail on the darkest area of white to specify

opaque regions. The opaque values in the thumbnail and the Composition panel are adjusted.

To produce the best possible key, make the black and white areas as different as you can so that the image retains as

many shades of gray as possible.

7 Select a matching accuracy from the Color Matching Accuracy menu. Choose Faster unless you are using a screen

that is not a primary color, such as orange. For those screens, choose More Accurate, which increases rendering time

but produces better results.

8 If you need to further adjust transparency values, repeat steps 5 and 6 for one or both of the partial mattes. Click

the Partial Matte B button or the Partial Matte A button to select a partial matte, and then repeat the steps.
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9 Adjust transparency values for each partial matte and for the final matte by dragging one or more of the following

slider bars in the Matte Controls section:

• Black slider bars adjust the transparency levels of each matte. You can adjust the same levels using the Black

eyedropper.

• White slider bars adjust the opaque levels of each matte. You can adjust the same levels using the White

eyedropper.

• Gamma slider bars control how closely the transparency values follow a linear progression. At a value of 1 (the

default), the progression is linear. Other values produce nonlinear progressions for particular adjustments or

visual effects.

10 When adjusting individual mattes, you can choose the following views from the View menu to compare the

mattes with and without adjustments:

• Choose Uncorrected to view a matte without adjustments made by the slider bars in step 9.

• Choose Corrected to view a matte with all adjustments made by the slider bars in step 9.

11 Before closing the Effect Controls panel, select Final Output from the View menu. Final Output must be selected

for After Effects to render the transparency.

To remove traces of reflected key color from the image, apply Spill Suppressor using Better for Color Accuracy. If the

image still has a lot of color, apply the Simple Choker or Matte Choker effect.

See also

“Color Difference Key effect (Pro only)” on page 463

“Matte Choker effect (Pro only)” on page 466

“Simple Choker effect (Pro only)” on page 467

To key out a single color with the Color Key effect
1 Select the layer.

2 Choose Effect > Keying > Color Key.

3 In the Effect Controls panel, specify a key color in one of two ways:

• Click the Key Color swatch to open the Color dialog box and specify a color.

• Click the eyedropper, and then click a color on the screen.

4 Drag the Color Tolerance slider to specify the range of color to key out. Lower values key out a smaller range of

colors near the key color. Higher values key out a wider range of color.

5 Drag the Edge Thin slider to adjust the width of the keyed area’s border. Positive values enlarge the mask,

increasing the transparent area. Negative values shrink the mask, decreasing the transparent area.

6 Drag the Edge Feather slider to specify the softness of the edge. Higher values create a softer edge but take longer

to render.

See also

“Color Key effect” on page 463
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To use the Color Range effect
1 Select the layer you want to make transparent, and then choose Effect > Keying > Color Range.

2 Choose the Lab, YUV, or RGB color space from the Color Space menu. If you’re having trouble isolating the

subject using one color space, try using a different one.

3 Select the Key Color eyedropper, and then click in the matte thumbnail to select the area that corresponds to a

color in the Composition panel you want to make transparent. Typically, this first color is the one that covers the

largest area of the image.

Note: To use the eyedroppers in the Layer panel, choose Color Range from View menu in the Layer panel.

4 Select the Plus eyedropper, and then click other areas in the matte thumbnail to add other colors or shades to the

range of colors keyed out for transparency.

5 Select the Minus eyedropper, and then click areas in the matte thumbnail to subtract other colors or shades from

the range of colors keyed out.

6 Drag the Fuzziness slider to soften the edges between transparent and opaque regions.

7 Use the slider bars in the Min/Max controls to fine-tune the color range you selected with the Plus and Minus

eyedroppers. The L, Y, R slider bars control the first component of the specified color space; the a, U, G slider bars

control the second component; and the b, V, B slider bars control the third component. Drag Min slider bars to fine-

tune the beginning of the color range. Drag Max slider bars to fine-tune the end of the color range.

See also

“Color Range effect” on page 464

To use the Difference Matte effect
The Difference Matte effect creates transparency by comparing a source layer with a difference layer, and then keying

out pixels in the source layer that match both the position and color in the difference layer. Typically, it is used to key

out a static background behind a moving object, which is then placed on a different background. Often the difference

layer is simply a frame of background footage (before the moving object has entered the scene). For this reason, the

Difference Matte Key is best used for scenes that have been shot with a stationary camera.

1 Select a motion footage layer as the source layer.

2 In the source layer, find a frame that consists only of background, and save the background frame as an image file.

3 Import the image file into After Effects, and add it to the composition. (See “To export a single composition

frame” on page 623.)

This is the difference layer. Make sure that its duration is at least as long as that of the source layer.

Note: If there is no full-background frame in the shot, you may be able to assemble the full background by combining

parts of several frames in After Effects or Photoshop. For example, you can use the Clone Stamp tool to take a sample of

the background in one frame, and then paint the sample over part of the background in another frame.

4 Turn off the display of the difference layer by clicking the Video switch in the Timeline panel.

5 Make sure that the original source layer is still selected, and then choose Effect > Keying > Difference Matte.

6 In the Effect Controls panel, choose Final Output or Matte Only from the View menu. (Use the Matte Only view

to check for holes in the transparency. To fill undesired holes after you complete the keying process, see “To close a

hole in a matte (Pro only)” on page 282.)

7 Select the background file from the Difference Layer menu.
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8 If the difference layer is not the same size as the source layer, choose one of the following controls from the If Layer

Sizes Differ menu:

Center Places the difference layer in the center of the source layer. If the difference layer is smaller than the source

layer, the rest of the layer is filled with black.

Stretch To Fit Stretches or shrinks the difference layer to the size of the source layer but may distort background

images.

9 Adjust the Matching Tolerance slider to specify the amount of transparency based on how closely colors must

match between the layers. Lower values produce less transparency; higher values produce more transparency.

10 Adjust the Matching Softness slider to soften the edges between transparent and opaque areas. Higher values

make matched pixels more transparent but do not increase the number of matching pixels.

11 If there are still extraneous pixels in the matte, adjust the Blur Before Difference slider. This option suppresses

noise by slightly blurring both layers before making the comparison. Note that the blurring occurs only for

comparison and does not blur final output.

12 Before closing the Effect Controls panel, make sure that you have selected Final Output from the View menu to

ensure that After Effects renders the transparency.

See also

“Difference Matte effect (Pro only)” on page 464

To use the Extract effect
In the Effect Controls panel, the Extract effect displays a histogram for a channel specified in the Channel menu. The

histogram displays a representation of the brightness levels in the layer, showing the relative number of pixels at each

level. From left to right, the histogram extends from the darkest (a value of 0) to the lightest (a value of 255).

Using the transparency control bar beneath the histogram, you can adjust the range of pixels that are made trans-

parent. The position and shape of the bar in relation to the histogram determine transparency. Pixels corresponding

to the area covered by the bar remain opaque; pixels corresponding to the areas not covered by the bar are made

transparent.

1 Select the layer you want to make transparent, and then choose Effect > Keying > Extract.

2 If you are keying out bright or dark areas, choose Luminance from the Channel menu. To create visual effects,

choose Red, Green, Blue, or Alpha.

3 Adjust the amount of transparency by dragging the transparency control bar in the following ways:

• Drag the upper right or upper left selection handles to adjust the length of the bar and to shorten or lengthen the

transparency range. You can also adjust the length by moving the White Point and Black Point slider bars. Values

above the white point and below the black point are made transparent.

• Drag the lower right or lower left selection handles to taper the bar. Tapering the bar on the left affects the softness

of transparency in the darker areas of the image; tapering it on the right affects the softness in the lighter areas.

You can also adjust the softness levels by adjusting White Softness (lighter areas) and Black Softness (darker areas).

Note: To taper the edges of the transparency control bar, you must first shorten the transparency bar.

• Drag the entire bar left or right to position it under the histogram.
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See also

“Extract effect (Pro only)” on page 464

To use the Spill Suppressor effect
1 Select the layer and choose Effect > Keying > Spill Suppressor.

2 Choose the color you want to suppress in one of the following ways:

• If you have already keyed out the color with a key in the Effect Controls panel, click the Color To Suppress

eyedropper, and then click the screen color in the key’s Key Color swatch.

• In Spill Suppressor, click the Key Color swatch and choose a color from the color wheel.

Note: To use the eyedropper in the Layer panel, choose Spill Suppressor from the View pop-up menu in the Layer panel.

3 In the Color Accuracy menu, choose Faster to suppress blue, green, or red. Choose Better to suppress other colors,

because After Effects may need to analyze the colors more carefully to produce accurate transparency. The Better

option may increase rendering time.

4 Drag the Suppression slider until the color is adequately suppressed.

See also

“Spill Suppressor effect (Pro only)” on page 466

To use the Inner/Outer Key effect
To use the Inner/Outer key, create a mask to define the inside and outside edge of the object you want to isolate. The

mask can be fairly rough—it does not need to fit exactly around the edges of the object.

In addition to masking a soft-edged object from its background, Inner/Outer Key modifies the colors around the

border to remove contaminating background colors. This color decontamination process determines the

background's contribution to the color in each border pixel, and removes that contribution—thus removing the halo

that can appear if a soft-edged object is matted against a new background.

1 Select the border of the object that you want to extract by doing one of the following:

• Draw a single closed mask near the object's border; then select the mask from the Foreground menu and leave the

Background menu set to None. Adjust the Single Mask Highlight Radius to control the size of the border around

this mask. (This method works well only on objects with simple edges.)

• Draw two closed masks: an inner mask just inside the object, and outer mask just outside the object. Make sure

that any fuzzy or uncertain areas of the object lie within these two masks. Select the inner mask from the

Foreground menu and the outer mask from the Background menu.

Note: Make sure that the mask mode for all masks is set to None.

2 If you want, move the masks around to find the location that provides the best results.

3 To extract more than one object, or to create a hole in an object, draw additional masks and then select them from

the Additional Foreground and Additional Background menus. For example, to key out a woman’s hair blowing in

the wind against a blue sky, draw the inner mask inside her head, draw the outer mask around the outside edge of

her hair, and then draw an additional mask around the gap in her hair where you can see sky. Select the additional

mask from the Additional Foreground menu to extract the gap and remove the background image.
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4 Create additional open or closed masks to clean up other areas of the image, and then select them from the

Cleanup Foreground or Cleanup Background menu. Cleanup Foreground masks increase the opacity along the

mask; Cleanup Background masks decrease the opacity along the mask. Use the Brush Radius and Brush Pressure

options to control the size and density of each stroke.

Note: You can select the Background (outer) mask as a Cleanup Background mask to clean up noise from the

background portions of the image.

5 Set Edge Thin to specify how much of the matte’s border is affected by the key. A positive value moves the edge

away from the transparent region, increasing the transparent area; negative values move the edge toward the trans-

parent region and increase the size of the foreground area.

6 Increase the Edge Feather values to soften edges of the keyed area. High Edge Feather values take longer to render.

7 Specify the Edge Threshold, which is a soft cutoff for removing low-opacity pixels that can cause unwanted noise

in the image background.

8 Select Invert Extraction to reverse the foreground and background regions.

9 Set Blend With Original to specify the degree to which the resulting extracted image blends with the original

image.

See also

“Creating masks” on page 244

“Inner/Outer Key effect (Pro only)” on page 465

To key out a luminance value with the Luma Key effect
When the object you want to matte has a very different luminance value than its background, you can make the

background value transparent by keying it out. For example, if you want to create a matte for dark musical notes on

a white background, you can key out the brighter values; the dark musical notes become the only opaque area.

1 Select the layer, and choose Effect > Keying > Luma Key.

2 Select a Key Type to specify the range to be keyed out.

3 Drag the Threshold slider in the Effect Controls panel to set the luminance value on which you want the matte to

be based.

4 Drag the Tolerance slider to specify the range of values to be keyed out. Lower values key out a smaller range of

values near the threshold. Higher values key out a wider range of values.

5 Drag the Edge Thin slider to adjust the width of the keyed area’s border. Positive values make the mask grow,

increasing the transparent area. Negative values shrink the mask.

6 Drag the Edge Feather slider to specify the softness of the edge. Higher values create a softer edge but take longer

to render.

See also

“Luma Key effect” on page 466
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Mattes

About track mattes and traveling mattes
When you want one layer to show through a hole in another layer, set up a track matte. You’ll need two layers—one

to act as a matte, and another to fill the hole in the matte. You can animate either the track matte layer or the fill layer.

When you animate the track matte layer, you create a traveling matte. If you want to animate the track matte and fill

layers using identical settings, consider precomposing them.

Define transparency in a track matte using values from either its alpha channel or the luminance of its pixels. Using

luminance is useful when you want to create a track matte using a layer without an alpha channel or a layer imported

from a program that can’t create an alpha channel. In both alpha channel mattes and luminance mattes, pixels with

higher values are more transparent. In most cases, you use a high-contrast matte so that areas are either completely

transparent or completely opaque. Intermediate shades should appear only where you want partial or gradual trans-

parency, such as along a soft edge.

After Effects preserves the order of a layer and its track matte after you duplicate or split the layer. Within the dupli-

cated or split layers, the track matte layer remains on top of the fill layer. For example, if your project contains Layers

A and B, where A is the track matte and B the fill layer, duplicating or splitting both of these layers results in the layer

order ABAB.

Traveling matte
A. Track matte layer: a solid with a rectangular mask, set to Luma Matte. The mask is animated to travel across the screen. B. Fill layer: a
solid with a pattern effect. C. Result: The pattern is seen in the track matte’s shape and added to the image layer, which is below the track matte
layer.

See also

“About alpha channels and mattes” on page 242

“To duplicate a layer” on page 157

“Splitting layers” on page 157

To create a track matte
1 Click the Switches/Modes button at the bottom of the Timeline panel. The Modes column appears in place of the

Switches column. You can also show the Modes column and the Switches column simultaneously.

2 Arrange two layers in the Timeline panel. Make sure that the designated matte layer is directly above the desig-

nated fill layer.

3 From the TrkMat menu for the fill layer, define transparency in the next layer above by choosing one of the

following:

No Track Matte No transparency created; next layer above acts as a normal layer.

Alpha Matte Opaque when alpha channel pixel value is 100%.
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Alpha Inverted Matte Opaque when alpha channel pixel value is 0%.

Luma Matte Opaque when a pixel’s luminance value is 100%.

Luma Inverted Matte Opaque when a pixel’s luminance value is 0%.

After Effects converts the next layer above into a track matte, turns off the video of the track matte layer, and adds a

track matte icon next to the track matte layer’s name in the Timeline panel. The Composition panel displays the

fill layer viewed through the alpha channel of the matte layer.

Note: Although the video is turned off for the matte layer, you can still select the layer to reposition, scale, or rotate it.

Select the layer in the Timeline panel, and then drag the center (indicated by a circle with an X) of the layer in the

Composition panel.

See also

“About alpha channels and mattes” on page 242

To preserve underlying transparency during compositing
The Preserve Underlying Transparency option causes the opaque areas of a layer to appear only when positioned

over opaque areas in underlying layers. With this option, you can make a layer visible only when it is positioned over

the layer below it. It’s useful for creating effects such as glints or light reflecting off a polished surface.

❖ Select the T option in the Modes column for the appropriate layer.

Example of using Preserve Underlying Transparency.
A. Underlying layer: White signifies opaque areas. B. Upper layer, with Preserve Underlying Transparency turned on. C. The composite.

To create a garbage matte
A garbage matte is merely a portion of a bluescreen scene that contains only the subject that you need. The remainder

of the scene, which may contain undesired objects, is not important and is masked out. The keyed subject can be

placed in another scene for still sequences or simple effects.

1 Create a mask to roughly outline a subject in bluescreen footage.

2 Apply one or more keying effects to mask out the remainder of the bluescreen scene.

3 Apply Matte effects as necessary to fine-tune the matte.

See also

“Creating masks” on page 244

“About keying” on page 270

“Matte Choker effect (Pro only)” on page 466

“Simple Choker effect (Pro only)” on page 467

A B C
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Using a hold-out matte
A hold-out matte (also known as a hold-back matte) is a duplicate of the layer you have keyed. The hold-out matte,

however, is masked to include only the area of the image containing the key color that you want to preserve as

opaque. The hold-out matte is then placed directly on top of the keyed layer; when rendered, the hold-out matte

prevents the area from becoming transparent.

Typically, you would create a hold-out matte for only one or two frames, when the subject is in a particular position

that makes the color visible. Hold-out mattes are not recommended for preserving color for longer periods of time

because the effect may become more obviously visible.

Example of using a hold-out matte
A. Original bluescreen image. The number’s background is also blue. B. After keying, the number’s background is also transparent. C. Hold-
out matte containing the part of the image you want to remain opaque D. When the hold-out matte is placed on top of the keyed image, the
number’s background is now opaque.

See also

“About keying” on page 270

To create a hold-out matte

1 Apply any Transform property keyframes to the original layer containing the color screen.

2 Duplicate the layer containing the color screen.

3 In the original, apply keys and Matte effects to create transparency.

4 In the copy, find the frame that contains the area you want to preserve, and then create a mask to mask out every-

thing in the image except the area you want to preserve.

5 Make sure that the copy (the hold-out matte) is positioned directly on top of the keyed layer and contains exactly

the same keyframes with the same values. Then render the movie.

See also

“Creating masks” on page 244

“About keying” on page 270

A B

C D
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“Matte Choker effect (Pro only)” on page 466

“Simple Choker effect (Pro only)” on page 467

To close a hole in a matte (Pro only)
The sequence of choking and spreading occurs in two stages, each with its own set of identical controls. Typically,

stage two does the opposite of stage one. After a specified number of back-and-forth adjustments (which are handled

automatically by Matte Choker), the hole is filled and the matte shape is preserved.

1 Select the layer, and choose Effect > Matte > Matte Choker.

2 Set stage-one controls (the first three sliders) to spread the matte as far as possible without altering its shape, as

follows:

Geometric Softness Specifies (in pixels) the largest spread or choke.

Choke Sets the amount of choke. Negative values spread the matte; positive values choke it.

Gray Level Softness Specifies how soft to make the edges of the matte. At 0%, the matte edges contain only fully

opaque and fully transparent values. At 100%, the matte edges have a full range of gray values but may appear

blurred.

3 Set stage-two controls (sliders four, five, and six) to choke the matte by the same amount you spread it in stage one.

4 (Optional) Use the Iterations slider to specify how many times After Effects repeats the spread-and-choke

sequence. You may need to try a few different settings so that the sequence is repeated as many times as necessary to

close any unwanted holes.

See also

“Matte Choker effect (Pro only)” on page 466
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Chapter 13: Text

Creating text

About text layers
With After Effects, you can add text to layers with flexibility and precision. You can create and edit text directly on-

screen in the Composition panel and quickly change the font, style, size, and color of the text. You can apply changes

to individual characters and set formatting options for entire paragraphs, including alignment, justification, and

word wrapping. In addition to all of these style features, After Effects provides tools for easily animating specific

characters and features such as text opacity and hue.

After Effects provides a wide range of text features accessible through the Tools, Character, and Paragraph panels.

You can add horizontal or vertical text anywhere in a composition. After Effects uses two types of text: point text and

paragraph text. Point text is useful for entering a single word or a line of characters; paragraph text is useful for

entering and formatting the text as one or more paragraphs.

Vertical and horizontal point text (left) and paragraph text in a bounding box (right)

In many ways, text layers are just like any other layer in After Effects. You can apply effects and expressions to text

layers, animate them, designate them as 3D layers, and edit the 3D text while viewing it in multiple views. As with

layers imported from Adobe Illustrator, text layers are continuously rasterized, so when you scale the layer or resize

the text, it retains crisp, resolution-independent edges. The main differences between text layers and other layers are

that you cannot open a text layer in its own Layer panel, and that you can animate the text in a text layer using special

text animator properties and selectors. (See “To animate text with text animator groups” on page 296.)

You can copy text from other applications such as Adobe Photoshop, Adobe Illustrator, Adobe InDesign, or any text

editor, and paste it into a text layer in After Effects. Because After Effects also supports Unicode characters, you can

copy and paste these characters between After Effects and any other application that also supports Unicode (which

includes all Adobe applications).

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

To enter point text
When you enter point text, each line of text is independent—the length of a line increases or decreases as you edit

the text, but it doesn’t wrap to the next line. The text you enter appears in a new text layer.
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The small line through the I-beam marks the position of the text baseline. For horizontal text, the baseline marks the

line on which the text rests; for vertical text, the baseline marks the center axis of the text characters.

1 Select text options in the Character panel.

2 Do one of the following to create a text layer:

• Choose Layer > New > Text. A new text layer is created and an insertion point for the Horizontal Type tool appears

in the center of the Composition panel.

• Select the Horizontal Type tool  or the Vertical Type tool , and then click inside the Composition panel to

set an insertion point for the text.

3 Enter text characters by typing. Press Enter on the main keyboard (Windows) or Return (Mac OS) to begin a new

line.

Note: You can also choose Edit > Paste to paste text that you have copied from any application that uses Unicode

characters.

4  To end text-editing mode, press Enter on the numeric keypad or select another tool.

To enter paragraph text
When you enter paragraph text, the lines of text wrap to fit the dimensions of the bounding box. You can enter

multiple paragraphs and select a paragraph justification option.

You can resize the bounding box, which causes the text to reflow within the adjusted rectangle. You can adjust the

bounding box while you’re entering text or after you create the text layer. The text you enter appears in a new text

layer.

1 Select text options in the Character or Paragraph panel.

2 Select the Horizontal Type tool  or the Vertical Type tool .

3 Do one of the following in the Composition panel to create a text layer:

• Drag diagonally to define a bounding box for the text.

• Alt-drag (Windows) or Option-drag (Mac OS) diagonally to define a bounding box around a center point.

4 Enter text characters by typing. Press Enter on the main keyboard (Windows) or Return (Mac OS) to begin a new

paragraph. If you enter more text than can fit in the bounding box, the overflow icon  appears on the bounding

box.

Note: You can also choose Edit > Paste to paste text that you have copied from any application that uses Unicode

characters.

5 Press Enter on the numeric keypad, or select another tool to end text-editing mode.

To resize a text bounding box
1 With a type tool active, select the text layer in the Composition panel to display the bounding box handles.

2 Position the pointer over a handle—the pointer turns into a double arrow —and do one of the following:

• Drag to resize in one direction.

• Shift-drag to maintain the proportion of the bounding box.

• Ctrl-drag (Windows) or Command-drag (Mac OS) to scale from the center.
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To convert text from Photoshop to editable text
Text layers from Adobe Photoshop retain their style and remain editable in After Effects.

1 Import the Adobe Photoshop text as footage or as a composition.

2 Open the Adobe Photoshop composition or add the layer to a composition.

3 Select the text layer and choose Layer > Convert To Editable Text.

Note: You cannot edit text on merged Adobe Photoshop layers.

See also

“Importing layered files as a composition” on page 90

“Importing layered files as single footage items” on page 91

To edit text in text layers
You can edit text in text layers at any time. If you set the text to follow a path, designate it as a 3D layer, transform it,

or animate it, you can still continue to edit it.

The pointer for a type tool changes as you move it around the Composition panel. When it is directly over a text layer,

it appears as the edit text pointer ; click to edit the existing text. When the pointer is not directly over a text layer,

it appears as a new text pointer ; click to create a new text layer. Shift-click always creates a new layer.

1 Select the Horizontal Type tool  or the Vertical Type tool .

2 In the Timeline panel, double-click the text layer to set the type tool to editing mode and select the text.

3 Edit text.

To move text without leaving editing mode
❖ In the Composition panel, move the type tool away from the text; when the pointer turns into a move icon ,

drag the text.

To hide and show layer controls
In editing mode, you may find it useful to hide the layer controls, such as highlights and vertices. For example, to

change the color for selected characters only, hide the layer controls to keep the characters selected, but remove the

highlight to see the color of the selected characters as they change.

❖ Choose View > Hide Layer Controls or View > Show Layer Controls.

Formatting characters

To select characters
Before you can format individual characters, you must select them. You can select one character, a range of

characters, or all characters in a text layer.

1 Select the Horizontal Type tool  or the Vertical Type tool .

2 Select the text layer in the Timeline panel, or click inside the text flow to automatically select a text layer.
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3 Position the insertion point inside the text flow, and do one of the following:

• Drag to select one or more characters.

• Click, move the insertion point, and then Shift-click to select a range of characters.

• Choose Edit > Select All to select all of the characters in the layer.

• Double-click a word to select it. Triple-click a line to select it. Click four times in a paragraph to select it. Click five

times anywhere in the text flow to select all characters in a bounding box.

• To use the arrow keys to select characters, hold down Shift and press the Right Arrow or Left Arrow key. To use

the arrow keys to select words, hold down Shift+Ctrl (Windows) or Shift+Command (Mac OS) and press the

Right Arrow or Left Arrow key.

Note: In After Effects, selecting and formatting characters in a text layer puts the type tool into editing mode.

Using the Character panel
The Character panel provides options for formatting characters. If text is highlighted, changes you make in the

Character panel affect only the highlighted text. If no text is highlighted, changes you make in the Character panel

affect the selected text layers and the text layer’s selected Source Text keyframes, if any exist. If no text is highlighted

and no text layers are selected, the changes you make in the Character panel become the new defaults for the next

text entry.

• To display the Character panel, choose Window > Character, click the Character panel tab if the panel is visible

but not active, or, with a type tool selected, click the panel button  in the Tools panel.

• To change values in the Character panel and update text in real time, drag an underlined value in the panel.

• To reset Character panel values to the default values, choose Reset Character from the Character panel menu.

See also

“To animate the source text” on page 296

About fonts
A font is a complete set of characters—letters, numbers, and symbols—that share a common weight, width, and style.

In addition to the fonts installed on your system, After Effects uses font files in this local folder:

Windows Program Files\Common Files\Adobe\Fonts

Mac OS X Library/Application Support/Adobe/Fonts

If you install a Type 1, TrueType, OpenType®, or CID font into the local Fonts folder, the font appears in Adobe appli-

cations only.
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To choose a font family and style
When you select a font, you can select the font family and its font style independently. The font family is a collection

of fonts sharing an overall typeface design; for example, Times. A font style is a variant version of an individual font

in the font family; for example, regular, bold, or italic. The range of available font styles varies with each font. If a font

doesn’t include the style you want, you can apply faux styles—simulated versions of bold, italic, superscript,

subscript, all caps, and small caps styles.

1 Choose a font family from the Font Family menu in the Character panel. If more than one copy of a font is

installed on your computer, an abbreviation follows the font name: (T1) for Type 1 fonts, (TT) for TrueType fonts,

or (OT) for OpenType fonts.

2 Do one of the following:

• Choose a font style from the Font Style menu in the Character panel.

• If the font family you chose does not include a bold or italic style, you can click the Faux Bold button  or the

Faux Italic button in the Character panel to apply a simulated style. Or you can choose Faux Bold or Faux Italic

from the Character panel menu.

You can choose a font family and style by typing the desired name in the text box. As you type, the name of the first

font or style beginning with that letter appears. Continue typing until the correct font or style name appears.

To choose a font size
The font size determines how large the type appears in the image. In After Effects, the unit of measurement for fonts

is pixels. When a text layer is at 100% scale value, the pixel values match composition pixels one-to-one. So if you

scale the text layer to 200%, the font size will appear to double; for example, a font size of 10 pixels will look like 20

pixels. Because After Effects continuously rasterizes text, the resolution remains high when you increase the scale

values.

❖ In the Character panel, enter or select a new value for Size .

To use smart quotes
Smart quotes, or printer’s quotation marks, use a curved left or right quotation mark instead of straight quotation

marks.

❖ Choose Use Smart Quotes from the Character panel menu.

To specify leading
❖ In the Character panel, do one of the following:

• Choose the desired leading from the Leading menu

• Select the existing leading value, and enter a new value.

• Drag the blue underlined leading value.

Filling and outlining text
For text, a fill is applied to the area inside the shape of an individual character; a stroke is applied to the shape or

outline of the character. After Effects applies a stroke to a character by centering the stroke on the character’s path;

half of the stroke appears on one side of the path, and the other half of the stroke appears on the other side of the path.
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The Character panel lets you apply both color fill and color stroke to text, control the stroke width, and control the

stacking position of the fill and stroke. You can change these properties for individual, selected characters; selected

Source Text keyframes; all text in a layer; or all text across multiple selected layers.

You can also control the stacking position of a text layer’s fill and stroke using the All Fills Over All Strokes or All

Strokes Over All Fills options, which override the Fill Over Stroke or Stroke Over Fill properties of individual

characters.

To add a stroke (outline) to text

1 Select the characters to which you want to add a stroke.

2 Set a stroke size with the Stroke Width  button in the Character panel.

3 Set the stroke color.

4 Choose one of the following in the Character panel to control the stroke’s position:

Stroke Over Fill, Fill Over Stroke The stroke of only selected text appears over or behind the fill.

All Strokes Over All Fills, All Fills Over All Strokes Strokes appear over or behind fills in the entire text layer.

To change the text color

The text you enter gets its color from the Fill and Stroke boxes in the Character panel. You can change the text color

before or after you enter text. You can change the fill or stroke color of individual, selected characters; selected Source

Text keyframes; all text in a layer; or all text across multiple selected layers.

❖ In the Character panel, do one of the following:

• Click the Fill box to select a color in the Color dialog box.

• Click the Stroke box to select a color in the Color dialog box.

• Click the Swap Fill And Stroke button to swap colors for fill and stroke.

• Click the No Color button to remove the fill or stroke, depending on which box is in front. To bring a box to the

front, click it.

• Click the Eyedropper and then click any color on-screen to set the fill or stroke to that color.

• Click the Set To Black or Set To White icon to set the fill or stroke to that color.

To specify kerning and tracking
Kerning is the process of adding or subtracting space between specific letter pairs. Tracking is the process of creating

an equal amount of spacing across a range of letters. Positive kerning or tracking values move characters apart

(adding to the default spacing); negative values move characters closer together (reducing the default spacing).

Note:When you open a project that was last saved in After Effects 6.0, text in the project may lie differently than in After

Effects 6.0 because of improvements in kerning behavior.

You can automatically kern type using metrics kerning or optical kerning. Metrics kerning uses kern pairs, which are

included with most fonts. Kern pairs contain information about the spacing of specific pairs of letters such as LA,

To, Tr, Ta, Tu, Te, Ty, Wa, WA, We, Wo, Ya, and Yo. After Effects uses metrics kerning by default so that specific pairs

are automatically kerned when you import or type text.
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Some fonts include robust kern-pair specifications. For other fonts, or for two different typefaces or sizes in a line,

you may want to use the optical kerning option. Optical kerning adjusts the spacing between adjacent characters

based on their shapes. You can also use manual kerning, which is ideal for adjusting the space between two letters.

Tracking and manual kerning are cumulative, so you can first adjust individual pairs of letters and then tighten or

loosen a block of text without affecting the relative kerning of the letter pairs.

Note:Values for kerning and tracking affect Japanese text, but normally these options are used to adjust the aki (spacing)

between Roman characters.

Tracking set to default value of 0 (left), Tracking set to -50 (center), and Tracking set to 200 (right)

• To use a font’s built-in kerning information, choose Metrics from the Kerning menu in the Character panel.

• To adjust kerning manually, click between two characters with a type tool, and enter, drag or select a numeric value

for Kerning  in the Character panel.

Note: If a range of text is selected, you can’t manually kern the characters. Instead, use tracking.

• To specify tracking, enter or select a numeric value for Tracking in the Character panel.

To adjust scale or specify baseline shift
Horizontal scale and vertical scale specify the proportion between the height and width of the text. Unscaled

characters have a value of 100%. You can adjust scale to compress or expand selected characters in both width and

height.

Baseline shift controls the distance that text appears from its baseline, either raising or lowering the selected text to

create superscripts or subscripts.

• To adjust scale, enter a new percentage for Horizontal Scale  or Vertical Scale  in the Character panel, or

drag the underlined value.

• To specify baseline shift, enter a value for Baseline Shift in the Character panel, or drag the underlined value.

A positive value moves horizontal text above and vertical text to the right of the baseline; a negative value moves

text below or to the left of the baseline.

To change the case of text
You can enter or format text as uppercase characters, either all caps or small caps. When you format text as small

caps, After Effects uses the small caps designed as part of the font, if they are available. If the font does not include

small caps, After Effects generates faux small caps.

❖ Do one of the following:

• Click the All Caps button  or the Small Caps button  in the Character panel.

• Choose All Caps or Small Caps from the Character panel menu. A check mark indicates that the option is selected.

Note: Selecting Small Caps will not change characters that were originally typed in uppercase.
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To format as superscript or subscript
You can enter or format text as superscript or subscript characters. Superscript characters are reduced in size and

shifted above the text baseline; subscript characters are reduced in size and shifted below the text baseline. If the font

does not include superscript or subscript characters, After Effects generates faux superscript or subscript characters.

❖ Do one of the following:

• Click the Superscript button  or the Subscript button  in the Character panel.

• Choose Superscript or Subscript from the Character panel menu. A check mark indicates that the option is

selected.

To blend overlapping characters in a text layer
1 In the Timeline panel, expand the text layer and the More Options group.

2 Choose a blending mode from the Inter-Character Blending menu.

Note: To blend a text layer with the layers beneath it, specify a blending mode from the Modes column in the Timeline

panel.

See also

“To apply a blending mode” on page 259

Formatting paragraphs

To use the Paragraph panel
A paragraph is any range of text with a carriage return at the end. You use the Paragraph panel to set options that

apply to entire paragraphs, such as the alignment, indentation, and leading. For point text, each line is a separate

paragraph. For paragraph text, each paragraph can have multiple lines, depending on the dimensions of the

bounding box.You can use the Paragraph panel to set formatting options for a single paragraph, multiple paragraphs,

or all paragraphs in a text layer.

• To show the Paragraph panel, choose Window > Paragraph, or click the Paragraph panel tab if the panel is visible

but not active.

• To modify values in the Paragraph panel and update text in real time, drag the underlined values next to an icon

in the panel.

• To reset values in the Paragraph panel to the default values, choose Reset Paragraph from the Paragraph panel

menu.

To select paragraphs for formatting
❖ Select the Horizontal Type tool  or the Vertical Type tool  and do one of the following:

• Click inside a paragraph to apply formatting to a single paragraph.

• Make a selection within a range of paragraphs to apply formatting to multiple paragraphs.

• Select one or more text layers in the Timeline panel to apply formatting to all paragraphs in the selected layers.

• Select one or more Source Text keyframes to apply formatting to layers only at those keyframes.
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To align and justify text
You can align text to one edge of a paragraph (left, center, or right for horizontal text; top, center, or bottom for

vertical text) and justify text to both edges of a paragraph. Alignment options are available for both point text and

paragraph text; justification options are available only for paragraph text.

• To specify alignment, in the Paragraph panel, click an alignment option:

 Aligns horizontal text to the left, leaving the right edge of the paragraph ragged.

 Aligns horizontal text to the center, leaving both edges of the paragraph ragged.

 Aligns horizontal text to the right, leaving the left edge of the paragraph ragged.

 Aligns vertical text to the top, leaving the bottom edge of the paragraph ragged.

 Aligns vertical text to the center, leaving both the top and bottom edges of the paragraph ragged.

 Aligns vertical text to the bottom, leaving the top edge of the paragraph ragged.

• To specify justification for paragraph text, in the Paragraph panel, click a justification option:

 Justifies all horizontal lines except the last, which is left-aligned.

 Justifies all horizontal lines except the last, which is center-aligned.

 Justifies all horizontal lines except the last, which is right-aligned.

 Justifies all horizontal lines including the last, which is force-justified.

 Justifies all vertical lines except the last, which is top-aligned.

 Justifies all vertical lines except the last, which is center-aligned.

 Justifies all vertical lines except the last, which is bottom-aligned.

 Justifies all vertical lines including the last, which is force-justified.

To indent and space paragraphs
Indentation specifies the amount of space between text and the bounding box or line that contains the text. Inden-

tation affects only the selected paragraph or paragraphs, so you can easily set different indentations for paragraphs.

• To indent paragraphs, enter a value in the Paragraph panel for an indentation option:

Indent Left Margin Indents text from the left edge of the paragraph. For vertical text, this option controls the inden-

tation from the top of the paragraph.

Indent Right Margin Indents text from the right edge of the paragraph. For vertical text, this option controls the

indentation from the bottom of the paragraph.

Indent First Line Indents the first line of text in the paragraph. For horizontal text, the first line indent is relative to

the left indent; for vertical text, the first line indent is relative to the top indent. To create a first line hanging inden-

tation, enter a negative value.

• To change space above or below paragraphs, enter a value in the Paragraph panel for Space Before and Space

After .
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To specify hanging punctuation for Roman fonts
Hanging punctuation controls whether punctuation marks fall inside or outside the margins. If hanging punctuation

is turned on for Roman fonts, then periods, commas, single quotation marks, double quotation marks, apostrophes,

hyphens, em dashes, en dashes, colons, and semicolons appear outside the margins.

❖ Choose Roman Hanging Punctuation from the Paragraph panel menu. A check mark indicates that the option is

selected.

Note: When you use Roman Hanging Punctuation, any double-byte punctuation marks available in Chinese, Japanese,

and Korean fonts in the selected range will not appear outside the margins.

To convert point or paragraph text
The Horizontal Type and Vertical Type tools let you create point text (independent lines of text) or paragraph text

(justifiable text that wraps within a bounding box). You can quickly convert point text to paragraph text and vice

versa.

Note:When you convert paragraph text to point text, all characters outside the bounding box are deleted. To avoid losing

text, resize the bounding box so that all text is visible prior to conversion.

1 Using the Selection tool , select the text layer.

Note: You can’t convert the text layer if it’s in text-editing mode.

2 Using the Text tool , right-click (Windows) or Control-click (Mac OS) anywhere in the Composition panel,

and choose Convert To Paragraph Text or Convert To Point Text.

When you convert from paragraph text to point text, a carriage return is added at the end of each line of text, except

the last line.

To display the bounding box of paragraph text and automatically select the Text tool, double-click the text layer in

the Timeline panel.

To change the direction of text
The Vertical Type and Horizontal Type tools let you enter text that flows horizontally or vertically. Horizontal text

flows from left to right; multiple lines of horizontal text lie from top to bottom. Vertical text flows from top to

bottom; multiple lines of text lie from right to left.

When you convert the vertical or horizontal orientation of a text layer, the results from paragraph text (justifiable

text that wraps within a bounding box) are very different from the results of point text (independent lines of text)

because paragraph text flows relative to its bounding box while point text lies relative to the Composition panel. For

example, when you convert paragraph text from horizontal to vertical or vice versa, the text’s bounding box doesn’t

change its orientation, but the flow of text inside the box does.
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A. Horizontal point text B. Horizontal point text converted to vertical C. Horizontal paragraph text D. Horizontal paragraph text converted
to vertical

1 Using the Selection tool , select the text layer.

Note: You can’t convert the text layer if it’s in text-editing mode.

2 Using the Text tool , right-click (Windows) or Control-click (Mac OS) anywhere in the Composition panel,

and choose Horizontal or Vertical.

Choosing a text composition method
The appearance of text on the page depends on a complex interaction of processes called text composition. Using the

word spacing, letter spacing, and glyph spacing options you’ve selected, After Effects evaluates possible line breaks

and chooses the one that best supports the specified parameters.

After Effects offers two composition methods, which you choose from the Paragraph panel menu:

Adobe Every-line Composer Considers a network of break points for a range of lines and thus can optimize earlier

lines in the paragraph in order to eliminate especially unattractive breaks later on. Working with multiple lines of

text results in more even spacing and fewer hyphens. The Every-line Composer approaches composition by identi-

fying possible breakpoints, evaluating them, and assigning a weighted penalty based on these principles:

• Highest importance is given to evenness of letter and word spacing. Possible breakpoints are evaluated and

penalized according to how much they deviate from optimal spacing.

• After breakpoint penalty values are identified for a range of lines, they are squared, magnifying the bad break-

points. The composer then uses the good breakpoints.

Adobe Single-line Composer Offers a traditional approach to composing text one line at a time. This option is useful

if you prefer to have manual control over how lines break. If spacing must be adjusted, the Single-line Composer first

tries to compress, rather than expand text.

A B

C D
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Working with Chinese, Japanese, and Korean text
After Effects provides several options for working with Chinese, Japanese, and Korean (CJK) text. Characters in CJK

fonts are often referred to as double-byte characters because they require more than one byte of information to

express each character.

To display CJK font name in English, choose Show Font Names In English from the Character panel menu.

To adjust tsume

Tsume reduces the space around a character by a specified percentage value. The character itself is not stretched or

squeezed as a result. When tsume is added to a character, spacing around both sides of the character is reduced by

an equal percentage.

1 Select the characters you want to adjust.

2 In the Character panel, enter or select a percentage for Tsume . The greater the percentage, the tighter the

compression between characters. At 100% (the maximum value), there is no space between the character’s bounding

box and its em box.

To specify how leading is measured

1 Select the paragraphs you want to adjust.

2 Choose Top-To-Top Leading or Bottom-To-Bottom Leading from the Paragraph panel menu. A check mark

indicates which option is selected.

To use tate-chuu-yoko

Tate-chuu-yoko (also called kumimoji and renmoji) is a block of horizontal text laid out within a vertical text line.

Original layer (left) and after tate-chuu-yoko is applied (right)

1 Select the characters that you want to rotate.

2 Choose Tate-Chuu-Yoko from the Character panel menu. (A check mark indicates that the option is turned on.

To turn the option off, choose Tate-Chuu-Yoko again.)

Using tate-chuu-yoko does not prevent you from editing and formatting text; you can edit and apply formatting

options to rotated characters as you do to other characters.
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Animating text

About text animation
As with other layers in After Effects, you can animate text layers. However, text layers offer additional animation

options. You can animate text layers by using any of the following methods:

• Animating the Transform properties, as you would any other layer.

• Applying text animation presets.

• Animating the source text of the layer, so that the characters themselves change to different characters or use

different character or paragraph formats over time.

• Using text animator properties and selectors to animate individual characters, the entire set of characters, or a

range of characters.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“About animation and layer properties” on page 188

Text animation presets
Browse and apply text animation presets as you would any other animation presets.

The text animation presets were created in an NTSC DV 720 x 480 composition, and each text layer uses 72-point

Myriad Pro. Some preset animations move the text on, off, or through the composition. The animation preset

position values may not be appropriate for a composition that is much larger or smaller than 720 x 480; for example,

an animation that is supposed to start off-screen may start on-screen. You may need to adjust the text animator’s

position values.

If the text isn't positioned as expected or the text disappears unexpectedly, adjust the text animator's position values

in the Timeline window or Composition window.

The Paths category of Text animation presets automatically replaces source text with the preset's name, changes the

font color to white, and may change other character properties.

The Fill And Stroke category of animation presets contains presets that may change the fill color and stroke

properties of the preset that you apply. If the animation preset requires a stroke or fill color, the animation works only

if you have assigned one to your text.

To smooth the edges and movement of animated text, enable motion blur for the text layer. See “To apply motion

blur to a layer” on page 215 for more information.

See also

“About animation presets” on page 202
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To animate the source text
Use the Source Text property to change and animate the character and paragraph features of the text characters

themselves (for example, change the letter b to the letter c). Because you can mix and match formatting within a text

layer, you can easily create animations that transform every detail of a word or phrase. For example, you can set

keyframes for the Source Text property to change the letters in a word, text color, font family, style, or stroke width

at different intervals.

Sequential frames in which source text has been animated

1 In the Timeline panel, expand the text layer you want to animate, and then expand the Text property.

2 Click the Source Text stopwatch to create an initial keyframe; then move the current-time indicator to the point

in time where you want the first change to appear and change the text characters or any of the options in the

Character or Paragraph panel.

See also

“About animation and layer properties” on page 188

To animate text with text animator groups
Once you create and format your text layers, use text animator groups to quickly and easily create elaborate anima-

tions. A text animator group includes one or more selectors and one or more animator properties. A selector is like

a mask—it specifies which characters or section of a text layer you want an animator property to affect. Using a

selector, you can define a percentage of the text, specific characters in the text, or a specified range of text.

Using a combination of animator properties and selectors, you can create complex text animations that would

otherwise require painstaking keyframing. Most text animations require you to animate only the selector values—

not the property values. Consequently, text animators use a small number of keyframes even for complex anima-

tions. For example, to animate the opacity gradually from the first character to the last, set the Opacity value (in the

Animator group) to 0, and then set the End (Range Selector property) to 0% at 0 seconds and 100% at the end of the

animation.

Animating the opacity of a text layer using the Opacity animator and the End Range Selector property
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Text animator groups animate a character’s position, shape, and size-related properties relative to each character's

own anchor point. The text property Anchor Point Grouping lets you reposition each character’s anchor point

relative to its word, line, or entire text block. In addition, you can control the alignment of the anchor point relative

to the anchor point group and the font with the Grouping Alignment property.

Original text, then rotated and with Grouping Alignment set to Character, Word, and Line

1 Select a text layer in the Timeline panel, or select the specific characters you want to animate in the Composition

panel.

2 Do one of the following:

• Choose Animation > Animate Text and then choose a property from the submenu.

• Choose a property from the Animate menu, located in the Switches/Mode column of the Timeline panel.

Animate menu

3 In the Timeline panel or in the Graph Editor, adjust the animator property values.

4 Expand the Range selector and set keyframes for Start or End by doing one of the following:

• Drag or type the values in the Timeline panel.

• Drag the selector bars in the Composition panel.
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Selector bars surrounding the three middle characters VEN

5 To refine the selection, expand Advanced and specify options and values as desired.

For information about using selectors, see “About selectors” on page 299.

Because all of the animator groups that you add to a text layer appear with the name “Animator” in the Timeline

panel, you may want to rename them using more descriptive names. You can rename animator groups and selectors

the same way you rename layers. (See “To rename a layer” on page 158.)

To remove animators from a text layer, select the text layer in the Timeline panel, and choose Animation > Remove

All Text Animators.

To set a text layer’s anchor point properties
1 Expand the text layer in the Timeline panel, and expand the More Options group.

2 Do any of the following:

• Choose how to group the text layer’s character anchor points from the Anchor Point Grouping menu.

• Lower the Grouping Alignment values to move each anchor point up and to the left.

• Raise the Grouping Alignment values to move each anchor point down and to the right.

To center the anchor point in a string of capital letters, try a Grouping Alignment value of 0%, -50%. To center the

anchor point in a string of lowercase letters, or if you’re using both lowercase and uppercase letters, try 0%, -25%.

Animator properties
Use animator properties to animate text in text layers.

Most animator properties are identical to other layer properties, such as Position, Scale, and Opacity; however, the

following properties are unique to text layers or behave differently for text layers:

Position The position of the characters. You can specify values for this property in the Timeline panel, or in the

Composition panel using the Selection tool, which changes to a move tool when positioned over text characters.

Skew The slant of the characters. The Skew Axis specifies the axis along which the character is skewed.

All Transform Properties All of the Transform properties are added at once to the animator group.

Fill Color (RGB, Hue, Saturation, Brightness, Opacity) The color of the character’s fill.

Stroke Color (RGB, Hue, Saturation, Brightness, Opacity) The color of the character’s stroke (outline).



ADOBE AFTER EFFECTS 7.0
User Guide

299

Stroke Width The width of the character’s stroke (outline).

Tracking The space between each character in a word.

Line Anchor The alignment for the tracking in each line of text. A value of 0% specifies left align, 50% specifies

center align, and 100% specifies right align.

Line Spacing The space between lines of text in a multiline text layer.

Character Offset The number of Unicode values to offset selected characters. For example, a value of 5 moves the

characters in the word forward five steps alphabetically, so the word offset becomes tkkxjy.

Character Value The new Unicode value for selected characters, replacing each character with one character repre-

sented by the new value. For example, a value of 65 replaces all of the characters in a word with the 65th Unicode

character (A), so the word value becomes AAAAA.

Character Range Specifies limits on the character. This property appears whenever you add the Character Offset or

Character Value property to a layer. Choose Preserve Case & Digits to keep characters in their respective groups.

Groups include uppercase roman, lowercase roman, digits, symbols, Japanese katakana, and so forth. Choose Full

Unicode to allow for unlimited character changes.

Blur The amount of Gaussian blur to be added to the characters. Horizontal and vertical blur amounts can be

specified separately.

See also

“About animation and layer properties” on page 188

To add animator properties
• To add an animator group to a text layer, select the text layer in the Timeline panel, and choose a property from

the Animate menu in the Timeline panel. A new animator group, along with a selector and the chosen animator

property, appears in the Timeline panel.

• To add a new animator property to an existing animator group, select the animator group in the Timeline panel,

and choose the property from the Add menu; then choose a property from the submenu. The new animator

property appears within the same group as the existing animator property and shares the existing selector.

Selectors

About selectors
Each animator group includes a default Range selector. You can add additional Range selectors to an animator group

or add multiple animator properties that use the same Range selector.

In addition to this Range selector, you can add a Wiggly selector. Use the Wiggly selector to create selections that

wiggle—vary within a specified amount—over time. You can add one or more Wiggly selectors to an animator group,

and that animator group can contain one or more properties.

When you add multiple selectors to an animator group, you can control the way they interact with each other by

using each selector’s Mode property. You can set values for the Start and End properties by changing the values in

the Timeline panel or by using the selector bars in the Composition panel.
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Note: Only add selectors to existing animator groups—you can’t create an animation unless you have a property to

animate.

To add a new selector to an animator group
❖ In the Timeline panel, select an animator group and choose Selector from the Add menu; then choose either

Range or Wiggly from the submenu.

Adding a new Range selector to an animator group

To specify ranges with the Range selector
❖ In the Timeline panel, do one of the following:

• To specify an animated range that gradually applies the animator property to all of the characters, set an End

keyframe of 0% at 0 seconds and 100% at the end of the animation.

• To specify a static range of individual characters in the Composition panel, drag the left selector bar to the left edge

of the first character you want in the range and drag the right selector bar to the right edge of the last character

you want in the range.

• To specify an animated range of individual characters in the Composition panel, drag both selector bars to the left

side of the first character in the range and set a Start or End keyframe, move the current-time indicator to the end

of the animation, and then drag the right selector bar to the right side of the last character in the range.

• To move both the Start and End values by an equal amount, set a value for Offset.

See also

“Using keyframes” on page 192

Range selector properties
The Range selector includes the following properties:

Start and End The beginning and end of the selection (relative to the number of characters, words, or lines as

specified by the Units and Based On properties). For example, if you set Start to 0%, and set keyframes for End for

0% at 0 seconds and 100% at 4 seconds, the animator property will gradually take effect over those 4 seconds.

Offset Specifies how much you want to offset the Start and End of the selection. This property is useful for animating

the selector through the text, because the value you specify moves the Start and End values equally, saving you the

trouble of animating them both exactly the same way. To set the offset in the Composition panel while you edit the

Start or End values, Shift-click the Start or End selector bars.

Units and Based On The units for Start, End, and Offset. You can use either the percentage or index units and base

the selection on the characters, characters excluding spaces, words, or lines. If you select Characters, After Effects

counts spaces and effectively pauses the animation between words as it animates the spaces between words.
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Original (left) and with VEN selected by the range selectors, Based On set to Character, Shape set to Triangle, and Scale set to 40% (right)

Mode If you have only one selector, Mode specifies the interaction between the selector and the text. With one

selector, you can use the Subtract mode to invert the selector; other modes do not have an effect on the layer. If you

have multiple selectors, Mode specifies the way each selector combines with the selectors above it, similar to how

multiple masks combine when you apply a mask mode. For example, if your first Range selector includes characters

20-80 and is set to Add mode and your second Range selector includes characters 50-55 and is set to Subtract mode,

the resulting selection includes only characters 20-49 and 56-80, subtracting 50-55 from the range.

Amount Specifies how much you want the range of characters to be affected by animator properties. At 0%, the

animator properties do not affect the characters. At 50%, half of each property value affects the characters. This

option is useful for animating the result of animator properties over time.

Shape Controls how characters are selected between the Start and End of the range. Each option modifies the

selection by creating gradual transitions between selected characters using the chosen shape. For example, when

animating the y Position values of text characters using Ramp Down, the characters gradually move at an angle from

bottom left to upper right. You can specify Square, Ramp Up, Ramp Down, Triangle, Round, and Smooth.

Original (left) and after selecting the entire word, setting Based On to Characters, animating the y Position value so that the word is at the
bottom of the frame, and setting Shape to Ramp Down (right)

Smoothness Determines the amount of time the animation takes to transition from one character to another when

you use the Square shape.

Ease High and Ease Low Determines the speed of change as selection values change from fully included (high) to

fully excluded (low). For example, when Ease High is 100%, the character changes more gradually (eases into the

change) while it is fully to partially selected. When Ease High is -100%, the character changes quickly while it is fully

to partially selected. When Ease Low is 100%, the character changes more gradually (eases into the change) while it

is partially selected to unselected. When Ease Low is -100%, the character changes quickly while it is partially

selected to unselected.

Randomize Order Randomizes the order in which the property is applied to the characters specified by the Range

selector. (By contrast, when you use the Wiggly selector, the value of the animator property is randomized.)

Random Seed Calculates the randomized order of a Range selector when the Randomize Order option is set to On.

When Random Seed is zero, the seed is based on its animator group. If you want to duplicate an animator group and

retain the same randomized order as in the original animator group, set Random Seed to a value other than zero.

See also

“About mask modes” on page 264
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Wiggly selector properties
The Wiggly selector includes the following properties:

Mode Specifies how each selector combines with the selectors above it, similar to how multiple masks combine

when you apply a mask mode. For example, if you want to wiggle only a specific word, use a Range selector on that

word and then add a Wiggly selector and set it to Intersect mode.

Max Amount and Min Amount Specifies the amount of variation from the selection.

Based On Select Characters, Characters Excluding Spaces, Words, or Lines.

Wiggles/Second Specifies how many variations from the set selection occur per second.

Correlation Correlation between variations for each character. At 100%, all characters wiggle by the same amount at

the same time, and at 0%, all characters wiggle independently.

Temporal and Spatial Phase (revolutions + degrees) The variation of wiggle, based on the phase of your animation

in time (temporal) or per character (spatial).

Lock Dimensions Scales the wiggled selection’s dimensions by the same value. This is useful when wiggling the Scale

property.

Random Seed Changes the starting time for the animation by a specified value. When the seed is left at zero, a

default value is derived based on the layer index and stream path.

See also

“About mask modes” on page 264

About the Expression selector
The Expression selector lets you dynamically specify how much you want characters to be affected by an animator

property through the use of expressions. You can add one or more Expression selectors to an animator group, and

that animator group can contain one or more properties.

The Expression selector includes the following options:

Based On Specifies whether to base the selection on characters, including spaces; on characters, excluding spaces;

on words; or on lines.

Amount Specifies how much you want the range of characters to be affected by animator properties. At 0%, the

animator properties do not affect the characters. At 50%, half of each property value affects the characters. You can

use expressions to dynamically set this option.

In addition to the expression elements you use elsewhere, you can use the following attributes to animate selections

in any number of interesting ways:

textIndex Returns the index of the character, word, or line.

textTotal Returns the total number of characters, words, or lines.

selectorValue Returns the value of the previous selector. Use selectorValue for three-dimensional animator

properties like RGB, or for two-dimensional animator properties like scale and position.

Note: The attributes textIndex, textTotal, and selectorValue can be used only with the Expression selector. Using them

elsewhere results in a syntax error.
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Fill color changes randomly using an expression animator.

See also

“About expressions” on page 555

To add an Expression selector to an animator group
1 In the Timeline panel, select an animator group.

2 Choose Selector > Expression from the Add menu.

Expand the Expression Selector property group and the Amount property group to reveal the expression field in the

timeline. By default, the Amount property begins with the expression selec torValue *  textIndex/textTotal .

See also

“About expressions” on page 555

Working with masks in text layers

Creating and animating text on a path
Once you create a mask in a text layer, you can make the text follow the mask as a path. You can then animate the

text along that path, or animate the path itself. You can use open or closed masks to create paths for text. After you

create the path, you can modify it at any time. When using a closed mask as a text path, make sure to set the mask

mode to None.

See also

“Creating masks” on page 244

“About mask modes” on page 264
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To position text along a mask’s path

1 Create a text layer and type the desired text.

2 With the text layer selected, use the Pen tool to draw a mask in the Composition panel.

3 In the Timeline panel, expand the Path Options property for the text layer and select the mask from the Path

menu. The text automatically uses the alignment specified in the Paragraph panel.

Note: If the mask is closed (for example, if the mask is a circle), set the mask mode to None.

4 To reposition the text on the path, do one of the following in the Composition panel:

• Drag the left margin control  to move left-aligned text away from the left edge of the path.

• Drag the center margin control  to move center-aligned text away from the center of the path.

• Drag the right margin control  to move right-aligned text away from the right edge of the path.

• Drag either the right or left margin control to move force-aligned text away from the edges of the path.

• Shift-drag any margin control to snap the control to the mask vertices.

Note: You can also change the text margins using the Right Margin and Left Margin properties in the Timeline panel.

Changing the Last Margin of path text in the Composition panel

See also

“Creating masks with the Pen tool” on page 245

“About mask modes” on page 264

To change or animate text path properties
Use the Path Options property to specify a path and alter the way that individual characters appear on the path—

perpendicular to the path, aligned to the left or right, reversed, and so on. Animating Path Options is an easy way to

create text that travels along a path. You can also animate the First Margin property so that the margin moves from

one end of the path to the other.

1 In the Timeline panel, expand the text layer you want to animate, expand the Text property, and then expand the

Path Options property.

2 Change any of the Path Options properties that you want.

3 To animate a property, click the property’s stopwatch icon to set the initial keyframe and then set the option as

desired.

Path Options include the following additional properties:

Reverse Path Reverses the path. This option is useful for closed paths; however, to see the results, make sure the

mask mode is set to None.

Perpendicular To Path Rotates each character so that it is perpendicular to the path.
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Force Alignment Positions the first character at the beginning of the path (or at the specified First Margin location),

positions the last character at the end of the path (or at the specified Last Margin location), and evenly spaces the

remaining characters between the first and last characters.

First Margin Specifies the position of the first character in pixels, relative to the start of the path. The First Margin is

not active when text is right-aligned and force alignment is not enabled.

Last Margin Specifies the position of the last character in pixels, relative to the end of the path. Last Margin is not

active when text is left-aligned and force alignment is not enabled.

See also

“About animation and layer properties” on page 188

“Using keyframes” on page 192

Examples of text animations

Example: To offset characters
This example illustrates how you can easily animate random characters so that they gradually form a legible word or

phrase. To do this, specify a Character Offset value and animate the Range selector.

Animating the offset values for the characters in the word Galaxy

1 Create a new composition.

2 Create a new text layer with the word Galaxy.

3 Position the pointer away from the text in the Composition panel and when the type pointer changes to the move

pointer , drag to move the text to the bottom and center of the panel. Resize it if necessary so that it fits within the

panel.

4 Choose Animation > Animate Text > Character Offset.

5 In the Timeline panel, set the Character Offset value to 5.

6 Expand Range Selector 1.

7 Click the Start stopwatch to set an initial keyframe at 0 seconds and set the value to 0%.

8 Move the current-time indicator to 5 seconds and set the Start value to 100%.

9 Preview the animation.

See also

“To create a composition” on page 109

“To enter point text” on page 283
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“To specify ranges with the Range selector” on page 300

“Using keyframes” on page 192

“Methods for previewing compositions” on page 134

Example: To animate characters with the Wiggly selector
This example demonstrates how easy it is to animate the position of individual characters. It also shows how the

Wiggly selector can create a dramatic change to the animation simply by adding it to the layer. The effect is

spectacular, but the keyframing is minimal.

Animating the color and position of the characters in the word Galaxy

1 Create a new composition.

2 Create a new text layer with the word Galaxy and set the color to blue in the Character panel.

3 Position the pointer away from the text in the Composition panel and when the type pointer changes to the move

pointer , drag to move the text to the center of the panel. Resize it if necessary so that it fits within the panel.

4 Choose Animation > Animate Text > Position.

5 In the Timeline panel, drag the Position property’s y value to the left until all the characters are off the screen.

6 Expand Range Selector 1.

7 Click the Start stopwatch and leave it at 0% at 0 seconds; then move the current-time indicator to 5 seconds and

set Start to 100%.

8 Preview the animation.

9 Collapse the Animator 1 group.

10 Make sure that nothing is selected except the text layer name in the Timeline panel, and choose Fill Color > Hue

from the Animate menu. A new animator group, Animator 2, appears in the Timeline panel.

11 Set Fill Hue to 1 x +0.0.

12 Expand the Range Selector 1 for Animator 2.

13 Click the Start stopwatch and leave it at 0% at 0 seconds; then move the current-time indicator to 5 seconds and

set Start to 100%.

14 Preview the animation. The colors change now as they drop from the top of the screen, but they all use the same

color and end up the same, original color.

15 With Fill Hue selected, choose Selector > Wiggly from the Add menu.

16 Expand the Wiggly Selector 1 property and choose Add from the Mode menu.

17 Preview the animation.
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Note: If you add the Fill Hue property to Animator 1 and then add the Wiggly selector, both the position and the colors

wiggle, instead of just the colors.

See also

“To create a composition” on page 109

“To enter point text” on page 283

“Range selector properties” on page 300

“Wiggly selector properties” on page 302

“Using keyframes” on page 192

“Methods for previewing compositions” on page 134

Example: To animate text tracking
This example illustrates how easy it is to isolate characters when tracking a line of text. Using the Tracking and Line

Anchor animator properties, you can easily move all but one or a few characters.

Animating the tracking values for the characters 3579 (left and center) so that only the 7 in the middle remains (right)

1 Create a new composition.

2 Create a new text layer and type 3579.

3 With the text layer selected, click the Center Text button in the Paragraph panel.

4 Position the pointer away from the text in the Composition panel and when the type pointer changes to the move

pointer , drag to move the text to the center of the panel. If necessary, use the Character panel to resize the text so

that it fits within the panel.

5 Choose View > Show Grid.

6 In the Timeline panel, select the text layer and choose Animation > Animate Text > Tracking.

7 Make sure that Before & After is specified in the Track Type menu.

8 Click the Tracking Amount stopwatch and leave the value at 0 at 0 seconds.

9 Move the current-time indicator to 5 seconds and drag the Tracking Amount value until all characters are off the

screen.

10 Preview the animation.

11 With the current-time indicator at 0, take a snapshot of the Composition panel. You will use this, and the grids,

to determine the original location of the number 7 at the end of the animation.

12 Move the current-time indicator to 5 seconds.

13 Click the Show Last Snapshot button.

14 In the Timeline panel, select Animator 1 and choose Line Anchor from the Add menu.
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15 Drag the Line Anchor value until the 7 is positioned in approximately its original position in the center of the

Composition panel.

16 Click the Show Last Snapshot button in the Composition panel to see the exact location of the 7 in its original

location. Adjust the Line Anchor value to position the character in the original location.

17 Preview the animation.

See also

“To create a composition” on page 109

“To enter point text” on page 283

“Using keyframes” on page 192

“To take or view a snapshot” on page 145

“Methods for previewing compositions” on page 134

Example: To use selectors to animate specific words
There are many ways to use selectors. This example shows how you can use them to limit an animation to a specific

word.

Animating the skew values in the characters in the word Speeding

1 Create a new composition.

2 Create a new text layer with the words Speeding Saucer.

3 Position the pointer away from the text in the Composition panel and when the type pointer changes to the move

pointer , drag to move the text to the center of the panel. Resize it if necessary so that it fits within the panel.

4 Choose Animation > Animate Text > Skew.

5 In the Timeline panel, set the Skew value to 35.

6 Expand Range Selector 1.

7 Make sure the current-time indicator is at 0 seconds and click the End stopwatch.

8 In the Composition panel, drag both selector bars to the left side of the S in Speeding.

9 Move the current-time indicator to 2 seconds and drag the right selector bar to the right side of the g in Speeding.

10 Preview the animation.

See also

“To create a composition” on page 109

“To enter point text” on page 283
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“Range selector properties” on page 300

“Using keyframes” on page 192

“Methods for previewing compositions” on page 134

Example: To change transitions between characters
Using different Shape options, you can significantly change the appearance of an animation.

Setting Shape to Triangle

1 Create a new composition.

2 Create a text layer with the characters 01234.

3 Position the pointer away from the text in the Composition panel and when the type pointer changes to the move

pointer , drag to move the text to the top of the panel. Resize it if necessary so that it fits within the panel.

4 Choose Animation > Animate Text > Position.

5 Expand Range Selector 1.

6 Make sure the current-time indicator is at 0 seconds and click the End stopwatch and set End to 0.

7 Move the current-time indicator to 5 seconds and set End to 5.

8 Adjust the y Position value so that the text appears at the bottom of the Composition panel.

9 Preview the animation.

10 Click Advanced and choose Triangle from the Shape menu; then preview the animation.

11 Choose Square from the Shape menu and preview the animation; then set Ease High to 100% and preview the

animation.

12 Set Ease High to -100 and preview the animation again.

13 Set different options from the Shape menu and preview the resulting animations.

See also

“To create a composition” on page 109

“To enter point text” on page 283

“Range selector properties” on page 300

“Using keyframes” on page 192

“Methods for previewing compositions” on page 134

Example: To create a write-on animation
You can easily create the appearance of writing on the screen by using the Opacity animator property.
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Writing text on using the Opacity property

1 Create a new composition.

2 Create a text layer with the characters 01234.

3 Position the pointer away from the text in the Composition panel and when the type pointer changes to the move

pointer , drag to move the text to the center of the panel. Resize it if necessary so that it fits within the panel.

4 Choose Animation > Animate Text > Opacity.

5 Set Opacity to 0%.

6 Expand the Range Selector 1 and click the stopwatch icon for Start.

7 In the Composition panel, drag the start selector to the left edge of the text (the value will be at 0).

8 Move the current-time indicator to 5 seconds and drag the start selector in the Composition panel to the right

edge of the text (the value will be 5).

9 Preview the animation.

10 By default, the Smoothness property is set to 100%. To create a typewriter appearance, expand the Advanced

property and set Smoothness to 0%.

See also

“To create a composition” on page 109

“To enter point text” on page 283

“Range selector properties” on page 300

“Wiggly selector properties” on page 302

“Using keyframes” on page 192

“Methods for previewing compositions” on page 134

Example: To animate text with multiple selectors
This example uses the selec torValue parameter with the Wiggly selector to make a string of characters flash on and

off randomly.

1 Create a new composition.

2 Create a new text layer.

3 In the Timeline panel, choose Opacity from the text layer’s Animate menu.

4 Expand the text layer and its animator in the Timeline panel.

5 Select the Range Selector and delete it.

6 Choose Add Selector > Wiggly next to the text layer’s Animator property group.
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7 Choose Add > Selector > Expression. If the Wiggly selector doesn’t come before the Expression selector, drag the

Wiggly selector above the Expression selector.

8 Expand the Expression Selector.

9 Expand the Amount property group to reveal the expression. The following expression appears by default:

selec torValue *  textIndex/textTota l

10 Replace the default expression text with the following expression:

r_val=selectorValue[0] ;

i f (r_val < 50)r_val=0;

i f (r_val > 50)r_val=100;

r_val

11 Set the opacity to 0%, and preview your animation.

See also

“To create a composition” on page 109

“To enter point text” on page 283

“About the Expression selector” on page 302

“Wiggly selector properties” on page 302

“Methods for previewing compositions” on page 134

Example: To animate text position with expressions
This example uses the textIndex and textTota l  attributes with the wiggle  expression to animate a line of text.

1 Create a new composition.

2 Create a new text layer.

3 Expand the text layer in the Timeline panel to view the text properties. Add a position animator group from the

Animate menu.

4 Delete the default Range selector. Be sure to click in the Timeline panel first to deselect the animator group, and

then select Range Selector 1 to delete it.

5 Add an Expression selector by selecting the Add menu, then choosing Selector > Expression. Expand the

Expression selector to reveal its options.

6 Expand the Amount property to reveal the expression. The following expression appears by default:

selec torValue *  textIndex/textTota l

7 Replace the default expression with the following expression:

seedR andom(textIndex) ;

amt = l inear(t ime,  0 ,  5 ,  200 * textIndex / textTotal , 0) ;

wigg le(1 ,  amt) ;

The l inear method is used in this example to ramp down the maximum wiggle amount over time.

8 Set the vertical position value. The greater the value, the more the characters wiggle.

9 Preview your animation.
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See also

“To create a composition” on page 109

“To enter point text” on page 283

“About the Expression selector” on page 302

“Methods for previewing compositions” on page 134
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Chapter 14: Paint tools

Using paint tools

To specify paint tool options
The Brush tool, Clone Stamp tool, and Eraser tool are all paint tools. Each uses brushes to apply paint strokes to a

layer to add or remove pixels from the layer or modify the layer’s transparency without modifying the layer source.

You can specify the properties of a paint stroke before you make it by choosing options from the Paint panel.

Note: Paint strokes appear as applications of the Paint effect. The Vector Paint effect behaves somewhat differently from

the Paint effect and uses a different set of tools. For more information, see “Vector Paint effect (Pro only)” on page 475.

You can apply the Brush tool and the Clone Stamp tool to the alpha channel (Alpha) of an image, the RGB channels

(RGB), or both (RGBA). When Alpha is selected, you can only add and remove opacity; swatches display colors in

monochromatic tones. Painting the alpha channel with 100% black has the same result as using the Eraser tool: It

creates transparent paint strokes. (See “About alpha channels and mattes” on page 242.)

Opacity and Flow settings can range from 0% to 100%. For the Brush tool, Opacity specifies the maximum amount

of paint coverage applied by the brush, whereas Flow specifies how quickly paint is applied. To simulate semi-trans-

parent paint, specify a low percentage value; to simulate opaque paint, specify a high value. For the Eraser tool,

Opacity specifies the maximum amount of paint and layer source removed by the brush, whereas Flow specifies how

quickly the removal occurs.

When a paint tool is selected, click the Toggle the Paint panels button to open or close the Paint panel and Brush

Tips panel.

❖ In the Paint panel, do any of the following:

• Choose an option from the Channels menu.

• Choose a blending mode from the Mode menu to specify how pixels in the image are affected by the paint stroke.

• Drag or type the Opacity or Flow value.

• Choose an option from the Duration menu:

Single Frame Applies the paint stroke to the selected frame only.

Constant (default) Applies the paint stroke to the current frame and all subsequent frames of the layer.

Write On Animates the paint stroke.

Custom Applies the paint stroke to a specified number of frames.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“Blending modes for paint strokes” on page 324



ADOBE AFTER EFFECTS 7.0
User Guide

314

To use the Brush tool
Use the Brush tool to paint on a layer with the current foreground color. With the Brush tool, you can modify the

color and transparency of a layer without altering the source footage.

By default, the Brush tool creates soft strokes of color. However, you can change these default characteristics by

changing the tool’s brush options. You can modify how the brush stroke interacts with the background color of the

layer and with other brush strokes by specifying a blending mode.

1 Double-click the layer you want to paint on.

2 Select the Brush tool  from the Tools panel.

3 Do any of the following in the Paint panel:

• Select a brush, and set brush tip options.

• Select a color by clicking the Foreground Color icon and specifying a color in the Color Picker.

• Specify opacity and flow, blending mode, channel, and duration.

4 Position the Brush tool over the layer, and drag to paint. The Brush tool changes to a brush tip cursor in the Layer

panel. Each resulting stroke appears in the Timeline panel as a separate item with properties that can be animated.

You can interleave paint strokes with other effects that are already applied to the layer: Click the View menu in the

Layer panel, and choose the view that you want to paint.

See also

“Blending modes for paint strokes” on page 324

To select a color for the Brush tool
The Paint panel provides a Foreground and Background color for you to use while painting. You can select from a

range of colors or enter RGB values to create a new color. Switch the order of these colors by clicking the Switch

icon  or reset the colors to black and white by clicking the Reset icon .

1 In the Paint panel, click the Foreground or Background color selection box.

2 Do one of the following:

• Select a color.

• Create a custom color by entering values for red (R), green (G), and blue (B); values for hue (H), saturation (S),

and brightness (B); or a single hexadecimal value.

See also

“To select a color with the Eyedropper tool” on page 327

“To select a color with the Color Picker” on page 327

To rotoscope with the Brush tool
Rotoscoping involves painting on individual frames over a series of frames to create an animation or to remove

unwanted details in your footage. Though rotoscoping can be tedious work, After Effects makes the process

somewhat easier.

1 Double-click the layer you want to paint.
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2 Select the Brush tool in the Tools panel.

3 In the Paint panel, choose Custom from the Duration menu, and specify the duration in frames. Select paint

options as desired.

4 Paint in the layer.

5 Press Ctrl + Page Down (Windows) or Command + Page Down (Mac OS) to advance the number of frames

specified by the Custom duration setting. (To move back the same number of frames, press Ctrl + Page Up

(Windows) or Command + Page Up (Mac OS).

If you use a graphics tablet, map the keyboard shortcuts to the buttons on your pen to work more efficiently. Refer to

your tablet’s documentation for instructions. For more information about using your tablet with the paint tools, see

“To set brush dynamics for graphics tablets” on page 319.

6 Repeat steps 4 and 5 as needed.

See also

“About Filmstrip format” on page 623

Using the Clone Stamp tool
The Clone Stamp tool samples the pixels on a source layer and applies the sampled pixels to a target layer; the target

layer can be the same layer or a different layer in the same composition.

You can use the Clone Stamp tool to clone pixels and repair images in the Layer panel. For example, you can use the

Clone Stamp tool to retouch footage, remove wires or a microphone boom from footage, or add elements to footage.

Removal of wire in moving footage with Clone Stamp tool

You can clone a single frame or apply clone strokes continuously over several frames. Each clone stroke paints on

more of the sample.

The Clone Stamp tool samples paint strokes and effects in the source layer, in addition to the layer source, when the

source layer and target layer are the same.

The clone source time automatically loops back to the starting sample point when the current sampling point goes

beyond the end of the source layer's duration. This is especially helpful when you have a lot of frames to repair in the

target layer but only a few good frames in the source layer.

Each clone stroke includes properties that are unique to the Clone Stamp tool in addition to blending modes, stroke

options, and transform properties. You can view these properties in the Stroke Options section in the Timeline panel:

Clone Source Specifies the sampled layer.

Clone Position Specifies the x, y location of the sample within the source layer.

Clone Time Specifies the time (measured in seconds) in the Composition panel when you sampled the source layer,

as indicated by the current-time indicator. This property appears only when Lock To Source is selected.
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Clone Time Shift Specifies the number of seconds between the sample and the clone stroke. This property appears

only when Lock To Source is not selected.

When using the Clone Stamp tool, you set a starting sample point (Source Position) in the source layer and then drag

in the target layer to apply the sample. To help you identify what the Clone Stamp tool is sampling as you apply cloned

strokes, a cross-hair appears in the source layer wherever a point is sampled. You can identify the sampled area more

easily with the Clone Source Overlay option, which displays a semi-transparent image of the source layer over the

target layer as you work.

Displaying the clone source overlay while cloning between two different layers
A. Clone Source Overlay B. Current stroke point C. Current sampling point

The Aligned option affects the Clone Stamp tool’s sampling behavior. If Aligned is selected, the source layer is fixed

in position no matter how many strokes you apply; you can release the mouse button without losing the current

sampling point. As a result, the sampled pixels are applied continuously to reproduce the entire sampled area, no

matter how many times you stop and resume painting. If Aligned is deselected, each new stroke in the target layer,

no matter where they are applied, begins sampling from the same starting sample point (Source Position) in the

source layer.

To use the Clone Stamp tool with the Paint panel

1 Open a composition that contains both the source layer and the target layer.

2 Open the target layer in a Layer panel.

3 Move the current-time indicator in the Layer panel to the frame to which you want to apply the sample.

4 Select the Clone Stamp tool from the Tools panel.

5 Select a brush in the Brush Tips panel, and set brush options. Optionally, set the opacity, flow, blending mode,

channel, and duration in the Paint panel.

6 In the Paint panel, choose the name of the layer to sample from the Source menu, or choose Current Layer to use

the target layer as the source layer.

7 If you want to view the source layer as you apply strokes in the target layer, select Clone Source Overlay in the

Paint panel, and do any of the following:

• To change the clone source overlay’s transparency, adjust the % value next to the Clone Source Overlay option.

• To apply the Difference blending mode to the clone source overlay, click the Difference Mode button .

A B C
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Moving the clone source overlay around while in the Difference blending mode can help you line up elements or see

differences between frames as you move through time. You can temporarily display the clone source overlay by

pressing Alt+Shift (Windows) or Option+Shift (Mac OS).

8 To sample from the source layer at a different point in time, drag or enter a Source Time Shift value in the Paint

panel.

9 Do one of the following to control where each new stroke samples in the source layer:

• Deselect Aligned to make each new stroke begin sampling from the starting sample point. Optionally, to adjust

the starting sample point’s position, adjust the Source Position’s x and y values, or click Reset to set them both

to zero.

• Select Aligned to match the offset between the current sampling point and the starting sample point to the offset

between each new stroke relative to the starting stroke point. Optionally, to change the offset between the starting

sample point and the starting stroke point, adjust the Offset x and y values or click Reset  to set them both to

zero.

10 Click or drag in the target layer to apply the sample.

Alt+Shift-drag (Windows) or Option+Shift-drag (Mac OS) to view and change the position of the source layer.

See also

“Blending modes for paint strokes” on page 324

To use the Clone Stamp tool manually

1 Open a composition that contains both the source layer and the target layer.

2 Select the Clone Stamp tool from the Tools panel.

3 Select a brush in the Brush Tips panel, and set brush options. Optionally, set the opacity, flow, blending mode,

channel, and duration in the Paint panel.

4 Open the source layer in a Layer panel.

5 Move the current-time indicator in the Timeline panel to the frame that you want to sample in the source layer.

6 Alt-click (Windows) or Option-click (Mac OS) the desired starting sampling point, setting the Source Position

value.

7 Open the target layer in a Layer panel. (The source layer can also be the target layer.)

8 Move the current-time indicator in the Layer panel to the frame to which you want to apply the sample.

9 To view the source layer as you apply strokes in the target layer, select Clone Source Overlay in the Paint panel,

and do any of the following:

• To change the clone source overlay’s transparency, adjust the % value next to the Clone Source Overlay option.

• To apply the Difference blending mode to the clone source overlay, click the Difference Mode button .

Moving the clone source overlay around while in the Difference blending mode can help you line up elements or see

differences between frames as you move through time. You can temporarily display the clone source overlay by

pressing Alt+Shift (Windows) or Option+Shift (Mac OS).
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10 Do one of the following to control where each new stroke samples in the source layer:

• Deselect Aligned to make each new stroke begin sampling from the starting sample point (Source Position).

Optionally, to adjust the starting sample point’s position, adjust the Source Position’s x and y values or click

Reset  to set them both to zero.

• Select Aligned to match the offset between each new stroke relative to the starting sample point (Source Position).

Optionally, to change the offset between the source layer and the target layer, adjust the Offset x and y values or

click Reset  to remove any offset and align the center of the source layer to the target layer.

11 Click or drag in the target layer to apply the sample. To extend the clone stroke in a straight line after creating

the stroke, Shift-click where you want the stroke to end.

Alt+Shift-drag (Windows) or Option+Shift-drag (Mac OS) to view and change the position of the source layer.

See also

“Blending modes for paint strokes” on page 324

To save a Clone Stamp preset

Clone Stamp presets let you conveniently save and reuse clone source settings and are particularly useful when

rotoscoping. You can apply Clone Stamp presets to layers in the same composition or in a different composition or

to a layer in a different project.

Clone stamp presets let you store the Source Layer, Aligned, Lock Source Time, Source Time Shift, and Offset or

Source Point values.

1 Select the Clone Stamp tool.

2 In the Paint panel, click the Clone Stamp Preset button to which you want to save the settings.

3 Adjust the Clone Options as desired. The settings are stored in the selected preset.

To quickly copy the settings from one Clone Stamp preset to another, click the Clone Stamp Preset button that you

want to copy, and Alt-click (Windows) or Option-click (Mac OS) the Clone Stamp Preset button to which you want

to paste the settings.

To use a Clone Stamp preset

1 Select the Clone Stamp tool.

2 Do one of the following:

• Press the number key on the main keyboard associated with the desired Clone Stamp preset. (3=first preset,

4=second preset, 5=third preset, 6=fourth preset, and 7=fifth preset.)

• Select the Clone Stamp tool in the Tools panel, and click the desired Clone Stamp Preset button in the Paint panel.

3 Use the Clone Stamp tool.

To use the Eraser tool
Use the Eraser tool to create transparency in a layer or remove paint strokes.

Eraser strokes made with the Layer Source And Paint or the Paint Only option create a separate item and duration

bar inside the layer’s Paint property group in the Timeline panel. You can animate the shape, stroke options, and

transform properties of these eraser strokes to create unique effects. In contrast, eraser strokes made with the Last

Stroke Only option can’t be animated, and permanently erase the targeted paint stroke.
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To temporarily use the Eraser tool with the Last Stroke Only option while using the Clone Stamp or Brush tool,

Ctrl+Shift-drag (Windows) or Command+Shift-drag (Mac OS) over the stroke you want to erase. You can also use

this shortcut while using the Eraser tool in Layer Source And Paint or Paint Only mode.

1 Select a layer in the Timeline or Composition panel.

2 Select the Eraser tool from the Tools panel.

3 In the Erase menu in the Paint panel, choose what you want to erase.

4 Select a brush in the Brush Tips panel, and set brush options.

5 (optional) Set the Opacity, Flow, Channels, and Duration values in the Paint panel.

6 Drag through the area you want to erase in the Layer panel. The pointer icon indicates the size and shape of the

selected brush tip.

See also

“About animation and layer properties” on page 188

Brushes

Selecting brushes
Once you’ve selected a paint tool, you can select preset brushes and design custom brushes in the Brush Tips panel.

The brush you select determines many characteristics of the resulting brush stroke.

Choose Window > Brush Tips to open the Brush Tips panel.

To set brush dynamics for graphics tablets
You can use a graphics tablet with each paint tool. You can adjust the brush tip by using the graphic tablet’s pen

pressure, pen tilt, or position of the pen thumbwheel. Specify brush dynamics options in the Brush Tips panel to add

dynamic (or changing) elements to brush tips. For example, you can change the size of your brush tip dynamically

by adding more or less pen pressure. Pressing the eraser side of the pen to the tablet always selects the Eraser tool.

Note: Brush dynamics are available only when you’re using a pressure-sensitive digitizing tablet such as a Wacom tablet.

❖ In the Brush Tips panel, select a brush tip, and change the value for one or more of the following options:

Size Specifies how much the size of brush marks varies in a stroke. Options include Off, Pen Pressure, Pen Tilt, and

Stylus Wheel.

Minimum Size Specifies a range between 1%-100%. This option is available only when Off is not chosen from the

Size menu.

Angle Specifies how much the angle of brush marks varies in a stroke. Options include Pen Pressure, Pen Tilt, and

Stylus Wheel.

Roundness Specifies how much the roundness of brush marks varies in a stroke. Options include Off, Pen Pressure,

Pen Tilt, and Stylus Wheel.

Opacity Specifies how much the opacity of brush marks varies in a stroke. Options include Off, Pen Pressure, Pen

Tilt, and Stylus Wheel.
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Flow Specifies how much the flow of brush marks varies in a stroke. Options include Off, Pen Pressure, Pen Tilt, and

Stylus Wheel.

Creating and managing preset brush tips
You can customize an existing brush tip and save it as a preset brush tip. You can create custom brush tips, rename

preset brush tips, and delete preset brush tips.

New preset brushes are saved in a preferences file so that they persist between editing sessions.

To create a new preset brush tip

1 In the Brush Tips panel, specify the desired settings.

2 Choose New Brush from the Brush Tips panel menu or click the Save Current Settings As New Brush icon .

3 Type a name for the brush tip in Choose Name, and click OK.

To rename a preset brush tip

1 In the Brush Tips panel, select the brush tip you want to rename.

2 Choose Rename Brush from the panel menu.

3 Type a name for the brush tip in Choose Name, and click OK.

To delete a preset brush tip

1 In the Brush Tips panel, select the brush tip you want to delete.

2 Choose Delete Brush from the panel menu, or click the Delete Brush icon .

3 Click OK to delete the brush tip.

To return to default preset brush tips

❖ Choose Reset Brush Tips from the Brush Tips panel menu, and then click OK.

Note: To save the custom brushes you created, click Append when the dialog box prompts you to replace current brush

tips with the default brush tips.

Brush Tips panel display options

You can choose a display option from the Brush Tips panel menu.

Text Only View a list of brushes

Small Thumbnail View large thumbnails of brushes.

Large Thumbnail View large thumbnails of brushes.

Small List View a list of brushes with small thumbnails.

Large List View a list of brushes with large thumbnails.
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To customize brush tip shape properties
A brush stroke is made up of many individual brush tip marks. The brush tip you select determines the shape,

diameter, and other properties of a brush mark. You can customize brush tips by changing the brush tip properties.

Any changes you make to an existing brush tip can be saved as a new brush tip; the default set of brush tips remains

unaltered.

1 In the Brush Tips panel, select the brush tip you want to customize.

2 To change the value for a brush tip property, do one of the following:

• Type a value and press Enter (Windows) or Return (Mac OS).

• Place the pointer over the value and drag a new value.

• Ctrl-drag (Windows) or Command-drag (Mac OS) the brush in the Layer panel to adjust diameter; release the

key, and continue to drag to adjust hardness. Both the cursor and Brush Tips panel update dynamically.

Diameter Controls the size of the brush. Enter a value in pixels or drag a new value.

Strokes with low diameter values (left) and high diameter values (right)

Angle Specifies the angle by which an elliptical brush’s long axis is rotated from horizontal. Enter a value in degrees

or drag a new value.

Note: Brush tip angles can be expressed in both positive and negative values. For example, a brush tip with a 45º angle

is equivalent to a brush tip with a -135º angle.

Angled brushes create chiseled strokes: 45-degree brush (left), and -45-degree brush (right).

Roundness Specifies the ratio between the brush’s short and long axes. A value of 100% indicates a circular brush, a

value of 0% indicates a linear brush, and intermediate values indicate elliptical brushes.

Brush strokes using 100-percent roundness (left) and varying percentages (right)
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Hardness Controls the brush stroke’s transition from 100% opaque at the center to 100% transparent at the edges.

Even with high hardness settings, only the center is fully opaque. Enter a percentage value or drag a new value.

Hardness settings at 100-percent (left) and 0-percent hardness (right)

Spacing Controls the distance between the brush tip marks in a stroke. The value is a percentage of the brush

diameter. When this option is deselected, the speed of the cursor determines the spacing.

Decrease spacing for continuous lines (left); increase spacing for dashed brush strokes (right).

Paint strokes

About paint strokes
Each time that you drag in an image with the Brush, Clone Stamp, or Eraser tool and create a paint stroke, After

Effects creates a separate paint item and duration bar in the Timeline panel. You can then use the Timeline panel to

change the stroke’s position in time and to animate each paint stroke’s shape, stroke options, and transform

properties.

Note: Eraser strokes made with the Last Stroke Only option can’t be animated and permanently erase the targeted paint

stroke.

You can change a stroke’s position in time by adjusting values in the Timeline panel’s In, Out, and Duration columns,

in addition to dragging the stroke’s duration bar. In addition, you can nudge a paint stroke’s position, rotation, or

scale with the same keyboard commands that you use for nudging a layer.

See also

“Keyboard shortcuts” on page 642

Working with paint strokes in the Timeline panel
Once you have applied a paint stroke to a layer, you can modify the way the stroke interacts with the layer and the

composition by adjusting the blending mode, stroke properties, and transform properties in the Timeline panel.

Note: To move a paint stroke, change its Position property values.
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Each paint stroke is labeled numerically in the Effects section of the Timeline panel and is named for the tool that

created it. For example, brush strokes are named as Brush 1, Brush 2; Clone Stamp strokes are named as Clone 1,

Clone 2.

To view paint strokes, select the layer in the Timeline panel, and press the P key twice.

Each paint stroke has a separate duration bar in the Timeline panel, similar to a layer’s duration bar. The initial length

of the duration bar is determined by the Duration option you choose in the Paint panel. Paint strokes behave like

layers: You can drag the In or Out point of the duration bar to change the stroke’s duration and shift the stroke up or

down to change its position relative to other strokes. You can hide a paint stroke from view by clicking the eye

icon  next to the stroke.

Note: Select any keyframes for a paint stroke before you move or alter the paint stroke’s duration bar.

You can move a paint stroke’s location in the Timeline panel by dragging its duration bar to another time in the

Timeline panel. To change the order of an overlapping stroke, drag the stroke up or down in the Timeline panel.

While you can’t edit a stroke’s shape, you can change its shape by copying and pasting a mask to a selected stroke in

the Timeline panel.

Each stroke is numbered and includes individual Stroke Options and Transform properties in the Effects section of the Timeline panel.

See also

“To specify paint tool options” on page 313

To select paint strokes
Use the Selection tool to select strokes in either the Timeline panel or the Layer panel. When you select a paint stroke,

it appears in the Layer panel with an anchor point at the start of the stroke and a black line running the length of the

stroke.

• To select a paint stroke, click the paint stroke in the Layer panel or select the paint stroke in the Paint section of

the Timeline panel.

• To select a contiguous range of paint strokes in the Timeline panel, Shift-click the first stroke and last stroke in the

range.

• To select multiple paint strokes in the Layer panel, drag using the Selection tool to draw a bounding box that

surrounds the paint strokes.

• To select non-contiguous paint strokes, hold down the Ctrl key (Windows) or Command key (Mac OS).

Note: To deselect a paint stroke, in the Timeline panel or the Layer panel, click anywhere but the paint stroke.
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To specify a blending mode for a paint stroke
You can apply blending modes to a paint stroke after it has been applied to a layer.

1 In the Timeline panel, click the triangle to the left of the layer to expand the Paint section.

2 Click Normal in the Switches column next to the paint stroke to open the Blending Modes menu, and then choose

a blending mode.

Blending modes for paint strokes
Normal Paints each pixel to make it the result color. This is the default mode.

Dissolve Paints each pixel to make it the result color. However, the result color is a random replacement of the pixels

with the underlying color or the blend color, depending on the opacity at any pixel location.

Darken Specifies an underlying or blend color—whichever is darker—as the result color. Pixels lighter than the

blend color are replaced, and pixels darker than the blend color don’t change.

Multiply Multiplies the underlying color by the blend color. The result color is always a darker color. Multiplying any

color with black produces black. Multiplying any color with white leaves the color unchanged. When you paint a

color other than black or white, successive strokes produce progressively darker colors. The result is similar to

drawing on the image with multiple markers.

Linear Burn Darkens the underlying color to reflect the blend color by decreasing the brightness. Painting with white

produces no change.

Color Burn Darkens the underlying color to reflect the blend color by increasing the contrast. Painting with white

produces no change.

Add Combines the color values of the underlying and blend colors to produce the result color. The result color is

lighter than the original colors. Painting with black produces no change. Painting any color onto an underlying color

of white also produces no change.

Lighten Selects the underlying or blend color—whichever is lighter—as the result color. Pixels darker than the blend

color are replaced, and pixels lighter than the blend color do not change.

Screen Multiplies the inverse of the blend and underlying colors. The result color is always a lighter color. Painting

with a black screen leaves the color unchanged. Painting with a white screen produces white. The result is similar to

projecting multiple photographic slides on top of each other.

Linear Dodge Brightens the underlying color to reflect the blend color by increasing the brightness. Painting with

black produces no change.

Color Dodge Brightens the underlying color to reflect the blend color by decreasing the contrast. Painting with black

produces no change.

Overlay Multiplies or screens the colors, depending on the underlying color. Patterns or colors overlay the existing

pixels while preserving the highlights and shadows of the underlying color. The underlying color is not replaced but

is mixed with the blend color to reflect the lightness or darkness of the original color.

Soft Light Darkens or lightens the colors, depending on the blend color. The result is similar to shining a diffused

spotlight on the image. If the blend color (light source) is lighter than 50% gray, the underlying color is lightened as

if it were dodged. If the blend color is darker than 50% gray, the underlying color is darkened as if it were burned in.

Painting with pure black or white produces a distinctly darker or lighter area but does not result in pure black or

white.

Hard Light Multiplies or screens the colors, depending on the blend color. The result is similar to shining a harsh

spotlight on the image. If the blend color (light source) is lighter than 50% gray, the underlying color is lightened, as
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if it were screened. This is useful for adding highlights to an image. If the blend color is darker than 50% gray, the

underlying color is darkened, as if it were multiplied. This is useful for adding shadows to an image. Painting with

pure black or white results in pure black or white.

Linear Light Burns or dodges the colors by decreasing or increasing the brightness, depending on the blend color. If

the blend color (light source) is lighter than 50% gray, the underlying color is lightened by increasing the brightness.

If the blend color is darker than 50% gray, the underlying color is darkened by decreasing the brightness.

Vivid Light Burns or dodges the colors by increasing or decreasing the contrast, depending on the blend color. If the

blend color (light source) is lighter than 50% gray, the underlying color is lightened by decreasing the contrast. If the

blend color is darker than 50% gray, the underlying color is darkened by increasing the contrast.

Pin Light Replaces the colors, depending on the blend color. If the blend color (light source) is lighter than 50% gray,

pixels darker than the blend color are replaced, and pixels lighter than the blend color do not change. If the blend

color is darker than 50% gray, pixels lighter than the blend color are replaced, and pixels darker than the blend color

do not change. This is useful for adding special effects to an image.

Hard Mix Enhances the contrast of the underlying layer through the use of a mask on the source layer. The mask size

determines the contrasted area; the inverted source layer determines the center of the contrasted area.

Difference Looks at the color information in each channel and subtracts either the blend color from the underlying

color or the underlying color from the blend color, depending on which has the greater brightness value. Painting

with white inverts the underlying color values; painting with black produces no change.

Exclusion Creates a result similar to but lower in contrast than the Difference mode. Painting with white inverts the

underlying color values. Painting with black produces no change.

Hue Creates a result color with the luminance and saturation of the underlying color and the hue of the blend color.

Saturation Creates a result color with the luminance and hue of the underlying color and the saturation of the blend

color. Painting with this mode in an area with no saturation (gray) causes no change.

Color Creates a result color with the luminance of the underlying color and the hue and saturation of the blend color.

This preserves the gray levels in the image and is useful for coloring monochrome images and for tinting color

images.

Luminosity Creates a result color with the hue and saturation of the underlying color and the luminance of the blend

color. This mode creates an inverse result from that of the Color mode.

Silhouette Luma Creates transparency in painted areas of the layer, allowing you to see underlying layers or

background. The luminance value of the blend color determines opacity in the result color. Painting with pure white

creates 0% opacity. Painting with pure black produces no change.

To specify transform properties for a paint stroke
You can specify transform properties of a paint stroke in the Timeline panel to set its position, scale, opacity, and

angle of rotation. Transform properties alter the paint stroke using the paint stroke’s anchor point as its center.

1 Click the triangle next to Effects to expand the effects properties for the layer.

2 Click the triangle next to Paint to expand the Paint properties for the layer.

3 Click the triangle next to the paint stroke (for example, Brush 1) to expand the stroke properties.

4 Click the triangle next to Transform to expand the Transform properties.

5 Specify the Anchor Point, Position, Scale, Rotation, or Opacity property by dragging or entering values.
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To enable Paint On Transparent
You can hide or display the layer that you paint on by enabling the Paint On Transparent option. You can enable the

Paint On Transparent option in the Timeline panel or Effect Controls panel. When you enable this option, paint

strokes appear on a transparent background instead of on the source layer.

1 Select the layer to which paint is applied in the Timeline panel.

2 Choose Effect > Paint > Paint.

3 Select Paint On Transparent.

You can specify all of the options listed in the Paint panel and the Brush Tips panel in the Timeline panel. Paint On

Transparent is also available in the Effect Controls panel.

See also

“To specify paint tool options” on page 313

Animating paint strokes
You can animate a paint stroke by setting keyframes for paint stroke properties. After Effects animates paint strokes

automatically when you choose Write On from the Duration menu in the Paint panel or when you replace paint

strokes (referred to as stroke targeting) in the Timeline panel. The time you take to apply the stroke determines the

stroke’s duration; the speed of your movements determines the speed of the stroke.

Note: When you change the shape of an animated paint stroke, After Effects alters the speed of the paint stroke with the

new shape such that the animation is smooth. If the speed of the original stroke was constant, the speed of the stroke with

the new shape will also be constant.

See also

“About animation and layer properties” on page 188

“Using keyframes” on page 192

To animate a paint stroke automatically

1 Open a layer and select a paint tool in the Tools panel.

2 In the Paint panel, choose Write On from the Duration menu.

3 Apply a paint stroke to the layer. As you paint, your movements are recorded in real time and determine the

duration and velocity of the resulting stroke.

4 In the Timeline panel, open the layer to view the paint stroke in the Stroke Options section. Two keyframes appear

in the End parameter.

5 Drag the second keyframe to the frame where you want the complete stroke to appear. The stroke begins on the

frame indicated by the first keyframe.

You can reverse the order of the animation by cutting and pasting the first keyframe in the Timeline panel to a later

time than the ending keyframe.

See also

“Using keyframes” on page 192
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To animate a paint stroke by stroke targeting

1 Open a layer and select a paint tool in the Tools panel.

2 In the Paint panel, choose Single Frame, Constant, or Custom from the Duration menu.

3 In the Layer panel, drag in the layer to create a paint stroke.

4 In the Timeline panel, click the triangles next to the layer in the Strokes section and in the Paint section to view

the stroke.

5 Do one of the following:

• Click the stopwatch for Shape to create a keyframe.

• Click the stopwatch for any other Brush properties that you want to animate.

6 Drag the current-time indicator to a new location in the Timeline panel.

7 While the stroke is still selected, drag in the layer to create a new paint stroke. A second keyframe appears in the

Timeline panel for each animated property.

When you render the work area, After Effects interpolates brush shape and other animated properties for all frames

between the two keyframes.

After Effects interpolates a paint stroke (center) between two different strokes created with the same brush (left and right).

See also

“Using keyframes” on page 192

Selecting colors

To select a color with the Eyedropper tool
1 Click the Eyedropper button, and move the pointer to the pixel that you want to sample. The color swatch next to

the Eyedropper button dynamically changes to the color under the Eyedropper.

2 Do one of the following:

• To select the color of a single pixel, click the pixel.

• To sample the color average of a 3-by-3-pixel area, Ctrl-click (Windows) or Command-click (Mac OS) the area.

Press the Escape key to deselect the Eyedropper.

To select a color with the Color Picker
1 Click the Foreground Color or Background Color swatch to display the Color Picker.
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2 Select the component you want to use to display the color spectrum:

H Displays all hues in the color slider. Selecting a hue in the color slider displays the saturation and brightness range

of the selected hue in the color spectrum, with the saturation increasing from left to right and brightness increasing

from bottom to top.

S Displays all hues in the color spectrum with their maximum brightness at the top of the color spectrum,

decreasing to their minimum at the bottom. The color slider displays the color that’s selected in the color spectrum

with its maximum saturation at the top of the slider and its minimum saturation at the bottom.

B (in the HSB section) Displays all hues in the color spectrum with their maximum saturation at the top of the color

spectrum, decreasing to their minimum saturation at the bottom. The color slider displays the color that’s selected

in the color spectrum with its maximum brightness at the top of the slider and its minimum brightness at the bottom.

R Displays the red color component in the color slider with its maximum brightness at the top of the slider and its

minimum brightness at the bottom. When the color slider is set to minimum brightness, the color spectrum displays

colors created by the green and blue color components. Using the color slider to increase the red brightness mixes

more red into the colors displayed in the color spectrum.

G Displays the green color component in the color slider with its maximum brightness at the top of the slider and

its minimum brightness at the bottom. When the color slider is set to minimum brightness, the color spectrum

displays colors created by the red and blue color components. Using the color slider to increase the green brightness

mixes more green into the colors displayed in the color spectrum.

B (in the RGB section) Displays the blue color component in the color slider with its maximum brightness at the top

of the slider and its minimum brightness at the bottom. When the color slider is set to minimum brightness, the color

spectrum displays colors created by the green and red color components. Using the color slider to increase the blue

brightness mixes more blue into the colors displayed in the color spectrum.

3 Do any of the following:

• Drag the triangles along the color slider, or click inside the color slider to adjust the colors displayed in the color

spectrum.

• Click or drag inside the large square color spectrum to select a color. A circular marker indicates the color's

position in the color spectrum.

Note: As you adjust the color using the color slider and color spectrum, the numeric values change to indicate the new

color. The top rectangle to the right of the color slider displays the new color; the bottom rectangle displays the original

color.

• For HSB, specify hue (H) as an angle, from 0˚ to 360˚, that corresponds to a location on the color wheel. Specify

saturation (S) and brightness (B) as percentages (0 to 100).

• For RGB, specify component values.

• For #, enter a color value in hexadecimal form.
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Chapter 15: Motion tracking (Pro only)

Motion tracking overview (Pro only)

Uses of motion tracking (Pro only)
Using conventional editing techniques, it is difficult and time-consuming to synchronize visual effects or other

images with moving footage. The motion tracking features of After Effects let you easily create composites and

dynamic visual effects regardless of whether the subjects or the camera (or both) are moving. After Effects can follow

or track the movement of a specified area in a shot and then apply that movement to an effect, image, or other

footage. The resulting visual effect precisely matches the original moving footage.

You can track the scale of a feature, view and edit the tracker’s motion path, restrict a motion target and the feature

region to horizontal or vertical movement, or make After Effects perform a specified action automatically based on

the tracking accuracy.

Motion tracking has many uses:

• Combining elements filmed separately, such as adding video footage to the side of a moving city bus or a star to

the end of a sweeping wand.

• Animating a still image to match the motion of action footage, such as making a cartoon bumblebee pursue a

swaying flower.

• Adding effects that follow a moving element, such as applying a lens flare to a scene where the camera pans or

making a ball glow.

• Applying effects or transform properties to a layer using tracking data in expressions, such as stretching a wire coil

between two objects.

• Stabilizing footage, such as smoothing the wobble of footage shot with a handheld camera.

Depending on the encoder you use, it is possible to decrease the size of your final output file by stabilizing motion

footage. Random motion, such as from the jostling of a handheld camera, can make it difficult for many compression

algorithms to compress your video.

See also

“About expressions” on page 555

About motion tracking (Pro only)
After Effects tracks motion by matching subpixels from a selected area in a frame to subpixels in each succeeding

frame. You specify the area to track by using the track point. The track point contains a feature region, a search region,

and an attach point. After Effects displays the track point during tracking in the Layer panel.
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Layer panel with track point
A. Search region B. Feature region C. Attach point

Feature region The feature region defines the area in the moving footage to be tracked. It should surround a distinct

feature. After Effects must be able to clearly identify the feature throughout the footage, despite changes in light,

background, and angle.

Search region The search region limits the area that After Effects must search to locate the feature. The feature needs

to stand out only within the boundary of the search region, not within the entire frame. Confining the search to a

small region saves search time and makes the search process easier, but runs the risk of the feature leaving the search

region entirely between frames.

Attach point The attach point designates the place of attachment for the target footage—the layer, image, or effect

that you want to synchronize with the motion footage.

You set up, initiate, and apply motion tracking with the Tracker Controls panel. The Tracker Controls panel lets you

track a feature’s scale, turn feature magnification on or off, choose different actions based on the tracking accuracy,

and show or hide tracked motion paths. You can set up a tracker and its track type before defining a motion target.

To open the Tracker Controls panel, choose Window > Tracker Controls.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

Motion tracking workflow (Pro only)

1. Setting up the shot

The key to good tracking is finding a good feature to track, as well as sizing the search region adequately so that After

Effects can easily locate the feature.

A B C
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For best results, first prepare the object or region you are tracking before you begin filming. Because After Effects

compares pixels from one frame to the next to produce an accurate track, attaching high-contrast markers to the

object or region lets After Effects more easily follow the motion from frame to frame. Lightweight, brightly colored

balls, such as ping-pong balls, placed on the feature work particularly well to preserve the shape of the track point.

The number of markers you use corresponds to the number of points you are tracking. For example, if you’re

tracking four points using the Perspective Corner Pinning option, you need at least four features, to correspond with

the four corners of the layer you want to attach to your filmed footage. The more markers you add to your subject

before shooting, the more features you’ll have for tracking later.

2. Searching your footage

Before you begin tracking, it is important to view the entire shot to determine the best feature to track. What is clearly

identifiable in the first frame may later blend into the background because the angle, lighting, or surrounding

elements have changed. A feature may disappear offscreen or be obscured by another element at some point in the

scene. While After Effects can extrapolate the motion of disappearing items, your chances for a successful track are

higher if you step through the entire shot and select the best candidates for tracking.

3. Selecting a good feature region

You need to locate and size the feature region carefully. For the smoothest tracking, the feature you select should meet

the following criteria:

• Visible for the entire shot

• A contrasting color from the surrounding area

• A distinct shape (at least within the search region)

• A consistent shape and color throughout the shot

Because of the changing nature of an image in motion, digital tracking is rarely perfect. In moving footage, the shape

of an image inevitably changes, along with the lighting and surrounding objects. Even with careful preparation, a

feature generally evolves during a shot and at some point no longer matches the original feature. If the change is too

great, After Effects may not be able to track the feature, and the track point will appear to wander or drift.

It can take time to develop an eye for good features to track. Because of the many variables interacting in moving

footage, regardless of your experience, you often need to make adjustments and track again. After Effects includes

several options to help improve your success in tracking. For example, you can track using different aspects of color

(RGB, luminance, or saturation), change the adaptiveness of the feature (allowing the feature region to change along

with the footage), or have After Effects extrapolate or estimate motion if necessary. You can track the layer as many

times as needed and then apply the best tracking results.

4. Adjusting the search region

The size and position of the search region depends on the movement of the feature you want to track. The search

region must accommodate the movement of the feature, but only the frame-to-frame movement, not its movement

throughout the shot. As After Effects locates the feature in a frame, both the feature and search regions move to the

new location. Therefore, if the frame-to-frame movement is gradual, the search region needs to be only slightly larger

than the feature region. If the feature changes position and direction quickly, the search region needs to be big

enough to encompass the largest position and direction change in any pair of frames.
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Feature and search region moving through footage

5. Using rotation track points

In addition to tracking the position of a feature, you can also track its rotation. You can apply rotation values to

another layer or to stabilize the same layer. When you select the Rotation option, After Effects displays two feature

and search regions. A line connects the two attach points that lie at the center of each feature region. An arrow points

from the first attach point to the second.

If possible, both feature regions should be on the same object, or at least they should both be on objects that are the

same distance from the camera. The first feature region (on the left by default) represents the base of the tracking.

The farther apart the regions, the more accurate the calculations and the better the result.

Layer panel showing the feature region and search region for tracking rotation with two track points

After Effects calculates rotation by measuring the change of angle between the first and second attach point from

one frame to the next.When you apply the tracking data to the target, After Effects creates rotation keyframes.

6. Positioning the attach point

The placement of the attach point determines the placement of your target footage, image, or effect control point.

The default position is in the center of the feature region. You can move the attach point as necessary. While most

times you’ll want your target to be centered exactly on the feature region, there may be times when you need to offset

the target from the source of the movement or times when the point of attachment is not the best feature to track.
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For example, if you wanted to animate a flying saucer hovering over an undercover spy, you would position the

feature region on a small, distinct area on the spy. If you left the attach point centered in the feature region, the saucer

would be attached to that point (and would appear to have already landed on the spy). However, if you wanted the

saucer to appear to be in pursuit, you would move the attach point out of the feature region to be somewhat above

and behind the spy.

Attach point centered in feature region

Attach point offset from feature region

Adjust a tracker’s Attach Point Offset property in the Timeline panel to move the attach point in the Layer panel. The

offset can be particularly useful when using corner pinning on footage in which the feature and the desired location

of the attach point are moving relative to one another.

See also

“About animation and layer properties” on page 188

Types of tracking (Pro only)
When setting up motion tracking, you can choose from one of five different tracking types in the Track Type menu

in the Tracker Controls panel, depending on what you want to track.

When you choose Stabilize Motion, the default tracking type is Stabilize. When you choose Track Motion, the default

tracking type is Transform if the composition contains multiple layers, or Raw if the composition contains a single

layer.

Transform Tracks position and/or rotation to apply to another layer. When tracking position, this option creates one

track point and generates position keyframes. When tracking rotation, this option creates two track points and

produces rotation keyframes.
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Stabilize Tracks position and/or rotation to stabilize jerky camera movement or to fix drift of the subject from its

mark. When tracking position, this option creates one track point and generates anchor point keyframes. When

tracking rotation, this option creates two track points and produces rotation keyframes.

Parallel Corner Pin Tracks skew and rotation, but not perspective, using three corner points. Parallel lines remain

parallel, and relative distances are preserved. This option creates three track points (calculating the position of the

fourth) and generates corner point keyframes. The three attach points mark the placement of the three corner points.

Perspective Corner Pin Tracks perspective changes in source footage using four corner points. This option creates

four track points and generates corner-point keyframes. The four attach points mark the placement of the corner

points.

Raw Tracks position. Use this option if the motion target is not available or if you want to apply the tracking data to

it at a later time. All tracking data is stored on the motion source layer within the project. The Edit Target button and

the Apply button are not available with this tracking option. You can also use this option to create tracking data to

use with expressions. This option displays one track point, but you can add others by using the New Track Point

option from the panel options menu.

See also

“About animation and layer properties” on page 188

Motion tracking properties in the Timeline panel (Pro only)
Once you have tracked a feature, After Effects stores the tracking data with the layer in a track. You can display this

information by selecting Reveal Current Track In Timeline from the Options menu in the Tracker Controls panel or

by expanding the layer to view the Motion Trackers section in the Timeline panel. You can apply the same tracking

data to different footage or effects. You can also track multiple features in the same footage. After Effects automati-

cally creates a new track each time you choose a tracking option from the Animation menu. Tracks are named

Tracker 1, Tracker 2, and so on. You can rename tracks to help identify them. You can also select tracks and track

points and modify their numeric values.

When you track motion, After Effects adds the following properties to the motion source in the Timeline panel:

Tracker [number] Specifies a track and all track points associated with the track. For example, Perspective Corner

Pinning tracks would list four track points.

Track Point [number] Specifies a feature region, search region, and attach point used in the track.

Feature Center Specifies Position property values for the center of the feature region.

Feature Size Specifies the area of the feature region in pixels.

Search Offset Specifies the distance between the feature region and the search region.

Search Size Specifies the area of the search region in pixels.

Confidence Specifies that accuracy with which the analyzed pixels match those specified by the search parameters.

Attach Point Offset Specifies the distance between the center of the feature region and the attach point.

Attach Point Specifies the position at which a target layer or effect is animated or attached to the motion source layer.
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Motion Trackers properties in the Timeline panel

See also

“About animation and layer properties” on page 188

Tracker Controls panel (Pro only)

Source, Current Track, and Target controls (Pro only)
You use the Tracker Controls panel to control all types of motion tracking and stabilization. In this panel, you specify

your motion source layer and motion target layer, choose the type of tracking you want to use, and set special

tracking options. Once you have set all your parameters, you initiate tracking with the Analyze buttons and apply the

tracking data with the Apply button.

Tracker Controls panel
A. Controls to create a new track, set the motion source and target B. Controls to set the type of tracking C. Controls to initiate, apply, and
delete tracks

In the Tracker Controls panel, you control which layer you want to track, which tracking data you want to use, and

the layer or effect to which you want to apply tracking.

Motion Source Specifies the layer that contains the motion you want to track. The menu lists all the moving footage

layers in the current composition. If you selected a motion source or an effect point control of a layer before you

opened the Tracker Controls panel, After Effects displays that layer for Motion Source.

Current Track Displays the track for the source layer that contains the tracking data. Every layer can have multiple

tracks associated with it, allowing you to track more than one feature in a layer or to track the same layer using

different settings.

Motion Target Specifies the footage, still image, or effect that you want to animate. When selected, the tracker

applies the tracked keyframes to the specified motion target layer to either animate or stabilize it. Change the target

C
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by clicking Edit Target and choosing a new target from the Layer pop-up menu in the Motion Target dialog box. The

Edit Target button is not available if Raw is selected for Track Type.

Options Opens the Motion Tracker Options dialog box, through which you can improve the accuracy of tracking

and select third-party tracker plug-ins.

Analyze, Reset, and Apply controls (Pro only)
You use the Analyze, Reset, and Apply controls only when you are ready to begin tracking. The Analyze controls

initiate tracking, while the Reset and Apply controls either delete the tracking data or apply it to the target layer.

Analyze Begins the frame-to-frame analysis of the track point in the source footage. Use the following controls for

Analyze: Step Back to analyze the current frame by stepping back to the previous frame. Analyze Backward

to analyze from the current-time indicator backward to the beginning of the work area or footage. Analyze

Forward to analyze from the current-time indicator to the end of the work area or footage. Step Forward to

analyze the current frame by advancing to the next frame.

Note: The Analyze Backward and Analyze Forward buttons change to a Stop button while analysis is in progress.

Reset Restores the feature region, search region, and attach point to their default positions and deletes the tracking

data from the currently selected track. Tracker Control settings and keyframes already applied to the target layer

remain unchanged.

Apply Sends the tracking data (in the form of keyframes) to the target layer or effect control point.

Tracker Controls (Pro only)
Track Name Indicates the track selected in the Current Track menu in the Tracker Controls panel.

Tracker Plug-in Sets the tracker plug-in used to calculate the tracking data for this track. By default, this option

displays Built-in, the only tracker plug-in included with After Effects.

Channel Specifies the comparison method to use for tracking. RGB compares the RGB values in the feature region;

select if the feature is a distinct color. Luminance compares the brightness value in the feature region; select

Luminance if the feature has high contrast, or brightness, compared to the surrounding objects and background

(such as a burning candle carried through a room). Saturation compares the density of color in the tracking region;

select Saturation if the feature has a high concentration of color, surrounded by variations of the same color (such as

a bright red scarf against a brick wall).

Process Before Match Temporarily blurs or sharpens an image to improve tracking. Blur reduces noise in the

footage. Usually a value of 2 to 3 pixels is enough to produce better tracks in grainy or noisy footage. Enhance

exaggerates or refines the edges of an image and makes them easier to track.

Note: After Effects blurs or enhances the footage only for tracking, restoring it to its original state after tracking.

Track Fields Tracks the motion in both video fields of interlaced video and doubles the frame rate to ensure that both

video fields are tracked.

Subpixel Positioning Specifies fractional position keyframes to match the specified feature region. When deselected,

the tracker rounds off position keyframes to the nearest pixel.

Adapt Feature On Every Frame Causes After Effects to adapt the feature region during tracking to better assist in

tracking the feature in subsequent frames.

If Confidence Is Below Makes the tracking perform a chosen action (stop, continue, adapt, or extrapolate motion)

when the confidence (accuracy) value falls below a specified threshold.
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Options Displays the Tracker Plug-in Options dialog box, which includes options for the AE Original Built-in

Tracker. This command is only available if you choose to use the older After Effects tracker plug-in.

Note: When you begin tracking, After Effects sets the quality of the motion source layer to Best and the resolution to

100% to improve the image quality and make the selected feature region easier to find.

Tracking motion (Pro only)

To track motion and apply it to another layer (Pro only)
One of the most common uses of motion tracking is to create composites with other footage or images. Motion

tracking lets you combine elements filmed separately or animate still images so that they appear to have been shot

together.

1 Select the layer you want to track in the Timeline panel.

Note: The selected layer must include motion or changing frames, such as video source footage for Track Motion to be

available in the Animation menu. If you want to track motion in still images or a sequence, first pre-compose the layer

by choosing Layer > Pre-compose.

2 Choose Animation > Track Motion or click Track Motion in the Tracker Controls panel. After Effects then

performs the following actions:

• Displays the Tracker Controls panel with the selected layer listed for Motion Source.

• Creates a new track and displays its name in the Tracker Controls panel for the Current Track.

• Displays Transform for Track Type (or Raw, if you haven’t added the target footage to the composition yet).

• Adds a track point for the motion source in the Layer panel.

• Adds the new track to the Motion Trackers section of the motion source layer in the Timeline panel.

3 Click Edit Target in the Tracker Controls panel, and choose the Motion Target layer from the Layer pop-up menu.

4 Select Position or Rotation as appropriate.

5 If you want to track a range of frames, define the work area you want to track in the Layer panel for the source

footage.

6 In the Layer panel, move the current-time indicator to the frame from which tracking should begin.

7 Using the Selection tool, position and resize the feature and search regions over the feature you want to track.

Note: The search region needs to be only big enough to accommodate the frame-to-frame position change of the feature.

8 Drag the attach point where you want After Effects to position the footage.

9 In the Tracker Controls panel, click either the Forward Analyze or Backward Analyze button to begin tracking.

Watch the tracking to make sure that it is accurate. If not, click the stop button to stop tracking, and then correct the

problem as described in “Correcting a drifting feature region (Pro only)” on page 346.

10 When you are satisfied with the position of the feature region and attach point throughout the footage, click the

Apply button to apply the motion to the specified target layer. If you are tracking position, you can choose to

constrain motion to the x axis or the y axis. After Effects creates keyframes for the target layer.

See also

“To set a work area” on page 121
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Adding new track points (Pro only)
To use tracking data with expressions, you may want to track additional features. You can add track points by

choosing New Track Point from the panel options menu. Each new point tracks position only. You cannot apply the

additional tracking data directly to a target layer, but you can refer to the data in expressions. As with any tracking

data, it is stored with the motion source in a track and appears as keyframes in the Timeline panel. You generally

select the Raw tracking type if you plan to add track points and later use the data in expressions.

See also

“About expressions” on page 555

To move or resize the track point (Pro only)
In setting up motion tracking, it’s often necessary to refine your track point by adjusting the feature region, search

region, and attach point. You can resize or move these items independently or in groups by dragging with the

Selection tool, whose pointer icon changes to reflect one of many different activities. To help you define the area to

be tracked, the image area within the feature region is magnified to 400% while you move the region.

To zoom into or out of the feature region in a Layer panel, push your mouse wheel forward or backward.

Track point components (left) and Selection tool pointer icons (right)
A. Search region B. Feature region C. Keyframe marker D. Attach point E. Moves search region F. Moves both regions G. Moves entire track
point H. Moves attach point I. Moves entire track point J. Resizes region

Note: Before you move or resize the regions, or move the attach point, always make sure that your work area defines the

frames you want to track and that the current-time indicator is at the first frame.

• To turn on or off feature region magnification, choose Magnify Feature When Dragging from the Tracker

Controls panel menu. A check mark appears next to the option when it’s on.

• To move the feature region, search region, and attach point together, using the Selection tool, drag inside the track

point area (avoiding the region edges and the attach point); the Move Track Point pointer  appears.

• To move just the feature and search regions together, drag the edge of the feature region with the Selection tool;

and then Move Both Regions pointer  appears.

• To move just the feature and search regions together, Alt-drag (Windows) or Option-drag (Mac OS) with the

Selection tool inside the feature or search region; the Move Both Regions pointer  appears.

• To move only the search region, using the Selection tool, drag the edge of the search region; the Move Search

Region pointer  appears.

• To move only the attach point, using the Selection tool, drag the attach point; the Move Attach Point pointer

appears.
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• To resize the feature or search region, drag a corner handle.

• To make all of the region’s sides match the length of the longest side and to resize the region relative to the original

region’s center point, Shift-drag a corner handle.

• To make all of the region’s sides match the length of the longest side and to resize the region relative to a particular

corner handle, Shift+Ctrl-drag (Windows) or Shift+Command-drag (Mac (OS) the opposite corner handle.

See also

“To set a work area” on page 121

Restricting the movement of a motion target (Pro only)
When you track motion in a layer, After Effects creates a motion path for you to apply to a motion target, which can

be another layer, an effect, or the same layer. You can make the motion target follow only the x (horizontal) or y

(vertical) coordinates of the motion path, and you can also restrict the motion path to either plane. Restricting the

movement of a motion target can be useful in certain situations; for example, to make a speech bubble (the motion

target) remain at the top of the frame even when the actor’s head (the motion source) moves downward.

To restrict the movement of the motion target (Pro only)

1 Set up your track point.

2 Define the motion target, and then track the motion path. Adjust the tracking as needed until you’re satisfied with

the motion path.

3 To apply the motion path to the motion target, click Apply in the Tracker Controls panel, and choose one of the

following in the Motion Tracker Apply Options dialog box:

X Only Restricts the motion target to horizontal movement.

Y Only Restricts the motion target to vertical movement.

X And Y Enables the motion target to move across both the horizontal and vertical planes.

To bypass the Motion Tracker Apply Options dialog box and apply the last option you chose in it, hold down the Alt

(Windows) or Option (Mac OS) key when you click Apply in the Tracker Controls panel.

To restrict movement on a motion path (Pro only)

1 Do one of the following to set up your track point:

• To restrict the motion path to horizontal movement, resize the height of the search region to match the height of

the feature region.

• To restrict the motion path to vertical movement, resize the width of the search region to match the width of the

feature region.

2 Define the motion target, and then track the motion path.

To apply tracking data to a new target (Pro only)
Once you’ve tracked a motion source layer, you can apply that layer’s stored tracking data to other target layers. For

example, you can apply the track to a light bulb’s position and to the Lens Flare effect’s control point.

1 In the Tracker Controls panel, choose the tracked layer from the Motion Source menu.

2 Choose the track containing the tracking data you want from the Current Track menu.
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3 Click Edit Target to open the Motion Target dialog box, which lists all the layers in the composition (except the

motion source layer) as well as any point controls in effects applied to the motion source layer.

4 Select the layer or effect point control you want to animate, and click OK.

5 In the Tracker Controls panel, click the Apply button to apply the tracking data to the specified target. After Effects

creates keyframes for the target layer or effect.

To track scale (Pro only)
After Effects tracks scale much as it tracks rotation: Two track points are created with a line that connects the attach

point of each to the other; an arrow points from the first attach point (the base) to the second. After Effects calculates

scale by comparing the distance between attach points on each frame with the distance between the attach points on

the start frame.

If possible, you should place the feature regions on the same object, or at least they should both be on objects that

are the same distance from the camera. The farther apart the regions, the more accurate the calculations and the

better the result.

1 Select a tracker in the Timeline panel.

2 Select Scale in the Tracker Controls panel. A second track point is added and connected to the first (base) track

point. (If the tracker was already set up to track rotation, the Scale option uses the existing track points instead of

creating a new one.)

3 Adjust the track points in the Layer panel so that the line between their attach points lies along the length of the

feature you want to track.

4 Use the Analyze buttons in the Tracker Controls panel to begin tracking.

5 Click the Apply button to apply the motion path to the motion target. After Effects creates scale keyframes and

copies them to the motion target.

To animate effects with motion tracking (Pro only)
You can animate effects applied to the motion source so that they follow a specific feature precisely throughout a

shot. After Effects repositions the effect point using the position data it gathered when tracking. For example, you

can track the sun as it moves across the sky to animate a lens flare. When applying tracking data to an effect point,

the motion target must be an effect point control on the same layer as the motion source.

1 In the Timeline panel, select the effect point control you want to animate.

Note: The selected effect must be applied to the motion source layer, and the layer must include motion or changing

frames, such as video source footage.

2 Choose Animation > Track Effect Point Control. After Effects then performs the following actions:

• Displays the Tracker Controls panel with the current layer (the layer containing the effect) listed for Motion

Source and the effect point control you selected in step 1 for Motion Target.

• Creates a new track and displays its name for Current Track in the Tracker Controls panel.

• Displays Transform for Track Type.

• Adds the new track to the Motion Trackers section of the motion source layer in the Timeline.

• Creates a track point in the Layer panel for the motion source.

3 If you want to track a range of frames, define the work area you want to track in the Layer panel for the source

footage.
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4 In the Layer panel for the motion source, move the current-time indicator to the frame from which tracking

should begin.

5 Using the Selection tool, position and size the feature region so that it surrounds the feature you want to track.

Note: The search region needs to be only big enough to accommodate the frame-to-frame position change of the feature.

6 In the Tracker Controls panel, click either the Forward Analyze or Backward Analyze button to begin tracking.

Watch the tracking to make sure that it is accurate. If not, click the stop button to stop tracking, and then correct the

problem as described in “Correcting a drifting feature region (Pro only)” on page 346.

7 When you are satisfied with the position of the feature regions throughout the footage, click the Apply button to

apply the motion to the effect. After Effects creates keyframes and copies them to the effect point control.

See also

“Placing an effect using effect points” on page 353

To stabilize a layer with motion tracking (Pro only)
If you shoot with a handheld or airborne camera or bump a camera during shooting, you may want to stabilize

footage. Stabilizing smooths unwanted camera movement or unwanted drift (when a subject has drifted out of

position). To stabilize footage, After Effects first tracks the motion in the shot. It then shifts the position and rotation

of each frame as necessary to remove the movement. When played back, the motion appears smooth because the

layer itself moves incrementally to offset the unwanted motion.

Depending on the encoder you use, it is possible to decrease the size of your final output file by stabilizing motion

footage. Random motion, such as from the jostling of a handheld camera, can make it difficult for many compression

algorithms to compress your video.

As with tracking motion to apply that motion to a target, you need to define a feature and search region. However,

for stabilization, you want to select a feature that is stationary within the context of the frame rather than select a

feature that is moving relative to the frame. Tracking a stationary object ensures that you are stabilizing only

unwanted motion. The rules for selecting a good feature are the same for stabilizing and tracking: The feature should

be visible during the entire shot, be of a contrasting color from the surrounding area, have a distinct shape (at least

within the search region), and have a fairly consistent shape and color throughout the shot.

After Effects gives you two options for stabilizing: Position and Rotation. Together these options can compensate for

undesired camera movement in all directions. You generally want to stabilize footage with these options on.

However, in some circumstances you may need to turn one of them off. For example, if you are panning, you would

turn off the Position option but leave the Rotation option on.

1 In the Timeline panel, select the layer containing footage you want to stabilize.

Note: The selected layer must include motion or changing frames, such as video source footage, for Stabilize Motion to

be available in the Animation menu. If you want to track motion in still images or a sequence, first pre-compose the layer

by choosing Layer > Pre-compose.

2 Choose Animation > Stabilize Motion or click Stabilize Motion in the Tracker Controls panel. After Effects then

performs the following actions:

• Displays the Tracker Controls panel with the selected layer listed for Motion Source as well as Motion Target.

• Creates a new track and displays its name in the Tracker Controls panel for the Current Track.

• Displays Stabilize for Track Type.

• Adds the new track to the Motion Trackers section of the motion source layer in the Timeline.



ADOBE AFTER EFFECTS 7.0
User Guide

342

• Creates a track point for the motion source in the Layer panel for the motion source.

3 In the Tracker Controls panel, select Position or Rotation as appropriate. If you select Rotation, After Effects adds

an additional track point, connected by a line, in the Layer panel.

4 In the Layer panel, specify the work area you want to track. The position and rotation in subsequent frames are

adjusted relative to the first frame.

5 Using the Selection tool, position and size the feature and search regions.

Note: The search region needs to be only big enough to accommodate the frame-to-frame position change of the feature.

6 In the Tracker Controls panel, click the Forward Analyze button to begin tracking.

7 If the feature region (or regions) drifts away from the feature you want to track, adjust the size and position of the

feature and search regions as described in “Correcting a drifting feature region (Pro only)” on page 346.

8 When you are satisfied with the location of the feature region(s) throughout the footage, click Apply. After Effects

creates anchor point keyframes for the footage.

If the image creeps in from the margins of the action-safe zone, increase the scale just enough to extend past the

margins. Find the frame that creeps in the most, and then nudge the scale (in the Composition panel) using the Alt

+ [plus sign] and Alt + [minus sign] keys on the numeric keypad (Windows), or the Option + [plus sign] and Option +

[minus sign] keys on the numeric keypad (Mac OS). This technique adjusts the scale for the duration of the footage.

See also

“To set a work area” on page 121

“To view and use safe zones and grids” on page 142

To create and adjust the motion path for a feature region (Pro only)
After setting up a track point, you use the Analyze controls in the Tracker Controls panel to begin tracking motion

in a layer. The Analyze controls let you track forward or backward from just one frame to the next or through an

entire sequence of frames. After Effects displays the feature region’s motion path by marking an X in the Layer panel

at the center of the feature region at each keyframe. You can then fine-tune the motion path’s keyframes and also the

track point.

Motion source and its motion path
A. Moving the feature and search regions B. Keyframe marker

1 Set up a track point.

2 Track the motion of the feature region.

A

B
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An X appears in the Layer panel at the center of the feature region at each keyframe.

3 To adjust the motion path, do any of the following in the Layer panel:

• To move the entire track point (feature region, search region, and attach point) at a particular keyframe, drag a

keyframe marker with the Selection tool.

• To adjust the speed, use standard techniques for modifying motion paths.

• To adjust the track point, display that frame in the Layer panel, and use the Selection tool.

See also

“About motion paths” on page 210

To set tracker confidence actions (Pro only)
As an image moves in a shot, the lighting, surrounding objects, and angle of the object can all change, making the

once-distinct feature region difficult to track confidently. After Effects reports the confidence of the motion tracking

through the track point’s Confidence properties in the Timeline panel. You can make the tracking stop, continue,

adapt, or extrapolate motion when the confidence value falls below a specified threshold.

1 Select a tracker in the Timeline panel, and click Options in the Tracker Controls panel.

2 Specify the lowest confidence threshold that is acceptable to you in the If Confidence Is Below text box. When the

track point’s confidence level is below the value you specify, After Effects performs the action you specify.

Note: To determine an acceptable confidence threshold, track the motion and then examine the Confidence values

displayed in the Timeline panel for problematic frames. Specify a confidence value that is slightly larger than the largest

confidence value for the problematic frames.

3 Choose the action that you want to occur while the confidence level is below the specified percentage value:

Continue Tracking Ignores the confidence level and continues tracking. This is the default behavior.

Stop Tracking Stops the motion tracking.

Extrapolate Motion Estimates the position of the feature region. Attach point keyframes aren’t created, and attach

point keyframes on the low-confidence frames from previous tracks are deleted. If the confidence level rises above

the specified threshold on a subsequent frame, After Effects interpolates the motion of the attach point on the low-

confidence frames.

Adapt Feature Uses the original feature region until the confidence level falls below the specified threshold. At that

point, After Effects adapts the feature region to the frame preceding the one that has low confidence and continues

tracking. This option isn’t available if Adapt Feature On Every Frame is selected in the Motion Tracker Options

dialog box, since enabling feature adaptiveness causes After Effects to adapt the feature region with every frame

regardless of the confidence level.

About corner pinning (Pro only)
Most tracking options track a single feature in a motion layer. This single feature determines the position keyframes

that are used to animate the anchor point (or center) of the target layer. Unlike standard tracking, the corner pinning

options track points that are used to animate the corners of a typically rectangular target layer. Corner pinning is

useful for adapting the target layer within a specified area of the motion layer. For example, you can track four

corners on the side of a moving bus to attach a billboard. Corner pinning options allow you to either skew the target

layer or simulate a change in perspective. The attach points, not the feature regions, determine the placement of the

target layer’s corners. By default, the attach points are centered within the feature regions.
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After Effects gives you two corner-pinning options when tracking: Parallel Corner Pinning and Perspective Corner

Pinning. These options create multiple track points and apply them to the target layer using the Corner Pin effect.

See also

“Corner Pin effect (Pro only)” on page 423

Parallel Corner Pinning option (Pro only)

When you track using the Parallel Corner Pinning option, you simultaneously track three points in the source

footage. After Effects calculates the position of a fourth point to keep the lines between the points parallel. When the

movement of the points is applied to the target layer, the Corner Pin effect distorts the layer to simulate skew, scale,

and rotation, but not perspective. Parallel lines remain parallel, and relative distances are preserved.

For example, suppose that you have footage of a door shot by a handheld camera that zoomed in or out during

shooting but remained perpendicular to the door. You want to replace the door with a landing space ship. Using the

Parallel Corner Pinning option, After Effects calculates the relative movement between the feature regions to

correctly scale the space ship footage.

When you choose Parallel Corner Pinning, the default positions of the attach points form a rectangle in the center of the motion footage layer
(left). Moving the upper left tracking region moves the lower right (inactive) tracking region in tandem (center).

See also

“Corner Pin effect (Pro only)” on page 423

Perspective Corner Pinning option (Pro only)

When you track using the Perspective Corner Pinning option, you simultaneously track four points in the source

footage. When applied to the target footage, the Corner Pin Effect uses the movement of the four points to distort

the layer, simulating changes in perspective.

For example, if you are replacing a sign on the side of a moving bus, the edges of the sign may be partially obscured

because of shadows or objects; but a window on the bus may be visible throughout the footage. You can first define

four feature regions that are distinct and easy to track, and then move the attach points to the four corners of the

sign. When the new image appears in the sign, After Effects calculates the relative movement between the feature

regions to create the correct perspective.

When you choose Perspective Corner Pinning, the default positions of the attach points form a rectangle in the center of the motion footage
layer (left). Moving each feature region extends the rectangle in the direction of motion (center).
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See also

“Corner Pin effect (Pro only)” on page 423

To track motion using either parallel or perspective corner pinning (Pro only)

To track motion using either parallel or perspective corner pinning, you select the layer and adjust settings in the

Tracker Controls panel. When you track motion using either parallel or perspective corner pinning, After Effects

scales and skews the target layer as necessary to fit the dimensions defined by the feature regions.

1 Select the layer you want to track in the Timeline panel.

Note: The selected layer must include motion or changing frames, such as video source footage, for Track Motion to be

available in the Animation menu. If you want to track motion in still images or a sequence, first pre-compose the layer

by choosing Layer > Pre-compose.

2 Choose Animation > Track Motion or click Track Motion in the Tracker Controls panel. After Effects then

performs the following actions:

• Displays the Tracker Controls panel with the selected layer listed for Motion Source.

• Adds a track point for the motion source in the Layer panel.

• Adds the new track to the Motion Trackers section of the motion source layer in the Timeline.

3 Click Edit Target in the Tracker Controls panel and choose the Motion Target layer from the Layer pop-up menu.

4 Choose either Parallel Corner Pinning or Perspective Corner Pinning from the Track Type menu. Four track

points appear in the Layer panel. (For Parallel Corner Pinning, one point is inactive.)

5 If you want to track a range of frames, define the work area you want to track in the Layer panel for the source

footage.

6 In the Layer panel, move the current-time indicator to the frame from which tracking should begin.

7 For parallel corner pinning only: To change which point is inactive, Alt-click (Windows) or Option-click (Mac

OS) the feature region of the point you want inactive. (One point must remain inactive to keep the lines parallel.)

8 Using the Selection tool, place and resize the feature and search regions over the areas you want to track. The

feature regions should lie in a single plane in the real world—for example, on the side of a bus, on the same wall, or

on the floor.

Note: The search region needs to be only big enough to accommodate the frame-to-frame position change of the feature.

9 Place the attach points at the locations where you want to attach the corners of the target layer. The attach points

should also all lie in a single plane, but not necessarily the same plane as the feature regions.

10 In the Tracker Controls panel, click either the Forward Analyze or Backward Analyze button to begin tracking.

Watch the tracking to make sure that it is accurate. If not, click the stop button to stop tracking, and then correct the

problem as described in “Correcting a drifting feature region (Pro only)” on page 346.

11 When you are satisfied with the position of the feature regions throughout the footage, click the Apply button to

apply the corner pinning track to the specified target. After Effects creates Corner Pin effect keyframes for each

corner and copies them to the target layer.

See also

“To set a work area” on page 121
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Correcting a drifting feature region (Pro only)
As an image moves in a shot, the lighting, surrounding objects, and angle of the object can all change, making the

once distinct feature no longer identifiable at the subpixel level. It takes time to develop an eye for choosing a

trackable feature. Even with careful planning and practice, you will often find that the feature region drifts away from

the desired feature. Re-adjusting the feature and search regions, changing the tracking options, and trying again is a

standard part of digital tracking. When drifting occurs, you may need to perform any combination of the following

adjustments:

• Resize the feature and search regions and track again.

• Track the shot in sections, redefining the feature region in places where the feature changes and the region drifts.

• Track a different area with movement that closely matches that of the feature. If you are applying an effect or

adding something to a specific point, you usually want to track close to the original feature. For example, you may

want to add a glow effect to the end of a sword, but the lighting in the shot creates so much glare on the tip of the

sword that tracking it is impossible. Tracking the opposite end of the sword would generate a much different

motion path than tracking the tip. (This is where planning ahead before you shoot can really pay off.)

• Add a high-contrast object to the scene either attached to the object or in an area that matches the movement of

the feature before you shoot.

• Adjust the tracking options to change the comparison method or precision of the frame-to-frame tracking.

To correct drifting by moving the feature region (Pro only)

1 Drag the current-time indicator to the last well-tracked frame.

2 Do one of the following actions:

• To correct a single frame, drag the feature and search regions to new locations. Alt-drag (Windows) or Option-

drag (Mac OS) the feature region to move it without moving the attach point. Monitor the feature region position

in the Timeline panel. After Effects automatically updates the previous tracking data to this new feature

region/attach point position.

• To correct several contiguous frames, drag the feature and search regions to new locations, resize if necessary, and

click Analyze. Watch the tracking to make sure that it is accurate. If the tracking is not accurate, then click the

button again to stop tracking, adjust the feature region, and begin again.

3 To preview tracking, press the spacebar.

4 When you are satisfied with the track, click Apply to copy keyframes to the selected layer or effect.

To correct drifting by modifying tracking settings (Pro only)

1 Drag the current-time indicator to the last well-tracked frame.

2 In the Tracker Controls panel, click Options.

3 In the Motion Tracker Options dialog box, select Enable Feature Adaptiveness if colors change in the feature

region or its shape evolves, and then click Options. After Effects displays the Tracker Plug-in Options dialog box.

4 Change the following settings as needed:

• If the feature has high contrast, select Luminance.

• If the feature has a high concentration of color, select Saturation.

• If the footage is noisy or grainy, select Process Before Match, and click Blur. Type a value of 2 to 3 pixels.

• If the edges of the feature are fuzzy, select Process Before Match, and click Enhance.
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• If the area is partially obscured during tracking, set a tolerance value for Extrapolate Motion if Confidence Is

Below_%. You can determine the proper value by creating a trial track and then examining the confidence value

displayed in the Timeline panel for any frames with an obscured feature region. Type a value that is slightly larger

than the largest confidence value for the problem frames.

5 Click OK in the Tracker Plug-in Options dialog box, and then click OK again in the Track Options dialog box.

6 In the Tracker Controls panel, click the Analyze Forward or the Analyze Backward button.

7 Watch the tracking to make sure that it is accurate. If the tracking is not accurate, then click the button again to

stop tracking, adjust the settings, and begin again.

8 To preview tracking, press the spacebar.

9 When you are satisfied with the track, click Apply to copy keyframes to the selected layer or effect.

To rename a track (Pro only)
After Effects names tracks sequentially as you create them. When you track more than one feature, it is helpful to

give each track a descriptive name so that it is easier to identify.

1 In the Tracker Controls panel, choose the tracked layer from the Motion Source menu.

2 Choose the track that you want to rename from the Current Track menu.

3 Click Options.

4 Type the name for the track, and click OK.
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Chapter 16: Applying effects

Working with effects

About effects
After Effects includes a variety of effects, which you apply to layers. For example, effects can alter the exposure or

color of footage, manipulate sound, distort images, enhance lighting, animate credits and titles, or create a transition.

All effects are stored in Adobe After Effects 7.0 > Support Files > Plug-ins (Windows) or Adobe After Effects 7.0 >

Plug-ins (Mac OS). Because effects are implemented as plug-ins, you can use additional effects from other Adobe

plug-in–compatible applications, such as Adobe Photoshop, and you can use effects provided by parties other than

Adobe. You can add a single new effect or an entire folder of new effects to the Plug-ins folder. When After Effects

starts, it searches this folder and its subfolders for all installed effects and adds them to the Effect menu and to the

Effects & Presets panel.

Expression Controls effects do not modify existing layer properties; rather, these effects add layer properties to which

expressions can refer.

For more information on the various categories of effects, see “Effect categories” on page 368.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“To modify properties with Expression Controls effects” on page 561

“Plug-ins” on page 66

Applying and controlling effects
You can apply or remove an effect at any time. Once you’ve applied effects to a layer, you can temporarily turn off

one or all the effects in the layer to concentrate on another aspect of your composition. Effects that are turned off do

not appear in the Composition panel and typically are not included when the layer is previewed or rendered.

However, in the Render Queue panel, you can specify that the composition is rendered with all effects on, regardless

of which effects you are displaying in the Composition panel. Turning off an effect does not delete the keyframes

created for any of the effect properties; all keyframes remain until the effect is deleted from the layer.

By default, when you apply an effect to a layer, the effect is active for the duration of the layer. However, you can make

an effect start and stop at specific times or make the effect more or less intense over time by using keyframes or

expressions.

You apply and edit effects to an adjustment layer just as you do to any other layer. However, when you apply an effect

to an adjustment layer, the effect is applied to all layers below it in the Timeline panel.

Note: Effects, masks, and transformations are ignored when referred to by another layer’s effect.

Effects can also be saved, browsed, and applied as animation presets.
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See also

“To apply an animation preset” on page 202

“Improving performance when using effects” on page 638

To apply an effect with the Effect menu

1 In the Timeline or Composition panel, select a layer.

2 Choose Effect > [category] > [effect].

Using this procedure, you can apply multiple instances of a single effect to a layer.

To apply an effect with the Effects & Presets panel

1 In the Effects & Presets panel, locate the effect or effects that you want to apply.

2 Do one of the following:

• With the target layer selected, double-click the effect or effects.

• Drag the effect to the target layer on the Timeline panel, either to the layer name, Effect list heading, Duration bar,

or to any spot in the existing list of effects.

• Drag the effect to the Composition panel. The Info panel displays the name of the targeted layer as you drag over it.

• With the target layer selected, drag the effect to the Effect Controls panel.

Note: Applying an effect to a layer makes it the active layer.

To paste a layer’s effects into other layers

1 In the Effect Controls panel, select one or more effects, and then choose Edit > Copy.

2 In the Timeline panel, select one or more layers, and then choose Edit > Paste.

To temporarily turn off effects

• To temporarily turn off one effect, select the layer in the Effect Controls or Timeline panel, and then click the

Effect switch to the left of the effect name.

• To temporarily turn off all effects in a layer, click the Effects switch in the Switches column for the layer.

Effect switch in the Effect Controls panel and Effect switch in the Timeline panel
A. The Effect switch in the Effect Controls panel turns a specific effect on or off. B. The Effect switch in the Timeline panel also turns a specific
effect on or off. C. The Effects switch in the Switches column of the Timeline panel turns all effects in a layer on or off.

To remove an effect

• To remove one effect, select the effect name in the Effect Controls panel, and press Delete.

A B C
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• To remove all effects applied to one or more layers, select the layer or layers from which you want to remove all

effects in the Timeline or Composition panel, and choose Effect > Remove All.

Note:This command eliminates all keyframes for the deleted effects. If you choose Remove All accidentally, immediately

choose Edit > Undo Delete Effect to restore the effects and keyframes.

Effect Controls panel
When you apply an effect to a layer, the Effect Controls panel opens, listing the effect you just applied. The Effect

Controls panel contains a variety of controls that modify the properties of an effect, including sliders, options, color

swatches, effect points, and angles.

Note: To switch between layers in the Effect Controls panel, click the tab at the top of the panel and select a layer from

the menu.

The effect is also listed in the Effects section under the layer name in the Timeline panel. If you apply additional

effects to the layer, they are listed under the first effect in the Timeline panel.

The order in which After Effects renders masks, effects, and transform properties, called the rendering order, may

affect the final result of an applied effect. Effects are rendered in order from top to bottom in this list. You change the

order in which effects are rendered by dragging the effect name to a new position in the list. To achieve certain

results, change the default rendering order so that a transform property is rendered before an effect in a layer instead

of after the effect.

Effects & Presets panel
Browse and apply effects and animation presets with the Effects & Presets panel. Each item in the panel is identified

by type with an icon: the 32-bit Effect icon , the 16-bit Effect icon , the 8-bit Effect icon , the Layer Property

icon , the Audio icon , or the Animation Preset icon . Use the Effects & Presets panel to store your own

custom animation presets, which can include effects, properties, and property groups, along with any settings,

keyframes, and expressions.

To locate an item in the Effects & Presets panel

1 Choose Window > Effects & Presets.

2 Do one of the following:

• Scroll through the list of items. If the items are listed by category or by Explorer or Finder folder, expand the

category or folder to see the enclosed items.

• Type the name of the item you want to locate, or a part of the name, in the Contains box. The panel lists the items

containing the characters you typed.

To specify how items are listed in the Effects & Presets panel

1 Choose one of the following views from the panel menu: Categories, Explorer Folders (Windows) or Finder

Folders (Mac OS), or Alphabetical.

2 Choose any of the following:

Show Effects Shows all available effects.

Show Referring Presets Lists animation presets that contain an effect, next to the effect in the panel. To see the

presets that use an effect, click the triangle to the left of the effect’s name.

Show Animation Presets Shows all animation presets, including those saved by you.
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Show Presets Contents Shows the individual effects, animators, and properties that make up an animation preset.

To see a preset’s components, click the triangle to the left of the preset’s name.

Note: Animation presets appear in the Effects & Presets panel only if they are located in the After Effects application

folder or a subfolder of the application folder. If you move them to a new folder, place a shortcut (Windows) or an alias

(Mac OS) of that folder in the Effects & Presets folder.

Show 16 bpc Effects Only Shows only 16-bits-per-channel and 32-bits-per-channel effects.

Show 32 bpc Effects Only (Pro only) Shows only 32-bits-per-channel effects.

Reveal In Explorer (Windows) or Reveal In Finder (Mac OS) Opens the folder that contains the effect selected in the

panel.

Refresh List Updates the list of effects and presets to include changes in the list made during an After Effects

session—for example, if you add, move, or delete presets or shortcuts to presets on your computer and outside After

Effects.

Color depth and effects
Many effects in After Effects support processing of image color and alpha channel data at a depth of 16 or 32 bits per

channel (bpc). If an effect supports only 8 bpc, and your project is set to 16 or 32 bpc, After Effects displays a warning

icon next to the effect name in the Effect Controls panel. Using an 8-bpc effect in a 16-bpc or 32-bpc project may

result in a loss of color detail. You can set the Effects & Presets panel to list only 16-bpc or 32-bpc effects.

Each color depth is indicated with an icon: the 32-bit Effect icon , the 16-bit Effect icon , or the 8-bit Effect

icon .

See also

“About color depth” on page 61

About Audio effects
Any audio effect can be customized to radically change the sound of the original audio. For more impact, you can

duplicate a layer that contains audio effects, add additional audio effects to the duplicate layer, and then turn off the

original layer’s effects to hear only the processed audio.

Many audio effects include Dry Out and Wet Out options. Use these to specify the mix of unprocessed (Dry) and

processed (Wet) audio in the final output.

For more information on audio effects, see “Audio effects” on page 384.

Effects with a Comp Camera attribute
Some of the After Effects effects can use a composition’s camera and lights. These effects include Card Dance, Card

Wipe, and Shatter. Some always use the composition camera, while others include light and camera options in the

Effect Controls panel. When you apply an effect with a Comp Camera attribute to a layer (2D only), it can track the

composition’s camera and light positions and render a 3D image on the 2D layer to which it is applied. See “To create

a light or camera layer” on page 151.

The effect’s results appear 3D; however, the layer with the Comp Camera attribute applied remains a 2D layer and

consequently has the following characteristics:

• 3D layers above and below it in the Timeline panel cannot interact with one another.
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• It can be relocated anywhere in the Timeline panel’s stacking order.

• It cannot interact with other effects with Comp Camera attributes, 3D layers, or shadows.

• The image is rendered on the layer, not the composition, so make sure that you apply these effects to layers that

are the same size as the composition and are exactly centered in the composition.

Modifying effects

About effect properties
The Effect Controls panel shows all the controls used to change the property values for an effect. These controls can

include underlined values, sliders, effect point icons, angle controls, menus, color swatches, eyedroppers, and graphs.

You can also change the property values for an effect in the Timeline panel, although using the Effect Controls panel

is often quicker and easier.

By default, when you apply an effect to a layer, the controls you specify do not change for the duration of a layer.

Animate effect properties in the same way that you animate any other properties—by adding keyframes or expres-

sions to one or more of the effect’s properties.

Effect properties in the Effect Controls panel
A. Click to expand or collapse an effect’s controls. B. Drag left to decrease or right to increase a value. C. Click to set or remove keyframes.
D. Click to return to the default values. E. Click to view animation presets that contain the current effect. F. Drag the line in the angle control
to set a new value. G. Drag or type to set a new value.

See also

“Using keyframes” on page 192

“About expressions” on page 555

To change the value of an effect property
1 In the Effect Controls panel, click the effect name to select it.

2 If the effect’s controls are not visible, click the triangle to the left of the effect name.

A
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3 Change the value using one of the following methods:

• Drag the slider left or right, if available.

• Drag the underlined value or type a new value directly over the existing value.

• Click Reset to select default values.

To open the Options dialog box for an effect, click Options to the right of the effect name in the Effect Controls panel.

Not all effects include an Options dialog box.

To set an angle value for an effect
❖ Do one of the following:

• Click a point inside the angle control .

• Click and drag the angle control line.

Note: Once you have clicked inside the angle control, you can drag outside it for more precision.

• Drag the highlighted value or type a new value directly over the existing value.

Note: You can set an angle of more than 360˚ by turning the dial more than once or by typing a new angle value.

To set a color value for an effect
❖ Do one of the following:

• In the Effect Controls panel, click the color swatch, select a color in the Color dialog box, and click OK.

• Click the eyedropper , position it on the desired color, and click to select the color.

Placing an effect using effect points
Some effects require that you identify specific positions on a layer to determine how the effect will be applied. Often,

these effect points enable After Effects to properly position the effect on the layer. An effect may require as few as

one or as many as four or more effect points.

Note: The positions of these effect points are based on the coordinate system for the layer, not for the composition. The

coordinates shown in the Info panel are layer coordinates when you’re working in the Layer panel.

To set an effect point

❖ Select the effect and then do one of the following:

• Click the effect control point in the Composition panel and drag. The coordinates in the Effect Controls panel

change as you drag.

• Click the effect control point button  in the Effect Controls panel; then, in the Composition or Layer panel,

position the control point where you want the effect point, and click.

To view an effect point or path

• To view an effect point or path in the Layer panel, choose the effect name from the Layer panel’s Viewer menu.

• To view an effect point in the Composition panel, select the effect name in the Timeline panel.
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To exactly position an effect
After Effects renders all effects using subpixel positioning, a highly accurate interpolation that calculates a layer’s

position to thousandths of a pixel. Effects are calculated to a level of precision higher than the resolution displayed

on-screen, which results in smooth, high-quality effects and animations. Positioning with subpixel accuracy may

soften pixels when used with blending or smoothing effects.

1 Choose View Options from the Composition panel menu and then select Effect Controls to make the effect points

visible.

2 Select the effect you want to position in the Effect Controls or the Timeline panel.

3 Zoom in on the layer in the Composition panel. The more you zoom in, the more accurate you can be. Effect

points for effects are interpolated throughout the area of the image.

Note:A layer must be set to Best quality to take advantage of subpixel accuracy. However, for faster editing, you can keep

layers at Draft quality until you render a finished movie.

Using Noise & Grain effects

About grain and visual noise
Almost every digital image that was captured in some way from the real world contains grain or visual noise caused

by the recording, encoding, scanning, or reproduction processes and equipment used to create that image. Examples

include the faint static of analog video, compression artifacts from digital cameras, halftone patterns from scanned

prints, CCD noise from digital image sensors, and the characteristic speckle pattern of chemical photography, known

as film grain.

Noise isn’t necessarily bad; it is often added to images to create a mood or tie elements together, such as adding film

grain to a computer-generated object to integrate it into a photographed scene. However, noise can also be unwanted

for aesthetic reasons. Archival footage or high-speed photography may appear unpleasantly grainy; digital

compression artifacts or halftone patterns may mar the image, or noise may interfere with technical processes such

as bluescreen compositing.

There are also technical reasons to reduce noise. For example, compression algorithms usually achieve smaller file

sizes when the input material is less noisy, so noise reduction is a valuable preprocessing step for applications such

as DVD creation and video streaming.

See also

“Adobe Media Encoder Filters options” on page 614

About grain effects
Effects such as Add Grain, Match Grain, and Remove Grain allow you to manipulate grain that appears more or less

evenly over the whole image. Grain effects can’t correct image problems that affect only a few pixels, such as dust,

salt and pepper noise, or analog video dropouts.

The Add Grain effect generates new grain from nothing; it doesn’t take samples from existing grain. Instead, a

number of parameters and presets for different types of film can be used to synthesize different types of grain.
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The Remove Grain and Match Grain effects use a two-step process to manipulate grain without affecting the edges,

sharpness, or highlights of an image. First, the grain is sampled, either automatically or manually; second, the grain

is analyzed and portrayed by a mathematical model, which the effect uses to add, remove, or match the grain.

Three types of grain effects: matching (left), adding (center), and removing (right)

To apply a grain effect
Each grain effect is applied with default settings and displayed in Preview viewing mode, which has a preview region

framed by a white border and centered on the image. The preview region displays the results of the grain effect on

just a portion of your image, for speed and comparison purposes.The grain effects are almost fully automatic but also

offer many controls to achieve precise results. You can also selectively apply the grain effects to portions of your

image using the extensive Blend With Original features provided with each effect.

1 Select the layer you want to affect.

2 Choose Effect > Noise & Grain > [effect].

3 Choose a viewing method from the Viewing Mode control in the Effect Controls panel:

Preview Displays the current settings of the applied effect in a 200 x 200 pixel area.

Blending Matte Shows the current color matte or mask, or the combination of both, which results from the current

settings of the Blend With Original controls group.

Final Output Renders the full active frame, using the current settings of the effect.

4 Adjust the effect’s controls in the Effect Controls panel; the preview region in the Composition panel reflects any

changes you make.

5 Choose Final Output from the Viewing Mode control.

To apply a grain effect to a selected area

The Blend With Original controls group lets you precisely apply a grain effect to a particular area of your image or

sequence by masking and matting the desired area. You can choose between two selection techniques or use a combi-

nation of both:

Color Matching Excludes any area of the image that matches a selected color. By inverting the matte, you can also

selectively process such an area.

Masking Layer Uses any layer in the current composition as a mask to selectively process or exclude an area of the

current layer or track.

When any grain effect is first applied, the Amount value of the Blend With Original controls group is set to 0%; this

value determines the percentage of blending between the original image and the processed version. At 0%, no

blending occurs and the selected effect is applied to the entire image at full strength; at 100%, white areas of the

blending matte are unchanged from the original image.
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Any mask or matte works in a similar way: The white pixels in it exclude that area of the original image from

processing by the grain effect; the black pixels process normally. At 100% Amount, the white areas fully blend with

the original so that they are completely excluded from the processing. This remains true when the match is inverted.

Regardless of the Amount value, the black areas of the matte or mask are always processed. The Amount slider affects

only the areas under the white pixels in the matte or mask. It affects only how the white areas of the matte or mask

are treated by each grain effect.

1 Apply a grain effect to your image.

2 Do any of the following in the Effect Controls panel:

• To create a matte around the area to which you want or don’t want to apply the grain effect, use the Color Matching

controls in the Blend With Original controls group. See “To generate a color-matching matte” on page 356.

• To mask the current layer with another layer or track, use the Masking Layer controls.

3 Adjust the Blur Matte value to soften the matte and to produce a softer transition between the affected and

unaffected areas of the image.

4 If you are using both a color matte and a layer mask, choose one of the following from the Combine Match And

Mask Using menu:

Screen Makes the matte white wherever either the mask or the color match is white.

Multiply Makes the matte white where both of the inputs are white.

5 Reduce the Amount value to let more of the original image show through the grain.

6 Choose Final Output from the Viewing Mode control.

To generate a color-matching matte

When a grain effect is first applied, a neutral gray color is used to generate a default color-matching matte, so that in

most images a visible matte appears. The Color Matching group of controls uses color matching to precisely define

a matte. The matte isolates portions of the image where the layer that is using the grain effect is blended with the

input.

1 Apply a grain effect to your image.

2 To select a color to exclude from or restrict to the effect, do one of the following adjacent to the Matching Color

control in the Blend With Original and Color Matching controls groups:

• Click the color swatch to choose a color in the Color Picker dialog box.

• Click the eyedropper  and click a color anywhere on your computer screen.

3 Do one of the following:

• To prevent the grain effect from affecting the selected color, make sure that the Invert Match control is deselected.

• To restrict the grain effect to the selected color, leaving the rest of the image unaffected, select Invert Match.

4 If you want to exclude colors that are similar to the matching color, increase the Matching Tolerance value, which

sets a threshold for color matching. As the value increases, the matte includes pixels with colors increasingly different

from the matching color.

5 Choose an option from the Match Color Using control if you want to change the default criterion (RGB) used to

determine that a color is similar to the matching color.

6 Adjust the Matching Softness controls to determine the width of the transition band between completely matched

and completely unmatched pixels or how smoothly the affected areas blend with the original image.
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7 Select Invert Match if you want to invert the matte so that the white areas become black and the black areas

become white. (The matching color will be black in the matte and will be processed by the grain effect regardless of

the Amount setting. The inversion does not affect any other settings.)

8 If you are using both a color matte and a layer mask, choose one of the following from the Combine Match and

Mask Using menu:

Screen Makes the matte white wherever either the mask or the color match is white.

Multiply Makes the matte white where both of the inputs are white.

9 Choose Final Output from the Viewing Mode control.

To generate a layer matte

In some cases, you may want to use a different layer or track as a mask for the layer that is using a grain effect. This

allows unlimited control over exactly which parts of the image are modified and how much.

1 Apply a grain effect to your image.

2 In the Effect Controls panel, choose the layer that you want to use as a mask from the Mask Layer control in the

Blend With Original and Masking Layer controls groups.

3 Choose a masking mode from one of the standard track matte mode options.

4 If the masking layer is a different size than the current layer, choose one of the following from the If Mask Size

Differs pop-up menu in the Masking Layer controls:

Center Centers the masking layer over the current layer.

Stretch To Fit Resizes the masking layer to match the dimensions of the current layer.

5 If you are using both a color matte and a layer mask, choose one of the following from the Combine Match And

Mask Using menu:

Screen Makes the matte white wherever either the mask or the color match is white.

Multiply Makes the matte white where both of the inputs are white.

6 Choose Final Output from the Viewing Mode control.

Previewing grain effects
You’ll achieve the best results by experimenting, applying small increments to each of several controls in the Effect

Controls panel, and viewing the results in the Composition panel after every adjustment. You can use the Preview

Region controls group to change the position or the size of a grain effect’s preview region.

Since adding or removing grain can affect sharpness of detail, you may also want to preview an area of fine detail

such as a human face or some text. When removing grain with the Remove Grain effect, it’s best to preview an area

where the grain is most clearly visible or most objectionable, such as a large expanse of solid color.

To change the preview region

1 After applying a grain effect, click the Center button  in the Preview Region group of controls in the Effect

Controls panel. A cross hair appears centered in the Composition panel.

2 In the image, click the desired center of the preview region. The preview region redraws, centered in the new

position.

3 To change the dimensions of the preview region, change the Width and Height values in the Effect Controls panel

to the desired size in pixels. (Larger preview regions can result in slower rendering.)
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4 Select Show Box if you want to outline the preview region in color. If you want to change the outline color, do one

of the following adjacent to Box Color:

• Click the color swatch to choose a color in the Color Picker dialog box.

• Click the eyedropper button, and click a color anywhere on your computer screen.

5 Use any of the following techniques to view your results:

• To view the fine detail of the noise structure, zoom into the preview region.

• To examine the noise in each channel independently, click the corresponding color channel icon in the Compo-

sition panel.

• To increase the effect’s interaction speed and RAM preview duration, use the Region Of Interest feature in the

Composition panel to reduce the area that is processed. (See “Changing the region of interest” on page 118.)

• To retain an image of the current frame in its current state, click Take Snapshot in the Composition panel. You

can subsequently click and hold down Show Last Snapshot  to view the most recent snapshot instead of the

active composition, and toggle between the current and previous state of the preview region. This is extremely

useful when evaluating subtle adjustments. (See “To take or view a snapshot” on page 145.)

• To compare the preview region with and without the grain effect, click the Effect switch (small f icon) next to the

grain effect’s name in the Effect Controls panel to temporarily disable the effect. Click Take Snapshot  in the

Composition panel, click the Effect switch again to re-enable the effect, and then click and hold down Show Last

Snapshot  to display the snapshot of the image without the effect.

To remove noise or grain from an image
To remove grain or visual noise, use the Remove Grain effect. This effect uses sophisticated signal processing and

statistical estimation techniques in an attempt to restore the image to how it would look without the grain or noise.

While many techniques, such as applying a mild Gaussian Blur effect or the Median effect, reduce the visibility of

noise in an image, the trade-off is an unavoidable loss of sharpness and highlights. The Remove Grain effect, in

contrast, differentiates fine image detail from grain and noise and preserves the image detail as much as possible.

The Remove Grain effect provides several options to precisely balance the reduction in noise and the amount of

sharpness retained in the image. Additionally, the Remove Grain effect can analyze the differences between frames

to further improve noise reduction and sharpness; since this process operates over time, it is called temporal filtering.

Note: Good degraining depends on good noise sampling. The results of the automatic sampling depend on the image

content and noise type. You can also change the number, size, and position of the samples to get the best results for a

particular image.

To increase the speed of the Remove Grain effect preview, adjust the Remove Grain controls in order in the Effect

Controls panel. Specifically, the most efficient workflow is to find effective degraining settings first and to adjust the

last three controls last.

Old photo with two sample points (left), applying Remove Grain effect (center), and using Unsharp Mask controls (right)

1 Select the layer you want to affect.
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2 Choose Effect > Noise & Grain > Remove Grain.

3 Adjust any of the following using the Noise Reduction Settings controls group:

• To adjust the overall amount of noise in the image, adjust the Noise Reduction value.

• To adjust the amount of noise on each channel individually, adjust the Red, Green, and Blue Noise Reduction

values in the Channel Noise Reduction controls.

The blue channel often has the most pronounced grain in a chemical film-based image. Try reducing the noise in

only the blue channel to retain all image detail in the other two channels.

4 Adjust the Passes value to control the maximum noise radius that can be detected:

• If your grain is large and chunky, try increasing the Passes value. A higher number of passes reduces larger-sized

noise.

• If your render time is longer than desired because your file size is large, try lowering the number of passes to

reduce the memory usage and render time.

Note: Once the optimum number of passes is applied, additional passes have no effect.

5 Choose one of the following from the Mode pop-up menu:

Multichannel Degrains all channels of a color image together, which generally produces the best results on color

images. This mode takes advantage of correlations between channels to improve the accuracy of the denoising

process.

Single Channel Degrains each channel independently. Use this mode for a monochromatic image or if Multichannel

causes objectionable color artifacts.

6 Adjust any of the following in the Fine Tuning controls group to improve the balance between noise reduction and

retained sharpness:

Chroma Suppression Suppresses some of the chroma from the noise to clean up the image. If the noise is very

colorful, increasing this control can help remove it. Setting the amount too high may strip some chroma from the

image itself. (Chroma Suppression has no effect on grayscale images and isn’t available if the Noise Reduction

Settings Mode is Single Channel.)

Texture Controls the amount of low-level noise that passes through to the output. This is especially useful to reduce

objectionable artifacts or to retain finely textured areas such as wood grain, brick, or the like. Lower values result in

a smoother, possibly artificial-looking result. Higher values may leave the output unchanged from the input.

Noise Size Bias Controls how the noise reduction process responds to variations in noise size within the same image.

The default value of zero treats all sizes equally. Negative values leave larger residual noise and more aggressively

remove smaller-sized grain; this leaves larger residual noise after degraining. Positive values leave smaller noise and

more aggressively remove noise of larger size.

Clean Solid Areas Controls the extent to which adjacent pixels with low variations in value are smoothed out by the

noise reduction process. This is helpful for large areas of solid color that need to be as clean as possible. Settings that

are too high can smooth out nearly solid areas of the image, resulting in an artificial appearance.

7 Adjust the Unsharp Mask controls to enhance subtle edge detail that may have been suppressed by the degraining.

8 If you are applying the effect to a sequence of frames, use the Temporal Filtering controls to perform inter-frame

noise reduction.

9 To change the effect view, choose any of the following from the Viewing Mode pop-up menu:

Noise Samples Shows the areas that have been sampled to extract the current noise model.
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Preview Displays the current settings of the applied effect in a 200 x 200 pixels area.

Blending Matte Shows the current color matte or mask, or the combination of both, which results from the current

settings of the Blend With Original controls group.

10 Choose Final Output from the Viewing Mode control.

Removing grain in frame sequences
The Temporal Filtering controls of the Remove Grain effect use a statistical algorithm to blend the current frame

with previous and next frames. These controls are particularly effective in removing compression artifacts from DV

or video footage. Because temporal filtering works on the basis of differences between frames, it is useful only for

sequences.

To properly evaluate the results of this filter, the sequence must be viewed in real time, either with a RAM preview

or by viewing a movie rendered to a file.

To add temporal filtering to a sequence

1 Apply the Remove Grain effect to your image.

2 Place the Remove Grain preview region over the area of the image that has the most subtle changes from frame to

frame or that has the most moving image detail.

3 Select Enable in the Temporal Filtering controls.

4 Adjust the Amount value to 100%.

5 Create a RAM preview of the sequence or render it.

6 If you see unwanted streaking or blurs around moving objects, reduce the Motion Sensitivity value, and then

preview or render it again.

7 Try the following techniques if you want to improve the results:

• To quickly reduce the noise of a sequence that has a lot of buzzing noise, set the Noise Reduction value to zero and

the Temporal Filtering Amount to 100%, and render the sequence.

• To speed up previews, apply temporal filtering to your sequence after all the settings for a single frame have been

adjusted.

• To retain a layer’s effects and also apply temporal filtering to it, precompose the selected layer (choose Layer >

Precompose), and then apply the Remove Grain effect to that layer.

To sharpen an image with Unsharp Mask controls
The Remove Grain effect contains Unsharp Mask controls, which increase the contrast of edges and fine details to

help restore some of the sharpness that may have been lost during the grain reduction process.

❖ Do any of the following:

• Increase the Unsharp Mask controls Amount value to obtain acceptable sharpening without generating

undesirable artifacts or bringing back too much grain.

• Increase the Threshold value to remove any unwanted artifacts that resulted from the sharpening.

• Adjust the Radius to change the area over which Unsharp Mask finds details.

• Adjust the Noise Reduction value until the image just begins to lose sharpness; then decrease the value a little, and

then apply the Unsharp Mask controls to sharpen the image.
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To match noise or grain between images
The Match Grain effect matches the noise between two images. This is especially useful for compositing and in

bluescreen/greenscreen work. The Match Grain effect only adds noise and can’t remove it, so if the destination is

already noisier than the source, an exact match is not possible. In this case, you can first use the Remove Grain effect

to clean up the destination and then apply the Match Grain effect to the result to get a perfect match.

The Match Grain effect uses noise sampling as its starting point. Basically, entire frames of new noise are synthesized

to match the noise samples. You can modify the noise in many ways before the effect is applied to the new image,

such as duplicate the noise from an image but make the noise larger and redder before applying the noise to another

image.

Note: The Match Grain effect samples the noise on the frame in the source layer that corresponds to the first frame in

the destination layer. If the source layer is not present at that frame, or if the noise samples contain transparent areas,

no noise is sampled or applied.

Computer graphics character (left) has no film grain (center), and using Match Grain effect (right)

1 Make sure that the source and the destination layers are in the same composition.

2 Select the destination layer to which you want to add grain.

3 Choose Effect > Noise & Grain > Match Grain.

4 Choose a layer from the Noise Source Layer control in the Effect Controls panel to specify the source layer from

which you want to sample the grain. (The Noise Source Layer control lists only layers that are in the Timeline panel.)

The grain is automatically sampled and applied to the preview region on the destination layer. If you need an

automatic match, you can skip the remaining steps.

5 If there already is significant noise in the destination layer before choosing a noise source layer and this causes a

grain mismatch, adjust the Compensate For Existing Noise slider to avoid grain build-up.

6 Do any of the following:

• To adjust the intensity and size of the applied grain and to introduce a blur, adjust the Tweaking controls.

• To modify the color of the added noise, adjust the Color controls.

• To determine how the color value of the generated noise combines with the color value of the underlying desti-

nation layer at each pixel, choose a Blending Mode in the Application controls group.

• To define how much grain is added to each tonal area in your image and the midpoint, adjust the Shadows,

Midtones, Highlights and Midpoint values in the Application controls group.

7 If you want to change the effect view, choose any of the following from the Viewing Mode menu in the Effect

Controls panel:

Noise Samples Shows the areas that have been sampled to extract the current noise model. Selecting the source layer

causes it to appear in the Composition panel, with its noise sample squares displayed.

Compensation Samples Shows the noise samples that have been automatically extracted from the destination image.

Preview Displays the current settings of the applied effect in a 200 x 200 pixels area.
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Blending Matte Shows the current color matte or mask, or the combination of both, which results from the current

settings of the Blend With Original controls group.

Final Output  Renders the full active frame, using the current settings of the effect.

8 Animate the added grain, if desired.

9 Choose Final Output from the Viewing Mode control.

To compensate for existing noise when matching noise

If you’re trying to match the grain between images with the Match Grain effect and your destination layer already

has its own visible grain, a grain mismatch or grain build-up may occur. To prevent these problems, the Compensate

For Existing Noise control extracts a noise model from both the source and the destination and then modifies the

noise from the source to account for the noise already present in the destination, before applying it to the destination.

To use this control automatically, simply set the Compensate For Existing Noise slider to 100%. You can then view

the noise samples in the destination layer by choosing Compensation Samples in the Viewing Mode menu. You can

also reposition the samples in the destination image by setting Sampling Mode to Manual. This makes the Compen-

sation Sample Points available for manual repositioning.

1 Apply the Match Grain effect to the destination layer.

2 in the Effect Controls panel, adjust the Compensate For Existing Noise value under the Match Grain effect as

needed. The noise in the source layer and the noise in the destination layer are sampled, and their difference is calcu-

lated, so that only enough noise to match the destination layer to the source layer is applied to the destination.

3 To modify the noise samples, choose Noise Samples from the Viewing Mode menu, change the Sampling >

Sample Selection control to Manual, and then expand the Compensation Sample Points. The current value of

Number Of Samples determines how many points are available.

4 To reposition each sample point, do any of the following:

• Drag each sample point in the Composition panel to a new location.

• Enter new x and y coordinates adjacent to the sample point under the Compensation Sample Points controls in

the Effect Controls panel.

• Click a Compensation Sample Point’s point parameter in the Effect Controls panel, and then click where you

want to move the point in the Composition panel.

5 Choose Final Output from the Viewing Mode control.

Adding grain or visual noise to an image
The Add Grain effect generates new noise from nothing and does not take samples from existing noise. Instead, a

number of parameters and presets for different types of film can be used to synthesize many different types of noise

or grain. You can modify virtually every characteristic of this noise, control its color, apply it to the image in several

ways, even animate it or apply it selectively to only a part of your image.

The distribution of the added noise over the color channels does affect the overall color of the resulting image. With

a dark background, the noise tends to add to the image visually, so a red tint or more noise in the red channel gives

a reddish hue to the image. With a bright background, the noise tends to subtract from the image visually, so a red

tint or more noise in the red channel gives a cyan color. The result also depends on the Blending Mode control in the

Application controls group.
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Digital video footage shown using three variations of Add Grain effect

Note: The actual grain of your image may vary from the film presets, because of factors such as exposure and scanning

resolution.

You can use the Add Grain effect’s controls to do the following:

• To reproduce the grain of a particular film or photographic stock, choose the film type from the Add Grain effect’s

Preset menu in the Effect Controls panel.

• To adjust the intensity and size of the applied grain and introduce a blur, adjust the Tweaking controls group for

the Add Grain effect in the Effect Controls panel.

• To modify the color of the added noise, adjust the Color controls.

• To define how the color value of the generated noise combines with the color value of the underlying destination

layer at each pixel, choose a Blending Mode in the Application controls group.

• To define how much grain is added to each tonal area in your image and the midpoint, adjust the Shadows,

Midtones, Highlights and Midpoint values in the Application controls group.

• To animate the added grain, adjust the properties in the Animation controls group.

• To apply the effect to the entire image, choose Final Output from the Viewing Mode menu.

Working with added or matched grain
The Add Grain effect creates new grain or noise in an image by building the grain from nothing or by basing the

grain’s properties on presets. The Match Grain effect also creates new grain in an image but by matching the grain in

a different image. Both effects share several controls in the Effect Controls panel that let you control the new grain’s

color, tonal range, blending mode, and animation properties.

Adjusting the tones of added or matched grain

The precise grain pattern present in any frame of film isn’t uniform throughout the frame but may depend on the

tonal values of the content at each pixel. For instance, in chemical film grain, the sizes of the silver halide crystals

actually vary with the exposure level.

The Add Grain and Match Grain effects let you reproduce these subtle changes in grain patterns across areas of your

image or sequence, using the Shadows, Midtones, Highlights, and Midpoint controls in the Application controls

group. These controls let you define how much grain is added to each tonal area and also to each channel in the

image. For example, you can add more grain to overexposed areas of the blue channel to give an image of sky a

grainier look.

You can use the Application controls group for the Add Grain or Match Grain effect to do the following:

• To define how much grain is added to each tonal area in your image, adjust the Shadows, Midtones, and Highlights

values.
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• To define the midpoint of the image’s tonal range for grain application purposes, adjust the Midpoint slider. By

default, this is centered at 0.5, which represents the middle of the range of pixel values, 127 for 8-bit images and

16384 in 16-bit images.

• For even finer control, use the Channel Balance controls to adjust the grain in the shadow, midtone, and highlight

areas independently for each channel.

Animating added or matched grain

By default, the grain or noise generated by the Add Grain and Match Grain effects moves at the same speed as your

source material, to accurately simulate realistic noise. Slowing down the noise processes may be useful for aesthetic

effect or to keep the added noise from buzzing and drawing attention to itself. These effects have an internal

randomizer that changes the positions of the noise pixels between frames. But you can also change the appearance

of the noise between layers on the same frame while keeping every other parameter constant.

You can use the Animation controls group for the Add Grain or Match Grain effect to do the following:

• To determine the frame rate of the added grain, as a multiple of the destination frame rate, adjust the Animation

Speed value in the Animation controls group in the Effect Controls panel. At the default 1, the noise moves at the

same rate as your frames. At zero, the noise is stationary over time.

• To use interpolation to create smooth transitions between the generated noise frames, select Animate Smoothly.

This control matters only when Animation Speed is less than 1.

• To change the appearance of the noise between layers on the same frame, adjust the Random Seed value. Each

Random Seed value represents one of 100 possible variations in the appearance; changing the value doesn’t make

the results more or less random.

Tweaking controls for matching and adding grain

The Match Grain and Add Grain effects share a group of Tweaking controls. You can use these controls to modify

the intensity and size of the noise and to introduce a blur, all of which can be done across the three channels or

individually for each channel. You can also change the aspect ratio of the applied grain.

Note: The values of the Tweaking controls are relative to the noise sampled in the source layer: a value of 1.0 leaves that

property of the source noise unchanged, while higher and lower values alter the applied noise.

Adjust any of the following controls in the Tweaking controls group:

Intensity Controls the amount of variation in brightness and color strength between pixels in the generated noise,

which determines the visibility of the noise. Increasing the value does not change the position or size of each grain

but makes the grain appear to pop more; lower values give a more subtle muted appearance.

Channel Intensities Controls the contrast between pixels in the generated noise separately for each channel. For

example, you may want to add more grain to the blue channel to emulate film.

Size Adjusts the size of the generated grain in pixels.

Channel Size  Adjusts the size of the generated grain in pixels independently for each channel.

Softness  Sets the amount of softness in the grain.

Aspect Ratio  Controls the ratio of the width of the generated grain over a constant height of 1; this is useful for

emulating the effect of anamorphic lenses or for aesthetic effects. A value higher than 1 stretches the grain horizon-

tally; values smaller than 1 squash it horizontally.
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Blending and adjusting the color of added or matched grain

You can adjust the color, saturation, and blending behavior of the grain that is generated by the Add Grain or Match

Grain effect to suit your needs.

Several factors can affect the apparent color of the grain that these effects generate, including the following:

• The color value of the underlying pixel in the source image.

• The Saturation value of the noise.

• The Tint Color and Tint Amount values, if you have modified these from the defaults.

• The Blending Mode value in the Application controls group.

• The amount of noise applied, if any, to each channel individually using the Channel Intensities controls group.

Using the Color controls group in the Effect Controls panel, you can adjust any of the following:

Monochromatic Gives the added noise a single tint. By default, the tones are black and white, but you can change the

Tint Color to make it a gradient of any color. (The Saturation and Channel Intensities controls aren’t available when

Monochromatic is selected.)

Tint Amount Controls the depth and intensity of the color shift.

Tint Color Controls the color the added noise shifts toward.

Saturation  Controls the amount and vividness of the color.

The Blending Mode in the Application controls determines how the color value of the generated noise combines with

the color value of the underlying source layer at each pixel:

Film Makes the generated grain appear embedded in the image. This mode affects darker colors more than lighter

ones, just as the grain in a film negative appears.

Multiply Simply multiplies the color values of the noise and the source. However the result may be either lighter or

darker than the original, because the noise may have either a positive or negative value.

Add Combines the color values of the pixel in the source with the noise. However, the result is not always lighter

than the original because the noise that is created by grain effects can have either a positive or negative value.

Screen Multiplies the inverse brightness values of the noise and the source. The effect is like printing from a multiple

exposure on a negative. The result is always brighter than the original.

Overlay Combines the behavior of Film and Multiply: Both shadows and highlights get less grain, while midtones

get a full application of grain.

Working with noise samples in grain effects
Noise sampling is the first and most important step in removing noise from an image or in matching the noise of one

image in another image. Normally, this process is entirely automatic. For very fine control, you can switch to Manual

mode and adjust the samples yourself using the Sampling controls group in the Effect Controls panel.

A noise sample should be a solid block of uniform color that clearly displays the noise pattern present in the image.

The object is to extract samples of pure noise, without any image features that the algorithm could misconstrue as

grain. For instance, extract samples from a piece of sky, a background wall, or an area of fleshtone. All samples should

be selected from the normal range of the film, DV, or video stock. Avoid underexposed or overexposed areas lacking

in information, especially areas where pixel values have been clipped to pure black or white. Within this normal

exposure range, it is best to select samples with various RGB values and colors, for instance one sample from a bright

area, one from a dark area, and one from the midtones.
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The number of samples in automatic mode is high to ensure that the algorithm has enough good noise data, even if

finding good samples in a particular image is difficult. In addition, the automatic mode may override the number of

samples you’ve set if the effect can’t find enough good samples. You can vary the size of the samples in either

automatic or manual mode; however, increasing sample size does not guarantee better results, especially if the

resulting samples include more substantial variations in RGB values. Sample size should be reduced if a particular

image doesn’t contain sufficiently large areas of constant color values. Conversely, increasing the sample size may

give better results if the image contains large featureless areas.

Repositioning grain or noise samples

Automatic grain or sample selection generally gives acceptable results for the Match Grain or Remove Grain effect,

but you can choose to manually position and resize each sample or change the sample number. For instance, you may

want to reposition samples if the automatic sampling selected a uniform area that is underexposed or overexposed

and that lacks information about grain structure.

Noise samples for the Match Grain and Remove Grain effects are always extracted from the source layer without

regarding any effects or masks that have already been applied to the layer; this results in more accurate sampling. If

you wish to have the samples include the existing effects, you must precompose or prerender the source layer with

all of its effects and then use the result as the source layer to which the grain effect is applied.

You should avoid the following: sharp edges, color gradients, highlights, textures such as grass and water ripples, fine

detail such as hair or tree leaves, and overexposed or underexposed areas lacking in information.

To manually reposition noise samples

1 In the Effect Controls panel, choose Noise Samples from the Viewing Mode menu. The samples appear as small

white squares (24 x 24 pixels) overlaid on the source image.

2 Choose Manual from the Sample Selection pop-up menu in the Sampling controls group.

3 To remove the least desirable samples from the image, try reducing the Number Of Samples value.

4 To move a noise sample, do one of the following:

• Click the point parameter  for the noise sample in the Noise Sample Points controls group. A cross hair

appears in the composition, centered on that sample. Click the desired location in the Composition panel to place

the sample.

• Using the Selection tool , drag the sample point in the Composition panel to the desired location.

• Enter the desired horizontal and vertical coordinates in the Effect Controls panel.

Note: The number of sample points that are enabled corresponds to the current value of the Number Of Samples.

5 Repeat for each sample point you want to move.

To change the sampling source frame

The Remove Grain and Match Grain effects take noise samples from the first frame of the sequence by default, but

you can choose to sample the noise from a different frame. This might be useful if there are large lighting or exposure

variations between frames within the sequence.

1 Decide which frame you want to sample; make sure that your project settings Display Style is set to Frames,

numbering from zero. The number of the current frame then appears in blue in the top left corner of the Timeline

panel. Enter that frame number as the Source Frame value in the Sampling controls group.

2 Choose Noise Samples from the Viewing Mode menu.

The selected frame appears in the Composition panel, and its automatic samples appear on the image.



ADOBE AFTER EFFECTS 7.0
User Guide

367

To change the noise sample box color

You can set the Remove Grain or Match Grain effect’s viewing mode to Noise Samples to see the areas sampled by

the effect. Sampled areas are automatically framed with a white outline. If the noise sample boxes are hard to see, you

can change the noise sample box color.

❖ Do one of the following adjacent to the Sample Box Color control in the Sampling controls group:

• Click the color swatch, and select a color in the Color Picker.

• Click the eyedropper, and click a color anywhere in the application window.
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Chapter 17: Effects: Reference

Galleries of effects

Effect categories
• “3D Channel effects gallery” on page 369

• “Audio effects” on page 384

• “Blur & Sharpen effects gallery” on page 369

• “Channel effects gallery” on page 370

• “Color Correction effects gallery” on page 371

• “Distort effects gallery” on page 373

• “Expression Controls effects” on page 561

• “Generate effects gallery” on page 374

• “Keying effects gallery” on page 375

• “Matte effects gallery” on page 376

• “Noise & Grain effects gallery” on page 376

• “Paint effects gallery” on page 377

• “Perspective effects gallery” on page 377

• “Simulation effects gallery” on page 378

• “Stylize effects gallery” on page 378

• “Text effects gallery” on page 379

• “Time effects gallery” on page 379

• “Transition effects gallery” on page 380

• “Utility effects gallery” on page 380

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“About animation presets” on page 202
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3D Channel effects gallery

Blur & Sharpen effects gallery

No effect applied

“3D Channel Extract effect (Pro only)”
on page 381

“Depth Matte effect (Pro only)” on
page 382

“Depth Of Field effect (Pro only)” on
page 382

“Fog 3D effect (Pro only)” on page 383 “ID Matte effect (Pro only)” on page 384

No effect applied

“Box Blur effect” on page 390 “Channel Blur effect” on page 390 “Compound Blur effect” on page 391

“Directional Blur effect” on page 391 “Fast Blur effect” on page 391 “Gaussian Blur effect” on page 392
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Channel effects gallery

“Lens Blur effect” on page 392 “Radial Blur effect” on page 393 “Sharpen effect” on page 393

“Smart Blur effect” on page 394 “Unsharp Mask effect” on page 394

No effect applied

“Alpha Levels effect (Pro only)” on
page 395

“Arithmetic effect” on page 395 “Blend effect” on page 396

“Calculations effect” on page 397 “Channel Combiner effect” on page 398 “Compound Arithmetic effect” on
page 398

“Invert effect” on page 399 “Minimax effect” on page 400 “Remove Color Matting effect” on
page 400
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Color Correction effects gallery

“Set Channels effect” on page 401 “Set Matte effect” on page 401 “Shift Channels effect” on page 402

“Solid Composite effect” on page 402

No effect applied

“Auto Color effect” on page 402 “Auto Contrast effect” on page 403 “Auto Levels effect” on page 403

“Brightness & Contrast effect” on
page 404

“Broadcast Colors effect” on page 404 “Change Color effect” on page 405

“Change To Color effect” on page 406 “Channel Mixer effect” on page 407 “Color Balance effect” on page 407
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“Color Balance (HLS) effect” on
page 408

“Color Link effect” on page 408 “Color Stabilizer effect (Pro only)” on
page 409

“Colorama effect” on page 410 “Curves effect” on page 413 “Equalize effect” on page 414

“Exposure effect” on page 414 “Gamma/Pedestal/Gain effect” on
page 415

“Hue/Saturation effect” on page 415

“Leave Color effect” on page 417 “Levels effect” on page 417 “Levels (Individual Controls) effect” on
page 418

“Photo Filter effect” on page 419 “PS Arbitrary Map effect” on page 419 “Shadow/Highlight effect” on page 420

“Tint effect” on page 422
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Distort effects gallery

No effect applied

“Bezier Warp effect (Pro only)” on
page 422

“Bulge effect (Pro only)” on page 423 “Corner Pin effect (Pro only)” on
page 423

“Displacement Map effect (Pro only)”
on page 424

“Liquify effect” on page 425 “Magnify effect” on page 426

“Mesh Warp effect (Pro only)” on
page 427

“Mirror effect” on page 428 “Offset effect” on page 428

“Optics Compensation effect (Pro
only)” on page 429

“Polar Coordinates effect” on page 430 “Reshape effect (Pro only)” on page 430

“Ripple effect” on page 432 “Smear effect” on page 433 “Spherize effect” on page 435
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Generate effects gallery

“Transform effect” on page 435 “Turbulent Displace effect” on page 436 “Twirl effect” on page 438

“Warp effect” on page 438 “Wave Warp effect” on page 439

No effect applied

“4-Color Gradient effect” on page 440 “Advanced Lightning effect (Pro only)”
on page 440

“Audio Spectrum effect” on page 442

“Audio Waveform effect” on page 443 “Beam effect” on page 444 “Cell Pattern effect” on page 444

“Checkerboard effect” on page 446 “Circle effect” on page 447 “Ellipse effect” on page 448
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Keying effects gallery

“Eyedropper Fill effect” on page 448 “Fill effect” on page 449 “Fractal effect” on page 449

“Grid effect” on page 451 “Lens Flare effect” on page 452 “Lightning effect” on page 452

“Paint Bucket effect” on page 454 “Radio Waves effect” on page 455 “Ramp effect” on page 458

“Scribble effect” on page 458 “Stroke effect” on page 460 “Vegas effect” on page 460

“Write-on effect” on page 462

“Color Difference Key effect (Pro only)”
on page 463

“Color Key effect” on page 463 “Color Range effect” on page 464
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Matte effects gallery

Noise & Grain effects gallery

“Difference Matte effect (Pro only)” on
page 464

“Extract effect (Pro only)” on page 464 “Inner/Outer Key effect (Pro only)” on
page 465

“Linear Color Key effect” on page 465 “Luma Key effect” on page 466 “Spill Suppressor effect (Pro only)” on
page 466

“Matte Choker effect (Pro only)” on
page 466

“Simple Choker effect (Pro only)” on
page 467

No effect applied

“Add Grain effect” on page 467 “Dust & Scratches effect” on page 468 “Fractal Noise effect” on page 468



ADOBE AFTER EFFECTS 7.0
User Guide

377

Paint effects gallery

Perspective effects gallery

“Match Grain effect” on page 471 “Median effect” on page 471 “Noise effect” on page 472

“Noise Alpha effect” on page 472 “Noise HLS effect and Noise HLS Auto
effect” on page 473

“Remove Grain effect” on page 474

“Paint effect” on page 474 “Vector Paint effect (Pro only)” on
page 475

No effect applied

“3D Glasses” on page 486 “Basic 3D effect” on page 488 “Bevel Alpha effect” on page 489

“Bevel Edges effect” on page 489 “Drop Shadow effect” on page 489 “Radial Shadow effect” on page 490
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Simulation effects gallery

Stylize effects gallery

“Card Dance effect” on page 491 “Caustics effect” on page 494 “Foam effect” on page 496

“Particle Playground effect (Pro only)” on
page 500

“Shatter effect” on page 514 “Wave World effect” on page 520

No effect applied

“Brush Strokes effect” on page 523 “Color Emboss effect” on page 524 “Emboss effect” on page 524

“Find Edges effect” on page 524 “Glow effect (Pro only)” on page 525 “Mosaic effect” on page 526

“Motion Tile effect” on page 527 “Posterize effect” on page 527 “Roughen Edges effect” on page 528



ADOBE AFTER EFFECTS 7.0
User Guide

379

Text effects gallery

Time effects gallery

“Scatter effect (Pro only)” on page 529 “Strobe Light effect” on page 530 “Texturize effect” on page 530

“Threshold effect” on page 531

No effect applied

“Basic Text effect” on page 531 “Numbers effect” on page 532 “Path Text effect” on page 534

“Timecode effect” on page 538

“Echo effect” on page 539 “Posterize Time effect” on page 541 “Time Difference effect” on page 541
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Transition effects gallery

Utility effects gallery

“Time Displacement effect (Pro only)” on
page 542

“Timewarp effect (Pro only)” on
page 544

No effect applied

“Block Dissolve effect” on page 544 “Card Wipe effect” on page 545 “Gradient Wipe effect” on page 548

“Iris Wipe effect” on page 548 “Linear Wipe effect” on page 549 “Radial Wipe effect” on page 549

“Venetian Blinds effect” on page 549

“Cineon Converter effect” on page 550 “Color Profile Converter effect” on
page 551

“Grow Bounds effect” on page 552



ADOBE AFTER EFFECTS 7.0
User Guide

381

3D Channel effects (Pro only)

About 3D Channel effects (Pro only)
After Effects Professional provides tools to integrate 3D scenes into 2D composites and to make changes to those 3D

scenes. You can import 3D channel image files saved in RLA, RPF, Softimage PIC/ZPIC, and Electric Image EI/EIZ

formats. For PIC and EI files, the 3D channel information is in the ZPIC or EIZ files, respectively. You don’t actually

import ZPIC and EIZ files, but as long as they’re in the same folder with the PIC and EI files, you have access to their

3D channels using the 3D Channel effects. The 3D Channel effects don’t affect other types of files.

3D Channel effects read and manipulate the additional channels of information, including z-depth, surface normals,

object ID, texture coordinates, background color, unclamped RGB, and material ID. You can layer 3D elements along

a z axis, insert other elements in a 3D scene, blur areas in a 3D scene, isolate 3D elements, apply a foggy effect with

depth, and extract 3D channel information for use as parameters in other effects.

Note: Apply 3D Channel effects to 2D layers that have the auxiliary information. If you convert a layer to 3D and view

it from anywhere but the front and center, it doesn’t appear as expected.

See also

“About 3D layers” on page 173

3D Channel Extract effect (Pro only)
The 3D Channel Extract effect makes auxiliary channels visible as either grayscale or multichannel color images. You

can then use the resulting layer as parameters for other effects. For example, extract the z-depth information in a 3D

channel image file and then use it as an influence map in the Particle Playground effect, or extract values from the

unclamped RGB channel to produce a matte that generates glowing highlights.

This effect works with 8-bpc color.

Original (left), duplicate of original with 3D Channel Extract applied using Texture UV (center), and original combined with duplicate using
the Luminosity blending mode (right)

“HDR Compander effect” on page 553 “HDR Highlight Compression effect” on
page 554
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Adjust the following controls for the 3D Channel Extract effect:

3D Channel Specifies the channel that you want to extract from the 3D channel image file.

White Point, Black Point Specify the value that is mapped to white or black.

See also

“About 3D layers” on page 173

Depth Matte effect (Pro only)
The Depth Matte effect reads the z-depth information in a 3D channel image file and can slice the image anywhere

along that z axis. Use this effect to create a matte for everything in front of or behind the value you specify. For

example, remove a background in a 3D scene, or insert objects into a 3D scene. Simply create two layers with the 3D

channel image file; then, in one layer, position everything behind a certain point. In the other layer, position every-

thing in front of that same point, so that the two layers together make up the original image; then insert a layer

between them with the object that you want to composite into the scene.

This effect works with 8-bpc color.

Original (left), and with Depth Matte applied with two different Depth values (center and right)

Adjust the following controls for the Depth Matte effect:

Depth Specifies the depth of the z axis where you want to slice the image.

Feather Specifies the amount of feather along the slice.

Invert Inverts the feather.

See also

“About 3D layers” on page 173

Depth Of Field effect (Pro only)
The Depth Of Field effect simulates a camera that’s focusing in on one area in a 3D scene (along the z axis) while

allowing other areas to blur.

This effect works with 8-bpc color.

Original (left), and with Depth Of Field applied using different Focal Plane values (center and right)
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Adjust the following controls for the Depth Of Field effect:

Focal Plane Specifies the specific distance, or plane, along the z axis that you want to focus on in the 3D scene.

Identify this distance by clicking different parts of the 3D scene in the Composition panel, while keeping an eye on

the z-axis values that appear in the Info panel. Note that you must select the effect in the Effect Controls panel before

you click.

Maximum Radius Describes how much blur is applied to objects outside this plane.

Focal Plane Thickness Determines the depth of the region that’s in focus.

Focal Bias Sets the speed with which the out-of-focus elements lose focus. The higher the value, the more quickly

elements drop out of focus.

See also

“About 3D layers” on page 173

Fog 3D effect (Pro only)
The Fog 3D effect applies fog along the z axis, so the distant parts of a 3D scene look hazier or disappear behind the

fog. Fog 3D simulates fog by behaving as though there is a scattering medium in the air that makes objects look more

diffuse as they get more distant along the z axis.

This effect works with 8-bpc color.

Original (left), Gradient Layer (center), and with Fog 3D applied (right)

Adjust the following controls for the Fog 3D effect:

Fog Color Specifies the color of the fog.

Fog Start Depth Determines where along the z axis the diffuse scattering begins. To specify this point, first select

different elements in the 3D scene and note their z depth in the Info panel.

Fog End Depth Determines where the most diffuse area appears along the z axis.

Fog Opacity Determines the opacity of the fog.

Scattering Density Determines how quickly the scattering occurs. The higher the value, the more dense the fog

appears from its starting point.

Foggy Background Creates a foggy background and is selected by default. Deselect this control to create trans-

parency at the back of the 3D scene for compositing on top of another image or scene.

Gradient Layer Specifies a grayscale layer to use as medium for increasing or decreasing the fog density. After Effects

reads the luminance value in the grayscale image and applies it as the scattering medium. You could, for example,

create a gradient layer from a swirling, drifting texture to create a more atmospheric fog effect. For best results, make

sure that the dimensions of the gradient layer are the same as the dimensions of the footage, not the same as the

dimenstions of the composition.
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Layer Contribution Specifies how much the gradient layer affects the resulting fog.

See also

“About 3D layers” on page 173

ID Matte effect (Pro only)
The ID Matte effect isolates elements in a 3D channel image file. Many 3D programs tag each element in a scene with

a unique Object ID. After Effects uses this information to create a matte that excludes everything in the scene except

the element you want. Identify each object’s Object ID by applying the ID Matte effect and then clicking different

parts of the image in the Composition panel as you watch the Info panel. (You can also identify Object IDs in the

Layer panel if you select the effect from the Layer panel menu first.) If you select Object ID for the Auxiliary Channel

parameter in the Effect Controls panel, the slider automatically reflects the Object ID for each object you select. You

can isolate objects based on their Material ID, as well.

Original (left), with ID Matte applied using the near alien as the ID Selection (center), and composited over a new background (right)

Adjust the following controls for the ID Matte effect:

Aux. Channel Specifies whether you’re isolating elements based on their Object IDs or their Material IDs.

ID Selection Identifies the unique ID value assigned to each element in a 3D scene.

Feather Specifies the amount of feather along the matte’s edges.

Invert Inverts the feather.

Use Coverage Creates a cleaner matte by decontaminating the pixels along the edge of the matte. It removes the

colors stored behind the object from these pixels. This is applicable only if your 3D channel image file contains a

coverage channel that stores information about the colors behind objects.

See also

“About 3D layers” on page 173

Audio effects

Audio effects
Audio effects add ambience to a layer, enhance or correct audio characteristics, and create special effects. You can

apply audio effects to existing audio footage or synthesize just about any sound by combining the Tone effect with

other audio effects.
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Backwards effect
The Backwards effect reverses an audio footage item by playing it from the last frame to the first frame. The frames

remain in their original order when viewed in the Timeline panel. Select Swap Channels to swap left and right

channels.

See also

“Previewing audio” on page 136

Bass & Treble effect
The Bass & Treble effect lets you adjust the amount of boost or cut applied to the low frequencies (bass) or the high

frequencies (treble) of the audio layer. If you need greater control in working with audio tone, use the Parametric EQ

effect (Pro only).

See also

“Previewing audio” on page 136

Delay effect
The Delay effect repeats the sounds in the audio layer after a specified amount of time. This simulates sound

bouncing off a surface, such as a wall some distance away.

To simulate the acoustic ambience of a room, use the Reverb effect (Pro only).

Adjust the following controls for the Delay effect:

Delay Time Specifies the interval of time between the original sound and its echo, in milliseconds. Drag the slider to

the right to increase the time between the original sound and its echo.

Delay Amount Specifies the level of the first delayed audio. Drag the slider to the right to increase the amount of the

original sound that is sent as echo.

Feedback Specifies the amount of the echo that is fed back into the delay line to create subsequent echoes. Drag the

slider to the right to increase the amount of echo signal fed back into the delay line.

Dry Out, Wet Out Specify the balance of the original (dry) sound to the delayed (wet) sound in the final output.

Values of 50% are commonly used.

See also

“Previewing audio” on page 136

Flange & Chorus effect (Pro only)
The Flange & Chorus effect lets you adjust both the flange and chorus. Chorus is commonly used to add depth and

character to audio footage that contains a single instrument or voice. Chorus makes one voice sound like many

voices.

Flange applies a copy of the sound that is detuned, or played at a frequency slightly offset from the original. By exper-

imenting with the voice separation time and the modulation depth, you can create a wavy, rushing sound. The

default settings apply to flange alone.
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Adjust the following controls for the Flange & Chorus effect:

Voice Separation Time (ms) Specifies the time in milliseconds that separates each voice. Each voice is a delayed

version of the original sound. Low values are commonly used for flange, and higher values for chorus.

Voices Specifies the number of voices in the processed (wet) audio. Increasing this value applies more of a chorus

effect.

Modulation Rate Specifies the rate in Hz at which the frequency modulates.

Modulation Depth Specifies the amount of frequency modulation.

Voice Phase Change Specifies the modulation phase difference in degrees between each subsequent voice. Invert

Phase inverts the phase of the processed (wet) audio, which emphasizes more of the high frequencies; not inverting

the phase emphasizes more of the low frequencies. Stereo Voices alternates each voice between two channels so that

the first voice appears in the left channel, the second in the right channel, the third in the left, and so on. To hear

stereo voices, you must preview the audio in stereo or render the movie in stereo.

Dry Out, Wet Out Specify the mix of unprocessed (dry) audio to processed (wet) audio in the final output. Values of

50% are commonly used.

See also

“Previewing audio” on page 136

To use chorus without flange (Pro only)

1 For Voice Separation Time (ms), specify a value of about 40. For a deeper chorus effect, increase this value.

2 For Voices, specify 4.

3 For Modulation Rate, specify a value of about 0.1.

4 For Modulation Depth, specify 50%.

5 For Voice Phase Change, specify 90, and then select Stereo Voices. To quickly find an optimal phase change based

on the number of voices you have specified, use the formula P=360/x, where P is the phase change and x is the

number of voices.

6 For Dry Out and Wet Out, specify 50% each. To make voices appear from more than one direction and get louder

over time, select Stereo Voices, drag the Dry Out slider to 0.0 so you hear just the effect, and then set keyframes so

that the voices fade in over time.

See also

“Previewing audio” on page 136

“Using keyframes” on page 192

High-Low Pass effect (Pro only)
The High-Low Pass effect sets a limit above or below which frequencies can pass. The High Pass filter option allows

frequencies above the limit and blocks frequencies below. Conversely, Low Pass allows frequencies below the limit

and blocks frequencies above. Use High-Low Pass to do the following:

• Enhance or attenuate (reduce) a sound. For example, using High Pass can reduce traffic noise, which often is

concentrated at low frequencies, while minimally affecting a voice recording. Using Low Pass can remove high-

frequency sounds, such as static and buzzing.
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• Change the focus from one sound to another over time. For example, in audio that contains both music and voice,

you can fade out the music while gradually bringing in the voice.

• Protect equipment from potentially damaging frequencies.

• Direct certain frequencies to specific equipment. For example, using Low Pass can isolate sounds intended for a

subwoofer.

Adjust the following controls for the High-Low Pass effect:

Filter Options Specifies whether to apply High Pass or Low Pass.

Cutoff Frequency For High Pass, specifies the frequency below which the footage is not audible. For Low Pass,

specifies the frequency above which the footage is not audible.

Dry Out, Wet Out Specify the mix of unprocessed (dry) audio to processed (wet) audio in the final output. Common

values for removing frequencies are 0% for Dry Out and 100% for Wet Out.

To remove frequencies using the High-Low Pass effect (Pro only)

1 Determine if the unwanted sound has predominantly high- or low-frequency content.

2 For Filter Options, choose High Pass if the unwanted sound has low-frequency content; otherwise, choose Low

Pass.

3 Adjust the cutoff frequency to isolate the unwanted sound from the frequencies you want to keep. To help isolate

the unwanted sound, apply the Audio Spectrum effect to a motion footage layer to see the magnitude of the

frequencies in the range you define. (See “Audio Spectrum effect” on page 442.)

4 Choose 0% for Dry Out and 100% for Wet Out.

5 To verify that the frequencies you are cutting off are the ones you want to remove, switch to the opposite filter and

then preview the audio.

6 To identify which cutoff frequencies work best, do one of the following:

• Continue to adjust the cutoff frequency and preview the audio until you reduce or remove the unwanted sound

while minimally affecting the frequencies you want to keep.

• Set keyframes for different cutoff frequencies, and then preview the audio.

See also

“Previewing audio” on page 136

“Using keyframes” on page 192

Modulator effect (Pro only)
The Modulator effect adds both vibrato and tremolo to audio by modulating (varying) the frequency and amplitude.

Using Modulator, you can create a Doppler effect, such as when the perceived sound of a train whistle is higher in

pitch as it approaches an observer, and lower in pitch as it passes.

Adjust the following controls for the Modulator effect:

Modulation Type Specifies the type of waveform to use. Sine waves produce the purest sounds. Triangle waves

produce more distorted sounds.

Modulation Rate Specifies the rate in Hz at which the frequency modulates.

Modulation Depth Specifies the amount of frequency modulation.
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Amplitude Modulation Specifies the amount of amplitude modulation.

See also

“Previewing audio” on page 136

Parametric EQ effect (Pro only)
The Parametric EQ effect either emphasizes or attenuates specific frequency ranges. Parametric EQ is useful for

enhancing music, such as boosting low frequencies to bring up bass. Using this effect, you can enhance up to three

different bands of the audio footage. As you adjust controls, a Frequency Response graph indicates the combined

equalization curve you create. On the Frequency Response graph, Band 1 is red, Band 2 is green, and Band 3 is blue.

You may find it easier to specify controls if you determine in advance the frequency-response curve you want.

Adjust the following controls for the Parametric EQ effect:

Band Enabled Activates an equalization band and its controls.

Frequency Specifies which frequency to modify. This frequency acts as the peak of the effect—the center of the

bandwidth you specify.

Bandwidth Sets the range of frequencies to enhance above and below the frequency specified under Frequency.

Boost/Cut Specifies the amount of boost or cut applied to the amplitude of the frequencies inside the specified

bandwidth. Positive values boost; negative values cut.

If you have audio with an unwanted sound (such as a beep from a forklift in the background), you can isolate and

cut the frequency range of the beep to attenuate the sound. You may need to experiment with several settings to

isolate the frequency range. To do this, set keyframes for different Parametric EQ properties, and then preview the

audio. You can also apply the Audio Spectrum effect to a motion footage layer to see the magnitude of the frequencies

in the range you define.

See also

“Previewing audio” on page 136

“Using keyframes” on page 192

“Audio Spectrum effect” on page 442

Reverb effect (Pro only)
The Reverb effect simulates a spacious or acoustically live interior by simulating random reflections of a sound off a

surface.

Adjust the following controls for the Reverb effect:

Reverb Time (ms) Specifies the average time, in milliseconds, between the original audio and the reverberated audio.

Diffusion Specifies how much the effect scatters the original audio. More diffusion can make the audio sound farther

from the microphone.

Decay Specifies the amount of time it takes for the effect to subside. A higher value simulates a larger space.

Brightness Specifies the amount of detail preserved from the original audio. More brightness can simulate a room

with live, or highly reflective, acoustics.

Dry Out, Wet Out Specify the mix of the unprocessed (dry) audio to the processed (wet) audio in the final output.
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See also

“Previewing audio” on page 136

Stereo Mixer effect
The Stereo Mixer effect mixes the left and right channels of an audio layer and pans the entire signal from one

channel to the other.

Adjust the following controls for the Stereo Mixer effect:

Left Level, Right Level Specify the level of the left or right audio channel of an audio layer. A value of 2.00 is full level.

Left Pan, Right Pan Shift the mixed stereo signal from one audio channel to the other. Values of –1.00 for Left pan

and +1.00 for Right pan produce an even balance.

Invert Phase Inverts the phase of both channels of the stereo signal. Use this control to prevent two sounds at the

same frequency from canceling each other out.

See also

“Previewing audio” on page 136

Tone effect (Pro only)
The Tone effect synthesizes simple audio tones to create effects such as the low rumble of a submarine, a telephone

ringing in the background, sirens, or a laser blast. You can add up to five tones for each effect to create a chord, for

example, in a composition. When you apply this effect to audio footage, the dry (unprocessed) audio is ignored, and

only the tone plays.

You can also apply the Tone effect to a layer that has no audio, such as an Adobe Illustrator object, to synthesize audio.

When you render the movie, make sure that you select an output format that supports audio.

Adjust the following controls for the Tone effect:

Waveform Options Specifies the type of waveform to use. Sine waves produce the purest tones. Square waves

produce the most distorted tones. Triangle waves have elements of both sine waves and square waves but are closer

to sine waves. Saw waves have elements of both sine waves and square waves but are closer to square waves.

Frequency 1...5 Specifies the frequency in Hz of the first through the fifth tones. To turn off a tone, set its frequency

to 0.0.

Level Changes the amplitude of all tones. If you hear clicking when you preview or play the audio, you may have set

the Level value too high. To produce a clean sound, use a percentage less than or equal to 100 divided by the number

of frequencies you use. For example, if you use all five frequencies, choose 20%.

To avoid clicks at the end of a tone, set a keyframe for the desired amplitude level at the frame just before the end of

the tone, and then set another keyframe for a level of 0.0 at the end of the tone. This technique works well for any

music that you end abruptly.

See also

“Previewing audio” on page 136

“Using keyframes” on page 192
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Blur & Sharpen effects

Box Blur effect
The Box Blur effect blurs an image based on the average color value of neighboring pixels. You can adjust the size of

the area that the effect uses to calculate the average value for a given pixel; a larger radius makes the image blurrier.

You can also make the effect perform one to five iterations; a higher number of iterations creates smoother transi-

tions between colors and increases the blur but also increases the render time.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left), and with effect applied (right)

Adjust the following properties:

Blur Radius Determines the size of the area the effect uses to calculate the average color value.

Blur Dimensions The axis on which to apply the blur.

Iterations Specifies how many times the effect is applied to the image.

Repeat Edge Pixels Repeats the pixels around the edges, preventing the edges from darkening and becoming more

transparent.

Channel Blur effect
The Channel Blur effect blurs a layer’s red, green, blue, or alpha channels individually. You can specify that the blur

is horizontal, vertical, or both. At Best quality, the blur is smooth. Use this effect for glow effects or if you want a blur

that does not become transparent near the edges of the layer. Edge Behavior describes how to treat the edges of a

blurred image. If you deselect Edge Behavior, pixels outside the image are transparent, which makes the edges of the

blurred image semitransparent. Select Repeat Edge Pixels to repeat the pixels around the edges, preventing the edges

from darkening and becoming more transparent.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left), and with effect applied (right)
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Compound Blur effect
The Compound Blur effect blurs pixels in the selected layer based on the luminance values of a blur layer, also known

as a blurring map. The blur layer, which can be any layer that contains pixels of different luminance values, is overlaid

on top of the selected layer, and the pixels of both layers are matched, one to one. Bright values in the blur layer corre-

spond to more blurring of the affected layer, while dark values correspond to less blurring. The blur layer is used only

as a map; it is not visible in the composition.

This effect works with 8-bpc and 16-bpc color.

Original (left); blur layer (center); result (right)

Blur Layer specifies the layer in the composition to use as the blurring map. Maximum Blur specifies the maximum

amount, in pixels, that any part of the affected layer can be blurred. Stretch Map To Fit stretches the blur layer to the

dimensions of the layer to which it is applied; otherwise, the blur layer is centered on the affected layer. Invert Blur

inverts the values.

This effect is useful for simulating smudges and fingerprints, or changes in visibility caused by atmospheric condi-

tions such as smoke or heat, especially with animated blurring layers. Compound Blur is especially effective in

combination with other effects, such as Displacement Map.

Directional Blur effect
The Directional Blur effect gives a layer the illusion of motion. In previous versions of After Effects, this effect was

called Motion Blur. At Draft quality, the effect is a blur of the image in which each pixel is the unweighted average of

its adjacent pixels. At Best quality, the effect uses Gaussian weighting, producing a smoother, more graduated blur.

The Direction control specifies the direction of the blur. The blur is applied equally around a pixel’s center; therefore,

a setting of 180 degrees and a setting of 0 degrees look the same.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left); with effect applied (right)

Fast Blur effect
The Fast Blur effect blurs an image. Specify whether the blur is horizontal, vertical, or both. At Best quality, the Fast

Blur effect is a close approximation of a Gaussian Blur, but it blurs large areas more quickly. Select Repeat Edge Pixels

to blur the contents of the layer while keeping the edges of the layer sharp.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.
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Original (left); with effect applied (right)

Gaussian Blur effect
The Gaussian Blur effect blurs and softens the image and can reduce the visibility of noise. Specify whether the blur

is horizontal, vertical, or both. The layer’s quality setting does not affect Gaussian Blur.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left); with effect applied (right)

Lens Blur effect
The Lens Blur effect introduces the appearance of a narrower depth of field by blurring some objects in an image,

while leaving others in focus. Use a simple selection to determine which areas become blurred, or provide a separate

alpha channel depth map to specify exactly how you want the blur added; black areas in an alpha channel are treated

as though they’re at the front of the photo, and white areas are treated as if they’re far in the distance.

The way the blur appears depends on the size, number, rotation, and curvature of the blades of the iris.

This effect works with 8-bpc and 16-bpc color.

Original (left); Depth Map layer (center); result (right)

To use the Lens Blur effect

1 Select a layer, and choose Effect > Blur & Sharpen > Lens Blur.

2 Choose a source layer (if you have one) from the Depth Map Layer menu.

3 Set the Blur Focal Distance parameter to the depth at which the desired pixels are in focus.

4 If you want to invert the selection or alpha channel you’re using as the depth map source, select Invert Depth Map.

5 Modify the iris with any of the following settings:

Iris Shape The polygon to use as the iris shape.

Iris Blade Curvature The roundness of the edges of the iris.
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Iris Rotation The rotation of the iris.

Iris Radius The size of the iris. Increase this value for greater blur.

6 To introduce specular highlights, set Specular Threshold. All pixels with a brightness value greater than Specular

Threshold are treated as specular highlights. To increase the brightness of the highlights, increase Specular

Brightness.

Film grain and noise are removed when you blur an image. To make the image look more realistic, you may want to

add noise back to the image so that the footage doesn’t look retouched. To add noise, set Noise Amount, and choose

a noise type from the Noise Distribution menu. To add noise without affecting the color in your image, choose

Monochromatic.

Radial Blur effect
The Radial Blur effect creates blurs around a specific point in a layer, simulating the effects of a zooming or rotating

camera. At Draft quality, the blur appears somewhat grainy. You may prefer the draft results for special effects, but

the grain may flicker on interlaced displays.

The Amount control specifies the amount of blur, depending on the choice (Spin or Zoom) for Type. For a Spin blur,

which applies blurs in circles around the center point, the Amount value indicates the degree of rotation. For a Zoom

blur, which applies blur that radiates out from the center point, the Amount value specifies the degree of radial

blurring. You can specify the level of anti-aliasing applied at Best quality; no anti-aliasing is applied at Draft quality.

This effect works with 8-bpc and 16-bpc color.

Original (left); with effect applied (right)

Reduce Interlace Flicker effect
The Reduce Interlace Flicker effect reduces high vertical frequencies to make images more suitable for use in an

interlaced medium (such as NTSC video). For example, images with very thin horizontal lines can flicker when

broadcast. Reduce Interlace Flicker softens horizontal edges to reduce the flickering.

This effect works with 8-bpc color.

Note: Flicker may result from fields that have not been separated.

Sharpen effect
The Sharpen effect increases the contrast where color changes occur. The layer’s quality setting does not affect

Sharpen.

This effect works with 8-bpc and 16-bpc color.
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Original (left); with effect applied (right)

Smart Blur effect
The Smart Blur effect blurs an image while preserving its edges. For example, you can use the Smart Blur effect to

smoothly blur shaded areas while retaining crisp edges.

This effect works with 8-bpc and 16-bpc color.

Radius How far the filter searches for dissimilar pixels to blur.

Threshold How different the pixels’ values should be before they are eliminated.

Mode What parts of the image receive the blur. Normal specifies that the blur be applied to the entire selection,

whereas Edge Only and Overlay Edge specify that the blur only be applied to the edges of color transitions. Where

significant contrast occurs, Edge Only applies black-and-white edges, and Overlay Edge applies white.

Note: Film grain and noise are removed from an image when you blur it. To make the image look more realistic, you

may want to add noise back to the image so that the footage doesn’t look retouched. (See “Adding grain or visual noise

to an image” on page 362.)

Unsharp Mask effect
The Unsharp Mask effect increases the contrast between colors that define an edge. Use the Radius control to specify

the depth of pixels that will be affected at an edge. If you specify a high value, more of the pixels surrounding the

edge are adjusted for contrast. If you specify a low value, only pixels at the edge are adjusted. Use the Threshold

control to specify a tolerance to define edges and prevent overall contrast adjustment that might generate noise or

cause unexpected results. Values define the range of contrast allowed between adjacent pixels before contrast is

adjusted. A lower value produces a more pronounced effect.

This effect works with 8-bpc and 16-bpc color.

Original (left); with effect applied (right)



ADOBE AFTER EFFECTS 7.0
User Guide

395

Channel effects

Alpha Levels effect (Pro only)
The Alpha Levels effect increases or decreases the transparency of a matte. Use Alpha Levels to adjust pure black or

pure white areas of a matte to be semitransparent, or to adjust grays (semitransparent areas) to be pure black and

white. Alpha values are converted using Input limits, Output limits, and the Gamma value.

This effect works with 8-bpc and 16-bpc color.

Original (left); matte created with Fractal Noise effect on a solid layer (center); result (right)

Adjust the following controls for the Alpha Levels effect:

Input limits, Output limits Specify where transparency begins and ends.

Gamma Affects the range of gray values that are converted. A Gamma value of 1 produces a gradual (linear) distri-

bution of gray values. A Gamma value less than 1 creates darker gray values and more transparency. A Gamma value

greater than 1 creates lighter gray values and less transparency.

To convert grays in a matte to pure black or white (Pro only)

1 Set the Input Black Level to a gray value. Alpha values at this level or lower become fully transparent (black).

2 Set the Input White Level to a gray value. Alpha values at this level or higher become fully opaque (white).

3 Leave the Output Black Level set to 0 and the Output White Level set to 255.

4 If necessary, adjust the Gamma value to increase or decrease transparency.

To convert pure black and white in a matte to gray (Pro only)

1 Leave the Input Black Level at 0 and the Input White Level at 255.

2 Set the Output Black Level slider to a gray value. Alpha values below this value rise to this value.

3 Set the Output White Level to a gray value. Alpha values above this value are lowered to this value.

Arithmetic effect
The Arithmetic effect performs various simple mathematical operations on an image’s red, green, and blue channels.

This effect works with 8-bpc color.
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Original (left); matte created with Fractal Noise effect on a solid layer (center); result (right)

Operator Specifies the mathematical operation to perform between the value you specify for each channel and the

existing value of that channel for each pixel in the image:

• And, Or, and Xor Apply bitwise logical combinations.

• Add, Subtract, Multiply, and Difference Apply basic math functions.

• Max and Min Select each pixel in the color channel that is respectively less or greater than the specified value and

set it at the specified value.

• Block Above and Block Below Turn the channel off everywhere that it is respectively greater or less than the

specified value.

• Slice Turns the channel off where it is below the value specified and turns it on where it is above the specified

value.

Clip Result Values Prevents all functions from creating color values that exceed the valid range. If this option is not

selected, some color values may wrap around from on to off, or vice versa.

Blend effect
The Blend effect blends two layers using one of five modes.

This effect works with 8-bpc and 16-bpc color.

Original (left); matte created with Fractal Noise effect on a solid layer (center); result of Blend effect with Mode set to Crossfade (right)

Note: You can create blends more easily and quickly using blending modes, but you can’t animate blending modes. The

advantage of using the Blend effect is that you can animate it. (See “About blending modes” on page 259.)

Adjust the following controls for the Blend effect:

Blend With Layer Specifies the layer to be blended with the original layer.

Mode Specifies the blending mode you want to use. Crossfade fades between the original image and the secondary

image; the original image fades out while the new image fades in. Color Only colorizes each pixel in the original

image based on the color of each corresponding pixel in the secondary image. Tint Only is similar to Color Only but

tints pixels in the original image only if they are already colored. Darken Only darkens each pixel in the original

image that is lighter than the corresponding pixel in the secondary image. Lighten Only lightens each pixel in the

original image that is darker than the corresponding pixel in the secondary image.
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Blend With Original Specifies the fading level between the blended image and the original image. A setting of 0%

shows only the secondary layer (or just the layers specified with Blend in Crossfade mode). At 100%, only the first

layer is visible. Changing this slider linearly over time gives you a standard crossfade. To try the other blending

modes, set Blend With Original to 0% to see the full effect of each mode.

Note: You can create a crossfade without applying an effect by animating the Opacity property of one layer on top of

another. However, this doesn’t work if the frontmost layer has any transparent portions (which allows the other layer to

show through, even when at full opacity). The Crossfade mode creates a proper crossfade between two layers, even if both

have transparent regions.

If Layer Sizes Differ Specifies how to position the layers. The layer’s quality setting affects Blend only if Stretch To Fit

is selected and if the layers are of different sizes. Stretching at Best quality is much smoother.

To use the Blend effect

1 Apply the Blend effect to one layer (A) in your composition, and choose the name of the other layer (B) in the

Blend With Layer menu.

2 Hide layer B by turning the Video switch off next to the layer in the Timeline panel.

Calculations effect
The Calculations effect combines the channels of one image with the channels of another. Use this effect to quickly

and easily produce some of the same results as you get from the Shift Channels effect, the Compound Arithmetic

effect, and precomposing.

This effect works with 8-bpc and 16-bpc color.

Original (left); Calculations effect applied to layer created from solid with Fractal Noise effect (center); result (right)

Adjust the following controls for the Calculations effect:

Input Channel Specifies the channel to extract and blend with the original layer. RGBA displays all channels

normally. Gray shows the luminance of the original RGBA image. Red, Green, Blue, or Alpha converts all channels

to the value of the specified channel.

Invert Input Inverts the layer before the effect extracts the specified channel information.

Second Layer Specifies the layer with which Calculations blends the original layer.

Second Layer Channel Specifies the channel to be blended with the input channels.

Second Layer Opacity Specifies the transparency of the second layer.

Invert Second Layer Inverts the second layer before the effect extracts the specified channel information and calcu-

lates the blend.

Stretch Second Layer To Fit Stretches the second layer’s edges to the original layer’s edges before blending. If you

don’t select this control, the Calculations effect centers the second source layer in the original layer and crops it to fit

the effect layer’s boundaries.
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Blending Mode Specifies the blending mode used for the blending of the original layer and second layer.

Preserve Transparency Ensures that the effect layer’s alpha channel is not modified.

Channel Combiner effect
The Channel Combiner effect extracts, displays, and adjusts various channels in your image.

This effect works with 8-bpc color.

Original (left); effect applied to layer created from solid with Fractal Noise effect (center); result (right)

Adjust the following controls for the Channel Combiner effect:

Use 2nd Layer Specifies that the effect uses another layer to retrieve values from.

Source Layer Specifies which layer you want to retrieve values from. This layer must be in the current composition

but does not need to be visible.

From Specifies how you want to select values from the source layer. Saturation Multiplied specifies that the

saturation value (including lightness) of an image is the source. This option represents the most common view of a

pixel’s saturation value. Saturation is multiplied by the minimum distance to black or white (lightness). For example,

a dark or light blue pixel has less saturation than a bright or pure blue pixel. Min RGB and Max RGB specify that the

lowest or highest value of the red, green, and blue channels of an image is the source.

To Specifies where the From values are applied. Some options, such as RGB To HLS, do not use a To selection. Use

Red Only, Green Only, and Blue Only to view selected RGB, HLS, alpha, or luminance values in one channel without

interference from the others. When you select Hue Only, Lightness Only, or Saturation Only, the applied hue value

is combined with 50% lightness and 100% saturation; the applied lightness value is combined with 0% saturation,

which then gives the hue no effect; and the applied saturation values are combined with 0% hue and 50% lightness.

Invert Inverts the values for the selected From and To options.

Solid Alpha Creates an opaque alpha channel throughout the layer, replacing the original alpha channel.

Compound Arithmetic effect
The Compound Arithmetic effect mathematically combines the layer to which it is applied with another layer. The

Compound Arithmetic effect is intended only to provide compatibility with projects created in earlier versions of

After Effects that use the Compound Arithmetic effect. Using blending modes is usually more effective than using

the Compound Arithmetic effect.

This effect works with 8-bpc color.
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Original (left); effect applied to layer created from solid with Fractal Noise effect (center); result (right)

Adjust the following controls for the Compound Arithmetic effect:

Second Source Layer Specifies the layer to use with the current layer in the given operation.

Operator Specifies the operation to perform between the two layers.

Operate On Channels Specifies the channels to which the effect is applied.

Overflow Behavior Specifies how pixel values that exceed the allowed range are treated.

• Clip Indicates that the values are limited to the allowed range.

• Wrap Indicates that values exceeding the allowed range wrap around from full on to full off, and vice versa.

• Scale Indicates that the maximum and minimum values are calculated and the results are stretched down from

that full range to the range of allowable values.

Stretch Second Source To Fit Scales the second layer to match the size (width and height) of the current layer. If this

option is deselected, the second layer is placed at its source’s current size, aligned with the upper left corner of the

source layer.

Blend With Original Adjusts the opacity of the second source layer so it blends with the original layer.

Invert effect
The Invert effect inverts the color information of an image.

This effect works with 8-bpc and 16-bpc color.

Original (left); effect applied to layer created from solid with Fractal Noise effect (center); result (right)

Adjust the following controls for the Invert effect:

Channel Specifies which channel or channels to invert. Each group of items operates in a particular color space,

inverting either the entire image in that color space or just a single channel. Alpha (not a color space) provides a way

to invert the alpha channel of the image.

Blend With Original Combines the inverted image with the original. You can apply a fade to the inverted image.
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Minimax effect
The Minimax effect enlarges or reduces a matte for a specific channel or all channels. It assigns each pixel the

minimum or maximum pixel value found within a specified radius. For example, a white solid layer with a square

mask shrinks one pixel on each side using Minimum and a radius of 1. The layer’s quality setting does not affect

Minimax.

This effect works with 8-bpc and 16-bpc color.

Original (left); effect applied to layer created from solid with Fractal Noise effect (center); result (right)

Adjust the following controls for the Minimax effect:

Operation Specifies how the effect processes the matte. Minimum replaces a pixel with the smallest pixel value

within the radius specified, and Maximum replaces a pixel with the largest pixel value within the radius specified.

Minimum Then Maximum performs the Minimum operation on the layer followed by the Maximum operation

using the Radius setting, and Maximum Then Minimum does the opposite.

Radius Specifies how many pixels to examine for the Minimum or Maximum operation.

Channel Specifies the channel. Color affects the color channels only. Alpha and Color affects all channels. Red,

Green, Blue, and Alpha affect only the respective channels.

Direction Specifies the direction of scanning for values. Horizontal & Vertical scans all directions for the minimum

or maximum pixel. Just Horizontal and Just Vertical scan only left and right or up and down, respectively.

Remove Color Matting effect
The Remove Color Matting effect removes color fringes from layers that are premultiplied with a color. It is useful

when merging alpha and fill from separate files. If you import footage with a premultiplied alpha channel or if you

create alpha channels with After Effects, you may need to remove halos from an image. Halos are caused by a large

contrast between the image’s color and the background, or matte, color. Removing or changing the color of the matte

can remove the halos. Halos can also be caused by a misinterpretation of an alpha channel’s premultiplied color.

Use Background Color to specify the new background color when you want to change the color of a matte.

This effect works with 8-bpc and 16-bpc color.

Original (left), after applying the Remove Color Matting effect (right)

Use this effect in conjunction with other effects that let you create alpha channels, to achieve more control over the

appearance of the alpha channel.
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Set Channels effect
The Set Channels effect copies channels from other layers to the red, green, blue, and alpha channels of the current

layer. For example, you can take the luminance of one layer and put it into the color channel of the selected layer. All

source layers are centered in the current layer. With Best quality selected, any stretched layers are anti-aliased.

Use Stretch Layers To Fit to resize all other layers to the size of the layer to which Set Channels is being applied.

This effect works with 8-bpc and 16-bpc color.

Original (left); background (center); result (right)

Set Matte effect
The Set Matte effect replaces the alpha channel (matte) of a layer with a channel from another layer above it for the

creation of traveling matte effects. The Set Matte effect is intended only to provide compatibility with projects created

in earlier versions of After Effects that use the Set Matte effect.

This effect works with 8-bpc and 16-bpc color.

Original (left) matte layer (center) result (right)

To create a traveling matte using the Set Matte effect, set up the motion of the matte layer and precompose that layer

with all properties. Use the resulting composition as the layer from which to take the matte. Although you can use

Set Matte for a traveling matte, it is easier and faster to create traveling mattes by using a track matte. (See “About

track mattes and traveling mattes” on page 279.)

Adjust the following controls for the Set Matte effect:

Take Matte From Layer Specifies the layer to use as the replacement matte. You can specify any layer in the compo-

sition.

Use For Matte Specifies the channel of the specified layer to use for the matte.

Invert Matte Inverts the transparency values of the matte.

Stretch Matte To Fit Scales the selected layer to match the size of the current layer. If Stretch Matte To Fit is

deselected, the layer designated as the matte is centered in the first layer.

Composite Matte With Original Composites the new matte with the current layer, rather than replacing it. The

resulting matte allows the image to show through only where the current matte and the new matte both have some

opacity.

Premultiply Matte Layer Premultiplies the new matte layer with the current layer.
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Shift Channels effect
The Shift Channels effect replaces red, green, blue, and alpha channels in the image with other channels. In Take

Channel From, specify which channel to use as a source.

This effect works with 8-bpc and 16-bpc color.

Note: You can use this effect to display the alpha channel for a layer if you set the RGB channels to Alpha and set the

alpha channel to Full.

Original (left); matte layer (center); result, using luminance values of matte layer as alpha channel values (right)

Solid Composite effect
The Solid Composite effect offers a quick way to create a composite of a new color solid behind the original source

layer. You can control the opacity of the source layer, control the opacity of the solid, and apply blending modes all

within the effect’s controls.

This effect works with 8-bpc and 16-bpc color.

Adjust the following controls for the Solid Composite effect:

Source Opacity Specifies the transparency of the source layer.

Color Specifies the color of the new solid.

Opacity Specifies the transparency of the solid.

Blending Mode Specifies the blending mode the effect uses to combine the original layer and the new solid.

Color Correction effects

Auto Color effect
The Auto Color effect adjusts the contrast and color of an image after analyzing the shadows, midtones, and

highlights of the image. By default, Auto Color neutralizes the midtones using a target color of RGB 128 gray, and

clips the shadows and highlight pixels by 0.5%.

The Auto Contrast effect and Auto Levels effect use many of the same controls as the Auto Color effect.

This effect works with 8-bpc and 16-bpc color.
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Original (left), and with effect applied (right)

Temporal Smoothing Specifies the duration of time surrounding the current frame, from which After Effects deter-

mines the amount of correction needed for the current frame relative to the surrounding frames. For example, if

Temporal Smoothing is set to 2 seconds, After Effects analyzes all frames 1 second before and after a given frame to

determine the appropriate level of adjustment for that frame. If Temporal Smoothing is set to 0, each frame is

analyzed independently of surrounding frames. Temporal Smoothing can result in smoother-looking corrections

over time.

Scene Detect Sets the Temporal Smoothing control to ignore frames in different scenes.

Black Clip, White Clip Specify how much to clip black and white pixels. A value between 0.0% and 1% is recom-

mended. By default, After Effects clips the black and white pixels by 0.1%—that is, it ignores the first 0.1% of either

extreme when identifying the lightest and darkest pixels in the image.

Snap Neutral Midtones Identifies an average nearly neutral color in the frame and then adjusts the gamma values to

make the color neutral.

Blend With Original Specifies the effect’s transparency. The higher you set this value, the less the color, contrast, or

levels are affected. For example, if you set this value to 100%, the effect has no affect on the layer.

Auto Contrast effect
The Auto Contrast effect adjusts the overall contrast and mixture of colors in a layer automatically. Because it does

not adjust channels individually, Auto Contrast does not introduce or remove color casts. It maps the lightest and

darkest pixels in the image to white and black, which makes highlights appear lighter and shadows appear darker.

When identifying the lightest and darkest pixels in an image, Auto Contrast clips the white and black pixels by

0.5%—that is, it ignores the first 0.5% of either extreme. This ensures that white and black values are based on repre-

sentative rather than extreme pixel values.

See “Auto Color effect” on page 402 for explanations of this effect’s controls.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Auto Levels effect
The Auto Levels effect automatically sets highlights and shadows by defining the lightest and darkest pixels in each

color channel as white and black and then redistributes intermediate pixel values proportionately. Because Auto

Levels adjusts each color channel individually, it may remove or introduce color casts.
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Auto Levels clips the white and black pixels by 0.5%—that is, it ignores the first 0.5% of either extreme when identi-

fying the lightest and darkest pixels in the image. This ensures that white and black values are based on representative

rather than extreme pixel values.

See “Auto Color effect” on page 402 for explanations of this effect’s controls.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Brightness & Contrast effect
The Brightness & Contrast effect adjusts the brightness and contrast of the entire layer (not individual channels).

The center point of each slider is neutral and indicates no effect. The layer’s quality setting does not affect Brightness

& Contrast. Using the Brightness & Contrast effect is the easiest way to make simple adjustments to the tonal range

of the image. It adjusts all pixel values in the image at once—highlights, shadows, and midtones.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left), and with effect applied (right)

Broadcast Colors effect
This effect works with 8-bpc color.

The Broadcast Colors effect alters pixel color values so that the layer can be accurately represented in a television

broadcast. Computers represent colors as combinations of red, green, and blue. Consumer video equipment repre-

sents colors using different composite signals. Home video equipment cannot reproduce signals above a certain

amplitude, and computer-generated colors can easily exceed this limit. (Signal amplitude is measured in IRE units;

120 IRE units is the maximum possible transmission amplitude.) Use the Broadcast Colors effect to reduce

luminance or saturation to a safe level. The layer’s quality setting does not affect the Broadcast Colors effect.

Reducing saturation requires greater amplitude modification than reducing luminance to achieve the same IRE unit

level, which alters the appearance of your image more. Key Out Unsafe and Key Out Safe are intended to make it easy

for you to determine which portions of the layer will be affected by the Broadcast Colors effect at the current settings.

If you make your background a contrasting color and temporarily select Key Out Unsafe or Key Out Safe, the

background will be visible through affected or unaffected areas of the layer, respectively.
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An unsafe level merely means that if some portions of your movie exceed the safe level, they will not look as you

intended when viewed on a television monitor. Here are some guidelines for using color in movies intended for

broadcast:

• Avoid using highly saturated colors. For example, a red value of 255 used with green and blue values of 0 will cause

red to smear on an NTSC monitor.

• Render a test of your movie and play it back on an NTSC monitor to ensure that colors are represented accurately.

• Avoid pure black and white values. Commonly used values for black and white are 235 and 16, respectively.

Note: The output you are creating should determine whether you use this effect. Many video systems alter colors for

broadcast during the encoding process.

You can adjust the following controls for the Broadcast Colors effect:

Broadcast Locale Specifies the type of broadcast standard you intend to use. NTSC (National Television Systems

Committee) is the North American standard, which is also used in Japan. PAL (Phase Alternating Line) is used in

most of Western Europe and South America.

How To Make Color Safe Specifies the method of reducing the signal amplitude. Reduce Luminance reduces a pixel’s

brightness by moving it towards black. This is the default setting. Reduce Saturation moves the pixel toward a gray

of similar brightness, making it less colorful. Key Out Unsafe makes unsafe pixels transparent and Key Out Safe

makes safe pixels transparent.

Maximum Signal Amplitude (IRE) Specifies the IRE unit level above which your layer’s pixels are altered. The range

is Amplitude (IRE) from 100 to 120 IRE. A level of 100 can affect a layer noticeably; a level of 120 is the maximum

possible IRE and is risky. The default, 110 IRE units, is conservative.

Change Color effect
The Change Color effect adjusts the hue, saturation, and lightness of a range of colors. Choose the range by speci-

fying a base color and similarity values. The similarity can be an RGB similarity, a hue similarity, or a chroma

similarity.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for the Change Color effect:

View Specifies what to view in the composition. Corrected Layer shows the results of the Change Color effect. Color

Correction Mask shows the areas of the layer that will be changed. White areas in the color correction mask are trans-

formed the most, and dark areas are transformed the least.

Hue Transform Specifies the amount, in degrees, to adjust the hue of the selected colors.

Lightness Transform Specifies the amount to increase or decrease the lightness of the selected colors. Positive values

brighten the selected regions; negative values darken them.
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Saturation Transform Specifies the amount to increase or decrease the saturation of the selected colors. Positive

values saturate the selected regions (moving toward pure color); negative values desaturate the selected regions

(moving toward gray).

Color To Change Specifies the color to be changed. Matching Tolerance and Matching Softness both use this color

as a target for building the color correction mask.

Matching Tolerance Specifies the degree of color matching before the color is affected by the color correction. With

low tolerances, only colors very similar to the change color are added to the color correction mask. Larger tolerances

add more of the image to the color correction mask.

Matching Softness Specifies the softness of the color correction. This control does not always soften the color

correction mask geometrically, but it affects the severity of the color correction for regions similar to the base color.

Match Colors Specifies the criterion for determining the similarity of two colors. RGB uses the red, green, and blue

components. Hue matches colors based on hue. For example, bright red, light pink, and burgundy have similar hue

values (a hue of red, but differing values of saturation and lightness). Chroma uses the two chromatic components

to determine similarity, ignoring brightness. Chroma matching is therefore sensitive to saturation and hue differ-

ences, but not to lightness differences.

Invert Color Correction Mask Inverts the mask that determines which colors to affect. If selected, all colors will be

color-corrected, except those selected by using Color To Change and matching controls.

Change To Color effect
The Change To Color effect (formerly Change Color HLS effect) changes a color you select in an image to another

color using hue, lightness, and saturation (HLS) values. Perform color changes either by transforming or interpo-

lating into the new color. This filter is useful for quickly changing one selected color to another, while leaving other

colors in the image unaffected.

Change To Color offers flexibility and options unavailable in the Change Color effect. These options include

tolerance sliders for hue, lightness, and saturation for exact color matching, and the ability to select the exact RGB

values of the target color that you wish to change to.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for the Change To Color effect:

From Specifies the color that you wish to change. This selection determines which pixels will be affected by the

color change.

To Specifies the color that you wish to change to. This control determines the target color for selected pixels.

Change Specifies the HLS channels that are affected. Hue affects hue only, leaving the original lightness and

saturation untouched. Hue & Lightness affects hue and lightness only, leaving the original saturation untouched. Hue

& Saturation affects hue and saturation only, leaving the original lightness untouched. Hue, Lightness, & Saturation

affects all the channels.
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Change By Specifies the color change operation the effect performs. Setting To Color performs a direct change of

affected pixels to the target color. Transforming To Color transforms affected pixel values towards the target color,

using HLS interpolation. The amount of transformation depends on how close the selected To pixel color lies to the

From color and also on the Tolerance value.

Tolerance Specifies the range of pixels that Change To Color affects. Expand this control to reveal separate sliders

for Hue, Lightness, and Saturation values. Higher Tolerance values expand the range of similar values. Lower

Tolerance values reduce the range of similar values.

Note: Use the View Correction Matte option to better identify which pixels are affected.

Softness Specifies the edge smoothness of the selected change areas. Higher values create smoother and more

seamless transitions between areas affected by the color change and those left unaffected.

View Correction Matte Specifies whether or not you are viewing a grayscale mask of the color values. White areas

indicate pixels that are affected by the color change. Black areas are left unchanged. Gray areas are only slightly

affected by the color change.

To animate a color change, first select the initial color you wish to change; then set subsequent keyframes only for

the To color.

Channel Mixer effect
The Channel Mixer effect modifies a color channel using a mix of the current color channels. Use it to make creative

color adjustments not easily done with the other color adjustment tools: Create high-quality grayscale images by

choosing the percentage contribution from each color channel, create high-quality sepia-tone or other tinted images,

and swap or duplicate channels. The Constant (Const) controls specify the base amount of the input channel to be

added to the output channel. Monochrome applies the same settings to all the output channels, creating a color image

that contains only gray values. This is useful for images that you plan to convert to grayscale. If you select and then

deselect Monochrome, you can modify the blend of each channel separately, creating a hand-tinted appearance.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Color Balance effect
The Color Balance effect changes the amount of red, green, and blue color in a layer. The center point of each slider

is neutral and indicates no change. A setting of –100 removes all of the color; a setting of +100 intensifies the color.

The layer’s quality setting does not affect Color Balance.

The Shadow/Midtone/Hilight channel Balance controls specify the amount of a channel’s color in the darker, middle,

and lighter color intensity ranges of a layer. Preserve Luminosity preserves the average brightness of the image while

changing the color. This control maintains the tonal balance in the image.

This effect works with 8-bpc and 16-bpc color.
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Original (left), and with effect applied (right)

Color Balance (HLS) effect
The Color Balance (HLS) effect alters an image’s levels of hue, lightness, and saturation. It is intended only to provide

compatibility with projects created in earlier versions of After Effects that use the Color Balance (HLS) effect. For

new projects, use the Hue/Saturation effect, which operates the same as the Hue/Saturation command in Adobe

Photoshop. You can convert a movie to grayscale by setting the Saturation to –100.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

See also

“Hue/Saturation effect” on page 415

Color Link effect
The Color Link effect colorizes one layer with the average pixel values of another selected layer. This effect is useful

for quickly finding a color that matches the color of a background layer.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for Color Link:

Source Layer Select the layer from which you wish to sample colors. Color Link chooses your original layer if None

is selected, taking into account any masking or other effects that you have applied. If you choose the original layer’s

name from the menu, Color Link samples from the source layer before masking or effects are applied.
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Sample Specifies which values the effect samples from the source layer and subsequently applies to the effect layer.

• Average Averages all RGB values from all opaque pixels in the source layer. This is useful if you are selecting a

specific region of pixels defined with a mask. Median samples the pixel value that falls in the middle of all RGB

values.

• Brightest Samples the brightest RGB value, using lightness, and Darkest samples the darkest RGB value, also

using lightness.

• Max RGB Samples the highest value of the individual RGB channels. Min RGB samples the lowest value of the

individual RGB channels.

• Average Alpha Samples only the average alpha channel value. Median Alpha samples the value that falls in the

middle of all alpha channel values. Max Alpha samples the highest value of the alpha channel. Min Alpha samples

the lowest value of the alpha channel.

Clip Specifies the percentage of the highest or lowest sampled target values that the effect disregards. This is useful

for reducing the influence of noisy pixels in an image.

Stencil Original Alpha If this box is checked, the effect places a stencil of the effect layer’s original alpha channel over

the new value. If this box is unchecked, the effect disregards the original alpha channel and fills the entire effect layer

with the average value of the source layer.

Opacity Specifies the transparency of the effect layer.

Blending Mode Specifies the blending mode that the effect uses to combine the new colorized layer with the original

layer. Blending modes are not available when averaging alpha channel values in the layer.

Color Stabilizer effect (Pro only)
The Color Stabilizer effect samples the exposure of specified areas of a single reference, or pivot, frame; it then adjusts

the total exposure of all the other frames to maintain the value of the selected point in the pivot frame. This is useful

to remove flicker from footage and to equalize the exposure of footage with color shifts caused by varying lighting

situations.

This effect works with 8-bpc and 16-bpc color.

Adjust the following controls for Color Stabilizer:

Set Frame Specifies the pivot frame. Display the frame that has the area of brightness or color that you want to

match, and click Set Frame.

Stabilize Specifies the method by which the stabilization is performed. Choose one of the following options from

the menu:

• Brightness Specifies that the brightness is to be stabilized throughout the footage. You can sample one point in

the pivot frame to specify this value.

• Levels Specifies that black-point and white-point values in the pivot frame are to be stabilized throughout the

footage.

• Curves Specifies that black-point, white-point, and midpoint values in the pivot frame are to be stabilized

throughout the footage.
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The following controls indicate the particular point on the pivot frame that remains constant throughout the footage.

Place the effect points to select an area for stabilization. If you select multiple points, consider that Color Stabilizer

is most effective when those points vary widely in color and brightness.

Black Point Specifies a single point that will remain constant, if you choose to stabilize brightness only. If you choose

to stabilize levels or curves, this control specifies a dark point that remains constant.

Mid Point Specifies a point between two values of color or brightness that will remain constant. This control is

available only if you choose to stabilize curves.

White Point Specifies a light point that will remain constant. This control is available only if you choose to stabilize

levels or curves.

Sample Size Specifies the size, in radius of pixels, of the sampled area.

Colorama effect
The Colorama effect assigns a custom palette to an element in a layer and then cycles the palette. First you colorize

an image with a specified palette, and then you cycle the colors in that palette—that is, change them smoothly around

the Output Cycle palette or color wheel. Color cycling is a quick way to animate pulsing colors that follow a gradient

path, colors that zoom out of a radial gradient, and many other effects.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Colorama works by first converting a specified property to grayscale and then remapping the grayscale values to the

specified color palette. The current color palette appears on the Output Cycle color wheel.

The grayscale is then wrapped around the color wheel. Black pixels are mapped to the color at the top of the cycle,

while increasingly lighter grays are mapped to successive colors going clockwise around the cycle, until this process

wraps around to the start again at full white. For example, with the default Hue Cycle palette, pixels corresponding

to black become red, while pixels that have been converted to 50% gray become cyan. You can animate the cycle so

that in one revolution, each pixel of the layer travels through the complete color cycle.

To customize a palette with the Colorama effect

You can customize any palette by altering the colors and locations of the triangles around the Output Cycle control

of the Colorama effect.

• To change a triangle’s location on the color wheel, drag the triangle. Shift-drag to snap the triangle to 45-degree

increments.

• To add a triangle, click in or near the color wheel, and select a color from the color picker.

• To duplicate a triangle, Ctrl-drag (Windows) or Command-drag (Mac OS) the triangle to the new position.

• To delete a triangle, drag it away from the color wheel.

• To change the opacity, select a triangle on the color wheel and then drag the attached triangle above the opacity

slider. Make sure that Modify Alpha is selected if you want the opacity information to affect your output.
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To adjust hue levels with the Colorama effect

1 Expand the Input Phase control, and choose Hue from the Get Phase From menu.

2 Expand the Output Cycle control, and choose Hue Cycle from the Use Preset Palette menu.

3 Expand the Modify control, and choose Hue from the Modify menu.

4 Optionally, animate the Phase Shift control to cycle the hues in the image.

5 Optionally, choose an animated gradient layer from the Add Phase menu to modulate the hue.

To adjust lightness levels with the Colorama effect

1 Expand the Input Phase control, and choose Lightness from the Get Phase From menu.

2 Expand the Output Cycle control, and choose Ramp Grey from the Use Preset Palette menu.

3 Choose Lightness from the Modify menu.

4 Add a triangle to the Output Cycle at 3 o’clock and another at 9 o’clock, and then drag them toward 6 o’clock. This

setting expands shadows and highlights while compressing the midtones of an image.

Input Phase controls for the Colorama effect
Get Phase From Specifies the property to which the Output Cycle is applied. Select Zero if you want to use a property

from another layer.

Add Phase Specifies the layer containing the property that you want to apply to the Output Cycle. To use this layer

instead of the first layer, select Zero for Get Phase From; otherwise, this layer becomes a secondary property to the

first property. Add Phase From specifies the property to use from the Add Phase layer.

Add Mode Specifies how Colorama combines properties from two layers.

• Wrap  Adds the values of the two properties for each pixel. A pixel cannot be whiter than 100%, so sum values

above 100% are wrapped around the cycle again. For example, a sum of 150% wraps back to 50%.

• Clamp  Adds the values up to 100%. The sum of any two pixels that is greater than 100% is rounded back down

to 100%.

• Average  Adds two pixels together and then divides by two. Average values never wrap or clamp, making this

option the safest choice for predictable output.

• Screen  Screens the second layer over the original layer; the brighter areas in the second layer brighten the first

layer, and the darker areas in the second layer are discarded. Screen mode is especially useful for compositing fire,

lens flares, and other lighting effects.

Phase Shift Shifts the colors around the color wheel. If you animate Phase Shift, the modified pixels cycle among the

colors defined in the Output Cycle palette. A positive value moves the pixels in a clockwise direction; a negative value

moves them counterclockwise.

Animate Phase Shift to cycle the colors around the color wheel. Phase Shift is the parameter that is most commonly

animated.

Output Cycle controls for the Colorama effect
Use Preset Palette Specifies the palette for the color cycle. The top palettes are designed for quick color-management

tasks. The bottom choices offer a variety of built-in color effects.

Output Cycle Specifies the color palette you are currently working with. The triangles specify the location on the

color wheel where a specific color occurs. The color between triangles is smoothly interpolated, unless Interpolate

Palette is off. You can add up to a total of 64 triangles per Output Cycle.
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Note:When you keyframe the Output Cycle, a triangle’s position and color are interpolated between keyframes. For best

results, make sure that all keyframes have the same number of Output Cycle triangles.

Cycle Repetitions Controls how the Output Cycle pixels are applied to the Input Phase. The default value of 1 maps

the Output Cycle once from Input Phase black to Input Phase white. A value of 2 maps the Output Cycle twice, once

from 1% to 50%, and again from 51% to 100%. Use this option to create a simple palette and repeat it many times

throughout a gradient. For example, you can create running lights, in which one cycle repeated 20 times generates

20 lights.

Interpolate Palette Specifies whether or not colors between triangles are interpolated smoothly. When it is not

selected, the output is posterized. For example, with Interpolate Palette not selected, the default Hue Cycle palette

becomes a useful tool for preparing custom shatter maps for use with the Shatter effect.

Modify controls for the Colorama effect

Modify controls specify which properties are modified by the Colorama effect. Once the Input Phase pixels are

mapped to a color on the Output Cycle, the results are applied to the property selected here. You can get a great deal

of selective control by choosing the same property for the Input Phase and the Modify property, along with an appro-

priate Output Cycle.

Note: Because the input layer is represented as a grayscale file, the Ramp Grey preset palette works well and is most

predictable with any Modify setting other than All.

Modify Specifies the specific property to be modified.

Modify Alpha Specifies whether the opacity information in your Output Cycle is applied to the output. Selecting

Modify Alpha changes the alpha information along with the other channels selected from the Modify menu. Modify

Alpha works in conjunction with the Change Empty Pixels option in determining the final change in opacity.

Note: If you apply Colorama to a layer with an alpha channel, and the Output Cycle does not contain alpha information,

the anti-aliased edges of the layer may appear pixelated. To smooth the edges, deselect Modify Alpha. If Modify Alpha is

selected and the Output Cycle contains alpha information, the output is affected even if you’ve selected None from the

Modify menu. This is how you can adjust the levels of just the alpha channel without also changing the RGB information.

Change Empty Pixels Specifies whether you want Colorama’s effects to extend into the transparent areas of your

layer as well. (This works only when Modify Alpha is selected.)

Pixel Selection, Masking, and other controls for the Colorama effect

Adjust the controls to choose which colors in your image you want to affect.

Pixel Selection For the Matching controls for Pixel Selection to work, Matching Mode must be set to anything other

than Off.

• Matching Color Specifies the specific pixel color to which you want to apply Colorama. To select a specific color

in the image using the eyedropper, turn off the Colorama effect temporarily.

• Matching Tolerance Specifies how close a color has to be to the Matching Color option before it is affected by

Colorama. When Matching Tolerance is 0, only the exact color selected for Matching Color is affected by Colorama.

When Matching Tolerance is 1, Colorama is tolerant of all colors; this value in effect turns the Matching Mode off.

• Matching Softness Specifies the softness between the selected and nonselected areas. This doesn’t blur the image,

but controls how smoothly the Colorama effect blends into the rest of the image. For example, if you have an image

of a man wearing a red shirt and blue jeans, and you want to change the color of the shirt from red to blue, subtly

adjust Matching Softness to spread the selection from the red in the shirt into the shadows of the shirt’s folds. If you

adjust it too high, the selection spreads to the healthy pink of the man’s skin; if you adjust it even higher, the selection

spreads to his blue jeans.
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• Matching Mode Specifies whether a pixel is close to the Matching Color. Use Matching Mode if Matching

Tolerance doesn’t increase the selection in the desired areas. In general, use RGB for high-contrast graphics and

Chroma for photographic images.

Masking Specifies the pixels you want to change using the luminance or alpha channel of another layer. Mask Layer

specifies the layer you want to use for your mask. Masking Mode specifies the Mask Layer property to use.

Composite Over Layer Specifies whether you want to see only the selected pixels or the selected pixels on top of the

original layer (the default).

Blend With Original Specifies the relative percentages of the original layer and the affected layer that you see. Use

this control to fade out the Colorama effect.

Curves effect
The Curves effect adjusts the tonal range of an image. You can also use Levels to do this, but Curves gives you more

control. Instead of making the adjustments using just three controls (highlights, shadows, and midtones) as Levels

does, Curves can adjust any point along the input scale while keeping up to 15 other values constant.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left), and with effect applied (right)

When you apply the Curves effect, After Effects displays a graph in the Effect Controls panel that you use to specify

a curve.

The horizontal axis of the graph represents the original brightness values of the pixels (input levels); the vertical axis

represents the new brightness values (output levels). In the default diagonal line, all pixels have identical input and

output values. Curves displays brightness values from 0 to 255 (8 bit) or 32768 (16 bit), with shadows (0) on the left.

To use the Curves effect

1 Choose Effect > Color Correction > Curves.

2 If the image has more than one color channel, choose the channel you want to adjust from the Channel menu.

RGB alters all channels using a single curve.

3 Select Bezier .

4 Click the part of the curve you want to adjust.

5 Click any points on the curve that you want to remain fixed. For example, if you want to adjust the midtones while

minimizing the effect on the highlights and shadows, click the quarter and three-quarter points on the curve. You

can add up to 14 points to the curve, locking those values.

6 To remove a fixed point, drag it off the graph.

7 Adjust the curve by dragging it.
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To use Arbitrary Map in the Curves effect

Use Arbitrary Map to draw a tonal curve by dragging. This control helps you create a variety of interesting tonal and

color effects. In addition, you can import curves and arbitrary maps from Adobe Photoshop. Curves supports .amp

files (Windows) and Photoshop lookup files (Mac OS) created by using the Pencil tool, and .acv files (Windows) and

Photoshop spline files (Mac OS) created by using the Graph tool. The Curves effect does not support Adobe

Photoshop color tables (.act).

1 Click the Folder icon to locate and open an existing map, or click the Pencil tool to edit the default curve.

2 Draw or edit the curve in the Curves graph.

3 If desired, click Smooth  to smooth the curve or click Line  to reset the curve.

Equalize effect
The Equalize effect alters an image’s pixel values to produce a more consistent brightness or color component distri-

bution. The effect works similarly to the Equalize command in Adobe Photoshop. Equalization can be performed

using either RGB values or the brightness component. Pixels with 0 alpha (completely transparent) values are not

considered, so masked layers are equalized based on the mask area. Layer quality settings do not affect Equalize.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)

Equalize Specifies which equalization method to use. RGB equalizes the image based on red, green, and blue compo-

nents. Brightness equalizes the image based on the brightness of each pixel. Photoshop Style equalizes by redistrib-

uting the brightness values of the pixels in an image so that they more evenly represent the entire range of brightness

levels.

Amount To Equalize Specifies how much to redistribute the brightness values. At 100%, the pixel values are spread

as evenly as possible, while lower percentages redistribute fewer pixel values.

Exposure effect
Use the Exposure effect to make tonal adjustments to footage, either one channel at a time, or to all channels at once.

The Exposure effect simulates the result of modifying the exposure setting (in f-stops) of the camera that captured

the image. The Exposure effect works by performing calculations in a linear color space, rather than in the image’s

current color space. The Exposure effect is designed for making tonal adjustments to high-dynamic-range images

with 32-bpc color, but you can use the effect on 8-bpc and 16-bpc images.

See also

“High dynamic range footage (Pro only)” on page 62

To use the Exposure effect

1 Select the layer that you want to adjust, and choose Effect > Color Correction > Exposure.
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2 Select a value from the Channels menu in the Effect Controls panel:

Master Adjust all channels simultaneously.

Individual Channels Adjust channels individually.

3 Set any of the following options:

Exposure This setting simulates the exposure setting on the camera that captures the image, multiplying all light

intensity values by a constant. The units for Exposure are f-stops.

Offset Darkens or brightens the shadows and midtones with minimal change to the highlights.

Gamma The value of gamma to use for adding an additional power-curve adjustment to the image. Negative values

are mirrored around zero (that is, they remain negative but still get adjusted as if they were positive). The default

value is 1.0, which corresponds to no additional adjustment.

Bypass Linear Light Conversion Select this option to apply the Exposure effect to the raw pixel values, which can be

useful if you manage your color manually using the Color Profile Converter effect.

See also

“High dynamic range footage (Pro only)” on page 62

Gamma/Pedestal/Gain effect
The Gamma/Pedestal/Gain effect adjusts the response curve independently for each channel. For pedestal and gain,

a value of 0.0 is completely off, and a value of 1.0 is completely on.

The Black Stretch control remaps the low pixel values of all channels. Large Black Stretch values brighten dark areas.

The effect is the same in all quality settings. Gamma specifies an exponent describing the shape of the intermediate

curve. The Pedestal and Gain controls specify the lowest and highest attainable output value for a channel.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)

Hue/Saturation effect
The Hue/Saturation effect adjusts the hue, saturation, and lightness of individual color components in an image. This

effect is based on the color wheel. Adjusting the hue, or color, represents a move around the color wheel. Adjusting

the saturation, or purity of the color, represents a move across its radius. Use the Colorize control to add color to a

grayscale image converted to RGB, or to add color to an RGB image.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.
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Original (left), and with effect applied (right)

Adjust the following controls for the Hue/Saturation effect:

Channel Control Specifies the color channel you want to adjust. Choose Master to adjust all colors at once.

Channel Range Specifies the definition of the color channel chosen in the Channel Control menu. Two color bars

represent the colors in their order on the color wheel. The upper color bar shows the color before the adjustment;

the lower bar shows how the adjustment affects all of the hues at full saturation. Use the adjustment slider to edit any

range of hues.

Master Hue Specifies the overall hue of the channel chosen in the Channel Control menu. Use the dial, which repre-

sents the color wheel, to change the overall hue. The underlined value displayed above the dial reflects the number

of degrees of rotation around the wheel from the pixel’s original color. A positive value indicates clockwise rotation;

a negative value indicates counterclockwise rotation. Values range from –180 to +180.

Master Saturation, Master Lightness Specify the overall saturation and lightness of the channel chosen in the

Channel Control menu. Values range from –100 to +100.

Colorize Adds color to a grayscale image converted to RGB, or adds color to an RGB image—for example, to make

it look like a duotone image by reducing its color values to one hue.

Colorize Hue, Colorize Saturation, Colorize Lightness Specify the hue, saturation, and lightness of the color range

you chose in the Channel Control menu. After Effects displays only the sliders for the Channel Control menu choice.

To adjust colors with the Hue/Saturation effect

1 Choose Effect > Color Correction > Hue/Saturation.

2 From the Channel Control menu, choose which colors to adjust:

• Choose Master to adjust all colors at once.

• Choose a preset color range for the color you want to adjust, and then use the sliders for that color range.

3 For Hue, type a value or drag the dial.

4 For Saturation, type a value or drag the slider. The color shifts away from or toward the center of the color wheel,

relative to the beginning color values of the selected pixels.

5 For Lightness, type a value or drag the slider.

To colorize an image or create a monotone result

1 Choose Effect > Color Correction > Hue/Saturation.

2 Select Colorize. The image is converted to the hue of the current foreground color. The lightness value of each

pixel does not change.

3 Drag the Colorize Hue dial to select a new color if desired.

4 Drag the Colorize Saturation and Colorize Lightness sliders.
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To modify the range of Hue/Saturation effect adjustments

1 From the Channel Control menu, choose an individual color. (By default, the range of color selected when you

choose a color component is 30˚ wide, with 30˚ of fall-off on either side. Setting the fall-off too low can produce

dithering in the image.)

2 Do any of the following:

• Drag one or both of the white triangles to adjust the amount of feather without affecting the range.

• Drag one or both of the vertical white bars to adjust the range. Increasing the range decreases the fall-off, and vice

versa.

Leave Color effect
The Leave Color effect removes all the colors from a layer except those similar to a given color. For example, a movie

of a basketball game could be decolored except for the orange of the ball itself. The layer’s quality setting does not

affect Leave Color.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for the Leave Color effect:

Amount To Decolor Specifies how much color is removed from the layer. A setting of 100% causes the areas of the

image dissimilar to the selected color to appear as shades of gray. At 50%, those areas lose half of their color

saturation.

Color To Leave Specifies the color that is to be left untouched.

Tolerance Specifies how closely the effect matches colors. A value of 0% decolors all areas of the image except those

that match the Color To Leave exactly. A value of 100% causes no color change.

Edge Softness Specifies the sharpness of the color boundaries. High values smooth the transition from color to gray.

Match Colors Specifies the color model to use for similarity. RGB uses the RGB color space to determine which areas

are decolored. Match Colors is a strict matching technique and usually decolors more of the image than Hue. Hue

uses hue (color) to determine which areas are decolored; in other words, choosing light blue as the Color To Leave

also leaves dark blue, since both colors have the same hue.

Levels effect
The Levels effect remaps the range of input color levels onto a new range of output color levels, and changes the

gamma correction curve at the same time. The Levels effect is useful for basic image quality adjustment. This effect

functions the same as the Levels adjustment in Photoshop and appears in the same way if monitor calibration is off.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.
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Original (left), and with effect applied (right)

The gamma of any curve is its slope, expressed as the ratio of the logarithms of the output to input values. For

example, a gamma value of 1.0 equals an output-to-input ratio of 1:1. Moving the midpoint of the curve up (in an

RGB readout) lowers the gamma value; moving the midpoint down raises the gamma value. Gamma specifies

contrast that affects the midtones in a range.

You can adjust the brightness, contrast, and gamma in an image. Use Levels to adjust the gamma to change the

brightness values of the middle range of gray tones without dramatically altering the shadows and highlights.

Adjust the following controls for the Levels effect:

Channel Specifies the color channel to be modified.

Histogram Shows how the pixel values are distributed in an image. The horizontal axis of the histogram represents

the brightness value. The vertical axis represents the number of pixels at each brightness level. No pixels can be

darker than the output black level, and no pixel can be brighter than the output white level.

Input Black Specifies the threshold of the black value for the input image. Pixels below the input black level are

mapped as black on the input image. The input black value is represented by the upper left triangle below the

histogram.

Output Black Specifies the limit of the black value for the output image. The output black value is represented by the

lower left triangle below the histogram.

Gamma Specifies the gamma value, which is represented by the middle triangle below the histogram.

Output White Specifies the limit of the white value for the output image. The output white value is represented by

the lower right triangle below the histogram.

Input White Specifies the threshold of the white value for the input image. Pixels below the input white level are

mapped as white on the input image. The input white value is represented by the upper right triangle below the

histogram.

Levels (Individual Controls) effect
The Levels (Individual Controls) effect functions like the Levels effect but allows you to adjust the individual color

values for each channel. This allows you to add expressions to individual properties or keyframe one property

independently of the others. To see each control individually, click the arrow next to the channel color to expand it.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left), and with effect applied (right)
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Photo Filter effect
The Photo Filter effect mimics the technique of putting a colored filter in front of the camera lens to adjust the color

balance and color temperature of the light transmitted through the lens and exposing the film. You can choose a

color preset to apply a hue adjustment to an image, or you can specify a custom color using the Adobe Color Picker

or the eyedropper.

You can use the Photo Filter effect controls to do the following:

• To use a color preset for the filter color, choose an option from the Filter pop-up menu.

• To select a custom color for the filter color, click the Color control’s color swatch to select a color using the Adobe

Color Picker, or click the eyedropper and click a color anywhere on your computer screen.

• To set the amount of color applied to the image, adjust Density.

• To ensure that the image isn’t darkened by the effect, select Preserve Luminosity.

To retain Photo Filter adjustment layers created in Photoshop CS, import the Photoshop file into your After Effects

project as a composition rather than as footage. If you changed your default Photoshop color settings, After Effects

may not be able to exactly match the color of the Photo Filter.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Photo Filter effect color preset categories
Warming Filter (85) and Cooling Filter (80) Color conversion filters that tune the white balance in an image. If an

image was photographed with a lower color temperature of light (yellowish), the Cooling Filter (80) makes the image

colors bluer to compensate for the lower color temperature of the ambient light. Conversely, if the photo was taken

with a higher color temperature of light (bluish), the Warming Filter (85) makes the image colors warmer to

compensate for the higher color temperature of the ambient light.

Warming Filter (81) and Cooling Filter (82) Light balancing filters for minor adjustments in the color quality of an

image. The Warming Filter (81) makes the image warmer (yellower), and the Cooling Filter (82) makes the image

cooler (bluer).

Individual Colors Apply a hue adjustment to the image depending on the color preset you choose. Your choice of

color depends on how you're using the Photo Filter command. If your photo has a color cast, you can choose a

complement color to neutralize the color cast. You can also apply colors for special color effects or enhancements.

For example, the Underwater color simulates the greenish-blue color cast caused when photographing underwater.

PS Arbitrary Map effect
The PS Arbitrary Map effect is intended only to provide compatibility with projects created in earlier versions of

After Effects that use the Arbitrary Map effect. For new work, use the Curves effect.

The PS Arbitrary Map effect applies a Photoshop arbitrary map file to a layer. An arbitrary map adjusts the brightness

levels of an image, remapping a specified brightness range to darker or brighter tones. In the Curves window in

Photoshop, you can create an arbitrary map file for the entire image or for individual channels.
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This effect works with 8-bpc and 16-bpc color.

Original (left), Curves dialog box in Photoshop showing map used (center), result (right)

You can import and apply an arbitrary map file with Options in the Effect Controls panel. When loaded into After

Effects, the specified arbitrary map is applied to the layer or to one or more channels of the layer, depending on how

it was created. If you do not select an arbitrary map, After Effects applies the default map (linear distribution of

brightness) to the layer. Although you can’t import .acv files or Photoshop spline files into the After Effects PS

Arbitrary Map effect, you can convert these files in Photoshop to create files that are compatible with the After

Effects Curves effect.

To convert .acv and Photoshop spline files, load the .acv file (Windows) or the Photoshop spline file (Mac OS) in the

Curves dialog box, click the Pencil tool, and then save the file as an .amp file (Windows) or Photoshop lookup file

(Mac OS).

Adjust the following controls for the PS Arbitrary Map effect:

Phase Cycles through the arbitrary map. Increasing the phase shifts the arbitrary map to the right (as viewed in the

Curves dialog box); decreasing the phase shifts the map to the left.

Apply Phase Map To Alpha Applies the specified map and phase to the layer’s alpha channel. If the specified map

does not include an alpha channel, After Effects uses the default map (linear distribution of brightness) for the alpha

channel.

See also

“Curves effect” on page 413

“To use Arbitrary Map in the Curves effect” on page 414

Shadow/Highlight effect
The Shadow/Highlight effect is suitable for correcting footage with images silhouetted by strong backlighting or for

correcting subjects that have been slightly washed out because of camera lighting. The adjustment is also useful for

brightening up areas of shadow in an otherwise well-lit image.

The Shadow/Highlight effect doesn’t just lighten or darken an image; it lightens or darkens based on the surrounding

pixels in the shadows or highlights. This enables separate controls of the shadows and the highlights. The default

settings are set to fix images suffering from backlighting problems.

This effect works with 8-bpc and 16-bpc color.
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Original (left), and with effect applied (right)

• To correct the shadow and highlight of a given frame relative to surrounding frames, specify a duration of time in

seconds for the Temporal Smoothing control.

• To set the Temporal Smoothing control to ignore frames in different scenes, select Scene Detect.

• To adjust the effect’s transparency, adjust the Blend With Original control.

• For finer control, adjust the controls in the More Options controls group.

The Shadow/Highlight effect provides the following options to help you fine-tune your results:

Shadow Tonal Width, Highlight Tonal Width Controls the range of tones in the shadows or highlights that are

modified. Smaller values restrict the adjustments to only the darker regions for Shadow correction and only the

lighter regions for Highlight correction. Larger values include more tonal regions (such as adding the midtones) that

are being adjusted. A value of 100% produces a linear effect; for Shadow correction, deep shadows get modified the

most with no correction to bright highlights and half the shadow correction to midtones. The tonal width require-

ments vary from image to image. Specifying a value that is too large for a given image might introduce halos around

strong dark to light edges. The default settings attempt to reduce these artifacts. These halos may occur when the

Shadow or Highlight Amount values are too large; they can also be reduced by decreasing these values.

The Tonal Width default value is 50%. If you’re trying to lighten a dark subject but the midtones or lighter regions

are changing too much, try reducing the Shadow Tonal Width towards zero; then only the darkest regions are

lightened. On the other hand, if you need to brighten up the midtones as well as the shadows, increase the Shadows Tonal

Width toward 100%.

Color Correction Fine-tunes the colors in regions that have changed in a color image. For example, if you increase

the Shadows Amount value, you bring out colors that were dark in the original image. You may want these colors to

be more or less vivid. Adjust the Color Correction slider to give the best results. In general, increasing values tends

to produce more saturated colors, and decreasing values produces less saturated colors.

Note: Since the Color Correction value affects only changed portions of the image, the amount of color variation depends

on how much or little Shadows Amount or Highlights Amount is applied. The greater the correction to the shadows and

highlights, the greater the range of color correction available. The Color Correction value applies subtle control over the

darkened or lightened colors in the image. If you want to change the color hues or saturation over the whole image, use

the Hue/Saturation effect after applying the Shadow/Highlight effect.

Midtone Contrast Adjusts the contrast in the midtones. A negative value reduces contrast, and a positive value

increases contrast. An increase in Midtone Contrast adjustment produces greater contrast in the midtones while

tending to darken the shadows and lighten the highlights.

Black Clip, White Clip Specify how much of the shadows and highlights are clipped to the new extreme shadow (level

0) and highlight (level 255) colors in the image. Larger values produce an image with greater contrast. Be careful of

setting the clipping values too large, as this reduces detail in the shadows or highlights as the intensity values get

clipped and sent to pure black or white.
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Tint effect
The Tint effect alters an image’s color information. For each pixel, the luminance value specifies a blend between two

colors. Map Black To and Map White To specify the colors to which dark and bright pixels are mapped. Intermediate

pixels are assigned intermediate values. Amount To Tint specifies the intensity of the effect. The layer’s quality setting

does not affect Tint. For more complex tinting, use the Colorama effect.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left), and with effect applied (right)

Distort effects

Bezier Warp effect (Pro only)
The Bezier Warp effect shapes an image using a closed Bezier curve along the boundary of a layer. The curve consists

of four segments. Each segment has four control points (two vertices and two tangents). The vertices control the

position of the segments, and the tangents control the curvature of the segments.

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Bezier Warp applied (center and right)

The positions of vertices and tangents determine the size and shape of a curved segment. Dragging these points

reshapes the curves that form the edge, thus distorting the image. For example, you can use Bezier Warp to reshape

one image to fit another, as in wrapping a label around a jar. Bezier Warp is also useful for correcting lens aberrations,

such as the fish-eye effect (barrel distortion) that can occur when using a wide-angle lens. Using Bezier Warp, you

can bend the image back to achieve an undistorted look. By animating the effect and choosing a high quality setting,

you can create fluid visual effects, such as a jiggling gelatin dessert or a fluttering flag.

Adjust the following controls for the Bezier Warp effect:

Top Left Vertex Specifies the starting vertex for the top segment or the ending vertex for the left segment.

Top Left Tangent, Top Right Tangent Specify the starting and ending tangents for the top segment.

Right Top Vertex Specifies the ending vertex for the top segment or the starting vertex for the right segment.

Right Top Tangent, Right Bottom Tangent Specify the starting and ending tangents for the right segment.

Bottom Right Vertex Specifies the ending vertex for the right segment or the starting vertex for the bottom segment.
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Bottom Right Tangent, Bottom Left Tangent Specify the ending and starting tangents for the bottom segment.

Left Bottom Vertex Specifies the ending vertex for the bottom segment or the starting vertex for the left segment.

Left Bottom Tangent, Left Top Tangent Specify the ending and starting tangents for the left segment.

Quality Specifies how closely the image follows the shape defined by the curve. The higher the quality value, the

more closely the image follows the shape. Higher quality settings require more rendering time.

Bulge effect (Pro only)
The Bulge effect distorts an image around a specified point, making the image appear to bulge toward or away from

the viewer, depending on the options you select.

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Bulge applied (center and right)

Adjust the following controls for the Bulge effect:

Horizontal Radius Sets the width of the bulge, measured in pixels. You can also set the radius values by dragging the

selection handles in the layer.

Vertical Radius Sets the length of the bulge, measured in pixels. You can also set the radius values by dragging the

selection handles in the layer.

Bulge Center Sets the center point from which the bulge is created.

Bulge Height Sets the depth of the bulge. Positive values push the bulge toward the viewer. Negative values pull the

bulge away from the viewer. A bulge height of 0 produces no bulge, which can be useful for setting keyframes so the

bulge fades in over time.

Taper Radius Sets the steepness of the sides of the bulge. A taper radius of 0 produces a steep, pronounced bulge.

Increasing the taper radius produces a more gradual bulge.

Antialiasing Sets the amount of edge smoothing (blending of colors) at the boundaries of the bulge. Anti-aliasing is

applied only when Best quality is selected for the layer. For many layers, Low produces satisfactory results. High

produces more smoothing but can significantly increase rendering time.

Pin All Edges Prevents the edges of the layer from bulging.

Corner Pin effect (Pro only)
The Corner Pin effect distorts an image by repositioning each of its four corners. Use it to stretch, shrink, skew, or

twist an image or to simulate perspective or movement that pivots from the edge of a layer, such as a door opening.

You can also use it to attach a layer to a moving rectangular region tracked by the Motion Tracker. You can move the

corner pins in the Composition panel or the Effect Controls panel.

This effect works with 8-bpc and 16-bpc color.
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Original (left) and with two variations of Corner Pin applied (center and right)

Displacement Map effect (Pro only)
The Displacement Map effect distorts a layer by displacing pixels horizontally and vertically based on the color

values of pixels in a second layer, called the displacement map. The type of distortion created by the Displacement

Map effect can vary greatly, depending on the displacement map and options you select.

This effect works with 8-bpc and 16-bpc color.

Original (left), displacement map (center) and displaced image (right)

The displacement is determined from the color values of the displacement map. The color values range from 0 to

255. Each value is converted into a scale ranging from -1 to 1. The displacement amount is calculated by multiplying

the converted value by the maximum displacement amount you specify. A color value of 0 produces maximum

negative displacement (–1 maximum displacement). A color value of 255 produces maximum positive displacement.

A color value of 128 produces no displacement. For other values, you can calculate the displacement amount, in

pixels, using the following equation:

displacement = maximum_displacement*(2*(color value – 128)/256)

To distort an image with Displacement Map (Pro only)

1 Select the layer, and choose Effect > Distort > Displacement Map.

2 In the Effect Controls panel, choose the layer to use as the displacement map from the Displacement Map Layer

pop-up menu. After Effects uses the layer in its original form, without any masking, effects, or transformations you

may have applied. If you want to include those alterations, precompose that layer using the Move All Attributes Into

the New Composition option.

3 Choose the channel to use for horizontal displacement and vertical displacement, and enter a maximum

displacement value for each in the Effect Controls panel.

4 Choose a behavior from the Displacement Map Behavior pop-up menu:

Center Map Overlays the displacement map over the layer.

Stretch Map To Fit Resizes the displacement map to the layer’s size.

Tile Map Fills the layer with as many copies of the map as can fit.

5 In Edge Behavior, deselect Wrap Pixels Around to halt the displacement at the edge of the image.
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Liquify effect
The Liquify effect lets you push, pull, rotate, enlarge and shrink areas in a layer. Several Liquify tools distort the brush

area when you hold down the mouse button or drag. The distortion is concentrated at the center of the brush area,

and the effect intensifies as you hold down the mouse button or repeatedly drag over an area.

You can limit the area of a layer you distort using Freeze Area Mask. Use the Reconstruction mode to lessen or undo

distortions you’ve created.

The Liquify effect can extend beyond the boundaries of the target layer. This is useful when the target layer is smaller

than the composition.

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Liquify applied (center and right)

Mask properties for the Liquify effect
Freeze Area Mask Determines the area of the image in which the distortion is affected by mask opacity and feather

settings. Areas outside the mask are distorted; areas within the mask are distorted according to Mask Opacity and

Mask Feather settings.

Mask Opacity Determines how the area within the mask is affected by the distortion. When Mask Opacity is set to

100%, the area within the mask is not affected by the distortion; when it’s set to 50%, the area within the mask is

somewhat affected. If you set the opacity to 100%, make sure to feather the mask to prevent jagged edges on the mask.

Mask Feather The width of the feather used to blend pixels between the masked area and the non-masked area.

Liquify tools
Warp Pushes pixels forward as you drag.

Turbulence Smoothly scrambles pixels. It is useful for creating fire, clouds, waves, and similar effects.

Twirl Clockwise Rotates pixels clockwise as you hold down the mouse button or drag.

Twirl Counterclockwise Rotates pixels counterclockwise as you hold down the mouse button or drag.

Pucker Moves pixels toward the center of the brush area as you hold down the mouse button or drag.

Bloat Moves pixels away from the center of the brush area as you hold down the mouse button or drag.

Shift Pixels Moves pixels perpendicular to the stroke direction.

Reflection Copies pixels to the brush area.

Clone Copies the distortions from around a source location to the current mouse location. Select the source

location by Alt-clicking (Windows) or Option-clicking (Mac OS) the source point.

Reconstruction Reverses distortions or applies them in different ways.

To distort an image with the Liquify effect

1 Select the layer, and choose Effect > Distort > Liquify.
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2 In the Layer panel, create a mask to freeze areas of the image, and then set mask properties.

3 In the Effect Controls panel do the following:

• Choose the mask you created from the Freeze Area Mask pop-up menu.

• Specify a brush size and brush pressure. A low brush pressure makes changes occur more slowly, so it’s easier to

stop them at exactly the right moment.

• Specify a turbulent jitter to control how tightly the Turbulence tool scrambles pixels.

• Select View Mesh under the View Options control.

• Set a distortion mesh offset if desired.

• Drag the Distortion Percentage slider to specify the amount of distortion.

4 Use the tools to distort the preview of the image.

5 Use the Reconstruction tool  to fully or partially reverse the distortions or to change the image in new ways.

(See “To undo distortions with the Liquify effect” on page 426.)

To undo distortions with the Liquify effect

Use the Reconstruction tool and its modes to reverse distortions or redo them in new ways.

1 Select the Reconstruction tool, and then choose a mode from the Reconstruction Mode pop-up menu:

Revert Changes unfrozen areas back to their predistorted state.

Displace Reconstructs unfrozen areas to match the displacement at the starting point for the reconstruction. You

can use Displace to move all or part of the preview image to a different location.

Amplitwist Reconstructs unfrozen areas to match the displacement, rotation, and overall scaling that exist at the

starting point.

Affine Reconstructs unfrozen areas to match all local distortions that exist at the starting point, including

displacement, rotation, horizontal and vertical scaling, and skew.

2 Drag the area to restore. The restoration occurs more quickly at the brush center.

Magnify effect
The Magnify effect enlarges a selected area of a layer. This effect can act like a magnifying glass placed over an area

of the image, or you can use it to scale the entire image far beyond 100% while maintaining resolution.

This effect works with 8-bpc color.

Original (left) and with variations of Magnify applied (center and right)

Adjust the following controls for the Magnify effect:

Shape Specifies the shape of the magnified area.

Center Specifies the center point of the magnified area.
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Magnification Specifies the percentage of magnification (or scale) of the area you select. The values represent the

percentage of the scale.

Link Specifies how the effect links the Size, Magnification, and Feather amounts so that they increase or decrease

proportionally. None specifies that the Size, Magnification, and Feather controls operate separately. Size To Magni-

fication specifies that the size of the magnified area increases or decreases proportionally in relation to the magnifi-

cation adjustment. Size & Feather To Magnification specifies that the size and edge feather of the magnified area

increase or decrease proportionally in relation to the magnification adjustment. Setting the Link control to any

setting except None disables the Resize Layer control.

Size Specifies the size of the magnified area, in pixels. Setting the size larger than your original source layer may

expand the magnified area outside the composition frame, depending upon the location of your center point.

However, the effect still retains the image resolution.

Feather Specifies the amount of feather, in pixels, that the effect applies to the edge of the magnified area. Higher

values soften the edge of the magnified area, and blends the edge with the layer behind it. Lower values sharpen the

edge of the magnified area.

Opacity Specifies the transparency of the magnified area. The Opacity value for the effect layer in the Timeline panel

represents the 100% setting of this control.

Scaling Specifies the type of scaling the effect uses to magnify a layer. Standard uses standard scaling. This method

maintains sharpness in the image but produces pixelated edges at higher values. Soft uses spline algorithms. If you

scale the image beyond 100%, Soft reduces edge pixelation and maintains image quality. Soft works well at large

magnification amounts. Scatter creates scatter or noise in the image as the image enlarges.

Blending Mode Specifies the blending mode that the effect uses to combine the magnified area with the original

layer. Except for None, all of these blending modes behave identically to the Timeline panel blending modes. The

None option displays transparent pixels around the magnified area.

Resize Layer If Resize Layer is selected, the effect uses only the composition boundaries as the edge of the layer when

the magnified area extends beyond the original layer’s boundaries. If Resize Layer is deselected, any area of the image

outside the original layer’s bounding box is cropped by the layer’s boundaries.

Mesh Warp effect (Pro only)
The Mesh Warp effect applies a grid of Bezier patches over a layer, which you can manipulate to distort areas of an

image. Each corner of a patch includes a vertex and two to four tangents (points that control the curvature of the line

segment that makes up the edge of the patch). The number of tangents depends on whether the vertex is in a corner,

on an edge, or inside the grid. By moving the vertices and tangents, you can manipulate the shape of the curved line

segment. The finer the grid, the tighter the adjustments you can make to the area of the image inside the patch.

You can also use Mesh Warp to create smooth transitions between multiple images and layers. Using keyframes for

effects and opacity, you can animate the transition between layers, revealing and distorting layers over time.

This effect works with 8-bpc and 16-bpc color.

Original (left), with distortion mesh (center) and with Mesh Warp applied (right)
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To select multiple vertices, Shift-click the vertices.

Adjust the following controls for the Mesh Warp effect:

Rows, Columns Specify up to 31 patches vertically (Rows) or horizontally (Columns). For broader distortion, use

fewer patches. For finer control, use more. Drag the vertices and tangents to change the grid shape. The image follows

the grid shape according to the elasticity setting and the boundary created by the adjacent patch.

Quality Specifies how closely the image follows the shape defined by the curve. The higher the quality value, the

more closely the image follows the shape. Higher quality settings require more rendering time.

Distortion Mesh Click the stopwatch to animate the distortion over time.

Note: Each patch becomes a boundary for the distortion. For example, when you stretch a patch, the area of the image

in the patch stretches, squishing the area of the image in the adjacent patch. The boundary of the adjacent patch protects

the image inside it from being squished to zero. In other words, you can’t push an image out of its patch.

Mirror effect
The Mirror effect splits the image along a line and reflects one side onto the other. Reflection Center specifies the

position of the line. Reflection Angle determines which side is reflected and where the reflection appears. An angle

of 0 degrees reflects the left side onto the right. An angle of 180 degrees reflects the right side onto the left. An angle

of 90 degrees reflects the top onto the bottom. An angle of 270 degrees reflects the bottom onto the top. The layer’s

quality setting influences the Mirror effect. At Best quality, the reflected image is smoother and more accurate.

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Mirror applied (center and right)

Offset effect
The Offset effect pans the image within a layer. Visual information pushed off one side of the image appears on the

opposite side. At Best quality, the offset is performed with subpixel precision.

Shift Center To specifies the new position of the original image’s center point. Blend With Original specifies the

amount by which the offset image is blended with the original image.

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Offset applied (center and right)
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Optics Compensation effect (Pro only)
Use the Optics Compensation effect to add or remove camera lens distortion. Elements composited with

mismatched lens distortion cause anomalies in the animation. For example, tracked objects in a distorted scene don’t

match the scene area because linear objects don’t follow the distortion of the scene.

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Optics Compensation applied (center and right)

Adjust the following controls for the Optics Compensation effect:

Field Of View (FOV) Specifies the field of view (FOV) of the distorted footage. The FOV is relative to the size of the

source layer and the selected FOV Orientation. The distortion amount is relative to FOV. There is no general rule as

to what FOV value applies to different lenses. Zooming in reduces the FOV, and zooming out increases it. Conse-

quently, if footage includes different zoom values, you’ll need to animate the FOV value.

Reverse Lens Distortion Reverses the lens distortion. For example, to remove wide-angle lens distortion, set Field Of

View to 40.0 and select Reverse Lens Distortion. Selecting Reverse Lens Distortion enables the Resize control.

FOV Orientation Specifies the axis on which the Field Of View value is based. This is useful when matching

computer-generated elements to the rendered view angle.

View Center Specifies an alternate center point of view. This is useful when using custom lenses that are not centered.

However, in most cases, this control should be left untouched.

Optimal Pixels Maintains as much pixel information as possible through the distortion. When selected, FOV values

are no longer reversible.

Resize Resizes the layer when the applied distortion stretches the layer beyond its boundaries. To use this control,

first select Reverse Lens Distortion, and then choose an option. Off does not resize the layer. Max 2X resizes the layer

to a maximum of twice the original width and height. Max 4X resizes the layer to a maximum of four times the

original width and height. Unlimited resizes as far as the layer is stretched. This option may require a large amount

of memory.

To add and match lens distortion with Optics Compensation (Pro only)

To match FOV values, layers must be the same size. However, if you select Resize, you can apply Optics Compen-

sation again and reverse the distortion using the same value (reversed). You can then apply another effect between

the two instances of Optics Compensation.

If you resize a layer using Optics Compensation and then precompose it into a larger composition, you cannot

reverse the distortion using the same value until you enlarge the precomposed layer to accommodate the expanded

layer.

1 Select the footage layer with the distortion, and choose Effect > Distort > Optics Compensation.

2 In the Effect Controls panel, adjust the FOV until a distorted edge or line appears straight. Note the FOV value.

3 Select the computer graphic layer you want to distort, and apply Optics Compensation to it using the FOV value

from step 2.
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4 Select Reverse Lens Distortion.

5 Remove Optics Compensation from the footage layer.

Polar Coordinates effect
The Polar Coordinates effect distorts a layer by transposing each pixel in the layer’s (x,y) coordinate system to the

corresponding position in the polar coordinate system, or the reverse. This effect produces unusual and surprising

distortions that can vary greatly depending on the image and the controls you select. The standard coordinate system

specifies points by measuring the horizontal distance (x axis) and the vertical distance (y axis) from the origin. Each

point is specified as (x,y). The polar coordinate system specifies points by measuring the length of a radius from the

origin (r) and its angle from the x axis ( ). Each point is specified as (r, ).

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Polar Coordinates applied (center and right)

Adjust the following controls for the Polar Coordinates effect:

Interpolation Specifies the amount of distortion. At 0% there is no distortion.

Type of Conversion Specifies the conversion process to use. Choose one of the following options:

• Rect To Polar Moves pixels by using (x,y) coordinates from each pixel as (r, ) coordinates. For example, an (x,y)

coordinate of (2,3) becomes a polar coordinate with a radius of 2 and a degree of 3. Horizontal lines distort into

circles, and vertical lines into radial lines.

• Polar To Rect Moves pixels by using the (r, ) coordinates from each pixel as the (x,y) coordinates. For example,

a polar coordinate of radius 10 and 45 degrees becomes an (x,y) coordinate of (10,45).

Reshape effect (Pro only)
The Reshape effect transforms one shape into another shape on the same layer, dragging the underlying image with

it. The image is distorted to fit the shape of the new area. You create or import up to three masks to define the area

you want to distort: the source mask, the destination mask, and the boundary mask (optional).

This effect works with 8-bpc and 16-bpc color.

Original including three masks (left) and with variations of Reshape applied (center and right)
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By default, After Effects assigns the masks a function (source, destination, or boundary) based on the order in which

you create or import them. You can also specify different masks. Use a closed path for each mask. All three masks

must be on the same layer as the footage to which you will apply the Reshape effect, although you can copy masks

from another layer.

As with the Mesh Warp effect, you can use Reshape to create unusual transitions between multiple images and layers.

Using keyframes for effects and opacity, you can animate the transition between layers, revealing and distorting

layers over time.

Controls for the Reshape effect (Pro only)
Source Mask Specifies the mask that contains the image area you want to reshape. If not specified, After Effects uses

the second mask created as the Source mask. In the Composition and Layer panels, a red outline defines the source

mask.

Destination Mask Specifies the mask that determines the shape of the final image. If not specified, After Effects uses

the third mask created as the Destination mask. In the Composition and Layer panels, a yellow outline defines the

destination mask.

Boundary Mask Specifies what part of the image is reshaped. Anything outside the boundary is not altered. If not

specified, After Effects uses the first mask created as the Boundary mask. In the Composition and Layer panels, a

blue outline defines the boundary mask.

Percent Specifies the amount of reshaping. This value is useful for creating partial distortions that grow over time.

Elasticity Specifies how closely the image follows the shape defined by the curve. Stiff acts like cold rubber, allowing

the image to distort the least amount. Super Fluid acts like hot rubber, allowing the image to distort in a fluid fashion.

The other settings fall between. The more fluid elasticity settings require more rendering time. If the final image

doesn’t follow the curve as expected, use the following elasticity guidelines:

• In general, use the stiffest setting possible that doesn’t create a polygonal image. Use a higher elasticity setting if

the final image looks polygonal but the curves are smooth.

• Use Stiff, Less Stiff, or Below Normal if the source and destination masks are similar in shape and have low

curvature (few curved segments that change direction radically).

• Use Normal, Absolutely Normal, or Above Average if the source and destination masks are dissimilar and have

mild curvature.

• Use Loose, Liquid, or Super Fluid if the masks are very dissimilar and have extreme curvature.

Correspondence Points Specifies the number of points on the source mask that are associated with, or mapped to,

points on the destination mask. These points appear in the Composition panel and control the interpolation of the

distortion through space. To control the precision of the effect, you can add, delete, or move the points on either

mask. A mask can have an unlimited number of points, but the more points it has, the longer the effect takes to

render. If the distortion appears twisted, try adding more correspondence points at distinguishing points along the

masks. (If the arc lengths of the curves between correspondence points are too different, twisting may result.)

Interpolation Method Specifies how After Effects determines the distortion of each video or animation frame in the

interval between keyframes or when no keyframes exist.

• Discrete  Requires no keyframes because it calculates the distortion at each frame. Discrete produces the most

accurate results but requires more rendering time.

• Linear  (The default) Requires two or more keyframes and performs a straight-line interpolation between the

keyframes. Linear produces steady changes between keyframes and sharp changes at keyframes.



ADOBE AFTER EFFECTS 7.0
User Guide

432

• Smooth Requires three or more keyframes and approximates the distortion using cubic curves, producing distor-

tions with graceful motion.

To use the Reshape effect (Pro only)

1 Open the layer in a Layer panel.

2 Create or import the source, destination, and boundary masks into the layer.

Name each mask so that you can easily recognize it in the Mask menu in the Effect Controls panel.

3 In the Timeline panel, choose None from the Mode pop-up menu for each mask.

4 Position the boundary mask to specify the area of the image that will remain unaltered. Areas within the boundary

mask will be distorted; areas outside the mask will remain unaltered. Keep the boundary mask as far away as possible

from the source and destination masks to avoid foldovers.

5 Scale and position the source mask over the image.

6 Scale and position the destination mask to indicate the final shape. Distortions work best if the source and desti-

nation masks are in approximately the same location.

7 Make the Composition or Timeline panel active, select the layer, and then choose Effect > Distort > Reshape.

8 From the Mask menus, choose the source, destination, and boundary masks.

9 Adjust the Percent control, and choose an option for Elasticity.

10 In the Composition panel, add, delete, or move correspondence points on the masks to control the distortion:

• To add a point, Alt-click (Windows) or Option-click (Mac OS) the mask.

• To delete a point, Alt-click or Option-click the point.

• To move a point, drag it to a new location.

• To change the interpolation of a pair of points, Shift-click a point. Smooth interpolation works best with round

masks, while linear interpolation works best with angular masks. You can combine smooth and linear interpo-

lation in the same composition.

11 Choose an interpolation method, and preview the distortion. If Linear or Smooth produces undesired results,

add more keyframes. If Discrete produces undesired results, choose another method.

Ripple effect
The Ripple effect creates the appearance of ripples in a specified layer, moving away from a center point in concentric

circles. The effect is similar to dropping a stone in a pond. You can also specify that ripples move toward the center

point.

Animate ripples at a constant speed using the Wave Speed control. This control does not require keyframes for

animation. Animate ripples at varying speeds by creating keyframes for the Ripple Phase control.

This effect works with 8-bpc and 16-bpc color.
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Animated Ripple effect

Adjust the following controls for the Ripple effect:

Radius Controls the distance the ripples travel from the center point. The Radius value is a percentage of the image

size. If the center of the ripple is the center of the layer and the radius is set to 100, the ripples travel to the edge of

the image. A value of 0 produces no ripples. Like ripples in water, ripples in the layer become smaller as they travel

farther from the center.

To create a single-wave ripple, set Radius to 100, Wave Width between 90 and 100, and Wave Height as desired.

Center Of Ripple Specifies the center of the effect.

Type Of Conversion Specifies how the ripples are created. Asymmetric produces more realistic-looking ripples;

asymmetric ripples include lateral motion and produce more distortion. Symmetric produces motion that travels

only outward from the center point; symmetric ripples produce less distortion.

Wave Speed Sets the speed at which the ripples travel outward from the center point. When you specify a wave

speed, the ripples are automatically animated at a constant speed (without keyframes) across the time range. A

negative value makes the ripples move toward the center, and a value of 0 produces no movement. To vary wave

speed over time, set this control to 0, and then create a keyframe for the Ripple Phase property of the layer.

Wave Width Specifies the distance, in pixels, between wave peaks. Higher values produce long, undulating ripples,

and low values produce many small ripples.

Wave Height Specifies the height of the ripple wave. Taller waves produce greater distortion.

Ripple Phase Specifies the point along the waveform at which a wave cycle begins. The default value of 0 degrees

starts the wave at the midpoint of its downward slope; 90 degrees starts it at the lowest point in the trough; 180

degrees starts it at the midpoint of the upward slope, and so on.

Smear effect
Using the Smear effect, you define an area within an image and then move that area to a new location, stretching, or

smearing, the surrounding part of the image with it. Use masks to define the area you want to distort.

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Smear applied (center and right)
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To use Smear, first create or import two masks: the source mask and the boundary mask. You can create masks on

the layer in After Effects or use masks created in Adobe Illustrator. To use a mask created in Illustrator, copy the mask

and paste it into a layer in After Effects. Masks must be closed to work with Smear; if a mask is an open trace, After

Effects closes it when you select it. Both masks must be on the same layer as the footage to which you will apply the

Smear effect, although you can copy masks from another layer.When you move the source mask within the image,

Smear stretches the portion of the image inside the boundary mask to follow the edges of the source mask. The

boundary mask tries to protect the image outside it from being stretched. Both the original position of the source

mask (set in the Layer panel) and the offset position of the source mask are displayed in the Composition panel. The

first position of the source mask is indicated by a light red outline, and the new position is indicated by a dark outline.

Using keyframes, you can animate the position, size, and rotation of the source mask as it moves to its offset position.

You can also animate the original position of the source mask in the Layer panel using keyframes.

Processing can take up to several minutes with certain settings. Computation time increases as the source mask gets

closer to the boundary mask. Processing is interrupted when you click a control.

Adjust the following controls for the Smear effect:

Source Mask Specifies a mask as the source mask. By default, After Effects selects the second mask you create or

import for the layer as the source mask.

Note: You must specify both a boundary mask and a source mask to create a distortion.

Boundary Mask Specifies a mask as the boundary mask. By default, After Effects selects the first mask you create or

import as the boundary mask.

Mask Offset Specifies a destination position for the source mask. The offset is a position specified by x and y coordi-

nates, which appear to the right of the Offset button. To set an offset location, click the Offset button, and then click

the image in the desired location. To set the offset position numerically, type a new value for each axis. When you

don’t need the precision provided by Mask Offset, you can simply drag the source mask offset in the Composition

panel.

Note: Unwanted undulations may occur if the source mask is close to the boundary mask during animation.

Mask Rotation Rotates the source mask around its center point, between 0 and 360 degrees.

Mask Scale Scales the source mask (at its offset position) larger or smaller, in relation to its original position.

Percent Specifies what percentage of the smear is actually performed. For example, when Percent is set to 50%,

Smear performs half of the smear you have specified by moving, scaling, and rotating the source mask. This value

doesn’t affect the location of the original and offset positions of the source mask; it affects only the percentage of the

effect that is performed.

Elasticity Specifies how closely the image follows the shape defined by the curve. Stiff distorts the least, while Super

Fluid distorts the most. In general, use the stiffest setting possible that doesn’t create polygonal images.

Interpolation Method Specifies a method for the interpolation that Smear performs between keyframes. Linear

requires two or more keyframes and performs a straight-line interpolation between the keyframes. Discrete

produces animations in which the distortions change at keyframes. Smooth requires three or more keyframes and

approximates the distortion using cubic curves, producing distortions with graceful motion. If you need further

accuracy in the animation between keyframes, add more keyframes. For example, a distortion representing a 90-

degree rotation between two keyframes appears as a folding of the image. To make this distortion more fluid, add a

keyframe for every 10 degrees.

To use the Smear effect

1 Open the layer in a Layer panel.
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2 Create or paste the masks you will use as the boundary mask and the source mask.

3 Position the boundary mask to specify the area of the layer you do not want Smear to affect.

4 Scale and position the source mask over the area you want to move.

5 Make the Composition panel active, and choose Effect > Distort > Smear.

6 Enter a Percent value to specify the amount of smear applied.

7 In the Composition panel, move the source mask to its destination position by dragging it or by using the Mask

Offset value.

8 Use the Mask Rotation control to rotate the source mask, and use the Mask Scale control to scale it.

9 Drag the Percent slider as needed, and choose a setting for Elasticity.

Spherize effect
The Spherize effect distorts a layer by wrapping a region of the image onto a spherical shape of variable size. The

layer’s quality setting influences the Spherize effect. Best quality samples the displaced pixels to subpixel accuracy;

Draft quality samples to the nearest whole pixel.

The Radius option specifies the radius of the sphere in pixels. You can exceed the highest slider value by clicking the

Radius value and typing a higher number in the dialog box. Center Of Sphere specifies the position of the sphere’s

center on the layer.

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Spherize applied (center and right)

Transform effect
The Transform effect applies 2D geometric transformations to the source layer. This effect supplements the

transform properties available for each layer in the Timeline panel. Using the Transform effect, you can skew a layer

along any axis. Also, if motion blur is enabled in the Switches column, you can specify motion blur independently of

the composition’s shutter angle. Anchor Point, Position, Rotation, and Opacity function the same as the layer

transform properties in the Timeline panel.

Note: This effect is relative to the input layer. Therefore, to make a layer rotate around the upper left corner, open the

Layer panel, choose Transform from the Layer panel menu, and then move the anchor point and the position to the upper

left corner.

This effect works with 8-bpc and 16-bpc color.
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Original (left) and with variations of Transform applied (center and right)

Adjust the following controls for the Transform effect:

Scale Height Scales height up or down as a percentage of the current layer height.

Scale Width Scales width up or down as a percentage of the current layer width.

Skew Specifies skew amount.

Skew Axis Specifies the axis on which the skew is based. Changing the skew axis has no effect if Skew is 0.

Use Composition’s Shutter Angle Specifies that the Transform effect uses the shutter angle of the composition when

performing motion blur. If this control is not selected, the Transform effect uses the option for the Shutter Angle

control.

Shutter Angle Determines the amount of motion blur to apply to the layer if Motion Blur is enabled for the layer.

Uniform Scale Scales both the width and the height of an image.

Turbulent Displace effect
The Turbulent Displace effect uses fractal noise to create turbulent distortions in an image. This effect is useful for

adding distorted movement to a layer. For example, use it to create flowing water, funhouse mirrors, and waving

flags.

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Turbulent Displace applied (center and right)

Adjust the following controls for Turbulent Displace:

Displacement Specifies the type of turbulence used. Turbulent, Bulge, and Twist warp the image in slightly different

directions. Turbulent Smoother, Bulge Smoother, and Twist Smoother each perform the same operation as

Turbulent, Bulge, and Twist, except that they create smoother warps and may take longer to render. Vertical

Displacement warps the image vertically only. Horizontal Displacement warps the image horizontally only. Cross

Displacement warps the image both vertically and horizontally.

Amount Specifies the amount of displacement in the layer. Higher values result in more distortion in the layer.

Size Specifies the size or radius of the displaced or distorted areas in the layer. Higher values result in larger areas of

distortion.
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Offset (Turbulence) Specifies the portion of the fractal shape that is present in the Composition panel, altering the

shape of the distortion on your layer. Because the fractal shapes used are infinite in all directions, what appears in

the Composition panel is only a small portion of the entire fractal. The Composition panel behaves like a fixed

viewing area, and the Offset control repositions the fractal within that view, which then brings a different portion of

the fractal into view. This alters the shape of the distortion.

Complexity Specifies the level of detail in the turbulence. Increasing the Complexity value increases the detailed

definition in the displacement pattern. Lower values result in smoother distortions.

Evolution Specifies the changes of the turbulence over time. Evolution values are progressive, not looping. The

image continues to change with each added revolution. The appearance of the image when this option is set to 0 is

different from that at 1 revolution, which, in turn, is different from that at 2 revolutions, and so on. The evolution

state progresses infinitely at each new value. To force the Evolution setting to return to its original state (necessary

to create a seamless loop) set the Evolution Options control to Cycle Evolution.

Set keyframes for Evolution to determine how much the turbulence evolves over the period of time allowed between

keyframes. The more revolutions that are made between keyframes, the more rapidly the turbulence changes. Higher

values may result in flashing rather than smooth changes.

Evolution Options Specifies how the effect’s evolution values are rendered. This control is useful to create one short

seamless evolution cycle (where the last frame matches up to the first) to be prerendered and looped as a new source

layer in a composition, rather than setting Evolution to animate over a greater number of frames. Options include

the following:

• Cycle Evolution  Creates a cycle of evolution that loops over a set amount of time. Cycle Evolution returns the

evolution state to its starting point to create a smooth, progressive, looping animation. Copied and pasted evolution

keyframes start and end with the same value, and the resulting animation repeats, rather than producing a smoothly

transitioning cycle.

• Cycle Specifies the number of revolutions of the Evolution setting that the fractal noise cycles through before it

repeats. The amount of time allowed between evolution keyframes determines the timing or speed of these evolution

cycles. Higher values create longer render times. Cycle affects only the state of the fractal, not geometrics or other

controls. For example, two identical states of the fractal don’t appear the same if viewed with different Size or Offset

settings.

• Random Seed  Specifies a unique random value from which to generate the turbulence. Animating the random

seed value results in flashing from one set of fractal shapes to another within that fractal type. For smooth transition

of the turbulence, use the Evolution control.

Pinning Specifies how the effect pins the edges of an image so that it remains in its initial position. The None option

pins no layer edges. Pin All, Pin Horizontal, and Pin Vertical minimize the effect of the turbulence on the corre-

sponding layer edges. All Locked Options locks the layer edge so that turbulence doesn’t affect it.

Resize Layer Enables the distorted image to expand past the layer’s bounding box.

Antialiasing For Best Quality Specifies the level of anti-aliasing of the displacement pattern. This control works best

if the layer is set to Best quality in the Timeline panel.

To create a seamless loop using Turbulent Displace

1 Set two keyframes for the Evolution control, using full revolutions only.

2 Adjust the time allowed between keyframes, and the number of Evolution revolutions until you are satisfied with

the appearance of the displacement.

3 Under Evolutions Options, select Cycle Evolution.
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4 Under Evolutions Options, drag the Cycle slider to set a value for Cycle that is evenly divisible by the number of

revolutions you set for Evolution.

5 Move the current-time indicator to the point on the Timeline panel where the Cycle completes. For example, if

the Cycle value is 2, find the frame on the Timeline panel where the Evolution value is 2 revolutions.

6 Move the current-time indicator back one frame. (Because the cycle begins again at the last frame, moving the

current-time indicator back prevents a duplicate frame in the seamless loop.)

7 Trim the layer’s Out point.

8 Prerender this layer, and import it into your project.

9 Set this prerendered footage item to loop. (See “To loop footage” on page 125.)

Note: If you set keyframes for any of the other controls, you must return them to their initial settings at the point on the

Timeline panel where the cycle begins to repeat. Otherwise, these properties don’t loop.

Twirl effect
The Twirl effect twirls the pixels of an image a specified amount around a specified point. Pixels nearer the center

point are twirled faster than pixels in outer regions, resulting in a whirlpool appearance. Because distortion in this

effect is significant, After Effects uses special anti-aliasing techniques to produce the highest-quality image. As a

result, the Twirl effect can be particularly slow to render.

This effect works with 8-bpc and 16-bpc color.

Twirling a layer

Adjust the following controls for the Twirl effect:

Angle Specifies how far and in which direction to twirl the image around the twirl center. Positive angles twirl the

image clockwise; negative angles twirl it counterclockwise. To animate the twirl as a whirlpool, set keyframes for the

angle.

Twirl Radius Specifies how far the twirl extends from the twirl center. This value is based on a percentage of the

maximum horizontal or vertical distance of the layer, whichever is greater. A value of 50, for example, produces a

twirl that extends to the edge of the layer.

Warp effect
Use Warp to distort or deform After Effects layers. The 15 warp styles work much like the Warp effects in Adobe

Illustrator and Warp Text in Adobe Photoshop.

This effect works with 8-bpc and 16-bpc color.
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Warping a layer

Wave Warp effect
The Wave Warp effect produces the appearance of a wave traveling across an image. You can produce a variety of

different wave shapes, including square, circular, and sine waves. The Wave Warp effect is automatically animated at

a constant speed across the time range (without keyframes or expressions). To vary speeds, you need to set keyframes

or expressions.

This effect works with 8-bpc and 16-bpc color.

Original (left) and with variations of Wave Warp applied (center and right)

Adjust the following controls for the Wave Warp effect:

Wave Type Specifies the shape of the wave.

Wave Height Specifies the height of the wave. Taller waves generally produce greater distortion.

Wave Width Specifies the distance, in pixels, between wave peaks. Smaller values produce more waves.

Direction Specifies the direction the wave travels across the image. For example, a value of 90 degrees makes waves

travel from left to right. A value of 180 degrees makes waves travel from top to bottom, and a value of 225 degrees

makes the waves travel diagonally from upper right to lower left.

Wave Speed Sets the speed (cycles per second) at which the waves travel. When you specify Wave Speed, the ripples

are automatically animated at a constant speed across the time range (without keyframes). Click the Wave Speed

value to specify negative values or values greater than 5. A negative value reverses the wave direction, and a value of

0 produces no movement. To vary wave speed over time, set this control to 0, and then set keyframes for the Phase

property of the layer.

Pinning Specifies areas of the image to be excluded from the wave. For example, if All Edges is selected, the wave

does not travel across the edges of the image.

Phase Specifies the point along the waveform at which a wave cycle begins. The default value of 0 degrees starts the

wave at the midpoint of its downward slope; 90 degrees starts it at the lowest point in the trough; 180 degrees starts

it at the midpoint of the upward slope, and so on.

Antialiasing Sets the amount of anti-aliasing, or edge smoothing, to perform on the image. Anti-aliasing is applied

only when the layer is set to Best quality. In many cases, lower settings produce satisfactory results; a high setting can

significantly increase rendering time.
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Generate effects

4-Color Gradient effect
The 4-Color Gradient effect produces a four-color gradient. Each color is controlled by one of four individual effect

points, which can be animated. Use 4-Color Gradient to create color backgrounds, mix color palettes, and generate

color gradients.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for 4-Color Gradient:

Points Adjusts the positioning of each color within the four-color gradient, based on (x,y) coordinate values.

Colors Specifies the RGB color values for each of the four points. Color 1 sets the color of Point 1, Color 2 sets the

color of Point 2, and so on.

Blend Specifies the blending of the gradient. The gradient is actually composed of four circles, each blending with

one another as the result of a calculation between one circle’s radius and that of the other surrounding circles. The

amount of blending depends on the location of the effect points.

Jitter Specifies the amount of jitter (noise) in the gradient when blending is applied. Jitter uses a controlled noise

type to change pixel values in the gradient, in order to reduce banding. The jitter noise affects only those areas where

banding could occur.

Opacity Specifies the transparency of the gradient. The lower the value, the more transparent the gradient. The

original source layer’s opacity value represents 100% opacity in the effect.

Blending Mode Specifies how the gradient colors interact with the original layer colors.

Advanced Lightning effect (Pro only)
The Advanced Lightning effect creates simulations of electrical discharges. Unlike the Lightning effect, Advanced

Lightning doesn't self-animate and includes the Alpha Obstacle feature, which lets you move the lightning around

designated objects in the frame. Use Advanced Lightning when you want more control over the lightning than is

available using the Lightning effect.

This effect works with 8-bpc color.

Original (left), with breaking lightning type (center), and with bouncy lightning type (right)
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Adjust the following controls for Advanced Lightning:

Conductivity State Changes the path of the lightning.

Core Settings These controls adjust various characteristics of the lightning’s core.

Glow Settings These controls adjust the lightning’s glow.

Note: To disable the glow, set Glow Opacity to 0. This setting can speed up rendering time significantly.

Alpha Obstacle Specifies the influence of the original layer’s alpha channel on the path of the lightning. The

lightning attempts to wrap itself around opaque areas of the layer’s alpha channel, seeing them as an obstacle.

Note: If Alpha Obstacles is set to a value other than 0, it's not always possible to preview the correct result in less than

full resolution; full resolution may reveal new obstacles. Be sure to check the result in full resolution before final

rendering.

Turbulence Specifies the amount of turbulence in the lightning path. Higher values result in a more complex strike

containing more branches and forks, and lower values produce simpler strikes with fewer branches.

Forking Specifies what percentage of a branch is forked. Its value is influenced by Turbulence and Alpha Obstacle

settings.

Decay Specifies the amount of continuous decay or dissipation of the lightning strength and influences where the

opacity of the forks begins to fade.

Decay Main Core Decays the main core along with its forks.

Add To Original Composites the lightning with the original layer using the Add blending mode. When deselected,

only the lightning is visible.

Lightning Type Specifies the characteristics of the lightning.

Note: The type determines the nature of the Direction/Outer Radius contextual control. In the Breaking type, the

branches are focused toward the Direction point as the distance between Origin and Direction increases.

Origin Specifies the point of origin for the lightning.

Direction, Outer Radius This control changes depending on the Lightning Type:

• Not In Use  Is available only when Vertical isn’t selected.

• Outer Radius Specifies the distance that the lightning travels from its origin. It is enabled when Omni or

Anywhere is selected as the lightning type. Use this control to terminate the lightning at a defined distance from the

origin.

• Direction Specifies the direction that the lightning will travel. It is enabled when any of the following lightning

types are selected: Direction, Strike, Breaking, Bouncy, and Two-Way Strike.

Complexity Specifies the complexity of the turbulence in the lightning.

Min. Fork distance Specifies the minimum pixel distance between new forks. Lower values create more forks in the

lightning. Higher values result in fewer forks.

Termination Threshold Specifies the level at which a path terminates, based on resistance in the atmosphere and

possible alpha collision. At lower values, the path terminates more easily when encountering resistance or alpha

obstacles. At higher values, the path more persistently moves around alpha obstacles.

Note: Increasing Turbulence or Complexity values causes resistance to increase in some areas. These areas change as

conductivity changes. Increasing the Alpha Obstacle value causes resistance to increase at alpha edges.
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Main Core Collision Only Calculates collisions only on the main core. The forks are not affected. This control is

relevant only when you select Alpha Obstacle.

Fractal Type Specifies the type of fractal turbulence used to create the lightning.

Core Drain Specifies the percentage by which the core strength is drained when creating a new fork. Increasing this

value reduces the opacity of the core where new forks appear. Because forks draw their strength from the main core,

decreasing this value reduces the opacity of the forks as well.

Fork Strength Specifies the opacity of the new fork. This amount is measured as a percentage of the Core Drain

value.

Fork Variation Specifies the amount of variation in the opacity of the fork and determines how much the fork opacity

will deviate from the amount set for Fork Strength.

Audio Spectrum effect
Apply the Audio Spectrum effect to a video layer to display the audio spectrum of an audio layer. The effect displays

the magnitude of frequencies in the range you define using Start Frequency and End Frequency. This effect can

display the audio spectrum in a number of different ways, including along a Bezier path of a layer. Apply the effect

to a layer that contains a solid or an image, and that may contain audio.

Note: Audio Spectrum uses the audio source footage without time-remapping, effects, stretch, or levels. To display the

spectrum with such effects, precompose the audio layer before applying the Audio Spectrum effect.

This effect works with 8-bpc color.

Original (left), and with effect applied (center and right)

Adjust the following controls for the Audio Spectrum effect:

Audio Layer Specifies the audio layer you want to display as a spectrum.

Start Point, End Point Specifies the position at which the spectrum starts or ends if Path is set to None.

Path The audio spectrum is displayed along the path of the layer, unless None is chosen.

Use Polar Path Specifies the path to start from a single point and displays as a radial graph.

Start Frequency, End Frequency Specify the first and last frequency, in hertz, of the range of frequencies being

displayed.

Frequency Bands Specifies the number of frequencies displayed.

Maximum Height Specifies the maximum height, in pixels, of a displayed frequency.

Audio Duration Specifies the duration of audio, in milliseconds, used to calculate the spectrum.

Audio Offset Specifies the time offset in milliseconds used to retrieve the audio.

Thickness Specifies the thickness of the bands.

Softness Specifies how feathered or blurry the bands appear.
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Inside Color, Outside Color Specifies the inside and outside colors of the bands.

Blend Overlapping Colors Specifies that overlapping spectrums are blended.

Hue Interpolation If value is greater than 0, the frequencies displayed rotate through the hue color space.

Dynamic Hue Phase When selected, and the Hue Interpolation is greater than 0, the Start color shifts to the

maximum frequency in the range of displayed frequencies. This allows the hue to follow the fundamental frequency

of the spectrum displayed as it changes.

Color Symmetry When selected, and the Hue Interpolation is greater than 0, the start and end colors are the same.

This allows color continuity on closed paths.

Display Options Specifies whether to display frequency as Digital, Analog Lines, or Analog Dots.

Side Options Specifies whether to display the spectrum above the path (Side A), below the path (Side B), or both

(Side A & B).

Duration Averaging Specifies that audio frequencies are averaged to reduce randomness.

Composite On Original When selected, displays the original layer with the effect.

Audio Waveform effect
Apply the Audio Waveform effect to a video layer to display the audio waveform amplitude of an audio layer. You

can display the audio waveform in a number of different ways, including along a Bezier path created by an open or

closed mask of a layer.

Note: Audio Waveform uses the audio source footage without time-remapping, effects, stretch, or levels. To display the

spectrum with such effects, precompose the audio layer before applying the Audio Waveform effect.

This effect works with 8-bpc color.

Original (left), and with effect applied (center and right)

Adjust the following controls for the Audio Waveform effect:

Audio Layer Specifies the audio layer you want to display as a waveform.

Start Point, End Point Specifies the position at which the waveform starts and ends, if Path is set to None.

Path If set to None, the audio waveform is displayed along the path of the layer.

Displayed Samples Specifies the number of samples to display in the waveform.

Maximum Height Specifies the maximum height, in pixels, of a displayed frequency.

Audio Duration Specifies the duration of audio, in milliseconds, used to calculate the waveform.

Audio Offset Specifies the time offset in milliseconds used to retrieve the audio.

Thickness Specifies the thickness of the waveform.

Softness Specifies how feathered or blurry the waveform appears.
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Random Seed (Analog) Specifies a starting point for randomizing the effect. Random Seed starts the randomizing

at a different point, changing the appearance of the waveform.

Inside Color, Outside Color Specifies the inside and outside colors of the waveform.

Waveform Options Specifies how to display a stereo audio waveform. Mono combines the left and right channels of

the audio layer. Non-stereo audio layers play as Mono.

Display Options Specifies how to display the audio waveform. Digital displays each sample as a single vertical line

connecting the minimum and maximum source sample. This option simulates the display used on digital

equipment. Analog Lines displays each sample as a line connecting the previous and next sample from either the

minimum or maximum audio source sample. This option simulates the retrace seen in the display of an analog oscil-

loscope. Analog Dots displays each sample as a dot representing either the minimum or maximum audio source

sample.

Beam effect
The Beam effect simulates the movement of a beam, such as a laser beam. You can make the beam shoot, or you can

create a wand-like beam with stationary start and end points. This effect uses a 3D perspective based on the change

in Starting Thickness and Ending Thickness. The beam looks best when motion blur is enabled and the shutter angle

is set to 360.

This effect works with 8-bpc color.

Original (left) and with a simulated beam (right)

The Length control specifies the length of the beam based on a percentage of the Time specified. For example, a

setting of 100% means that the visible beam length is at its maximum when the Time control is 50%. Time specifies

the time of the beam’s travel from start to end as a percentage. The 3D Perspective control uses 3D perspective when

animating Time.

Cell Pattern effect
The Cell Pattern effect generates cellular patterns based on cellular noise. Use it to create static or moving

background textures and patterns. The patterns can be used in turn as textured mattes, as transition maps, or as a

source for displacement maps.

This effect works with 8-bpc color.

The crystal cell pattern creates a displacement map (center) that is used with the Displacement Map effect (right).
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Adjust the following controls for the Cell Pattern effect:

Cell Pattern Choose a pattern from the menu. HQ denotes high-quality patterns that render with more definition

than their unmarked counterparts. Mixed Crystals is available only as a high-quality option. The patterns appear as

pictured below:

Note: The Static Plates option is identical in appearance to the Plates option. However, when evolving, the static plates

retain a uniform lightness value, while the plates shift the lightness of the cell pattern.

Invert Inverts the cell pattern. Black areas become white, and white areas become black.

Contrast/Sharpness Specifies the contrast of the cell pattern layer when you use the Bubbles, Crystals, Pillow, Mixed

Crystals, or Tubular cell pattern. The control specifies sharpness for any of the Plate or Crystallize options.

Note: The layer’s contrast is affected by the option chosen in the Overflow menu.

Overflow Specifies the method used to remap values that fall outside the grayscale range of 0–255. Overflow is not

available when sharpness-based cell patterns are chosen.

• Clip  Specifies values above 255 as pure white, and values below 0 as pure black. Contrast amount controls how

much of the image falls outside this range; higher contrast amounts result in a mostly black or white image, with less

gray. Therefore, less subtle cellular detail appears at higher contrast settings.

• Soft Clamp Remaps grayscale values to fall inside the 0–255 range. As a result, contrast appears reduced; the cells

are mostly gray with very few areas of pure black or white.

• Wrap Back Changes overflow values to the 0-255 range by folding values back in the other direction. For example,

if the maximum value allowed is 255 and the actual value is 285 (255 + 30), the resulting value is 225 (255 - 30). As

a result, more defined subtle detail appears when Contrast is set above 100.

Disperse Specifies how randomly the pattern is drawn, thus affecting the angle of the cells relative to each other.

Lower values result in more uniform or grid-like cell patterns.

Note: If you set the Disperse value above 1.0, set the layer to Best quality to avoid artifacts.

Size Specifies the size of the cell shapes. The default size is 60.

Note: To determine the size of your tiles, use the following calculations: tile width=Cells Horizontal x Size; tile

height=Cells Vertical x Size. For example, to create a tile size of 256x256 pixels, set Size, Cells Horizontal, and Cells

Vertical to 16.

Offset Specifies the portion of the cell pattern visible in the Composition panel. This control is useful when

animating the cell pattern across the composition frame.

Tiling Options Choose one of the following options to control tiling:

• Enable Tiling  Renders the cell patterns in seamless tiles. The shape and number of tiles are determined by the

Cells Horizontal and Cells Vertical values.

• Cells Horizontal, Cells Vertical Specify the number of horizontal or vertical cells on a tile.

Evolution Creates subtle changes in the shape of the cell pattern. Animating this control results in smooth changes

of cell shapes over time. Set keyframes for Evolution to determine how much the cell shapes “evolve” over the period

of time allowed between keyframes. The more revolutions in a given amount of time, the more rapidly the cell shape

changes. Higher Evolution values may result in less smooth changes in the cell shapes.

Note:Although the Evolution value is set in units called “revolutions,” it is important to realize that these revolutions are

progressive. The Evolution state continues to progress infinitely at each new value. Use Cycle Evolution (under Evolution

Options) to return the Evolution setting to its original state at each revolution.
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Evolution Options Because of the complexity of the cell shapes that generate the cell patterns, render time can be

great. For this reason, Evolution Options provide controls that render the effect for one short cycle and loop it for

the duration of your project. Use the controls below to create a smooth, progressive loop segment.

• Cycle Evolution Creates a loop that forces the evolution state to return to its starting point.

• Cycle Is available if Cycle Evolution is selected. Cycle specifies the number of revolutions (of the Evolution setting)

that the cell pattern cycles through before it repeats. For example, if you set the evolution to occur over five revolu-

tions and you set the Cycle value to 2, the evolution loops twice. The timing or speed of these Evolution cycles is

determined by the amount of time allowed between Evolution keyframes.

Note: The Cycle control affects only the state of the cell pattern, not geometrics or other controls. For example, two

identical states of the cell pattern don’t appear the same if viewed with different Size or Offset settings.

• Random Seed Specifies a unique random value from which to generate the pattern. Animating this control results

in flashing from one set of cell shapes to another of the same cell pattern type. For smooth transition of the cell

pattern, use the Evolution control.

Create new cell pattern animations by reusing previously created Evolution cycles and changing only the Random

Seed value. Typing a new Random Seed value alters the cell pattern without disturbing the evolution animation.

Checkerboard effect
The Checkerboard effect creates a checkerboard pattern.

This effect works with 8-bpc color.

A matching color produces a subtle effect (center); using red with high Width and low Height settings (right) creates a striped effect.

Adjust the following controls for the Checkerboard effect:

Anchor Specifies the point of origin, or anchor point, of the Checkerboard pattern. Moving the anchor point offsets

the pattern.

Size From Specifies how the effect defines the size of the squares. Choose one of the following options from

the menu:

• Corner Point Specifies that the spatial relationship between the corner point and anchor point controls deter-

mines the checkerboard size.

• Width Slider Specifies that the Width value determines the checkerboard pattern size and shape. The individual

checkered shape remains square because the Width value determines both width and height of the checkers.

• Width & Height Sliders Specifies that the Width and Height values determine the checkerboard pattern size and

shape. Choose this option to set the width and height of the checkered shapes independently.

Corner Specifies the spatial relationship between the corner point and the anchor point. The effect uses the position

of these two points to define the size of the checkerboard pattern if you choose Corner Point in the Size From menu.
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Width Specifies the horizontal width of the checkerboard pattern. If you choose Width Slider in the Size From menu,

this value determines both the width and height of the checkerboard pattern. If you choose Width & Height Sliders

in the Size From menu, this value determines the width only.

Height Determines the vertical height of the checkerboard squares when you choose Width & Height Sliders in the

Size From menu.

Feather Specifies the size of the edge feather of the checkerboard pattern. Expand this control to reveal the

Width and Height sliders. Set Width and Height values independently, or set them both to the same value for

a uniform feather.

Color Specifies the color of one set of the checkerboard squares. The other set of squares is always transparent.

Opacity Specifies the transparency of the checkerboard pattern.

Blending Mode Specifies the blending mode the effect uses to create an interaction between the checkerboard

pattern and the original layer. All of these blending modes work identically to the ones in the Timeline panel, except

the default None mode, which renders the checkerboard pattern only.

Circle effect
The Circle effect creates a customizable solid circle or ring.

This effect works with 8-bpc color.

Original image (left), circle with no edge (center), circle specifying a Thickness & Feather *Radius edge

Adjust the following controls for the Circle effect:

Center Specifies the center point of the circle.

Radius Specifies the size of the radius, in pixels. If you set the radius to be larger than your original source layer, some

or all of the circle’s edge may fall outside the composition frame, depending upon the location of the circle’s center

point.

Edge Specifies the shape and edge treatment of the circle. Depending upon the option, the slider changes its name

to correspond to the option. Choose one of the following options from the menu, and use the slider to adjust the

option:

• None Creates a solid circle.

• Edge Radius Creates a ring. The difference in the values set for this control and Radius determines the ring’s

width.

• Thickness Creates a ring with a specified thickness. The corresponding slider measures the ring thickness in

pixels.

• Thickness * Radius Creates a ring that uses the Radius value to determine the Thickness value. As you increase

the Radius value of the ring, the Thickness value increases proportionally.

• Thickness & Feather * Radius Creates a ring that uses the Radius value to determine both the Thickness and

Feather values. As you increase the Radius value, the Thickness and Feather values scale proportionally.
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Feather Specifies the amount of feather applied to the edge of the circle. Increasing this amount softens the edges of

the circle, blending it with whatever appears behind it. Decreasing this amount sharpens the edge of the circle.

Note: Feather Inner Edge is disabled when Edge is set to None, since there is no inner edge on a solid circle.

Invert Circle Specifies that the circle matte is inverted, if this box is checked.

Color Specifies the color that fills the circle.

Opacity Specifies the transparency of the circle.

Blending Mode Specifies the blending mode that the effect uses to combine the circle and the original layer. All of

these blending modes behave like those in the Timeline panel, except for None, which displays only the circle,

without the original layer.

Ellipse effect
The Ellipse effect draws an ellipse based on the dimensions you specify in the Effect Controls panel. In addition to

width and height, you can specify the thickness, softness, and color of the ellipse.

The Width and Height controls specify the width and height of the ellipse in pixels. Values range from 0 to 2000

pixels. Thickness specifies the thickness of the arc forming the ellipse. Values range from 0 to 1000 pixels. Softness

specifies the softness or degree of blur of the ellipse’s arc.

This effect works with 8-bpc color.

Ellipse is applied to the background once (center) and then applied multiple times (right).

Eyedropper Fill effect
The Eyedropper Fill effect (formerly Color Picker effect) applies a sampled color to the source layer. This effect is

useful for quickly picking a solid color from a sample point on the original layer or picking a color value from one

layer and using blending modes to apply this color to a second layer.

This effect works with 8-bpc color.

Original (left), and with two different color samples applied (center and right)

Adjust the following controls for the Eyedropper Fill effect:

Sample Point Specifies the sampled pixel colors.

Sample Radius Specifies the size of the sample area.
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Average Pixel Colors Specifies which color values the effect samples within the area defined by the sample point and

sample radius. Skip Empty samples the average RGB color values, excluding those of transparent pixels. The All

option samples the average of all RGB color values, including those of transparent pixels. All Premultiplied samples

the average of all RGB color values, premultiplied with the alpha channel. Including Alpha samples the average of all

RGB color and alpha channel values. This results in the sampled color also containing the average transparency of

the sampled pixels.

Maintain Original Alpha When selected, the effect maintains the original layer’s alpha channel. If you choose

Including Alpha in the Average Pixel Color menu, the original alpha is stenciled over the sampled color.

Blend with Original Specifies the amount of blending between the new solid color and the original layer.

Fill effect
The Fill effect is used to fill a mask with a specified color. The Fill Mask menu displays the available masks. If you

want to add both a stroke and a fill to a closed path, the order in which you apply the stroke and fill determines the

visible width of the stroke. If the fill is applied before the stroke, the full stroke brush size is visible. If the stroke is

applied before the fill, the fill appears on top of the stroke, obscuring the half of the stroke that falls inside the path.

This effect works with 8-bpc color.

An inverted mask (left) is filled with black (center); a mask of a spaceship is filled with black and feathered (right).

The Fill effect includes an All Masks option that fills all the layer’s closed mask paths with the chosen color.

Activating this option also fills the mask path of a mask that has None chosen as its mode. To fill each layer mask,

make sure that All Masks is selected in the Effect Controls panel.

See also

“Scribble effect” on page 458

Fractal effect
The Fractal effect renders the Mandelbrot or Julia set, creating colorful textures. When you first apply the effect, the

picture you see is the classic sample of the Mandelbrot set; the set is the area that is colored black. Any pixel outside

the set is colorized, depending on how close it is to the set. Pixels near the border appear chaotic (noisy), but as you

zoom in, a quite startling and beautiful structure is revealed.

This effect works with 8-bpc and 16-bpc color.

A Mandelbrot fractal with a Lightness Gradient palette (center), and a Julia fractal (right)
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Adjust the following controls for the Fractal effect:

Set Choice Specifies the set used. Mandelbrot is the typical Mandelbrot set. Mandelbrot Inverse is the Mandelbrot

set mathematically inverted. Julia always changes depending on the center point from the Mandelbrot set and can

produce the set of all possible Julia sets. Julia Inverse is the inverse of the Julia set. To see a Julia set, you may want to

set the magnification to a negative value, because these sets tend to fill up the complex plane outside the normal

boundary. Mandelbrot Over Julia is the same as Mandelbrot, except that it does change when the Julia center point

changes. Mandelbrot Inverse over Julia is the same as Mandelbrot Inverse, except that it does change when the Julia

center point changes.

Mandelbrot, Julia Specify the settings for the specified set. X (Real) and Y (Imaginary) specify the pixels at the center

of the image for either the Mandelbrot or Julia set. Magnification specifies the magnification of the effect. Escape

Limit specifies how many times the calculation looks for a color for a given pixel before it assigns the color black.

This is also the maximum number of line segments the Selection tool can use when tracing the path of a point.

Higher numbers require longer render times.

Color Specifies the color of the effect:

• Overlay Displays a ghosted version of the opposite set. For example, when viewing the Julia set, use this control

to display a ghosted version of the Mandelbrot set. When you select Overlay, a white cross hair with a black drop

shadow appears so you can see the exact point at the center of the opposite set. This control is useful because the Julia

set depends on the center point of the Mandelbrot set.

• Transparency  Specifies whether black pixels are transparent. If you choose Solid Color from the Palette menu,

this control specifies whether everything inside or outside the set is transparent.

• Palette  Specifies the palette to use when drawing the set. Lightness Gradient creates a gradient from black

through the hue specified by the Hue control to white. Then it applies the same gradient eight more times, each time

using the hue 45˚ away on the color wheel. The number of colors in the gradient is specified by the Cycle Steps

control. Hue Wheel uses all the color from the Hue color wheel, with maximum brightness and saturation. Black And

White uses alternating bands of black and white. Solid Color turns everything transparent except the inside of the

set, which uses the color specified by the Hue control. Select Transparent to get the opposite result.

• Hue Specifies the hue for solid colors and the starting hue for color gradients. This control works well for creating

smooth color changes or for cycling through the palette. Cycle Steps specifies the number of bands of different color

that appear before the cycle starts over. Cycle Offset specifies where, other than the beginning, a cycle starts.

• Edge Highlight  Highlights the edges between color bands. This control requires low-quality mode. If you want

to use high-quality edge highlighting, use the Find Edges effect instead.

High Quality Settings Specify the oversampling settings for the effect:

• Oversample Method  Specifies the method used to oversample the effect: Edge Detect-Fast-May Miss Pixels

performs a simple edge detection and oversamples only those pixels. This is the fastest option, especially in areas with

a lot of solid color, such as black, and generally produces results indistinguishable from Brute Force. Brute Force-

Slow-Every Pixel oversamples every pixel in the image. It is slow but precise.

• Oversample Factor Specifies the amount of oversampling to perform. For example, a value of 4 specifies that each

pixel is sampled 16 times (4x4=16) and that the average color is used. Higher values produce better quality output

but require longer render times.
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Using tools with the Fractal effect

When the Fractal effect is selected in the Effect Controls panel, you can use After Effects tools in the following way.

(If you don’t want the Fractal tools active, deselect the effect before using tools.)

• Drag the Selection tool to see if a point’s path lies within the set. If the path leads out of the bounded rectangle (-

2, -2, 2, 2), it has gone into infinity; in such a case, the starting-point color is based on how many line segments it

takes to reach infinity. If the path ends within the rectangle, it is colored black.

• Use the Zoom tool to zoom in or out on a particular point, or hold down Ctrl (Windows) or Command (Mac OS),

click and hold the Magnifying tool over the center of the image, and navigate from the center. For example, to

zoom straight in, stay in the center; to move up, drag up just a little and then quickly move back to the center.

• Use the Hand tool to pan the image. Press Ctrl (Windows) or Command (Mac OS) to pan the opposite fractal. For

example, when viewing the Julia set, press Ctrl (Windows) or Command (Mac OS) to pan the Mandelbrot set and

see how the Julia set depends on the center point of the Mandelbrot set.

• Use the arrow keys to pan the center point by 1 pixel. Press Shift as you press an arrow key to adjust the point by

10 pixels. Press Ctrl (Windows) or Command (Mac OS) as you press an arrow key to adjust the center point of the

opposite set.

Grid effect
Use the Grid effect to create a customizable grid. Render this grid in a solid color or as a mask in the alpha channel

of the source layer. This effect is good for generating design elements and mattes within which other effects can be

applied.

This effect works with 8-bpc color.

Original (left) and with variations of Grid applied (center and right)

Use Grid with the Advanced Lightning effect to create lightning forks that follow a grid pattern.

Adjust the following controls for Grid:

Anchor Specifies the point of origin of the Grid, based on (x,y) coordinates.

Size From Specifies the grid size. Each option enables the corresponding effect controls.

• Corner Point Determines the spatial relationship between the Corner point and Anchor point controls.

• Width Slider Determines the value set for the Width control. The Grid cells will be square, as the Width value is

used to determine both width and height of the Grid cells.

• Width & Height Sliders  Determines the values set for the Width and Height controls. Use this option to set the

width and height of the Grid cells independently.

Corner Specifies the size of the grid cells, based on the spatial relationship between the Corner point and the Anchor

point.
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Width Specifies the horizontal width of the grid cells. If you choose Width Slider in the Size From menu, this value

specifies both the width and height of the grid cells. If you choose Width & Height Sliders in the Size From menu,

this value specifies the width only.

Height Specifies the height of the Grid cells when you choose Width & Height Sliders in the Size From menu.

Border Specifies the border thickness of the grid. A Border value of 0 causes the grid to disappear.

Note: The anti-aliasing of the grid borders may cause the visible thickness to vary by one pixel.

Feather Specifies the softness of the grid. You can set Width and Height amounts individually, or set both to the

same amount for a uniform feather on all edges. The maximum width value is 20 pixels; the maximum height value

is 400 pixels.

Invert Grid Inverts the transparent and opaque areas of the grid.

Color Specifies the RGB color values of the grid.

Opacity Specifies the opacity of the grid.

Blending Mode Specifies how the grid interacts with the original layer.

Lens Flare effect
The Lens Flare effect simulates the refraction caused by shining a bright light into the camera lens. Specify a location

for the center of the flare by clicking anywhere inside the image thumbnail or by dragging its crosshair.

This effect works with 8-bpc color.

A single lens flare (center) and multiple lens flares (right)

Lightning effect
The Lightning effect creates lightning bolts and other electrical effects, including a Jacob’s Ladder effect (as seen in

old horror movies) between two specified points in a layer. This effect is automatically animated without keyframes

across the time range. Use The Wiggler to add randomness to the lightning bolt.

This effect works with 8-bpc color.

Variations in thickness, color, and number of branches (center and right)

Adjust the following controls for the Lightning effect:

Start Point, End Point Specify where the lightning begins and ends.
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Segments Specifies the number of segments that form the main lightning bolt. Higher values produce more detail

but reduce the smoothness of motion.

Amplitude Specifies the size of undulations in the lightning bolt as a percentage of the layer width.

Detail Level, Detail Amplitude Specify how much detail is added to the lightning bolt and any branches. For Detail

Level, typical values are between 2 and 3. For Detail Amplitude, a typical value is 0.3. Higher values for either control

are best for still images but tend to obscure animation.

Branching Specifies the amount of forking that appears at the ends of bolt segments. A value of 0 produces no

branching; a value of 1.0 produces branching at every segment.

Rebranching Specifies the amount of branching from branches. Higher values produce tree-like lightning bolts.

Branch Angle Specifies the size of the angle between a branch and the main lightning bolt.

Branch Seg. Length Specifies the length of each branch segment as a fraction of the average length of the segments

in the lightning bolt.

Branch Segments Specifies the maximum number of segments for each branch. To produce long branches, specify

higher values for both the branch segment length and the branch segments.

Branch Width Specifies the average width of each branch as a fraction of the width of the lightning bolt.

Speed Specifies how fast the lightning bolt undulates.

Stability Determines how closely the lightning undulates along the line defined by the start and end points. Lower

values keep the lightning bolt close to the line; higher values create significant bouncing. Use Stability with Pull Force

to simulate a Jacob’s Ladder effect and cause the lightning bolt to snap back to a position along the start line after it

has been pulled in the Pull Force direction. A Stability value that is too low does not allow the lightning to be

stretched into an arc before it snaps back; a value that is too high lets the lightning bolt bounce around.

Fixed Endpoint Determines whether the end point of the lightning bolt remains fixed in place. If this control is not

selected, the end of the bolt undulates around the end point.

Width, Width Variation Specify the width of the main lightning bolt and how much the width of different segments

can vary. Width changes are randomized. A value of 0 produces no width changes; a value of 1 produces the

maximum width changes.

Core Width Specifies the width of the inner glow, as specified by the Inside Color value. The Core Width is relative

to the total width of the lightning bolt.

Outside Color, Inside Color Specify the colors used for the lightning bolt’s outer and inner glows. Because the

Lightning effect adds these colors on top of existing colors in the composition, primary colors often produce the best

results. Bright colors often become much lighter, sometimes becoming white, depending on the brightness of colors

beneath.

Pull Force, Pull Direction Specify the strength and direction of a force that pulls the lightning bolt. Use the Pull Force

value with the Stability value to create a Jacob’s Ladder appearance.

Random Seed Specifies a starting point for randomizing the lightning effects you have specified. Because random

movement of the lightning may interfere with another image or layer, typing another value for the Random Seed

starts the randomizing at a different point, changing the movement of the lightning bolt.

Blending Mode Specifies how the lightning is added to the layer. These modes behave the same as layer blending

modes.
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Rerun At Each Frame Controls the frame-by-frame generation of the lightning. Selecting this control regenerates the

lightning at each frame. To make the lightning behave the same way at the same frame every time you run it, do not

select this control. Selecting this control may increase rendering time.

Paint Bucket effect
The Paint Bucket effect (formerly Basic Fill effect) is a non-destructive paint tool that fills a selected area with a solid

color. It works much like the Paint Bucket tool in Adobe Photoshop. Use Paint Bucket for colorizing cartoon-type

outlined drawings or replacing selected areas of color in an image.

Note: Paint Bucket has minimal impact on a solid layer.

This effect works with 8-bpc color.

Colors fill spiral-shaped alpha channels on separate layers (left and center); Paint Bucket is applied to the saucer with the Color blending mode
(right).

Adjust the following controls for the Paint Bucket effect:

Fill Point Specifies the area of the image the effect fills with the new color. Depending upon where you place the

effect point, the control samples between 1 and 4 pixels’ RGB and alpha values and calculates an average value. This

value determines which pixels to fill with the new color. How far the fill color spreads depends upon the specified

Tolerance setting, as well as the option you choose in the Fill Selector menu.

Fill Selector Specifies the channels to fill with the new color.

• Color & Alpha  Specifies that the effect fills the fill point’s RGB and alpha channels with the new color.

• Straight Color  Specifies that the effect fills only the fill point area’s RGB channel with the new color.

• Transparency Specifies that the effect fills only the transparent areas near the fill point. You must set a fill point

in a transparent area for this option to work.

• Opacity Specifies that the effect fills only the opaque areas near the fill point. You must set a fill point in an opaque

area for this option to work.

• Alpha Channel Specifies that the effect fills either the opaque or transparent areas in the whole image, depending

upon the alpha channel value at the point you set the fill point.

Tolerance Specifies the range of pixels that the effect fills with the new color. This value is based upon the option

chosen in the Fill Selector menu. Higher values expand the range of similar pixel values that the effect fills. Lower

tolerance values restrict that range.

View Threshold Causes the effect to display the threshold values in black and white (based on the tolerance value)

in the Composition panel. The white areas within the tolerance range fill with the selected fill color. This is especially

useful in tracking leaks. When there is a small gap, the color can flow over and fill areas not intended to be filled. If

a leak is found, try reducing the Tolerance value or retouching your image, either by using the Paint effect or by

editing the image in the application in which you created it.
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Stroke Specifies how the effect treats the edges of the filled area.

• Antialias  Anti-aliases the edges of the filled area.

• Feather Creates a feathered edge for the filled area. Feather Softness values create a more gradually disappearing

edge.

• Spread  Expands the area of the fill color. The Spread Radius value indicates the number of pixels the fill color

extends beyond the edge of the fill area.

• Choke  Contracts the area of the fill color. The Spread Radius value indicates the number of pixels the fill color

shrinks from the edge of the fill area.

• Stroke Confines the fill to just the border of the selected area. The Stroke Width value indicates the width of the

stroke, in pixels.

Each of the options has a corresponding slider, except for Antialias.

Invert Fill Reverts all currently filled pixels to their original colors and transparency, and fills the previously unfilled

pixels using the current settings.

Color Specifies the color to use as the fill color.

Opacity Specifies the transparency of the filled area.

Blending Mode Specifies the blending mode the effect uses to create the operation between the new fill color and

the original layer. All of these blending modes appear in the Mode menu in the Timeline panel, except for Fill Only.

Use Fill Only if you don’t wish to composite the fill with the original image. Only the fill remains visible.

Note: If you apply multiple instances of Paint Bucket to a layer, be sure not to set more than one to use the Fill Only

blending mode. If you set more than one instance to use this blending mode, only the first application of the filter is

displayed. The blending mode drops out the original image, thereby changing the fill point selection for the following

applications of the filter.

Radio Waves effect
The Radio Waves effect creates radiating waves from a stationary or animated effect point. You can use this effect to

generate pond ripples, sound waves, or intricate geometric patterns. You can control the emitted waves’ shape, width,

color, speed, rotation, life span, fade rate, and other properties. Use the Reflection control to make the shapes bounce

off the sides of the layer. You can also use Radio Waves to create realistic wave displacement maps that work well with

the Caustics effect.

This effect works with 8-bpc color.

Polygon wave type with a square stroke profile (center) and Image Contour wave type with Sine stroke profile (right)

Adjust the following controls for the Radio Waves effect:

Producer Point Specifies the point from which the waves appear.
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Parameters Are Set At Specifies whether parameters can be animated for individual waves. Birth specifies that each

wave maintains the same parameter settings over time. Each Frame specifies that the waves change as the parameters

change. For example, if you create a star wave with an animated rotation property, select Birth to offset each star from

the previous one to create a twisting tunnel effect, or select Each Frame to make all the stars rotate in unison as the

rotation property changes.

Render Quality Controls the quality of the output. Radio Waves renders a smooth, anti-aliased shape for every shape

by rendering a high-resolution version of the shape and then scaling it down in a process called oversampling. For

example, to create a 100x100-pixel image, it may first generate a 400x400-pixel image and then scale it down using

4x oversampling. Oversampling provides high-quality results but result in long render times. This option works only

when in Best quality mode.

Wave Type Specifies the type of wave you want to create.

Polygon Specifies the appearance of the polygon shape used for the wave. This control is available when Polygon is

chosen for Wave Type.

• Sides Specifies the type of polygonal shape you want to produce. Three sides create a triangle, four create a square,

and so on. Size values above 64 result in a smooth circle. You can also create a circle by setting Sides to 3, Curve Size

to 1, and Curvyness to about 0.62.

• Curve Size Specifies how much of each side is curved at each point.

• Curvyness Specifies how extreme the curve is at each point of the wave.

• Star Specifies that the polygon is shaped like a star. To change the number of points on the star, change the

number of sides.

• Star Depth Specifies the star’s angles by controlling the distance between inner points and the star’s center.

Mask Specifies the mask used to create a wave. This control is available when you choose Mask from the Wave Type

pop-up menu.

Image Contour controls for the Radio Waves effect

Image Contour controls specify the image you want to use as the wave and controls how the image appears. These

controls are available when Image Contours is chosen for Wave Type.

Source Layer Specifies the layer you want to use as the shape of the wave. Select an animated layer to emit moving

shapes. A well-defined outline, high-contrast grayscale layer, or alpha channel works well as a source. The Radio

Waves effect detects edges and converts sources into outlines.

Source Center Specifies the center point of the shape, relative to the source layer. For example, if you isolate a shape

that is positioned in the left half of the frame, the shape radiates to the left by default; you can move the source center

anywhere on the layer.

Value Channel Specifies the channel of the layer that defines the wave shape.

Invert Input Inverts the chosen value channel option.

Value Threshold Specifies the threshold for the chosen value channel. It determines the percentage value at which

everything below it or above it is mapped to either white or black. This control can make a big difference in the shape

of the wave.

Pre-Blur Smooths out the value channel before the value threshold is sampled. If you have a high-contrast image,

such as white on black, and you want the wave to follow the edges very closely, set this to 0.

Tolerance Defines how tightly the wave conforms to the layer. A very high setting results in sharp corners; a very

low value can make the wave shape more sensitive to noise.
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Contour Specifies the shape in the source layer that you want to use as the emitted wave. Contour numbers the

shapes by their order in the frame from top to bottom, left to right. The shape in the top left corner is number 1.

Wave Motion controls for the Radio Waves effect

Wave Motion controls specify how the wave emits from the center point.

Frequency Specifies the number of waves per second flowing out of the producer point.

Expansion Specifies the speed at which the wave travels from the producer point once it is born. This does not affect

the number of waves per second.

Orientation Specifies the rotation of the shape at birth around its center point. To animate the rotation, use the Spin

control.

Direction Specifies the wave’s initial direction when Velocity is greater than 0. By default, particles are emitted from

the producer point in an expanding radial pattern.

Velocity Specifies the speed at which the wave moves in the specified direction.

Spin Controls the continued rotation of a shape after it is born.

Lifespan (sec) Specifies the time, in seconds (including the fade-in and fade-out times), that the wave exists.

To prevent waves from abruptly disappearing when their lifetime ends, use the Fade Out Time control.

Reflection Specifies whether the waves bounce off the edges of the layer and back into the scene. This is effective for

generating displacement maps for use as water ripples.

Stroke controls for the Radio Wave effect

Stroke controls specify the appearance of the wave’s stroke.

Profile Controls the appearance of the stroke that defines the shape. The outline of the shape is animated in the wave

that emanates from the effect point. The quality of the stroke is defined as a 3D wave type.

Color Specifies the color of the stroke.

Opacity Specifies the maximum possible opacity of the stroke. The actual opacity of the stroke takes into account

this setting in conjunction with the Fade-in Time and Fade-out Time controls.

Fade-in Time Specifies the amount of time it takes the wave to fade into view. Fade-in Time is measured in seconds

and begins with 0 opacity at birth. For example, if the Lifespan is 3 seconds and Fade-in Time is 1 second, the stroke

is completely transparent at birth and fades smoothly to full opacity at 1 second.

Fade-out Time Specifies the amount of time it takes the wave to fade out of view. Fade-out Time is measured

backward in time from the end of the Lifespan. If the Lifespan is 3 seconds and Fade-out Time is 1 second, the wave

begins to fade out at 2 seconds. If the sum of Fade-in Time and Fade-out Time is greater than the Lifespan value, the

intersection point of the two fades is calculated so that the wave does not reach full transparency. If either Fade-in

Time or Fade-out Time is longer than the Lifespan, that amount is truncated to equal the Lifespan.

Start Width Specifies the width of the shape at its birth. End Width specifies the width of the shape at the end of its

lifespan.
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Ramp effect
The Ramp effect creates a color gradient, blending it with the original image contents. Create linear or radial ramps,

and vary the position and colors of the ramp over time. Use the Start Of Ramp and End Of Ramp controls to specify

the start and end positions. Use the Ramp Scatter control to disperse the ramp colors and eliminate banding.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left), Linear ramp with red at 30% opacity (center), and radial ramp with black at 30% opacity (right)

Note: Ramps often do not broadcast well; serious banding occurs because the broadcast chrominance signal does not

contain sufficient resolution to reproduce the ramp smoothly. The Ramp Scatter control disperses the ramp colors, elimi-

nating the banding apparent to the human eye.

Scribble effect
The Scribble effect creates the appearance of hand-drawn artwork by replacing a closed mask shape with strokes.

For example, Scribble can simulate fills that look like marker, cross-hatching, or textiles. Scribble replaces a mask

shape with a single zigzagging line that criss-crosses the path. Some paths, because of their geometry, cannot be filled

with a single line. Scribble breaks these paths into several simpler paths, each of which it then fills with a zigzagged

stroke.

This effect works with 8-bpc color.

Masks (left), Scribble applied to outside edges (center), and Scribble applied to inside edges with Composite on Original (right)

Controls for the Scribble effect
Scribble Specifies the mask you want to use for the Scribble effect. Single Mask scribbles a specified mask on the

layer; All Masks scribbles all masks on the layer; All Masks Using Modes combines the masks using their modes and

then scribbles the resulting shape.

Mask Specifies the mask to use for the effect. It is enabled if Scribble is set to Single Mask.

Fill Type Controls whether the fill is drawn inside the path or creates a scribble along the path. Left Edge draws the

fill along the path’s left edge; Right Edge draws the fill along the path’s right edge. The left and right edges of a path

are determined by the direction in which the path is drawn. From start to end of the path, the left edge is on the left,

and the right edge is on the right. When using the Left Edge or Right Edge fill types on masks that have tight curves,

you get best results by making the Edge Width less than the radius of the curve.

Edge Options Specifies the options for the edge of the scribble. It is enabled if Fill Type is set to an edge.

• Edge Width Controls the width of the edge.
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• End Cap Controls the ends of scribble lines. Use Round for stroked lines with semicircular ends; use Butt for

stroked lines with squared ends; and use Projecting for stroked lines with squared ends that extend half the line width

beyond the end of the line, making the weight of the line extend equally in all directions around the line. This option

is enabled only if Fill Type is set to Centered Edge.

• Join Specifies how the corners of a scribble line appear. Use Round for stroked lines with rounded corners; use

Bevel for stroked lines with squared corners; and use Miter for stroked lines with pointed corners.

• Miter Limit Controls when the effect switches from a miter (pointed) join to a bevel (squared-off) join. Specify a

value between 1 and 500. For example, if the value is set to the default value of 4, the effect switches from a miter to

a bevel join when the length of the point reaches four times the stroke weight. A miter value of 1 results in a bevel

join. It is enabled if Join is set to the Miter option.

• Start/End Apply To Specifies how changes to the effect’s Start and End options in the Timeline panel are applied;

Scribble Result affects the scribble in the order in which it is drawn, and Mask Path follows the path of the mask to

create more continuous drawing in or out of the scribble.

Color Specifies Scribble color.

Opacity Specifies the opacity of the lines in the scribble.

Angle Specifies the angle of the scribbled stroke.

Stroke Width Specifies the width of the stroke. Specify a value from 0.1 to 50.

Stroke Options Specify the curviness, spacing, and overlap of the scribbled line.

• Curviness Controls the amount of curve at the end of each scribbled stroke. Specify a value between 0 and 100

degrees.

• Curviness Variation Determines the amount of variance the curviness values can have at each end point. Specify

a value between 0 and 100 percent. A value of 0 gives the scribble sharp corners, while a value of 100 makes the

scribble loopy.

• Spacing and Spacing Variation (specified in pixels) Control the amount of space between lines and zigzags.

Specify a value between 0 and 50 percent. Setting a value equal to the stroke width value makes the lines fall next to

each other.

• Path Overlap Determines whether the scribble ends at the path, inside the path, or outside the path. Specify 0 to

make it end at the path, negative values to make it end inside, and positive values to make it end outside. Path Overlap

Variation determines how much each stroke can vary from the value specified for Path Overlap.

Start, End Control the point along the stroke where the stroke starts and ends.

Fill Paths Sequentially Enabled when Scribble is set to All Masks. When this control is selected, the start and end

values apply to the combined length of the scribbles for all masks. When it is not selected, the start and end values

apply independently to the scribble for each mask.

Wiggle Type Specifies an animation style: Static keeps the scribble constant over time; Jumpy changes from one

scribble to the next abruptly; and Smooth changes from one scribble to the next smoothly.

Wiggles/Second Controls how frequently a new scribble is generated when the Wiggle Type control is set to Smooth

or Jumpy.

Random Seed Generates random scribbles. This control is most useful when the Wiggle Type control is set to Static.

Composite Controls the composition of the effect on the original layer.
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Stroke effect
The Stroke effect creates a stroke or border around a mask or along a Bezier path. You can also specify stroke color,

opacity, and spacing, as well as brush characteristics. Specify whether the stroke appears on top of the image, on a

transparent image, or if it reveals the original alpha channel. To use a path created in Illustrator, copy the path and

paste it into a layer in After Effects.

This effect works with 8-bpc color.

Original (left), with mask (center), and with Stroke applied (right)

Brush Hardness Specifies the edge quality of the stroke, between hard and soft.

Spacing Specifies the spacing between stroke segments.

Paint Style Specifies whether the stroke is applied to the original layer or to a transparent layer.

Vegas effect
The Vegas effect generates running lights and other path-based pulse animations around an object. You can outline

just about anything, surround it with a number of lights or longer pulses, and then animate it to create the effect of

lights chasing around the object.

This effect works with 8-bpc color.

Image contours of the spaceship are used to create animations on a transparent background (right).

Adjust the following controls for the Vegas effect:

Stroke Specifies what you want to use to create a stroke: Image Contours or Mask/Path.

Image Contours Specifies the area where the lights will appear. Vegas sets thresholds for the image and then creates

contours around the edges of the resulting shapes.

• Input Layer Specifies where the strokes appear. High-contrast, grayscale layers, and alpha channels work well and

are easy to work with.

• Invert Input Inverts the input layer prior to creating the stroke.

• If Layer Sizes Differ Determines how to adjust the layers if the size of the input layer differs from that of the layer

to which Vegas is applied. Center centers the input layer in the composition at its original size. Stretch To Fit scales

the input layer to match the layer to which Vegas is applied.

• Channel Specifies the channel or property of the input layer used to define the contours.
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• Threshold Sets the threshold for the selected channel. The threshold is the percentage value at which everything

below or above is mapped to either white or black. For example, if a grayscale file were an altitude map with white

high and black low; the Threshold value moves the contour up or down the terrain. This is an important factor in

determining the location of the edges that Vegas strokes.

• Pre-Blur Smooths out the input layer before the threshold is sampled. Set this to 0 if you have a high-contrast

image and want the stroke to follow the edges very closely.

• Tolerance Defines how tightly the stroke conforms to the input layer. A very high setting results in sharp corners,

while very low values can make the stroking sensitive to noise.

• Render Specifies whether to apply Vegas to a selected contour or to all contours in the layer.

• Selected Contour Specifies the contour to use when Selected Contour is selected in the Render menu. Contours

are numbered from left top to bottom right; the contour with the highest point is number 1, the second highest point

is number 2, and so on.

• Shorter Contours Have Specifies whether shorter contours have fewer segments. By default, Vegas breaks each

contour into the same number of segments. For example, if you apply Vegas to the letter R, the outside contour may

look fine with 32 segments, but the inside contour may be almost solid. To resolve this, select Fewer Segments.

Mask/Path Specifies the path to use for the stroke. Select the mask from the Path menu. You can use either closed or

open masks.

Segments Specifies the number of segments used to create each stroked contour. For example, if Vegas is applied to

the word Vegas and Segments is set to 10, the outline of each of the letters, plus the inner contours of e, g, and a, are

broken into 10 segments.

Length Determines the length of a segment’s stroke in relation to its maximum possible length. For example, if

Segments is set to 1, the maximum length of a stroke is one complete trip around the object outline. If Segments is

set to 3, the maximum length of a segment is 1/3 of the total outline, and so on.

Segment Distribution Determines the spacing of the segments. Bunched puts the segments together like boxcars in

a train: the shorter the segment length, the shorter the overall length of the train. Even spaces the segments evenly

around the contour.

Rotation Animates the segments around the contour. For example, to create the appearance of running lights, start

with a large number of segments set to 50% of their length, and then animate Rotation to move the lights around the

shapes.

Random Phase Specifies that the stroke starting point is different for each contour. By default, Vegas strokes a

contour beginning at its highest point on the screen. In the event of a tie, it starts at the leftmost highest point.

Random Seed Gives different stroke origins to two identical contours with identical settings on a layer. A random

seed is a number that is inserted into the calculation to generate a unique result. By using a different Random Seed

setting, you can make things appear different, while still using the same settings.

Blend Mode Determines how the stroke is applied to the layer. Transparent creates the effect of Vegas on a trans-

parent background. Over places the stroke over the existing layer. Under places the stroke behind the existing layer.

Stencil uses the stroke as an alpha channel mask, filling the stroke with the pixels of the original layer.

Color Specifies the color of the stroke, unless Stencil is chosen for Blending Mode.

Width Specifies the width of the stroke in pixels. Fractional values are supported.

Hardness Determines how sharp or blurry the edges of the stroke are. A value of 1 creates a slight blur; a value of 0.0

blurs the line so that few solid areas of color remain.

Start, End Opacity Specify the opacity at the beginning or end of the stroke.
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Mid-point Opacity Specifies the opacity of the midpoint of the stroke. This works in terms of relative opacity, not

absolute opacity. Setting this to 0 makes the change in opacity smooth from the start point to the end point, as if there

were no midpoint at all.

Mid-point Position Specifies the location of the midpoint within a segment: Lower values move the midpoint closer

to the beginning; higher values move the midpoint closer to the end. Use this control to move the midpoint opacity

from the center of the stroke.

Write-on effect
The Write-on effect animates strokes on a layer. For example, you can simulate the writing of cursive text or create

snakelike movement for a stroke. Using the Write-on effect, you can animate the brush size, color, hardness, and

opacity of a stroke.

This effect works with 8-bpc color.

Animating the Write-on effect

Other methods of animating paint strokes and text are also available. For example, you can animate text by using the

type tools and text animators. (See “About text animation” on page 295.)

Adjust the following controls for the Write-on effect:

Brush Position Specifies where the stroke begins.

Color, Brush Size, Brush Hardness, and Brush Opacity Specify the size and appearance of the stroke.

Stroke Length Specifies the length, in seconds, of the stroke at any moment. If this value is 0, the stroke has

unlimited length. Use a single stroke length (not 0) for all keyframes to create a snakelike movement of the stroke

across the layer. Change the stroke length at keyframes to make the length of the stroke expand and contract as it is

drawn.

Brush Spacing Specifies the time interval, in seconds, between dabs of color as the stroke is drawn. Smaller values

produce smoother paint strokes but take more time to render.

Paint Time Properties Specifies whether paint properties (color and opacity) are applied to each stroke segment or

to the entire stroke. None applies color and opacity specified at each keyframe to the entire stroke. Color applies the

color specified at a keyframe to the stroke starting at that keyframe until it is changed at a later keyframe. The opacity

specified at each keyframe is applied to the entire stroke. Opacity applies the opacity specified at a keyframe to the

stroke starting at that keyframe until it is changed at a later keyframe. The color specified at each keyframe is applied

to the entire stroke.

Brush Time Properties Specifies whether brush properties (size and hardness) are applied to each stroke segment or

to the entire stroke. None applies the brush size and hardness specified at each keyframe to the entire stroke. Size

applies the brush size specified at a keyframe to the stroke starting at that keyframe until it is changed at a later

keyframe. The hardness specified at each keyframe is applied to the entire stroke. Hardness applies the hardness

specified at a keyframe to the stroke starting at that keyframe until it is changed at a later keyframe. The size specified

at each keyframe is applied to the entire stroke. Size & Hardness applies both the brush size and hardness specified

at a keyframe to the stroke starting at that keyframe until they are changed at a later keyframe.
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Paint Style Specifies whether the stroke is applied to the original layer or to a transparent layer.

Keying effects

Color Difference Key effect (Pro only)
The Color Difference Key effect creates transparency from opposite starting points by dividing an image into two

mattes, Matte Partial A and Matte Partial B. Matte Partial B bases the transparency on the specified key color, and

Matte Partial A bases transparency on areas of the image that do not contain a second, different color. By combining

the two mattes into a third matte, called the alpha  matte, the Color Difference Key creates well-defined trans-

parency values.

The Color Difference Key produces high-quality keying for all well-lit footage items shot against a bluescreen or

greenscreen and works especially well with images that contain transparent or semitransparent areas, such as smoke,

shadows, or glass.

This effect works with 8-bpc and 16-bpc color.

Original (left) and background layer (center) are combined using Color Difference Key (right).

See also

“To use the Color Difference Key effect” on page 273

Color Key effect
The Color Key effect keys out all image pixels that are similar to a specified key color. This effect modifies only the

alpha channel of a layer. The layer’s quality setting does not affect Color Key.

This effect works with 8-bpc and 16-bpc color.

A non-standard color screen (left) and the background (center) are combined with Color Key (right).

When you key out a color value in a layer, that color or range of colors becomes transparent for the entire layer.

Control the range of transparent colors by adjusting the tolerance level. You can also feather the edges of the trans-

parent area to create a smooth transition between the transparent and opaque areas.
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See also

“To key out a single color with the Color Key effect” on page 274

Color Range effect
The Color Range effect creates transparency by keying out a specified range of colors in either the Lab, YUV, or RGB

color space. You can use this key on screens that consist of more than one color or on bluescreens or greenscreens

that have been unevenly lit and contain different shades of the same color.

This effect works with 8-bpc color.

A poorly lit green screen (left) and a background layer (center) are combined using Color Range Key (right).

See also

“To use the Color Range effect” on page 275

Difference Matte effect (Pro only)
The Difference Matte effect creates transparency by comparing a source layer with a difference layer, and then keying

out pixels in the source layer that match both the position and color in the difference layer. Typically, it is used to key

out a static background behind a moving object, which is then placed on a different background. Often the difference

layer is simply a frame of background footage (before the moving object has entered the scene). For this reason, the

Difference Matte Key is best used for scenes that have been shot with a stationary camera.

This effect works with 8-bpc and 16-bpc color.

Original (left), Matte Only view of keyed-out subject (center), and composite of subject with new background (right)

See also

“To use the Difference Matte effect” on page 275

Extract effect (Pro only)
The Extract effect creates transparency by keying out (or extracting) a specified brightness range, based on a

histogram of a specified channel. It is best used to create transparency in an image shot against a black or white

background or against a background that is very dark or bright but consists of more than one color. You can also use

it to remove shadows from a composition.

This effect works with 8-bpc and 16-bpc color.
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Original (left) and background layer (center) are combined using Extract (right).

See also

“To use the Extract effect” on page 276

Inner/Outer Key effect (Pro only)
The Inner/Outer Key effect isolates a foreground object from its background. Even objects with wispy, intricate, or

undefinable edges can be clipped from their backgrounds with minimal work.

This effect works with 8-bpc and 16-bpc color.

The original masked layer (left) and the background layer (center) are combined using Inner/Outer Key (right).

See also

“To use the Inner/Outer Key effect” on page 277

Linear Color Key effect
The Linear Color Key effect uses RGB, hue, or chroma information to create transparency from a specified key color.

This effect works with 8-bpc and 16-bpc color.

Features such as these eyes (left) that closely match the background (center) can become transparent when using keys; Linear Key keeps them
opaque with the Keep This Color control (right).

See also

“To apply the Linear Color Key effect” on page 271

“To preserve a color after applying Linear Color Key” on page 273
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Luma Key effect
The Luma Key effect keys out all the regions of a layer with a specified luminance or brightness. The layer’s quality

setting does not influence the Luma Key effect.

This effect works with 8-bpc and 16-bpc color.

A white background of the original (left and center) is removed using Luma Key (right).

See also

“To key out a luminance value with the Luma Key effect” on page 278

Spill Suppressor effect (Pro only)
The Spill Suppressor effect removes traces of the key color from an image with a screen that has already been keyed

out. Typically, the Spill Suppressor is used to remove key color spills from the edges of an image. Spills are caused by

light reflecting off the screen and onto the subject.

If you are not satisfied with the results from using the Spill Suppressor, try applying the Hue/Saturation effect to a

layer after keying, and then decrease the saturation value to de-emphasize the key color. (See “Hue/Saturation effect”

on page 415.)

This effect works with 8-bpc and 16-bpc color.

The original green key (left) leaves a green glow when keyed out (center). Spill Suppressor removes the glow (right).

See also

“To use the Spill Suppressor effect” on page 277

Matte effects (Pro only)

Matte Choker effect (Pro only)
The Matte Choker effect repeats a sequence of choking and spreading the matte to fill undesired holes (transparent

areas) in opaque regions. The repetition is necessary because the entire matte must be choked and spread; the

spreading fills the hole, but the edges of the matte must be choked back to preserve the matte shape.

This effect works with 8-bpc and 16-bpc color.
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Original (left) shows areas of unwanted transparency after using Color Key (center) that are removed with Matte Choker (right).

See also

“To close a hole in a matte (Pro only)” on page 282

Simple Choker effect (Pro only)
The Simple Choker effect shrinks or expands the edges of a matte in small increments to create a cleaner matte. The

Final Output view displays the image with the effect applied, and the Matte view provides a black-and-white view of

the image with black areas indicating transparency and white areas indicating opacity. Choke Matte sets the amount

of choke. Negative values spread the matte; positive values choke it.

This effect works with 8-bpc and 16-bpc color.

The original (left) contains unwanted edges after keying (center) that are removed with Simple Choker (right).

Noise & Grain effects

Add Grain effect
This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

See also

“Adding grain or visual noise to an image” on page 362

“Working with added or matched grain” on page 363
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Dust & Scratches effect
The Dust & Scratches effect reduces noise by changing dissimilar pixels. To achieve a balance between sharpness of

the image and hiding defects, try various combinations of radius and threshold settings. Draft and Best quality

settings give the same results.

This effect works with 8-bpc and 16-bpc color.

Scratch highlighted (left); result, with scratch removed (right)

To use the Dust & Scratches effect

1 Choose Effect > Noise & Grain > Dust & Scratches.

2 Drag the Radius slider right, or enter a value in the value field from 0 to 255 pixels. The radius determines how

far the filter searches for differences among pixels. Adjusting the radius makes the image blurry. Stop at the smallest

value that eliminates the defects.

3 Drag the Threshold slider left to 0 to turn off the value, so that all pixels in the selection or image can be examined.

The threshold determines how different the pixels’ values should be before they are eliminated.

Note: The Threshold slider gives greater control for values between 0 and 128—the most common range for images—

than for values between 128 and 255.

4 Increase the threshold gradually by entering a value or by dragging the slider to the highest value possible that

eliminates defects.

5 Select the Operate On Alpha Channel checkbox to apply the filter to the alpha channel.

Fractal Noise effect
The Fractal Noise effect creates textures and objects that cannot be described using simple geometric shapes. Use this

effect to create organic-looking backgrounds, displacement maps, and textures, or to simulate things like clouds,

lava, or vapor.

Evolution creates subtle changes in the shape of the fractal. Animating these controls results in smooth changes of

the noise over time, creating an effect such as passing clouds or flowing water. Evolution uses progressive revolutions

that continue to change the image with each added revolution, unlike typical revolutions that refer to a setting on the

dial control for which the result is the same for every multiple of 360˚. For Evolution, the appearance at 0˚ is different

from that at 1 revolution, which is different from that at 2 revolutions, and so on. To return the Evolution setting to

its original state (for example, to create a seamless loop), use the Cycle Evolution option.

You can specify how much the fractals evolve over a period of time by setting keyframes for Evolution. The more

revolutions within a given amount of time, the more rapidly the noise changes. Large changes in the Evolution value

over a short period of time may result in flashing.

To create a seamless loop, use Cycle Evolution, and set Evolution keyframes at full revolutions with no degrees—

partially completed revolutions may interrupt the loop.

This effect works with 8-bpc and 16-bpc color.
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Original (left), result with two kinds of noise (center and right)

Controls for the Fractal Noise effect
Fractal Type Specifies the fractal shape you want to use to create the noise.

Noise Type Specifies the type of noise.

Invert Inverts the noise. Select this option to create a negative or inverse of the current noise layer. Black areas

become white, and white areas become black.

Contrast Adjusts the contrast of the noise layer. The default value is 100. Higher values create larger, more sharply

defined areas of black and white in the noise, generally revealing less subtle detail. Lower values result in more areas

of gray, softening or muting the noise. A layer’s contrast is also affected by the Overflow option.

Brightness Adjusts the brightness of the noise layer.

Overflow Remaps the values that fall outside of the grayscale range of 0–255 using one of the following options:

• Clip Remaps values so that any value above 255 is displayed as pure white, and any value below 0 is displayed as

pure black. The Contrast value controls how much of the image falls outside of this range. Higher values result in a

mostly black and/or white image with less gray area. Therefore, higher contrast settings display less subtle fractal

detail. When used as a luma matte, the layer has sharper, better defined areas of transparency.

• Soft Clamp Remaps values on an infinite curve so that all values stay in the range. This option reduces contrast

and makes fractals appear gray with few areas of pure black or pure white. When used as a luma matte, the layer

contains subtle areas of transparency.

• Wrap Back Remaps triangularly, so that values above 255 or below 0 fall back into the range. This option reveals

subtle detail when Contrast is set above 100. When used as a luma matte, the layer reveals more detailed textured

areas of transparency.

Transform Specifies the size and rotation of the noise.

• Rotation Rotates the fractals. Scale specifies the proportional scale of the fractal shapes; the default is 100.

Uniform Scaling scales the noise uniformly. Scale Width and Scale Height specifies the width size and height size

individually for the fractal shapes; available only when Uniform Scaling is not selected.

• Offset Turbulence Specifies the portion of the fractal that is visible in the Composition panel. Because the fractal

shapes are infinite in all directions, only a portion of the fractal is visible at any given time. Use this control to

reposition the shape in the layer.

• Perspective Offset Specifies that the perspective is influenced by the Sub Settings control Sub Scaling. This option

makes it possible to create a perspective effect when animating the Offset Turbulence.

Complexity Adjusts the visible level of detail in the fractal shapes. Lower values result in a softer, almost blurred

appearance. Higher values result in more distinct fractal shapes.

Note: Increasing Complexity results in longer rendering times. If appropriate, try reducing the Size rather than increasing

Complexity to achieve similar results and avoid longer rendering.
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Sub Settings Fractals are generated by repeating instances of a noise function derived from the Fractal Type and

Noise Type. In each instance, the following controls affect how each iteration value is calculated. Complexity deter-

mines the number of iterations that are calculated.

• Sub Influence Determines how much each iteration influences the final image. This value also affects any subse-

quent iterations. At 100%, all iterations have the same amount of influence. At 50%, each iteration has half as much

influence as the previous iteration.

• Sub Scaling Scales the coordinates on which the iteration is calculated. When this value is set lower than 100%,

each iteration adds more refined details. Setting this value at 50% increases the detail by a factor of two for each

iteration—the same way detail increases when scaling down an image.

• Sub Rotation Rotates each iteration by a degree you set. Sub Offset offsets each iteration by an amount you set.

• Center Subscale Calculates each iteration from the same point as the previous. This can result in the appearance

of duplicated layers stacked on top of each other. To avoid this type of repetitive fractal look, don’t select this control.

Evolution Specifies Evolution cycles.

Evolution Options Options for Evolution.

• Cycle Evolution Creates a cycle of evolution that loops over the set amount of time. It forces the evolution state to

return to its starting point, creating a smooth progressive cycle, a nonrepeating cycle, or a loop segment.

To ensure that a cycle completes full revolutions, choose a Cycle value that either matches or is evenly divisible by

the number of revolutions set for Evolution.

• Cycle (in Revolutions) Specifies the number of revolutions that the fractal noise cycles through before it repeats.

The speed of these Evolution cycles is determined by the amount of time between Evolution keyframes. This option

affects only the evolution of the fractal, not Transform or other controls. For example, if you view two identical states

of a fractal with different Size or Offset settings, they do not appear the same.

Note: Cycle is available only when Cycle Evolution is selected.

• Random Seed Sets a unique random value from which to generate the noise. Animating the Random Seed results

in flashing from one set of fractal shapes to another (within that fractal type). For smooth transition of the fractal

shapes use the Evolution option.

You can easily create new fractal noise animations by reusing previously created Evolution cycles and changing only

the Random Seed value. Typing a new Random Seed value alters the noise pattern without disturbing the evolution

animation.

Instead of animating Evolution over the entire composition, save rendering time by pre-rendering and looping one

short evolution cycle for the duration you want.

Opacity Specifies the opacity of the noise layer.

Blending Mode Specifies an operation between the fractal noise and the original layer. These Blending Modes are

identical to the ones in the Modes column, with the following three exceptions:

• None Renders the fractal only and does not composite with the original layer.

• Hue Renders the fractal as hue values instead of grayscale. The Saturation and Lightness of the original layer are

maintained. If the original layer is grayscale, nothing happens.

• Saturation Renders the fractal as saturation values instead of grayscale. The Hue and Lightness of the original

layer are maintained. If the original layer is grayscale, nothing happens.
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To create a seamless loop using Fractal Noise

1 Select a layer in the Timeline panel, and choose Effect > Noise & Grain > Fractal Noise.

2 Set two keyframes for Evolution.

3 Adjust the time between keyframes and the number of Evolution revolutions until you are satisfied with the

animation of the noise.

4 Select Cycle Evolution.

5 Set a value for Cycle. (The evolution completes the number of revolutions you specify for Cycle in the amount of

time determined by the distance between Evolution keyframes. Determine the Cycle value by considering how much

of this cycle you need to render before it repeats. The length of the project and use of the cell pattern created

determine this. Choose the shortest length appropriate for your project to save rendering time.)

6 Initially, the last frame of a cycle is identical to the first frame. To create a seamless loop, skip the last frame by

setting the Out point of the layer one frame before the last frame of the cycle.

7 Move the current-time indicator to the point on the timeline where the cycle completes. For example, if the Cycle

is set to 2, locate the frame on the timeline where the Evolution value is 2.

Note: If you set keyframes for other Fractal Noise controls, return them to their initial settings where the cycle begins to

repeat in the timeline or the controls don’t loop.

8 Move the current-time indicator back one frame.

9 Trim the layer’s Out point at this frame.

10 Prerender this layer, and import it into your project.

11 Select the file in the Project panel, and choose File > Interpret Footage. Then set Loop to the number of loops

required for the duration of the layer in the project.

Match Grain effect
This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

See also

“To match noise or grain between images” on page 361

“Working with added or matched grain” on page 363

Median effect
The Median effect replaces each pixel with the median pixel value of neighboring pixels within a given radius. At low

values, this effect is useful for reducing some types of noise. At higher values, this effect gives a layer a painterly effect.

This effect is the same at both Draft and Best quality. Use Radius to specify how many pixels to examine for the

Median effect. For instance, when Radius is set to 1, the Median is performed on the eight neighboring pixels that

are within one pixel of the center pixel.
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This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Noise effect
The Noise effect randomly changes pixel values throughout the image. The layer’s quality setting does not affect

Noise.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for the Noise effect:

Amount Of Noise Specifies the amount of noise, and therefore the amount of distortion, through random

displacement of the pixels. The range is 0% (no effect) to 100% (the image may not be recognizable).

Noise Type Randomly changes the red, green, and blue values of the image’s pixels individually when Use Color

Noise is selected. Otherwise, the same value is added to all channels.

Clipping Determines whether the noise causes pixel colors to wrap around. When the color of a pixel gets as large

as it can, clipping makes it stay at that value. With unclipped noise, the color value wraps around or starts again at

low values. When Clipping is selected, even 100% noise leaves a recognizable image. For a completely randomized

image, turn off Clipping and turn on Color Noise.

Noise Alpha effect
The Noise Alpha effect adds uniform or squared noise to the alpha channel of a source layer.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)
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Adjust the following controls for the Noise Alpha effect:

Noise Specifies the type of noise the effect uses. Unique Random creates equal amounts of black and white noise.

Squared Random creates high-contrast noise. Uniform Animation creates animated noise, and Squared Animation

creates animated contrast.

Amount Specifies the amount of noise that’s added to the layer.

Original Alpha Specifies how to apply noise to the alpha channel of a layer. Add produces equal amounts of noise in

the transparent and opaque areas of the layer. Clamp produces noise in the opaque areas only. Scale increases the

amount of noise proportionate to the level of opacity and produces no noise in 100% transparent areas. Edges

produces noise only in partially transparent areas, such as the edge of the alpha channel.

Overflow Specifies how the effect remaps values that fall outside the grayscale range of 0-255. Clip displays values

above 255 as opaque and values below 0 as transparent. Wrap Back forces values back into the 0-255 range, creating

subtle details. For example, a value of 256 wraps back to 254, and a value of -1 wraps back to 1.

Random Seed Specifies a random value for noise. This control is active only if you choose Uniform Random or

Squared Random.

To produce flashing noise, animate the Random Seed control. To create smoothly animated noise, animate the Noise

Phase value.

Noise Phase Specifies the placement of noise. This control is active only if you choose Uniform Animation or

Squared Animation from the Noise pop-up menu.

Noise Options (Animation) Specifies how you animate noise.

• Cycle Noise Produces a cycle of noise that plays through once in the specified amount of time.

• Cycle Specifies the numbers of revolutions of the Noise Phase that the noise cycles through before it repeats

(available only when Cycle Noise is selected).

Alter the timing of the Noise Phase keyframes to adjust the speed of the Noise Phase cycles.

To save time animating the Noise Phase value, use the Cycle Noise option to create a seamless noise loop. Then,

render the layer, and reimport it as a new source footage.

Noise HLS effect and Noise HLS Auto effect
The Noise HLS effect generates static noise in layers that use still or moving source footage. The Noise HLS Auto

effect automatically creates animated noise. Both effects offer various types of noise that can be added to the hue,

saturation, or lightness of a layer. Controls for these effects are the same except for the final control that determines

noise animation.

These effects work with 8-bpc color.

Original (left), and with effect applied (right)
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Adjust the following controls for either the Noise HLS effect or the Noise HLS Auto effect:

Noise Specifies the type of noise the effect adds. Uniform produces evenly distributed pixel noise. Squared produces

sparse, high-contrast noise that is distributed randomly. Grain produces grain-like noise that is useful for simulating

film.

Hue Specifies the amount of colored noise that the effect generates, in proportion to the layer’s hue values.

Lightness Specifies the amount of grayscale noise that the effect generates, in proportion to the layer’s luminance

values.

Saturation Specifies the amount of colored and grayscale noise that the effect generates, in proportion to the layer’s

saturation values.

Grain Size This control is active only when you choose Grain from the Noise pop-up menu.

Noise Phase (Noise HLS only) Specifies the random seed value for the noise. When you set keyframes for Noise

Phase, the effect cycles through the phases to create animated noise. Greater value differences between keyframes

increase the speed of the noise animation.

Noise Animation Speed (Noise HLS Auto only) Specifies the speed of the noise animation. To increase the rate at

which the noise effect changes, set the value higher. For slower changing noise, set a lower value. To accelerate or

decelerate the speed of the noise, set keyframes for this control.

Remove Grain effect
This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

See also

“To remove noise or grain from an image” on page 358

“Removing grain in frame sequences” on page 360

Paint effects

Paint effect
The Paint effect lets you modify the color and transparency of a layer while leaving the source file unaltered. To use

this effect, apply the effect or simply select any of the paint tools in the Tools panel. You can use the Brush tool to

create spontaneous-looking writing or painting effects by animating paint strokes. You can use the Clone Stamp tool

to retouch footage and perform necessary tasks such as wire removal. Since paint strokes are applied as effects, you

can interleave them with other effects.

This effect works with 8-bpc and 16-bpc color.
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Paint strokes applied to background and foreground layers

See also

“To specify paint tool options” on page 313

Vector Paint effect (Pro only)
Vector Paint strokes are made up of many tiny points that create the stroke path. You cannot isolate or individually

adjust these individual points, but you can affect them using Vector Paint features such as smoothing and wiggling.

The wiggling of a stroke is created by manipulating and displacing these points along the stroke path.

This effect works with 8-bpc and 16-bpc color.

Original (left), brushstroke with a selection spline (center), and a second stroke created with Wiggle control (right)

Vector Paint strokes are nondestructive, so painting and erasing actions affect only the appearances on a layer; they

do not alter the original source file of any image on the layer. All paint strokes are recorded and stored as they are

drawn, so you can make the strokes appear in various sequences, such as animated over time or all at once.

For animated strokes, the exact timing (real time) you used to draw the strokes can be played back and rendered. You

can also adjust the playback speed to fit the timing you want. You can also create new strokes by blending existing

strokes, both in space and in time.

Vector Paint supports the Wacom and Creation Station tablets’ pressure-stylus and erase functions.

Note: The Vector Paint options menu contains some unique commands and settings that are not otherwise accessible.

Open this menu by clicking the Vector Paint toolbar options button when a painting tool is selected.

When you use Vector Paint on a layer, you can start over at any time by deleting all strokes or the Vector Paint effect

itself. To delete the effect, select Vector Paint in the Effect Controls panel and press Delete or Backspace.

To paint with the Vector Paint effect (Pro only)

1 Select the Selection tool  in the Tools panel.

2 In either the Composition or Timeline panel, select the layer on which you want to paint.

3 Choose Effect > Paint >Vector Paint. The Vector Paint effect appears and is selected in the Effect Controls panel,

and the Vector Paint toolbar appears on the left side of the Composition panel.

Note: This toolbar appears only when Vector Paint is selected (highlighted) in the Effect Controls panel. If the rulers in

the Composition panel interfere with your view of the Vector Paint toolbar, choose View > Hide Rulers.
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4 Select the paint tool you want to use from the Vector Paint toolbar.

5 In the Effect Controls panel, select the options you want for Brush Settings and Composite Paint.

6 In the Timeline panel, move the current-time indicator to the appropriate point in time.

7 In the Composition panel, drag to draw strokes on the layer.

To quickly set your brush Radius and Feather amounts as you paint, press Ctrl (Windows) or Command (Mac OS)

and click anywhere in the Composition panel; then drag in or out to resize the brush. When you release the Control

or Command key, you can then drag in or out to resize the feather.

Vector Paint tools (Pro only)

Vector Paint tools in Composition panel

You can use three tools in the Vector Paint toolbar to work with Vector Paint:

Selection tool Select a stroke by clicking or dragging across it. You can drag across several strokes to select them

simultaneously. You select strokes in order to edit or delete them.

Paint tool Paint directly on the layer, using settings defined in the Effect Controls panel. When you use the Paint

tool, the pointer appears as a circle (or square) in the actual size of the brush.

Eraser tool Erase areas of the layer, using Brush Type settings defined in the Effect Controls panel. The Eraser

pointer appears as a circle with an X through it. If you are using an installed tablet with stylus eraser support, Vector

Paint automatically switches to eraser mode when you use the stylus eraser.

Clicking the active tool (Selection, Paint, or Brush) in the Vector Paint toolbar deactivates painting and hides the

other buttons in the toolbar. You can then drag and scale the layer. To reactivate the toolbar, reselect one of the three

Vector Paint tool buttons.

To change Vector Paint brush types (Pro only)

Vector Paint includes three brush types: Paint, Air, and Square. These brush types define the shapes and performance

of both the Paintbrush tool and the Eraser tool. All brush types but the Air brush include a Feather setting.

❖ Do one of the following:

• In the Vector Paint toolbar, select the Paint , Air , or Square  button.

• In the Effect Controls panel, click the current Brush Type setting (Paint, Air, or Square) repeatedly to cycle

through the three brushes until the brush you want is selected.
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With increased Feather and reduced Opacity settings, Paint brushstrokes may resemble Air brushstrokes. However,

when you paint a single stroke that crosses itself, the two brush types produce different results. Air brushstrokes build

up opacity as the stroke crosses itself. Paint brushstrokes don’t build up opacity within the same stroke, whether they

cross themselves or not. To increase opacity with Paint brushstrokes, create multiple strokes over the area (like

multiple coats of paint).

Note: Each brush type is also available for the Eraser tool. When the Eraser tool is selected in the Vector Paint toolbar,

the name appears with a -E after it in the Effect Controls panel. Also, if a tablet is installed and the stylus has eraser

support, Vector Paint automatically switches to eraser mode when you use the stylus eraser.

Brush Settings controls for the Vector Paint effect (Pro only)
Radius Controls the size of the brush or eraser.

If you press Alt (Windows) or Option (Mac OS) when clicking the question mark representing the Radius value, a

Set Value dialog box appears. You can then type a Relative Radius, reducing the radius of each stroke by that

percentage. The default value is 100%, which produces no change in the stroke radii.

Feather Controls the softness of brush or eraser edges (but does not affect the airbrush).

When you drag to change Radius, Feather, or Opacity values, hold down Ctrl (Windows) or Command (Mac OS) to

reduce the size of the increments. To change the value by larger increments, hold down Shift as you drag.

Opacity Controls the transparency of the paint or erasures.

Brush Type Shows the brush type you selected in the Vector Paint toolbar in the Composition panel.

Color Represents the paint color used to draw strokes. Select a new color by clicking the Color swatch and then using

the Color Picker, or by using the eyedropper to sample a color from the desktop.

When one or more strokes of the same color are selected, this swatch displays the Color of those strokes. You can

change the color of the selected strokes.

Color Clone When Color Clone is turned on, the brush behaves like a combination eyedropper and brush. The color

of the stroke is determined by the pixels at the position where the stroke begins. The Color swatch in the Effect

Controls panel Brush Settings displays the new sampled color. When you begin another stroke, a new group of pixels

is sampled and used to color that stroke.

The Color Clone affects strokes only while you draw; it has no effect on an already completed stroke. This is the only

Brush Setting you can’t apply after drawing. Clicking either the eyedropper or Color swatch turns off the Color Clone

feature.

Stylus The Radius option affects stylus sensitivity. When you select this option, the pressure of the pen on the tablet

changes the weight of the stroke as it is drawn. Lighter pressure decreases the radius (creating a thinner stroke), and

increased pressure increases the radius (creating a wider one). The Radius value setting indicates the maximum

radius amount. Use the tablet settings to adjust the pressure-width sensitivity for the pen.

Note:You can choose Stylus Radius even when no tablet is installed. This option affects strokes when wiggling is enabled.

The pressure variation of the pen on the tablet alters the opacity of the stroke as you draw. Light pressure results in

lower opacity values, while increased pressure creates more opaque strokes. The Opacity value defines the maximum

of the Opacity range.

Selecting and editing Vector Paint strokes (Pro only)

When you select a single stroke or strokes with the same Brush Settings, you can edit the enabled Brush Settings in

the Effect Controls panel. Your changes to the strokes immediately appear in the Composition panel as you complete

them.



ADOBE AFTER EFFECTS 7.0
User Guide

478

When you select multiple strokes that have different Brush Settings, a question mark [-?-] appears next to that Brush

Setting in the Effect Controls panel. If you edit that value, all of the selected strokes are reset to the new value.

To edit a specific paint stroke, select it using the Selection tool  on the Vector Paint toolbar and click or drag, or

choose Select from the Vector Paint options menu. You can select and then move, revise attributes, or delete either a

paint stroke or erasure stroke.

Use the following commands from the Select option in the Vector Paint toolbar option menu to select and edit paint

strokes:

Note: Some options are tied to the current position of the current-time indicator in the Timeline panel.

All Selects all strokes on a layer.

None Deselects all strokes on a layer (available only if some strokes are selected.)

Visible Selects all strokes visible at the current frame.

Current Time Selects all strokes that were drawn at the current time position. (Playback Speed does not affect the

original start time of strokes.)

Last Painted Selects the last-painted brush stroke (or erase stroke). If you painted several strokes with the Shift key

held down, this command selects that group of strokes.

Similar With one or more strokes selected, this command selects additional strokes with similar Brush Settings

properties. If strokes with dissimilar properties are initially selected, this command selects a broader range of strokes.

Inverse Toggles to a selection of all unselected strokes, leaving the previously selected strokes unselected.

After you select one or more strokes, you can transform them, such as by rotating, scaling (vertically, horizontally,

or both), or nudging (repositioning one pixel at a time).

Tools for editing paint work with Vector Paint (Pro only)

Use the following tools on the Vector Paint toolbar in the Composition panel to revise your paint work:

Undo button Click the Undo button to cancel your most recent single painting action, if it can be undone. If the

action cannot be undone, this tool is dimmed (not available). You can also undo paint actions using the Undo

command on the Vector Paint options menu or by pressing Ctrl+Z (Windows) or Command+Z (Mac OS).

Note: Do not use the Undo command on the Edit menu to undo Vector Paint actions.

Eyedropper Use the eyedropper to select a color to paint with from a sampling anywhere on the desktop. Press

the Escape key to cancel the eyedropper.

Note: By default, the eyedropper samples a single pixel. Hold down Ctrl (Windows) or Command (Mac OS) and click

the eyedropper to sample a 3-x-3-pixel average. Hold down Shift and drag to sample a range of multiple pixels.

Color swatch Displays the current selection as a solid color. When clicked, it opens the Color Picker dialog

box. If the Opacity setting is less than 100%, the Color Swatch icon appears checkered, not solid.

If Color Clone is enabled in the Effect Controls panel, this swatch represents the sampled color. Shift-click the Color

Swatch to open the Set Value dialog box for Opacity without turning off Color Clone.

Smoothing a Vector Paint stroke (Pro only)

The Smoother command in the Vector Paint options menu removes points from a selected stroke or strokes. This

action simplifies stroke paths, smoothing out the curves. By eliminating unneeded points, Smoother can also

dramatically reduce the size of the project file when you have complex drawings composed of many strokes.
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When you select a path and choose Smoother, a dialog box appears in which you can type a Max Error value. This

value sets the tolerance for the smoothing. Higher values remove more points on the path, resulting in a smoother

stroke. Set values within the range 0–100. The default value, 1.0, removes only redundant points, maintaining details

in the stroke.

After you click OK in the dialog box, the stroke paths immediately reflect the smoothing in the Composition panel.

Note: Smoothing cannot be undone. Removing these points may alter the shape of the path. If you want to preview the

results before you commit, create a duplicate of the layer and apply Smoothing to test the result. If the results are satis-

factory, then apply the command to the original layer.

Configuring a stylus for Vector Paint in Windows (Pro only)

You can specify your preferences for your Wacom or Creation Station tablet in several areas of the After Effects

interface.

Note: Using a tablet with the Vector Paint effect is not supported in Mac OS X. You can, however, use a tablet with the

standard paint tools and the Paint effect. See “To set brush dynamics for graphics tablets” on page 319.

Select the following preferences in the Vector Paint Preferences dialog box by clicking Options in the Effects Control

panel:

Stylus Vendor Tablets are not supported in Vector Paint on Mac OS X. “Unknown” appears.

Use High Res. Coordinates When this option is checked, data is recorded with high resolution (if supported by the

stylus). This setting overrides normal mouse coordinates to use the higher resolution of the tablet, recording strokes

with greater precision and subpixel accuracy.

Note: Wacom tablets do not support High Res. Coordinates when Proportional mode is selected in the Wacom control

panel.

If you experience offset coordinates with your pen, try the following:

• Check that screen resolution and monitor settings haven’t changed.

• If using a Wacom tablet, make sure that your tablet-mapping aspect isn't set to Proportional. Select To Fit mode

or One To One mode instead.

• Restart your system.

If all else fails, turn off Use High Res. Coordinates; subpixel accuracy will be lost, but Pressure and Eraser modes will

still be available.

Playing back your painting with Vector Paint (Pro only)

Use the Playback Mode pop-up menu in the Effect Controls panel to specify when and how quickly your strokes

appear in your composition. When you draw strokes, Vector Paint records information for the stroke start time and

the drawing time of each stroke (in real time). The Playback Mode you select determines when a stroke starts and

for how long it appears. You can set the speed at which the strokes play back using Playback Speed.

Play back your strokes using standard (spacebar) preview or RAM preview, or by viewing the results of a rendered

Composition.

Note: Regardless of how you record your strokes and which Playback Mode you select when recording, you can always

switch to another Playback Mode at any time.

While the Playback Mode chosen affects what you see during playback, it also determines what you see while you

are drawing strokes. Onion Skin mode, for example, is used primarily while drawing strokes, and then another mode

is selected before rendering.
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Note: Note the position of the current-time indicator when you begin drawing strokes. This position affects the

appearance of strokes in all modes except All Strokes.

Adjust the following controls to affect the way that strokes appear in the composition:

All Strokes Displays all strokes for the full duration of the layer, regardless of the position of the current-time

indicator when you drew them.

Past Strokes Displays strokes from the time at which they were recorded until the end of the layer (the Out point).

Hold Strokes Displays strokes from the frame on which they were drawn and holds them only until the point at

which the next stroke was drawn. This treats strokes like Hold keyframes; as a stroke appears, it replaces the next, as

in a slide show.

Animate Strokes Begins drawing the stroke at the current time (that is, at the frame where the current-time indicator

is when you draw the stroke). The stroke animates in the same way as it was drawn.

Current Frame The default Draw Strokes setting. This control displays the stroke only at the frame at which it was

painted.

Onion Skin Displays strokes drawn on the current frame plus strokes drawn on the surrounding few frames. These

additional strokes appear color-coded and at reduced opacity, to distinguish them from the strokes on the current

frame. Those strokes actually exist only on the frames in which they are drawn. Onion-skinning is very useful for

drawing frame-by-frame animations because it gives you reference points for the stroke positions.

Use the Onion Skinning options in the Vector Paint Preferences dialog box to specify how previous and forward

strokes appear when Onion Skin is the active Playback Mode. (To open Vector Paint Preferences, use the Vector Paint

options menu and choose Options.) These options include the following:

• Frames Backward / Frames Forward Sets the number of frames backward or forward that are displayed. Both

backward and forward frames are displayed unless one or both of these values is set to 0.

• Color Backward / Color Forward Sets the color of the display of backward and forward strokes.

• Skin Opacity Sets the percentage of opacity for onion-skin strokes.

Drawing a three-frame animation in Onion Skin Playback Mode: As you draw on successive frames, the strokes you drew on previous (or
forward) frames also appear for your reference.

To adjust the playback speed for the Vector Paint effect (Pro only)

The Playback Speed value in the Effect Controls panel can change the timing at which painted strokes appear in

previews and rendered compositions. Playback Speed affects the Vector Paint strokes only when you set the Playback

Mode to Past Strokes, Hold Strokes, or Animate Strokes.

When you create strokes on a layer, the stroke is tied to the location of the current-time indicator in the Timeline

panel when you start drawing. Vector Paint also records the amount of time you take to draw the stroke. For example,

you might start painting a stroke with the current-time indicator set to 0:00 and use 1.5 seconds to draw the stroke.

Then, you might move the current-time indicator to 2:00 and draw a second stroke (leaving 0.5 seconds between the

completion of the first stroke and the beginning of the second one). For this example, let’s say you use 1.0 second to

draw the second stroke. The entire process covers 3.0 seconds on the timeline.
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By changing the playback speed, you can change the timing for stroke appearances in previews and rendered compo-

sitions.

1 In the Effect Controls panel under Vector Paint, make sure that the Playback Mode option is one of the following:

Past Strokes, Hold Strokes, or Animate Strokes.

2 In the Effect Controls panel, click the underlined Playback Speed value and type a new value, using a number

between 0 and 100.

You can also change the playback speed by dragging the value itself or the slider below it: left to decrease the speed,

right to increase it.

For animations, always begin painting strokes at the layer In point, especially when adjusting the Playback Speed.

Doing this locks the In point (first stroke’s start time) to the In point of the layer, making it easier to locate the

beginning of the animation. Then, simply place the layer’s In point where you want the animation to begin in the compo-

sition.

The results that your changes produce depend on the Playback Mode setting:

Animate Strokes With the Playback Speed at 1.0, each stroke appears as if drawn by an unseen hand, taking the same

amount of time as you used to create it. When you increase the Playback Speed value, you reduce the time it takes to

draw each stroke and the gaps between strokes. If you decrease Playback Speed, both the time taken to draw the

strokes and the length of the gaps between strokes increase. Using the example above, if you increase the Playback

Speed value to 2.0 (double the speed), the first stroke would be drawn in 0.75 seconds, the gap between the two

strokes would be shortened to 0.25 seconds, and the second stroke would be drawn in 0.5 seconds. The entire

animation would be complete after 1.5 seconds of playback.

Past Strokes At Playback Speed 1.0, each stroke appears in completed form at the frame in which you started

drawing and remains visible for the duration of the layer playtime. When you increase Playback Speed, each stroke

appears at an earlier point in time. If you decrease Playback Speed, strokes occur at later points in time.

Hold Strokes Like Past Strokes mode, each stroke appears in completed form at the frame in which it was drawn.

However, in Hold Strokes mode, each stroke disappears when the next stroke appears (without any gap between

them). Otherwise, the results of changing Playback Speed are similar to those in Past Strokes mode.

To change playback time with the Vector Paint Re-timer (Pro only)

The results from using the Re-timer or changing the Playback Speed value are similar but have important differences:

• You apply the Re-timer to individual strokes you select before choosing the Re-timer option. In comparison,

changes in Playback Speed apply to all paint strokes on the layer.

• The Re-timer affects only playbacks that use Animate Strokes mode. Playback Speed changes can also influence

Hold Strokes and Past Strokes modes.

• The Re-timer does not affect the start times of strokes. Changing the Re-timer value shortens or lengthens the

amount of time previews and rendered versions take to draw the stroke. The strokes begin to appear at the same

points in time as before, but they are drawn more quickly or more slowly.

• The values for Re-timer are percentages of the original time required to draw the stroke. The default value is 100%.

A higher value causes the drawing time to increase, so that a setting of 200% uses twice the time to draw the

selected strokes. A lower value draws the selected strokes more quickly.

1 Using the Vector Paint Selection tool , click or drag to select the strokes.

2 Open the Vector Paint options menu, and choose Re-timer.

3 In the Set Value dialog box, type a value for Relative Duration (%), and click OK.
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Note: You cannot use the Undo command to reverse the Re-timer after you apply it. However, you can apply the Re-

timer again, using the inverse of the value you typed previously to revert to the original value. For example, if you

changed the Re-timer value to 200% and then wanted to go back to the earlier setting, choose Re-timer again and type

a value of 50%.

To paint using QuickPaint mode in Vector Paint (Pro only)

Ordinarily, when you draw strokes with Vector Paint, those strokes are associated with the position of the current-

time indicator. After you draw a stroke, you can draw more strokes at the same time setting or at different time

settings. The results you see when you preview or render the composition depend on your Playback Mode setting.

The Shift-Paint Records controls change the way that strokes associate with time settings. This is called QuickPaint

mode. One of the advantages of this feature is that you can create fast continuous recordings of a sequence of strokes

without redraw delays after each one.

1 Choose a Shift-Paint Records control from the Shift-Paint Records submenu of the Vector Paint options menu:

Note: You cannot apply a Shift-Paint Records option to strokes you have already created.

To Current Frame Specifies all strokes to start at the current frame (the current-time indicator position when you

draw the strokes). This is similar to ordinary painting mode except that Shift-Paint Records has no redraw delays.

To Sequential Frames Specifies that all stroke start times are offset by one frame. The next frame is calculated

according to the composition frame rate at the time of drawing. For example, if the current-time indicator is at 0:00

when you draw three strokes, then the start point is 0:00 for the first stroke, 00:01 for the second stroke, and 00:02

for the third stroke.

In Realtime Specifies that stroke start times are determined by how they are drawn. The strokes are recorded and

played back in real time even if you lift the brush while drawing. Strokes play back exactly as they were recorded,

including any time that elapsed (gaps) between the creation of the strokes (provided that you continued to hold down

Shift during the time gap).

Continuously Specifies that stroke start times follow one another, without any gaps. When one stroke is finished

drawing, the next one begins immediately. Otherwise, this is similar to the In Realtime option.

2 Press Shift as you paint.

When you draw, the Info panel displays the name of the selected control: Current Frame, Sequential Frames,

Realtime, or Continuously.

Wiggle Controls for the Vector Paint effect (Pro only)
Enable Wiggling When Enable Wiggling is selected, all strokes on that layer are set to wiggle using the Wiggle

Control values set in the Effect Controls panel.

Wiggles/sec Determines the number of Wiggles per second of Composition time. Wiggling is spline-based

morphing of paint strokes. Wiggles/sec controls the speed at which the morph completely shifts shape. For example,

in a 30-fps composition, setting the Wiggles/sec value to 30 creates one wiggle per frame. Lower values result in a

smooth animation of morphing strokes. Higher values create more rapid wiggling.

Displacement Variation Determines how far the stroke moves from its original position while wiggling. The greater

the value, the greater the deviation in shape.
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No Displacement Variation (left), Medium Displacement Variation (center), and High Displacement Variation (right)

Displacement Detail Determines how much the original shape of the path is altered while wiggling. Greater values

increase the detail of displacement (or change in shape) in the stroke. Lower values produce less displacement,

leaving the path closer to its original shape.

When Displacement Detail values are set very high, the stroke may not resemble its original shape at all. This is useful

in creating randomly animated strokes.

Low Displacement Detail (left), Medium Displacement Detail (center), and High Displacement Detail (right)

Set the Displacement Detail value by using the slider in the Effect Controls panel (preset to values between 0 and

100) or by clicking the underlined Displacement Detail value and typing a number between 0 and 1000.

Pressure Variation Determines how much the Radius and Opacity values of the stroke vary while wiggling. For

strokes that have Stylus Radius enabled, the Radius wiggles. For strokes that have Stylus Opacity enabled, the Opacity

wiggles. The amount of variation in either the Radius or Opacity value while wiggling depends on the value specified

for Pressure Variation. The Radius and Opacity settings in the Brush Settings act as maximum amounts, not to be

exceeded while wiggling.

Note: Strokes that do not have either Stylus Radius or Stylus Opacity options selected are not affected by the Wiggle

Pressure Settings. However, these options can be enabled even when a tablet is not installed.

No Pressure Variation (left), Low Pressure Variation (center), and High Pressure Variation (right)

In the Effect Controls panel, set the Pressure Variation value by clicking the underlined Pressure Variation value and

typing a number between -30,000 and 30,000, or by dragging the Pressure Variation slider.

Pressure Detail Determines how tight the pressure variation appears along the stroke. Higher values create more

dense variations.
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Low Pressure Detail (left), Medium Pressure Detail (center), and High Pressure Detail (right)

Individual Stroke Seeds When selected, this option creates a different random wiggle seed for each stroke on a layer.

Because the Wiggle Controls apply to all strokes on a layer, the wiggle parameters are always the same. To randomize

the wiggling of the individual strokes, select the Individual Stroke Seeds option.

If Individual Stroke Seeds is not selected, all strokes use the same wiggle seed, so they all have the same spatial wiggle

values. For example, two strokes exactly on top of each other will wiggle equally. By setting individual seeds for each

stroke, you avoid identical strokes wiggling in the same way.

Original (left), Individual Stroke Seeds Off (center), and Individual Stroke Seeds On (right)

Selecting Composite Paint options for Vector Paint (Pro only)

Various options control the way Vector Paint composites strokes on a layer. Select the option you want in the Effect

Controls panel for a layer, in the Composite Paint pop-up menu under Vector Paint. These options control two

things: what you see in the Composition panel as you work, and what aspects of the layer the strokes affect, including

what happens when you preview and render the composition.

As you paint and erase, you can either hide or display the footage image. You have similar viewing options when you

paint using matte and alpha-channel options.

As you work, painting and erasing can block pixels in an original image, such as a footage file or solid. You can also

paint on a virtual layer above or below that image (although this does not appear as a separate layer in the Timeline

panel). You can paint and erase to adjust mattes and alpha channels for the original image. You can restrict Vector

Paint strokes to the areas inside or outside the original alpha channel.

Each Composite Paint option specifies a unique combination of work view, layer type (image, matte, or alpha

channel), and placement of strokes relative to the original image. You can select strokes later and change the

Composite Paint option, but it is a good idea to understand what results each option produces before you start

painting.

The following illustrations use the same basic example of an imported image. A paint stroke has been applied,

followed by an erasure stroke. The original image is the green layer, including an alpha channel that reveals the

background layer. For these examples, the Transparency Grid is turned on. (Click the Transparency Grid button

at the bottom of the Composition panel).
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Composite Paint options

A. In Original (default setting), before painting The imported image is visible.

B. In Original, with paint stroke The paint strokes appear above the original image.

C. In Original, with paint stroke and erasure stroke An erasure stroke removes underlying portions of both the paint

stroke and the original image.

D. Only The original image on the layer does not appear in the working view; only paint strokes are shown. Erasures

remove only paint, not the original image.

E. Over Original The original image is visible in the working view, similar to the In Original option. Painting and

erasing occur as with the Only option: Erasing removes pixels from underlying paint strokes but does not alter the

original image.

F. Under Original The layer image is visible in the working view. Painting does not alter the original image; it affects

only areas of the layer that are outside the original image. Erasures remove only paint pixels, not the original image.

G. Track Original Matte The original image is not visible in the working view. Paint strokes are visible. Painting

affects only the area within the original image alpha channel (that is, paint applied within the original circle area).

Erasures remove only existing paint pixels.

H. Track Original Matte Visible The original image is visible in the working view. Otherwise, Vector Paint strokes

behave exactly as with Track Original Matte, so erasures do not affect the original image.

I. As Matte Before you paint, nothing is visible in working view. Paint strokes affect only the matte, revealing the

underlying original image. Erasures add back areas of opacity, so that they appear to erase the underlying image

again. Both types of strokes are restricted to the area of the original alpha channel.

J. As Inverse Matte Before you paint, the original image is visible in the working view. Painting affects only areas

within the original image alpha channel. Paint strokes block (rather than reveal) the original image, appearing to

erase the original image. Erasures remove only painting strokes, (that is, they re-reveal the underlying image within

the alpha channel).

K. In Original Alpha Only The original image appears within its alpha channel in working view. Strokes affect the

alpha channel itself. Painting adds areas of opacity. Erasures add areas of transparency.

A B C D

E F G H

I J K L
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Note: You do not need to switch colors when you paint in the alpha channel, even if you paint with gray. The changes to

the opacity of the painted area are determined by the values shown for Opacity and Feather under Brush Settings in the

Effect Controls panel, not by the color of paint.

L. Under Original Alpha Only The original image appears within its alpha channel in working view. Strokes do not

affect the original image alpha channel, only areas outside of it. Painting adds areas of opacity; erasing restores trans-

parency to painted areas only.

Note: The difference between using Under Original and Under Original Alpha Only is that in the latter, strokes affect

only the alpha channel; RGB is unchanged.

To select Vector Paint Preference options (Pro only)

Use the Vector Paint Preferences dialog box to customize the way you view your work in Vector Paint. Unlike most

other effects, the options you select as Vector Paint preferences apply to all your Vector Paint work, both on the

current layer and on other layers. Your current preferences are also used for subsequent sessions of Vector Paint.

1 Select Vector Paint in the Effect Controls panel and open the Vector Paint Preferences dialog box in any of the

following ways:

• Click the menu button  in the Vector Paint toolbar in the Composition panel, and choose Options.

• Right-click (Windows) or Control-click (Mac OS) anywhere in the Composition panel, and choose Options.

• In the Effect Controls panel, click the word Options next to the name Vector Paint.

2 Choose the appropriate options.

Note: Better Preview While Drawing is temporarily disabled in low-memory situations, and Draft quality is used

instead. Also, if your preview doesn’t drawing correctly, you may have an incompatible graphics card.

Perspective effects

3D Glasses
The 3D Glasses effect creates a single 3D image by combining a left and right 3D view. You can use images from 3D

programs or stereoscopic cameras as sources for each view. The method you use to create the combined images

dictates how you view them. For example, you can use 3D Glasses to create an anaglyphic image, which is an image

containing two slightly different perspectives of the same subject that are tinted contrasting colors and superimposed

on each other. To create an anaglyphic image, first combine views and tint each one a different color. Then, use 3D

glasses that have either red and green lenses or red and blue lenses to view the resulting image stereoscopically.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)
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To avoid problems with flipped views, keep the following guidelines in mind:

• Use the same vertical dimensions for the composition and source images. A one-pixel difference produces the

same result as moving the position one pixel vertically.

• Make sure that the layer’s Position values are whole numbers (such as 240 instead of 239.7).

• If your left and right view images are interlaced, de-interlace them before using 3D Glasses, to avoid field

mismatch.

• Because 3D Glasses creates interlaced frames, do not select an interlace option in the Render Settings dialog box.

Ghost effects occur when the luminance values of one color exceed those of another color to such an extent that you

can see the first color through the wrong lens of anaglyph glasses. For example, an excessive red luminance value

becomes visible through the blue lens. If you adjust the Balance value, test the results on the final output media. If

you set the Balance value too high, a reversed shadow may appear.

Controls for the 3D Glasses effect
Left View, Right View Specify the layer to use as the left or right view. You need to apply 3D Glasses to only one layer

in a composition. If you use a second layer, make sure that the two layers are the same size. The second layer does

not need to be visible in the composition.

Convergence Offset Specifies the amount that the two views are offset. Use this control to realign uncalibrated

camera views of rendered material. Photos or images rendered from 3D programs are generally misaligned and

require a negative Convergence Offset value. If the original footage was shot with correct convergence, there is no

need to change this value. Keyframing this value may result in erratic animation.

Swap Left-Right Swaps the left and right views.

3D View Specifies the rendering mode the effect uses to combine the views.

• Stereo Pair Scales both layers to fit side by side within the effect layer’s bounding box. Select Swap Left-Right to

create cross-eyed vision. Selecting Stereo Pair disables Convergence Offset.

• Interlace Upper L Lower R Takes the upper (first) field from the Left View layer, and the lower (second) field from

the Right View layer, and combines them into a single or a sequence of interlaced frames. Use this option if you want

to view the results with polarized or LCD shutter glasses. Select Swap Left-Right to switch fields.

• Red Green LR Tints the Right View layer red, and the Left View layer green using the luminance values of each

layer.

• Red Blue LR Tints the Right View layer red and the Left View layer blue using the luminance values of each layer.

• Balanced Red Green LR Performs the same operation as Red Green LR but also balances the colors to reduce

shadows or ghosting effects caused by one view showing through the other. Setting a high value reduces the overall

contrast.

• Balanced Red Blue LR Performs the same operation as Red Blue LR but also balances the colors in order to reduce

shadows or ghosting effects.

• Balanced Colored Red Blue Converts the layer into a 3D view using the original layer’s RGB channels. This option

maintains the layer’s original colors but may produce shadows and ghosting effects. To reduce these effects, adjust

the balance or desaturate the image, and then apply 3D Glasses. If you are using CG images, raise the black level of

both views before applying the effect.

Balance Specifies the level of balance in a balanced 3D view option. Use this control to reduce shadows and ghost

effects. The default balance that 3D Glasses sets when you select the Balanced Colored Red Blue option is the ideal
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value: If you set Balance to 0.0, 3D Glasses creates no 3D depth, and if you set Balance too high, 3D Glasses produces

a highly saturated output.

About red, blue, and green lenses

When you work with red and blue images, the blue color in glasses with red and blue lenses is actually cyan, not blue.

Red and cyan are complementary colors, producing the best separation because they filter each other out more

efficiently. When you work with red and green images, it may appear that the green is not as bright as the red.

However, viewing the images with red and green lenses produces an even result because green has a higher

luminance value than red.

Basic 3D effect
If you are working on a project that was created in an older version of After Effects and the Basic 3D effect is applied

to one or more layers, you can continue to use the Basic 3D effect; otherwise, use the 3D layer option instead.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)

The Basic 3D effect manipulates a layer in 3D space. You can rotate your image around horizontal and vertical axes

and move it toward or away from you. With Basic 3D, you can also create a specular highlight to give the appearance

of light reflecting off a rotated surface. The light source for the specular highlight is always above, behind, and to the

left of the viewer. Because the light comes from above, the image must be tilted backward to see this reflection. This

can enhance the realism of the 3D appearance. The specular highlight can be viewed only at Best quality.

The layer’s quality setting affects Basic 3D. Draft quality calculates pixel location to the nearest integer value; Best

quality calculates pixel location to the subpixel level.

Adjust the following controls for the Basic 3D effect:

Swivel Controls horizontal rotation (rotation around a vertical axis). You can rotate past 90˚ to see the back side of

the image, which is the mirror image of the front.

Tilt Controls vertical rotation (rotation around a horizontal axis).

Distance To Image Specifies the image’s distance from the viewer. As the distance gets larger, the image recedes.

Specular Highlight Adds a glint of light that reflects off the surface of the layer, as if an overhead light were shining

on the surface. In Preview mode, the specular highlight is indicated by a red plus sign (+) if it is not visible on the

layer (that is, if the center of the highlight does not intersect the layer) and a green plus sign (+) if the highlight is

visible.

Preview Draws a wireframe outline of the 3D image. The wireframe outline renders quickly. Deselect the Preview

control when you finish manipulating the wireframe image to see your final results. The preview wireframe is drawn

only at Draft quality; when you switch to Best quality, the image content is drawn. This way, you won’t accidentally

render a Best quality movie in Preview mode.
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Bevel Alpha effect
The Bevel Alpha effect gives a chiseled and lighted appearance to the alpha boundaries of an image, often giving 2D

elements a 3D appearance. If the layer’s alpha channel is completely opaque, the effect is applied to the bounding box

of the layer. The edge created in this effect is somewhat softer than that of the Bevel Edges effect. This effect works

especially well for elements with text in the alpha channel.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Bevel Edges effect
The Bevel Edges effect gives a chiseled and lighted 3D appearance to the edges of an image. Edge locations are deter-

mined by the alpha channel of the source image. Unlike Bevel Alpha, the edges created in this effect are always

rectangular, so images with nonrectangular alpha channels do not produce the proper appearance. All edges have

the same thickness. Best quality calculates the thickness of the chiseled area; the edge thickness is interpolated with

smooth visual results.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)

Drop Shadow effect
The Drop Shadow effect adds a shadow that appears behind the layer.

When you add a drop shadow to an object, a soft-edged duplicate shape of the object is displayed behind the object,

making it appear that a shadow is being cast on the background or any underlying objects. The shape of the shadow

is determined by the layer’s alpha channel. Drop Shadow can create a shadow outside the bounds of the layer;

however, memory requirements for this effect grow as the distance setting increases. The layer’s quality setting affects

the subpixel positioning of the shadow and the smoothness of the shadow’s soft edges. It works well with footage files

from 3D rendering programs and drawing programs that support the alpha channel. If you want to render the

shadow without the image, select Shadow only.

Note: To apply a drop shadow to a layer that rotates, rotate the layer using the Transform effect and then apply the Drop

Shadow effect. You can also use nesting, precomposing, or an adjustment layer to achieve this effect. If you do not use

one of these methods, the shadow rotates with the layer.

This effect works with 8-bpc and 16-bpc color.
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Original (left), and with effect applied (right)

Radial Shadow effect
The Radial Shadow effect creates a shadow from a point light source over the layer it’s applied to, rather than from

an infinite light source (as with the Drop Shadow effect). The shadow is cast from the alpha channel of the source

layer, allowing the color of that layer to influence the color of the shadow as light passes through semi-transparent

areas. You can use this effect to make a 3D layer appear to cast a shadow onto a 2D layer.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for the Radial Shadow effect:

Shadow Color Specifies the color of the shadow.

Note: The colors of the layer may override this option if you choose the Glass Edges option from the Render control. See

the Render and Color Influence controls for more information.

Opacity Specifies the transparency of the shadow.

Light Source Specifies the point from which light is cast over the layer to create the shadow.

Copy and paste position keyframes from another effect’s control point (for example, Lens Flare) to quickly create a

shadow that matches another effect’s light source.

Projection Distance Specifies the distance of the surface on which the shadow falls from the layer and the light

source. This value affects the size of the shadow. By default, the distance between the light source and the layer

remains fixed. So, use the Projection Distance control to move the background closer to or farther away from the

light source and the layer, thereby making the shadow smaller or larger respectively.

Softness Specifies the softness or sharpness of the shadow’s edges.

Render Specifies the type of shadow the effect creates. Regular creates a shadow based on the Shadow Color and

Opacity values, regardless of semi-transparent pixels in the original layer; if Regular is chosen, the Color Influence

control is disabled. Glass Edge creates a colored shadow based on the color and opacity of the original layer. If there

are semi-transparent pixels in the source layer, the shadow uses both the color and transparency of the original layer.

This creates the appearance, for example, of sun shining through stained glass. The more transparent the pixels in

the original layer are, the closer the shadow color matches the colors of the original layer. The Shadow Color has

more influence on the less transparent areas of the original layer. If there are no semi-transparent pixels in the source

layer, Glass Edge has little effect on the layer.
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Note: Anti-aliased edges produce colors in a shadow edge when you choose Glass Edge, even if the original layer is fully

opaque. The layer’s original colors shine through these anti-aliased edges, while the Shadow Color fills the center of the

shadow.

Color Influence Specifies the amount of the source layer’s color values that appear in the shadow. At a value of 100%,

the shadow takes on the color of any semi-transparent pixels in the layer. If this layer contains no semi-transparent

pixels, Color Influence has little or no effect, and the Shadow Color value determines the shadow’s color. Decreasing

the Color Influence value blends the colors of the original layer in the shadow with the color chosen for the Shadow

Color. Increasing Color Influence reduces the influence of the Shadow Color.

Animate Color Influence to reduce or increase the blending of the original layer’s colors with the Shadow Color

over time.

Shadow Only Specifies whether the original layer is visible. If this box is checked, the original layer appears over the

shadow. If this box is not checked, only the shadow appears.

Resize Layer Specifies whether or not the effect considers the original layer’s bounding box as the edge of the layer.

If the box is checked, the shadow can extend beyond the layer boundaries. If the box is not checked, any area of the

shadow falling outside the original layer’s bounding box is cropped by the layer’s original boundaries. This option is

not useful for shadows that fall outside the composition boundaries.

Simulation effects

Card Dance effect
This effect creates the appearance of card choreography by segmenting layers into numerous cards and then

controlling all geometric aspects of the cards by using a second layer. For example, Card Dance can simulate an

extruded pin sculpture, a crowd doing the wave, or letters floating on the surface of a pond.

This effect works with 8-bpc color.

Original (left) and rotation adjusted using Camera Position controls (center) and Corner Pin controls (right)

Original (left), gradient layer (center), and with Card Dance applied (right)

Apply Card Dance to the layer you want to use for the front of the cards. To set the view, use the rotation or

perspective controls, or match the perspective of the effect in any scene by corner-pinning.
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Consider the following example: If you select a vertical grayscale gradient (black on top, white on bottom) from the

Gradient Layer 1 menu and then select Intensity 1 from the X Rotation Source menu, Card Dance uses the intensity

of the gradient to animate the x-axis rotation of the cards. It assigns a numeric value to the center pixel of each card

on the gradient layer, based on the pixel’s intensity. Pure white equals 1, pure black equals –1, and 50% gray equals

0. Card Dance then multiplies that value by the X Rotation Multiplier value and rotates each card that amount.

If X Rotation Multiplier is set to 90, the cards in the top row rotate almost 90˚ backward, the cards in the bottom row

rotate almost 90˚ forward, and cards in middle rows rotate by lesser amounts. Cards in the 50% gray area don’t rotate

at all.

If you want half of the cards in a layer to come in from the right, and the other half to come in from the left, create a

gradient layer that is half black and half white. Set the gradient as the source for X Position, and set X Position Multi-

plier to 5, and animate it to 0. The cards in the black area initially appear at the left, and the cards in the white area

initially appear at the right.

Rows, Columns, Layer, and Order controls for the Card Dance effect
Rows & Columns Specifies the interaction of the numbers of rows and columns. When you choose Columns Follow

Rows, the number of columns is always the same as the number of rows.

Rows, Columns Define the number of rows or columns up to 1,000.

Note: Rows and columns are always evenly distributed across a layer, so odd-shaped rectangular tiles don’t appear along

the edges of a layer, unless you are using an alpha channel.

Back Layer Defines what appears on the back sides of the cards when they rotate into view, or when the camera

rotates around to the back of the layer. You can use any image file in the composition; its visibility can be turned off.

Gradient Layer 1 Specifies the first gradient that you want to use to make the cards “dance.” You can use any grayscale

(grayscale produces the most predictable results) or color image, movie, or composition. The gradient layer acts as

a displacement map for animating the cards. The pixel luminance of the gradient layer directly controls the

geometrics of the Card Dance tiles.

Gradient Layer 2 Specifies a second gradient, which you can use to add another level of animation to the card dance.

Rotation Order Determines the order in which the cards rotate around multiple axes, when using more than one axis

for rotation. This control can greatly affect the appearance of the animation.

Transformation Order Determines the order in which the transformational properties occur (scale, rotation, and

position). This control can also greatly affect the appearance of the animation.

Position, Rotation, and Scale controls for the Card Dance effect

Position (X, Y, Z), Rotation (X, Y, Z), and Scale (X, Y) specify the transformation properties you want to adjust.

Because Card Dance is a 3D effect, you can control these properties separately for each axis of the cards. However,

because the cards themselves are still 2D, they have no inherent depth—hence the absence of z scaling.

Source Specifies the gradient layer channel you want to use to control the transformation. For example, select

Intensity 2 to use the Intensity from Gradient Layer 2.

Multiplier Specifies the amount of transformation applied to the cards.

Offset Specifies the value at which the transformation begins. It is added to the transformation value (a card’s center

pixel value times the Multiplier amount) so that you can start the transformation from some place other than 0.
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Camera System and Camera Position controls for the Card Dance effect

Camera System specifies whether to use the Camera Position, Corner Pins, or Comp Camera controls. Comp

Camera tracks the composition's camera and light positions and renders a 3D image on the layer.

Adjust the following Camera Position controls to specify the camera position:

X Rotation, Y Rotation, Z Rotation Rotate the camera around the corresponding axis. Use these controls to look at

the layer from the top, side, back, or any other angle.

X, Y Position Specifies where the camera is positioned in (x,y) space.

Z Position Specifies where the camera is positioned in z space. Smaller numbers move the camera closer to the layer,

and larger numbers move the camera away from the layer.

Focal Length Specifies the zoom factor and is like a camera’s zoom lens. Smaller numbers zoom the camera lens out,

and larger numbers zoom the camera lens in.

Transform Order Specifies the order in which the camera rotates around its three axes, and whether the camera

rotates before or after it is positioned by using the other Camera Position controls.

Corner Pins controls for the Card Dance effect

Corner pinning is an alternative camera control system. Use it as an aid for compositing your layer into a scene.

Upper Left Corner, Upper Right Corner, Lower Left Corner, Lower Right Corner Specify the location of each of the

four corners of your layer.

Auto Focal Length Specifies the perspective of the effect during the animation. When Auto Focal Length is off, the

Focal Length you specify is used to find a camera position and orientation that positions the corners of the layer at

the corner pins. If this isn’t possible, the layer is replaced by its outline, drawn between the pins. When Auto Focal

Length is on, the Focal Length required to match the corner points is used, if possible. If not, it interpolates the

correct value from nearby frames.

Focal Length Overrides the other settings if the results you’ve obtained aren’t what you need. If you set Focal Length

to something that doesn’t correspond to what the focal length would be if the pins were actually in that configuration,

the image may look odd (strangely sheared, for example). But if you know the focal length that you are trying to

match, the Focal Length control is the easiest way to get correct results.

Lighting controls for the Card Dance effect
Light Type Specifies the type of light you want to use. When a light is at a great distance from an object, all the light

rays strike the object from virtually the same angle. Sun rays, for example, are parallel by the time they reach the

earth. As a light source moves closer to the object, the rays strike the object from an increasing number of angles.

Distant Source is similar to sunlight and casts shadows in the one direction. Point Source is similar to a light bulb

and casts shadows in all directions. First Comp Light uses the composition’s first light layer, which can use a variety

of settings.

Light Intensity Specifies the power of the light. The higher the value, the brighter the layer. Other lighting settings

affect the overall light intensity as well.

Light Color Specifies the color of light.

Light Position Specifies the position of the light in (x,y) space.

Light Depth Specifies the position of the light in z space. Negative numbers move the light behind the layer.
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Ambient Light Distributes light over the layer. Increasing it adds an even illumination to all objects and prevents

shadows from being totally black. Turning Ambient Light all the way to pure white and setting all other light controls

to 0 makes the object fully lit and eliminates any 3D shading from the scene.

Material controls for the Card Dance effect

The Material controls specify the reflection values of the cards.

Diffuse Reflection Gives objects form-defining shading. Shading depends on the angle at which the light strikes the

surface and is independent of the viewer’s position.

Specular Reflection Takes into account the position of the viewer. It models the reflection of the light source back to

the viewer. It can create the illusion of shininess. For realistic effects, you can animate this control by using higher

and higher values to mask the transition from filtered to nonfiltered versions of the layer.

Highlight Sharpness Controls shininess. Very shiny surfaces produce small tight reflections, while duller surfaces

spread the highlight out into a larger region. Specular highlights are the color of the incoming light. Because light is

typically white or off-white, broad highlights can desaturate an image by adding white to the surface color.

In general, use the following process to adjust lighting: Set Light Position and Diffuse Reflection to control the overall

light level and shading in a scene. Then adjust Specular Reflection and Highlight Sharpness to control the strength

and spread of highlights. Finally, adjust Ambient Light to fill in the shadows.

Caustics effect
This effect simulates caustics—reflections of light at the bottom of a body of water, created by light refracting through

the water’s surface. The Caustics effect generates this reflection and creates realistic water surfaces when used with

Wave World and Radio Waves.

This effect works with 8-bpc color.

Original (left) and with Bottom set to the text layer and Water Surface set to the whirl layer with Surface Opacity set to 0% (right)

To get the most realistic results from Caustics, render the Bottom layer separately, with Render Caustics enabled and

Surface Opacity at 0. Then precompose, and use the resulting layer as the Bottom layer for another Caustics effect

with Render Caustics off. With this process you can offset, scale, or otherwise manipulate the Bottom layer in the precom-

posed composition, and thus simulate lighting that doesn’t come from straight overhead.

Bottom controls for the Caustics effect

The Bottom controls specify the appearance of the bottom of the body of water:

Bottom Specifies the layer at the bottom of the body of water. This layer is the image that is distorted by the effect,

unless Surface Opacity is 100%.

Scaling Makes the bottom layer larger or smaller. If the edges of the bottom layer show, because of the refraction of

the light through the waves, scale up the bottom layer. Scaling down is useful for tiling a layer to make a complex

pattern.
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Repeat Mode Specifies how a scaled-down bottom layer is tiled. Once uses only one tile, basically turning tiling off.

Tiles uses the traditional tiling method of abutting the right edge of one bottom layer tile to the left edge of another

bottom layer tile. This option works well if the bottom layer contains a repeating pattern, like a logo, that needs to

read a certain way. Reflected abuts each edge of a bottom layer tile to a mirrored copy of the tile. This option can

eliminate a hard edge where the two tiles meet.

If Layer Size Differs Specifies how to handle the bottom layer when it is smaller than the composition.

Blur Specifies the amount of blur applied to the bottom layer. To make the bottom totally sharp, set this control to

0. Higher values make the bottom appear increasingly blurry, especially where the water is deeper.

Water controls for the Caustics effect
Water Surface Specifies the layer to use as the water’s surface. Caustics uses the luminance of this layer as a height

map for generating a 3D water surface. Light pixels are high, and dark pixels are low. You can use a layer created by

using the Wave World or Radio Waves effect; precompose the layer before using it with Caustics.

Wave Height Adjusts the relative height of the waves. Higher values make the waves steeper and the surface

displacement more dramatic. Lower values smooth the Caustics surface.

Smoothing Specifies the roundness of the waves by blurring the water surface layer. Very high values eliminate

detail. Very low values show imperfections from the water surface layer.

Water Depth Specifies depth. A small disturbance in shallow water moderately distorts the view of the bottom, but

the same disturbance in deep water distorts the view significantly.

Refractive Index Affects the way the light bends as it passes through the liquid. A value of 1 does not distort the

bottom. The default value of 1.2 accurately simulates water. To add distortion, increase the value.

Surface Color Specifies the color of the water.

Surface Opacity Controls how much of the bottom layer is visible through the water. If you want a milky effect,

increase the Surface Opacity and Light Intensity values; a value of 0 results in a clear liquid.

Set Surface Opacity to 1.0 to perfectly reflect a sky later. With a suitable texture map, you can use this technique to

create the effect of liquid mercury.

Caustics Strength Displays the caustics, the concentrations of light on the bottom surface, caused by the lensing

effect of the water waves. This control changes the way everything looks: The waves’ dark spots get much darker, and

the light spots get much lighter. If you don’t set a value for this control, the effect distorts the bottom layer when the

waves pass over it, but it doesn’t render the lighting effect.

Sky controls for the Caustics effect
Sky Specifies the layer above the water. Scaling makes the sky layer larger or smaller. If the edges of the sky layer

show, scale the layer up. Scaling down is useful for tiling a layer to make a complex pattern.

Repeat Mode Specifies how a scaled-down sky layer is tiled. Once uses only one tile, basically turning tiling off. Tiles

uses the traditional tiling method of abutting the right edge of one layer tile to the left edge of another layer tile. This

option works well if the layer contains a repeating pattern, like a logo, that needs to read a certain way. Reflected abuts

each edge of a layer tile to a mirrored copy of the tile. This option can eliminate a hard edge where the two tiles meet.

If Layer Size Differs Specifies how to handle the layer when it is smaller than the composition. Intensity specifies the

opacity of the sky layer. Convergence specifies how close the sky and the bottom or water layer appear, controlling

the extent to which the waves distort the sky.
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Lighting controls for the Caustics effect
Light Type Specifies which type of light you want to use. Distant Source simulates sunlight and casts shadows in one

direction, where all the light rays strike the object from virtually the same angle. Point Source is similar to a light

bulb and casts shadows in all directions. First Comp Light uses the composition’s first light layer, which can use a

variety of settings.

Light Intensity Specifies the power of the light. The higher the value, the brighter the layer. Other lighting settings

affect the overall light intensity as well.

Light Color Specifies the color of light.

Light Position Specifies the position of the light in (x,y) space. To position the light interactively, Alt-drag

(Windows) or Option-drag (Mac OS) the light’s effect point.

Light Depth Specifies the position of the light in z space. Negative numbers move the light behind the layer.

Ambient Light Distributes light over the layer. Increasing it adds an even illumination to all objects and prevents

shadows from being totally black. Turning Ambient Light all the way to pure white and setting all other light controls

to 0 makes the object fully lit and eliminates any 3D shading from the scene.

Material controls for the Caustics effect

The Material controls specify the reflection values of the cards.

Diffuse Reflection Gives objects form-defining shading. Shading depends on the angle at which the light strikes the

surface and is independent of the viewer’s position.

Specular Reflection Takes into account the position of the viewer. It models the reflection of the light source back to

the viewer. It can create the illusion of shininess. For realistic effects, you can animate this control by using higher

and higher values to mask the transition from filtered to nonfiltered versions of the layer.

Highlight Sharpness Controls shininess. Very shiny surfaces produce small tight reflections, while duller surfaces

spread the highlight out into a larger region. Specular highlights are the color of the incoming light. Because light is

typically white or off-white, broad highlights can desaturate an image by adding white to the surface color.

In general, use the following process to adjust lighting: Set Light Position and Diffuse Reflection to control the overall

light level and shading in a scene. Then adjust Specular Reflection and Highlight Sharpness to control the strength

and spread of highlights. Finally, adjust Ambient Light to fill in the shadows.

Foam effect
This effect generates bubbles that flow, cling, and pop. Use the effect’s controls to adjust attributes for the bubbles

such as stickiness, viscosity, life span, and bubble strength. You can control exactly how the foam particles interact

with each other and with their environment, and specify a separate layer to act as a map, controlling precisely where

the foam flows. For example, you can have particles flow around a logo or fill a logo with bubbles.

This effect works with 8-bpc color.

Original (left), with Foam applied (center), and with a robot layer used as the Bubble Texture Layer (right)
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You can also substitute any image or movie for bubbles. For example, you can create swarms of ants, flocks of birds,

or crowds of people.

Note: On a frame-by-frame basis, Foam renders quickly, but the slightest adjustment in the initial settings is likely to

result in very different output a few seconds into the simulation. When making adjustments to Physics controls, the

farther into the simulation you are, the longer the adjustments take to render, because each adjustment results in the

simulation being recalculated all the way back to the beginning. Not every frame takes this long to calculate; once Foam

adjusts to the change, rendering speeds up again.

View controls for the Foam effect
Draft Displays the bubbles without fully rendering them. This is a fast way to preview the behavior of the bubbles.

Draft mode is the only way to preview the universe edges, the Flow Map alignment, and the Producer location, orien-

tation, and size. Bubbles are represented by blue ellipses. The Producer Point is represented by a red ellipse. The

bubble universe is represented by a red rectangle.

Draft + Flow Map Displays the Draft view wireframe superimposed over a grayscale representation of the flow map,

if selected.

Rendered Displays the final output of the animation.

Producer controls for the Foam effect

The Producer controls specify the location where the bubbles originate, as well as the speed at which they are

generated:

Producer Point The center of the area from which the bubbles can be produced.

Producer X Size, Producer Y Size Adjust the width and height of the area from which the bubbles can be produced.

Producer Orientation Adjusts the rotation (orientation) of the area from which the bubbles can be produced.

Producer Orientation has no noticeable effect when Producer X Size and Producer Y Size are identical.

Zoom Producer Point Specifies whether the producer point and all of its associated keyframes remain relative to the

universe (selected) or to the screen (deselected) when you zoom in or out on it. For example, if you set a position for

Producer Point in the upper left corner of the layer and then zoom out on that layer, the producer point stays in the

upper left corner of the screen if you don’t select Zoom Producer Point. If you select Zoom Producer Point, the point

moves with the universe as it is zoomed out, and the point ends up closer to the center of the screen.

Production Rate Determines the rate at which bubbles are generated. This control does not affect the number of

bubbles per frame. Rather, the rate is the average number of bubbles generated every 30th of a second. Higher

numbers yield more bubbles.

If a large number of bubbles appear in the same point at the same time, some may pop. If you want a lot of foam,

increase the values for Producer X Size and Producer Y Size so that the bubbles don’t immediately pop each other.

Bubbles controls for the Foam effect
Size Specifies the average size for adult bubbles. Size Variance, Bubble Growth Speed, and Random Seed also affect

the size of a bubble in any particular frame.

Size Variance Specifies the range of possible bubble sizes. This control uses the Size value as the average and creates

smaller-than-average and larger-than average-bubbles by using the range you specify here. For example, a default

bubble Size of 0.5 and default Size Variance of 0.5 generate bubble sizes ranging from 0 to 1 (0.5 –.5 = 0 and 0.5 + 0.5

= 1).
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Lifespan Specifies the maximum life of a bubble. This value is not absolute; if it were, the bubbles would all pop after

the same lifespan, as if they were hitting a wall. Rather, this value is a target lifespan; some bubbles pop early, and

others may last until the end.

Bubble Growth Speed Specifies how fast a bubble reaches full size. When a bubble is released from the producer

point, it generally starts out rather small. If you set this value too high and you specify a small producer area, the

bubbles pop each other, and the effect generates fewer bubbles than expected.

Strength Influences how likely a bubble is to pop before it reaches its Lifespan limit. Lowering a bubble’s Strength

makes it more likely to pop early in its life, when forces like wind and flow maps act upon it. Lower values are good

for soap bubbles. The highest value is recommended for flocking animations.

Set this value low, and set Pop Velocity high to create chain reactions of popping bubbles.

Physics controls for the Foam effect

The Physics controls specify the motion and behavior of the bubbles:

Initial Speed Sets the speed of the bubble as it is emitted by the producer point. This speed is affected by the other

Physics parameters.

Low Initial Speed values in conjunction with the default producer size don’t affect the results much because the

bubbles bounce off each other. For more control over initial speed, increase the values for Producer X Size and

Producer Y Size.

Initial Direction Sets the initial direction in which the bubble moves as it emerges from the producer point. This is

affected by other bubbles and other Physics controls.

Wind Speed Sets the speed of the wind that pushes the bubbles in the direction specified by Wind Direction.

Wind Direction Sets the direction in which the bubbles blow. Animate this control to create turbulent wind effects.

Bubbles are affected by wind as long as Wind Speed is greater than 0.

Turbulence Applies small random forces to the bubbles, making them behave chaotically.

Wobble Amount Randomly changes the shape of bubbles from perfectly round to a more natural elliptical shape.

Repulsion Controls whether bubbles bounce off each other, stick to each other, or pass through each other. With a

value of 0, bubbles don’t collide; they pass through each other. The higher the Repulsion value, the more likely

bubbles are to interact with each other when they collide.

Pop Velocity Controls how popping bubbles affect each other. When a bubble pops, it affects other bubbles around

it by leaving a hole that other bubbles can fill, pushing other bubbles away, or popping other bubbles. The higher the

value, the more popping bubbles affect one another.

Viscosity Specifies the rate at which bubbles decelerate after being released from the producer point, and controls

the speed of the flow of the bubbles. A high Viscosity value creates resistance as the bubbles get farther away from

the producer point, causing them to slow down. If Viscosity is set high enough, the bubbles stop. The thicker the

substance, the higher the Viscosity. For example, if you want to create the effect of bubbles traveling through oil, set

Viscosity fairly high, so that the bubbles meet resistance as they travel. To create the effect of bubbles floating in air,

set Viscosity fairly low.

Stickiness Causes bubbles to clump together and makes them less vulnerable to other Physics controls like Wind

Direction. The higher the Stickiness, the more likely the bubbles are to form clusters and cling. Use Stickiness and

Viscosity to create a bubble cluster.
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Zoom and Universe Size controls for the Foam effect
Zoom Zooms in or out around the center of the bubble universe. To create really large bubbles, increase the Zoom

value instead of the Size value because large bubble sizes can be unstable.

Universe Size Sets the boundaries of the bubble universe. When bubbles completely leave the universe, they pop and

are gone forever. By default, the universe is the size of the layer. Values greater than 1 create a universe that stretches

beyond the borders of the layer. Use higher values to make bubbles flow in from off-screen, or make it possible to

zoom out and bring them back into the picture. Using a value lower than 1 clips the bubbles before they reach the

edge of the layer. For example, when you want to confine bubbles to a specific area, such as inside a mask shape, set

Universe Size a little larger than the mask size to remove all the extra bubbles and speed up the rendering process.

Rendering controls for the Foam effect

The Rendering controls specify the appearance of the bubbles, including their texture and reflection:

Blend Mode Specifies the relative transparency of bubbles as they intersect. Transparent blends the bubbles

smoothly together, allowing you to see the bubbles through each other. Solid Old On Top makes a younger bubble

appear to be underneath an older bubble and eliminates transparency. Use this setting to simulate bubbles flowing

toward you. Solid New On Top makes younger bubbles appear to be on top of older bubbles and also eliminates

transparency. Use this setting to make bubbles appear as if they are flowing downhill.

Bubble Texture Specifies the bubble texture. Use a preset texture, or create your own. To see the texture, make sure

that View is set to Rendered. To create your own texture, select User Defined, and then from the Bubble Texture

Layer menu choose the layer you want to use as the bubble.

Note:The preset bubble textures are prerendered 64 x 64 images. If you zoom in above 64 x 64, the bubble appears blurry.

To avoid this, use a higher-resolution custom bubble.

Bubble Texture Layer Specifies the layer you want to use as the bubble image. To use this control, choose User

Defined from the Bubble Texture menu. If you want the layer to appear only as a bubble, turn off the video switch

for the layer in the Timeline panel.

Note: You can use any file type that After Effects supports. If you plan on zooming in or using a large bubble size, make

sure that the resolution of the layer is high enough to avoid blurring. Remember, this doesn’t have to be a normal bubble.

You can make blood cells, starfish, bugs, space aliens, or flying monkeys. If it’s a layer in your composition, it can be a

bubble.

Bubble Orientation Determines the direction that the bubble rotates. Fixed releases the bubble from the producer

right side up and keeps it that way. Use this control if the bubble has built-in highlights and shading, as all of the

preset bubbles do. Physical Orientation buffets and spins bubbles around by the forces on them, creating a chaotic

scene. Bubble Velocity faces the bubble in the direction of its motion. This is the most useful setting for flocking-

style animations.

Environment Map Specifies the layer that is reflected in the bubbles. If you want to use this layer only for the

reflection, turn off the layer’s video switch.

Reflection Strength Controls how much of the selected Environment Map is reflected in the bubbles. The higher the

value, the more the reflection obscures the original bubble texture. Reflections appear only on opaque pixels, so

bubbles with high degrees of transparency, such as the Spit preset, don’t reflect much.

Reflection Convergence Controls how much your Environment Map is distorted as it is mapped onto the bubbles.

A value of 0 projects the map flat on top of all of the bubbles in the scene. As the value increases, the reflection

distorts to account for the spherical shape of each bubble.
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Flow Map controls for the Foam effect

The Flow Map controls specify the map that the flow of the foam follows:

Flow Map Specifies the layer used to control the direction and speed of the bubbles. Use a still image layer; if you

select a movie as the flow map layer, only the first frame is used. A flow map is a height map based on luminance:

White is high, and black is low. White is not infinitely high; if a bubble travels fast enough, it can travel past a white

obstacle. Make sure that the map is a little blurry; sharp edges can create unpredictable results. For example, to make

bubbles flow through a canyon, create a flow map with a white canyon rim, a black canyon, and blurry gray walls.

Use wind to blow the bubbles in the direction you want them to flow, and the walls of the canyon contain them. You

can also use a gentle gradient on the floor of the canyon to control the flow direction, but this is somewhat more

difficult to set up.

Note: If the bubbles don’t follow the map, use the Simulation Quality control. Also, try blurring the flow map a little to

make sure that it does not have excessively abrupt edges.

Flow Map Steepness Controls the difference between white and black as they are used to determine steepness. If the

bubbles are ricocheting randomly off the flow map, decrease this value.

Flow Map Fits Specifies whether the flow map is relative to the layer or to the universe. The flow map resizes itself to

fit whichever you specify. This control is useful when you want to enlarge the universe but the flow map is designed

for a particular layer, or when you want the bubbles to start off-screen and be affected by the flow map as they arrive

on-screen.

Simulation Quality Increases the accuracy, and therefore the realism, of the simulation. However, the higher the

value, the longer the composition takes to render. Normal generally produces good results and takes the least amount

of time to render. High returns better results but takes longer to render. Intense increases the rendering time but

produces more predictable bubble behavior. Use this option if the bubbles aren’t following the flow map. It often

solves problems of erratic behavior that can occur with small bubbles, high bubble speeds, and steep slopes.

Random Seed control for the Foam effect

The Random Seed control affects all parameters that have any randomized elements in them. If the settings are the

same, any given random-based parameter looks exactly the same every time you apply it. That is, you get predeter-

mined randomness. Using a different Random Seed value makes things appear different while still using the same

settings. Changing the Random Seed value doesn’t make things more or less random; it only makes them random in

a different way.

Particle Playground effect (Pro only)
The Particle Playground effect lets you animate a large number of similar objects independently, such as a swarm of

bees or a snow storm. Use the Cannon to create a stream of particles from a specific point on the layer, or use the

Grid to generate a plane of particles. The Layer Exploder and Particle Exploder can create new particles from existing

layers or particles. You can use any combination of particle generators on the same layer.

This effect works with 8-bpc color.

Particles shooting out of the spacecraft layer (left) and text characters used as particles shooting out of a ray gun (center) and Layer Exploder
used on spacecraft layer (right)
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Start by creating a stream or plane of particles, or by exploding an existing layer into particles. Once you have a layer

of particles, you can control their properties, such as speed, size, and color. However, the possibilities available in

Particle Playground go beyond the obvious. For example, you can replace the default dot particles with the footage

from an existing layer and create an entire snowstorm from a single snowflake layer. You can also use text characters

as particles. For example, you can shoot words across the screen, or you can create a sea of text in which a few letters

change color, revealing a message.

Note: Because of the complexity of Particle Playground, you may experience long computation, preview, and render

times.

To use Particle Playground (Pro only)

1 Select the layer on which you want particles to exist, or create a new solid layer.

2 Choose Effect > Simulation > Particle Playground. The layer becomes an invisible layer in which only the particles

are visible. Animating the layer in the Timeline panel animates the entire layer of particles.

3 Set up a particle generator to determine how particles are created. You can shoot a stream of particles from the

Cannon, generate a flat plane full of particles from the Grid, or use the Layer Exploder to create particles from an

existing layer. If you’ve already created particles, you can apply the Particle Exploder to explode them into more new

particles.

4 Select your particles. By default, Particle Playground creates dot particles. You can replace the dots with footage

from a layer already in the composition or with text characters you specify.

Note: If you want to use footage from a layer as particles, see “Replacing default particles with layers using Layer Map

(Pro only)” on page 504. If you want to use text as particles, see “To replace default Cannon particles with text (Pro

only)” on page 505.

5 Specify the overall behavior of some or all particles. Use Gravity to pull particles in a specified direction, Repel to

push particles apart from or toward one another, or Wall to contain or exclude particles from a certain area.

6 Use an image to specify the behavior of individual particles. You can modify controls that change particle motion,

such as speed and force, and controls that change particle appearance, such as color, opacity, and size.

For more information, see “About Property Mappers and Particle Playground (Pro only)” on page 508.

Particle Playground controls
A. Use to generate particles. B. Use to specify footage from a layer in place of each default dot particle. C. Use to influence overall particle
behavior. D. Use to influence particle properties. E. Use to set options, including those for substituting text characters in place of dots.

A

B

C

D

E
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The Particle Playground effect renders with anti-aliasing when the layer to which it is applied is set to Best quality.

It also applies motion blur to moving particles when both the Motion Blur switch and the Enable Motion Blur option

are enabled. When you use Best quality and motion blur, the layer takes longer to render.

When you use another layer as a source for particles, Particle Playground ignores any property or keyframe changes

you made to that layer within that composition, such as changing the Position values. Instead it uses the layer in its

original state. To keep property or keyframe changes for a layer when you use it as a particle source, precompose the

layer.

Particle content and particle generators (Pro only)

Particle Playground can generate three kinds of particle: dots, footage from a layer, or text characters. You can specify

only one kind of particle per particle generator.

Create particles by using the Cannon, the Grid, the Layer Exploder, and the Particle Exploder. The Grid creates

particles in an organized grid format with straight rows and columns. The exploders create particles randomly, like

firecracker sparks.

The particle generators set the attributes of particles at the moment they are created. After that, particle behavior is

influenced by the Gravity, Repel, Wall, Exploder, and Property Mapper controls. For example, if you want particles

to stick to grid intersections, you might use the Static Friction option in the Persistent Property Mapper to hold

particles in place. Otherwise, as soon as particles are created, they begin moving away from their original grid

positions.

Cannon controls for Particle Playground (Pro only)

The Cannon is on by default; to use a different method to create particles, first turn the Cannon off by setting

Particles Per Second to zero. The Cannon creates particles in a continuous stream, as though they were shot out of a

cannon.

Position Specifies the (x,y) coordinates from which particles are created.

Barrel Radius Sets the size of the Cannon’s barrel radius. Negative values create a circular barrel, and positive values

create a square barrel. For a narrow source such as a ray gun, specify a low value. For a wide source such as a school

of fish, specify a high value.

Particles Per Second Specifies how often particles are created. A value of 0 creates no particles. A high value

increases the density of the particle stream. If you don’t want the Cannon to fire continuously during the compo-

sition, set keyframes for this control so that the value is 0 at the times when you don’t want to create any particles.

Direction Sets the angle at which particles are fired.

Direction Random Spread Specifies how much each particle’s direction deviates randomly from the cannon

direction. For example, specifying a 10-degree spread sprays particles in random directions within +/–5 degrees of

the cannon direction. For a highly focused stream such as a ray gun, specify a low value. For a stream that widens

quickly, specify a high value. You can specify up to 360 degrees.

Velocity Specifies the initial speed of particles in pixels per second as they emanate from the Cannon.

Velocity Random Spread Specifies the amount of random velocity of particles. A higher value results in more

variation in the velocity of particles. For example, if you set Velocity to 20 and Velocity Random Spread to 10,

particles leave the Cannon at velocities ranging from 15 to 25 pixels per second.

Color Sets the color of dots or text characters. This control has no effect if you use a layer as the particle source.

Particle Radius Sets the radius of dots, in pixels, or the size of text characters in points. This control has no effect if

you use a layer as the particle source.
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Grid controls for Particle Playground (Pro only)

The Grid creates a continuous plane of particles from a set of grid intersections. The movement of Grid particles is

completely determined by the Gravity, Repel, Wall, and Property Mapper settings. By default, the Force control of

Gravity is on, so Grid particles fall toward the bottom of the frame.

With the Grid, a new particle appears on every frame at each grid intersection. You can’t adjust this frequency, but if

you want to turn off the Grid or make the Grid stop generating particles at specific times, set the Particle Radius/Font

Size control to 0, or use keyframes to animate the value of the Particles Across and Particles Down controls. To make

more particles appear each frame, increase the values for Particles Across and Particles Down.

Note: By default, the Cannon is on and the Grid is off. If you are using the Grid and want to stop the Cannon from gener-

ating particles, turn off the Cannon by setting its Particles Per Second value to 0.

Position Specifies the (x,y) coordinates of the grid center. When a grid particle is created, it is centered over its grid

intersection, regardless of whether it is a dot, a layer, or a text character. If you’re using text characters as particles,

the Use Grid option in the Edit Grid Text dialog box is on by default, placing each character on its own grid inter-

section, so normal character spacing, word spacing, and kerning do not apply. If you want text characters to appear

at the grid position with normal spacing, use a text alignment other than the Use Grid option.

Width, Height Specify the dimensions of the grid, in pixels.

Particles Across, Particles Down Specify the number of particles to distribute horizontally and vertically across the

grid area. Particles are generated only when the value is 1 or more.

Note: If the Width, Height, Particles Across, and Particles Down controls are not available, the Use Grid option has been

turned off in the Edit Grid Text dialog box.

Color Sets the color of dots or text characters. This control has no effect if you use a layer as the particle source.

Particle Radius/Font Size Sets the radius of dots in pixels or the size of text characters in points. This control has no

effect if you use a layer as the particle source.

Using the Layer Exploder and Particle Exploder (Pro only)

The Layer Exploder explodes a layer into new particles, and the Particle Exploder explodes a particle into more new

particles. In addition to explosion effects, the exploders are also handy for simulating fireworks or for rapidly

increasing the number of particles.

The following guidelines can help you control particles resulting from an explosion:

• A layer is exploded once for each frame. By default, this creates a continuous shower of particles for the duration

of the composition. If you want to start or stop a layer explosion, animate the Radius of New Particles control by

using keyframes so that its value is zero at times when you don’t want particles to be created.

• If the source of the layer is a nested composition, you can set different Opacity values or In and Out points for the

layers within the nested composition to make the exploding layer transparent at different points in time. The Layer

Exploder does not create particles where the source of the layer is transparent.

• To change the position of the exploding layer, precompose the layer with its new position (use the Move All

Attributes into The New Composition option), and then use the precomposed layer as the exploding layer.

• When you explode particles, the new particles inherit the position, velocity, opacity, scale, and rotation of the

original particles.

• After you explode layers or particles, the movement of particles is influenced by the Gravity, Repel, Wall, and

Property Mapper controls.
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Some Persistent Property Mapper and Ephemeral Property Mapper options can make explosions more realistic. For

example, change Opacity to make the resulting particles fade out, or change the Red, Green, and Blue color channels

to make resulting particles change color as they appear to cool. (See “About Property Mappers and Particle Playground

(Pro only)” on page 508.)

Layer Exploder and Particle Exploder controls (Pro only)
Explode Layer (Layer Exploder only) Specifies the layer you want to explode. To make the video disappear the

moment the particles appear, either turn off the video for the layer or trim the layer’s Out point.

Radius Of New Particles Specifies the radius of the particles resulting from the explosion. This value must be smaller

than the radius of the original layer or particle.

Velocity Dispersion Specifies, in pixels per second, the maximum speed of the range within which Particle

Playground varies the velocity of the resulting particles. High values create a more dispersed or cloudlike explosion.

Low values keep the new particles closer together and can make the exploded particles resemble a halo or shock

wave.

Affects Specifies which particles are affected by the Layer Exploder and Particle Exploder. (See “Affects controls for

Particle Playground (Pro only)” on page 508.)

Replacing default particles with layers using Layer Map (Pro only)

By default, the Cannon, Grid, Layer Exploder, and Particle Exploder create dot particles. To replace the dots with a

layer in the composition, use the Layer Map. For example, if you use a movie of a single bird flapping wings as a

particle source layer, After Effects replaces all dots with an instance of the bird movie, creating a flock of birds. A

particle source layer can be a still image, a solid, or a nested After Effects composition.

A multiframe layer is any layer with a source that varies over time, such as a movie or a composition. When you map

new particles to a multiframe layer, use the Time Offset Type control to specify how you want to use the layer’s

frames. For example, use Absolute to map an unchanging image onto a particle, or use Relative to map an animating

sequence of frames onto a particle. You can randomize both Absolute and Relative across particles.

Note: When you choose a layer for Layer Map, Particle Playground ignores any property or keyframe changes that you

made to that layer within that composition. Instead, it uses the layer in its original state. To keep transformations, effects,

masks, rasterization options, or keyframe changes for a layer when you use it as a particle source, precompose the layer.

Layer Map controls for Particle Playground (Pro only)
Use Layer Specifies the layer you want to use as the particles.

Time Offset Type Specifies how you want to use a multiframe layer’s frames. For example, if you are using a layer of

a bird flapping its wings and you choose Relative for Time Offset Type with a Time Offset of 0, the flapping wings

for all the instances of the bird are synchronized. While this might be realistic for a marching band, it is not realistic

for a flock of birds. To make each bird start flapping its wings from a different frame in the layer, use Relative

Random.

• Relative Starts playing the layer at a frame based on the Time Offset you specify, relative to the effect layer’s

current time; then advances in step with the Particle Playground layer’s current time. If you specify a Time Offset of

0, all particles show the frame that corresponds to the effect layer's current time. If you choose a Time Offset of 0.1

(and your composition is set to 30 fps), each new particle displays the frame that is 0.1 seconds after the previous

particle’s frame. Regardless of the Time Offset you specify, the first particle always displays the frame of the source

layer that corresponds to the effect layer’s current time.

• Absolute Displays a frame from the layer based on the Time Offset you specify, regardless of the current time.

Choose Absolute when you want a particle to show the same frame of a multiframe source layer for its entire lifespan,
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instead of cycling through different frames as the effect layer advances in time. For example, if you choose Absolute

and specify a Time Offset of 0, every particle shows the first frame of the source layer for its entire lifespan. If you

want to show a frame other than the first frame, move the layer earlier in time until the frame you want to show

corresponds to the In point of the Particle Playground layer. If you specify a Time Offset of 0.1, for example, each

new particle displays a frame that is 0.1 second after that of the previous particle (or every third frame of a 30-fps

animation).

• Relative Random Starts playing the layer from a frame chosen at random, within the range between the effect

layer’s current time and the Random Time Max you specify. For example, if you choose Relative Random and specify

a Random Time Max of 1, each particle starts playing from a layer frame chosen at random from between the current

time and 1 second after the current time. If, for another example, you specify a negative Random Time Max value of

- 1, the Random Time Max is before the current time, so that the range within which new particles start playing

advances as the current time advances. However, the range is always between the current time and one second earlier

than the current time.

• Absolute Random Takes a frame at random from the layer, by using a time between 0 and the Random Time Max

you specify. Choose Absolute Random when you want each particle to represent a different single frame of a multi-

frame layer. For example, if you choose Absolute Random and specify a Random Time Max of 1, each particle shows

a layer frame from a random time between 0 and 1 second into the layer’s duration.

Time Offset Specifies the frame from which to start playing sequential frames from the layer.

Affects Specifies which particles are affected by the Layer Map controls. (See “Affects controls for Particle

Playground (Pro only)” on page 508.)

To replace default Cannon particles with text (Pro only)

You can use text characters as particles. For example, you can type a message that the Cannon shoots across the

frame. You can also change the attributes of any three sets of characters. For example, you can make some of the

characters larger or brighter than others. (See “Affects controls for Particle Playground (Pro only)” on page 508.)

1 In the Effect Controls panel, click Options.

2 Click Edit Cannon Text.

3 Type text in the text box, and then set the following options:

• For Font/Style, choose the font and style for Cannon characters.

• For Order, click to specify the sequence in which characters exit the Cannon. The sequence is relative to the

character order typed in the text box. For example, if the Cannon Direction is set to 90 degrees (making it point

to the right), English text must exit the Cannon last letter first to be in readable order. Therefore, select Right to

Left.

• For Loop Text, select to continuously generate the characters you typed. Deselect to generate only one instance of

the characters.

4 Click OK to close the Edit Cannon Text dialog box, and then click OK to close the Particle Playground dialog box.

5 Click the right-facing triangle next to Cannon so that it points downward.

6 Click the Font Size value, type a value of 10 or greater, and press Enter (Windows) or Return (Mac OS).

If you want to stop replacing default particles with text, delete all text from the text box in the Edit Cannon Text

dialog box.

To replace default Grid particles with text (Pro only)

1 In the Effect Controls panel, click Options, and then click Edit Grid Text.
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2 Set the following options:

• For Font/Style, choose the font and style for Grid characters.

• For Alignment, click Left, Center, or Right to position text in the text box at the Position specified in the Grid

control, or click Use Grid to position each letter in the text on consecutive grid inter-sections.

• For Loop Text, select to repeat the characters you typed until all the grid intersections contain one character. Grid

intersections are specified by the Particle Across and Particle Down controls. (See “Grid controls for Particle

Playground (Pro only)” on page 503.) Deselect to generate only one instance of the text. (This option is available

only if you select Use Grid alignment.)

3 Type text in the text box. If Use Grid alignment is selected and you want to skip a grid intersection, type a space.

To force the next character down to the next grid row, press Enter (Windows) or Return (Mac OS).

4 Click OK to close Edit Grid Text, and then click OK to close the Particle Playground dialog box.

5 Click the right-facing triangle next to Grid so that it points downward.

6 Click the Font Size value, type a value of 10 or greater, and press Enter (Windows) or Return (Mac OS).

If you want to stop replacing default particles with text, delete all text from the text box in the Edit Grid Text dialog

box.

Changing a particle over its lifespan (Pro only)

Some controls affect the particle from birth: Cannon, Grid, Layer Exploder, and Particle Exploder. Others affect the

particle after birth and over the course of its lifespan: Gravity, Repel, Wall, Persistent Property Mapper, and

Ephemeral Property Mapper. To have full control over particle movement and appearance, you must balance these

controls.

For example, if you want to use the Cannon to shoot sparks that fade over time, it may seem that you need only

animate the Cannon’s Color control. However, using this method, you change only the color of each new particle as

it’s created. To control the color for the lifespan of particles, you must create a layer map and use one of the Property

Mappers to alter the particles’ color channels. (See “About Property Mappers and Particle Playground (Pro only)” on

page 508.)

The following list covers common particle behavior and how you can influence it.

Speed At particle creation, particle velocity is set by the Cannon and the exploders; Grid particles have no initial

speed. After particle creation, use the Force control in the Gravity and Repel control groups. You can also influence

the speed of individual particles by using a layer map to set values for the Speed, Kinetic Friction, Force, and Mass

properties in the Property Mappers.

Direction At particle creation, the Cannon includes particle direction, the Layer Exploder and Particle Exploder

send new particles in all directions, and Grid particles have no initial direction. After particle creation, direction can

be influenced by the Direction control in the Gravity control group or by specifying a Boundary (mask) in the Wall

control group. You can also influence the direction of individual particles by using a layer map to set values for the

Gradient Force, X Speed, and Y Speed properties in the Property Mappers.

Area Use a Wall mask to contain particles to a different area or to remove all barriers. You can also restrict particles

to an area by using a layer map to set values for the Gradient Force property in the Property Mappers.

Appearance At particle creation, the Cannon, Grid, Layer Exploder, and Particle Exploder set particle size unless

you replace the default dots with a layer map. The Cannon and Grid set the initial color, while the Layer Exploder

and Particle Exploder take color from the exploded dot, layer, or character. The Options dialog box affects the initial

appearance of text. After particle creation, you can use the Property Mappers to set values for Red, Green, Blue, Scale,

Opacity, and Font Size.



ADOBE AFTER EFFECTS 7.0
User Guide

507

Rotation At particle creation, the Cannon and Grid set no rotation; the Particle Exploder takes rotation from the

exploded dot, layer, or character. Use Auto-Orient Rotation to make particles rotate automatically along their

respective trajectories. For instance, a particle can point up as it climbs an arc, and point down as it descends.

Rotation isn’t easily visible for a dot particle. It is easier to observe only when you replace the dot particle with text

characters or a layer. After particle creation, use a layer map to set values for the Angle, Angular Velocity, and Torque

property in the Property Mappers.

Note:The appearance and rotation of a layer map particle changes in relation to the mapped layer’s original appearance

and rotation. For instance, if you replace the default dot particles with a movie of a spinning wheel, the spinning-wheel

particles appear to spin when no particle rotation is applied.

Gravity controls for Particle Playground (Pro only)

Use Gravity controls to pull existing particles in a direction you specify. Particles accelerate in the direction of gravity.

Apply in a vertical direction to create falling particles such as rain or snow, or rising particles such as champagne

bubbles. Apply in a horizontal direction to simulate wind.

Force Specifies the force of gravity. Positive values increase the force, pulling particles more strongly. Negative values

reduce the force.

Force Random Spread Specifies a range of randomness for the Force. At zero, all particles fall at the same rate. At a

higher value, particles fall at slightly different rates. Although pure gravity accelerates all objects equally, increasing

the Force Random Spread value can produce more realistic results with subjects such as leaves falling through air,

where there is enough air resistance to vary the leaves’ rates of descent.

Direction Specifies the angle along which gravity pulls. The default is 180 degrees, which simulates the real world by

pulling particles toward the bottom of the frame.

Affects Specifies a subset of the layer’s particles to which Gravity applies. (See “Affects controls for Particle

Playground (Pro only)” on page 508.)

Repel controls for Particle Playground (Pro only)

Repel controls specify how nearby particles repel or attract each other. This feature simulates adding a positive or

negative magnetic charge to each particle. You can specify which particles, layers, or characters are the repelling force

and which are repelled.

Note: If you want to repel an entire layer of particles away from a specific area, use the Property Mapper controls, Wall

or Gradient Force. (See “Wall controls for Particle Playground (Pro only)” on page 508 and “About Property Mappers

and Particle Playground (Pro only)” on page 508.)

Force Specifies the repel force. Greater values repel particles with more force. Negative values result in particle

attraction.

Force Radius Specifies the radius (measured in pixels) within which particles are repelled. Another particle must be

within this radius to be repelled.

Repeller Specifies which particles act as the repellers or attractors to another subset you specify by using the Affects

control.

Affects Specifies a subset of the layer’s particles to which repulsion or attraction applies. (See “Affects controls for

Particle Playground (Pro only)” on page 508.)
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Wall controls for Particle Playground (Pro only)

Wall controls contain particles, limiting the area within which particles can move. A wall is a closed mask that you

create by using a mask tool, such as the Pen tool. When a particle hits the wall, it bounces off at a velocity based on

the force with which it hit.

Boundary Specifies the mask to use as the wall. You can create a new mask by drawing one on the effect layer.

Affects controls for Particle Playground (Pro only)

Many Particle Playground controls include Affects controls. Affects controls specify which particles are affected by

the encompassing control. For example, the Affects controls within the Particle Exploder controls specify which

particles the Particle Exploder affects.

Particles From Specifies the particle generator or combination of particle generators whose particles you want affect.

Selection Map Specifies the layer map that influences which particles are affected. (See “Replacing default particles

with layers using Layer Map (Pro only)” on page 504.)

Note: The simulation space is not bounded by the dimensions of the layer to which Particle Playground is applied. You

may need to use a selection map that is larger than the Particle Playground layer so that dots that are not visible are still

affected by Selection Map.

Characters Specifies the characters you want to affect. This control applies only if you are using text characters as

the particle type.

Older/Younger Than Specifies the age threshold, in seconds, above or below which you want to affect a particle.

Positive values affect older particles, and negative values affect younger particles. For example, a value of 10 means

that as soon as a particle reaches 10 seconds, it changes to the new value.

Age Feather Specifies the age range in seconds within which the Older/Younger Than value is feathered, or softened.

Feathering creates a gradual, rather than abrupt, change. For example, if you set Older/Younger Than to 10 and Age

Feather to 4, about 20% of particles start changing when they’re 8 seconds old, 50% change when they’re 10 seconds

old (the Older/Younger Than value), and the remainder change by the time they’re 12 seconds old.

About Property Mappers and Particle Playground (Pro only)

You can control specific properties of individual particles by using a layer map and either the Persistent Property

Mapper or the Ephemeral Property Mapper. You can’t alter a specific particle directly, but you can use a layer map to

specify what happens to any particle that passes over a specific pixel in the layer. Particle Playground interprets the

brightness of each layer map pixel as a specific value. (See “Replacing default particles with layers using Layer Map

(Pro only)” on page 504.) The Property Mapper associates a specific layer map channel (Red, Green, or Blue) with a

specific property, so that as a particle passes over a certain pixel, the brightness value at that pixel modifies the

property.

A particle property can be modified in either a persistent or an ephemeral way:

• A persistent change to a particle property retains the most recent value set by a layer map for the remaining lifespan

of the particle, unless the particle is modified by another control such as Repel, Gravity, or Wall. For example, if

you use a layer map to modify particle size and you animate the layer map so it exits the frame, the particles keep

the last size value set by the layer map after it exits the frame.

• An ephemeral change to a particle property causes the property to revert to its original value after each frame. For

example, if you use a layer map to modify particle size and you animate the layer map so that it exits the frame,

each particle returns to its original size value as soon as no layer map pixels correspond to it. Similarly, if you apply

an operator such as Add, each time a particle passes over a different layer map pixel, the value of the layer map

pixel is added to the original value of the particle.
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In both the Persistent and Ephemeral Property Mappers, you can control up to three particle properties indepen-

dently by using a single RGB image as a layer map. Particle Playground achieves this by extracting brightness values

separately from the red, green, and blue channels in the image. You don’t have to use all three channels if you want

to modify just one property. To change just one property or change up to three properties using the same values, use

a grayscale image as the layer map because the RGB channels are identical. (See “Creating an RGB layer map for

Particle Playground (Pro only)” on page 513.)

To use Particle Playground Property Mapper controls (Pro only)

In combination with keyframes, the Property Mappers provide complete control over individual particle properties

in space and time. Using layer maps, you can change particle properties at any location within a frame. By applying

keyframes to Property Mapper options and animating a layer map, you can control how particle properties change.

1 For Use Layer As Map, choose a layer map to use as the source for values that modify particle values. The layer

map must be part of the composition. (See “Replacing default particles with layers using Layer Map (Pro only)” on

page 504.)

2 To apply the effect to a subset of particles, specify the Affects controls as necessary. (See “Affects controls for

Particle Playground (Pro only)” on page 508.)

3 Choose a property for each of the Map Red To, Map Green To, and Map Blue To controls. You don’t have to map

properties to all of the color channels. For example, if you want to change scale over an image map, you can map the

color red to scale without setting other properties.

4 Specify the minimum and maximum values you want the layer map to produce for each Map To group. Min is the

value to which a black pixel is mapped, and Max is the value to which a white pixel is mapped. The complete tonal

distribution between Min and Max is then scaled proportionally. (See “Using Min and Max controls for Property

Mappers (Pro only)” on page 511.)

5 If using the Ephemeral Property Mapper, you can apply an operator the value of a particle property and the value

of the corresponding layer map pixel. (See “Operator controls for the Ephemeral Property Mapper (Pro only)” on

page 511.)

Note: Because particle properties use many kinds of units, such as pixels, degrees, and seconds, you may want to

compress or expand the range of values from the layer map so that all the resulting values are usable in the measurement

system of a specific particle property. First, use the Min and Max controls, which define the range of values to use from

the layer map. If further adjustment is necessary and you’re using the Ephemeral Property Mapper, use the Operator

control and choose a mathematical operator to amplify, attenuate, or limit the effect of a layer map.

Particle Playground Property Mapper controls (Pro only)

In both the Persistent and Ephemeral Property Mappers, you can use a layer map’s alpha channel to make more subtle

changes to the value of a particle property. For example, particles over a layer-map pixel in which the alpha channel

value is 255 are fully affected, while lower values affect particles less. Layer-map pixels that are completely trans-

parent have no effect on particle properties. (See “Replacing default particles with layers using Layer Map (Pro only)”

on page 504.)

When you choose any of the following properties, Particle Playground copies the value from the layer map (that is,

the layer selected in the Use Layer as a Map menu) and applies it to the particle.

None Modifies no particle property.

Red, Green, Blue Copy the value of the particle’s red, green, or blue channel within a range of 0.0–1.0.

Kinetic Friction Copies the amount of resisting force against a moving object, typically within a range of 0.0–1.0.

Increase this value to slow down or stop moving particles as if braking.



ADOBE AFTER EFFECTS 7.0
User Guide

510

Static Friction Copies the amount of inertia that holds a stationary particle in place, typically within a range of 0.0–

1.0. At zero, a particle moves when any other force, such as gravity, is present. If you increase this value, a stationary

particle requires more of another force to start moving.

Angle Copies the direction in which the particle points, in degrees relative to the particle’s original angle. The angle

is easily observable when a particle is a text character or a layer without radial symmetry.

Angular Velocity Copies the velocity of particle rotation in degrees per second. This determines how fast a particle

rotates around its own axis.

Torque Copies the force of particle rotation. The angular velocity of a particle is increased by a positive torque and

is increased more slowly for particles of greater mass. Brighter pixels affect angular velocity more forcefully; if

enough torque is applied against angular velocity, the particle starts spinning in the opposite direction.

Scale Copies the scale value of a particle along both the x and y axes. Use this to stretch a particle proportionally. A

value of 1.0 scales the particle to its full size; a value of 2.0 scales it 200%, and so on.

X Scale, Y Scale Copy the scale value of a particle along the x or y axis. Use these to stretch a particle horizontally or

vertically.

X, Y Copy the position of a particle along the x or y axis in the frame, in pixels. A value of zero specifies a position

at the left of the frame (for X) or at the top of the frame (for Y).

Gradient Velocity Copies the velocity adjustment based on areas of a layer map on both the x and y planes of motion.

X Speed, Y Speed Copy the horizontal speed (x-axis velocity) or vertical speed (y-axis velocity) of a particle in pixels

per second.

Gradient Force Copies the force adjustment based on areas of a layer map on both the x and y planes of motion. The

pixel brightness values in the color channel define the resistance to particle force at each pixel, so the color channel

acts like a layer map of hills and valleys that decrease or increase particle force. In the layer map, areas of equal

brightness result in no adjustment, similar to flat land. Lower pixel values represent less resistance to a particle’s force,

similar to a downhill grade. Higher pixel values represent more resistance to a particle’s force, similar to an uphill

grade. For best results, use a soft-edged layer map image.

If you are using a layer map for Gradient Force where flat areas equal no adjustment, and you are using the Min and

Max controls (not the Min or Max operators) to set the range of values for Gradient Force, set them to positive and

negative values of the same number (for example, –30 and +30). This ensures that the middle of the range remains

centered at zero.

X Force Copies the coercion along the x axis of motion. Positive values push a particle to the right.

Y Force Copies the coercion along the y axis of motion. Positive values push a particle down.

Opacity Copies the transparency of a particle, where zero is invisible, and 1 is solid. Adjust this value to fade particles

in or out.

Mass Copies the particle mass, which interacts with all properties that adjust force, such as Gravity, Static Friction,

Kinetic Friction, Torque, and Angular Velocity. It takes greater force to move particles with a larger mass.

Lifespan Copies the elapsed length of time a particle exists, in seconds. At the end of its lifespan, the particle is

removed from the layer. The default lifespan is effectively immortal.

Character Copies the value that corresponds to an ASCII text character, making it replace the current particle.

Applies only if you’re using text characters as particles. You can specify which text characters appear by painting or

drawing shades of gray on the layer map that correspond to the ASCII characters you want. A value of zero produces

no character. For US English characters, use values between 32 and 127. The range of possible values can accom-
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modate Japanese characters. For more information about the ASCII character values for a font you’re using, see the

documentation for the font, use a utility such as Character Map (Windows), or contact the font manufacturer.

Note: If you simply want to make certain characters spell a message, it’s much easier to type the text directly in the

Options dialog box. The Character property is more useful as a secret message effect in which you scramble text

characters. (See “To replace default Cannon particles with text (Pro only)” on page 505.)

Font Size Copies the point size of characters. Applies only if you’re using text characters as particles. Increase this

value to make characters larger.

Time Offset Copies the Time Offset value used by the Layer Map. Applies only if you used the Layer Map control to

specify a multiframe layer (such as a movie) as a particle source. (See “Replacing default particles with layers using

Layer Map (Pro only)” on page 504.)

Scale Speed Copies the scale of a particle. Positive values expand the particle, and negative values shrink the particle.

Particles expand or shrink by a percentage per second.

Using Min and Max controls for Property Mappers (Pro only)

When the overall range of layer map brightness values is too wide or narrow, use Min and Max to stretch, compress,

or shift the range of values produced by the layer map. The following examples describe when you might want to

adjust Min and Max:

• You want to set the smallest font size for your text to 10 points and the largest size to 96 points. Set the Min value

to 10 and the Max value to 96.

• You set the initial color of a particle and then use a layer map to change particle colors. If you find that the color

changes aren’t dramatic enough, you can lower the Min value and raise the Max value to increase the contrast of

the color changes.

• You set the initial velocity of a particle and then use a layer map to affect the X Speed value. However, you find

that the difference between the fastest and slowest particles is too great. By raising the Min value and lowering the

Max value for the layer map channel that is mapped to the X Speed value, you narrow the resulting range of

particle speeds.

• You use a layer map to affect the Scale property of particles and find that the smallest particles aren’t small enough

while the largest resulting particles are too large. In this case the entire output range needs to be shifted down;

lower both the Min and Max values.

• You have a layer map that modifies particles in the opposite direction from the one you want. Swap the Min and

Max values, which has the same result as inverting the layer map.

Note: The alpha channel of the layer map is used as the selection map for the Persistent and Ephemeral Property

Mappers.

Operator controls for the Ephemeral Property Mapper (Pro only)

When you use the Ephemeral Property Mapper controls, Particle Playground replaces the value of a particle’s

property with the value represented by the layer map pixel at the particle’s current location. You can also amplify,

attenuate, or limit the resulting values by specifying a mathematical operator and then using both the value of a

particle’s property and its corresponding layer map pixel value.

Set Replaces the value of a particle property by the value of the corresponding layer map pixel. For example, to

simply replace the value of a particle property with the brightness value of the corresponding pixel on the layer map,

use Set. This is the most predictable operator and is the default.

Add Uses the sum of the value of a particle property and the value of the corresponding layer map pixel.
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Difference Uses the absolute value of the difference of the value of a particle property and the brightness value of the

corresponding pixel on the layer map. Because it takes the absolute value of the difference, the resulting value is

always positive. This operator is useful when you want to limit values to only positive values. If you’re trying to model

realistic behavior, the Difference operator may not be ideal.

Subtract Starts with the value of a particle property and subtracts the value of the brightness value of the corre-

sponding pixel on the layer map.

Multiply Multiplies the value of a particle property by the brightness value of the corresponding pixel on the layer

map and uses the result.

Min Compares the brightness value of the layer map to the value of the particle property and uses the lower value.

To limit a particle property so that it is less than or equal to a value, use the Min operator and set both the Min and

Max controls to that value. If you use a white solid as a layer map, you need only set the Max control to that value.

Max Compares the brightness value of the layer map to the value of the particle property and uses the higher value.

To amplify existing values of properties, try applying the Add operator with positive values or the Multiply operator

with values above 1.0. To attenuate (tone down) property value changes, try applying the Multiply operator using

values between 0 and 1.0.

About layer maps and Particle Playground (Pro only)

A layer map is an image in which each pixel’s brightness value is used by an effect in a calculation. Particle

Playground uses a layer map to exercise precise control of a particle property such as opacity. In this way, After

Effects doesn’t use a layer map as a picture but as a matrix of numbers. In many cases, you never see the actual layer

map in the final movie—you see only the result of an effect applying the layer map’s pixel values to the corresponding

pixels in a destination layer.

Regardless of the color depth of the image that you use as a layer map, After Effects always uses its red, green, and

blue channels as if each were an 8-bit grayscale image. If you create a layer map using colors, the Property Mappers

in Particle Playground can extract the brightness values from each RGB color channel separately. (See “Creating an

RGB layer map for Particle Playground (Pro only)” on page 513.)

A layer map is often used as a stationary layer of the same dimensions as its destination layer. The value of each pixel

in the layer map applies only to one specific pixel at the corresponding position in the destination layer. However,

when you animate a layer, the appearance of the pixels in the destination layer changes depending on which layer-

map pixel corresponds to it at a particular point in time. Layer maps are often animated so that the layer map effect

appears to sweep through the destination layer.

Creating a layer map for Particle Playground (Pro only)

Layer maps are often created by painting in an image-editing program such as Adobe Photoshop, although you can

use any program that can save an image compatible with After Effects. The key to creating a good layer map is to

remember that the brightness value of each pixel influences an effect property. Here are some hints and tips for

creating layer maps:

• If you want a layer map to match the shape of an image that already exists, simply use that image. For best results,

create a layer map that has the same dimensions as the layer containing the image.

• You can create a layer map by precomposing a white solid layer, a black solid layer, and a mask on the top layer

that determines which areas are white and black. Increasing the mask’s feather softens the transition between black

and white values.
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• In Photoshop, an easy way to create a layer map is to create a layer with a black or white background, draw a

selection, and fill the selection with the opposite color. Blurring the entire layer softens the transition between

black and white values.

• You can set layer map values more precisely by painting shades of gray within a range from 0 (black) to 255 (white).

This is the tonal range of an 8-bit channel. To simplify painting or drawing, see if your image-editing program

provides or allows you to create a palette of 256 gray shades.

Note: While images created for use as displacement maps (in other effects or programs) often map tones to values on a

scale from –127 to +127, Particle Playground interprets tones of gray as values on a scale from 0.0 (black) to 1.0 (white).

If you’re using images created as displacement maps, use the Min and Max controls to modify the range of tones produced

by the layer map. (See “Using Min and Max controls for Property Mappers (Pro only)” on page 511.)

• The alpha channel in a layer map modifies the value before it’s applied to the destination layer. Areas where the

alpha channel is completely off (transparent areas of a layer map) don’t affect on particle values. Areas where the

alpha channel has a partial value (semitransparent areas of a layer map) partially affect the particle value. For

example, if a layer-map pixel has a value of 10 and the layer-map alpha channel has a value of 127 (50%), the layer-

map pixel is affected by 50%, and its true value is 5. When you use the Persistent and Ephemeral Property

Mappers, the actual value applied to a particle is also affected by the range set for the Min and Max controls. (See

“Using Min and Max controls for Property Mappers (Pro only)” on page 511.)

• If you want to change any of the layer map’s layer properties (Masks, Effects, or Transform), change them,

precompose the layer, and then use the resulting composition as the layer map. Otherwise, Particle Playground

ignores any property settings.

• The contrast between adjacent pixel values determines how smoothly the values change across the surface of the

layer map. To create smooth changes, paint using a soft or anti-aliased brush, or apply gradients. To create abrupt

changes, avoid intermediate shades, using just a few widely spaced shades such as 50% gray, black, and white.

• You can adjust overall edge contrast with blur or sharpen filters, if your painting or drawing program provides

them.

Note: If you want to edit individual pixels, open the layer map in the program you used to create it and make the change.

Before you apply a layer map to a particle layer, they must be in the same composition, in a stacking order that

produces the results you want. If you want particles to be visible in front of the layer map, make sure that the layer

with Particle Playground applied is in front of the layer map. If you don’t want the layer map to be visible, hide it by

clicking the layer’s eye icon  in the Timeline panel.

Creating an RGB layer map for Particle Playground (Pro only)

Particle Playground can extract brightness values separately from the red, green, and blue channels in an image. If

you want to create different layer maps for each channel, use a program that can edit individual color channels, such

as Adobe Photoshop, and then paint or paste each layer map into its own channel. Save the layer map as an RGB

image in a format After Effects can import. The image may look unusual when viewed in RGB mode because it’s

intended to be used as a single hidden layer containing three different layer maps, not as a visible color layer.

When you apply an effect that can use each color channel as a separate layer map, you can still use a grayscale image;

the RGB channels will be identical.

If you already have three separate images, you can combine them into a single RGB file by using the Set Channels

effect. Set Channels can load each image into its own channel in a combined file, making it suitable for use as an

RGB layer map.
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Improving performance with Particle Playground (Pro only)

Keep the following in mind when working the Particle Playground effect:

• When you’re generating a Particle Playground effect, keep an eye on the Info panel to see how many particles are

being produced. If an effect contains more than 10,000 particles, it can significantly slow rendering. If you notice

performance problems, set Particles Per Second and/or Particles Down to relatively low values (between 1 and

100).

• The Grid and Layer Exploder generate particles on every frame, which may generate too many particles for the

effect you’re creating and slow down rendering. To avoid continuous particle generation, animate these controls

to decline to zero over time: Layer Exploder, Radius of New Particles, Grid Width and Height, Particle Radius, and

Font Size. Then Particle Playground generates new particles only at the start of a sequence.

• When you apply a Particle Playground effect to a layer, the particle positions aren’t limited to the bounds of that

layer. To control particles that you can't see or that appear near the edge of the image, use a Selection or Property

Map that’s larger than the area of the Particle Playground layer. Also, note that After Effects takes an image map’s

alpha channel into account. If you want transparent areas of your map to affect the particles, precompose the map

layer with a black solid behind it.

To specify field-rendering with a Particle Playground effect, select Enable Field Rendering in the Particle Playground

options dialog box. Then Particle Playground calculates the simulation at double the frame rate of the current

composition, which is what field rendering requires.

Shatter effect
The Shatter effect explodes graphic images. Use the effect’s controls to set explosion points and adjust the strength

and radius. Anything outside the radius doesn’t explode, leaving portions of the layer unaltered. You can choose from

a variety of shapes for the shattered pieces and extrude the pieces to give them bulk and depth. You can even use a

gradient layer to precisely control the order of an explosion. For example, if you import a logo, use Shatter to blow a

logo-shaped hole in a layer.

This effect works with 8-bpc color.

Original (left) and as Shatter is applied over time to reveal another layer (center and right)

View control for the Shatter effect

The View control specifies exactly how a scene appears in the Composition panel by using the following views:

Rendered Displays the pieces with textures and lighting—as they will look at final output. Use this view when

rendering the animation.

Wireframe Front View Displays the layer from a full-screen, straight-on camera angle with no perspective. Use this

view to adjust effect points and other parameters that are hard to see from an angle. In addition, the outlines of the

shatter map are visible so you can precisely position, rotate, and scale the shatter pattern. It’s handy to toggle between

this view and the perspective view you use for the scene.

Wireframe Displays the correct perspective of the scene, so you can quickly set up the camera the way you like it and

fine-tune the Extrusion Depth.
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Wireframe Front View + Forces Displays the wireframe front-view representation of the layer, plus a blue represen-

tation of each force sphere.

Wireframe + Forces Displays the wireframe view, plus a blue representation of the force spheres. This view includes

camera controls, so you can position everything accurately in 3D space.

Render control for the Shatter effect

The Render control renders the whole scene (the default), the unshattered layer, or the shattered pieces indepen-

dently. For example, if you want to apply the Glow effect only to shattered pieces and not to the portions of the layer

that remain intact, create the explosion and duplicate the layer. Next, for the back layer, choose Layer from the

Render menu, and for the front layer, choose Pieces. Then apply the Glow effect to the front layer.

Shape controls for the Shatter effect

Shape controls specify the shape and appearance of the shattered pieces.

Pattern Specifies the preset pattern to use for the exploded pieces.

Custom Shatter Map Specifies the layer you want to use as the shape of the exploded pieces. See “Creating a custom

shatter map” on page 519.

White Tiles Fixed Prevents pure white tiles in a custom shatter map from being exploded. You can use this control to

force certain parts of a layer to remain intact.

Use this control when your shatter map uses images or letters such as O: Set the portion you don’t want to blow out,

such as the centers of the O and the background, to pure white and set the rest to another pure color.

Repetitions Specifies the scale of the tile pattern. This control works only in conjunction with the preset shatter

maps, which all seamlessly tile. Increasing this value increases the number of pieces on the screen by scaling down

the size of the shatter map. Consequently, the layer breaks into more and smaller pieces. Animating this control is

not recommended, as it can cause sudden jumps in the number and size of shatter pieces.

Direction Rotates the orientation of a preset shatter map, relative to the layer. As with Repetitions, animating this

control results in sudden jumps in the animation and is not recommended.

Origin Precisely positions a preset shatter map on the layer. This is useful if you want to line up portions of an image

with specific shattered pieces. Animating this control results in sudden jumps in the animation and is not recom-

mended.

Extrusion Depth Adds a third dimension to the exploded pieces. The higher the value, the thicker the pieces. In

Rendered view, this effect isn’t visible until you start the shatter or rotate the camera. As you set this control higher,

the pieces may actually pass through each other. While this is generally not a problem in full-speed animations, it

may become visible when the pieces grow very thick and move slower.

Force 1 and Force 2 controls for the Shatter effect

Force 1 and Force 2 controls define the blast areas by using two different Forces.

Position Specifies the current center point of the blast in (x,y) space.

Depth Specifies the current center point in z space, or how far in front of or behind the layer the blast point is. Adjust

Depth to determine how much of the blast radius is applied to the layer. The blast radius is a sphere, and the layer is

basically a plane; therefore, only a circular slice of the sphere intersects the plane. The farther away the layer is from

the center of the blast, the smaller the circular slice. When pieces explode, they fly away from the force center. Depth

determines which way the pieces fly: Positive values cause the pieces to explode forward, toward the camera

(assuming the default camera settings of 0, 0, 0); negative values cause pieces to blow backward, away from the

camera. To see the result of the Depth setting, use the Wireframe + Force Sphere view.
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Radius Defines the size of the blast sphere. The radius is the distance from the center of a circle (or sphere) to the

edge. By adjusting this value, you can fine-tune exactly which pieces explode. Changing this value can vary the speed

and completeness of the explosion. Animating it from small to large generates an expanding, shockwave explosion.

Note: To determine when the pieces shatter, animate the Radius control, not the Strength control. Pieces inside the force

sphere are pulled off-screen by gravity even if Strength is set to 0.

Strength Specifies the speed at which the exploded pieces travel—how hard they are blown away from or sucked

back into the blast point. A positive value blows the pieces away from the blast point; a negative value sucks the pieces

into the blast point. The greater the positive value, the faster and farther they fly away from the center point. The

greater the negative value, the faster the pieces launch themselves toward the center of the force sphere. Once the

pieces are launched, however, they are no longer affected by the force sphere; the Physics settings take over. A

negative Strength value does not suck the pieces into a black hole; instead, the pieces fly through each other and back

out the other side of the sphere. Setting Strength very low causes the pieces to break up into shapes, creating cracks

in the layer, but it doesn’t actually blow the pieces apart. If gravity is set to anything other than 0, the pieces are pulled

in the direction of gravity after they break up.

Note: A shatter piece is made up of vertices (points or dots that define the corners of the shape), edges (lines that connect

the dots), and planes (walls of the shape). Shatter determines when a shape has come in contact with a force sphere based

on when a vertex comes in contact with the sphere.

Gradient controls for the Shatter effect

Gradient controls specify the gradient layer used to control the timing of an explosion and the pieces that are affected

by the blast.

Shatter Threshold Specifies which pieces in the force sphere shatter according to the corresponding luminance of

the specified gradient layer. If Shatter Threshold is set to 0%, no pieces in the force sphere shatter. If it is set to 1%,

only the pieces in the force sphere corresponding to white (or very-nearly-white) areas on the gradient layer shatter.

If it is set to 50%, all the pieces in the force sphere corresponding to white-to-50%-gray areas on the gradient layer

shatter. If it is set to 100%, all pieces in the force sphere shatter. Because there are 256 shades of gray (including black

and white), each percentage point represents approximately 2.5 shades of gray.

Animating Shatter Threshold influences the timing of the explosion. If you leave it set to 0%, the layer never

explodes. However, if you set a Shatter Threshold keyframe at 50%, the pieces of your layer in the force field that

correspond to areas of your gradient layer that range from white to 50% gray explode. If you then animate Shatter

Threshold up to 100%, the remaining pieces in the force sphere explode.

Gradient Layer Specifies the layer to use to determine when specific areas of the target layer shatter. White areas

shatter first; black areas shatter last. Shatter determines which pixels correspond to which pieces by subdividing the

layer into pieces, each with a center point or balance point. If you superimpose the shatter map over the gradient

layer, the gradient layer pixels that are precisely under each balance point control the explosion.

Note: Some shapes have a balance point that falls outside the actual area of the shape—for example, the letters C and

U. When designing a gradient layer in such a situation, avoid using grayscale versions of letters. Instead, use larger

shapes that cover the balance point of each character.

Invert Gradient Inverts the pixel values in the gradient. White becomes black, and black becomes white.
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Physics controls for the Shatter effect

Physics controls specify the way the pieces move and fall through space.

Rotation Speed Specifies the speed at which pieces rotate around the axis set by the Tumble Axis control, allowing

you to simulate different rotation speeds for different materials. In nature, similarly shaped pieces spin at different

speeds based on their mass and air friction. For example, a brick spins faster than Styrofoam.

Tumble Axis Specifies the axis that the pieces spin around. Free spins the pieces in any direction. None eliminates all

rotation. X, Y, and Z spin the pieces only around the selected axis. XY, XZ, and YZ spin the pieces only around the

selected combination of axes.

Note: Any application of z-axis rotation appears only when a second force hits the layer. The pieces do not rotate from

the first blast if only z-axis rotation is selected.

Randomness Affects the initial velocities and spins generated by the force sphere. When this control is set to 0,

pieces fly directly away from the center point of a blast (assuming a positive force). Since real explosions are rarely

this orderly, Randomness allows you to vary things a little bit.

Viscosity Specifies how fast pieces decelerate after being blown apart. The higher the Viscosity value, the more resis-

tance the pieces encounter as they move and spin. If Viscosity is set high enough, the pieces quickly come to a stop.

To replicate an explosion in water or sludge, set Viscosity to a high value. In air, set it to a medium value, and for an

explosion in space, set it very low, or to 0.

Mass Variance Specifies the theoretical weight of the pieces as they explode. For example, a large piece is heavier

than a small piece and therefore does not fly as far or as fast when it encounters the blast. Mass Variance’s default

setting of 30% gives a realistic approximation of this law of physics. Setting Mass Variance to 100% greatly

exaggerates the difference between the behavior of large versus small pieces. Setting it to 0% makes all pieces behave

the same, regardless of their size.

Gravity Determines what happens to the pieces after they break up and blow apart. The higher the gravity setting,

the faster the pieces are sucked in the direction set by Gravity Direction and Gravity Inclination.

Gravity Direction Defines the direction in (x,y) space that the pieces travel when affected by gravity. The direction

is relative to the layer. If Gravity Inclination is set to -90 or 90, Gravity Direction has no effect.

Gravity Inclination Determines the direction in z space that the pieces travel once they explode. A value of 90

explodes the pieces forward, relative to the layer. A value of -90 explodes them backward, relative to the layer.

Textures controls for the Shatter effect

Textures controls specify the texture of the pieces.

Color Specifies the color of the piece as defined by the Front Mode, Side Mode, and Back Mode menus. This color

may or may not be visible depending on the Mode settings: When a Mode setting is Color, Tinted Layer, Color +

Opacity, or Tinted Layer + Opacity, the selected color is factored into the appearance of the piece.

Opacity Controls the opacity of the corresponding Mode setting. A Mode setting must be Color + Opacity, Layer +

Opacity, or Tinted Layer + Opacity for the opacity to affect the appearance of the piece. You can use the Opacity

control in conjunction with texture maps to create the look of semitransparent materials.

Front Mode, Side Mode, Back Mode Determine the appearance of the front, sides, and back of the pieces. Color

applies the selected Color to the applicable side of the piece. Layer takes the layer chosen in the corresponding Layer

menu and maps it to the applicable side of the piece. Tinted Layer blends the chosen layer with the selected Color;

the effect is similar to viewing the layer through a colored filter. Color + Opacity combines the selected Color and

the Opacity amount. With Opacity at 1, the applicable side is given the selected Color. With Opacity at 0, the appli-

cable side is transparent. Layer + Opacity combines the chosen layer and the Opacity amount. With Opacity at 1, the
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chosen layer is mapped to the applicable side. With Opacity at 0, the applicable side is transparent. Tinted Layer +

Opacity combines the tinted chosen layer and the Opacity amount. With Opacity at 1, the tinted chosen layer is

mapped to the applicable side. With Opacity at 0, the applicable side is transparent.

Note: If you apply Shatter to a layer containing an alpha channel that you want to use for transparency, use the same

texture (or at least another layer with an identical alpha channel) for the front, sides, and back of the pieces to make all

sides transparent.

Front Layer, Side Layer, Back Layer Specify the layer to be mapped onto the corresponding side of the piece. Front

Layer maps the chosen layer to the front of the piece. Back Layer maps the chosen layer backward to the layer. If Layer

is chosen for both Front Mode and Back Mode, and the same layer is specified for each, each shattered piece has the

same pixel information on both sides. Side Layer maps an extrusion of the chosen layer to the extruded sides of the

piece, as if the chosen layer is also mapped to the front and back, and the layer has been sliced through.

Note: If you choose a layer with an effect applied, the effect does not show up in the texture unless you precompose the

layer. However, if you select None, the layer to which you have applied Shatter, along with any effects that occur before

Shatter, is used as the texture map, with no precomposing required.

Camera System and Camera Position controls for the Shatter effect

The Camera System control specifies whether to use Camera Position, Corner Pins, or Comp Camera. Comp

Camera tracks the composition's camera and light positions and renders a 3D image on the layer.

Camera Position controls specify the camera position:

X Rotation, Y Rotation, Z Rotation Rotate the camera around the corresponding axis. Use these controls to look at

the layer from the top, side, back, or any other angle.

X, Y Position Specifies where the camera is positioned in (x,y) space.

Z Position Specifies where the camera is positioned in z space. Smaller numbers move the camera closer to the layer,

and larger numbers move the camera away from the layer.

Focal Length Specifies the zoom factor and is like a camera’s zoom lens. Smaller numbers zoom the camera lens out,

and larger numbers zoom the camera lens in.

Transform Order Specifies the order in which the camera rotates around its three axes and whether the camera

rotates before or after it is positioned using the other Camera Position controls.

Corner Pins controls for the Shatter effect

Corner pinning is an alternative camera control system. Use it as an aid for compositing your layer into a scene.

Upper Left Corner, Upper Right Corner, Lower Left Corner, Lower Right Corner Specify the location of each of the

four corners of your layer.

Auto Focal Length Controls the perspective of the effect during the animation. When Auto Focal Length is off, the

focal length you specify is used to find a camera position and orientation that positions the corners of the layer at the

corner pins. If this isn’t possible, the layer is replaced by its outline, drawn between the pins. When Auto Focal Length

is on, the focal length required to match the corner points is used, if possible. If not, Focal Length interpolates the

correct value from nearby frames.

Focal Length Overrides the other settings if the results you’ve obtained aren’t what you need. If you set Focal Length

to something that doesn’t correspond to what the focal length would be if the pins were actually in that configuration,

the image may look odd (strangely sheared, for example). But if you know the focal length that you are trying to

match, Focal Length is the easiest way to get correct results.
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Lighting controls for the Shatter effect

Lighting controls specify the lighting for the Shatter effect.

Light Type Specifies which type of light you want to use. Distant Source simulates sunlight and casts shadows in one

direction, where all the light rays strike the object from virtually the same angle. Point Source is similar to a light

bulb and casts shadows in all directions. First Comp Light uses the composition’s first light layer, which can use a

variety of settings.

Light Intensity Specifies the power of the light. The higher the value, the brighter the layer. Other lighting settings

affect the overall light intensity as well.

Light Color Specifies the color of light.

Light Position Specifies the position of the light in (x,y) space.

Light Depth Specifies the position of the light in z space. Negative numbers move the light behind the layer.

Ambient Light Distributes light over the layer. Increasing it adds an even illumination to all objects and prevents

shadows from being totally black. Turning Ambient Light all the way to pure white, and setting all other light controls

to 0, makes the object fully lit and eliminates any 3D shading from the scene.

Material controls for the Shatter effect

Material controls specify the reflection values of the pieces.

Diffuse Reflection Gives objects form-defining shading. Shading depends on the angle at which the light strikes the

surface, and is independent of the viewer’s position.

Specular Reflection Takes into account the position of the viewer. It models the reflection of the light source back to

the viewer. It can create the illusion of shininess. For realistic effects, you can animate this control by using higher

and higher values to mask the transition from filtered to nonfiltered versions of the layer.

Highlight Sharpness Controls shininess. Very shiny surfaces produce small tight reflections, while duller surfaces

spread the highlight out into a larger region. Specular highlights are the color of the incoming light. Because light is

typically white or off-white, broad highlights can desaturate an image by adding white to the surface color.

Note: In general, use the following process to adjust lighting: Set the Light Position and Diffuse Reflection to control the

overall light level and shading in a scene. Then, adjust Specular Reflection and Highlight Sharpness to control the

strength and spread of highlights. Finally, adjust Ambient Light to fill in the shadows.

Creating a custom shatter map

All layers in After Effects are represented as an RGBA image (even black-and-white images). The Shatter effect calcu-

lates the luminance threshold of each channel to create a custom shatter map. Shatter calculates the 50% luminance

threshold of each channel, creating an image composed of only eight colors: red, green, blue, yellow, magenta, cyan,

white, and black. These eight colors become possible combinations of the channels set either all the way on (255) or

all the way off (0). The shatter layer splits along the edges of these different colored sections.

When designing custom shatter maps, it can be useful to manually set a threshold for each channel of the image at

50% (you can use the Curves effect to do this). When you set the threshold you can see how the image will be broken

into pieces. Alternatively, you can create custom shatter maps by drawing an image using only the eight colors listed

above, with no intermediate shades or anti-aliasing.

The alpha channel determines whether or not a shattered piece exists. A white alpha channel value results in a

shattered piece, and a black alpha channel value results in no piece. Using an alpha channel, you can make a tile map

with holes in it or generate simple 3D models like extruded text.
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Note: The custom shatter map determines the shapes of the pieces your layer shatters into, but not when the pieces

shatter. The timing is determined by the Force controls and can be further controlled by a gradient layer.

Wave World effect
Use this effect to create a grayscale displacement map for use with other effects such as Colorama or Caustics. This

effect creates physics-based liquid waves. Waves emanate from an effect point, interact with each other, and realisti-

cally reflect off their environment. Use Wave World to create a top-down view of a logo, with waves reflecting off the

logo and the sides of the layer.

This effect works with 8-bpc color.

Wireframe view (left), Height Map view (center), and resulting image (right). The result is used as the Water Surface source for the Caustics
effect example.

Wireframe view (left), Height Map view (center), and resulting image (right). The result is used as the Input Phase for the Colorama effect
example.

To understand how this effect works, consider the following information about the physics of waves: A wave consists

of a peak and a trough. The amplitude of a wave is the height, or distance, between the peak and trough. The

wavelength is the distance from one peak to the next. Frequency is the number of waves per second passing a fixed

point.

View controls for the Wave World effect

View controls specify the method used to preview the Wave World effect. Choose one of the following views:

Height Map Is a grayscale image that displays the highest points as bright pixels and the lowest points as dark pixels.

Use this view when creating a displacement map.

Wireframe Preview Provides a visual depiction of how the wave is being created. The grayscale output represents a

height map: White represents the highest possible wave, and black represents the lowest. The two rectangular

outlines represent these two extremes: The cyan rectangle represents pure white, and the violet rectangle represents

pure black. The green grid represents the ground layer; it is flat by default but can be distorted by using a grayscale

image. The white grid represents the surface of the water.
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Wireframe controls for the Wave World effect

Wireframe controls fine-tune the appearance of the wireframe model. These controls do not affect the grayscale

output.

Horizontal Rotation Rotates the wireframe preview around the horizontal axis (right and left). As you adjust this

control, the distortion of the wireframe model keeps the entire wireframe model in full view.

Vertical Rotation Rotates the wireframe preview around the vertical axis (up and down).

Vertical Scale Distorts the wireframe preview vertically so that you can see heights more easily. It does not affect the

grayscale output.

Height Map controls for the Wave World effect

Height Map controls specify the appearance of the height map.

Note: While adjusting Brightness and Contrast, keep the wave surface layer between the cyan and violet rectangles. If a

peak pokes through the cyan rectangle, it clips at pure white. If a trough pokes through the bottom of the violet rectangle,

it clips at pure black. If you want to create a displacement map, try to avoid clipping because it shows up as flat peaks

and valleys, which look unnatural.

Brightness Adjusts the overall height of the water surface. Adjusting it brightens or darkens the overall grayscale

output. When you use Wave World for displacement, this control moves the surface of the water up or down.

Contrast Changes the difference between the grays of the peaks and troughs, making the difference more or less

extreme. Lower values even out the grays, and higher values create a wider range from black to white (until clipping

occurs).

Gamma Adjustment Controls the slope of the waves in relation to the Brightness. Results are visible only in Height

Map view. Higher values result in rounder peaks and narrower valleys, while lower values result in smoother valleys

and pointier peaks.

Render Dry Areas As Specifies how the water surface is rendered when a dry area exists. Dry areas are created when

a portion of the ground layer rises above the surface of the water. You can manipulate the dry area by using the

Steepness control.

This control is useful for compositing a Wave World effect into a scene. For example, you can use a precomposed

Wave World scene with transparency as a displacement map for the Caustics effect, and as a track matte for the effect

layer.

Transparency Controls the clarity of the water by adjusting how opaque the alpha channel is in shallower areas. For

example, you can easily see to the bottom of a pool filled with fresh water, but you can see only an inch or two into

a pool filled with coffee. This control is most useful when compositing a Wave World effect into another scene. For

example, you can use a Wave World composition as a source layer for Caustics, and also as a track matte for the effect

layer.

Simulation controls for the Wave World effect

The Simulation controls specify the resolution of the water surface and ground grids.

Grid Resolution Specifies the number of horizontal and vertical divisions that make up the wave surface and ground

grids. Higher values greatly increase the accuracy of the simulation but require more memory and increase rendering

time.

Grid Res Downsamples Reduces the internal simulation resolution when the output resolution decreases, increasing

the rendering speed. However, this may cause the output to look significantly different.

Wave Speed Specifies how fast waves travel away from their starting point.
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Damping Specifies how quickly a wave’s energy is absorbed by the liquid it is travelling through. The higher the

value, the quicker the wave energy is absorbed, and the shorter the distance the wave travels.

Wave Speed, Damping Specify the apparent viscosity of the liquid, and the apparent size of the body of liquid. For

example, waves in water move faster and farther than waves in honey; waves in a sink move much faster and fade out

much more quickly than waves in a lake.

Note: Wave World is optimized for small-to-medium-sized bodies of water—anything from a teacup to a small lake.

Large bodies of water, like an ocean, include swells, or wide, stable waves with no apparent slowdown. Even at the lowest

settings, Wave World cannot generate swells because the waves fade out relatively quickly.

Reflect Edges Specifies how waves bounce off the edges of the layer and back into the scene.

Pre-roll (seconds) Specifies when the waves start moving. By default, the effect starts with a still surface without

waves or ripples. Use this control to start the waves moving before the layer begins. The settings at the first frame of

the effect are applied to the layer during the Pre-roll.

Ground controls for the Wave World effect

The Ground controls specify the appearance of the ground layer.

Ground Specifies the layer that appears at the bottom of the water. If you use an animated layer for the ground, Wave

World samples only the first frame. Wave World determines the intersection of the water’s surface with the edge of

the ground, computes the waves bouncing off the shore, and properly adjusts the speed of the waves depending on

the depth. The ground surface is determined by the layer’s brightness: White represents higher elevation, and black

represents lower elevation.

Steepness Adjusts the steepness of the ground by expanding and contracting the height of the displaced wireframe.

The mesh is locked at the black level, so it always grows up from the bottom—in other words, you cannot adjust the

bottom of a canyon to be deeper; you can only adjust the rim to be higher. To make the canyon deeper, combine a

higher Steepness setting with a lower Height setting.

Height Controls the distance between the water surface and the ground’s deepest possible point. Use this control to

make the body of water deeper or shallower. When you change the depth of the water, the waves behave accordingly:

They move faster in deep water and slower in shallow water. (Adjusting the Height control when using the wireframe

preview may appear to lower the ground level, but the wireframe camera always moves with the water level.)

Wave Strength Controls how big the resulting waves are when the ground height or steepness is animated. A value

of 0 results in no waves.

Note: You can create a pulsing wave effect by animating the ground’s steepness so that the ground pokes through the

water, producing waves. Then use the Wave Strength control to intensify the effect.

Producer 1 and Producer 2 controls for the Wave World effect

The Producer controls specify the point at which the waves begin.

Type Specifies the type of producer. Ring creates a wave as if a stone were dropped into a pond; waves radiate

outward in circles (or ovals, depending on the size settings of the effect point). Line creates waves that emanate from

the producer’s position in a line instead of an oval. This is useful for creating waves that look as though they were

generated from much farther away. The waves are produced perpendicular to the edges of the line. The length of the

line is based on the Height/Length setting.

Position Specifies the location of the center of the wave producer.

Height/Length Specifies the (vertical) height of a Ring producer and adjusts the length of a Line producer.

Width Specifies the (horizontal) width of the producer area.
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Angle Specifies the angle of the wave producer area for the Line and Ring types. This control sets the orientation of

the line and thus controls the initial direction of the waves, which emanate from either side of the line, perpendicular

to its length.

Amplitude Controls the height of the produced wave. Higher values create more dramatic waves but may result in

clipping, which you can repair by using the Brightness and Contrast controls.

Frequency Controls how many waves are produced per second. A value of 1 has the effect of waves surfacing once

every second.

Phase Specifies where in the wave phase the wave actually begins. For example, with the default setting of 0˚, the

first disturbance in the liquid is a convex wave (projecting upward from the surface of the water). With Phase set to

180˚, the first disturbance in the liquid is a concave wave.

Stylize effects

Brush Strokes effect
The Brush Strokes effect applies a rough painted look to an image. You can also use this effect to achieve a pointillist

style by setting the length of the brush strokes to 0 and increasing the stroke density. Although you specify the

direction of strokes, they are scattered randomly by a small amount to give a more natural effect. This effect alters

the alpha channel, as well as the color channels; if you have masked out a portion of the image, the brush strokes

paint over the edges of the mask.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for the Brush Strokes effect:

Stroke Angle Specifies the direction in which the strokes are made. The image is effectively shifted in this direction,

which may cause some clipping at the layer boundaries. To avoid this, place the layer you want to brush into a larger

composition, and then apply the Brush Strokes effect to the composition.

Brush Size Specifies the size of the brush in pixels.

Stroke Length Indicates the maximum length of each stroke, in pixels. If Stroke Randomness is not 0, the actual

length of any given stroke may be slightly less than this maximum length.

Stroke Density Higher densities result in overlapping brush strokes and interesting visual effects.

Stroke Randomness Creates non-uniform strokes. The more randomness, the more the strokes vary from the brush

and stroke settings you’ve specified.

Paint Surface Specifies where brush strokes are applied. Paint on Original Image puts the strokes on top of the

unmodified layer. This is the default setting. Paint on Transparent causes only the strokes themselves to appear,
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leaving the layer transparent between the strokes. Paint on White and Paint on Black let you apply your strokes over

a white or black background.

Blend With Original Specifies the percentage of effect applied—the higher you set this value, the more of the original

layer you can see in the background. For example, if you set this value to 50%, 50% of the original layer shows

through the effect; if you set this value to 100%, the effect has no affect on the layer. If you want to create an affect of

a rainstorm, set this value to about 50%.

Color Emboss effect
The Color Emboss effect works like the Emboss effect, without suppressing the image’s original colors.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Emboss effect
The Emboss effect sharpens the edges of objects in the image and suppresses colors. The effect also highlights the

edges from a specified angle. The layer’s quality setting influences the Emboss effect by controlling the Relief setting.

Relief is calculated at the subpixel level in Best quality and rounded off to the pixel level in Draft quality.

The Direction control specifies the apparent direction from which the highlight source is shining, in degrees. A

setting of 45˚ causes the shadow to be cast from the northeast direction. Relief specifies the apparent height of the

embossing, in pixels. The Relief setting actually controls the maximum width of highlighted edges. Contrast specifies

the sharpness of the image content’s edges. At lower settings, only distinct edges show the effect. As you increase the

setting, the highlight becomes more extreme. Blend With Original specifies the total amount of effect applied to the

layer.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Find Edges effect
The Find Edges effect identifies the areas of the image that have significant transitions and emphasizes the edges.

Edges can appear as dark lines against a white background or colored lines against a black background. When the

Find Edges effect is applied, images often look like sketches or photographic negatives of the original.

The Invert option inverts the image after the edges are found. When selected, edges appear as bright lines on a black

background; when not selected, edges appear as dark lines on a white background. Blend With Original specifies the

total amount of effect applied to the layer.
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This effect works with 8-bpc color.

Original (left), and with effect applied (right)

Glow effect (Pro only)
The Glow effect finds the brighter parts of an image and then brightens those and surrounding pixels to create a

diffuse, glowing halo. The Glow effect can also simulate overexposure of brightly lit objects. You can base the glow

on either the original colors of the image or on its alpha channel. Glows based on alpha channels produce diffuse

brightness only at the edges of the image, between the opaque and transparent regions. You can also use the Glow

effect to create a gradient glow between two colors and to create multicolor effects with looping.

Rendering the Glow effect at Best quality can change the appearance of the layer. This is especially true if you are

using Adobe Photoshop arbitrary maps to color your glows. Be sure to preview your Glow effect at Best quality

before you render it.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for the Glow effect:

Glow Based On Specifies the properties on which you want to apply the glow.

Glow Threshold Sets a threshold as a percentage brightness to which the glow is not applied. A lower percentage

produces more glow; a higher percentage produces less.

Glow Radius Specifies the radius, in pixels, that the glow extends out from the bright areas of the image. Larger

values produce diffuse glows; smaller values produce glows with sharp edges.

Glow Intensity Sets the brightness of the glow. Higher values produce brighter glows.

Composite Original Specifies how to composite the effect with the layer. On Top places the glow on top of the image,

using the blending method selected for Glow Operation. Behind places the glow behind the image, creating a

backlighting effect. None separates the glow from the image.

To reduce the layer to the glow only, choose None for Composite Original and None for Glow Operation. To achieve

a glow effect for text that knocks out (blocks) all layers below it, choose Silhouette Alpha for Glow Operation. These

glow effects are more noticeable when the image has a feathered edge.

Glow Colors Specifies the colors that glow. A & B Colors creates a gradient glow using the colors specified by using

the Color A and Color B controls. Arbitrary Map creates a gradient glow using colors specified in an arbitrary map
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file created using the Curves dialog box in Adobe Photoshop. Selecting this option displays a standard Open dialog

box for locating the arbitrary map file. For information about arbitrary maps, see Photoshop Help.

Color Looping Specifies the beginning and ending colors for the glow, if A & B Colors is selected for Glow Colors.

The Sawtooth options begin with one color and end with the second color. The Triangle options begin with one color,

move to another, and then end with the first.

Color Loops Creates multicolor ringing in the glow, when you select two or more loops. A single loop cycles through

the gradient (or arbitrary map) specified for Glow Colors.

Color Phase Begins color loops at a specific point in the cycle. Specify a phase angle in the Color Phase control. By

default, color loops begin at the origin of the first loop.

A & B Midpoint Specifies the midpoint of the gradient if you’ve selected A & B Colors for Glow Colors. The midpoint

specifies the balance between the two colors used in the gradient. Lower percentages use less of the A color. Higher

percentages use less of the B color.

Color A, Color B Specify the colors that glow. You can choose to use these colors by choosing them from the Glow

Colors menu.

Glow Dimensions Specifies whether the glow is horizontal, vertical, or both.

To apply a basic glow using original colors (Pro only)

1 Select the layer, and choose Effect > Stylize > Glow.

2 In the Effect Controls panel, choose Glow Based On > Color Channels.

3 Adjust the Glow controls as desired.

4 For Composite Original, choose On Top.

5 For Glow Operation, choose Add.

6 For Glow Colors, choose Original Colors.

To apply a basic glow based on the alpha channel (Pro only)

1 Select the layer, and choose Effect > Stylize > Glow.

2 In the Effect Controls panel, choose Glow Colors > A & B Colors.

3 For Glow Based On, choose Alpha Channel.

4 Choose an option for Composite Original.

Mosaic effect
The Mosaic effect fills a layer with solid color rectangles. It is useful for simulating low-resolution displays and for

obscuring faces. You can also animate it for a transition. At Best quality, the edges of the mosaic are anti-aliased.

The Horizontal/Vertical Blocks options specify the number of mosaic divisions in each direction. Use the Sharp

Colors option to give each tile the color of the pixel in its center in the unaffected layer; otherwise, the tiles are

colored with the average color of the corresponding region in the unaffected layer.

This effect works with 8-bpc and 16-bpc color.
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Original (left), and with effect applied (right)

Motion Tile effect
The Motion Tile effect replicates the source image across the output image. It is called Motion Tile because, when

changing the placement of the tiles, it uses motion blur to accentuate the movement if motion blur is enabled. Tile

Center controls the position of the main tile.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for the Motion Tile effect:

Tile Center Specifies the area on the layer that becomes the center of the tile.

Tile Width, Tile Height Specify the size of the tiles as a percentage of the input.

Output Width, Output Height Specify the size of the output image, or modified layer, as a percentage of the input.

Mirror Edges When Phase is set to 0, selecting this causes the edges of the layer to be mirrored with the surrounding

tiles.

Phase Controls the horizontal or vertical shift of the tiles that are adjacent to the main tile.

Horizontal Phase Shift Applies horizontal shifting to the tiles instead of vertical shifting.

Posterize effect
The Posterize effect lets you specify the number of tonal levels (or brightness values) for each channel in an image.

Posterize then maps pixels to the closest matching level. For example, choosing two tonal levels in an RGB image

gives you two tones for red, two tones for green, and two tones for blue. Values range from 2 to 255. Although the

results of this effect are most evident when you reduce the number of gray levels in a grayscale image, Posterize also

produces interesting effects in color images.

Use Level to adjust the number of tonal levels for each channel to which Posterize will map existing colors.

This effect works with 8-bpc and 16-bpc color.
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Original (left), and with effect applied (right)

Roughen Edges effect
The Roughen Edges effect roughs up the edges of a layer’s alpha channel by using calculations. It gives rasterized text

or graphics a naturally rough look, like that of eroded metal or typewriter text.

This effect works with 8-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for the Roughen Edges effect:

Edge Type Specifies how the effect is applied to the alpha channel. If you choose an option that uses color, such as

Photocopy Color, specify the color using the Edge Color control.

Edge Color Fills the effect areas with this color when you choose an Edge Type that uses color, such as Roughen

Color.

Border Specifies how far from an alpha channel edge the effect extends.

Edge Sharpness Specifies how sharp or soft the roughened edge appears. Low values create softer edges, and high

values create sharper edges.

Fractal Influence Specifies how much of the introduced roughness is influenced by fractal calculations.

Scale Specifies the scale of the fractal used to calculate the roughness.

Stretch Width or Height Specifies the width or height of the fractal used to calculate the roughness.

Offset (Turbulence) Specifies the portion of the fractal shape that is present in the Composition panel, altering the

shape of the distortion or roughness applied to your layer. Because the fractal shapes generated by this effect are

infinite in all directions, the result that appears on the layer is only a small portion of the entire fractal. Animating

the Offset control repositions the fractal, bringing a different portion of it into view. This alters the shape and texture

of the roughness.

Complexity Specifies the level of detail in the roughness. Higher Complexity values increase the detailed definition

in the texture of the roughness. Lower Complexity values reduce the definition.

Note: Increasing complexity results in longer rendering times. Reduce the Scale value rather than increasing Complexity

to achieve similar results.
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Evolution controls for the Roughen Edges effect

You can adjust the following Evolution controls:

Evolution Creates subtle changes in the shape of the roughness. Animating this setting results in smooth changes or

evolution of the roughness over time. Set keyframes for Evolution to determine how much the roughness will evolve

over the period of time between keyframes. The more revolutions in a given amount of time, the more rapidly the

roughness changes. Higher Evolution values may result in less smooth changes in the roughness.

Note: Although the Evolution value is set in units called revolutions, it is important to realize that these revolutions are

progressive. The Evolution state continues to progress infinitely at each new value. Use the Cycle Evolution option

(explained below) to return the Evolution setting to its original state at each revolution.

Evolution Options Evolution Options provide controls that render the effect for one short cycle and then loop it for

the duration of your project. Use these controls to prerender your roughen elements into loops, and thus speed up

rendering time. Use the following controls to create a smooth, progressive, nonrepeating loop:

• Cycle Evolution Creates a loop that forces the evolution state to return to its starting point.

• Cycle (available only when you select Cycle Evolution) Specifies the number of revolutions (of the Evolution

setting) that the fractal noise cycles through before it repeats. For example, if you set the evolution to occur over five

revolutions and you set the Cycle value to 2, then the evolution loops twice. The timing or speed of these Evolution

cycles is determined by the amount of time allowed between Evolution keyframes.

Note: The Cycle control affects only the state of the fractal, not geometrics or other controls. For example, two identical

states of the fractal will not appear the same if viewed with different Size or Offset settings.

• Random Seed Specifies a unique random value from which to generate the roughness texture. Animating this

property results in flashing from one set of fractal shapes to another within the same fractal type. For smooth

transition of the roughness, use the Evolution control.

Note: Create new roughness animations by re-using previously created Evolution cycles and changing only the Random

Seed value. Typing a new Random Seed value alters the noise pattern without disturbing the evolution animation.

Scatter effect (Pro only)
The Scatter effect scatters the pixels in a layer, creating a blurry or smeared appearance. Without changing the color

of each individual pixel, the Scatter effect redistributes the pixels randomly, but in the same general area as their

original positions. You can automatically animate the Scatter effect over the time range without keyframes by

randomizing every frame.

This effect works with 8-bpc and 16-bpc color.

Original (left), and with effect applied (right)

Adjust the following controls for the Scatter effect:

Scatter Amount Specifies the amount of scattering. Higher values produce more blur.

Grain Specifies the direction in which to scatter the pixels—horizontally or vertically. Select None to scatter pixels

in all directions.
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Scatter Randomness Specifies whether scattering changes at each frame. To animate scattering without keyframes,

select the Randomize Every Frame option. If this option is not selected, scattering remains the same at each frame

unless keyframes are created for the Scatter Amount and Grain properties.

Strobe Light effect
The Strobe Light effect performs an arithmetic operation on a layer at periodic or random intervals. For example,

every five seconds the layer could appear completely white for one-tenth of a second, or a layer’s colors could invert

at random intervals. The layer’s quality setting does not affect Strobe Light.

This effect works with 8-bpc color.

Adjust the following controls for the Strobe Light effect:

Strobe Color Specifies the color of the light.

Blend With Original Specifies the percentage of the entire effect that is applied to the layer.

Strobe Duration Specifies in seconds how long a strobe effect lasts.

Strobe Period Specifies in seconds the duration between the start of subsequent strobes. For example, if the Strobe

Duration is set to 0.1 second and the Strobe Period is set to 1.0 second, the layer will have the effect for 0.1 second

and then be without the effect for 0.9 seconds. If this value is set lower than the Strobe Duration, the strobe effect is

constant.

Random Strobe Probability Specifies the probability that any given frame of the layer will have the strobe effect,

giving the appearance of a random effect.

Strobe Specifies how the effect is applied. Operates on Color Only performs the strobe operation on all color

channels. Make Layer Transparent makes the layer transparent when a strobe effect occurs.

Strobe Operator Specifies the arithmetic operator to use when Operates on Color Only is selected from the Strobe

menu. The default setting is Copy.

Texturize effect
The Texturize effect gives a layer the appearance of having the texture of another layer. For example, you could make

the image of a tree appear as if it had the texture of bricks, and control the depth of the texture and the apparent light

source. At Best quality, the texture layer is positioned and scaled with subpixel accuracy.

This effect works with 8-bpc color.

Original layers (left and center) and with center applied as the texture (right)

Adjust the following controls for the Texturize effect:

Texture Layer Specifies the layer you want to use as the texture.

Light Direction Specifies the angle at which light hits the texture. This setting affects where shadows appear.

Texture Contrast Specifies how distinct the texture appears on the effect layer.
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Texture Placement Specifies how the effect is applied. Tile Texture applies the texture repeatedly over the layer.

Center Texture positions the texture in the middle of the layer. Stretch Texture to Fit stretches the texture to the

dimensions of the selected layer.

Threshold effect
The Threshold effect lets you convert grayscale or color images to high-contrast, black-and-white images. Specify a

certain level as a threshold; all pixels lighter than the threshold are converted to white and all pixels darker to black.

This effect works with 8-bpc and 16-bpc color.

Effect applied with threshold settings of 44 (left), 70 (center), and 200 (right)

Text effects

Basic Text effect
Using the Basic Text effect, you can create text and text animation. You can specify font, style, and alignment of text,

as well as select horizontal or vertical text orientation. Animation is created by changing the Position point over time.

Basic Text also gives you the choice of either compositing the text over the layer image or using the text by itself. Best

quality creates anti-aliased text that animates smoothly.

This effect works with 8-bpc color.

Original (left) and after applying Basic Text (center) and selecting Composite On Original (right)

The Basic Text effect places text on an existing layer—unlike imported text created in Adobe Photoshop or Adobe

Illustrator, which becomes its own layer. This effect can be used for basic title text; for more flexibility in working

with text, import text created in an illustration or imaging program. The font you select when creating text must be

available on the system you use to render the composition. If the font is not available, an available font is substituted.

After Effects creates an alpha channel for text it creates. You can use a text effect’s alpha channel with features such

as track matte.

Note:The width and height of text are not constrained by the dimensions of the layer; the layer dimensions merely define

the visible region of the text. This feature makes it simple to scroll text over a layer.
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The following options and values are available in the Basic Text dialog box, which opens automatically when you

apply the effect: Font, Style, Direction, Alignment, and Show Font. To edit the text after you close this dialog box,

click Edit Text in the Effect Controls panel. Adjust the following controls after you close the Basic Text dialog box:

Position Specifies the position of the text in the composition.

Note: The behavior of the Position point is affected by the Alignment setting in the Basic Text dialog box. The point

always positions the vertical center of the text relative to the layer. However, if the text is left-aligned, the point positions

the left edge; if the text is center-aligned, the point positions the center; and if the text is right-aligned, the point positions

the right edge.

Fill and Stroke Specifies the color and width of the text. Display Options specifies the use of a fill or stroke or a

combination of both on the text. Fill Only fills the characters with a color. Stroke Only strokes the edges of the

characters with a color. Fill Over Stroke overlaps the fill color onto the stroke color. Stroke Over Fill overlaps the

stroke color onto the fill color. Fill Color specifies the color you want to use to fill the characters. Stroke Color

specifies the color you want to use to outline the characters. Stroke Width specifies the size of the outline around

each character.

Size Specifies the size of the characters.

Tracking Specifies the average distance between characters.

Line Spacing Specifies the space between lines of characters.

Composite On Original Specifies that the text is composited on the layer to which the effect is applied. When

Composite On Original is not selected, the layer is not visible.

Numbers effect
The Numbers effect generates random and sequential numbers in different formats. You can use it to display random

times and dates or timecodes, or to print the current date and time on a layer whenever it’s rendered.

Note: Leap years are taken into consideration. Note that on some Mac OS systems, the clock starts on January 1, 1904,

and does not go beyond February 6, 2040.

This effect works with 8-bpc color.

Original (left); after applying the Numbers effect (center); and after setting Type to Numbers, Time, and Hexadecimal on three different layers
(right)

The following options and values are available in the Font Style dialog box: Font, Style, Direction, and Alignment.

To open this dialog box again, click Edit Text at the top of the Effect Controls panel.

Format controls for the Numbers effect

Adjust the following format controls for the Numbers effect after you close the Font Style dialog box:

Type Specifies the type of numeric string used, such as time, timecode, date, or hexadecimal.

• Number Specifies a decimal number. If you select Random and Number, the number is bounded by 0 and the

slider value.
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• Number [Leading Zeros] Specifies a decimal number with 5 digits to the left of the decimal place at all times.

• Timecode [30], Timecode [25], and Timecode [24] Specify the standard timecode formats (XX:XX:XX:XX) using

the stated frame rate. The timecode types use the layer’s current time.

• Time Specifies the number of minutes since midnight. If you also select Current Time/Date, the

Value/Offset/Random Max value is ignored. If you select Random, the time is bounded by 0 (12:00 AM) and the

slider value.

• Numerical Date, Short Date, and Long Date Specify the date and are determined by other Number settings. If you

do not also select Current Time/Date, the Value/Offset/Random Max is the number of days since January 1, 1995 (0

on the slider corresponds to January 1, 1995). If you do select Current Time/Date, Value/Offset/Random Max is the

number of days since the current date (0 on the slider corresponds to the current date). If you select Random, the

date is bounded by 0 (either the current date or January 1, 1995) and the slider value. If you use more than one system

to render a composition that uses the date or time types, make sure that the format specified in the Date & Time

system control is the same on all systems.

• Hexadecimal Is a base-16 value (digits from 0 to F). Hexadecimal corresponds to the Value/Offset/Random Max

value displayed. It increments by 0x1 for every 0.0000125 that the slider increases, and increments by 0x10000 for

every 1.0 that the slider increases. If you select Random, the number is bounded by 0 and the slider value.

Random Values Generates random values limited by the Value/Offset/Random Max setting. If

Value/Offset/Random Max is 0, values are random across their maximum possible range.

Value/Offset/Random Max Varies based on the chosen type and whether or not Random Values is selected.

Decimal Places Specifies the number of places to the right of the decimal point.

Current Time/Date Specifies whether you will enter a specific time and date (not selected) or whether After Effects

will enter the current time and date (selected).

Fill and Stroke controls for the Numbers effect

Fill and Stroke controls specify the color and width of the text.

Position Specifies the position of the numbers in the composition.

Display Options Specifies the use of a fill or stroke or a combination of both on the text. Fill Only fills the characters

with a color. Stroke Only strokes the edges of the characters with a color. Fill Over Stroke overlaps the fill color onto

the stroke color. Stroke Over Fill overlaps the stroke color onto the fill color.

Fill Color Specifies the color you want to use to fill the characters.

Stroke Color Specifies the color you want to use to outline the characters.

Stroke Width Specifies the size of the outline around each character.

Size and Tracking controls for the Numbers effect
Size Specifies the size of the characters.

Tracking Specifies the average distance between characters.

Proportional Spacing Specifies that numbers use proportional spacing instead of monospacing.

Composite on Original Specifies that the text is composited on the layer to which the effect is applied. When

Composite on Original is not selected, the layer is not visible.
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Path Text effect
The Path Text effect lets you animate text along a path. You can define a path as a straight line, a circle of any

diameter, or a Bezier curve. You can also import a path created in another application, such as Adobe Photoshop or

Adobe Illustrator. The Path Text effect works with nonsquare pixels, adjusting both character shape and path shape

accordingly.

This effect works with 8-bpc color.

Original (left), after Path Text effect is applied (center), and with Shape Type set to Bezier and Baseline Jitter and Scale Jitter values increased
(right)

You can animate text on an existing layer or, for additional control over placement of text, create a solid and animate

the text on it. The layer on which you animate text is transparent, unless you specify compositing. To modify and

animate text, type the text using a specified font, define the path, and then create keyframes for the text properties

you want to change over time. To move text along a path, create keyframes for the left margin or right margin. To

change the text after closing the Path Text dialog box, click Edit Text in the Effect Controls panel.

Note: If you are using Adobe Type Manager (ATM) and large text looks blocky or does not otherwise render properly,

increase the Character Cache Size in the ATM control column.

Animating text with Text effects

When changing the shape of a Bezier path over time, make sure to create initial keyframes for all four path control

points; moving a control point without an initial keyframe does not move it over time. You may find it easier to

animate a path by modifying the motion paths of individual control points in the Layer panel.

Note: Handles appear in the Composition panel only if the effect is selected in the Effect Controls panel and if you are

not animating text along a mask or path.

If you want to move a Bezier path across the composition but you don’t want to change its shape, animate the layer

rather than the path. If you want to stretch, shrink, or wag one side of the Bezier path while keeping the other half

in the same position, move a tangent-vertex pair together. To do this, create keyframes for both by dragging the outer

circle of the appropriate vertex.

Note: When animating the control points of a Bezier path, don’t confuse the Bezier path shape with the Bezier spatial

interpolation of the keyframes. Like keyframes for other position controls, those for the vertex or tangent of a Bezier path

can be set to either linear or Bezier. The default spatial interpolation is specified in General Preferences. Spatial interpo-

lation can be selected for individual keyframes by choosing Animation > Keyframe Interpolation.

You can apply motion blur to motion that you create with the Path Text effect. Blurring occurs on each character.

Like motion blur for layers, blurring for characters is more visible when movement is quick. For example, blurring

is quite pronounced when you choose negative jitter values, which produce jumpy motion.
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Path Options controls for the Path Text effect

You can adjust the following Path Options controls to specify the shape of the path:

Shape Type Defines the shape of the path. The Path Text effect name must be selected in the Effect Controls panel

to make the path visible in the Composition panel.

• Bezier Shapes text along a Bezier curve, defined by four control points (Vertex 1/Circle Center, Tangent 1/Circle

Point, Tangent 2, and Vertex 2). Characters that don’t fit on the path are placed off the end in a straight line.

• Circle Shapes text around the circumference of a circle, defined by two control points (Tangent 1/Circle Point, and

Vertex 1/Circle Center). If the text is longer than the circumference of the circle, the text overlaps itself. If an arbitrary

path is chosen and if the path is closed, this property forms the text around the path, as opposed to looping it.

• Loop Shapes text around the circumference of the circle, defined by two control points (Vertex 1/Circle Center,

and Tangent 1/Circle Point). If text is longer than the circumference of the circle, it flows off the Tangent 1 point in

a straight line. You can also use margin controls to make text enter or exit a circle in a straight line.

• Line Shapes text in a straight line, defined by two control points (Vertex 1/Circle Center, and Vertex 2). Note that,

as with the Bezier path, the distance between the two control points does not affect the spacing of the text, unless

alignment is set to Force. (See “Paragraph controls for the Path Text effect” on page 536.)

Control Points Specify the points on the path.

• Tangent 1/Circle Point Specifies the following points: starting tangent for a Bezier curve, diameter of a circle and

starting or ending point of text (depending on specified alignment), and diameter of a loop and the point where text

enters.

• Vertex 1/Circle Center Specifies the starting vertex for a Bezier curve, center of a circle or loop, and starting or

ending point for text on a line (depending on specified alignment).

• Tangent 2 Specifies the ending tangent of the Bezier curve. The line between Tangent 2 and Vertex 2 specifies the

slope of the curve at its ending point. For circles or loops, Tangent 2 is ignored.

• Vertex 2 Specifies the ending vertex of a Bezier curve and the angle of a line. For circles or loops, Vertex 2 is

ignored.

Custom Path Specifies an arbitrary path. You can use a mask created in the Layer panel or in Adobe Illustrator.

Reverse Path Reverses the path.

Fill and Stroke controls for the Path Text effect

You can adjust the following Fill and Stroke controls to specify the color and width of the text:

Options Specifies the use of a fill or stroke or a combination of both on the text. Fill Only fills the characters with a

color. Stroke Only strokes the edges of the characters with a color. Fill Over Stroke overlaps the fill color onto the

stroke color. Stroke Over Fill overlaps the stroke color onto the fill color.

Fill Color Specifies the color you want to use to fill the characters.

Stroke Color Specifies the color you want to use to outline the characters.

Stroke Width Specifies the size of the outline around each character.

Character controls for the Path Text effect

You can specify the size and kerning of letters by using the following controls:

Size Specifies the size of the characters.

Tracking Specifies the average distance between characters.
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Kerning Controls the horizontal distance between two characters. If you change the text, specified kerning is

preserved for all unchanged character pairs. You cannot use the Undo command to undo kerning changes. To change

horizontal spacing between characters over time, use Kerning Jitter Max or create keyframes for Tracking. (See

“Advanced controls for the Path Text effect” on page 537.)

• Kerning Pair Specifies the pair of character you want to kern. Click the arrow to move among the pairs.

• Kerning Value Specifies the amount of kerning you want to apply to the specified pair.

Orientation Specifies the orientation or rotation values of each character.

• Character Rotation Specifies the rotation of all characters. Each character is rotated by the specified number of

degrees from its current angle. The center of rotation is on the point where the character intersects the path. Note

that Perpendicular to Path changes the initial angle of the characters.

• Perpendicular To Path Rotates each character so that it is perpendicular to the path. If Perpendicular to Path is

deselected, characters always remain upright (unless rotated by Character Rotation).

• Vertical Writing Rotates each character so it is vertical along the path.

• Rotate Roman Characters Rotates Roman characters vertically along the path; when Rotate Roman Characters is

deselected, only non-Roman characters are rotated.

Horizontal Shear Slants characters left or right, similar to italics. The slant is based on the point where the character

intersects the path. To slant characters from their centers, set Baseline Shift to make the path go through the centers

of the characters.

Horizontal Scale, Vertical Scale Resize the characters by the specified percentage in the horizontal and vertical direc-

tions. Text is scaled from the initial rasterization size, specified for Size. Setting the scaling percentage greater than

100 may result in blurred edges. For best results, set Size to a point size that does not require scaling beyond 100%

to achieve the largest desired text size. For example, to increase the size text from 48 to 88 points, set Size at 88 and

specify a starting value for both Vertical and Horizontal Scale at 55%; then increase both scale values to 100% when

you want the text displayed at 88 points.

Paragraph controls for the Path Text effect

You can specify the alignment and appearance of the paragraph using the following controls:

Alignment Specifies the horizontal alignment of the text on the specified path.

• Left Places the first character at the position specified by Left Margin; all other characters are drawn relative to it.

Right Margin is ignored.

• Right Places the last character at the position specified by Right Margin; all other characters are drawn relative to

it. Left Margin is ignored.

• Center Centers the text between Left Margin and Right Margin.

• Force Places the first character at the position specified by Left Margin and the last character at the position

specified by Right Margin, spacing all other characters evenly between. Tracking is ignored.

Left Margin, Right Margin Specify the margins. Left Margin specifies the position of the first character in pixels,

relative to the starting point; Right Margin specifies the position of the last character, relative to the ending point. In

path shapes, the starting point for Bezier curves and lines is Vertex 1, and the starting point for circles and loops is

Tangent 1. The ending point for Bezier curves and lines is Vertex 2, and the ending point for circles and loops is

Tangent 1. To move text across the path shape that you’ve defined, create keyframes for the Left or Right margins

(depending on the specified alignment). Positive values move the text to the right; negative values move it to the left.

Line Spacing Specifies the space between lines of characters.
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Baseline Shift Specifies the distance in pixels between the path and the bottom of the characters. Depending on the

path shape, text may appear to be better spaced when the path passes through the centers of the characters. To do

this, set Baseline Shift to a negative value so that the centers of characters lie on the path.

Advanced controls for the Path Text effect

Use the following controls to specify the appearance of the characters:

Visible Characters Specifies the number of characters that appear at the current time. By creating keyframes, you can

use Visible Characters to display one or more characters at a time to create the appearance of typing characters.

Positive values specify the number of visible characters from the beginning of the text to the end. Negative values

specify the number of visible characters from the end of the text to the beginning. Remember that spaces are

characters, too.

You can also use this control with Fade Time to fade in characters. When Fade Time is 0, the next character appears

when the value of Visible Characters is halfway to the next whole number. For example, the second character appears

when the value of Visible Characters is 1.5, the third character appears when the value is 2.5, and so on. A Fade Time

value of 0 produces the appearance of typing characters. For other Fade Time values, see Fade Time.

Note: Visible Characters does not alter the positions of characters defined by the path and other controls.

Fade Time Specifies a range of time over which a particular character is partially visible. Fade Time works in

conjunction with Visible Characters. When Fade Time is 0, each letter appears fully opaque at the appropriate Visible

Characters value. When Fade Time is 100%, a particular character is displayed with greater and greater opacity as

the value of Visible Characters increases between whole numbers. The exact opacity of the character is equal to the

fractional part of the Visible Characters value. For example, the eighth character is displayed at 10% opacity when

the value of Visible Characters is 7.10 and Fade Time is 100%; the same character is displayed at 60% opacity when

the value of Visible Characters is 7.60, and so on.

For Fade Time values between 0 and 100%, the opacity of the character is defined as a range across the halfway point

between whole-number values of Visible Characters. For example, when Fade Time is 20%, the eighth character

begins to appear at a Visible Character value of 7.40 and is fully opaque at 7.60. If Fade Time is set to 60%, the same

character begins to appear at a value of 7.20 and is fully opaque at 7.80.

Mode Specifies the transfer mode used when characters overlap each other. The specified mode is applied only to

the parts of characters that overlap. When Mode is set to Difference, overlapping parts of characters appear in black.

When Mode is set to Normal, overlapping parts appear in the specified Text color.

Jitter Settings Specify maximum amount of deviation added randomly to baseline, kerning, rotation, or scale.

Higher values produce greater deviations. Positive values produce smooth motion; negative values produce jumpy

motion. Movement is created without keyframes, although you can use keyframes to change the maximum values.

A specific jitter value generates the same seemingly random motion for identical text and settings. If your compo-

sition contains duplicate animated text, you can generate different motion for each instance of the text by changing

a setting but making the change invisible. For example, you could add a space to a second instance of text, and then

adjust the kerning so that the space is not visible. This creates an invisible change that will generate different motion.

You can specify the following Jitter options:

• Baseline Jitter Max Sets a maximum distance, in pixels, that characters are randomly moved above or below the

path after Baseline Shift is applied.

• Kerning Jitter Max Sets a maximum distance, in pixels, that characters are randomly moved apart from one

another along the horizontal axis after kerning and tracking are applied.
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• Rotation Jitter Max Sets a maximum amount, in degrees, that characters are randomly rotated after Character

Rotation is applied.

• Scale Jitter Max Sets a maximum amount, as a percentage, that characters are randomly scaled after Horizontal

Scale and Vertical Scale are applied. For best results, characters should not scale greater than 100%.

To animate path text with the Path Text effect

1 In the Timeline panel, select the layer that has the Path Text effect applied. Display the properties for Path Text,

and expand the controls under Path Options and Control Points.

2 Move the current-time indicator to a point where you want to add a keyframe.

3 Adjust the path control points so that the text is displayed as desired.

4 Repeat steps 2 and 3 until you have created the keyframes needed to animate the text.

5 Click the stopwatch next to the control points or other properties for which you will create keyframes.

Note: Path text is animated primarily on the location of the path control points. Text moves with the position of these

points or on a closed path that can be selected from the Path Control Points control. You can also animate text by creating

keyframes for margin, kerning, tracking, and size.

To specify the location of vertices and tangents

❖ Do one of the following:

• Drag the points in the Composition or Layer panel. Dragging the outer circle of a point dynamically updates the

shape of the curve in the Composition panel. To constrain the point to its current vertical or horizontal coordinate,

press Shift while dragging its cross hair.

• Click the cross hair for the point in the Effect Controls panel, and then click in the Composition panel.

• Click the coordinates for the point in the Effect Controls panel, and then specify new coordinates.

Note: If you have animated the position of one or more points over time, you can modify their individual motion paths

in the Layer panel when you select Path Text in the Layer panel menu.

To move vertices, circle centers, and tangents

• To move the Vertex 1/Circle Center and the Tangent 1/Circle Point together, drag the outer circle of the Vertex

1/Circle Center.

• To move only the Vertex 1/Circle Center, drag its cross hair

• To automatically snap the Tangent 1/Circle Point on top of the Vertex 1/Circle Center, select the Pen tool and then

click the outer circle of Tangent 1 (Windows) or Command-click the outer circle (not the cross hair) of Tangent 1

(Mac OS).

• To snap the Tangent 1/Circle Point to increments of 45 degrees from the Vertex 1/Circle Center, Shift-drag the

outer circle of Tangent 1.

• To move Vertex 2 and Tangent 2 together, drag the outer circle of Vertex 2.

• To move only Vertex 2, drag its cross hair.

Timecode effect
The Timecode effect displays timecode or frame number information within a layer. You can render movies

containing visible timecode. This effect cannot modify timecode embedded from external sources, such as

QuickTime.
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This effect works with 8-bpc color.

Original (left), with SMPTE HH:MM:SS:FF timecode applied (center), and with Feet + Frames (35mm) timecode applied (right)

You can adjust the following controls for the Timecode effect:

Display Format Specifies whether timecode is displayed in the SMPTE format of HH:MM:SS:FF, in frame numbers,

in Feet + Frames (35mm), or Feet + Frames (16mm).

Time Units Use Time Units to mark each frame of a layer for variable composition frame rates. The Time Units

control determines the frame rate in frames per second (fps) for a specific layer in the composition. For example, a

value of 60 changes the timecode for a specific layer to match the composition’s 60-fps rate. This control affects how

After Effects counts the layer’s frames, not how the footage plays.

Drop Frame Select Drop Frame to calculate drop frame timecode or deselect it to calculate nondrop frame timecode.

Starting Frame Specifies the timecode count at the beginning of the layer. You can set the Starting Frame slider to

correspond to the layer’s In point or, if you combine a layer with another composition and need to match the

timecode at a frame other than the In point, you can set the Starting Frame accordingly.

Text Position Specifies the position of the timecode.

Text Size Specifies the size of text.

Text Color Specifies the text color.

Time effects

Echo effect
The Echo effect combines frames from many different times in a layer. It has a variety of uses, from a simple visual

echo to streaking and smearing effects. This effect is visible only when there is change across time in the layer, such

as motion. By default, a layer’s mask and any previously applied effects are ignored when you apply the Echo effect.

If you do not want them ignored, precompose the layer with other effects before applying the Echo effect. This

creates a new composition with the mask already applied. Whenever Echo needs to retrieve a frame, it can do so from

that composition.

This effect works with 8-bpc and 16-bpc color.

Echo effect
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Adjust the following controls for the Echo effect:

Echo Time (seconds) Specifies the time, in seconds, between echoes. Negative values seek backward in time; positive

values echo forward in time.

Number of Echoes Specifies the number of frames to combine for the Echo effect. For example, if two echoes are

specified, Echo makes a new image out of (current time), (current time + Echo Time), and (current time + 2 * Echo

Time).

Starting Intensity Specifies the intensity of the starting frame in the echo sequence. For example, if this is set to 1,

the first frame is combined at its full intensity. If this is set to 0.5, the first frame is combined at half intensity.

Decay Specifies the ratio of intensities of subsequent echoes. For example, if the decay is set to 0.5, the first echo will

be half the strength of the Starting Intensity. The second echo will then be half that, or 0.25 times the Starting

Intensity.

Echo Operator Specifies the operations to be performed between the echoes. Add combines the echoes by adding

their pixel values. If the starting intensity is too high, this mode can quickly overload and produce streaks of white.

Maximum combines the echoes by taking the maximum pixel value from all the echoes. Minimum combines the

echoes by taking the minimum pixel value from all the echoes. Screen emulates combining the echoes by

sandwiching them optically. This is similar to Add, but it will not overload as quickly. Composite in Back uses the

echoes’ alpha channels to composite them back to front. Composite in Front uses the echoes’ alpha channels to

composite them front to back. Blend averages the echoes together evenly.

To incorporate layer motion into the Echo effect

1 Set up your motion before applying the Echo effect.

2 Precompose the layer with any additional effects. This creates a new composition containing only that layer and

its motion keyframes.

3 Choose Effect > Time > Echo.

Note: Use a large Number of Echoes and a short Echo Time to get smooth streaking and smooth trail effects.

4 Set controls as needed.

To create an image trail using the Echo effect

1 Choose File > Import > File, select the source footage file, and then click OK.

2 Drag the source footage from the Project panel into the Composition panel.

3 Highlight the source footage layer in the Timeline panel, and create a motion path using position keyframes.

4 Highlight the source footage layer in the Timeline panel, and choose Layer > Pre-compose.

5 Type a name for the precomposed composition in the Pre-compose dialog box, select Move All Attributes into the

New Composition, and then click OK.

6 Select the name of the precomposed composition in the Timeline panel.

7 Choose Effect > Time > Echo.

8 Change the effect controls to these values:

• Echo Time: –0.10

• Number of Echoes: 10

• Starting intensity: 1.00

• Decay: 0.68
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• Echo Operator: Composite in Front

9 Press the spacebar to preview the trail effect, use RAM Preview for a quicker preview, or render the composition

to view the effect in real time.

Posterize Time effect
The Posterize Time effect locks a layer to a specific frame rate. It is useful on its own as a special effect, but it also has

more subtle uses. For example, 60-field-per-second video footage can be locked to 24 fps (and then field rendered at

60 fps) to give a film-like look. Also, nested compositions can be locked to a given frame rate. This effect is sometimes

called Strobe in hardware devices.

A layer’s mask and any previously applied effects are ignored when the Posterize Time effect is applied. To posterize

the time of a masked layer, create the mask in another composition or precompose the layer with other effects before

applying the Posterize Time effect.

Animating the value of the Frame Rate slider can give unpredictable results. For this reason, the only interpolation

of the frame rate allowed is Hold.

This effect works with 8-bpc and 16-bpc color.

Posterize Time effect

Time Difference effect
The Time Difference effect calculates the color difference between two layers and is a useful aid in color correction;

use it to extract color differences when matching a clean background plate with foreground footage. It is also good

for creating mattes to be used to apply trails of smoke, fire, or echoing effects. Once you’ve applied Time Difference

to locate color differences in your footage, use color and levels controls to apply the color corrections.

This effect works with 8-bpc color.

Time Difference effect

Use Time Difference with Particle Playground to shed particles only from moving sections.

Adjust the following controls for the Time Difference effect:

Target Specifies the layer to be compared to the effect layer. The comparison layer’s video does not need to be on

(unless you select the source layer as the Target).
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Time Offset Specifies the point in time in the comparison layer, in seconds, where the layers are compared. If this

control is set to 0.00, the comparison occurs at the current time. To compare the effect layer to a point 3 seconds into

the comparison layer, for example, change the Time Offset value to 3. When you select the underlined offset value,

you can type the specific frame offset value in the format frames/framerate. After Effects automatically calculates the

value. For example, type 3/30 to offset three frames forward in a 30-fps composition. The calculated value is 0.1, or

10% of the total time.

Contrast Adjusts the comparison result. This control can be especially helpful in fine-tuning color corrections.

Absolute Difference Displays the result of the comparison as an absolute value. Any area of the comparison layer

that is not different from the effect layer is represented by black, and any amount of difference is represented as

brighter than black. When this option is unselected, compared areas with no difference are represented as gray.

Alpha Channel Specifies how the alpha channel is calculated.

• Original Uses the effect layer’s alpha channel.

• Target Uses the target layer’s alpha channel.

• Blend Blends the effect and target layers’ alpha channels.

• Max Uses the most opaque of the original source and Target layers’ alpha channels.

• Full On Sets the alpha channel to completely opaque.

• Lightness Of Result Uses the lightness of the RGB difference as alpha.

• Max Of Result Uses the highest values of the RGB difference as alpha.

• Alpha Difference Calculates differences in the effect and target layers’ alpha channels the same way RGB

difference is calculated.

• Alpha Difference Only Calculates only the differences in the alpha channels. RGB is set to white.

Time Displacement effect (Pro only)
The Time Displacement effect distorts the image by shifting pixels across time, producing a wide variety of effects.

For example, the traditional slit-scan technique, which captures different stages of a moving image across time, can

be simulated using the Time Displacement effect.

This effect works with 8-bpc and 16-bpc color.

Time Displacement effect

Like the Displacement Map effect, the Time Displacement effect uses a displacement map, but it bases the movement

of pixels in the layer on luminance values in the map. Pixels in the layer that correspond to bright areas in the

displacement map are replaced by pixels in the same position but at a specified number of seconds forward in time.

Likewise, pixels in the layer that correspond to dark areas in the displacement map are replaced by pixels at a

specified number of seconds backward in time. You can use any layer as a displacement map, though using a

grayscale image lets you more easily see brightness levels and predict how pixels will be displaced.
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The Time Displacement effect automatically replaces pixels across time without keyframes. However, you can also

set keyframes for other controls to vary the effect over time.

To better understand how pixels are displaced in time, think of the displacement occurring in steps, as follows:

1 After Effects overlays the displacement map layer on top of the effect layer (the layer you are distorting). If the

dimensions of the displacement map are different from those of the effect layer, you can specify whether the map is

centered or stretched to fit.

2 You specify a maximum displacement amount, in seconds.

3 After Effect uses the luminance value of each pixel in the displacement map to calculate the displacement of the

corresponding pixel in the effect layer based on the maximum displacement amount.

In grayscale images, the luminance value range extends from 0 to 255, which is converted into a scale ranging from

-1 to 1. A luminance value of 0 produces maximum backward displacement, meaning that pixels at the current time

are replaced by pixels from a previous time. A luminance value of 255 produces maximum positive displacement,

meaning that pixels at the current time are replaced by those at a future time. A luminance value of 128 produces no

displacement. For other values in grayscale displacement maps, you can calculate the displacement amount, in

seconds, using the following equation:

Displacement amount in seconds = maximum_displacement_time * (2 * (luminance value – 128)/256)

4 After Effects displaces each pixel in the image by replacing a pixel in the image at the current time with the pixel

in the same position at another time. The other time is the displacement amount in seconds for the pixel, calculated

in step 3.

Suppose you specified 2 seconds as the maximum time displacement. After Effects finds the luminance value of each

pixel in the displacement map, and then replaces the corresponding pixels at the current time with pixels from

another time based on the maximum time of 2 seconds. A luminance value of 255 in the displacement map replaces

that pixel with the pixel 2 seconds ahead in the same position. A luminance value of 42 replaces that pixel with the

pixel 1.34 seconds behind in the same position.

Time Displacement controls (Pro only)
Time Displacement Layer Specifies the layer to use as the displacement map.

Max Displacement Time (sec) Sets the maximum time, in seconds, from which pixels are replaced, before or after the

current time. Note that only luminance values of 0 or 255 (maximum darkness and maximum brightness) produce

the maximum time. All other luminance values produce times less than the maximum time.

Time Resolution (fps) Sets the number of frames per second in which to replace pixels. Typically, this value should

not be greater than the frame rate of the affected layer. Increasing Time Resolution can significantly increase

rendering time.

Stretch Map to Fit Resizes the Time Displacement Layer to match the dimensions of the layer you are distorting. If

this option is not selected, the time displacement layer is centered in the composition.

To use the Time Displacement effect (Pro only)

1 In the Composition panel, display both the layer you want to distort and the displacement map layer.

2 Hide the displacement map layer by clicking the Video switch in the Timeline panel.

3 In the Composition panel, select the layer you want to distort.

4 Choose Effect > Time > Time Displacement.
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5 Choose a displacement map from the Time Displacement Layer menu, which lists all layers in the composition.

Grayscale maps are recommended.

Note: After Effects uses the layer you select in its original form, without any masking, effects, or transformations you

may have applied. If you want to use the layer with those alterations included in the displacement map, precompose that

layer using the Move All Attributes into the New Composition option.

6 Adjust the Time Displacement controls.

To apply a mask and time displacement to a layer (Pro only)

Any mask you apply to the original layer is ignored by the Time Displacement effect. To use a mask with time

displacement in the same layer, precompose the layer as a separate composition, and then apply the mask inside the

new composition. This method, however, can significantly increase rendering time.

1 In the Composition panel, select the layer you want to distort.

2 Apply the Time Displacement effect.

3 Choose Layer > Pre-compose.

4 Select the Leave All Attributes in “Comp [composition number]” option, specify a name for the new composition

or accept the default name, and then click OK.

5 In the new composition, double-click the layer you are distorting. In the Layer panel, apply the mask.

Timewarp effect (Pro only)
This effect works with 8-bpc and 16-bpc color.

Timewarp effect

See also

“To apply the Timewarp effect (Pro only)” on page 239

Transition effects

Block Dissolve effect
The Block Dissolve effect makes a layer disappear in random blocks. The width and height of the blocks, in pixels,

can be set independently. At Draft quality, the blocks are placed with pixel accuracy and have sharply defined edges;

at Best quality, the blocks can be positioned with subpixel accuracy and have soft edges.

This effect works with 8-bpc and 16-bpc color.
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Original (left) and after applying the Block Dissolve effect (center and right)

Card Wipe effect
This effect simulates a group of cards displaying a picture and then flipping to display another picture. Card Wipe

provides control over the number of rows and columns of cards, the flip direction, and the transition direction

(including the ability to use a gradient to determine flip order). You can also control randomness and jitter to make

the effect appear more realistic. By varying the rows and columns, you can also create venetian blind and Chinese

lantern effects.

This effect works with 8-bpc color.

Original (left) and after applying the Card Wipe effect (center and right)

Adjust the following controls for the Card Wipe effect:

Transition Completion Specifies how far along you are in the transition. A setting of 100% displays the new image

revealed by the transition; a setting of 0% displays the original image.

To create an animated transition, animate this value from 0% to 100%.

Transition Width Specifies the width of the area that is actively changing from the original to the new image.

Back Layer Specifies the image to be revealed by the transition. You can use any file in the composition (its visibility

can be turned off). If the image has an effect or mask applied, precompose the layer first.

Rows & Columns Specifies the interaction of the numbers of rows and columns. Independent makes both the Rows

and Columns sliders active. Columns Follows Rows makes only the Rows slider active. When you choose this option,

the number of columns is always the same as the number of rows.

Rows Defines the number of rows up to 1,000.

Columns Determines the number of columns up to 1,000, unless Columns Follows Rows is selected.

Note: Rows and columns are always evenly distributed across a layer, so odd-shaped rectangular tiles don’t appear along

the edges of a layer, unless you are using an alpha channel.

Card Scale Specifies the size of the cards. A value smaller than 1 scales down the cards, causing transparent grid lines

to appear between them. A value greater than 1 scales up the cards. Oversized cards create a blocky mosaic effect as

they overlap each other from lower left to upper right. During the transition, the jumbo cards actually pass through

one another.
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Flip Axis Specifies the axis around which each card flips. Choose an axis for precision flipping, or Random for a more

realistic effect.

Flip Direction Specifies the direction in which the cards flip around their axes. With the x axis selected, Positive flips

the cards up and Negative flips them down; with the y axis selected, Positive flips the cards to the right, and Negative

flips them to the left. Selecting Random randomly flips positively or negatively.

Flip Order Specifies the direction the transition occurs. For example, Left to Right starts the cards flipping on the left

and proceeds to the right. You can also use a gradient to define a custom flip order: Cards flip first where the gradient

is black and last where the gradient is white.

Gradient Layer Specifies the gradient layer you want to use for the Flip Order. You can use any file in the compo-

sition (visibility can be turned off).

Timing Randomness Randomizes the timing of the transition. When this control is set to 0, the cards flip with

precision. The higher the value, the more randomly the cards flip and the more realistic the effect.

Random Seed Generates a unique result for random effects. True randomness is not repeatable; if effects were

genuinely random, you couldn’t go back and fine-tune part of an effect without rerendering. However, two random

effects running next to each other may look noticeably alike. To avoid this, use a random seed. A random seed is a

number that is inserted into the calculation to generate a unique result. By changing the Random Seed setting, you

can make effects using the same settings appear different.

Camera System Specifies whether to use Camera Position, Corner Pins, or Comp Camera. Comp Camera tracks the

composition’s camera and light positions and renders a 3D image on the layer.

Camera Position controls for the Card Wipe effect
X Rotation, Y Rotation, Z Rotation Rotate the camera around the corresponding axis. Use these controls to look at

the layer from the top, side, back, or any other angle.

X, Y Position Specifies where the camera is positioned in (x,y) space.

Z Position Specifies where the camera is positioned in z space. Smaller numbers move the camera closer to the layer,

and larger numbers move the camera away from the layer.

Focal Length Specifies the zoom factor. It is like a camera’s zoom lens. Smaller numbers zoom the camera lens out,

and larger numbers zoom the camera lens in.

Transform Order Specifies the order in which the camera rotates around its three axes, and whether the camera

rotates before or after it is positioned using the other Camera Position controls.

Corner Pins controls for the Card Wipe effect

Corner Pinning is an alternative camera control system. Use it as an aid for compositing your layer into a scene.

Upper Left Corner, Upper Right Corner, Lower Left Corner, Lower Right Corner Specify the location of each of the

four corners of your layer.

Auto Focal Length Controls the perspective of the effect during the animation. When Auto Focal Length is

deselected, the focal length you specify is used to find a camera position and orientation that positions the corners

of the layer at the corner pins. If this isn’t possible, the layer is replaced by its outline, drawn between the pins. When

Auto Focal Length is selected, the focal length required to match the corner points is used, if possible. If not, it inter-

polates the correct value from nearby frames.

Focal Length Overrides the other settings if the results you’ve obtained aren’t what you need. If you set the Focal

Length to something that doesn’t correspond to what the focal length would be if the pins were actually in that
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configuration, the image may look odd (strangely sheared, for example). But if you know the focal length that you

are trying to match, this is the easiest way to get correct results.

Lighting controls for the Card Wipe effect
Light Type Specifies which type of light you want to use. When a light is at a great distance from an object, all the

light rays strike the object from virtually the same angle. Sun rays, for example, are parallel by the time they reach

the earth. As a light source moves closer to the object, the rays strike the object from an increasing number of angles.

Distant Source is similar to sunlight and casts shadows in the one direction. Point Source is similar to a light bulb

and casts shadows in all directions. First Comp Light uses the composition’s first light layer, which can use a variety

of settings.

Light Intensity Specifies the power of the light. The higher the value, the brighter the layer. Other lighting settings

affect the overall light intensity as well.

Light Color Specifies the color of light.

Light Position Specifies the position of the light in (x,y) space. To position the light interactively, hold down Alt

(Windows) or Option (Mac OS), and drag the light’s effect point.

Light Depth Specifies the position of the light in z space. Negative numbers move the light behind the layer.

Ambient Light Distributes light over the layer. Increasing it adds an even illumination to all objects and prevents

shadows from being totally black. Turning Ambient Light all the way to pure white and setting all other light

properties to 0 makes the object fully lit and eliminates any 3D shading from the scene.

Material controls for the Card Wipe effect

The Material controls specify the reflection values of the cards.

Diffuse Reflection Gives objects form-defining shading. Shading depends on the angle at which the light strikes the

surface and is independent of the viewer’s position.

Specular Reflection Takes into account the position of the viewer. It models the reflection of the light source back to

the viewer. It can create the illusion of shininess. For realistic effects, you can animate this control using higher and

higher values to mask the transition from filtered to nonfiltered versions of the layer.

Highlight Sharpness Controls shininess. Very shiny surfaces produce small tight reflections, while duller surfaces

spread the highlight out into a larger region. Specular highlights are the color of the incoming light. Because light is

typically white or off-white, broad highlights can desaturate an image by adding white to the surface color.

The total lighting process can be thought of in this way: Set the Light Position and Diffuse Reflection to control the

overall light level and shading in a scene. Then adjust Specular Reflection and Highlight Sharpness to control the

strength and spread of highlights. Finally, adjust Ambient Light to fill in the shadows.

Jitter controls for the Card Wipe effect

Adding jitter (Position and Rotation Jitter) makes this transition more realistic. Jitter works on the cards before,

during, and after the transition occurs. If you want the jitter to happen only during the transition, start with the Jitter

Amount at 0, animate it up to the desired amount during the transition, and then animate it back down to 0 at the

completion of the transition.

Position Jitter Specifies the amount and speed of jitter at the x, y, and z axis. X, Y, Z Jitter Amount specifies the

amount of extraneous movement. Increasing X Jitter Amount makes the cards jitter from side to side; increasing Y

Jitter Amount makes the cards jitter up and down; increasing Z Jitter Amount makes the cards jitter in z space (closer

or farther away). X, Y, Z Jitter Speed controls the speed of jitter for each Jitter Amount option.
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Rotation Jitter Specifies the amount and speed of rotation jitter at the x, y, and z axis. X, Y, Z Rotation Jitter Amount

specifies the amount of rotational jitter along an axis. A value of 90˚ makes it possible for a card to rotate up to 90˚

in either direction. X, Y, Z Rot Jitter Speed controls the speed of rotational jitter.

Gradient Wipe effect
The Gradient Wipe effect creates transitions based on the luminance values of a second layer, called the gradient

layer. The luminance of a pixel in the gradient determines the time at which the corresponding pixel in the first layer

becomes transparent. Dark areas of the gradient layer represent those areas which become transparent first, followed

by lighter areas.

This effect works with 8-bpc and 16-bpc color.

Original (left) and after applying the Gradient Wipe effect (center and right)

For example, a simple grayscale gradient from left to right produces a left-to-right wipe. The gradient layer need not

be a still image; you can use any layer in After Effects as a gradient for unusual wipe effects. You can create more

interesting wipes in a variety of ways. The Ramp effect is a good starting point because it can generate a variety of

grayscale gradients. To make completely custom gradients, paint them in a program such as Adobe Photoshop, or

draw them in a program such as Adobe Illustrator.

Adjust the following controls for the Gradient Wipe effect:

Transition Completion Specifies the percentage of the transition applied to the layer.

Transition Softness Specifies the amount of softness applied to the transition’s edge.

Gradient Layer Specifies the layer used as the gradient. The gradient layer must be in the same composition as the

layer to which you apply Gradient Wipe.

Gradient Placement Specifies how the gradient is positioned and sized in the layer. Tile Gradient creates multiple

tiled copies of the gradient. Center Gradient places a single gradient in the center of the layer. Stretch Gradient to Fit

resizes the gradient layer horizontally and vertically to fit the entire area of the layer.

Invert Gradient Inverts the position of the gradient layer and the layer affected by the gradient transition.

Iris Wipe effect
The Iris Wipe effect creates a radial transition that reveals an underlying layer. Specify the number of points used to

create the iris using a range of 6 to 32 points, and specify whether an inner radius is used. When Use Inner Radius

is selected, you can specify values for both Inner Radius and Outer Radius; the iris is not visible when Outer Radius,

Inner Radius, or both are set to 0. The iris is roundest when both Outer Radius and Inner Radius are set to the same

value.

This effect works with 8-bpc and 16-bpc color.



ADOBE AFTER EFFECTS 7.0
User Guide

549

Original (left) and after applying the Iris Wipe effect (center and right)

Linear Wipe effect
The Linear Wipe effect performs a simple linear wipe of a layer in a specified direction. At Draft quality, the edge of

the wipe is not anti-aliased; at Best quality, the edge of the wipe is anti-aliased and the feather is smooth.

The Wipe Angle control specifies the direction that the wipe travels. For example, at 90˚ the wipe travels from left to

right.

This effect works with 8-bpc and 16-bpc color.

Original (left) and after applying the Linear Wipe effect (center and right)

Radial Wipe effect
The Radial Wipe effect reveals an underlying layer using a wipe that circles around a specified point. At Best quality,

the edges of the wipe are anti-aliased.

The Start Angle control specifies the position or angle at which the transition starts. With a start angle of 0˚, the

transition starts at the top of the layer. Wipe specifies whether the transition moves clockwise or counterclockwise,

or alternates between the two.

This effect works with 8-bpc and 16-bpc color.

Original (left) and after applying the Radial Wipe effect (center and right)

Venetian Blinds effect
The Venetian Blinds effect reveals an underlying layer using strips of specified direction and width. At Draft quality,

the strips are animated with pixel accuracy; at Best quality the strips are animated with subpixel accuracy.

This effect works with 8-bpc and 16-bpc color.
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Original (left) and after applying the Venetian Blinds effect (center and right)

Utility effects

Cineon Converter effect
The Cineon Converter effect provides a high degree of control over color conversions of Cineon frames. In After

Effects, you can convert the color in a Cineon file using controls in the Interpret Footage dialog box or using the

Cineon Converter effect. To use the Cineon Converter effect, import a Cineon file and leave it in its default state;

After Effects either condenses the colors to 8-bpc or expands them to 16-bpc, depending on the mode you are

working in. You can then apply the Cineon Converter effect to the file and precisely adjust the colors while interac-

tively viewing the results in the Composition panel. Set keyframes to adjust for changes in tone over time—use

keyframe interpolation and ease handles to precisely match the most irregular lighting changes, or leave the file in

its default state and use the converter.

The 10 bits of data available in each Cineon channel for each pixel make it easier to enhance an important range of

tones while preserving overall tonal balance. By carefully specifying the range, you can create a version of the image

that faithfully resembles the original.

Adjust the following controls for the Cineon Converter effect:

Conversion Type Specifies how the Cineon file is converted. Log To Linear converts an 8-bit logarithmic non-

Cineon layer that you plan to render as a Cineon sequence. Linear To Log converts a layer containing an 8-bpc linear

proxy of a Cineon file into an 8-bpc logarithmic file so that its display characteristics are consistent with the original

Cineon file. Log To Log detects an 8-bpc or 10-bpc logarithmic Cineon file when you plan to render it as an 8-bpc

logarithmic proxy.

Note: Obsolete versions of each option are available for compatibility with projects converted from earlier versions of

After Effects.

10 Bit Black Point Specifies the black point (minimum density) for converting a 10-bpc logarithmic Cineon layer.

Internal Black Point Specifies the black point used for the layer in After Effects.

10 Bit White Point Specifies the white point (maximum density) for converting a 10-bpc logarithmic Cineon layer.

Internal White Point Specifies the white point used for the layer in After Effects.

Gamma Specifies the value of midtones.

Highlight Rolloff Specifies the rolloff value used to correct bright highlights.

See also

“About Cineon files” on page 104

“To import a Cineon sequence” on page 104
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“To set options for Cineon files” on page 105

“About color depth” on page 61

To control the tonal balance of a Cineon file

1 Import the Cineon file into After Effects, and add it to a composition.

2 Select the Cineon file layer in the Composition or Timeline panel, and choose Effect > Utility > Cineon Converter.

3 Choose an option from the Conversion Type menu.

4 Adjust the black point by dragging the 10 Bit Black Point slider right or left.

5 Adjust the white point by dragging the 10 Bit White Point slider left or right. (If adjusting the brightest areas makes

the rest of the image appear too dark, use the Highlight Rolloff slider to adjust these bright highlights.)

6 Adjust midtones by dragging the Gamma slider to the left to darken midtones, or to the right to lighten midtones.

7 If highlights appear as white blotches, drag the Highlight Rolloff slider to the right until details are visible. An

image with high contrast may require a high rolloff value.

Note: Each computer monitor has unique display characteristics that affect your perception of color on-screen. For best

results when evaluating tonal balance, use the Info panel in After Effects to see the true color values of pixels as you move

the pointer over them.

See also

“About Cineon files” on page 104

“To import a Cineon sequence” on page 104

“To set options for Cineon files” on page 105

“About color depth” on page 61

Color Profile Converter effect
The Color Profile Converter effect converts a layer from one color space to another by specifying input and output

profiles. You can use the profile specified in Project Settings, or select another profile. The profiles you select are

embedded in your project, so you can use them even if you transfer the project to a computer that does not have the

same profiles. When converting from one color space to another, you can specify how After Effects handles the color

conversion by selecting a rendering intent. You can also choose whether to linearize the input or output profile.

See also

“Color management” on page 64

To convert the color profile of a layer

1 Select a layer, and choose Effect > Utility > Color Profile Converter.

2 In Effects Controls, select a color profile from the Input Profile menu. Select Project Working Space to use the

profile specified in your project settings (File > Project Settings). To linearize the input profile, select the Linearize

Input Profile option.

3 Select an output profile from the Output Profile menu. To linearize the output profile, select the Linearize Output

Profile.

4 In the Intent menu, select a rendering intent.
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See also

“Color management” on page 64

Rendering intents

Rendering intent options determine how source colors are adjusted. For example, colors that fall inside the desti-

nation gamut may remain unchanged, or they may be adjusted to preserve the original range of visual relationships

when translated to a smaller destination gamut.

The result of choosing a rendering intent depends on the graphical content of an image and on the profiles used to

specify color spaces. Some profiles produce identical results for different rendering intents.

When specifying a rendering intent, you can choose to use black point compression. Black point compression

ensures that the shadow detail in the image is preserved by simulating the full dynamic range of the output device.

The following rendering intents are available for the Color Profile Converter effect:

Perceptual Attempts to preserve the visual relationship between colors so it’s perceived as natural to the human eye,

even though the color values themselves may change. This intent is suitable for images with many of out-of-gamut

colors.

Saturation  Attempts to produce vivid colors in an image at the expense of color accuracy. This rendering intent is

suitable for images, such as graphic logos, in which bright saturated colors are more important than the exact

relationship between colors.

Relative Colorimetric  Compares the extreme highlight of the source color space to that of the destination color

space and shifts all colors accordingly. Out-of-gamut colors are shifted to the closest reproducible color in the desti-

nation color space. This rendering intent preserves more of the original colors in an image than Perceptual. This is

the default, and is the rendering intent used by default throughout After Effects.

Absolute Colorimetric Leaves colors that fall inside the destination gamut unchanged. Out-of-gamut colors are

clipped. No scaling of colors to the destination white point is performed. This intent aims to maintain color accuracy

at the expense of preserving relationships between colors.

See also

“Color management” on page 64

Grow Bounds effect
The Grow Bounds effect increases the layer size for the effect that directly follows this effect. It is most useful with

layers with Collapse Transformations/Continuously Rasterize enabled, because they render using a buffer that is the

size of the composition. For example, if you apply Drop Shadow to a Text layer that is partially off the composition,

the shadow will be clipped because only the portion of the text that is in the composition will cast a shadow. Applying

the Grow Bounds effect before the Drop Shadow effect prevents the shadow from being cut off. The number of pixels

you specify increases the height and width of the layer’s buffer.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.
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Original (left); the Wave Warp effect is constrained by the dimensions of the layer (center); Grow Bounds fixes this problem (right).

HDR Compander effect
The HDR Compander (compressor/expander) effect gives you a way to work with tools that don’t support HDR—

such as 8-bpc and 16-bpc effects—without the sacrificing the high dynamic range of your footage.

The HDR Compander effect works by first compressing the highlight values in the HDR image so that they fall

within the range of an 8-bpc or 16-bpc file, and then expanding the values back to the 32-bpc range.

Apply the HDR Compander effect to your footage once before working with low-dynamic-range tools and effects.

Then, when you’re finished, use the HDR Compander effect to expand the dynamic range back to 32-bpc.

Because the first application of the HDR Compander effect compresses the range of values through sampling, some

accuracy is lost. Only use the HDR Compander effect if you are willing to make the tradeoff of some accuracy in

values for the sake of high dynamic range.

See also

“High dynamic range footage (Pro only)” on page 62

To use the HDR Compander effect

1 Select a layer in a 32-bpc project, and choose Effect > Utility > HDR Compander.

2 In the Effect Controls panel, select Compress Range for the Mode property.

3 Set Gain and Gamma. Gain specifies the maximum value to be represented in the compressed range; Gamma

affects the distribution of values in the range, allowing more precision in specific areas of the range.

4 Apply whatever low-dynamic-range effects you choose to the layer.

5 Apply another instance of the HDR Compander effect to the layer. Make sure that the second instance of HDR

Compander is ordered after (below) any 8-bpc or 16-bpc effects you have applied.

6 In the Effect Controls panel, select Expand Range for the Mode property for the second instance of the HDR

Compander effect.

7 Set Gain and Gamma to the same values as set in the first instance of the HDR Compander effect.

A more convenient way to use the HDR Compander effect is to apply the Compress-Expand Dynamic Range

animation preset. This animation preset consists of an expression and two instances of the HDR Compander effect:

The first instance has Compress Range selected, and the second has Expand Range selected. The expression automati-

cally sets the Gain and Gamma for the second instance to be the same as that which you set for the first instance. Insert

whatever low-dynamic-range effects you choose between these two instances of the HDR Compander effect.

See also

“High dynamic range footage (Pro only)” on page 62
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HDR Highlight Compression effect
The HDR Highlight Compression effect compresses the highlight values in a high-dynamic-range image so that they

fall within the value range of a low-dynamic-range image. Adjust the amount of compression by setting the effect’s

Amount property.

See also

“High dynamic range footage (Pro only)” on page 62
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Chapter 18: Expressions

Creating and modifying expressions

About expressions
When you want to create and link complex animations, such as multiple car wheels spinning, but would like to avoid

creating tens or hundreds of keyframes by hand, try using expressions instead. With expressions, you can create

relationships between layer properties and use one property’s keyframes to dynamically animate another layer. For

example, if you set rotation keyframes for a layer and then apply the Drop Shadow effect, you can use an expression

to link the Rotation property’s values with the Drop Shadow effect’s Direction values; that way, the drop shadow

changes accordingly as the layer rotates.

Expressions are based on the standard JavaScript language, but you do not need to know JavaScript to use expres-

sions. You can create expressions by using simple examples and modifying them to suit your needs or by chaining

objects and methods together.

All of your work with expressions occurs in the Timeline panel. You can use the pick whip to create expressions, or

you can enter and edit expressions manually in the expression field, a text field in the time graph under the property.

You can write an expression in a text editor and then copy it into the expression field. When you add an expression

to a layer property, a default expression appears in the expression field.

In Graph Editor view, the expression field appears as a resizable text box at the bottom of the Graph Editor. Only the

active expression for the selected property appears in the Graph Editor expression field.

Note: If an expression cannot be processed, After Effects displays a message explaining the error and automatically

disables the expression. A yellow warning icon appears next to the expression; click the warning icon to view the error

message again.

If you have used Motion Math scripts in past versions of After Effects, you can now create the same results using

expressions.

Some expressions rely on the names of layers or properties in your project; if you change the name of a layer or

property that is involved in an expression, After Effects will attempt to update the expression to use the new name.

However, in some complex cases After Effects will be unable to automatically update the expression, in which case

the expression may produce an error message, and you must update the expression yourself.

Note: The parameters for some After Effects effects have changed. If you have existing expressions that use parameter

index references rather than parameter names, you may need to make adjustments to the expressions to use parameter

names.
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Expression options in the Timeline panel
A. On/Off switch B. Graph overlay icon C. Pick whip D. Expression Language menu E. Expression field

To temporarily turn an expression off or on, click the On/Off switch  next to the layer property name on which

the expression is written. When an expression is off, a slash appears through the switch.

After you add an expression to a property, you can continue to add or edit keyframes for the property. The value of

a keyframe at the time you create it or edit it is the value it would be without the expression applied.

Animation presets can include expressions, or even consist entirely of an expression.

When you are animating text, you can use the Expression selector to dynamically specify how much you want

characters to be affected by an animator property through the use of expressions. You can add one or more

Expression selectors to an animator group, and that animator group can contain one or more properties. (See “About

the Expression selector” on page 302.)

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“To save an animation preset” on page 203

“About animation and layer properties” on page 188

To create an expression with the pick whip
If you are not familiar with JavaScript or the After Effects expression language, you can still take advantage of the

power of expressions by using the pick whip. You simply drag the pick whip  from one layer to another, and the

property that you set or animated in the first layer is copied into the second layer.

Use the pick whip to create expressions that link the values of one property or effect to another. For example, link the

Rotation property of Layer A to the Rotation property of Layer B to make Layer A’s rotation values the same as Layer

B’s; or link a camera’s Point of Interest property to the Position property of another 3D layer to make the camera

follow the layer as it moves through space.

1 Select a property in the Timeline panel and choose Animation > Add Expression.

2 Drag the pick whip to another property in the Timeline panel or Effect Controls.

3 Optionally, modify the default expression in the expression field.

B C D EA
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Drag the pick whip to a property to create a link to the property’s value.

See also

“About animation and layer properties” on page 188

Selecting values with the pick whip
When you use the pick whip, you can drag it to a property’s name or to its values. If you drag to the property’s name,

the resulting expression displays all the values as one. For example, if you drag the pick whip to the Position

property’s name, the following expression appears:

posit ion

If you drag the pick whip to one of the Position property’s values (such as the y value), the following expression

appears, providing access to the specific Array values:

[posit ion[1] ,  posit ion[1]]

Once you select a property’s name or value, After Effects automatically inserts the appropriate expression in the

expression field at the location of the cursor. If text is already selected in the expression field, that text is replaced by

the new expression text. If the cursor is not in the expression field, all text in the field is replaced by the new text.

If the layer, mask, or effect name that you drag the pick whip to is not unique, After Effects renames it. For example,

if you have two or more masks named “Mask” and you drag the pick whip to one of them, After Effects renames it

“Mask 2”.

See also

“About animation and layer properties” on page 188

To modify pick whip expressions
Once you use the pick whip to create an expression, you can perform simple edits to alter the expression’s effect. For

example, you can add a scale factor to the expression to increase or decrease the effect.

❖ Type directly in the expression field, and then press Enter on the numeric keypad or click outside of the field to

activate the expression.

You can modify a pick-whip expression by using simple math operations, such as those listed in the following table:

Symbol Function

+ add

- subtract
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Using complex math functions provides great flexibility. For example, you could use the math function /360*100 to

change an expression’s range from 0-360 to 0-100. This would be useful if you wanted to convert the values of a 360-

degree dial to a slider that is measured in percentages.

To specify the format for pick whip expressions
You can specify the way the pick whip formats expressions. By default, the pick whip creates compact English expres-

sions, which use the Timeline panel’s name for the properties within an expression. Because these names are coded

into the product and never change, the expression does not break when opened on a computer that uses a language

other than English. Any property names that you can change are enclosed in straight quotes and remain the same in

any language. If you don’t plan on sharing your projects across a language barrier, you can deselect this preference

and line up properties in an expression hierarchically, using parentheses.

1 Choose Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS).

2 Select or deselect Expression Pick Whip Writes Compact English.

To see the difference between the two expression formats, create the same pick-whip expression with the preference

selected and deselected.

Note: Because the default is set to use compact English, this document uses compact English in all examples and illus-

trations.

To build an expression using the Expression Language menu
The Expression Language menu in the Timeline panel contains all the language elements specific to After Effects

that you can use in an expression. This menu is helpful for determining valid elements and their correct syntax; use

it as a reference for available elements. Select any object, attribute, or method, and After Effects automatically inserts

it in the expression field at the location of the cursor. Then, you can edit and add to it as needed.

The Expression Language menu lists arguments and default values. This makes it easy to remember which elements

you can control when you write an expression. For example, in the language menu, the Property function for wiggle

lists: wigg le( f req,  amp,  octaves=1,  ampMult=.5 ,  t=t ime). There are five arguments listed in the parentheses

following wiggle . The = in the last three arguments indicates that using those parameters is optional. If you specify

no values for them, they default, respectively, to 1, .5, and the current time.

/ divide

* multiply

*-1 perform opposite of original, such as
counterclockwise instead of clockwise

Symbol Function
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Add expression elements to the expression field by choosing them from the Expression Language menu.

1 Select a layer property and choose Animation > Add Expression.

2 Click the Expression Language menu icon  and choose Global > thisComp. The element appears in the

expression field at the location of the cursor:

thisC omp

3 To continue the expression, add a period (.) to the end, click the Expression Language menu icon, and then choose

an attribute from the Comp menu, such as layer(index) :

thisC omp.layer( index)

4 Insert the specific layer information you want. For example, if you want to use the keyframe information from

Layer 1, change index to 1 as follows:

thisC omp.layer(1)

5 Next, add a period and choose an attribute or method from any of the Layer, Light, or Camera menus. For

example, if Layer 1 has Position keyframes that you want to use in your expression, choose position from the Layer

Properties menu, and so on.

thisC omp.layer(1) .posit ion

See also

“About animation and layer properties” on page 188

Example: Writing a simple expression
Do the following to construct a simple expression that copies position values from one layer to another:

1 Create two solid layers: Solid 1 and Solid 2.

2 Animate the Position property values for Solid 1. (See “Using keyframes” on page 192.)

3 Select the Position property for Solid 2 and choose Animation > Add Expression. The following expression

appears by default:

transform.posit ion

4 Type the following directly over transform.posit ion:

thisC omp
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5 The element thisC omp is a global attribute whose value is a Comp object representing the current composition.

To determine what can follow thisC omp in your expression, look up the return value for thisC omp under “Global

objects” on page 571.

6 Note that thisC omp returns a Comp. Next, look at “Comp attributes and methods” on page 576 to see which

attributes and methods you can use with a Comp. One option is layer( index). The index, or number, inside the

parentheses specifies the layer that you want to use. For this example, we assume Solid 1 is the second layer in your

composition. To retrieve values from the second layer in the active composition, type the following:

thisC omp.layer(2)

7 Again, look at the expression elements reference to see that layer( index) returns a Layer. Look at “Layer General

attributes and methods” on page 579, and find the element you want to use. For example, if you want to access the

Position property’s values for the layer, type the following:

thisC omp.layer(2) .posit ion

8 From “Layer General attributes and methods” on page 579, you can see that the posit ion attribute returns a

property. Look up “Property attributes and methods” on page 584 and notice that you can add a time factor to the

expression. To add a specific time, such as current time minus 2 seconds, type the following:

thisC omp.layer(2) .posit ion.va lueAtTime(t ime-2)

9 From “Property attributes and methods” on page 584, notice that the valueAtTime method returns a number or

Array. When an expression returns a Number, Array, or Boolean (such as true or false), you cannot add further

attributes or methods to the expression (if you want, however, you can add operators such as +, - , * , or /).

See also

“Using the expression elements reference” on page 570

Writing expressions for source text
All expressions produce a result that is a number or an array of numbers—with one exception: expressions written

for the Source Text property of a text layer. The result of an expression that links to the Source Text property is inter-

preted as a JavaScript String. The expression replaces the existing text for the layer, using the style of the first

character. You can use the pick whip to retrieve the source text from another text layer; however, only the style of the

first character of the destination layer is used.

For example, to copy the original text from one layer and add it to another layer in all uppercase characters, type the

following expression:

text .sourceText  + " \r"  +  text . sourceText . toUpperCase()

You can use "\r" in a string expression to start a new line of text. For more information on the String object, consult

a JavaScript guide.

To add comments to an expression
• Do either of the following:

• Type //  at the beginning of the comment. Any text between // and the end of the line is ignored. For example:

//  This  i s  a  comment .

• Type /* at the beginning of the comment and */ at the end of the comment. Any text between /* and */ is ignored.

For example:

/*This  i s  a  mult i l ine  comment .  */
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To modify properties with Expression Controls effects
Use Expression Controls effects to manipulate one or many properties’ values in your expressions. These effects

provide controls that you can refer to in any expression. A single control can affect several properties at once. You

can apply Expression Controls effects to any layer; however, it is useful to apply them to a null layer, which you can

simply use as a control layer. You then add expressions to other layers to access that control—you can simply copy

and paste the same expression on different layer properties. For example, you can add the Slider effect to a null layer

(Null 1), and then copy and paste an expression such as the following to a series of layers in the composition:

posit ion+[0,10*( index-1)*thisC omp. layer("Nul l  1") .e f fec t("Sl ider  C ontrol")( "Sl ider")]

As you drag the slider, each layer with this expression will animate, with the position of each dependent on the value

of slider and the index of the layer. The layers with greater index numbers will be shifted more than the layers with

lower index numbers, at 10-pixel intervals.

All you need to do is set keyframes for the slider on the null layer and all the other layers animate accordingly.

❖ In the Timeline panel, select the layer to which you want to add the expression control, and then choose Effect >

Expression Controls > [effect name].

See also

“To create a null object” on page 209

Expression Controls effects

After Effects includes the following Expression Controls effects for which you can set keyframes:

Angle Control You can adjust the angle control by dragging the underlined values.

Checkbox Control This control contains a single on/off value that you can click. You can animate this control to start

and stop animation at specific intervals.

Color Control This control contains a color swatch and an eyedropper. You can use this effect to control the gradual

or sporadic change of colors on one layer or among several layers.

Layer Control This control contains a layer menu that lists all of the layers in the active composition. You cannot add

keyframes to this effect.

Point Control This control contains an effect point control. You can use this to perform as a master control for

animation in a series of layers.

Slider Control This control contains a slider with a default value range of 0 to 100. To use values that exceed this

limit, drag the underlined value above the slider instead. To change the slider range, right-click (Windows) or

Control-click (Mac OS) the underlined slider value and choose Edit Value from the menu that appears. Type the new

values in the Slider Range text box.

Working with expressions

To view expressions
In Graph Editor mode, the single expression field shows only the expression for the selected property. To see multiple

expressions simultaneously, the Timeline panel must be in layer bar mode.
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To toggle between layer bar mode and Graph Editor mode, press Shift+F3.

• To view only properties with expressions, select one or more layers, and then press EE on the keyboard.

• To show the expression field in the Graph Editor, choose Show Expression Editor from the Choose Graph Type

And Options  menu at the bottom of the Graph Editor.

To resize the expression field, drag its bottom edge up or down.

Viewing the expression graph
To see how an expression changes the value or velocity graph, click the graph overlay icon while viewing the value

or velocity graph in the Graph Editor. The dimly colored graph displays the value or velocity before the expression

is applied, and the brightly colored graph displays value or velocity after the expression is applied.

Turning on the graph overlay for the Position property also changes the motion path display in the Composition

panel so that you can see the expression-affected path.

See also

“Working with the Graph Editor” on page 189

Saving expressions
Once you have written an expression, you can save it for future use by copying and pasting it into a text-editing appli-

cation, such as Notepad, Simple Text, or even Stickies. However, because expressions are written in relation to other

layers in a project and may use specific layer names, it doesn’t always work to simply save and load expressions into

a project. If you want to save an expression for use in another project, you may want to add comments to the

expression or save the entire project file so that you can use it as a reference when you reuse the expression.

You can save an animation preset that includes an expression and reuse it in other projects, as long as the expression

does not refer to properties that don’t exist in the other projects.

See also

“To save an animation preset” on page 203

To reuse an expression
You can copy an expression from a layer property, with or without the property’s keyframes. Copying an expression

without keyframes is particularly useful when you want to simultaneously copy multiple expressions and paste them

onto one or more new layers, or when you want to copy one expression and paste it onto more than one layer.

• To apply an expression and copy keyframes, copy the layer property that contains the expression and paste it onto

other layers.

• To apply an expression to any other property without copying keyframes, copy the expression in the expression

field and paste it into other expression fields.

• To apply an expression to the same property in a different layer without copying keyframes, select the layer

property that contains the expression, choose Edit > Copy Expression Only, select a different layer, and choose

Edit > Paste.
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• To apply an expression to a different property in the same layer or a different layer without copying keyframes,

select the layer property that contains the expression, choose Edit > Copy Expression Only, select a different

property in the desired layer, and choose Edit > Paste.

You can also save an expression as an animation preset and then apply that animation preset to another layer.

See also

“About animation and layer properties” on page 188

“To apply an animation preset” on page 202

To convert an expression to keyframes
In some situations, it may be useful to convert an expression to keyframes. For example, if you want to freeze the

values in an expression, you can convert the expression to keyframes and then adjust the keyframes accordingly; or,

if an expression takes a long time to evaluate, you can convert it to keyframes so that it renders more quickly. When

you convert an expression to keyframes, After Effects evaluates the expression, creating a keyframe at every frame,

and then disables the expression.

❖ In the Timeline panel, select the property in which the expression is written and choose Animation > Keyframe

Assistant > Convert Expression To Keyframes.

See also

“About animation and layer properties” on page 188

“Using keyframes” on page 192

Expression presets
Animation presets can include expressions. In fact, an animation preset may consist of only an expression. When you

save a preset in which a property has an expression but no keyframes, only the expression is saved. If the property

has one or more keyframes, the saved preset will contain the expression along with all keyframe values.

An example of a particularly useful animation preset that includes an expression is the Separate XYZ Position

animation preset, which creates individual properties for x, y, and z components of position. These properties can

then be easily manipulated individually, with keyframes, expressions, or other means. Choose Animation > Apply

Animation Preset, and select Separate XYZ Position to apply this animation preset to a layer.

See also

“To apply an animation preset” on page 202

“To save an animation preset” on page 203
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The expression language

About the expression language
The After Effects expression language is based on JavaScript 1.2, with an extended set of built-in objects. After Effects

uses only the core standard JavaScript 1.2 language, not the web browser–specific extensions. Instead of browser

extensions, After Effects contains its own set of extension objects such as Layer, Comp, Footage, and Camera that

you can use to access most of the values in an After Effects project.

For more information about JavaScript, see a JavaScript reference manual, such as JavaScript: The Definitive Guide,

by David Flanagan.

When creating expressions, keep the following in mind:

• JavaScript is case-sensitive.

• Semicolons are required to separate statements or lines.

• Spaces between words are ignored.

In JavaScript, a value stored in an object is called a property. However, After Effects uses the term property to refer to

layer attributes as defined in the Timeline panel. Consequently, for clarity, After Effects documentation refers to a

JavaScript property as a method when the property takes arguments, or an attribute when it does not.

Accessing values
You use the expression language to access values of properties. To access a value, use a chain of object references

separated by the period (.) operator. To chain object references past the layer level (for example, to chain effect

properties, masks, or text animators), use parentheses. For example, to link the Opacity property in Layer A to the

Gaussian Blur effect’s Blurriness property in Layer B, type the following expression in the expression field for Layer

A’s Opacity property:

thisC omp. layer("L ayer  B") .e f fec t( "Gaussian Blur")("Blurr iness")

The default object for an expression is the property on which the expression is written, followed by the layer

containing the expression; therefore, you do not need to specify the property. For example, a wiggle expression

written on a layer’s Position property can be either of the following:

wigg le(5 ,  10)

posit ion.wigg le(5 ,  10)

You do need to include the layer and property when retrieving them from outside the layer and property on which

the expression is written. For example, an expression written on Layer B’s Opacity property, linking it to Layer A’s

Position property would read:

thisC omp. layer("L ayer  A") .posit ion[0] .wigg le(5 ,  10)

To visualize how this works, use the pick whip to link one property to another.

See also

“About animation and layer properties” on page 188

Global objects
All expressions start with a global object. Only an attribute or method of the global object can appear in an expression

with nothing to the left of it.
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The default global object for any expression is the layer on which the expression is written. For example, if you add

an expression to the Scale property of Layer A and you want the expression to return Layer A’s Position property’s

values, you can use any of the following expressions, as they are equivalent:

thisC omp.layer("L ayer  A") .posit ion

thisL ayer.posit ion

posit ion

To retrieve values from an object other than the layer containing the expression, insert the object in the expression.

For example, if you write an expression on Layer A and you want to retrieve position values from Layer B, use the

following expression:

thisC omp.layer("L ayer  B") .posit ion

See also

“About animation and layer properties” on page 188

Arrays
An Array is a type of object that stores an ordered set of numbers. An Array is represented as a list of numbers

separated by commas and surrounded by brackets, as in this example:

[10,  23]

You can assign an Array to a variable, making it easy to refer to Array values in other areas of the expression. For

example:

myArray = [10,  23]

The dimension of an Array is the number of elements in the Array. The dimension of myArray is 2. Different

properties in After Effects have different dimensions depending on the number of value parameters they have. In the

expression language, properties’ values are either single values (Numbers) or Arrays.

The following table provides examples of some properties and their dimensions:

You can access the individual elements of an Array by using brackets and an index number to indicate which element

you want. The elements in an Array are indexed starting from 0. Using the previous example, myArray[0] is 10 and

myArray[1]  is 23.

The following two expressions are equivalent:

Value type Value dimensions

1D Rotation ˚

Opacity %

2D Scale [x=width, y=height]

Position [x, y]

Anchor Point [x, y]

3D Scale [width, height, depth]

Position [x, y, z]

Anchor Point [x, y, z]

4D Color [red, green, blue, alpha]
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[myArray[0] ,  5]

[10,  5]

The Position property arrays are indexed as follows:

• posit ion[0]  is the x coordinate of position.

• posit ion[1]  is the y coordinate of position.

• posit ion[2]  is the z coordinate of position.

Colors are represented as 4D arrays [r, g, b, a]. Each value in a color array ranges from 0 (black) to 1 (white). For

example, red can range from 0 (no color) to 1 (red). So, [0,0,0,0] is black and transparent, and [1,1,1,1] is white and

completely solid.

If you use an index that is greater than the index of the highest-dimension component in an Array, After Effects

returns an error. For example, myArray[2]  causes an error, but posit ion[2]  returns the z coordinate of Position.

Many of the properties and methods in the After Effects expression language take Array objects as arguments or

return them as values. For example, thisL ayer.posit ion is an Array that is either two-dimensional or three-dimen-

sional depending on whether your layer is 2D or 3D.

If you want to write an expression that keeps the y value of an object's animation but fixes the x value at 9, you would

use the following:

y  = posit ion[1] ;

[9 ,  y]

The following is even more succinct:

[9 ,  posit ion[1]]

This is an important point, so let’s look at one more example. If you want to combine the x position value from Layer

A with the y position value from Layer B, you would use the following:

x = thisC omp.layer("L ayer  A") .posit ion[0] ;

y  = thisC omp.layer("L ayer  B") .posit ion[1] ;

[x ,  y]

Vectors
In After Effects, many properties and methods take or return vectors. After Effects refers to an Array as a vector if it

represents either a point or direction in space. For example, After Effects describes posit ion as returning a vector.

However, while a function like audioLevels does return a two-dimensional value (the left and right channel levels),

it is not called a vector because it does not represent a point or direction. Some functions in After Effects accept

vector arguments, but they are generally only useful when the values passed represent a direction. For example,

cross(vec1,  vec2)  computes a third vector that is at right angles to the input vectors. This is useful when vec1 and

vec2 are two vectors representing directions in space, but not if they just represent two arbitrary collections of

numbers.

Vector and array indices
Indexing for Layer, Effect, and Mask elements in After Effects starts from 1. For example, the first layer in the

Timeline panel is layer(1) .
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Generally, it is best to use the name of a layer, effect, or a mask instead of a number to avoid confusion and errors if

the layer, effect, or mask is moved, or if the parameters are changed during product updates and upgrades. When

you use a name, always enclose it in straight quotes. For example, the first expression below is easier to understand

than the second expression, and the first expression will continue to work even if you change the order of effects:

ef fec t("C olorama") .param("Get  Phase  From")

ef fec t(1) .param(2)

You can create an expression that refers to just one value within the Array of a 2D or 3D property. By default, the first

value is used, unless you specify otherwise. For example, if you drag the pick whip from layer 1’s Rotation property

to layer 2’s Scale property, the following expression appears:

thisC omp. layer(2) .sca le[0]

By default, the above expression uses the first value of the Scale property, which is width. If you prefer to use the

height value instead, drag the pick whip directly to the second value instead of the property name, or change the

expression as follows:

thisC omp. layer(2) .sca le[1]

Conversely, if you drag the pick whip from layer 2’s Scale property to layer 1’s Rotation property, After Effects

automatically duplicates the expression so that two values are available for the scale. The following expression

appears:

[ thisC omp. layer(1) .rotat ion,  thisC omp. layer(1) .rotat ion]

To use a different value as one of the value parameters instead of doubling the one rotation value, remove the

duplicate expression and insert a value. For example, to use the rotation value for the scale’s height and 10 for the

width, you would create the following expression:

[thisC omp. layer(1) .rotat ion,  10]

The value of an expression is the value of the last statement evaluated. For example, in the following expressions, the

results are the same:

x = rotat ion *  10 ;  [x ,  20]

[rotat ion *  10 ,  20]

Expression time
Time within an expression is always measured in seconds. The default time for any expression is the current compo-

sition time at which the expression is being evaluated. The following expressions both use the default composition

time and return the same values:

thisC omp.layer(1) .posit ion

thisC omp.layer(1) .posit ion.va lueAtTime(t ime)

To use a relative time, add a time value to the t ime argument. For example, to get a value at a time 5 seconds before

the current time, use the following expression:

thisC omp.layer(1) .posit ion.va lueAtTime(t ime-5)

Default time references to properties in nested compositions use the original default composition time, not

remapped time. However, if you use the source function to retrieve a property, the remapped time is used.

For example, if the source of a layer in the parent composition is a nested composition, and in the parent composition

you have remapped time, when you access the position values of a layer in the nested composition with the following

expression, the position values use the composition’s default time:

comp("nested comp") . layer(1) .posit ion

However, if you access layer 1 using the source function, the position values use the remapped time:



ADOBE AFTER EFFECTS 7.0
User Guide

568

thisC omp. layer(“nested comp”) .source. layer(1) .posit ion

Note: If you use a specific time in an expression, After Effects ignores the remapped time.

Commonly used attributes and methods

The hasParent attribute
Use the hasParent attribute to determine if a layer has a parent. You can use this attribute even if there isn’t a parent

layer at present. For example, the following expression indicates that the layer to which you apply it will wiggle based

on the position of the layer’s parent. If the layer has no parent, then it will wiggle based on its own position. If the

layer is given a parent later, then the layer’s behavior will change accordingly:

idx = index;

i f  (hasParent)  {

idx = parent . index;

}

thisC omp.layer( idx) .posit ion.wigg le(5 ,  20)

The name attribute
Use the name attribute with Comp, Footage, Layer, Mask, and Effect objects when you want to apply the same

expression to several layers and vary the results based on the name of an object. For example, the following

expression wiggles the position of a layer differently if the layer is named "hero":

amp = 20;

i f  (name == "hero")  {

amp = 40;

}

wigg le(5 ,  amp)

Layer space transform methods
Use layer space transform methods to transform values from one space to another, such as from layer space to world

space. The “from” methods transform values from the layer’s space to the named space (comp or world). The “to”

methods transform values from the named space (comp or world) to the layer space. Each transform method takes

an optional parameter to determine the time at which the layer’s transform is computed; however, you can almost

always use the current (default) time.

Use “Vec” transform methods when transforming a direction vector, such as the difference between two position

values. Use the plain (non-”Vec”) transform methods when transforming a point, such as position. Comp and world

space are the same for 2D layers. For 3D layers, however, comp space is relative to the active camera, and world space

is independent of the camera.

See also

“Layer Space Transforms methods” on page 581
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Keyframe-looping methods
You can use keyframe-looping methods to repeat a series of keyframes. You can use these methods on any property

except marker. Keyframes or duration values that are too large are clipped to the maximum allowable value. Values

that are too small result in a constant loop.

The default argument for keyframe-looping methods is c ycle , which repeats the specified segment. However, you

can substitute c ycle  with any of the following arguments:

pingpong Repeats the specified segment, but alternates between repeating forward and backward in the segment.

offset Repeats the specified segment, but offsets each cycle by the difference in the value of the property at the start

and end of the segment, multiplied by the number of times the segment has looped.

continue Does not repeat the specified segment, but continues to animate a property based on the velocity at the

first or last keyframe. For example, if the last keyframe of a layer’s Scale property is 100%, the layer continues to scale

from 100% to the Out point, instead of looping directly back to the Out point. This type does not accept a keyframes

or duration argument.

The active and enabled attributes
You can use the act ive attribute in an expression to return a Boolean value that reports the status of a layer, camera,

property, property group, or effect.

The act ive attribute has the following behaviors:

• When reporting on a layer, act ive is true if the Video switch  is selected and the current time is between the

layer’s In and Out points.

• When reporting on an effect, ac t ive is true if the effect is turned on and the layer effect switch  is selected.

• When reporting on a camera, act ive is true if the camera is the Active Camera for the composition at the current

time.

• When reporting on any other property group or property, act ive is true if the property is enabled.

The enabled attribute returns a Boolean value that reports whether a property or layer is enabled based on the Video

switch  or effect switch  in the Timeline panel.

To animate with the propertyGroup method and propertyIndex attribute

Values of propertyGroup relative to the brush stroke’s Position property
A. propertyGroup(4) B. propertyGroup(3) C. propertyGroup(2) D. propertyGroup(1) E. Position’s propertyIndex value is 2; Rotation’s
propertyIndex value is 4.

The example below uses the proper tyGroup method and proper tyIndex attribute to create swirling paint strokes.

D

C

B
A

E
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Animating a brush stroke with an expression

1 Open a new composition, and choose Layer > New > Solid to create a new solid layer. Click Make Comp Size in

the Solid Footage Settings dialog box.

2 Double-click the solid in the Composition panel to open it in the Layer panel.

3 Select the Brush tool from Tools, and draw a stroke in the Layer panel. Modify the stroke options as desired.

4 Expand the solid layer in the Timeline panel, expand the Effects property group, expand the Paint property group,

expand the Brush property group, and then expand the Transform property group.

5 Select the Rotation property, and choose Animation > Add Expression.

6 Type the following expression in the expression text field in the timeline:

proper tyGroup(2) .proper tyIndex *  t ime *  200

7 Click outside the expression field, or press Enter on the numeric keypad to activate the expression.

8 Select Brush 1, and press Ctrl+D (Windows) or Command+D (Mac OS) multiple times to duplicate the brush.

9 Press the spacebar to preview your animation.

In this example, each brush stroke’s proper tyGroup method targets the Brush property group because that group is

two property groups up from the Rotation property. The proper tyIndex attribute in each Brush stroke then returns

a unique value for each Brush stroke. The resulting value is then multiplied by the time and 200 and applied to each

rotation value, rotating each brush stroke differently.

After Effects expression elements reference

Using the expression elements reference
Use the After Effects expression elements along with standard JavaScript elements to write your expressions.

Remember that you can also use the Expression Language menu at any time to insert functions into an expression.

If an argument contains an equal sign (=) and a value (such as t=t ime or width=.2), then the argument uses the

included default value if you don’t specify a different value.
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Some argument descriptions include a number in square brackets—this number indicates the dimension of the

expected property or Array. If a specific dimension is not included, any dimension will work.

Some return value descriptions include a number in square brackets—this number specifies the dimension of the

returned property or Array. If a specific dimension is not included, the dimension of the returned Array depends on

the dimension of the input.

Global objects
comp(name) Return type: Comp. Retrieves another composition by name.

Argument type: name is a String.

footage(name) Return type: Footage.

Argument type: name is a String.

Retrieves a footage item by name.

thisComp Return type: Comp.

Represents the composition containing the expression.

thisLayer Return type: Layer, Light, or Camera.

Represents the layer containing the expression. Because thisL ayer is the default object, its use is optional. For

example, you can start an expression with thisL ayer.width or width and get the same result.

thisProperty Return type: Property.

Represents the property containing the expression. For example, if you write an expression on the Rotation property,

you can start an expression with thisProper ty to refer to the Rotation property value.

time Return type: Number.

Represents the composition time, in seconds, at which the expression is being evaluated.

colorDepth Return type: Number.

Returns the project’s color depth value. For example, colorDepth returns 16 when the project’s color depth is 16 bits

per channel.

posterizeTime(framesPerSecond) Return type: Number.

Argument type: framesPerSecond is a Number.

The framesPerSecond value becomes the frame rate from which the rest of the expression operates. This allows you

to set the expression to a frame rate lower than that of the composition. For example, the following expression

updates the property value with a random value once per second:

poster izeTime(1) ;

random

value Return type: Number or Array.

Represents the value at the current time for the property containing the expression.

Time conversion methods
timeToFrames(t = time + thisComp.displayStartTime, fps = 1.0 / thisComp.frameDuration, isDuration = false)
Return type: Number.
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Argument type: t and fps are Numbers; isDuration is a Boolean.

Converts the value of t, which defaults to the current composition time, to an integer number of frames. The number

of frames per second is specified in the fps parameter, which defaults to the frame rate of the current composition

(thisC omp.f rameDurat ion). The isDuration parameter, which defaults to false, should be true if the t value repre-

sents a difference between two times instead of an absolute time. Absolute times are rounded down towards negative

infinity; durations are rounded away from zero (up for positive values).

framesToTime(frames, fps = 1.0 / thisComp.frameDuration) Return type: Number.

Argument type: frames and fps are Numbers.

The inverse of t imeToFrames. Returns the time corresponding to the frames parameter, which is required. It doesn't

have to be an integer. See t imeToFrames for explanation of the fps parameter.

timeToTimecode(t = time + thisComp.displayStartTime, timecodeBase = 30, isDuration = false) Return type: String.

Argument type: t and timecodeBase are Numbers; isDuration is a Boolean.

Converts the value of t to a String representing timecode. See t imeToFrames for an explanation of the t and

isDuration parameters. The timecodeBase value, which defaults to 30, specifies the number of frames in one second.

timeToNTSCTimecode(t = time + thisComp.displayStartTime, ntscDropFrame = false, isDuration = false) Return

type: String.

Argument type: t is a Number, ntscDropFrame and isDuration are Booleans.

Converts t to a String representing NTSC timecode. See t imeToFrames for an explanation of the t and isDuration

parameters. If ntscDropFrame is false (the default), the result String is NTSC non-drop timecode. If ntscDropFrame

is true, the result String is NTSC dropframe timecode.

timeToFeetAndFrames(t = time + thisComp.displayStartTime, fps = 1.0 / thisComp.frameDuration, framesPerFoot =
16, isDuration = false) Return type: String.

Argument type: t, fps, and framesPerFoot are Numbers; isDuration is a Boolean.

Converts the value of t to a String representing feet of film and frames. See t imeToFrames for an explanation of the

t, fps, and isDuration parameters. The framesPerFoot parameter specifies the number of frames in one foot of film. It

defaults to 16, which is the most common rate for 35mm footage.

timeToCurrentFormat(t = time + thisComp.displayStartTime, fps = 1.0 / thisComp.frameDuration, isDuration = false)
Return type: String.

Argument type: t and fps are Numbers; isDuration is a Boolean.

Converts the value of t to a String representing time in the current Project Settings display format. See t imeToFrames

for a definition of all of the parameters.

If you want more control over the look of timecode in your footage, use the timeToCurrentFormat expression to

generate the timecode instead of using the Timecode or Numbers effect. Create a text layer, add an expression to the

Source Text property, and enter timeToCurrentFormat in the expression text box. This method enables you to format

and animate the timecode text. In addition, the timecode uses the same display style defined by the current project

settings.
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Vector Math methods
Vector Math functions are global methods that perform operations on arrays, treating them as mathematical vectors.

Unlike built-in JavaScript methods, such as Math.s in, these methods are not used the Math prefix . Unless otherwise

specified, Vector Math methods are lenient about dimensions and return a value that is the dimension of the largest

Array, filling in missing elements with zeros. For example, the expression [10,  20]+[1,  2 ,  3]  returns [11,  22 ,  3] .

add(vec1, vec2) Return type: Array. Adds two vectors.

Argument type: vec1 and vec2 are Arrays.

sub(vec1, vec2) Return type: Array.

Argument type: vec1 and vec2 are Arrays.

Subtracts two vectors.

mul(vec, amount) Return type: Array.

Argument type: vec is an Array, amount is a Number.

Multiplies every element of the vector by the amount.

div(vec, amount) Return type: Array.

Argument type: vec is an Array, amount is a Number.

Divides every element of the vector by the amount.

clamp(value, limit1, limit2) Return type: Number or Array.

Argument type: value, limit1, and limit2 are Numbers or Arrays.

The value of each component of value is constrained to fall between the values of the corresponding values of limit1

and limit2.

dot(vec1, vec2) Return type: Number.

Argument type: vec1 and vec2 are Arrays.

Returns the dot (inner) product of the vector arguments.

cross(vec1, vec2) Return type: Array [2 or 3].

Argument type: vec1 and vec2 are Arrays [2 or 3].

Returns the vector cross product of vec1 and vec2. Refer to a math reference or JavaScript guide for more infor-

mation.

normalize(vec) Return type: Array.

Argument type: vec is an Array.

Normalizes the vector so that its length is 1.0. This is a short way of writing div(vec ,  length(vec)) .

length(vec) Return type: Number.

Argument type: vec is an Array.

Returns the length of vector vec.

length(point1, point2) Return type: Number.

Argument type: point1 and point2 are Arrays.
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Returns the distance between two points. The point2 parameter is optional. For example, length(point1 , point2) is

the same as length(sub(point1 ,  point2)) .

lookAt(fromPoint, atPoint) Return type: Array [3].

Argument type: fromPoint and atPoint are Arrays [3].

The argument fromPoint is the location in world space of the layer you want to orient. The argument atPoint is the

point in world space you want to point the layer at. The return value can be used as an expression for the Orientation

property, making the layer’s z-axis point at atPoint. This method is especially useful for cameras and lights. If you use

this on a camera, turn off auto-orientation. Example: lookAt(posit ion,  thisC omp.layer(1) .posit ion)

Random Numbers methods
seedRandom(seed, timeless=false) Return type: none.

Argument type: seed is a Number, timeless is a Boolean.

Takes the existing seed and increments it by a random value that depends on the layer’s index (number), stream

(property), and time. If timeless is true, the seed does not depend on time.

random() Return type: Number.

Returns a random number between 0 and 1.

random(maxValOrArray) Return type: Number or Array.

Argument type: maxValOrArray is a Number or Array.

If maxValOrArray is a Number, this method returns a number between 0 and maxValOrArray. If maxValOrArray is

an Array, this method returns an Array with the same dimension as maxValOrArray, with each component ranging

between 0 and the corresponding component of maxValOrArray.

random(minValOrArray, maxValOrArray) Return type: Number or Array.

Argument type: minValOrArray and maxValOrArray are Numbers or Arrays.

If minValOrArray and maxValOrArray are Numbers, this method returns a number between minValOrArray and

maxValOrArray. If the arguments are Arrays, this method returns an Array with the same dimension as the

argument with the greater dimension, with each component between the corresponding components of

minValOrArray and maxValOrArray. For example, the expression random([100, 200] , [300, 400]) returns an Array

whose first value is between 100 and 300 and whose second value is between 200 and 400. If the dimensions of the

two input Arrays don’t match, higher-dimension values of the the shorter Array are filled out with zeros.

gaussRandom() Return type: Number.

Returns a random number. The results have a Gaussian (bell-shaped) distribution. Approximately 90% of the results

are between 0 and 1, and the remaining 10% are outside this range.

gaussRandom(maxValOrArray) Return type: Number or Array.

Argument type: maxValOrArray is a Number or Array.

When maxValOrArray is a Number, this method returns a random number. Approximately 90% of the results are in

the 0 to maxValOrArray range, and the remaining 10% are outside of this range. When maxValOrArray is an Array,

this method returns an Array of random values, with the same dimension as maxValOrArray. Ninety percent of the

values range between 0 and the value in maxValOrArray, and the remaining 10% are outside of this range. The results

have a Gaussian (bell-shaped) distribution.



ADOBE AFTER EFFECTS 7.0
User Guide

575

gaussRandom(minValOrArray, maxValOrArray) Return type: Number or Array.

Argument type: minValOrArray and maxValOrArray are Numbers or Arrays.

If minValOrArray and maxValOrArray are Numbers, this method returns a random number. Approximately 90% of

the results are between minValOrArray and maxValOrArray, and the remaining 10% are outside of this range. If the

arguments are Arrays, this method returns an Array of random numbers with the same dimension as the argument

with the greater dimension. For each component, approximately 90% of the results are between the corresponding

components of minValOrArray and maxValOrArray, and the remaining 10% are outside of this range.The results

have a Gaussian (bell-shaped) distribution.

noise(valOrArray) Return type: Number.

Argument type: valOrArray is a Number or an Array [2 or 3].

Returns a number between 0 and the input value. Noise is not actually random, but is used when you want a

seemingly random number with some correlation between nearby samples. It is based on Perlin Noise. (See a

computer graphics reference book for more information.) Example: add(posit ion,  noise(posit ion)*50)

Interpolation methods
linear(t, value1, value2) Return type: Number or Array.

Argument type: t is a Number, and value1 and value2 are Numbers or Arrays.

Returns a value that linearly interpolates from value1 to value2 as t ranges from 0 to 1. Returns value1 when t <= 0.

Returns value2 when t >= 1.

linear(t, tMin, tMax, value1, value2) Return type: Number or Array.

Argument type: t, tMin, and tMax are Numbers, and value1 and value2 are Numbers or Arrays.

Returns value1 when t <= tMin. Returns value2 when t <= tMax. Returns a linear combination of value1 and value2

when tMin < t < tMax.

ease(t, value1, value2) Return type: Number or Array.

Argument type: t is a Number, and value1 and value2 are Numbers or Arrays.

Similar to l inear, except that the interpolation eases in and out so that the velocity is 0 at the start and end points.

This method results in a very smooth animation.

ease(t, tMin, tMax, value1, value2) Return type: Number or Array.

Argument type: t, tMin, and tMax are Numbers, and value1 and value2 are Numbers or Arrays.

Similar to l inear, except that the interpolation eases in and out so that the velocity is 0 at the start and end points.

This method results in a very smooth animation.

easeIn(t, value1, value2) Return type: Number or Array.

Argument type: t is a Number, and value1 and value2 are Numbers or Arrays.

Similar to ease, except that the tangent is 0 only on the value1 side and interpolation is linear on the value2 side.

easeIn(t, tMin, tMax, value1, value2) Return type: Number or Array.

Argument type: t, tMin, and tMax are Numbers, and value1 and value2 are Numbers or Arrays.

Similar to ease, except that the tangent is 0 only on the tMin side and interpolation is linear on the tMax side.
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easeOut(t, value1, value2) Return type: Number or Array.

Argument type: t is a Number, and value1 and value2 are Numbers or Arrays.

Similar to ease, except that the tangent is 0 only on the value2 side and interpolation is linear on the value1 side.

easeOut(t, tMin, tMax, value1, value2) Return type: Number or Array.

Argument type: t, tMin, and tMax are Numbers, and value1 and value2 are Numbers or Arrays.

Similar to ease, except that the tangent is 0 only on the tMax side and interpolation is linear on the tMin side.

See also

“Interpolation methods” on page 220

“To automatically ease speed” on page 231

Color Conversion methods
rgbToHsl(rgbaArray) Return type: Array [4].

Argument type: rgbaArray is an Array [4].

Converts a color in RGBA space to HSLA space. The input is an Array of normalized red, green, blue, and alpha

channel values, all in the range of 0.0 to 1.0. The resulting value is an Array of hue, saturation, lightness, and alpha

channel values, also in the range of 0.0 to 1.0. Example: rgbToHsl .e f fec t("Change C olor")("C olor  To Change")

hslToRgb(hslaArray) Return type: Array [4].

Argument type: hslaArray is an Array [4].

Converts a color in HSLA space to RGBA space. This is the opposite of rgbToHsl .

Other Math methods
degreesToRadians(degrees) Return type: Number.

Argument type: degrees is a Number.

Converts degrees to radians.

radiansToDegrees(radians) Return type: Number.

Argument type: radians is a Number.

Converts radians to degrees.

Comp attributes and methods
layer(index) Return type: Layer, Light, or Camera.

Argument type: index is a Number.

Retrieves the layer by number (order in the Timeline panel). Example: thisC omp. layer(3)

layer(“name”) Return type: Layer, Light, or Camera.

Argument type: name is a String.
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Retrieves the layer by name. Names are matched by layer name, or source name if there is no layer name. If duplicate

names exist, After Effects uses the first one in the Timeline panel. Example: thisC omp.layer("S ol id  1")

layer(otherLayer, relIndex) Return type: Layer, Light, or Camera.

Argument type: otherLayer is a Layer object, and relIndex is a Number.

Retrieves the layer that is relIndex layers above or below otherLayer. For example, layer(thisL ayer,  -2)  returns the

layer that is two layers higher in the Timeline panel than the layer on which the expression is written.

marker(“name“) Return type: Number.

Argument type: name is a String.

Retrieves the time of a composition-time marker. For example, you can use this in an expression written on a layer’s

opacity property to to fade out at the time where the marker resides:

markTime = thisC omp.marker(1) ;  l inear(t ime,  markTime - .5 ,  markTime,  100,  0)

numLayers Return type: Number.

Returns the number of layers in the composition.

activeCamera Return type: Camera.

Returns the Camera object for the camera through which the composition is rendered at the current frame. This is

not necessarily the camera through which you are looking in the Composition panel.

width Return type: Number.

Returns the composition’s width, in pixels.

height Return type: Number.

Returns the composition’s height, in pixels.

duration Return type: Number.

Returns the composition’s duration, in seconds.

displayStartTime Return type: Number.

Returns the composition start time, in seconds.

frameDuration Return type: Number.

Returns the frame duration, in seconds.

shutterAngle Return type: Number.

Returns the shutter-angle value of the composition, in degrees.

shutterPhase Return type: Number.

Returns the shutter-phase of the composition, in degrees.

bgColor Return type: Array [4].

Returns the background color of the composition.

pixelAspect Return type: Number.

Returns the pixel aspect ratio of the composition.

name Return type: String.
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Returns the name of the composition.

Footage attributes and methods
To use footage from the Project panel as an object in an expression, use the global footage method, as in

footage(" f i lename") , and then use any of the attributes below. You can also access a footage object using the source

attribute on a layer whose source is a footage item.

width Return type: Number.

Returns the width of the footage, in pixels.

height Return type: Number.

Returns the height of the footage, in pixels.

duration Return type: Number.

Returns the duration of the footage, in seconds.

frameDuration Return type: Number.

Returns the duration of a frame, in seconds.

pixelAspect Return type: Number.

Returns the pixel aspect ratio of the footage.

name Return type: String.

Returns the name of the footage.

Layer subobjects attributes and methods
source Return type: Comp or Footage.

Returns the source Comp or source Footage object for the layer. Default time is adjusted to the time in the source.

Example: source. layer(1) .posit ion

effect(name) Return type: Effect.

Argument type: name is a String.

After Effects finds the effect by its name in Effect Controls. The name can be the default name or a user-defined

name. If there is more than one effect with the same name, the effect closest to the top of Effect Controls is used.

Example: ef fec t("Fast  Blur")("Blurr iness")

effect(index) Return type: Effect.

Argument type: index is a Number.

After Effects finds the effect by its index in Effect Controls, starting at 1 and counting down from the top.

mask(name) Return type: Mask.

Argument type: name is a String.

The name can be the default name or a user-defined name. Example: mask("Mask 1")

mask(index) Return type: Mask.

Argument type: index is a Number.
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After Effects finds the mask by its index in the Timeline panel, starting at 1 and counting from the top.

Layer General attributes and methods
width Return type: Number.

Returns the width of the layer, in pixels. It is the same as source.width.

height Return type: Number.

Returns the height of the layer, in pixels. It is the same as source.height .

index Return type: Number.

Returns the index number of the layer in the composition.

parent Return type: Layer, Light, or Camera.

Returns the parent Layer object of the layer, if there is one. Example: posit ion[0]  + parent .width

hasParent Return type: Boolean.

Returns true if the layer has a parent or false if it doesn’t.

inPoint Return type: Number.

Returns the In point of the layer, in seconds.

outPoint Return type: Number.

Returns the Out point of the layer, in seconds.

startTime Return type: Number.

Returns the start time of the layer, in seconds.

hasVideo Return type: Boolean.

Returns true if the layer has video, or false if it doesn’t.

hasAudio Return type: Boolean.

Returns true if the layer has audio or false if it doesn’t.

active Return type: Boolean.

Returns true if the layer’s video switch  is on or false if it isn’t.

audioActive Return type: Boolean.

Returns a true value if the layer’s audio switch  is on or a false if it isn’t.

Layer Properties attributes and methods
When you add masks, effects, paint, or text to a layer or apply motion tracker to it, After Effects adds new properties

to the Timeline panel. There are too many of these properties to list here, so use the pick whip to learn the syntax for

referring to them in your expressions. For any of the levels that represent groups of properties, you can use the name

and numEntr ies properties to return the user-specified name and the number of entries in the group. For example,

text("Animators") .numEntr ies  returns the number of animators on your text layer.

anchorPoint Return type: Property [2 or 3].

Returns the anchor point value of the layer in the layer’s space.
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position Return type: Property [2 or 3].

Returns the position value of the layer, in world space if the layer has no parent or in the parent’s layer space if there

is a parent.

scale Return type: Property [2 or 3].

Returns the scale value of the layer, expressed as a percentage.

rotation Return type: Property.

Returns the rotation value of the layer in degrees. For a 3D layer, it returns the z rotation value in degrees.

opacity Return type: Property [1].

Returns the opacity value for the layer, expressed as a percentage.

audioLevels Return type: Property [2].

Returns the value of the Audio Levels property of the layer, in decibels. This is a 2D value; the first value represents

the left audio channel, and the second value represents the right. The value is not the amplitude of the source

material’s audio track; instead, it is the value of the keyframed Audio Levels property.

timeRemap Return type: Property.

Returns the value of the Time Remap property, in seconds, if Time Remap is enabled.

marker.key(index) Return type: Marker Number.

Argument type: index is a Number.

Returns the value of the Marker Number property for a layer. The only methods and attributes available from marker

are key, nearestKey, and numKeys.

marker.key(name) Return type: Marker Number.

Argument type: name is a String.

Returns the name of the Marker Number property for a layer. The name value is the name of the marker, as typed in

the comment field in the marker dialog box, for example, marker.key("ch1") . The value for a marker key is a String,

not a Number. Example:

m1 = marker.key("Star t") . t ime;  m2 = marker.key("End") . t ime;  l inear(t ime,  m1,  m2,  0 ,  100) ;

marker.nearestKey Return type: Marker Number.

Returns the value for the marker that is nearest to the current time.

marker.numKeys Return type: Number.

Returns the total number of layer-time markers.

name Return type: String.

Returns the name of the layer.

Layer 3D attributes and methods
orientation Return type: Property [3].

Returns the 3D orientation value, in degrees, for a 3D layer.

rotationX Return type: Property [1].
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Returns the x rotation value, in degrees, for a 3D layer.

rotationY Return type: Property [1].

Returns the y rotation value, in degrees, for a 3D layer.

rotationZ Return type: Property [1].

Returns the z rotation value, in degrees, for a 3D layer.

lightTransmission Return type: Property [1].

Returns the value of the Light Transmission property for a 3D layer.

castsShadows Return type: Property.

Returns a value of 1.0 if the layer casts shadows.

acceptsShadows Return type: Property.

Returns a value of 1.0 if the layer accepts shadows.

acceptsLights Return type: Property.

Returns a value of 1.0 if the layer accepts lights.

ambient Return type: Property.

Returns the ambient component value as a percentage.

diffuse Return type: Property.

Returns the diffuse component value as a percentage.

specular Return type: Property.

Returns the specular component value as a percentage.

shininess Return type: Property.

Returns the shininess component value as a percentage.

metal Return type: Property.

Returns the metal component value as a percentage.

Layer Space Transforms methods
toComp(point, t=time) Return type: Array [2 or 3].

Argument type: point is an Array [2 or 3], and t is a Number.

Transforms a point from layer space to composition space. Example: toC omp(anchorPoint) .

fromComp(point, t=time) Return type: Array [2 or 3].

Argument type: point is an Array [2 or 3], and t is a Number.

Transforms a point from composition space to layer space. The resulting point in a 3D layer may have a nonzero

value even though it is in layer space. Example: f romC omp(thisC omp. layer(2) .posit ion).

toWorld(point, t=time) Return type: Array [2 or 3].

Argument type: point is an Array [2 or 3], and t is a Number.
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Transforms a point from layer space to view-independent world space. Example: toWorld.ef fec t( "Bulge")("Bulge

C enter")

fromWorld(point, t=time) Return type: Array [2 or 3].

Argument type: point is an Array [2 or 3], and t is a Number.

Transforms a point from world space to layer space. Example: f romWorld(thisC omp. layer(2) .posit ion)

toCompVec(vec, t=time) Return type: Array [2 or 3].

Argument type: vec is an Array[2 or 3], and t is a Number.

Transforms a vector from layer space to composition space. Example: toC ompVec([1 ,  0])

fromCompVec(vec, t=time) Return type: Array [2 or 3].

Argument type: vec is an Array[2 or 3], and t is a Number.

Transforms a vector from composition space to layer space. Example (2D layer):

dir=sub(posit ion,  thisC omp.layer(2) .posit ion) ;  f romC ompVec(dir)

toWorldVec(vec, t=time) Return type: Array [2 or 3].

Argument type: vec is an Array[2 or 3], and t is a Number.

Transforms a vector from layer space to world space. Example:

p1 = ef fec t("Eye Bulge  1")("Bulge  C enter") ;  p2  = ef fec t("Eye Bulge  2")("Bulge  C enter") ;  toWorld(sub(p1,  p2))

fromWorldVec(vec, t=time) Return type: Array [2 or 3].

Argument type: vec is an Array [2 or 3], and t is a Number.

Transforms a vector from world space to layer space. Example: f romWorld(thisC omp. layer(2) .posit ion)

fromCompToSurface(point, t=time) Return type: Array [2].

Argument type: point is an Array [2 or 3], and t is a Number.

Projects a point located in composition space to a point on the surface of the layer (zero z-value) at the location where

it appears when viewed from the active camera. This is useful for setting effect control points. Use with 3D layers

only.

Camera attributes and methods
Camera objects have the same attributes and methods as Layer objects, except for source, ef fec t , mask, width,

height , anchorPoint , sca le , opacity, audioLevels , t imeRemap, and all of the material properties.

pointOfInterest Return type: Property [3].

Returns the camera’s point of interest values in world space.

zoom Return type: Property.

Returns the camera’s zoom values in pixels.

depthOfField Return type: Property.

Returns 1 if the camera’s Depth Of Field property is on, or returns 0 if it is off.

focusDistance Return type: Property.

Returns the camera’s focus distance values, in pixels.
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aperture Return type: Property.

Returns the camera’s aperture value, in pixels.

blurLevel Return type: Property.

Returns the camera’s blur level value as a percentage.

active Return type: Boolean.

Returns true if the camera’s video switch  is on, the current time is between the camera’s In and Out points, and

it is the first such camera listed in the Timeline panel. Returns false otherwise.

See also

“About cameras” on page 180

“Camera settings” on page 181

Light attributes and methods
Light objects have the same attributes and methods as Layer objects, except for source, ef fec t , mask, width, height,

anchorPoint , sca le , opacity, audioLevels , t imeRemap, and all of the material properties.

pointOfInterest Return type: Property [3].

Returns the light’s point of interest values in world space.

intensity Return type: Property.

Returns the light’s intensity values as a percentage.

color Return type: Property [4].

Returns the light’s color value.

coneAngle Return type: Property.

Returns the light’s cone angle, in degrees.

coneFeather Return type: Property.

Returns the light’s cone feather value as a percentage.

shadowDarkness Return type: Property.

Returns the light’s shadow darkness value as a percentage.

shadowDiffusion Return type: Property.

Returns the light’s shadow diffusion value, in pixels.

See also

“About lights and points of interest” on page 183

Effect attributes and methods
active Return type: Boolean.

Returns true if the effect is turned on in both the Timeline panel and Effect Controls, or false if it is turned off in

either panel.
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param(name) Return type: Property.

Argument type: name is a String.

Returns a property within an effect. Effect point controls are always in layer space. Example: ef fec t("Bulge")("Bulge

Height")

param(index) Return type: Property.

Argument type: index is a Number.

Returns a property within an effect. Effect point controls are always in layer space. For example, ef fec t("Bulge")(4)

returns the Bulge Height property.

Mask attributes and methods
Note: You cannot access the mask shape with an expression.

maskOpacity Return type: Property.

Returns the mask’s opacity value as a percentage.

maskFeather Return type: Property.

Returns the mask’s feather value, in pixels.

maskExpansion Return type: Property.

Returns the mask’s expansion value, in pixels.

invert Return type: Boolean.

Returns true if the mask is inverted or false if it is not.

Property attributes and methods
value Return type: Number or Array.

Returns the property’s value at the current time.

valueAtTime(t) Return type: Number or Array.

Argument type: t is a Number.

Returns the property’s value at the specified time, in seconds.

velocity Return type: Number or Array.

Returns the temporal velocity value at the current time. For spatial properties, such as Position, it returns the tangent

vector value. The result is the same dimension as the property.

velocityAtTime(t) Return type: Number or Array.

Argument type: t is a Number.

Returns the temporal velocity value at the specified time.

speed Return type: Number.

Returns a 1D, positive speed value equal to the speed at which the property is changing at the default time. This

element can be used only for spatial properties.

speedAtTime(t) Return type: Number.
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Argument type: t is a Number.

Returns the spatial speed value at the specified time.

wiggle(freq, amp, octaves=1, ampMult=.5, t=time) Return type: Number or Array.

Argument type: freq, amp, octaves, ampMult, and t are Numbers.

Randomly shakes (wiggles) the value of the property. The freq value is in wiggles per second, amp is in units of the

property to which it is applied, octaves is the number of octaves of noise to add together, ampMult is the amount that

amp is multiplied by for each octave, and t is the base start time. Example: posit ion.wigg le(7 ,  30 ,  3)

temporalWiggle(freq, amp, octaves=1, ampMult=.5, t=time) Return type: Number or Array.

Argument type: freq, amp, octaves, ampMult, and t are Numbers.

Samples the property at a wiggled time. The freq value is in wiggles per second, amp is in units of the property to

which it is applied, octaves is the number of octaves of noise to add together, ampMult is the amount that amp is

multiplied by for each octave, and t is the base start time. For this function to be meaningful, the property it samples

must be animated, because the function alters only the time of sampling, not the value. Example: sca le . tempora l-

Wiggle(5 ,  .2)

smooth(width=.2, samples=5, t=time) Return type: Number or Array.

Argument type: width, samples, and t are Numbers.

Applies a box filter to the value of the property at the specified time, and smooths the result over time. The width

value is the range of time (in seconds) over which the filter is averaged. The samples value is the number of discrete

samples evenly spaced over time. Generally, you’ll want samples to be an odd number so that the value at the current

time is included in the average. Example: posit ion.smooth( .1 ,  5)

loopIn(type=“cycle”, numKeyframes=0) Return type: Number or Array.

Loops a segment of time that is measured from the first keyframe on the layer forward toward the layer’s Out point.

The loop occurs from the layer’s In point to the first keyframe on the layer. The segment to loop is delineated by the

specified number of keyframes. The numKeyframes value sets the number of keyframe segments to loop; the

specified range is measured from the first keyframe. For example, loopIn(“c ycle”, 1) loops the segment bounded by

the first and second keyframes. The default value of 0 means that all keyframes will loop.

loopOut(type=“cycle”, numKeyframes=0) Return type: Number or Array.

Loops a segment of time that is measured from the last keyframe on the layer back toward the layer’s In point. The

loop occurs from the last keyframe on the layer to the layer’s Out point. The segment to loop is delineated by the

specified number of keyframes. The numKeyframes value sets the number of keyframe segments to loop; the

specified range is measured backward from the last keyframe. For example, loopOut(“c ycle”,  1)  loops the segment

bounded by the last keyframe and second-to-last keyframe. The default value of 0 means that all keyframes will loop.

loopInDuration(type=“cycle”, duration=0) Return type: Number or Array.

Loops a segment of time that is measured from the first keyframe on the layer forward toward the layer’s Out point.

The loop occurs from the layer’s In point to the first keyframe on the layer. The segment to loop is delineated by the

specified duration. The duration value sets the number of composition seconds in a segment to loop; the specified

range is measured from the first keyframe. For example, loopInDurat ion(“c ycle”,  1)  loops the first second of the

entire animation. The default of 0 means that the segment to loop begins at the layer Out point.

loopOutDuration(type=“cycle”, duration=0) Return type: Number or Array.
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Loops a segment of time that is measured from the last keyframe on the layer back toward the layer’s In point. The

loop occurs from the last keyframe on the layer to the layer’s Out point. The segment to loop is delineated by the

specified duration. The duration value sets the number of composition seconds in a segment to loop; the specified

range is measured backward from the last keyframe. For example, loopOutDurat ion(“c ycle”, 1) loops the last second

of the entire animation. The default of 0 means that the segment to loop begins at the layer In point.

key(index) Return type: Key.

Argument type: index is a Number.

Returns the Key object by number. For example, key(1) returns the first key. When you access a Key object, you can

get Time, Index, and Value properties from it. For example, the following expression gives you the value of the third

position key: posit ion.key(3) .va lue. The following expression, when written on a layer’s animated Opacity property,

ignores the keyframe values and uses only the keyframes’ placement in time to determine where a flash should occur:

d = Math.abs(t ime -  nearestKey(t ime) . t ime) ;  easeOut(d,  0 ,  .1 ,  100,  0)

key(markerName) Return type: Key.

Returns the keyframe for the marker key with this name. Use only on marker properties.

nearestKey(t) Return type: Key.

Returns the keyframe nearest to a designated time.

numKeys Return type: Number.

Returns the number of keyframes in a property.

propertyGroup(countUp = 1) Return type: Group.

Returns a group of properties relative to the property on which the expression is written. For example, if you add the

proper tyGroup(1)  expression to a Brush stroke’s Rotation property, the expression targets the Transform property

group, which contains the Rotation property. If you add proper tyGroup(2) instead, the expression targets the Brush

property group. This lets you establish name-independent relationships in the property hierarchy. This is especially

useful when duplicating properties that contain expressions.

propertyIndex Return type: Number.

Returns the index of a property relative to other properties in its property group, including property groups within

masks, effects, text animators, selectors, trackers, and track points.

Key attributes and methods
value Return type: Number or Array.

Returns the value of the keyframe.

time Return type: Number.

Returns the time of the keyframe.

index Return type: Number.

Returns the index of the keyframe.
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Pick-whip expression examples

Example: To turn a dial and illuminate a lamp
The following example shows how to use the pick whip to link opacity values to rotation values so that as rotation

changes, opacity changes, too. This expression could be used to simulate dimming a light bulb while rotating a dial.

1 Start with a composition containing two layers: one to be used as the switch that you’ll rotate, and one to be used

as the object that changes in opacity as you rotate the switch. This example uses two Adobe Illustrator files and

named one “robot” and the other “switch”. (See “About layers” on page 149.)

2 Create keyframes to animate the rotation of the switch layer. (See “Using keyframes” on page 192.)

3 Select the Opacity property for the robot layer and choose Animation > Add Expression. A default expression

appears under the property.

4 Click the pick whip next to the Opacity expression and drag it to the Rotation property for the switch layer. After

Effects automatically fills in the following expression:

thisC omp. layer("switch.ai ") . rotat ion

5 Preview the animation. Notice that the Opacity property of the robot layer is animated, yet there are no opacity

keyframes. (See “Methods for previewing compositions” on page 134.)

Note:Make sure to use rotation values that are compatible with the Opacity property. For example, opacity values range

from 0 to 100, so rotating the switch layer backward using a negative value results in an opacity value of 0.

Expression linking opacity and rotation.

Example: To rotate the hands of a clock
The following example shows how to use the pick whip to link rotation values between layers. Quickly animate the

hands on a clock so that as the hour hand moves from hour to hour, the minute hand rotates the full circumference

of the clock face. This type of animation would take a long time to create if you had to set each keyframe for both

hand layers, but with the pick whip, you can do it in a matter of minutes.

1 Import or create two layers: an hour hand and a minute hand. (See “About layers” on page 149.)

2 Position them as if they were hands on a clock, and then set the anchor points for the hands at the center of the

clock. (See “About anchor points” on page 206.)

3 Set Rotation keyframes for the hour hand. (See “Using keyframes” on page 192.)

4 Select the Rotation property for the minute hand and choose Animation > Add Expression.
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5 Drag the pick whip to the hour hand’s Rotation property. The following expression appears:

thisC omp.layer("hour hand") .rotat ion

6 To make the minute hand rotate 12 times as fast as the hour hand, add *12 at the end of the expression as follows:

thisC omp.layer("hour hand") .rotat ion*12

Example: To increase blur with depth
The following example shows how to use the pick whip to control blur by a layer’s position in z-space. This expression

is useful for making an object blurrier as it travels farther away in space.

1 Import or create a layer in the shape of a star. (See “About layers” on page 149.)

2 Click the 3D switch for the layer and set Position keyframes so that it moves farther away in z-space. (See “To

designate a layer as 3D” on page 175 and “Using keyframes” on page 192.)

3 Apply the Fast Blur effect. (See “Applying and controlling effects” on page 348.)

4 Select the Fast Blur effect’s Blurriness property in the Timeline panel and choose Animation > Add Expression.

5 Drag the pick whip to the Position property. The following expression appears:

posit ion[2]

6 If the blur is too intense, cut the blur amount by one-fifth by adding  /5 to the end of the expression as follows:

posit ion[2]/5

Manually entered expression examples

Example: To position one layer between two others
This example expression positions and maintains one layer at a balanced distance between two other layers. To

achieve this effect, you need three layers in your composition.

1 Start with three layers. (See “About layers” on page 149.)

2 Create motion paths for the first two layers in the Timeline panel. (See “To create a motion path” on page 210.)

3 Select the Position property for the third layer and choose Animation > Add Expression.

4 Select the default expression text and type the following:

(thisC omp. layer(1) .posit ion + thisC omp.layer(2) .posit ion)* .5

Example: To create a trail of images
This example expression instructs a layer to be at the same position as the next higher layer in the Timeline panel,

but delayed by a specified amount of time (in this case, 0.5 seconds). You can set similar expressions for the other

geometric properties. This expression requires two or more layers.

1 Start with two solids that are scaled to approximately 30%. (See “To create a solid-color layer” on page 150.)

2 Create a motion path for the first layer. (See “To create a motion path” on page 210.)

3 Select the Position property for the second layer and choose Animation > Add Expression.

4 Select the default expression text and type:

thisC omp.layer(thisL ayer,  -1) .posit ion.va lueAtTime(t ime -  .5)
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5 Duplicate the last layer five times. All layers follow the same path, and each is delayed 0.5 seconds from the

previous. (See “To duplicate a layer” on page 157.)

Example: To create a bulge between two layers
This example expression synchronizes the Bulge Center parameter of the Bulge effect in one layer with the position

of another layer. For example, you can create an effect that looks like a magnifying glass moving over a layer, with

the contents under the magnifying glass bulging as the lens (that is, the overlying layer) moves. This expression uses

the fromWorld element, which makes the expression work correctly regardless of whether you move the magnifying

glass layer or the underlying layer. You can rotate or scale the underlying layer, and the expression stays intact.

You can also use other effects, such as Ripple, with this expression.

1 Start with two layers. Make one layer a magnifying glass or similar object with a hole in the middle and name it

Magnifier. (See “About layers” on page 149.)

2 Create a motion path for the magnifying glass layer. (See “To create a motion path” on page 210.)

3 Apply the Bulge effect to the other layer. (See “Applying and controlling effects” on page 348.)

4 Select the Bulge effect’s Bulge Center property in the Timeline panel and choose Animation > Add Expression.

5 Select the default expression text and type the following:

f romWorld(thisC omp. layer("Magnif ier") .posit ion)

Example: To create a circular movement in one layer
You can create an expression without using properties from other layers. For example, you can make a layer revolve

in a perfect circle or move back and forth diagonally.

1 Start with one layer. (See “About layers” on page 149.)

2 Select the Position property for the layer and choose Animation > Add Expression.

3 Select the default expression text and type:

[( thisC omp.width/2) ,  ( thisC omp.height/2)]  + [Math.s in(t ime)*50,  -Math.cos(t ime)*50]
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Chapter 19: Rendering and exporting

Rendering a movie

About rendering
When you create output, the layers of a composition and each layer’s masks, effects, and properties are rendered

frame by frame into one or more output files or, in the case of a sequence, into a series of consecutive files.

Making a movie from your final composition can take a few minutes or many hours, depending on the composition’s

frame size, quality, complexity, and compression method. When you place your composition in the render queue, it

becomes a render item that uses the render settings assigned to it. As After Effects renders the item, you are unable

to work in the program. An audio alert indicates when rendering is complete.

After Effects provides a variety of formats and compression types for rendering output; the format you choose

depends on the medium from which you’ll play your final output or on the requirements of your hardware, such as

a video-editing system.

You can render movies to use in a wide variety of ways, including the following:

• To play on systems that have a movie player application (such as Apple QuickTime Player).

• To record on videotape for playback on NTSC and PAL broadcast television equipment.

• To record to 35mm film for editing into a cinema release.

• To play from DVD, from CD-ROM, or as streaming video on the World Wide Web.

• To import into nonlinear editing systems, such as Adobe Premiere Pro, Avid, or Apple Final Cut Pro, for final

output.

• To broadcast for high-definition television.

To render to film or video, you must have the proper hardware for film or video transfer, or have access to a service

bureau that can provide transfer services.

After Effects includes a Render Queue panel, in which you can specify items to be rendered, each with its own

rendering settings. The Render Queue panel allows you to render any number of compositions unattended and in

any order. You can also render each composition into multiple output formats in one session.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

Supported file formats for output
When you have finished assembling and animating an After Effects composition, you can create many types of

output from a single composition, including a compressed movie ready for videotape or an image sequence of the

composition frames.

Adobe After Effects 7.0 Professional supports file formats at 32, 16, and 8 bits per channel (bpc). The Standard

edition exports these files at 8 bpc. Unless otherwise noted, all file formats are exported at 8 bpc.
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Supported video and animation file formats

You can output the following video and animation file formats from After Effects:

• 3GPP (3GP, 3G2, AMC; requires QuickTime 6.5 or later)

• Animated GIF (GIF)

• Cineon (CIN, DPX; 16 and 32 bpc converted to 10 bpc)

• ElectricImage (IMG, EIZ)

• Filmstrip (FLM)

• FLC (FLC)

• FLI (FLI)

• MPEG-2 (Windows only)

• MPEG-2 DVD (Windows only)

• MPEG-4 (requires QuickTime)

• OMF (Pro only)

• QuickTime (MOV, DV; requires QuickTime for 8 bpc and codec support for 16 bpc)

• RealMedia (RAM, RM; Windows only)

• SWF

• Video for Windows (AVI)

• Windows Media (Windows only)

After Effects can read and render QuickTime files in 16-bpc color depth. When you select a QuickTime codec that

supports 16-bpc color depth in the Output Module dialog box, such as the None16 codec, Trillions Of Colors is

available. (See “Supported file formats for import” on page 69.) To find out whether your video codec supports 16-bpc

color depth, contact the manufacturer directly.

Supported video project file formats

• Advanced Authoring Format (AAF; Pro only)

• Adobe Premiere Pro project (PRPROJ; Windows only)

Supported still-image file formats

You can output the following still image or still image sequence file formats from After Effects:

• Adobe Photoshop (PSD, 8, 16, and 32 bpc)

• Bitmap (BMP, RLE)

• CompuServe GIF (GIF)

• Maya IFF (IFF; 16 bpc)

• JPEG (JPG, JPE)

• Open EXR (EXR)

• PCX (PCX)

• Pict (PCT, PIC)

• Pixar (PXR)
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• PNG (PNG)

• Radiance (HDR, RGBE, XYZE)

• RLE (RLE)

• SGI (SGI, BW, RGB, 16 bpc)

• Targa (TGA, VBA, ICB, VST)

• TIFF (TIF; 8, 16, and 32 bpc)

Note: File formats that use Adobe Photoshop plug-ins include bitmap, PCX, Pixar, and PNG.

Supported audio file formats

You can output the following audio file formats from After Effects:

• AU audio file (AU)

• Audio Interchange File Format (AIFF)

• MP3 (MP3)

• WAV

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

See also

“Supported file formats for import” on page 69

About high-definition (HD) video
High-definition video refers to any video format with higher resolution than standard-definition (SD) video formats,

such as NTSC and PAL. There are many competing HD video formats, but the most common have a resolution of

1280 x 720 or 1920 x 1080, with a widescreen aspect ratio of 16:9.

HD video formats include interlaced and noninterlaced varieties. Typically, the highest-resolution formats are inter-

laced at the higher frame rates, because noninterlaced video at this resolution would require a prohibitively high data

rate.

HD video formats are designated by their vertical resolution, scan mode, and frame or field rate (depending on the

scan mode). For example, 1080i60 denotes interlaced scanning of 60 interlaced 1920 x 1080 fields per second,

whereas 720p30 denotes progressive scanning of 30 noninterlaced 1280 x 720 frames per second. In both cases, the

frame rate is approximately 30 frames per second.

Each program in Adobe Production Studio (Adobe Premiere Pro, Adobe After Effects, Adobe Audition, and Adobe

Encore DVD) includes preset settings that are designed for working with various HD formats. Some of the most

common HD video formats you may encounter include the following:

DVCPRO HD Panasonic’s high-definition variant of its DVCPRO format, which also includes DVCPRO25 and

DVCPRO50. Whereas DVCPRO25 and DVCPRO50 support data rates of 25Mbit/s and 50Mbit/s, respectively,

DVCPRO HD supports a data rate of 100Mbit/s, from which it gets its other name, DVCPRO100.
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HDCAM Sony’s high-definition version of their Digital Betacam format. A variant called HDCAM SR uses a tape

with a higher particle density to record video with greater color sampling and at higher bit rates. However, HDCAM

SR is supported by decks only, and not camcorders.

HDV Developed jointly by several companies, HDV employs a form of MPEG-2 compression to enable high-

definition video to be encoded on standard miniDV cassette media.

H.264 Also known as MPEG-4 part 10 and AVC (Advanced Video Coding), H.264 can deliver video over a range of

bitrates more efficiently than previous standards. For example, H.264 can deliver the same quality as MPEG-2 at half

the data rate. H.264 is built into the Apple QuickTime 7 multimedia architecture, and will be supported by both of

the rival next-generation DVD formats, HD-DVD and Blu-ray Disc.

Uncompressed HD Refers to high-definition video in an uncompressed format. Without compression to reduce the

video’s data rate, uncompressed video requires relatively fast computer processors, hard disks, and a specialized

capture device.

WM9 HDTV Microsoft’s high-definition delivery format is among numerous formats included in the Windows

Media 9 (WM9) framework. By employing an aggressive compression scheme, WM9 HDTV permits high-

definition video encoding and playback at relatively low data rates.

Creating motion-picture film
If you intend to display your finished project on motion picture film, you should plan your workflow carefully. You

may employ a matchback process, in which you shoot on film, transfer to video, and then conform the film negative

to your edits. On the other hand, you may choose to shoot and edit using a video format (ideally, a high-definition

format) and transfer the finished project to film. In any case, you will need to consider the important ways film and

video formats differ—such as in their image resolutions and frame rates—and how to reconcile those differences.

For the production phase, you will need to consider the acquisition format that best suits your needs. During post-

production, you may need to transfer the source footage to the appropriate format for editing, effects, and sound

design (using programs such as Adobe Premiere Pro, Adobe After Effects, and Adobe Audition). When exporting

from post-production software, you must determine the file settings appropriate to the film stock you will use, or

decide how to best translate your editing decisions to film. If you choose to transfer video to film, it’s likely you will

employ a facility that can accomplish the transfer using a film recorder, a device that prints video frames to motion

picture film frames. To determine the best course, consult the production and post-production facilities that will

provide the services necessary to deliver the project on film before you begin.

Default rendering order
The order in which After Effects renders the various parts of a composition can affect the look of some visual effects

in a rendered movie. An understanding of how After Effects renders a composition will help you get the results you

want.

In rendering a composition, After Effects processes 2D layers in the order in which they are listed in the Timeline

panel, starting at the bottom of the list. However, After Effects processes 3D layers in Z order within their 3D bins.

(See “About 3D rendering” on page 625.) In processing each layer, After Effects processes changes from the top

down, as these three categories appear in the Timeline panel: first the masks, then effects, and finally the transfor-

mations. The blending modes and track mattes are processed after that. After Effects processes elements with

multiple effects in the order in which they are listed in the Effect Controls and the Timeline panels.
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Changing the rendering order
Sometimes, projects require a visual effect that cannot be achieved by using the default rendering order. For example,

you may be constructing an animation in which you want a rotated object to have a drop-shadow effect. By default,

After Effects renders an effect before rotation, which creates shadows that all have different light-source orientations.

To render the animation so that the shadows appear as if created by a single light source, you need to apply rotation

before you apply the drop-shadow effect.

Although you can’t instruct After Effects to change the order of processing within a layer, there are three ways to get

the rendering order you want: applying the Transform effect; including an adjustment layer above the layer; or

nesting or precomposing.

Transform effect

Apply Transform effects when you want a transform property to render before another effect. These transform

changes will be rendered before subsequent effects. Other transform properties, set in the Timeline panel, will be

rendered last.

Adjustment layer

Use an adjustment layer in your composition when you want to change rendering order and apply transform

properties or effects to more than one layer at a time. When you apply an effect to an adjustment layer, After Effects

renders the effect after rendering all properties in the other layers. To apply an adjustment layer to some (but not all)

of the layers below it, you must either nest or precompose the adjustment layer with those layers.

Nesting or precomposing

Use either nesting or precomposing to change the rendering order while also applying an effect to continuously

rasterized or collapsed layers. To make an effect render after a transform property, apply the effect to the nested

composition instead of to the layer inside that composition.

See also

“To create a new adjustment layer” on page 152

“Organizing a project using nesting” on page 60

“To precompose layers” on page 133

To make a movie from a composition
1 Save the project, and then do one of the following:

• Select the composition in the Project panel, choose Composition > Make Movie, specify the name and location of

the output file, and then click Save.

• Choose Window > Render Queue, and then drag the composition you want to render from the Project panel to

the Render Queue panel. Default render settings and output module templates are assigned automatically.

2 Click the underlined setting to the right of the Render Settings heading to change the default render settings

template, or click the triangle to the right of the Render Settings heading to choose a render settings template.

3 Choose a Log type from the Log menu.

4 Click the underlined setting to the right of the Output Module heading to change the default output module

settings template, or click the triangle to the right of the Output Module heading to choose an output module settings

template.
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5 Click the underlined text after Output To to specify the name and location of the output file.

Note: You can locate a previously rendered item or check the destination of a queued render item by expanding the

Output Module and clicking the underlined file path listed below it, or by right-clicking (Windows) or Control-clicking

(Mac OS) the Output Module.

6 Select the Render option under the Render column heading. The status of the item changes to Queued.

7 Click Render. First, After Effects translates each layer or nested composition into a usable format with its masks,

effects, and layer transformations. Next, After Effects applies and translates any included blending modes. Finally,

After Effects sends the composited frame to each output module to create the final movie.

Note: To view more information about the composition as it renders, click the triangle to the left of Current Render

Details. To view details of a completed rendering, review the log file.

See also

“To work in the Render Queue panel” on page 602

“To change render settings” on page 604

“To change output module settings” on page 607

To render with OpenGL
If you have an OpenGL card that supports OpenGL 1.5 or later, you can use OpenGL to render in After Effects by

using hardware acceleration. You can view information about your OpenGL card by choosing Edit > Preferences >

Previews (Windows) or After Effects > Preferences > Previews (Mac OS) and clicking the OpenGL Info button.

Note that only features supported by OpenGL and your graphics card will be rendered into the final movie. If your

card doesn’t support advanced OpenGL features, don’t use OpenGL to render. For a list of features supported by

OpenGL, see “Supported OpenGL features” on page 140.

❖ Do one of the following:

• Click the underlined text next to Render Settings in the Render Queue panel, and select Use OpenGL Renderer.

• Choose Composition > Composition Settings, click the Advanced tab, and choose OpenGL Hardware from the

Rendering Plug-In menu.

Note: Use caution when enabling the OpenGL renderer in a network rendering environment. Inconsistencies may arise

if the OpenGL cards in the network aren’t the same.

Note: OpenGL works with 8 and 16 bpc projects only.

See also

“About 3D rendering” on page 625

Reducing a movie
There are several methods for producing a reduced-size movie from your composition, each with trade-offs between

speed and quality:

Nest the composition Create a new composition at the smaller dimensions, and nest the large composition inside it.

For example, if you create a 640 x 480 composition, place it in a 320 x 240 composition. Use the Fit To Comp

command to scale the composition to fit the new smaller composition size: Press Ctrl+Alt+F (Windows) or

Command+Option+F (Mac OS), and then collapse transformations by choosing Layer > Switches > Collapse. The
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resulting composition rendered at full resolution and best quality will have excellent image quality, better than if you

had rendered using a reduced resolution.

Stretch the composition This method produces the highest quality reduced-size movie but is slower than nesting.

For example, if you create a 640 x 480 composition and render it at full resolution, you can set the stretch value in

the Output Module Settings dialog box to 50% to create a 320 x 240 movie. For a composition rendered at full

resolution, the image quality is excellent when the Stretch Quality is set to High.

Note:Do not use stretching to change the vertical dimensions of a movie when field rendering is on. Stretching vertically

mixes the field order, which distorts motion. Use either cropping or composition nesting if you need to vertically resize a

field-rendered movie.

Crop the composition This method is ideal for reducing the size of a movie by a few pixels. Use the Crop options in

the Output Module Settings dialog box. Remember that cropping cuts off part of the movie, so objects centered in

the composition may not appear centered unless the movie is cropped evenly on opposite edges.

Crop to a region of interest To render just a portion of the composition frame, select a region of interest in the

Composition panel. Then, select the Region of Interest option in the Output Module Settings dialog box before

rendering. (See “To change the region of interest” on page 118.)

Note: Cropping an odd number of pixels from the top of a field-rendered movie reverses the field order. For example, if

you crop one row of pixels from the top of a movie with Upper Field First field rendering, the field-rendering order then

becomes Lower Field First. Remember that if you crop pixels from the top of the movie, you need to add to the bottom

row of the movie to maintain the original size. If you are willing to lose one scan line, this gives you a way to output two

movies from one render, each with a different field order. (See “About field separation and pulldown” on page 99 and “To

test field-rendering order” on page 597.)

Render the composition at a reduced resolution This is the fastest method to create reduced-size movies. For

example, if you create a 640 x 480 composition, you can set the composition resolution to one half, reducing the size

of the rendered composition to 320 x 240. You can then create movies or images at this size. Note that the reduced

resolution reduces the sharpness of the image and is best used for creating preview or draft movies.

Note: When rendering at reduced resolution, set the quality of the composition to Draft. Rendering at Best quality while

reducing resolution does not produce a clean image and takes longer to render than rendering at Draft quality.

Enlarging a movie
Increasing the size of the output from a rendered composition reduces the image quality of a movie and is not recom-

mended. If you must enlarge a movie, to maintain highest image quality, enlarge a composition that was rendered at

full resolution and highest quality using one of the following methods:

Nest the composition Create a new composition at the larger dimensions and nest the smaller composition inside it.

For example, if you create a 320 x 240 composition, you can place it in a 640 x 480 composition. Stretch the compo-

sition to fit the new larger composition size, and then collapse transformations by choosing Layers > Switches >

Collapse. The resulting composition rendered at full resolution and best quality will have better image quality than

if you had stretched the movie. However, this method also renders slower than if you created a composition and

stretched it.

Note: To create a draft movie with specific dimensions, use both the Stretch option and reduced resolution in the

rendered composition.

Stretch the composition For example, if you create a 320 x 240 composition and render it at full resolution, you can

set the stretch value in the Output Module Settings dialog box to 200% to create a 640 x 480 movie. For a composition

rendered at full resolution, the image quality will usually be acceptable.
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Note:Do not use stretching to change the vertical dimensions of a movie with field rendering. Stretching vertically mixes

the field order, which distorts any motion. Use either cropping or composition nesting if you need to vertically resize a

field-rendered movie.

Crop the composition To enlarge a movie by a few pixels, increase the size using negative values for the Crop options

in the Output Module Settings dialog box. For example, to increase the size of a movie by 2 pixels, type –2 in the

Cropping section of the Output Module Settings dialog box. Remember that negative cropping adds to one side of a

movie, so objects originally centered in the composition may not appear centered when the movie is cropped.

Note: Adding an odd number of pixels to the top of a field-rendered movie reverses the field order. For example, if you

add one row of pixels to the top of a movie with Upper Field First field rendering, the field-rendering order then becomes

Lower Field First. Remember that if you add pixels to the top of the movie, you need to crop from the bottom row of the

movie to maintain the original size. (See “About field separation and pulldown” on page 99.)

Creating low-resolution movies for testing motion
You can test the motion of a high-quality composition by quickly creating a low-resolution, or thumbnail, movie. Do

this by making a movie at a resolution less than full (using the Resolution pop-up menu in the Render Settings dialog

box). After Effects creates a movie with dimensions proportional to the resolution.

For example, if your composition is 640 x 480 pixels and you make a movie at quarter resolution, the resulting movie

will be 160 x 120 pixels (one-sixteenth the size of the composition). This thumbnail renders almost 15 times faster

than at full resolution. You can then play the thumbnail on your system to get a good idea of what motion will be like

in your final, full-sized movie. You can also enlarge the thumbnail in a movie-playing application to see playback at

full size. In addition, you can use RAM preview for testing purposes.

To test field-rendering order
When you render a composition containing separated footage, set the Field Rendering option to the same field order

as your video equipment. If you field-render with the incorrect settings, the final movie may appear too soft, jerky,

or distorted. A simple test can determine the order in which your video equipment requires fields.

Note: The field order might get altered if you change the hardware or software of your production setup. For example,

changing your device control software or VCR after setting the field order can reverse your fields. Therefore, any time

you make a change to your setup, test the field-rendering order.

The test takes about 15 to 20 minutes and involves creating two movie versions of the same composition (one

rendered with Upper Field First and one with Lower Field First), and then playing the movies to see which choice

looks right.

1 Create a simple composition with the correct frame size and frame rate. Choose an NTSC or PAL preset in the

Composition Settings dialog box, and make the composition at least 3 seconds long.

2 Within the composition, make a layer that is a small rectangular solid. The layer can be any color as long as it

contrasts sharply with the composition background. You may wish to add a title, such as “Upper Field First,” to the

solid to make identification of the movie easier.

3 Apply some fast movement to the solid using keyframes in its Position property. Set keyframes from the upper left

of the Composition panel to the lower right for 1 second.

4 Save the project, and then drag the composition to the Render Queue panel.

5 Click the underlined Render Settings name, and then choose Upper Field First from the Field Render menu.

6 Click OK, and then click Render to make the movie.
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7 In the composition, change the color of the solid in the Composition panel, and add a new title, such as “Lower

Field First,” to identify it.

8 Render the composition again, choosing Lower Field First from the Field Render menu in the Render Settings

dialog box.

9 Record both movies to the same device.

10 Play both movies.

One movie will look distorted and have jumpy horizontal motion or shape distortion during vertical motion. The

other movie will play back smoothly, with sharply defined edges. Use the field order for the smooth-playing movie

whenever you render movies with that particular hardware configuration.

To save a RAM preview as a movie
Use RAM preview to preview frames, including audio, at the frame rate of your composition or as quickly as your

system allows. To simplify the rendering process, save RAM preview frames as a movie. After Effects saves RAM

previews as uncompressed AVI files (Windows) or MOV files (Mac OS). When saving a RAM preview, keep in mind

the following:

• After Effects uses the composition frame size and resolution setting to determine the final dimension in pixels of

a saved RAM preview. It doesn’t consider the zoom level.

• RAM preview doesn’t generate interlaced fields, so a saved RAM preview never contains fields. If you require

interlaced fields, render the movie normally.

1 Choose Composition > Save RAM Preview.

2 Type a name, specify a location, and click Save.

Note: The 3D View of the active composition panel must be set to Active Camera for Save RAM Preview to work, even

if the composition doesn’t contain 3D files.

Collecting files in one location
The Collect Files command gathers copies of all of the files in a project or composition into a single location for

rendering or archiving. When you use this command, After Effects creates a new folder in which it saves a new copy

of the project, copies of the specified footage files, proxy files as specified, and a report describing the files, effects,

and fonts necessary to render the project.

After you collect files, you can continue making changes to a project, but be aware that those changes are stored with

the original project and not with the newly collected version.

When you collect files, options include the following:

Generate Report Only Selecting this option does not copy the files and proxies.

Obey Proxy Settings Use this option with compositions that include proxies to specify whether you want the copy

to include the current proxy settings. If this is selected, only the files used in the composition are copied. If this is not

selected, the copy contains both proxies and source files, so you can later change proxy settings in the collected

version.

Note: If you choose For Queued Comps in the Collect Source Files dialog box, After Effects uses the proxy settings from

the render settings, not the composition.
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Reduce Project Removes all unused footage items and compositions from the collected files when the following

options are chosen in the Collect Source Files pop-up menu: For All Comps, For Selected Comps, and For Queued

Comps.

Change Render Output To Use to redirect the output modules to render files to a named folder in the collected files

folder. This option ensures that you have access to your rendered files when you’re rendering the project from

another system. Note that the rendering status must be valid (Queued, Unqueued, or Will Continue) for the output

modules to render files to this folder.

Enable ‘Watch Folder’ Render (Pro only) You can use the Collect Files command to save projects to a specified watch

folder and then initiate watch-folder rendering over a network. After Effects also includes a render control file called

[project name]_RCF.txt, which signals to watching systems that the project is available for rendering. After Effects

and any installed render engines can then render the project together across a network. (See “To set up watch-folder

rendering (Pro only)” on page 628.)

Maximum Number Of Machines (Pro only) Use to specify the number of render engines or licensed copies of After

Effects that you want to allocate to render the collected project. Below this option, After Effects reports how many

items in the project will be rendered using more than one computer.

Note: If rendering time is unusually slow, you may have set Maximum Number Of Machines too high, and the network

overhead required to track rendering progress among all computers is out of proportion to the time spent actually

rendering frames. The optimal number depends on many variables related to the network configuration and the

computers on it; experiment to determine the optimal number for your network.

To gather files for rendering or archiving
1 Choose File > Collect Files.

2 In the Collect Files dialog box, choose an appropriate option for Collect Source Files.

3 Select appropriate options, as needed. (See “Collecting files in one location” on page 598.)

4 To add your own information to the report that will be generated, click Comments, type your notes, and click OK.

The comments appear at the end of the report.

5 Click Collect. Name the folder and specify a location for your collected files.

The options for Collect Source Files include the following:

All Collects all footage files, including unused footage and proxies.

For All Comps Collects all footage files and proxies used in any project compositions.

For Selected Comps Collects all footage files and proxies used in compositions currently selected in the Project

panel.

For Queued Comps Collects all footage files and proxies used directly or indirectly in any of the compositions with

a valid rendering status in the Render Queue panel.

None Copies the project to a new location without collecting any source footage.

Once you start the file collection, After Effects creates the folder and copies the specified files to it. The folder

hierarchy is the same as the hierarchy of folders and footage in your project. The new folder includes a (Footage)

folder and may include an output folder (if you selected Change Render Output To).

The names of these folders appear in parentheses to signal to any attending render engines that they should not

search these folders for projects (Professional edition only).
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Using Post-Render Action options

About Post-Render Action options
After a composition is rendered, After Effects can automate simple tasks through options available in the Post-

Render Action menu. These options allow you to prerender footage items and then replace existing footage or set

proxies.

Note:You can choose a Post-Render Action option in an Output Module template, so be aware that changing the Output

Module template could also change the Post-Render Action option. (See “To change output module settings” on

page 607.)

To specify Post-Render Action options
The Post-Render Action menu specifies the action you want After Effects to perform after it renders the item. You

can choose Post-Render Action options in the Render Queue panel.

Note: Choosing Pre-render from the Composition menu adds a selected composition to the render queue and sets the

Post-Render Action option to Import & Replace Usage.

1 Place the item you want to render in the Render Queue panel. (See “To work in the Render Queue panel” on

page 602.)

2 Expand the Output Module, and choose one of the following from the Post-Render Action menu:

None Performs no post-render action. This option is the default.

Import Imports the rendered file to the project when the rendering is complete.

Import & Replace Usage Imports the rendered file and substitutes it for each use of the specified Project panel item.

Drag the pick whip to the Project panel item to specify it.

Set Proxy Sets the rendered file as a proxy for the specified project item. Drag the pick whip to the Project panel item

to specify it.

Setting a render item (right) as a proxy for a project item (left) using the Post-Render Action pick whip
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To create placeholders for output
You can create placeholder files that can be used in different compositions. For example, you can create a placeholder

for an item in the render queue that will create a 24-fps movie and then drag that placeholder into a 30-fps compo-

sition. Then, when you render the 30-fps composition, After Effects first renders the placeholder at 24 fps and uses

this rendered version as it renders the 30-fps composition.

❖ Drag the output module for a queued item from the Render Queue panel to the Project panel. After Effects creates

a placeholder for output in the Project panel and sets the Post-Render Action option for the item to Import & Replace

Usage.

To name output files automatically
The Use Default File Name And Folder preference ensures that all compositions added to the render queue are

automatically assigned a unique output file name (except for files created by saving RAM previews, which still use

the composition name). When this option is selected, each composition is assigned the same folder name as the

previous composition until you change the path. If a composition is rendered more than once, After Effects adds a

number to the file name (for example, compname_1).

Note:  Avoid using high-ASCII or other extended characters in file names for projects to be used on different platforms

or rendered using a watch folder.

1 Choose Edit > Preferences > Output (Windows) or After Effects > Preferences > Output (Mac OS).

2 Select Use Default File Name And Folder.

To introduce 3:2 pulldown
If you are creating output for film that’s been transferred to video or if you want to simulate a film look for animation,

use 3:2 pulldown. Footage items that were originally film transferred to video and had 3:2 pulldown removed when

imported into After Effects can be rendered back to video with 3:2 pulldown reintroduced. You can introduce 3:2

pulldown by choosing one of five different phases. (See “About 3:2 and 24Pa pulldown” on page 101.)

Note: It is important to match the phase of a segment that had 3:2 pulldown removed if it will be edited back into the

video footage it came from.

1 In the Render Queue panel, select the render item and then click the underlined Render Settings name.

2 For Field Render, choose a field order.

3 For 3:2 Pulldown, choose a phase.

4 Select other settings as appropriate, and then render.

To create a proxy
Use the Create Proxy command to create a proxy from footage or compositions selected in the Project panel or the

Timeline panel. This command adds the selected footage to the Render Queue panel and sets the Post-Render Action

option to Set Proxy. (See “About Post-Render Action options” on page 600 and “About placeholders and proxies” on

page 128.)

1 Select a footage item or composition in the Project or Timeline panel.

2 Choose one of the following commands:

• File > Create Proxy > Still to create a still image proxy.

• File > Create Proxy > Movie to create a moving image proxy.
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3 Specify a name and output designation for the proxy.

4 Specify Render settings, and click Render.

Note: To create a still image proxy from a movie or sequence file, open the footage in the Footage panel and set as the

poster frame the frame you want to use as the proxy.

Using the Render Queue panel

To work in the Render Queue panel
Use the Render Queue panel to render compositions, apply rendering and output module options, and obtain infor-

mation on the rendering process. You can queue items to be rendered in any order.

The Render Queue panel contains all the settings you need for rendering a movie or sequence. When you drag or

place a composition into the Render Queue panel, it becomes a render item. You can then queue a number of items,

so that After Effects can render multiple items unattended. The settings you change in the Render Queue panel affect

only rendering, and do not change the original compositions.

The top section of the Render Queue panel monitors the item that After Effects is rendering. In the bottom section,

you can arrange a queue of items to be rendered, and specify render settings and output modules for each one.

The Render Queue panel
A. Information on an item that is rendering B. Information on items queued for rendering, including settings you can change

You can place multiple items in the render queue. When rendering is complete, each item remains in the Render

Queue panel with its status changed to Done until you remove it. You cannot re-render a completed item, but you

can duplicate it to create a new item in the queue with the same settings or with new settings.

• To add a composition to the queue, drag it from the Project panel to the Render Queue panel and select Render,

or select the composition, choose Composition > Make Movie or Composition > Add To Render Queue, and then

select Render.

• To remove a composition from the queue, select it in the Render Queue panel and deselect Render.

B

A
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• To remove a composition from the Render Queue panel, select it and press Delete or choose Edit > Clear

• To rearrange compositions in the Render Queue panel, drag a composition up or down the queue. A heavy black

line appears between compositions, indicating where the composition will be placed.

• To pause or stop rendering, click Pause or Stop.

Note: While the rendering process is paused, you will not be able to change settings or otherwise use After Effects in any

other way. If you stop the rendering process, the item you stopped is assigned the status User Stopped, and a new item

with the status of Unqueued is added to the Render Queue panel and set to resume rendering at the first unrendered

frame.

To re-render a previously rendered item

You can re-render previously rendered items, including those that were only partially rendered.

1 In the Render Queue panel, select the render item.

2 Do one of the following:

• To render with the same file name, choose Edit > Duplicate With File Name.

• To render with a new file name, choose Edit > Duplicate, click the underlined Output To file name, type a new file

name, and then click Save.

3 Click Render.

To change the destination for multiple queued items

1 In the Render Queue panel, press the Shift key to select multiple queued items.

2 Click the underlined Output To file name of any item.

3 Choose the hard disk to which you want to render the files. The file paths for all selected items change to the new

destination.

To create a composition and render source footage simultaneously
You can simultaneously create a composition from source footage and prepare it for rendering. This process is useful

when you want to change some aspect of the source footage, such as frame rate or compression method, and have

that rendered version available in your project.

1 Choose Window > Render Queue.

2 Drag one or more footage items from the Project panel to the Render Queue panel, or make sure the footage is

selected and press Ctrl+Shift+/ (Windows) or Command+Shift+/ (Mac OS). After Effects creates both a new item

in the render queue and a new composition in the Project panel for each footage item.

3 Adjust the render settings as desired, and click Render.

To name rendered output
You use the Output To field in the Render Queue panel to enter a name for the rendered output, choose a location

for the file, and choose the output type. You can also set the output’s file name by choosing a preset file naming

template from the Output To menu. Custom templates let you name the output according to specified properties of

the composition and project.

• To manually enter a file name, click the underlined text field adjacent to Output To, enter a file name, and click

Save.



ADOBE AFTER EFFECTS 7.0
User Guide

604

• To use a file naming template, choose a template from the Output To pop-up menu.

To make a file naming template the default template, hold down Control (Windows) or Command (Mac OS) and

choose the desired template from the Output To pop-up menu.

To create a file naming template

1 In the Render Queue panel, choose Custom from the Output To pop-up menu.

2 If you want to base the new file naming template on an existing template, choose the existing template from the

Preset menu.

3 In the File Name Templates dialog box, click in the Template box where you want to insert a file naming rule, and

do any of the following:

• To add a preset property to the file name, choose the property from the Add Property menu.

• Type text in the Template box.

Note: Make sure that the insertion point is outside the square brackets ([ ]) of preset properties.

4 Do any of the following:

• To save the file naming template as a preset for future use in the Output To menu, click the Save button . In the

Choose Name dialog box, enter a name for the file naming template, and click OK.

• To always use the selected file naming template, select Default.

• To apply the selected file naming template to the current Output Module, click OK.

To change render settings
The Render Queue panel displays the current render settings—either default settings or settings you made when you

created the composition. You can change these settings or override them for all layers or compositions.

When you set the quality and resolution of a composition while editing, it doesn’t change the quality or resolution

of compositions nested within it. When rendering, you can have After Effects automatically adjust the settings of all

layers and compositions in your final rendered item.

❖ Do one of the following:

• Choose a template from the Render Settings menu. Several basic templates are provided. Use the Draft Settings

template for reviewing motion or for testing. The Best Settings template works well for final rendering. To use the

composition’s current settings, use the Current Settings template.

• Click the underlined render settings template name. These settings affect the composition and all nested compo-

sitions.

The Render Settings dialog box has the following options:

Quality Determines the quality setting for all layers.

Resolution Determines the size and clarity of the rendered composition, relative to the original composition dimen-

sions.

Note: If you render at reduced resolution, set the Quality option to Draft. Rendering at Best quality when reducing

resolution produces an unclear image and takes longer than Draft quality.

Disk Cache Determines whether the disk caches preferences are used during rendering.

• Read Only Writes no new frames while After Effects renders.
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• Current Settings (the default setting) Uses the disk cache settings defined in the Memory & Cache preferences.

Use OpenGL Renderer Determines whether you use OpenGL to render (see “To render with OpenGL” on page 595).

Proxy Use Determines whether to use proxies when rendering. Current Settings uses the settings for each item.

Effects Determines which effects are enabled for the rendered composition. You can choose to use current settings

or to turn all effects on or off. If you choose All On, all applied effects are used in a composition or a layer. If you

choose All Off, all effects for the composition are disabled.

Solo Switches Determines whether solo layers are rendered.

• Current Settings (default) Leaves all Solo switches as they currently are on your layers. This option renders all

layers regardless of the status of their Solo switch, unless layer visibility is turned off.

• All Off Makes all Solo switches behave as if they are off.

Guide Layers Determines whether guide layers are rendered. Choose Current Settings to render guide layers in the

current composition or All Off (the default setting) to not render guide layers. (Guide layers in nested compositions

are never rendered.)

Color Depth Determines the color bit depth for the rendered composition. Choose Current Settings (default) to use

the project bit depth, or choose a different bit depth to override the project bit depth.

Frame Blending Determines the frame blending settings for all layers. Use On For Checked Layers to render frame

blending only for layers with frame blending enabled in the Switches column in the Timeline panel, regardless of the

composition’s Enable Frame Blending setting. (See “Enhancing time-altered motion by blending frames” on

page 169.)

Field Render Determines the field-rendering technique used for the rendered composition. Choose Off if you are

rendering for film or for display on a computer screen. (See “To test field-rendering order” on page 597 and “To

separate video fields in imported footage” on page 100.)

3:2 Pulldown Determines the phase of 3:2 pulldown introduction. (See “About 3:2 and 24Pa pulldown” on page 101.)

Motion Blur Determines when motion blur is applied.

• Current Settings Renders motion blur as currently specified by the motion blur switches and Enable Motion Blur

composition setting in the Timeline panel.

• On For Checked Layers Renders motion blur only for layers with motion blur enabled in the Switches column in

the Timeline panel, regardless of the composition’s Enable Motion Blur setting. Shutter angle affects the amount of

Motion Blur.

• Off For All Layers Renders all layers without motion blur regardless of their settings in the Timeline panel.

Time Span Indicates how much of the composition is being rendered. To render the entire composition, choose

Length Of Comp. To render only the part of your composition indicated by the work-area markers, choose Work

Area Only. To render a custom time span, choose Custom, type timecodes in Start, End, and Duration, and then click

OK.

Frame Rate Determines the sampling frame rate used to render the composition. Select Use Comp’s Frame Rate to

use the frame rate specified in the Composition Settings dialog box, or select Use This Frame Rate to type in a

different frame rate. The actual frame rate of the composition is unchanged.

Use Storage Overflow Determines whether rendering continues when the first assigned storage volume overflows.

If this option isn’t selected, rendering stops when the first assigned volume reaches capacity. (See “Working with

overflow volumes and segments” on page 631.)
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Skip Existing Files Lets you re-render part of a sequence of files without wasting time on previously rendered frames.

When rendering a sequence of files, After Effects locates files that are part of the current sequence, identifies the

missing frames, and then renders only those frames, inserting them where they belong in the sequence. You can also

use this option to render single-frame sequences on multiple systems.

Note: The current sequence must have the same name as the existing sequence, and the starting frame number, frame

rate, and time span must be the same. You must render to the folder that contains the previously rendered frames.

Monitoring the rendering process
The Render Queue panel displays both elapsed time and estimated time remaining for the composition being

rendered. The Render Queue panel also displays the render and output settings for all render items. You can view

these settings by clicking the triangle to the left of the queued item’s name and to the left of Output Module. Click

the underlined file path to locate the output destination in Windows Explorer (Windows) or the Finder (Mac OS).

In addition, the Render Queue panel displays the following information for all queued items:

Message Contains a status message.

RAM Shows the memory available for the rendering process.

Renders Started Lists which items in the queue have started rendering.

Total Time Elapsed Shows the time elapsed for all items that have been rendered or are currently being rendered.

Log File Shows the name and location of the file to which rendering status messages are written. After Effects creates

a log file, AE Log (date/time).txt. The path of the log file is displayed in the Render Queue panel during rendering.

Use the Log menu in the Render Queue panel to select which information is written to the log file.

Press the Caps Lock key before you start rendering to prevent the Composition panel from displaying frames while it

renders. By not updating the Composition panel, After Effects requires less time to process simple render items with

a lot of frames.

The status line in the Render Queue panel provides important information on the results of the rendering process.

Render queue status options include the following:

Unqueued The render item is listed in the Render Queue panel but is not ready to render. Confirm that you have

selected the desired render and output module settings, and then select the Render option to queue the composition.

Queued The composition is ready to render.

Needs Output An output file name has not been specified for one of the output modules.

Failed After Effects was unsuccessful in rendering the movie. Use a text editor to view the log file for specific infor-

mation on why the rendering was unsuccessful.

User Stopped The rendering process was stopped.

Done The rendering process for the item is complete.
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To create and use render settings templates
You can create templates that save commonly used render settings. These templates appear in the Render Settings

pop-up menu in the Render Queue panel. For example, you can specify a default render settings template for movie

rendering and another for creating a single frame. You can also save all render settings templates to a file to use on

another computer.

❖ Choose Edit > Templates > Render Settings, and then do one of the following:

• To specify a default template to be used when rendering movies, choose a template from the Movie Default menu.

• To specify a default template to be used when rendering a single frame, choose a template from the Frame Default

menu.

• To create a new render settings template, click New, specify the render settings you want, and click OK. Enter a

name for the new template.

• To edit an existing render settings template, choose a template from the Settings Name menu, and then click Edit.

Specify the render settings you want.

Note: Changes to an existing template do not affect render items that are already in the render queue.

• To save all currently loaded templates to a file, click Save All. Select a location for the file, and then enter a file

name.

• To load a saved template file, click Load, select the template file, and then click Open.You can also click the arrow

next to Render Settings in the Render Queue panel and choose Make Template to specify default render settings

templates or create a new render settings template.

To apply an additional output module
You can apply more than one output module to each render item in the queue. This is useful when you want to make

more than one version of a movie at the same time. For example, you can automate the creation of a movie and its

alpha matte, or you can create high-resolution and low-resolution versions of a movie.

When you apply more than one output module to a render item, After Effects renders to the various output formats

simultaneously, saving you time.

1 In the Render Queue panel, select an item.

2 Choose Composition > Add Output Module.

To change output module settings
An output module includes options for the specific video and audio output format to which you are rendering the

movie, as well as video compression options. The Render Queue panel shows the current settings for an output

module.

Note: Before rendering, check the Audio Output settings in the Output Module Settings dialog box to ensure that they

are correct. If your project includes audio, be sure that Audio Output is selected. If your project does not include audio,

do not select Audio Output so that the size of the rendered file will not increase needlessly.

❖ Do any of the following:

• Click the underlined output module template.

• Choose a template from the Output Module menu. Several templates are provided, including the Lossless template

for creating movies for transfer to video or film.
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You can specify the following settings in the Output Module Settings dialog box:

Format Specifies the format for the output file or sequence of files. File formats include QuickTime, Video for

Windows, and file types available from plug-in file format modules.

Embed Specifies whether to include information in the output file that links to the source project in After Effects.

When you open the output file in another application such as Adobe Premiere Pro, you can use the Edit Original

command to edit the source project in After Effects. Selecting Project Link creates a link between the output file and

the source project. Selecting Project Link And Copy creates a link and adds an embedded copy of the linked project

to the output file; if the project is missing or updated when you choose Edit Original in another application, you can

choose whether to open the source project or the saved copy of the project.

Post-Render Action Specifies an action for After Effects to perform after the composition is rendered. (See “About

Post-Render Action options” on page 600.)

Format Options Opens a dialog box with format-specific information. For example, if QuickTime is your format,

Format Options opens a QuickTime Compression dialog box.

Starting # Specifies the number for the starting frame of a sequence. For example, if this option is set to 38, After

Effects names the first frame [file name]_00038.tga. The Use Comp Frame Number option adds the starting frame

number in the work area to the starting frame of the sequence.

Channels Specifies the output channels contained in the rendered movie. After Effects creates a movie with an alpha

channel if you choose RGB+Alpha, implying a depth of Millions of Colors+. Not all codecs support alpha channels.

Note: All files created with a color depth of Millions of Colors+, Trillions of Colors+, or Floating Point + have labeled

alpha channels; information describing the alpha channel is stored in the file. Therefore, you do not have to specify an

alpha interpretation each time you import an item created in After Effects.

Depth Specifies the color depth of the rendered movie. Choose from color or grayscale options, and note that certain

formats may limit depth and color settings.

Color Specifies how colors are created with the alpha channel. Choose from either Premultiplied (Matted) or

Straight (Unmatted). (See “To set the alpha channel interpretation method” on page 72.)

Note: PNG files don’t support premultiplied alpha.

Stretch Specifies the size of your rendered movie. Select Lock Aspect Ratio To if you want to retain the existing

frame aspect ratio when stretching the frame size. Select Low Stretch Quality when rendering tests, and select High

Stretch Quality when rendering a final movie. (See “Reducing a movie” on page 595 and “Enlarging a movie” on

page 596.)

Crop Used to subtract or add rows or columns of pixels to the edges of the rendered movie. You can specify the

number of rows or columns of pixels to be added or subtracted from the top, left, bottom, and right sides of the

movie. Type positive values to crop, and type negative values to add rows or columns of pixels. Select Region of

Interest to render only the region of interest selected in the Composition or Layer panel.

Note: By adding one row of pixels to the top of a rendered movie or composition with field rendering, you can change

the field-rendering order. (See “To determine the original field order” on page 100.)

Audio Output Specifies the sample rate, sample depth (8 Bit or 16 Bit), and playback format (Mono or Stereo).

Choose a sample rate that corresponds to the capability of the output format. Choose an 8-bit sample depth for

playback on the computer, and a 16-bit sample depth for compact disc and digital audio playback or for hardware

that supports 16-bit playback.
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To create and use output module templates
You can create templates that save commonly used output module settings. These templates appear in the Output

Module pop-up menu in the Render Queue panel. You can specify a default output module template for movie

rendering and another for creating a single frame. After Effects provides several templates that include commonly

used formats, such as Microsoft DV NTSC. You can also save all output module settings templates to a single file to

use on another computer.

Note:After Effects includes templates that specify the use of the Pre-render and Create Proxy commands. (See “To create

a proxy” on page 601.)

❖ Choose Edit > Templates > Output Module, and do one of the following:

• To set the default template to be used when creating movies, choose a template from the Movie Default menu.

• To set the default template to be used when creating a single frame, choose a template from the Frame Default

menu.

• To create a new template, click New. Then type the output module settings and a name for the new template, and

click OK.

• To edit an existing template, choose a template from the Settings Name menu and click Edit. Change the settings

you want, and then click OK.

Note: Changes to an existing template do not affect render items that are already in the render queue.

• To save all currently loaded output module templates to a file, click Save All. Select a location for the file, type a

file name, and then click OK.

• To load a saved output module template file, click Load, select the template file, click Open, and then click OK.

You can also create an output module template by clicking the arrow next to Output Module in the Render Queue

panel and choosing Make Template.

Exporting to Macromedia Flash (SWF) format

About Flash format
You can export compositions from After Effects as Macromedia® Flash™ (SWF) files. Web browsers with the Flash

Player plug-in can play SWF files.

The Flash (SWF) format is a widely used vector graphics and animation format for the web. Flash movies are

distributed as SWF files, a compact binary format that can contain audio and vector objects. See “Supported features

for SWF export” on page 611 for information about which features After Effects can export as vector objects.

Note: When you export to SWF, vector objects in a nested composition—including solids—are rasterized.

To export a composition to Macromedia Flash (SWF) format
During export to SWF, After Effects maintains vectors as much as possible. However, raster images and some effects,

blending modes, and motion blur cannot be represented as vectors in the SWF file and are rasterized. (See

“Supported features for SWF export” on page 611.)

You can choose to ignore these unsupported items so that the SWF file includes only those After Effects features that

can be converted into native SWF elements, or you can choose to rasterize frames that contain unsupported features

and add them to the SWF file as JPEG-compressed bitmap images, which may reduce the efficiency of the SWF file.
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Audio is encoded in MP3 format and added to the SWF file as an audio stream.

1 Select the composition you want to export, and then choose File > Export > Macromedia Flash (SWF).

2 Type a file name (making sure to include the .swf extension) and location, and then click Save (Windows) or OK

(Mac OS).

3 Specify options as appropriate, and then click OK:

JPEG Quality Specifies the image quality. The higher the quality, the larger the file. (If you select Rasterize for Unsup-

ported Features, the JPEG Quality setting is used for all JPEG-compressed bitmap images exported to the SWF file,

including bitmap images generated from composition frames or Adobe Illustrator files.)

Unsupported Features Specifies whether to rasterize features that SWF format doesn’t support. Choose Ignore to

exclude unsupported features, or choose Rasterize to render all frames that contain unsupported features as JPEG-

compressed bitmap images and include them in the SWF file. If you choose Rasterize, the SWF Exporter rasterizes

source files for each layer in the composition (except layers that use Illustrator files or solids as the source footage)

and nested compositions with Collapse Transformations enabled.

Audio Sample Rate Specifies the sample rate of the audio.

Audio Channels Specifies whether the audio tracks are mono or stereo.

Audio Bit Rate Specifies the bit rate of the exported audio. Choose Auto to get the lowest bit rate available for the

specified Sample Rate and Channel. Higher bit rates increase file size. (See “To change output module settings” on

page 607.)

Loop Continuously Specifies that the exported SWF file loops continuously during playback. If you plan to specify

looping by writing HTML code to control the Flash Player, deselect Loop Continuously.

Prevent Import Creates a SWF file that digital image or video-editing programs can’t import.

Include Object Names Includes layer, mask, and effect names in the file. Selecting this option increases file size. (See

“Including object names in a SWF file” on page 612.)

Flatten Illustrator Artwork Splits all overlapping objects into non-overlapping pieces. When you select this option,

you don’t need to convert Illustrator text to outlines before exporting. (This option supports source files from

Illustrator 9.0 or later.)

There are advantages and disadvantages to flattening Illustrator artwork. When you flatten Illustrator artwork, text

exports to SWF properly, so you don’t need to convert text to outlines. Overlapping objects are removed, so

composited layers appear the same in both After Effects and the SWF file. End caps, joins, and transparency groups

export properly, and artwork outside crop marks, which is not visible in the SWF file, is not included. However, SWF

files don’t necessarily become smaller. In addition, the flattening process may introduce unsupported objects that are

then ignored or rasterized, and white fringes may appear around some objects. The process can be slow, memory-

intensive, and possibly ineffective for complex Illustrator artwork.

Include Layer Marker Web Links Makes layer-time markers behave as web links. (See “Including web links in a SWF

file” on page 612.)

The SWF Exporter saves a report ([SWF file name]R.htm) to the same folder as the SWF file. Open the report in a

browser to see which items are unsupported in the SWF file.

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.
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Supported features for SWF export
When creating compositions intended for SWF format, note the following information about each feature:

Layers After Effects text layers export to SWF as vector graphics in After Effects. The following layer types and layer

switches aren’t supported: Track Mattes, 3D Layers, 3D Cameras, 3D Lights, Adjustment Layers, Preserve Trans-

parency, Collapse Transformations, and Motion Blur. The Fill Over Stroke character option and the Blur animator

property aren’t supported, and only Normal blending mode is supported. Nested layers aren’t supported and are

rasterized.

Masks Only masks with Add mask mode or Difference mask mode are supported; multiple masks in a layer must

use the same mask mode. If Add mode is specified, Partial Opacity and the mask Inverted option are also supported.

Mask feathers are not supported.

Note:The SWF Exporter renders overlapping Add mode masks that include alpha channels or partial opacity differently

than After Effects.

Effects Path Text, Audio Waveform, and Audio Spectrum can export to SWF. All Path Text options are supported,

except the following: Composite On Original, Fill And Stroke/Options/Fill Over Stroke, and

Advanced/Mode/Difference.

The SWF Exporter converts lines drawn by the Audio Spectrum and Audio Waveform effects to vectors and ignores

unsupported features: Outside Color (only Inside Color is used), Softness, and Composite On Original. In addition,

only uniformly thick lines are included in the SWF file. For example, if you select the Use Polar Path option in Audio

Spectrum, lines become thicker farther from the center in After Effects, but in the SWF file the lines remain at the

same thickness.

The waveforms may increase the SWF file size, so decrease the Displayed Samples value in the Audio Waveform

effect or the Frequency Bands value in the Audio Spectrum effect, or decrease the frame rate to make the SWF file

smaller.

Resolution The SWF Exporter always creates files at full resolution (size of composition) and renders JPEG-

compressed bitmap images at full resolution.

Adobe Illustrator files Only stroked paths and filled paths in CMYK or RGB color spaces are supported.

The SWF Exporter converts layers that have Illustrator source files to corresponding SWF items, provided the layer

does not contain masks or have Collapse Transformations enabled (Illustrator layers that contain masks or have

Collapse Transformations enabled are rasterized). The SWF file maintains the Illustrator crop marks. Artwork

outside the crop marks is included in the SWF file even though it’s not visible, thereby increasing the file size.

The SWF export report lists information for unsupported features in Illustrator files for the first frame in which the

Illustrator file is visible. Unsupported features are ignored or rasterized (depending on whether you’ve selected

Ignore or Rasterize Unsupported Features) on all frames in which the footage is visible.

About SWF references
The SWF Exporter uses each item in the After Effects composition once, and then references it for any further use,

provided the content doesn’t change and regardless of whether the frames are consecutive. For example, the SWF

Exporter adds a layer that contains still source footage and a non-animated mask to the composition and then refer-

ences the layer on all subsequent frames, even if you’ve animated the layer’s transformation properties. However, if

you animate the mask, or if the layer’s source file is video or a composition that changes over time, the SWF Exporter

adds a new object to the composition on each frame where the layer is visible. Objects added this way include JPEG-

compressed bitmap images, SWF movie clips created in Adobe Illustrator, and text characters applied with the Path

Text effect.
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Referencing also works across layers, so if multiple layers in the composition share the same source, the source is

added once to the composition and is then referenced for every additional layer that shares the source. If the source

is an Illustrator file or layer, a SWF movie clip is created and referenced. If the Path Text effect is applied, the text

characters are added as vectors once and then referenced on all subsequent frames, unless you choose Fill Over

Stroke from the Fill And Stroke options menu; in that case, the characters are added as vectors on every frame.

Including object names in a SWF file
The Include Object Names option in the SWF Settings dialog box retains the name of each layer, mask, and effect.

However, rasterized objects are not named.

Each mask exports as a separate SWF object whose name is the Layer name followed by the Mask name. If all masks

use Difference mode, all masks export as one SWF object, and the name is the layer name. Each path text character

exports as a separate SWF object whose name is the layer name, followed by the effect name and the character index

(starting at 0).

Including web links in a SWF file
The Include Layer Marker Web Links option adds web links and a Get URL action to the SWF file by using infor-

mation from layer-time markers that you add in the Timeline panel. (To create layer-time markers, see “To create a

web link from a marker” on page 166.) This option also adds a frame label to each SWF frame that has a layer-time

marker. You can specify how the browser opens the web link with standard target commands (for example, _blank):

_blank Loads the web link into a new browser window.

_parent Loads the web link into the parent frame of the frame in which the current file is playing.

_self Loads the web link into the current frame.

_top Loads the web link into the top frame in the current window.

_level0 Loads another SWF file into level 0. The current file typically plays at level 0; another file loaded into level 0

usually replaces the current file. Note that the URL must refer to another SWF file.

_level1 Loads another SWF file into level 1 if the URL refers to another SWF file.

Rendering to Windows Media, RealMedia, or MPEG
(Windows only)

About Windows Media or RealMedia format (Windows only)
Windows Media format supports embedded web links and chapters. To include them in the rendered file, create

layer-time markers in your composition. (See “About markers” on page 164.) When you add a web link to a layer-

time marker, After Effects adds the link with a Get URL command to the Window Media file. If you add chapter

information as well, After Effects translates the chapter information as a script command for the web link.

By using the RealMedia format, you can render RealVideo files with or without audio, and RealAudio files.

To render a Windows Media or a RealMedia file (Windows only)
1 Select the file or composition in the Project panel, and choose Composition > Add To Render Queue.

2 In the Render Queue panel, click the underlined Output Module setting.
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3 Choose either Windows Media or RealMedia from the Format menu.

4 Do one of the following in the Windows Media or RealMedia dialog box:

• Choose a Preset from the Preset menu.

• Load a preset by clicking the Import Preset icon.

5 Select Export Video and Export Audio, and choose options in the lower area of the Windows Media or RealMedia

dialog box. Your ability to modify these options is based on the preset and codec you’ve selected.

6 Click OK, set render options, and then click Render.

About MPEG
MPEG is the name of a family of file formats specified by the ISO/IEC Moving Picture Experts Group. MPEG

formats include several compression methods. It requires significant processing power and time to generate these

keyframe-based file formats from other video formats.

MPEG-1 Generally used for the Internet and CD-ROM, providing picture quality comparable with VHS quality at

quarter-screen frame size.

MPEG-2 Delivers higher quality video than MPEG-1. A specific form of MPEG-2 was chosen as the standard for

compressing video for DVD video. This is called DVD-compliant MPEG-2.

MPEG-4 Includes many of the features of MPEG-1 and MPEG-2, and adds support for interactivity. It offers better

compression and reduces file size while maintaining the same perceptual quality level as MPEG-2. MPEG-4 part 10

is the HD DVD standard.

After Effects and Adobe Premiere Pro offer a number of MPEG presets to optimize the output quality for various

project types. If you’re experienced with MPEG encoding, you can further fine-tune projects for specific playback

situations by customizing the presets in the Export Settings dialog box.

In After Effects, you can create MPEG-2 and MPEG-2 DVD video. In Adobe Premiere Pro, you can create various

types of MPEG video by using the File > Export > Adobe Media Encoder command or export directly to DVD-

compliant video by using the Export To DVD command (any video you export to DVD is automatically transcoded

to MPEG-2 if it isn’t already in that format).

After Effects and Adobe Premiere Pro add metadata to MPEG-2 files that Adobe Encore DVD can read for aid in

authoring and building DVDs. This metadata contains information that enables Adobe Encore DVD to multiplex

audio and video, automatically generate DVD chapter points, and generate Edit Original information. For more infor-

mation, see Adobe Encore DVD Help.

To render to MPEG-2 or MPEG-2 DVD (Windows only)
1 Select the file or composition in the Project panel, and choose Composition > Add To Render Queue.

2 In the Render Queue panel, click the underlined Output Module setting.

3 Choose MPEG2 or MPEG2-DVD from the Format menu.

4 Do one of the following in the MPEG2 or MPEG2-DVD dialog box:

• Choose a Preset from the Preset menu.

• Load a preset by clicking the Import Preset icon.

5 Select Export Video or Export Audio and then choose options in the lower area of the MPEG2 or MPEG2-DVD

dialog box. Your ability to modify these options is based on the preset and codec you’ve selected. The MPEG2 preset

displays advanced MPEG parameters, while the MPEG2-DVD preset displays only DVD-legal MPEG-2 parameters.
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About the Adobe Media Encoder
The Adobe Media Encoder is an encoding mechanism employed by programs such as Adobe Premiere Pro, Adobe

After Effects, and Adobe Encore DVD for output to certain media formats. Depending on the program, the Adobe

Media Encoder provides a specialized Export Settings dialog box that accommodates the numerous settings

associated with certain export formats, such as MPEG-1, MPEG-2, and those designed for delivering content over

the web. For each format, the Export Settings dialog box includes a number of presets that are tailored for particular

delivery media. You can also save custom presets that you can share with others or reload as needed.

Although the Export Settings dialog box’s appearance varies slightly and it is accessed differently in each program,

its general form and function are consistent. The Export Settings dialog box always contains an area for specifying

general export settings (such as the Format, Range, Preset, and tracks to export) and an area with tabbed panels. The

types of tabbed panels available depend on the format and preset you specify. A panel menu also contains commands

specific to the selected format.

When exporting a movie file for delivery media other than full-screen, full frame-rate television, it is often necessary

to deinterlace the frames, crop the image, or apply certain filters. Through the Export Settings dialog box, the Adobe

Media Encoder offers these tasks as pre-rendering options, because it’s best to perform them prior to encoding the

file. You can also specify post-encoding tasks, which include generating a log file or uploading the exported file to a

specified server automatically.

Adobe Media Encoder Filters options
Noise, grain, and similar artifacts can interfere with the efficient compression of images. For this reason, the size of

the final output file may in some cases be reduced by applying a noise reduction filter to an image or movie before

compression takes place.

In the Export Settings dialog box, you can specify whether to apply a noise reduction filter before compression, and

you can also set the amount of noise filtering to apply.

If you intend to remove noise and grain from your project for reasons other than reduction of compressed file size,

consider using the Noise & Grain effects in Adobe Premiere Pro or After Effects.

Adobe Media Encoder Video options
The options available in the Adobe Media Encoder Video tab depend on the format you specify in the Export

Settings area. Video settings include some or all of the following options:

Codec Specifies the codec used to encode the video from those available on your system. The term codec is derived

from compressor/decompressor and coder/decoder.

Quality Specifies the encoding quality. Generally, higher values increase rendering time and file size.

TV Standard Conforms the output to the NTSC or PAL standard.

Frame Width Scales the output frame’s horizontal aspect to the specified width.

Frame Height Scales the output frame’s vertical aspect to the specified height.

Frame Rate The output frame rate for either NTSC or PAL formats.

Field Order Specifies whether the output file’s frames are interlaced, and if so, whether the upper or lower field is first

in the scanning order. (See “About interlaced and noninterlaced video” on page 98.)

Pixel Aspect Ratio Specifies the ratio of each pixel’s width to height, which determines the number of pixels required

to achieve a given image aspect ratio. Some formats use square pixels, while others use nonsquare pixels.
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Bitrate Encoding Specifies whether the codec achieves a constant or variable bitrate in the exported file:

• Constant Bit Rate (CBR) Compresses each frame in the source video to the fixed limit you specify, producing a file

with a fixed data rate. Therefore, frames containing more complex data are compressed more, while less complex

frames are compressed less.

• Variable Bit Rate (VBR) Allows the exported file’s data rate to vary within a range you specify. Because a given

amount of compression degrades the quality of a complex image more than it degrades the quality of a simple image,

VBR encoding compresses complex frames less and compresses simple frames more.

In general, an image is complex and more difficult to compress efficiently if it contains great detail or if it differs

significantly from previous frames, as it would in a scene containing motion.

Note:When comparing CBR and VBR files of the same content and file size, you can make the following generalizations:

A CBR file may play back more reliably over a wider range of systems, because a fixed data rate is less demanding on a

media player and computer processor. However, a VBR file tends to have a higher image quality, because VBR tailors

the amount of compression to the image content.

Bitrate Specifies the number of megabits per second of playback for the encoded file. (This is available only if you

select CBR as the Bitrate Encoding option.)

The following options appear only if you select VBR as the Bitrate Encoding option:

Encoding Passes Specifies the number of times the encoder will analyze the clip before encoding. Multiple passes

increases the time it takes to encode the file, but generally results in more efficient compression and higher image

quality. (Adobe After Effects does not support multiple encoding passes.)

Target Bitrate Specifies the number of megabits per second of playback for the encoded file.

Maximum Bitrate Specifies the maximum number of megabits per second of playback you want the encoder to

allow.

Minimum Bitrate Specifies the minimum number of megabits per second of playback you want the encoder to allow.

The minimum bitrate differs according to the format. For MPEG-2-DVD, the minimum bitrate must be at least 1.5

Mbps.

M frames Specifies the number of B frames (Bi-directional frames) between consecutive I frames (Intra-frames) and

P frames (Predicted frames).

N frames Specifies the number of frames between I frames (Intra-frames). This value must be a multiple of the M

frames value.

Closed GOP Every Specifies the frequency of each Closed Group of Pictures (Closed GOP), which cannot reference

frames outside of the closed GOP. A GOP consists of a sequence of I, B, and P frames. (This option is available when

you choose MPEG-1 or MPEG-2 as the format.)

Automatic GOP Placement When selected, sets the placement of Group of Pictures (GOP) automatically. (This

option is available when you choose MPEG-1 as the format.)

Note: MPEG-1 and MPEG-2 formats include numerous advanced options not listed here. In most cases, selecting a

format or preset designed for your target output sets the appropriate options automatically. For detailed information on

options not listed, consult the specifications for the MPEG-1 (ISO/IEC 11172) and MPEG-2 (ISO/IEC 13818) formats.
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Adobe Media Encoder Audio options
The options available in the Export Settings dialog box Audio tab depend on the format you specify in the Export

Settings area. Some common audio options include the following:

Codec Specifies the codec used to encode the audio:

• SurCode for Dolby Digital 5.1 A high-quality encoding format developed for multichannel digital sound and the

most common encoder for DVD-video.

• MainConcept MPEG Audio A high-quality encoder developed by MainConcept media technologies, and included

with Adobe Premiere Pro and Adobe After Effects.

• PCM (pulse-code modulation) Audio A lossless audio format sampled at 48 kHz. Files of this format tend to be

larger than files of the other formats.

Audio Format Determines the audio type.

Bit Rate Specifies the output bitrate of the audio. Generally, higher bit rates increase both quality and file size. This

option is available for Dolby® Digital, MainConcept MPEG, and some Windows Media audio codecs.

Note: Options not documented here are specific to the selected format. For detailed information, consult the specifica-

tions for the selected format.

Adobe Media Encoder Alternates and Audiences options
Specifying a streaming media codec in RealMedia or Windows Media formats enables Audiences options, while

QuickTime streaming media codecs enable a similar set of Alternates options. Both allow you to output variations

of a movie suited to different network speeds. The player software associated with the format detects and selects the

most appropriate version to ensure smooth playback. For example, Windows Media includes Audiences such as

Dial-up Modems (56 Kbps) and Broadband Or Cable Modem/DSL (384 Kbps). Whereas QuickTime generates

individual movies suited for each export type, RealMedia and Windows Media generate a single movie that stores

the variations.

Note: Some codec-specific settings are not documented here. For more detailed information regarding a particular codec,

check the documentation provided by its developer.

To add Alternates or Audiences

1 In the Adobe Media Encoder Export Settings dialog box, specify a format that supports streaming media

(QuickTime, RealMedia, or Windows Media) and choose a streaming option from the Preset menu.

2 Select the Filters, Video, Audio, and Others tabs and specify the options you want.

3 Do either of the following:

• For RealMedia or Windows Media output, select the Audiences pane and specify the options you want.

• For QuickTime output, select the Alternates pane and specify the options you want.

4 With any pane selected, choose Add/Remove Audiences (or Add/Remove Alternates) from the panel menu (click

the arrow button in the upper right of the panel).

5 In the Select Audiences (or Select Alternates) dialog box, click Add.

6 In the System Audiences (or System Alternates) dialog box, check the options appropriate for your intended

viewers, and click OK.

7 Click OK to close the Select Audiences (or Select Alternates) dialog box.
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Note: You can’t have more than ten alternates or audiences. If necessary, you can delete the ones you don’t want, and

add the ones you want.

To copy or delete an Alternate or Audience

1 In the Adobe Media Encoder Export Settings dialog box, specify a format that supports streaming media

(QuickTime, RealMedia, or Windows Media) and choose a streaming option from the Preset menu.

2 Select the Filters, Video, Audio, and Others tabs and specify the options you want.

3 Do either of the following:

• For RealMedia or Windows Media output, select the Audiences pane and specify the options you want.

• For QuickTime output, select the Alternates pane and specify the options you want.

4 With any pane selected, choose Add/Remove Audiences (or Add/Remove Alternates) from the panel menu (click

the arrow button in the upper right of the panel).

5 In the Select Audiences (or Select Alternates) dialog box, select the item you want to copy or delete, and click

Duplicate or Remove.

6 If copying, click the name of the duplicate item, move the mouse slightly to highlight it, type a new name, and then

press Enter.

7 When you are finished, click OK.

Note: Removing an item from the Alternates or Audiences list can’t be undone.

Adobe Media Encoder Others options
The Others pane of the Export Settings dialog box allows you to upload the exported file to an FTP (File Transfer

Protocol) server that has storage space allocated for file sharing. FTP is a common method for transferring files over

a network, and is especially useful for sharing relatively large files using an Internet connection. The server’s admin-

istrator can provide you with the correct information to connect to the server successfully. The Others panel includes

the following options:

Server Name Enter the DNS or IP address of the server on which the FTP site is located.

Port Specify the number assigned to the FTP server’s command port, which is 21 by default.

Remote Directory Enter the location on the FTP server to access, expressed as a file path.

User Login Enter the user’s identity, as designated by the server’s administrator.

Password Enter the password to a password protected server.

Retries Specify the number of attempts to contact the server if a connection isn’t established.

Send Local File To Recycle Bin Deletes the local copy of the exported file once it has been uploaded to the FTP server.

Test Verifies the connection with the FTP server.

Log File Details Specify whether to generate a log file, and select the information that the log file includes (errors,

warnings, settings, and render frame time).

MPEG multiplexer preset options
Multiplexer preset options control how After Effects and Adobe Premiere Pro merge MPEG video and audio data

into a single stream. The exact options available depend on the MPEG format you choose.
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When you choose the MPEG-2 format, all Multiplexer options provided by the MPEG standard are available for

manual control. In most cases, it’s better to select an MPEG format specifically targeted to your output medium (such

as MPEG-2 DVD).

For more information on the options available, search the web for the ISO/IEC standards for the MPEG formats.

About XMP metadata
Metadata is descriptive file information that can be searched and processed by a computer. Adobe’s eXtensible

Metadata Platform (XMP) lets you include metadata with a file to provide information about the contents of the file.

Applications that support XMP can read, edit, and share this information across databases, file formats, and

platforms. Some Adobe programs, such as Adobe Bridge, can use or write XMP information.

You can specify XMP metadata to be included with a file you export using the Adobe Media Encoder when you

specify an MPEG-1 or MPEG-2 format.

To add XMP metadata to an exported file
❖ In the Export Settings dialog box’s panel menu (available in any pane, such as Video or Filters), select XMP Info,

and then enter information in the appropriate fields.

See also

“About metadata” on page 35

Rendering to OMF (Pro only)

About Open Media Framework (OMF) Interchange (Pro only)
After Effects lets you output to the OMF (Open Media Framework Interchange) format to generate Avid media (or

essence) files (files that contain only media —not metadata or project data). Each OMF codec has a fixed frame size

and frame rate, depending on the output resolution you choose. Make sure that the composition or render settings

are set appropriately: If you use an unsuitable frame size or frame rate, After Effects doesn’t render the file and

returns an error displaying the expected frame size or frame rate.

The OMF file format doesn’t support audio, so any audio tracks aren’t exported, but you can output audio tracks

separately, if desired.

To render a composition to OMF (Pro only)
1 In the Render Queue panel, click the Output Module template name to launch the Output Module Settings dialog

box.

2 From the Format menu, select OMF.

MPEG format ISO/IEC standard

MPEG-4 ISO/IEC 14496

MPEG-2 ISO/IEC 13818

MPEG-1 ISO/IEC 11172
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3 Click Format Options.

4 Choose a format (NTSC or PAL), an AVR (Avid Video Resolution) codec, and OMF version.

Note: OMFI version 1.0 is supported for backward compatibility with older Avid systems.

OMF AVR codec options (Pro only)
The following table lists the OMF AVR (Avid Video Resolution) codec options available for OMF in After Effects

and their associated frame sizes and frame rates.

Compression options

About compression
Compression is essential to reduce the size of movies that could otherwise be so that they can be stored, transmitted,

and played back effectively. When exporting or rendering a movie file for playback on a specific type of device at a

certain bandwidth, you choose a compressor/decompressor (also known as an encoder/decoder), or codec, to

compress the information and generate a file readable by that type of device at that bandwidth.

A wide range of codecs is available; no single codec is the best for all situations. For example, the best codec for

compressing cartoon animation is generally not efficient for compressing live-action video. When compressing a

movie file, you can fine-tune it for the best-quality playback on a computer, video playback device, the web, or from

a DVD player. Depending on which encoder you use, you may be able to reduce the size of compressed files by

removing artifacts that interfere with compression, such as random camera motion and excessive film grain.

The codec you use must be available to your entire audience. For instance, if you use a hardware codec on a capture

card, your audience must have the same capture card installed, or a software codec that emulates it.

For more information about compression, search for the Adobe DV Compression Primer (English only) on the

Adobe website.

About data rate
With some video codecs, you can specify the data rate, which controls the amount of video information that must

be processed each second during playback. Specifying a data rate actually sets the maximum data rate, because the

actual data rate varies depending on the visual content of each frame.

To maximize the quality of encoded video, set the data rate as high as the target delivery medium can support. If you

plan to stream video to an audience using dial-up Internet access, this may be as low as 20 kilobits per second;

however, if you plan to distribute video on DVD, it may be as high as 7 megabits per second.The data rate you specify

depends on the purpose of the video. The following list describes data rate guidelines for some uses:

DVD production The data rate should maximize quality while fitting the entire program within the space available

on the DVD. In Adobe Premiere Pro, the DVD data rate is automatically adjusted by the Adobe Media Encoder when

you choose File > Export > Export To DVD.

AVR Codec NTSC PAL

1:1 720 x 480 (interlaced), 29.97 fps 720 x 576 (interlaced), 25 fps

1:1 (24p/25p) 720 x 486 (progressive), 24 fps 720 x 576 (progressive), 25 fps

DV 720 x 480 (interlaced), 29.97 fps 720 x 576 (interlaced), 25 fps
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Non-DV videotape production The data rate should fall within the capabilities of the computer and hard disk that

perform the final playback to tape.

Hard-disk playback If the final video will be played back from a hard disk, determine the typical data transfer rate

of your audience’s hard disks and set the data rate accordingly. If you are exporting video to be used in another editing

system or to be imported into a compositing application, you’ll want to export at the maximum quality. Use a lossless

codec or the codec supported by your video capture card, and specify the data rate that the editing system supports

for video capture and editing.

CD-ROM playback The data rate for video played from a CD-ROM depends on the speed of the drive. For example,

if you are preparing a final video file for a quad-speed CD-ROM drive (600 kilobytes per second), you might specify

between 300 and 500 kilobytes per second to account for both the data rate of the drive and for the system overhead

required to move the data.

Intranet playback The data rate can be 1 megabit per second or faster, depending on the speed of your intranet.

Because they are limited in scope, intranets generally use higher quality communications lines than standard

telephone lines, so they are usually much faster than the Internet.

Streaming video over the web The data rate should account for real-world performance at the target data rate. For

example, the data rate for streaming video designed for a 56-kilobit-per-second connection is often set to 40 kilobits

per second. That’s because factors such as data volume and line quality often prevent telephone-based Internet

connections from consistently achieving their stated data rate. For broadband connections, set the data rate for

streaming video to 128 kilobits per second.

Downloading a video file over the web The data rate is less important than the size of the video file on disk, because

the main concern is how long it takes to download the file. However, it still may be desirable to reduce the data rate

for downloaded video because doing so reduces the size of the video file, making it download faster.

If you use Adobe Premiere Pro, use the Get Properties For command to analyze the data rate of files you export.

To specify QuickTime compression options
1 In the Render Queue panel, click the underlined name of the output module.

2 For Format, choose QuickTime.

3 Click Format Options in the Video Output section.

4 In the Compression Settings dialog box, choose a compressor.

Note: Set the color depth in the Compression Settings dialog box instead of in the Output Module Settings dialog box.

This ensures that non-Adobe plug-ins receive color depth information from After Effects. See step 8.

5 Select a Quality level from Least to Best.

Note: (Mac OS only): If you intend to use keyframes in the movie, hold down Option and adjust the Quality slider to

control the temporal compression of the movie. Temporal compression compresses a movie by comparing successive

frames and keeping only changed data. High temporal quality maintains smoothness of motion. Low temporal quality

tends to produce jerkiness of motion because a pixel doesn’t change unless the difference between frames is great.

6 If you want the smallest possible files, and your compressor choice allows for a key frame rate, select the box and

type a number in the Key Frame Every box. Generally, you should type a number equal to the frame rate. For

example, if you set a frame rate of 30 fps, type 30 in the Key Frame box. This sets one key frame every 30 frames of

your movie.
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Note: If you are going to use the resulting movie in another After Effects composition, type a small value (less than 5) in

the Key Frame Every box or deselect the Key Frame Every option. The presence of keyframes greatly increases the

memory required to edit and render a movie.

7 Click OK.

8 If your compressor choice supports different image color depths, choose the appropriate color depth in the Output

Module Settings dialog box:

• Choose Millions of Colors+ if you want 24-bit color quality and you want your composition background to be

transparent (to include an alpha channel). The composition’s background color is disregarded. Only Animation

and None can support the Millions of Colors+ color depth.

• Choose Millions of Colors if you want 24-bit color quality but want to include your composition background color

(no alpha channel).

Note: Color depth settings of Thousands of Colors or lower may cause banding and dithered images.

9 Select other options in the Output Module Settings dialog box, as described in “To change output module settings”

on page 607. Then click OK.

QuickTime compression options

Choices you make in the Compression Settings dialog box require trade-offs between file size and movie quality. The

higher the visual quality of your movie, the larger the file size.

Quality The Quality control specifies the spatial compression of the movie, which compresses the data in each frame

of a composition. Higher quality produces better image quality but results in a bigger movie file. Note that this

quality is unrelated to each layer’s quality setting in After Effects.

Key Frame Every In QuickTime terminology, the term key frames is different from the change-over-time keyframes

placed in the After Effects Timeline panel. In QuickTime, key frames are frames that occur at regular intervals in the

movie. During compression they are stored as complete frames. Each intermediate frame that separates them is

compared to the previous frame, and only changed data is stored. This greatly reduces movie size. Shorter intervals

between key frames enable faster seeking and reverse playback, but can significantly increase the size of the file.

To specify Video for Windows compression options
1 In the Render Queue panel, click the underlined name of the output module.

2 Choose Video For Windows from the Format menu.

3 Click Format Options in the Video Output section.

4 In the Video Compression dialog box, choose a compressor from the first menu in the Compressor section.

Choose a compressor based on the type of original images you have and the purpose of the rendered movie (available

compressors depend on the Video for Windows codecs installed on your computer).

You can render with 10-bpc YUV compression to create 10-bpc AVI files for use with HD footage in Adobe Premiere

Pro: choose 10-bit YUV (4:2:2 YUV) from the Compressor menu.

5 Select a Compression Quality level.

6 If you selected either Cinepak or Microsoft Video 1 in step 4, click the Configure button to set other options:

• For Cinepak, choose whether the movie is compressed to color or to black and white.
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• For Microsoft Video 1, choose a level for the temporal compression quality of the movie. Temporal compression

compresses a movie by comparing successive frames and keeping only changed data. High temporal quality

maintains smoothness of motion. Lower temporal quality tends to produce jerkiness of motion because a pixel

doesn’t change unless the difference between frames is great.

7 If you want the smallest possible files, and your compressor choice allows for a key frame rate, select the Key

Frame Every option and type a number of frames. Generally, you should type a number equal to the frame rate. For

example, if you set a frame rate of 30 fps, type 30 in the Key Frame box. This sets one keyframe every 30 frames of

your movie.

Note: If you are going to use the resulting movie in another After Effects composition, type a small value (less than 5) in

the Key Frame Every field or deselect the Key Frame Every option. The presence of keyframes greatly increases the

memory required to edit and render a movie.

8 Click OK.

9 If your compressor choice supports different image color depths, choose the appropriate color depth in the Output

Module Settings dialog box.

10 Choose other options in the Output Module Settings dialog box. (See “To change output module settings” on

page 607.) Then click OK.

Video for Windows compression options
Microsoft RLE Use for lossless compression limited to 256 colors.

Microsoft DV Use for digital video camcorders.

Intel Indeo/Microsoft Video Use when compressing video for playback from CD.

No Compression Use for a depth setting of Millions of Colors+ when an alpha channel is required.

Cinepak Use when compressing 16-bit and 24-bit video for playback from CD or for desktop presentations. For best

results, use the Cinepak compressor on raw source data that has not been previously compressed with a highly lossy

compressor. Note that this is a slow compression method. With Cinepak, decompression is much faster than

compression, and the data rate for playback can be defined by the user. However, you cannot save an alpha channel

using the Cinepak compressor.

Exporting footage using QuickTime components

Exporting using QuickTime
If you have QuickTime 6.0 or later installed on your system, you can export footage using components provided by

QuickTime. This rendering process exports footage directly without using the Render Queue panel in After Effects.

Compositions are exported using the Composition panel’s current quality and resolution settings, and only the work

area indicated in the time ruler is exported.

Note: You can also render to QuickTime by using the Render Queue panel. However, some QuickTime options, such as

Fast Start and Hinted Streaming, are available only through the QuickTime exporter.

The specific file formats you can export to depend on how you’ve configured QuickTime. If you install new export

modules as they become available from Apple or other third parties, those modules appear in the File > Export

submenu in After Effects. With this QuickTime support, you can export AVI files on both platforms or prepare

streaming video and audio for web distribution. If you want to apply QuickTime effects, you can do so during export.
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For more information about effects and file formats supported by QuickTime, see QuickTime Help.

To export files using QuickTime components
1 Select an item in the Project panel.

2 Choose File > Export, select the export module you want to use, specify options as necessary, and click Save.

Exporting and rendering single frames, filmstrip files,
and still sequences

About single-frame export
You can save a single frame from a composition to any supported still image format, such as an Adobe Photoshop

file with layers intact. One frame of the composition is rendered at the current time as set in the Composition panel.

This is useful for editing files in Adobe Photoshop, preparing files for Adobe Encore DVD, or for creating a proxy.

The Photoshop Layers command preserves all layers from a single frame of an After Effects composition in the

resulting Photoshop file, making it possible to use footage imported into After Effects as images in Photoshop.

Preserving layers is also useful if you want to use a composition frame as a source for print, web, and video.

The Photoshop Layers command also preserves layers that are in a nested composition by saving them as a

Photoshop layer group in the Photoshop file. In addition, the Photoshop file contains an embedded composite

(flattened) image of all the layers. This ensures that the file is compatible with applications that don’t support

Photoshop layers; such applications display the composited image and ignore the layers.

Keep in mind that the layered Photoshop file saved from After Effects may look different than the frame viewed in

After Effects if the frame uses features that aren’t supported by Photoshop. For example, if the frame contains a

blending mode that isn’t available in Photoshop, a blending mode that most resembles it is substituted in the layer,

but the embedded composite image (viewable only by applications that don’t support Photoshop layers) looks the

same. Alternatively, you can render the frame to a file format that doesn’t support layers instead of using the

Photoshop Layers command, and the resulting image looks the same in Photoshop as the frame does in After Effects.

To export a single composition frame
1 In the Composition panel, display the frame you want to export.

2 Do one of the following:

• To export a single composition frame, choose Composition > Save Frame As > File. Adjust settings in the Render

Queue panel if necessary, and then click Render.

• To export a single composition frame as an Adobe Photoshop file with layers, choose Composition > Save Frame

As > Photoshop Layers. Type a file name and click OK.

About Filmstrip format
Use Filmstrip format to paint directly on video frames in Adobe Photoshop, a process known as rotoscoping. You can

also rotoscope with paint tools in After Effects.
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You can render or export part or all of a composition, sequence, or clip as a single filmstrip file. Because video

compression is not used in creating filmstrip files, they can be large. If your computer doesn’t have enough memory

for Photoshop to load the filmstrip file, you can break the file into any number of smaller files by setting the work

area to a different portion of the composition or sequence before rendering or exporting each portion, or you can

export the composition, clip, or sequence as numbered still images so you can edit each frame as a separate file.

Note: If you simply want to export a single frame, you don’t need to use Filmstrip format.

A filmstrip opens in Adobe Photoshop as a series of frames in a column, with each frame labeled by number, reel

name, and timecode. If the column created by the filmstrip frames is more than 30,000 pixels tall, the frames

continue in a second column. The number of frames displayed depends on the duration of the footage or clip and

the frame rate selected when you render the filmstrip.

When editing a filmstrip in Adobe Photoshop, use the following guidelines for best results:

• After Effects will display only the part of each frame that lies within the frame border; however, you can paint on

the gray lines dividing the frames of the filmstrip without damaging the file.

• You can edit the red, green, blue, and alpha channels in the filmstrip file. Use only channel #4 as the alpha channel;

other alpha channels are not recognized.

• Do not resize or crop the filmstrip.

• Flatten any layers you add in Adobe Photoshop.

See also

“About single-frame export” on page 623

To render a composition as a filmstrip
1 Be sure that the composition you want to render is active. If you want to render only part of the composition, set

the work-area markers to define the part you want to render.

2 Choose Composition > Make Movie.

3 Type a file name.

4 In the Render Queue panel, click the underlined Output Module template name.

5 Choose Filmstrip from the Format pop-up menu. Specify the rest of the settings you want and click OK.

6 In the Render Queue panel, click Render.

To export a range of frames as a sequence of stills
Movies are the type of output most useful for easy previewing. However, a sequence of still images from a compo-

sition can be used for movie-making and desktop presentations. You can use a sequence of stills in the following

ways:

• Create still images for use in 3D animation.

• Transfer frames to film using a film recorder.

• Create still images for high-end video systems.

• Create still images and use them in a presentation.

• Select images for publishing or creating storyboards.
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• Export source images for a graphics program in which the images can be edited or retouched and imported back

into After Effects as footage items.

1 Choose Composition > Make Movie.

2 Type a file name.

Note: When rendering frames in Mac OS for use in Windows, the file name must be in this format: file_name[###].tga.

As each frame is rendered and a file name created for it, After Effects replaces the [###] portion of the name with a

number indicating the order of the frame in the sequence.

3 In the Render Queue panel, click the underlined Output Module template name.

4 Choose one of the sequence formats from the Format menu. Specify the rest of the settings you want and click OK.

5 In the Render Queue panel, click Render.

3D rendering

About 3D rendering
After Effects provides three 3D rendering plug-ins: Advanced 3D, Standard 3D, and OpenGL Hardware. These plug-

ins compute the motion blur, lighting, shadow, and depth-of-field information unique to 3D. OpenGL also provides

rendering support for a number of other 2D effects. After Effects can also use OpenGL—if the appropriate hardware

is available—during interactions like moving and rotating layers. After Effects can use the Advanced 3D rendering

plug-in to create both RAM previews and output files. The 3D rendering plug-in you specify becomes the default for

future compositions.

Rendering compositions containing both 2D and 3D layers
If a composition contains both 2D and 3D layers, After Effects renders the 3D layers in independent, noninteractive

groups (determined by their order in the Timeline panel) that are separated by the 2D layers. For example, if the

Timeline panel contains (from top to bottom) two 3D layers, two 2D layers, and two 3D layers, After Effects renders

the composition in the following order: First, the bottom two 3D layers as a set, according to their spatial order in

the Composition panel. Second, the 2D layers according to their Timeline panel order, from bottom to top. Third,

the top two 3D layers as a set. These are rendered in a geometric space independent of the 3D layers at the bottom

of the Timeline panel.

Essentially, the 2D layers split the 3D space into separate universes. The result is that shadows cast by either set of 3D

layers do not fall on the other set, and the two sets of 3D layers do not interact geometrically. The two sets of 3D

layers do share cameras and lights, because these two elements are global to the composition.

To use the Advanced 3D rendering plug-in
Use the Advanced 3D rendering plug-in (the default) to render compositions containing intersecting 3D layers. The

Advanced 3D rendering plug-in accurately calculates these layers so that they appear to slide through each other

naturally instead of popping from one side to the other. This plug-in also accurately calculates anti-aliasing, motion

blur, and blending modes for intersecting layers.
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To render shadows, the plug-in uses shadow maps, which are images rendered from the point of view of each light

source. Normally, a shadow’s resolution is computed automatically based on the composition resolution and the

quality settings (switches). If normal resolution doesn’t create the quality you want, or renders too slowly, you can

adjust the shadow map resolution. For example, if shadows are blurry and the Shadow Diffusion material option is

set to 0, increase the shadow map resolution. Or, if shadows render too slowly, decrease the shadow map resolution.

If your animation doesn’t include intersections and you don’t want to set the shadow map resolution, use the

Standard 3D rendering plug-in, which usually renders more quickly.

When using the Advanced 3D rendering plug-in, non-intersecting planes sometimes render as intersecting when the

layers almost touch, resulting in rear layers being visible through the front before they actually intersect. To avoid

this, move the layers slightly apart.

Note: The Advanced 3D rendering plug-in doesn’t support the Dissolve or Dancing Dissolve blending modes.

A 3D file with intersecting layers rendered with the Standard 3D renderer (left) compared to the Advanced 3D renderer (right)

1 Choose Composition > Composition Settings.

2 Click the Advanced tab.

3 Choose Advanced 3D from the Rendering Plug-in menu.

4 To specify the shadow map resolution, click Options, and choose an option from the Shadow Map Resolution

menu. (These options represent the resolution in pixels. Choose Comp Size or a resolution larger than the compo-

sition size for best results. Lower resolutions may result in shadows that appear blurry.)

Note: When a shadow-casting layer intersects another layer, sometimes there is a small gap behind the intersection that

is supposed to be shadowed. To decrease the size of the gap, increase the shadow map resolution.

To use the Standard 3D rendering plug-in
Use the Standard 3D rendering plug-in if your composition does not include intersecting layers—it may be faster for

some compositions, and it creates output of the same quality as the Advanced 3D rendering plug-in.

1 Choose Composition > Composition Settings.

2 Click the Advanced tab.

3 Choose Standard 3D from the Rendering Plug-in menu.

4 To specify anti-aliasing, click Options, and choose one of the following options from the Anti-aliasing menu:

Faster Renders the animation without employing any advanced anti-aliasing, which results in a faster render, but

with possibly ragged edges on edge-on animations.

More Accurate Employs advanced anti-aliasing when rendering the animation, which may slow the render time, but

will create edge-on animations with smoother edges.



ADOBE AFTER EFFECTS 7.0
User Guide

627

Rendering over a network

Network rendering with watch folders (Pro only)
The Adobe After Effects Professional Watch Folder feature speeds up the rendering process on a network. If you have

a full licensed copy of After Effects Professional, you can set it up to work with render-only versions of After Effects.

Your license entitles you to install as many copies of the render engine as you want on your network, as long as one

licensed copy of After Effects Professional is installed on that network.

You cannot use a watch folder and multiple render engines to render a single movie file. However, you can use

multiple render engines to render a sequence of individual still-image files.

When you have multiple render engines on multiple systems monitoring a watch folder, they cooperate to achieve

optimal efficiency. If your queued rendering items are set to Skip Existing Files (a Render Settings option), the render

engines all work on a single render item at once—no render engine renders any frame another render engine has

already worked on. If this option is not selected, each render engine handles a render item itself.

Computer with full version of After Effects Professional (A) saves a project and all source files to a folder (B) on a server. Computers with the
render engine installed (C) open the project and render a still-frame sequence to a designated output folder (D) on the server.

Network considerations

When working with multiple render engines on multiple systems, keep the following guidelines in mind:

• Each Windows computer monitoring the watch folder as a mapped network drive must map that drive using the

same drive letter. If this is a problem, make sure that the computer creating or collecting the project does not access

the volume being watched as a mapped drive letter. For example, connect to the volume as \\network\watch

instead of X:\watch.

• Each Macintosh computer monitoring the watch folder must have a unique name.

• Do not use the same computer to serve a watch folder and to run After Effects in Watch Folder mode. Use a

dedicated server that’s accessible to all render engines to serve your watch folder.

• Make sure that all servers and clients (computers monitoring the watch folder) have hard disks with unique names.

• Do not render to or initiate Watch Folder mode on the root of a volume or a shared folder that appears as the root

when viewed from another computer. Specify a subfolder instead. Also, avoid using high-ASCII or other extended

characters and slashes in file names. For multiple-computer rendering, After Effects includes a “Multi-machine”

sample template that you can use as a starting point.

A

B

D

C 
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When rendering across a network that includes volumes using different network or operating systems, such as

Windows, Mac OS, Novell, and UNIX®, make sure that you specify output files using a file-naming convention that’s

compatible with all rendering or destination volumes.

Project considerations

Make sure that you install all fonts, effects, and compressors used in the project on all computers monitoring the

watch folder. If a computer monitoring the watch folder can’t find fonts, effects, or compressors used in a project, the

render fails.

Collect Files folder considerations

If you save the Collect Files folder to a networked computer other than a server, don’t run a render engine on that

computer. Avoid saving the Collect Files folder to a local disk, the root level of a disk (such as C: in Windows or the

Macintosh HD in Mac OS), or a shared folder, all of which can signify different locations to each render engine. All

render engines must interpret the path the same way.

Once the collected files appear in the watch folder, all monitoring render engines start rendering automatically. If you

prefer, you can use the Collect Files command to store compositions and their source footage to a specified location

and then initiate the watch-folder rendering process later. Doing so renders the projects in alphabetical order, rather than

the order in which they were saved to the location.

To set up watch-folder rendering (Pro only)

1 Install the After Effects render engine on as many computers as you want to involve in network rendering.

Note: If rendering time is unusually slow, you may be rendering to too many computers, and the network overhead

required to track rendering progress among all computers is out of proportion to the time spent actually rendering

frames. The optimal number depends on many variables related to the network configuration and the computers on it;

experiment to determine the optimal number for your network.

2 Create a watch folder called AE Watch Folder on a system that’s accessible to all of the After Effects render engines

on your network.

3 In each render engine, choose File > Watch Folder, and select the watch folder that you’ve created.

4 Create your projects and compositions, and set them up in the Render Queue with the render settings and output

modules you want to use. (All render queue items in the project must have output names; otherwise the Enable

Watch Folder Render option in the Collect Files dialog box isn’t available.)

5 Choose File > Collect Files to copy completed projects to your specified watch folder. Once you choose Collect

Files, After Effects copies the project or composition and all source files to the watch folder.

Note:After Effects can’t copy source files that are larger than 2 GB using the Collect Files command: you must copy them

manually to the (Footage) folder in the Collect Files folder.

6 Choose For Queued Comps from the Collect Source Files menu (unless you’re manually moving source files), and

then select Change Render Output To. This option creates a folder on the networked server for rendered files—all of

the render engines need access to this folder to complete their rendering tasks.

7 Select Enable Watch Folder Render, click Collect, and name the Collect Files folder.

8 Save the Collect Files folder to a networked computer, preferably to a networked server.

9 Monitor the progress of the render engines by using a web browser to view HTML pages saved in the watch folder.

After Effects generates these pages automatically when the rendering begins. Click the Reload button in your

browser to see the updated status. These HTML pages will describe any errors that occur.
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After Effects renders the item to the specified destination folder and, if necessary, to the overflow volumes you have

specified in the Output preferences (see “Working with overflow volumes and segments” on page 631). When After

Effects finishes rendering all of the queued items in a given project, it closes that project without saving it and then

scans the watch folder for new projects to render. Because it doesn’t save the project, After Effects ignores any Post-

Render Actions in the Output Module settings dialog box that specify to import the item when it is rendered.

To track dependencies of a watch-folder render (Pro only)

You can track render dependencies when you render over a network by setting Post-Render Action options. When

you set these options, After Effects confirms that all of the items that it needs to render are ready and available. For

example, if one item depends on another to render, and the first has not finished rendering or has received an error,

the second does not render.

You can use this process to render a single QuickTime or AVI movie from a watch-folder render. The movie is

actually created on only one computer.

Note:This procedure assumes that you have already created a multiple-system watch-folder. (See “To set up watch-folder

rendering (Pro only)” on page 628.)

1 In the Render Queue panel, drag the output module to the Project panel. After Effects creates a placeholder for

that item's output.

2 Drag the placeholder back to the Render Queue panel.

3 Set the render settings and output module settings for the placeholder, and click Render.

To start in watch folder mode (Pro only)

Watch-folder mode applies only to rendering from a folder on your local computer.

• To start After Effects in watch-folder mode automatically, save a project with the file name Watch This Folder.aep.

After Effects watches the folder containing the project if you open that project.

• To start After Effects in watch-folder mode when you start your computer, create a shortcut (Windows) or alias

(Mac OS) to the Watch This Folder.aep project and move it to your Startup folder (Windows) or your Startup

Items folder (Mac OS). After Effects watches the folder containing the project if you open that project.

• (Windows only) To start After Effects in watch-folder mode from the command line, choose Start > Run, and then

enter the following, modifying the application path to the exact name of the folder in which you installed After

Effects, and replacing C:\[temp] with the path to your watch folder: “C:\Program Files\Adobe\Adobe After

Effects 7.0\Support Files\afterfx.exe" -wf C:\[temp]

Note: You can also use this command line in batch files.

Using multiple computers to render plug-in effects (Pro only)

When a composition contains layers that use a plug-in effect, the plug-in that created the effect must be present on

all of the computers that will render the composition.

When you install an After Effects render engine on a computer, it contains all the plug-ins included with After Effects

Professional. If a composition uses a plug-in from another manufacturer, that plug-in must be present on all

computers that will render the composition. However, support for network rendering varies among plug-in

manufacturers. Before you set up a network to render effects created by third-party plug-ins, see your plug-in’s

documentation or contact the plug-in manufacturer and get answers to the following questions:

• Does the plug-in’s license agreement allow installing multiple copies on a network for the purposes of rendering?

• Are there any other limitations or tips that apply to using that plug-in for network rendering?
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To render a single-frame sequence with multiple systems
Although the preferred method of rendering for multiple systems is using the Watch Folder feature, you can also use

multiple systems and multiple copies of After Effects to render a project across a network. You can use multiple

systems to render only single-frame sequences; you cannot use multiple systems to render movies.

When you render a single-frame sequence with multiple systems, rendering in each copy of After Effects starts at

approximately the same time. By specifying that each copy skip existing frames or frames in progress, multiple

systems can render the project simultaneously, writing the single-frame sequence to a single folder.

There is no limit to the number of systems you can use for rendering; in general, the more systems, the faster the

rendering. However, if too many systems are used across a busy network, network traffic may slow down the entire

process. You can detect network slowdown by observing the time spent in the Compressing & Writing stage in the

Show Details section of the Render Queue panel. Rendering with multiple instances does not work if you run two or

more instances of After Effects on the same computer running Mac OS X.

Note: Adobe does not provide technical support for general network configuration; consult your network administrator.

Note: If you are rendering a project using After Effects Professional effects on multiple systems, each system must be

running After Effects Professional.

1 Install After Effects on each system rendering the project. Make sure that you have the same fonts installed on

each system.

Note: Do not share plug-ins across a network. Make sure that you have a copy of the plug-ins folder on each system that

is running After Effects. When using third-party plug-ins, also be sure that the same plug-ins are available on all systems

and that you have sufficient licenses for the plug-ins.

2 Open the project on one system, and then choose Composition > Add To Render Queue.

3 In the Render Queue panel, select Skip Existing Files in the Render Settings section so that multiple systems do

not render the same frames. Make sure that Use Storage Overflow is deselected.

4 Specify a single-frame sequence in the Output Module area, and specify a folder in the Output To area. This folder

must be available for all the systems that are rendering.

5 Save the project on the system where you opened it in step 2.

6 On each system that will be rendering, open and save the project. This ensures that After Effects records the new

relative paths to each system in the following step.

7 Unless the network can handle large file transfers rapidly, copy the project file and all its source footage to each

rendering system.

8 Open the Render Queue panel on each system and click Render. You do not need to start rendering on each

system simultaneously, but to ensure equal workloads, start them at approximately the same time. As each system

finishes rendering a frame, After Effects searches the Output folder for the next unrendered frame and starts

rendering again.

9 You can stop and start any system at any time. However, if you stop a system without starting it again, the frame

that it was rendering may not be finished. If one or more systems stop during rendering, starting any one system will

ensure that all frames in the sequence get rendered.
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Working with overflow volumes and segments
You can set the Output preferences to make After Effects render to up to five different disk volumes and according

to when the remaining hard disk space reaches a certain limit. These options are useful when your rendered output

exceeds the amount of available hard disk space. After Effects can also render sequences and movie files into

segments that are limited to a specified number of files or by file size.

A situation in which After Effects reaches a disk space limit while rendering a composition is called an overflow.

Specify this limit for Minimum Diskspace Before Overflowing in the Output Preferences dialog box. When After

Effects overflows a volume, the resulting files go into a folder on the root of the next volume in the After Effects

Overflows list. You can specify multiple volumes to which rendered compositions can be directed. By doing so, each

time a volume fills up, After Effects tries the next volume on the Preferences list.

Note: It is important to look at the log file after rendering; the log file reports when a render overflows.

To specify overflow settings

1 Choose Edit > Preferences > Output (Windows) or After Effects > Preferences > Output (Mac OS).

2 To set overflow volumes, choose the volumes you want from the Volume menus under Overflow Volumes.

3 Specify the minimum number of megabytes left on your volume before overflowing to the next volume in the

Minimum Diskspace Before Overflowing text box, and then click OK.

To specify segment settings

You can specify a size for your output so that After Effects renders files in segments even if overflow isn’t necessary.

You may want to segment files if you work with applications that restrict the size of imported files. In addition, if

After Effects reaches a disk space limit and overflows across volumes, your output is distributed to files of a prede-

termined size.

1 Choose Edit > Preferences > Output (Windows) or After Effects > Preferences > Output (Mac OS).

2 To specify segment sizes for your output, do any of the following and then click OK:

• Select Segment Sequences At, and then enter a number for the maximum number of files each folder should

contain.

• Select Segment Movie, and then enter a number for the maximum size in kilobytes for each movie segment.

To remove clicks or pops from rendered MP3 output, set the Audio Block Duration in Output preferences to longer

than the length of the output movie.

Exporting project information to other Adobe
applications

To export an After Effects project to Adobe Premiere Pro (Windows only)
You can export an After Effects project as an Adobe Premiere Pro project without rendering.

When you export an After Effects project as an Adobe Premiere Pro project, Adobe Premiere Pro uses the settings

from the first composition in the After Effects project for all subsequent sequences. Keyframes, effects, and other

properties are converted in the same way as when you paste an After Effects layer into an Adobe Premiere Pro

sequence.

1 Choose File > Export > Adobe Premiere Pro Project.
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2 Specify a file name and location for the project, and click Save.

Note: You can also import Adobe Premiere Pro projects into After Effects. (See “To import an Adobe Premiere Pro

project” on page 94.)

See also

“Copying from After Effects to Adobe Premiere Pro (Windows only)” on page 126

About Adobe Dynamic Link (Adobe Production Studio only)
Until now, sharing media assets among post-production applications has required you to render your work in one

application before importing it into another—an inefficient and time-consuming workflow. If you wanted to make

changes in the original application, you had to re-render the asset. Multiple rendered versions of an asset consume

disk space and can lead to file-management challenges.

Adobe Dynamic Link, a feature of Adobe Production Studio, offers an alternative to this workflow: the ability to

create dynamic links, without rendering, between new or existing compositions in After Effects and either Adobe

Premiere Pro or Adobe Encore DVD. Creating a dynamic link is as simple as importing any other type of asset, and

dynamically linked compositions appear with unique icons and label colors to help you identify them. Dynamic links

are saved as part of the Adobe Premiere Pro or Adobe Encore DVD project.

Changes you make to a dynamically linked composition in After Effects appear immediately in the linked files in

Adobe Premiere Pro or Adobe Encore DVD; you don’t have to render the composition or even save changes first.

When you link to an After Effects composition, it appears in the target product’s Project panel. You can use the linked

composition as you would any other asset. When you insert a linked composition into the target product’s timeline,

a linked clip, which is simply a reference to the linked composition in the Project panel, appears in the Timeline

panel. After Effects renders the linked composition on a frame-by-frame basis during playback in the target product.

• In Adobe Premiere Pro, you can preview the linked composition in the Source Monitor, set In and Out points, add

it to a sequence, and use any of the Adobe Premiere Pro tools to edit it. When you add a linked composition that

contains both footage and audio layers to a sequence, Adobe Premiere Pro inserts linked video and audio clips in

the timeline. (You can unlink these to edit them separately; search for “To unlink video and audio” in Adobe

Premiere Pro Help.)

• In Adobe Encore DVD, you can use the linked composition to create a motion menu or insert it into a timeline,

and use any of the Adobe Encore DVD tools to edit it. When you add a linked composition that contains both

video and audio layers to an Adobe Encore DVD timeline, Adobe Encore DVD inserts separate video and audio

clips in the timeline.

Other ways to share content among Production Studio applications include copying and pasting between After

Effects and Adobe Premiere Pro, exporting After Effects projects to Adobe Premiere Pro, using the Capture In Adobe

Premiere Pro command in After Effects, creating After Effects compositions from Adobe Encore DVD menus, or

importing Adobe Premiere Pro projects into After Effects. For more information, see the relevant product’s Help.

For a tutorial on Adobe Dynamic Link, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.
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Saving and Adobe Dynamic Link (Adobe Production Studio only)
You must save your After Effects project at least once before you can create a dynamic link from Adobe Premiere Pro

or Adobe Encore DVD to a composition within it. However, you don’t have to subsequently save changes to an After

Effects project to see changes to a linked composition in Adobe Premiere Pro or Adobe Encore DVD.

If you use the Save As command to copy an After Effects project that contains compositions referenced by Adobe

Dynamic Link, Adobe Premiere Pro or Adobe Encore DVD uses the original composition—not the new copy—as

its source for the linked composition. You can relink a composition to the new copy at any time (see “To relink a

dynamically linked composition (Adobe Production Studio only)” on page 635).

Managing performance and Adobe Dynamic Link (Adobe Production Studio only)
Because a linked composition may reference a complex source composition, actions you perform on a linked compo-

sition may require additional processing time as After Effects applies the actions and makes the final data available

to Adobe Premiere Pro or Adobe Encore DVD. In some cases, the additional processing time may delay preview or

playback.

If you’re working with complex source compositions and experiencing playback delays, you can take the compo-

sition offline or disable a linked clip to temporarily stop referencing a dynamically linked composition (see “To take

a dynamically linked composition offline (Adobe Production Studio only)” on page 635), or render the composition

and replace the dynamically linked composition with the rendered file. If you commonly work with complex source

compositions, try adding RAM or using a faster processor.

Color and Adobe Dynamic Link (Adobe Production Studio only)
Adobe After Effects works in the RGB (red, green, blue) color space. Adobe Premiere Pro, however, works in the

YUV color space. When you work with a dynamically linked composition, Adobe Premiere Pro either converts it to

YUV or retains the RGB color space, depending on the output format.

Dynamically linked compositions are rendered in the color depth of the After Effects project (8-, 16-, or 32-bpc,

depending on Project Settings). Set the After Effects project color depth to 32-bpc if you’re working with HDR (high

dynamic range) assets.

In Adobe Premiere Pro, choose Project > Project Settings > Video Rendering, and select Maximum Bit Depth to have

Adobe Premiere Pro process at the highest possible quality. This option may slow processing.

To link to a new composition with Adobe Dynamic Link (Adobe Production Studio
only)
When you link to a new composition from Adobe Premiere Pro or Adobe Encore DVD, After Effects starts and

creates a new project and composition with the dimensions, pixel aspect ratio, frame rate, and audio sample rate of

your Adobe Premiere Pro or Adobe Encore DVD project. (If After Effects is already running, it creates a new compo-

sition in the current project.) The new composition name is based on the Adobe Premiere Pro or Adobe Encore DVD

project name, followed by “Linked Comp [x].”

1 In Adobe Premiere Pro or Adobe Encore DVD, choose File > Adobe Dynamic Link > New After Effects Compo-

sition.

2 If the After Effects Save As dialog box appears, enter a name and location for the After Effects project, and click

Save.
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When you link to a new After Effects composition, the composition duration is set to 30 seconds. To change the

duration, select the composition in After Effects and choose Composition > Composition Settings. Click the Basic tab,

and specify a new value for Duration.

To link to an existing composition with Adobe Dynamic Link (Adobe Production Studio
only)
For best results, composition settings (such as dimensions, pixel aspect ratio, frame rate, and audio sample rate)

should match those used in the Adobe Premiere Pro or Adobe Encore DVD project.

❖ Do one of the following:

• In Adobe Premiere Pro or Adobe Encore DVD, choose File > Adobe Dynamic Link > Import After Effects

Composition. Choose an After Effects project file (.aep), and then choose one or more compositions.

• Drag one or more compositions from the After Effects Project panel to the Adobe Premiere Pro or the Adobe

Encore DVD Project panel.

• In Adobe Premiere Pro, choose File > Import. Choose an After Effects project file and click Open, and then choose

a composition in the Import Composition dialog box and click OK.

• In Adobe Premiere Pro, drag an After Effects project file into the Project panel. If the After Effects project file

contains multiple compositions, Adobe Premiere Pro displays the Import Composition dialog box.

Note: You can link to a single After Effects composition multiple times in a single Adobe Premiere Pro project. In an

Adobe Encore DVD project, however, you can link to an After Effects composition only once.

Adobe Encore DVD and After Effects: If you are linking to DVD menus or buttons, turn off subpicture highlight

layers in After Effects so that you can control their display in Adobe Encore DVD. For more information, search for

“subpicture” in Adobe Encore DVD Help or Adobe After Effects Help.

Dynamically linked After Effects compositions

To delete a dynamically linked composition or clip (Adobe Production Studio only)
You can delete a linked composition from an Adobe Encore DVD project if the composition isn’t used in the project.

You can delete a linked composition from an Adobe Premiere Pro project at any time, even if the composition is used

in a project.

You can delete linked clips, which are simply references to the linked composition in the Project panel, from the

timeline of an Adobe Premiere Pro sequence or from an Adobe Encore DVD menu or timeline at any time.

❖ In Adobe Premiere Pro or Adobe Encore DVD, select the linked composition or clip and press the Delete key.

To edit a dynamically linked composition in After Effects (Adobe Production Studio
only)
Use the Edit Original command in Adobe Premiere Pro or Adobe Encore DVD to edit a linked After Effects compo-

sition. Once After Effects is open, you can make edits without having to use the Edit Original command again.

1 Select the After Effects composition in the Adobe Premiere Pro or Adobe Encore DVD Project panel, or choose

a linked clip in the Timeline, and choose Edit > Edit Original.
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2 Make edits in After Effects, and then switch back to Adobe Premiere Pro or Adobe Encore DVD to view your

changes.

Note: If you change the name of the composition in After Effects after you’ve created a dynamic link to it from Adobe

Premiere Pro, Adobe Premiere Pro doesn’t update the linked composition name in the Project panel, but retains the

dynamic link.

About offline compositions and Adobe Dynamic Link (Adobe Production Studio only)
Adobe Premiere Pro and Adobe Encore DVD display dynamically linked compositions as offline in any of the

following circumstances:

• You’ve renamed, moved, or deleted the After Effects project that contains the composition.

• You’ve purposefully taken the composition offline.

• You’ve opened the project that contains the composition on a system on which the Adobe Production Studio isn’t

installed.

Offline compositions appear with an Offline icon  in the Adobe Premiere Pro or Adobe Encore DVD Project

panel. If you’re working with an offline composition, you can relink it to the original After Effects composition. You

can also choose to relink a linked composition to a different source composition.

To take a dynamically linked composition offline (Adobe Production Studio only)

You can take a dynamically linked composition offline if system resources are low, preventing you from smoothly

playing back or previewing, or if you want to share your project without having to open it on a system with

Production Studio installed. When you take a composition offline, you sever the dynamic link with After Effects,

and the linked composition is replaced in the Project panel with an offline composition.

In Adobe Encore DVD, you take a composition offline by transcoding it (transcoding is the process by which Adobe

Encore DVD converts non-DVD compliant files to the DVD-compliant files that are burned to disc).

❖ Select the composition in the Project panel and do one of the following:

• In Adobe Premiere Pro, choose Project > Make Offline.

• In Adobe Encore DVD, choose File > Transcode Now.

You can temporarily suppress a linked clip in Adobe Premiere Pro by selecting the clip and choosing Clip > Enable.

To relink the clip, choose Clip > Enable again (a check mark next to the command indicates that the clip is enabled).

For more information about disabling clips, see Adobe Premiere Pro Help.

To relink a dynamically linked composition (Adobe Production Studio only)

❖ Do one of the following:

• In Adobe Premiere Pro, select the composition and choose Project > Link Media. In the Import Composition

dialog box, choose an After Effects project, and then choose a composition.

• In Adobe Encore DVD, right-click the composition and choose Locate Asset. In the Open dialog box, locate the

composition you want to link to and then click Open.
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Chapter 20: Performance and memory

Memory

Memory usage
Memory requirements for viewing and rendering increase with the resolution of the composition frame, the memory

requirement of the most memory-intensive layer in the composition, and the size of the project file.

After Effects renders each frame of a composition one layer at a time. For this reason, the memory requirement of

each individual layer is more important than the duration of the composition or the number of layers in the compo-

sition. The memory requirement for a composition is equivalent to the memory requirement for the most memory-

intensive single layer in the composition. For example, it generally takes less memory to render 30 layers at NTSC

resolution than 2 layers at motion-picture film resolution.

When a layer includes a composition as a source item, everything in that composition must be rendered before the

next layer is rendered.

The memory requirements of a layer increase under the following circumstances:

• You use a larger source image.

• You add a mask.

• You use certain blending modes or effects, especially those that involve multiple layers.

• You apply certain output options, such as 3:2 pulldown, cropping, and stretching.

• You add shadows or depth-of-field effects.

If you have no problems viewing each frame of a full-resolution, best-quality preview of a composition, then you

have enough memory to render the composition. Rendering a composition into a movie takes no more memory than

displaying it on-screen.

Occasionally, After Effects may display an alert message indicating that it requires more memory to display or render

a composition. If you receive an out-of-memory alert, follow procedures in this section to free memory or reduce

the memory requirements of your most memory-intensive layers, and then try again.

Free memory immediately with one or more of the commands in the Edit > Purge menu.

After Effects requires a contiguous block of memory to store each frame; it cannot store a frame in pieces in

fragmented memory.

Use the following formula to determine the number of megabytes required to store one uncompressed frame at full

resolution:

(height in pixels) x (width in pixels) x (number of bits per channel) / 2,097,152

Note: The value 2,097,152 is a conversion factor that accounts for the number of bytes per megabyte (220), the number

of bits per byte (8), and the number of channels per pixel (4).

For example, a DV NTSC frame in an 8-bpc project requires 1.3 megabytes, and a D1/DV PAL frame in an 8-bpc

project requires 1.6 megabytes, whereas a 1080i60 DVCPRO HD frame in a 32-bpc project requires 21.1 megabytes.
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After Effects on the Mac OS X operating system can use up to 3.5 GB of RAM.

After Effects on the 32-bit Windows XP Professional operating system can use up to 3GB of RAM; however, to use

more than 2GB in After Effects, you must configure Windows appropriately. (See the Microsoft website for details.)

After Effects on 64-bit Windows operating systems can use up to 4GB of RAM with no special configuration.

Caches
As you work on a composition, After Effects temporarily stores some rendered frames and source images in RAM,

so that previewing and editing can occur more quickly. After Effects does not cache frames that require little time to

render. Frames remain uncompressed in the cache. You can control how After Effects stores images by setting image-

caching preferences.

After Effects also caches at the footage and layer level for faster previews; layers that have been modified are rendered

during the preview, and unmodified layers are displayed from the cache.

When the cache is full, any new frame added to the cache replaces a frame cached earlier. When you compile frames

for RAM previews, After Effects stops adding frames to the cache when the cache is full and begins playing only the

frames that could fit in the cache. The disk cache is not used for RAM previews. If disk caching is enabled, After

Effects can store rendered items to your hard disk when the RAM cache is full during standard previews.

The RAM cache and disk cache are automatically purged when you quit After Effects.

To purge the RAM cache and disk cache, choose Edit > Purge > Image Caches.

Blue bars in the Timeline panel mark frames that are cached to disk. Green bars mark frames that are cached to RAM.

Choose Show Cache Indicators from the Timeline panel menu to turn the cache indicators on and off.

To set caching preferences
1 Choose Edit > Preferences > Memory & Cache (Windows) or After Effects > Preferences > Memory & Cache

(Mac OS).

2 Set any of the following values:

Maximum Memory Usage Sets the maximum amount of memory to use for any purpose. You can specify values over

100% (where 100% equals the amount of physical RAM you have installed) because virtual memory uses hard-disk

space. Values over 200% are not recommended. The default value is 120%.

Maximum RAM Cache Size Sets the maximum amount of installed RAM to use for cached frames. If you set this

value to greater than the default value of 60%, you may encounter problems such as decreased performance when

switching from one application to another. Set this value above 60% only if necessary. You should not set this value

above 90%.

Enable Disk Cache Moves rendered frames to your hard disk when the RAM cache is full. Select a folder to contain

your cache, and click OK (Windows) or Choose (Mac OS).

For the best performance, select a folder that’s on a different physical hard disk than your source footage. If possible,

the folder should be on a hard disk that uses a different drive controller than the disk that contains your source

footage. The disk cache folder can’t be the hard disk’s root folder.

Maximum Disk Cache Size Specifies the number of megabytes of hard disk space to use.
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Simple ways to improve performance

Improving performance before starting After Effects
You can achieve significant performance improvements by preparing your system before you start After Effects. Do

any of the following before you start After Effects:

Make sure that you’ve installed the current version of After Effects, including any available updates.

Visit the Adobe website for details.

Make sure that you’ve installed the latest versions of drivers and plug-ins.

To download updates for drivers and plug-ins, visit the provider’s website.

Quit applications that are not necessary for your work.

This may include some applications that start automatically during startup of the operating system.

Make sure that your system includes a display card that supports OpenGL 1.5 or later (2.0 recommended).

Though After Effects can function without it, OpenGL accelerates various types of rendering, including rendering

to the screen for previews. (See “Supported OpenGL features” on page 140.)

Adjust the size of the virtual memory paging file (Windows only).

Virtual memory enables the system to use hard-disk space to store information normally stored in RAM. Windows

manages virtual memory using a paging file. To improve performance in After Effects, adjust the size of the paging

file to a maximum of twice the amount of installed RAM—the default in Windows XP. (See Windows Help.)

Defragment all hard disks regularly.

See the documentation for your operating system for details.

Make sure that your system has enough RAM.

See the documentation for your operating system and computer for details on how to check the amount of installed

RAM and how to install RAM.

Improving performance when using effects
Some effects, such as blurs and distortions, require large amounts of memory and processor resources. By being

selective about when and how you apply these effects, you can greatly improve overall performance.

Do any of the following:

Apply memory-intensive and processor-intensive effects later.

Animate your layers and do other work that requires real-time previews before you apply memory-intensive or

processor-intensive effects (such as blurs), which may make previews slower than real time.

Temporarily turn off effects to increase the speed of previews.

See “To temporarily turn off effects” on page 349.

Limit the number of particles that are generated by the Particle Playground effect.

See “Improving performance with Particle Playground (Pro only)” on page 514.
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Choose Stiff Elasticity for the Mesh Warp, Reshape, and Smear effects in the Distort effects category.

See “Mesh Warp effect (Pro only)” on page 427, “Reshape effect (Pro only)” on page 430, and “Smear effect” on

page 433.

Turn off linear blending.

See “To enable linear blending” on page 66.

Improving performance by simplifying your project
By simplifying and dividing your project, you can prevent After Effects from using memory and other resources to

process elements other than those that you are currently working with. Also, by controlling when After Effects

performs certain processing, you can greatly improve overall performance. For example, you can avoid repeating an

action that needs to happen only once, or you can postpone an action until it is more convenient for you.

Do any of the following:

Delete unused elements from your project.

See “To remove footage from a project” on page 59.

Divide complex projects into simpler projects, and then recombine them before you render the finished movie.

To recombine projects, import all of the projects into a single project by choosing File > Import > File.

Prerender nested compositions.

Render a completed composition as a movie so that After Effects doesn’t rerender the composition every time it is

displayed.

See “Saving time by prerendering nested compositions” on page 132

Deselect Switches Affect Nested Comps to restrict the effect of layer switches.

Choose Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS), and deselect

Switches Affect Nested Comps. Remember to select this option again before you render the composition for final

output.

Collapse transformations for nested compositions.

See “Using the Collapse Transformations/Continuously Rasterize switch” on page 168.

Substitute a low-resolution or still-image proxy for a source item when not working directly with that item.

See “To work with low-resolution proxies for footage” on page 129

Lower the composition’s resolution.

See “Setting resolution” on page 114.

Note: To increase the rendering speed of RAM previews, set the resolution of the Composition panel to match the magni-

fication. For example, if the magnification is 50%, choose Half from the Resolution menu.

Isolate the layer you’re working on by using the Solo switch.

See “To solo a layer” on page 160.
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Deselect the Continuously Rasterize switch for an Illustrator file until you need to view or render it in detail.

This prevents After Effects from rasterizing the entire file after each change.

See “Using the Collapse Transformations/Continuously Rasterize switch” on page 168 and “To continuously

rasterize an Illustrator file” on page 92.

Improving performance by modifying screen output
You can improve performance in many ways that don’t affect how After Effects treats your project data, only how

output is drawn to the screen as you work. Although it is often useful to see certain items and information in your

workspace, After Effects must use memory and processor resources to update this information, so be selective in

what you choose to display as you work. You will likely need to see different aspects of your project at different points

in your workflow, so you may apply the following suggestions in various combinations at various stages.

Do any of the following:

Close unneeded panels.

After Effects must use memory and processor resources to update open panels, which may slow the work that you

are doing in another panel.

Create a region of interest.

If you are interested only in changes in a small part of your composition, limit which portion of the composition is

rendered to the screen during previews. See “To change the region of interest” on page 118.

Deselect Show Cache Indicators.

Deselect Show Cache Indicators in the Timeline Options menu to prevent After Effects from displaying green and

blue bars in the time ruler to indicate cached frames.

Deselect Show Rendering Progress In Info Panel & Flowchart.

Deselect this Display preference to prevent the details of each render operation for each frame from being written to

the screen.

Hide Current Render Details in the Render Queue panel.

To hide these details, click the triangle beside Current Render Details in the Render Queue panel.

Press the Caps Lock key to prevent After Effects from updating Footage, Layer, or Composition panels.

When you make a change that would otherwise appear in a panel, After Effects adds a red outline to the panel. After

Effects continues to update panel controls such as motion paths, anchor points, and mask outlines as you move them.

To resume panel updates and display all changes, press Caps Lock again.

Lower a layer’s display quality to Draft or Wireframe.

See “To change the layer image quality” on page 168.

Select Draft 3D mode in the Timeline panel menu.

Draft 3D mode disables all lights and shadows that fall on 3D layers. It also disables the camera’s depth-of-field blur.

Deselect Live Update in the Timeline panel menu.

This prevents After Effects from updating compositions dynamically.
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Display audio waveforms only when necessary.

See “Audio Waveform effect” on page 443.

Deselect Pixel Aspect Ratio Correction.

For best results, select Pixel Aspect Ratio Correction for previewing only. (See “To correct pixel aspect ratio for

previewing” on page 113.)

Deselect Mirror On Computer Monitor when previewing video on an external video monitor.

See “Previewing on an external video monitor” on page 147.

Hide layer controls, such as color masks, color axes, and layer handles.

Choose View > Hide Layer Controls.

Lower the composition’s magnification.

When After Effects displays the Composition, Layer, and Footage panels at magnifications of 100% or greater, screen

redraw speed decreases.

Multiprocessor plug-in
On multiprocessor systems, After Effects uses a multiprocessor plug-in to accelerate processor-intensive operations,

such as movement, rotation, motion blur, and blending. Performance improvement also depends on factors such as

the operating system and the type and number of processors.

The multiprocessor plug-in is installed automatically during After Effects installation.

The multiprocessor plug-in for Windows XP Professional (MThread.aex) works on multiprocessor systems,

including systems with virtual multiprocessors. The multiprocessor plug-in for Mac OS X (MThread.plugin) works

on multiprocessor systems such as Apple G5.

To determine the effect that the multiprocessor plug-in has on rendering speed, render a project using the plug-in,

move the plug-in out of the Plug-ins folder, render the project again, and compare the rendering times.

See also

“Plug-ins” on page 66
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Chapter 21: Keyboard shortcuts

Default keyboard shortcuts

Keyboard shortcuts
“Keys for selecting tools” on page 642

“Keys for working with settings” on page 643

“Keys for using footage items” on page 643

“Keys for viewing panels” on page 644

“Keys for moving around the Timeline panel” on page 645

“Keys for moving around panels” on page 645

“Keys for previewing” on page 646

“Keys for nudging layers” on page 646

“Keys for using layers” on page 647

“Keys for viewing layer properties” on page 648

“Keys for working with the Composition panel” on page 649

“Keys for modifying keyframes” on page 650

“Keys for working with the Graph Editor” on page 651

“Keys for setting the work area” on page 651

“Keys for using masks” on page 652

“Keys for using the Effect Controls panel” on page 652

“Keys for 3D animation” on page 652

“Keys for using markers” on page 653

“Keys for painting” on page 653

“Keys for using text” on page 654

“Keys for working with Adobe Bridge” on page 655

For additional information, go to Adobe Studio on the Adobe website.

Adobe periodically provides updates to software and Help. To check for updates, click the Preferences button  in

Adobe Help Center, and then click Check For Updates. Follow the on-screen instructions.

Keys for selecting tools
Use these shortcuts in the Tools panel. In most cases, you can momentarily switch tools by holding down the

keyboard shortcut for the tool.
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Keys for working with settings
You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Keys for using footage items
Use these shortcuts in the Project panel.

You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Result Windows Mac OS

Selection tool V V

Rotation tool W W

Camera tools (Orbit, Track XY, and
Track Z)

C or Shift + C to select and cycle
through tools

C or Shift + C to select and cycle
through tools

Brush, Clone Stamp, and Eraser
tool

Ctrl + B to select and cycle
through tools

Command + B to select and cycle
through tools

Hand tool H, or hold down spacebar H, or hold down spacebar

Zoom tool Z. With the Zoom In tool selected,
hold Alt to select the Zoom Out
tool.

Z. With the Zoom In tool selected,
hold Option to select the Zoom
Out tool.

Pan Behind tool Y Y

Mask tools (Rectangular and Ellip-
tical)

Q or Shift + Q to select and cycle
through tools

Q or Shift + Q to select and cycle
through tools

Type tools (Horizontal and
Vertical)

Ctrl + T to select and cycle
through tools

Command + T to select and cycle
through tools

Pen tools (Add Vertex, Delete
Vertex, and Convert Vertex)

G to select and cycle through
tools. Hold down Ctrl to switch
between the Pen tool and Selec-
tion tool.

G to select and cycle through
tools. Hold down Command to
switch between the Pen tool and
Selection tool.

Result Windows Mac OS

Open Project Settings dialog box Ctrl + Alt + Shift + K Command + Option + Shift + K

Restore default preferences
settings

Hold down Alt + Ctrl + Shift while
starting After Effects

Hold down Option + Command +
Shift while starting After Effects

Result Windows Mac OS

Open selected footage item or
composition

Double-click or Enter on numeric
keypad

Double-click or Enter on numeric
keypad

Open movie in an After Effects
footage panel

Alt + double-click Option + double-click

Activate most recent composition \ \

Add selected item to most
recently activated composition

Ctrl + / Command + /
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Keys for viewing panels
You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

*If there is content in the Composition, Layer, Footage, or Effect Controls panel, this shortcut closes the content

before closing the panel.

Replace a selected layer’s source
footage in Composition panel
with selected footage

Ctrl + Alt + / Command + Option + /

Replace a selected layer’s source
footage item or composition in
the Timeline panel

Alt-drag footage item from
Project panel into composition

Option-drag footage item from
Project panel into composition

Delete a footage item without a
warning dialog box appearing

Ctrl + Backspace Command + Delete

Result Windows Mac OS

Display/hide title-or action- safe
zones

‘ (apostrophe) ‘ (apostrophe)

Display/hide proportional grid Alt + ‘ (apostrophe) Option + ‘ (apostrophe)

Suspend image updates Caps Lock Caps Lock

Take multiple (up to four) snap-
shots

Shift + F5, F6, F7, and F8 Shift + F5, F6, F7, and F8

Display snapshot in active panel F5, F6, F7, and F8 F5, F6, F7, and F8

Display channel (RGBA) Alt + 1, 2, 3, or 4 Option + 1, 2, 3, or 4

Display channel (RGBA) in color Alt + Shift + 1, 2, 3, or 4 Option + Shift + 1, 2, 3, or 4

Close active tab or panel Ctrl + W* Command + W*

Toggle Graph Editor Shift + F3 Shift + F3

Display footage file name in Info
panel

Ctrl + Alt + E Command + Option + E

Maximize panel Tilde (don’t press the Shift key) Tilde (don’t press the Shift key)

Reset view in the Composition
panel to 100% and center compo-
sition in the panel

Double-click Hand tool Double-click Hand tool

Zoom in . (period) or Ctrl + = on main
keyboard

. (period) or Command + = on
main keyboard

Zoom out , (comma) or Ctrl + - (hyphen) on
main keyboard

, (comma) or Command + -
(hyphen) on main keyboard

Zoom to 100% / (on main keyboard) / (on main keyboard)

Resize application window or
floating window to fit screen.
(Press again to resize window so
that contents fill the screen.)

Ctrl + \ (backslash) Command + \ (backslash)

Result Windows Mac OS
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Keys for moving around the Timeline panel
You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Keys for moving around panels
Use these shortcuts in the Composition, Timeline, Layer, and Footage panels.

You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Result Windows Mac OS

Go to beginning of the work area Shift+Home Shift+Home

Go to end of the work area Shift+End Shift+End

Go to previous visible keyframe or
layer-time marker

J J

Go to next visible keyframe or
layer-time marker

K K

Go to a composition time marker 0 - 9 on main keyboard 0 - 9 on main keyboard

Scroll selected layer to top of the
Timeline panel

X X

Scroll current time to center of
panel while zoomed

D D

Zoom out time - -

Zoom in time = =

Result Windows Mac OS

Go to the beginning of a composi-
tion

Home or Ctrl + Alt + Left Arrow
key

Home or Command + Option +
Left Arrow key

Go to the end of a composition End or Ctrl + Alt + Right Arrow key End or Command + Option +
Right Arrow key

Step forward 1 frame Page Down or Ctrl + Right Arrow
key

Page Down or Command + Right
Arrow key

Step forward 10 frames Shift + Page Down or Shift + Ctrl +
Right Arrow key

Shift + Command + Right Arrow
key or Shift + Page Down

Step backward 1 frame Page Up or Ctrl + Left Arrow key Page Up or Command + Right
Arrow key

Step backward 10 frames Shift + Page Up or Shift + Ctrl +
Left Arrow key

Shift + Page Up or Command +
Shift + Left Arrow key

Go to layer In point i i

Go to layer Out point o o

Snap items such as keyframes,
time markers, and In and Out
points to each other on a time
ruler

Shift-drag item Shift-drag item
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Keys for previewing
Use these shortcuts in the Timeline panel.

You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

*Make sure Num Lock is on.

Keys for nudging layers
Use these shortcuts in the Composition and Timeline panels.

You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Result Windows Mac OS

Start/pause playback Spacebar Spacebar

RAM preview 0 on numeric keypad* 0 on numeric keypad*

RAM preview every other frame Shift + 0 on numeric keypad* Shift + 0 on numeric keypad*

Manually preview (scrub) video Drag or Alt-drag current-time indi-
cator, depending on Live Update
setting

Drag or Option-drag current-time
indicator, depending on Live
Update setting

Manually preview (scrub) audio Ctrl-drag current-time indicator Command-drag current-time indi-
cator

Wireframe preview Alt + 0 on numeric keypad* Option + 0 on numeric keypad*

Display rectangle instead of alpha
outline during wireframe preview

Ctrl + Alt + 0 on numeric keypad* Command + Option + 0 on
numeric keypad*

Leave panel contents during wire-
frame preview

Shift + Alt + 0 on numeric keypad* Shift + Option + 0 on numeric
keypad*

Leave panel contents during rect-
angle preview

Ctrl + Shift + Alt + 0 on numeric
keypad*

Command + Shift + Option + 0 on
numeric keypad*

Show current frame on output
device specified in Video Preview
preferences

/ on numeric keypad / on numeric keypad.

Toggle Output Device preference
between Desktop Only and previ-
ously specified output device

Ctrl + / on numeric keypad Command + / on numeric keypad

Result Windows Mac OS

Nudge layer 1 pixel in specific
direction

Arrow key Arrow key

Nudge layer 1 frame earlier Alt + Page Up Option + Page Up

Nudge layer 1 frame later Alt + Page Down Option + Page Down

Nudge layer rotation +1˚ + (plus) on numeric keypad + (plus) on numeric keypad

Nudge layer rotation -1˚ - (minus) on numeric keypad - (minus) on numeric keypad
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Keys for using layers
Use these shortcuts in the Composition and Timeline panels.

You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Nudge layer scaling +1% Ctrl + + (plus) on numeric keypad Option + + (plus) on numeric
keypad

Nudge layer scaling -1% Ctrl + - (minus) on numeric
keypad

Option + - (minus) on numeric
keypad

Nudge layer scaling +10% Ctrl + Shift + + (plus) on numeric
keypad

Option+ Shift + + (plus) on
numeric keypad

Nudge layer scaling -10% Ctrl + Shift + - (minus) on numeric
keypad

Option + Shift + - (minus) on
numeric keypad

Result Windows Mac OS

Rename layer, composition,
folder, or effect

Enter (on main keyboard) Return

Send layer backward Ctrl + Alt + Down Arrow key Command + Option + Down
Arrow key

 Bring layer forward Ctrl + Alt + Up Arrow key Command + Option + Up Arrow
key

Send layer to back Ctrl + Shift + Alt + Down Arrow
key

Command + Shift + Option +
Down Arrow key

Bring layer to front Ctrl + Shift + Alt + Up Arrow key Command + Shift + Option + Up
Arrow key

Select a layer by its layer-outline
number

Layer number on numeric
keypad*

Layer number on numeric
keypad*

Select non-contiguous layers Ctrl-click layers Command-click layers

Select contiguous layers Shift-click layers Shift-click layers

Deselect all layers  F2  F2

Activate Composition panel with
layer

\ \

Display selected layer in Layer
panel

Enter (on numeric keypad) Enter (on numeric keypad)

Display Effect Controls panel for
selected layers

Ctrl + Shift + T Command + Shift + T

Open source of a layer Alt-double-click a layer Option-double-click a layer

Constrain layer movement along x
axis or y axis

Shift-drag layer (begin dragging
before pressing key)

Shift-drag layer (begin dragging
before pressing key)

Set In point [ (left bracket) [ (left bracket)

Set Out point ] (right bracket) ] (right bracket)

Result Windows Mac OS
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*Make sure Num Lock is on.

Keys for viewing layer properties
Use these shortcuts in the Timeline panel.

You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Note: This table contains double-letter shortcuts (for example, “LL”). To enable these shortcuts, press the letters in quick

succession.

Trim In point of a layer Alt + [ (left bracket) Option + [ (left bracket)

Trim Out point of a layer Alt + ] (right bracket) Option + ] (right bracket)

Add/remove expression Alt-click a property stopwatch in
the Effect Controls or Timeline
panel

Option-click a property stopwatch
in the Effect Controls or Timeline
panel

Add an effect (or multiple selected
effects) to selected layers

Double-click an effect in the
Effects & Presets panel

Double-click an effect in the
Effects & Presets panel

Set In point by time-stretching Ctrl + Shift + , (comma) Command + Shift + , (comma)

Set Out point by time-stretching Ctrl + Alt + , (comma) Command + Option + , (comma)

Move In point to beginning of
composition

Alt + Home Option + Home

Move Out point to end of compo-
sition

Alt + End Option + End

Constrain rotation to 45˚ incre-
ments

Shift-drag Rotation tool Shift-drag Rotation tool

Constrain scaling to footage frame
aspect ratio

Shift-drag layer handle with Selec-
tion tool

Shift-drag layer handle with Selec-
tion tool

Reset rotation angle to 0˚ Double-click Rotation tool Double-click Rotation tool

Reset scale to 100% Double-click Selection tool Double-click Selection tool

Change property value by 10 Shift-drag underlined values in
Switches/Modes column

Shift-drag underlined values in
Switches/Modes column

Change property value by .10 Ctrl-drag underlined values in
Switches/Modes column

Command-drag underlined
values in Switches/Modes column

Set all dimensions to same value
for Scale and Mask Feather prop-
erties

Deselect Constrain Proportions
option, and Alt-click to reselect
option

Deselect Constrain Proportions
option, and Option-click to rese-
lect option

Result Windows Mac OS

Anchor Point A* A*

Audio Levels L L

Audio Waveform LL LL

Effects E E

Result Windows Mac OS
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*For light and camera layers, this shortcut displays the Point Of Interest property.

**For light layers, this shortcut displays the Intensity property.

***For light and camera layers, this shortcut displays the Orientation property.

Keys for working with the Composition panel
You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Expressions EE EE

Mask Feather F F

Mask Shape M M

Mask Opacity TT TT

Mask Properties MM MM

Material options (3D) AA AA

Opacity T** T**

Position P P

Paint Effects PP PP

Reveal modified properties UU UU

Rotation R*** R***

Time Remapping RR RR

Scale S S

Set layer property value in dialog
box (works with P, R, F, and M)

Ctrl + Shift + property shortcut Command + Shift + property
shortcut

Show all animating values U U

Show selected properties SS SS

Hide property or category Alt + Shift-click property or cate-
gory name

Option + Shift-click property or
category name

Display/hide Parent column Shift + F4 Shift + F4

Add/remove property Shift + property shortcut Shift + property shortcut

Toggle switches/modes F4 F4

Turn off all other solo switches Alt-click solo switch Option-click solo switch

Zoom to or from frame view ; (semicolon) ; (semicolon)

Zoom in time = on main keyboard = on main keyboard

Zoom out time - (hyphen) on main keyboard - (hyphen) on main keyboard

Result Windows Mac OS
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Keys for modifying keyframes
Use these shortcuts in the Timeline panel.

You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Result Windows Mac OS

Set composition resolution to
custom

Ctrl + Alt + J Command + Option + J

Result Windows Mac OS

Add or remove keyframe (if stop-
watch is on) or turn on time-vary
stopwatch

Alt + Shift + property display
shortcut

Option + Shift + property display
shortcut

Select all keyframes for a property Click property name Click property name

Deselect all keyframes Shift + F2 Shift + F2

Snap keyframe to significant times Shift-drag keyframe Shift-drag keyframe

Nudge keyframe 1 frame forward Alt + Right Arrow key Option + Right Arrow key

Nudge keyframe 1 frame back-
ward

Alt + Left Arrow key Option + Left Arrow key

Select all visible keyframes and
properties

Ctrl + Alt + A Command + Option + A

Go to previous keyframe J J

Go to next keyframe K K

Switch interpolation between
Linear and Auto Bezier

Alt-click keyframe (Graph Editor)
or Ctrl-click keyframe (Layer Bar
mode)

Option-click keyframe (Graph
Editor) or Command-click
keyframe (Layer Bar mode)

Change Auto Bezier interpolation
to Continuous Bezier

Drag keyframe handle Drag keyframe handle

Toggle between Continuous
Bezier and Bezier interpolation

Alt-drag keyframe handle (Graph
Editor) or Ctrl-drag keyframe
(Layer Bar mode)

Option-drag keyframe handle
(Graph Editor) or Command-drag
keyframe (Layer Bar mode)

Easy ease F9 F9

Easy ease in Shift + F9 Shift + F9

Easy ease out Ctrl + Shift + F9 Command + Shift + F9

Deselect selected keyframes and
animator groups and leave their
layers selected

Ctrl + Alt + Shift + A Command + Option + Shift + A

Go to the next In or Out point Ctrl + Shift + Alt + Right Arrow key Command + Shift + Option +
Right Arrow key

Go to the previous In or Out point Ctrl + Shift + Alt + Left Arrow key Command + Shift + Option + Left
Arrow key
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Keys for working with the Graph Editor
You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Keys for setting the work area
Use these shortcuts in the Timeline panel.

You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Result Windows Mac OS

Select all keyframes Alt-click segment between two
keyframes with Selection tool

Option-click segment between
two keyframes with Selection tool

Move all keyframes Alt-drag segment between two
keyframes with Selection tool

Option-drag segment between
two keyframes with Selection tool

Switch to Convert Vertex tool,
separate direction handles, and
move them independently

Alt-drag a direction handle with
Selection or Pen tool

Option-drag a direction handle
with Selection or Pen tool

Switch to Convert Vertex tool and
toggle keyframe interpolation

Alt-click a keyframe with Selection
or Pen tool

Option-click a keyframe with
Selection or Pen tool

Draw new direction handles Alt-drag a keyframe with Selec-
tion tool

Option-drag a keyframe with
Selection tool

Switch to Pen tool and add
keyframe

Ctrl-click a segment between two
keyframes with Selection tool

Command-click a segment
between two keyframes with
Selection tool

Switch to Pen tool and delete
keyframe

Ctrl-click a keyframe with Selec-
tion tool

Command-click a keyframe with
Selection tool

Toggle selection of two neigh-
boring keyframes

Shift-click a segment between
two keyframes with Selection tool

Shift-click a segment between
two keyframes with Selection tool

Toggle keyframe selection Shift-click a keyframe with Selec-
tion tool

Shift-click a keyframe with Selec-
tion tool

Constrain movement of keyframe
vertically or horizontally

Shift-drag a keyframe with Selec-
tion tool

Shift-drag a keyframe with Selec-
tion tool

Constrain movement of direction
handle horizontally

Shift-drag a direction handle with
Selection tool

Shift-drag a direction handle with
Selection tool

Switch to Selection tool Ctrl-click segment, keyframe, or
direction handle with Pen or
Convert Vertex tool

Command-click segment,
keyframe, or direction handle with
Pen or Convert Vertex tool

Create new keyframe and extend
direction handles horizontally

Shift-drag a segment with Pen
tool

Shift-drag a segment with Pen
tool
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Keys for using masks
Use these shortcuts in the Composition and Layer panels.

You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Keys for using the Effect Controls panel
You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Keys for 3D animation
Use these shortcuts in the Composition and Timeline panels.

Result Windows Mac OS

Set beginning of work area to
current time

B B

Set end of work area to current
time

N N

Set work area to selected layers Ctrl + Alt + B Command + Option + B

Set work area to composition
duration when no layers are
selected

Ctrl + Alt + B Command + Option + B

Result Windows Mac OS

Reset oval or rectangle mask to fill
frame

Double-click Rectangular or Ellip-
tical Mask tool

Double-click Rectangular or Oval
Mask tool

Scale around center point in Free
Transform mode

Ctrl-drag Command-drag

Select all points in a mask Alt-click mask Option-click mask

Free transform points Ctrl + T, or double-click mask Command + T, or double-click
mask

Exit free transform points Enter Return

Toggle Mask Shape keyframe for
selected mask shapes

Shift + Alt + M Shift + Option + M

Toggle mask display Ctrl + Shift + H Command + Shift + H

Toggle between smooth and
corner points

Ctrl + Alt-click point Command+Option-click point

Redraw handles Ctrl+Alt-drag point Command+Option-drag point

Result Windows Mac OS

Add keyframe for effect control Alt-click effect property name Option-click effect property name

Add an expression in the Timeline
panel

Alt-click a property stopwatch in
the Effect Controls panel

Option-click a property stopwatch
in the Effect Controls panel
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You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Keys for using markers
Use these shortcuts in the Composition and Timeline panels.

You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Keys for painting
You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Result Windows Mac OS

View Custom View 1 (defaults to
front)

F10 F10

View Custom View 2 (defaults to
custom view 1)

F11 F11

View Custom View 3 (defaults to
active camera)

F12 F12

Return to previous view Esc Esc

Move the camera and its point of
interest to look at selected objects

Shift + Alt + Ctrl + \ Option + Command + Shift + \

Result Windows Mac OS

Remove layer-time marker Ctrl-click marker Command-click marker

Go to previous visible layer-time
marker or keyframe

J J

Go to next visible layer-time
marker or keyframe

K K

Go to a composition-time marker 0-9 on main keyboard 0-9 on main keyboard

Set and number a composition-
time marker at the current time

Shift + 0-9 on main keyboard Shift + 0-9 on main keyboard

See the duration between two
layer-time markers or keyframes
in the Info panel

Alt-click the markers or keyframes Option-click the markers or
keyframes
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*Make sure Num Lock is on.

Keys for using text
You can find most keyboard shortcuts in menu commands and tool tips. Additional shortcuts appear in the table

below.

Result Windows Mac OS

Toggle Paint panel background
color and foreground colors

X X

Set Paint panel foreground color
to black and background color to
white

D D

Set foreground color to the color
currently under any paint tool
pointer

Alt-click Option-click

Set foreground color to the
average color of a 4 x 4 area under
any paint tool pointer

Alt + Shift-click Option + Shift-click

Set a paint tool’s brush size Ctrl-drag Command-drag

Set a paint tool’s brush hardness Ctrl-drag, then release Ctrl while
dragging

Command-drag, then release
Command while dragging

Append a straight paint stroke to
the last stroke

Shift + Click Shift + Click

Set starting sample point to color
currently under Clone Stamp tool
pointer

Alt-click Option-click

Select Last Stroke Only option in
Paint panel for Eraser tool

Ctrl + Shift Command + Shift

Change aligned Clone Stamp
tool’s Offset value or change
unaligned Clone Stamp tool’s
Source Position value

Alt + Shift-drag Option + Shift-drag

Duplicate a Clone Stamp tool
preset in Paint panel

Alt-click the preset Option-click the preset

Reduce a painting tool’s opacity
10% at a time

Press the corresponding digit on
numeric keypad (9=90%, 1=10%)*

Press the corresponding digit on
numeric keypad (9=90%, 1=10%)*

Set a painting tool’s flow to 100% Shift + decimal point (.) on
numeric keypad*

Shift + decimal point (.) on
numeric keypad*

Reduce a painting tool’s flow to
10% at a time

Press Shift + the corresponding
digit on numeric keypad (9=90%,
1=10%)*

Press Shift + the corresponding
digit on numeric keypad (9=90%,
1=10%)*
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Keys for working with Adobe Bridge
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu

commands or tool tips.

Result Windows Mac OS

Align text left, center, or right Horizontal Type tool + Shift +
Ctrl + L, C, or R

Horizontal Type tool + Shift +
Command + L, C, or R

Align text top, center, or bottom Vertical Type tool + Shift + Ctrl + L,
C, or R

Vertical Type tool + Shift +
Command + L, C, or R

Select 1 character left/right, or 1
line down/up, or 1 word left/right

Shift + Left Arrow/Right Arrow,
Shift + Down Arrow/Up Arrow,
Shift + Ctrl + Left Arrow/Right
Arrow

Shift + Left Arrow/Right Arrow,
Shift + Down Arrow/Up Arrow,
Shift + Command + Left
Arrow/Right Arrow

Select characters from insertion
point to mouse click point

Shift + click Shift + click

Move insertion point 1 character
left/right, 1 line down/up, or 1
word left/right

Left Arrow/Right Arrow, Down
Arrow/Up Arrow, Ctrl + Left
Arrow/Right Arrow

Left Arrow/Right Arrow, Down
Arrow/Up Arrow, Command + Left
Arrow/Right Arrow

Select word, line, or paragraph Double-click, triple-click,
quadruple-click, or quintuple-
click

Double-click, triple-click,
quadruple-click, or quintuple-
click

Toggle All Uppercase on/off Shift + Ctrl + K Shift + Command + K

Toggle Small Caps on/off Shift + Ctrl + Alt + K Shift + Command + Option + K

Toggle Superscript on/off Shift + Ctrl + + (plus) Shift + Command + + (plus)

Toggle Subscript on/off Shift + Alt + Ctrl + + (plus) Shift + Option + Command + +
(plus)

Choose 100% horizontal scale Shift + Ctrl + X Shift + Command + X

Choose 100% vertical scale Shift + Alt + Ctrl + X Shift + Option + Command + X

Choose Auto leading Shift + Alt + Ctrl + A Shift + Option + Command + A

Choose 0 for tracking Shift + Ctrl + Q Shift + Control + Command + Q

Justify paragraph; left aligns last
line

Shift + Ctrl + J Shift + Command + J

Justify paragraph; forces last line Shift + Ctrl + F Shift + Command + F

Decrease/increase type size of
selected text 2 pts/px

Shift + Ctrl + < or > Shift + Command + < or >

Decrease/increase leading 2
pts/px

Alt + Down Arrow/Up Arrow Option + Down Arrow/Up Arrow

Decrease/increase baseline shift 2
pts/px

Shift + Alt + Down Arrow/Up
Arrow

Shift + Option + Down Arrow/Up
Arrow

Decrease/increase kerning or
tracking 20/1000 ems

Alt + Left Arrow/Right Arrow Option + Left Arrow/Right Arrow
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Result Windows Mac OS

Open Adobe Bridge from other
Creative Suite application

Control + Alt + O, Control + Shift +
O

Command + Option + O,
Command + Shift + O

Switch to previous Bridge window Shift + Control + ~ Shift + Command + ~

Switches to the next view (As
Thumbnails. As Filmstrip, As
Details, or As Versions And Alter-
nates)

Control + \ Command + \

Switch to user-defined work-
spaces

Control + F6 through Control +
F12

Command + F6 through
Command + F12

Switch to previous view Shift + Control + \ Shift + Command + \

Show all files Alt + Control + A Option + Command + A

Show files with 1 or more stars Alt + Control + 1 Option + Command + 1

Show files with 2 or more stars Alt + Control + 2 Option + Command + 2

Show files with 3 or more stars Alt + Control + 3 Option + Command + 3

Show files with 4 or more stars Alt+Control+4 Option + Command + 4

Show files with 5 stars Alt + Control + 5 Option + Command + 5

Show files with label 1 (red) Alt + Control + 6 Option + Command + 6

Show files with label 2 (yellow) Alt + Control + 7 Option + Command + 7

Show files with label 3 (green) Alt + Control + 8 Option + Command + 8

Show files with label 4 (blue) Alt + Control + 9 Option + Command + 9

Mark selected Version Cue file as
in use

Shift + Control + M Shift + Command + M

Synchronize local view and server
view of selected Version Cue file

Shift + Control + B Shift + Command + B

Make selected Version Cue files
alternates of each other.

Shift + Control + G Shift + Command + G

Create saved version of selected
Version Cue file

Shift + Control + V Shift + Command + V

Open Version Cue Versions dialog
box

Shift + Alt + Control + V Shift + Option + Command + V

Return to last application that
launched Bridge

Alt + Control + O Option + Command + O

Move up a folder (in folder view)
or a row

Up Arrow Up Arrow

Move down a folder (in folder
view) or a row

Down Arrow Down Arrow

Move up a level (in folder view) Control + Up Arrow Command + Up Arrow

Move left one item Left Arrow Left Arrow

Move right one item Right Arrow Right Arrow



Move to the first item Home Home

Move to the last item End End

Add to selection (discontiguous) Control-click Command-click

Refresh tree and thumbnail panes F5 F5

Add an item to the selection Shift + Right Arrow, Left Arrow, Up
Arrow, or Down Arrow

Shift + Right Arrow, Left Arrow, Up
Arrow, or Down Arrow

Rotate image clockwise Control + ]

Rotate image counterclockwise Control + [

Launch File Bridge in maximized
state and auto-hide palettes

Control-click the Open Bridge
icon in the options bar

Open File Info dialog box Control + Alt + Shift + I Command + Option + Shift + I

Display Help F1 F1

Result Windows Mac OS
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Index

Numerics

0,0 (image area origin) 23

16-bpc color

effects 351

mode 62

3:2 pulldown 101, 601

32-bpc color

effects 63, 351

mode 61

3D Channel effects

about 381

Depth Matte effect 382

Depth Of Field effect 383

Fog 3D effect 383

ID Matte effect 384

3D files, importing 107, 173

3D Glasses effect

about 486

3D layers

about 173

adjusting 176

auto-orientation 179

axes 176

axis modes 182

Comp Camera attribute 351

designating layer as 3D 175

effects 174

expression elements 580

masks 175

nesting 132

order 174

previewing 179

rendering 179, 625

track mattes 174

views 178

3D properties 173

3D rotation, smoothing 176

3D views 177

3GPP format 590

4-Color Gradient effect 440

A

AAC format

importing 69

AAF format

exporting 590

importing 70, 105

acceleration, fine-tuning 226

acceptsLights (expression

element) 581

acceptsShadows (expression

element) 581

action-safe zone 142

activation, software 1

active (expression element) 569, 579,

583

activeCamera (expression

element) 577

Adaptive Resolution preview

mode 140

add (expression element) 573

Add Grain effect 357, 362, 363

Add Output Module command 607

Add To Favorites command 32

Add To Render Queue command 602

Add Vertex command 254

adjustment layers

about 151

effects 348

from Adobe Photoshop 92

lights 183

Adobe After Effects

conversion of layers in Adobe

Premiere Pro 126

copying layers to Adobe Premiere

Pro 126

workflow overview 9

Adobe Bridge

See also Bridge window

about 24

Adobe Dynamic Link

about 632

and color spaces 633

deleting links 634

editing linked compositions 634

Import After Effects Composition

command 634

Link Media command 635

linking to compositions 633, 634

managing performance 633

New After Effects Composition

command 633

offline compositions 635

relinking compositions 635

Replace Asset command 635

Revert To Original command 635

Save As command, behavior 633

saving projects 633

suppressing linked clips in Adobe

Premiere Pro 635

unlinking compositions 635

Adobe Encore DVD

creating buttons 172

creating chapter references 164

Adobe Expert Support 2

Adobe Help Center

about 2

adding contact information to 3

changing the view 5

displaying More Resources 3

Help topics in 3

navigating Help 4

preferences for 2

printing Help topics 5

searching Help topics 4

viewing support documents 3

Adobe Illustrator

alpha channels 72

copying paths 90

importing layers 90

importing paths as masks 249

preparing and importing files 90

rasterizing 92

supported file formats 69

text from 283

Adobe InDesign

metadata in 35

text from 283

Adobe Media Encoder

about 614

Audio options 616

command 613

filters options 614

Video options 614

Adobe PDF files. See PDF files
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Adobe Photoshop

adjustment layers 92

alpha channels 72

files, exporting 590

files, preparing and importing 89

layer effects 92

preparing and importing 89

rendering a frame to 623

supported file formats 69

text from 283

transparent areas 91

Adobe Premiere Pro

capturing footage 95

conversion of assets in After

Effects 127

copying assets to After Effects 126

projects, exporting 590

projects, importing 94

Adobe Premiere Pro Project

command 631

Adobe Press 7

Adobe Stock Photos

See also Stock Photo accounts

about 40

buying 43, 44

comps 43

in Bridge 24

preferences 48

redownloading photos 47

search tips 42

searching with keywords 41

shopping cart 44

viewing order details 45

Adobe Studio 6

Adobe Version Cue

in Bridge 24

Advanced 3D rendering plug-in 625

Advanced Authoring Format. See

AAF

Advanced Lightning effect 440

AI formats

importing 69

AIFF format

exporting 592

importing 69

air brush tool (Vector Paint) 476

Align panel 154

aligning

layers 154

text 291, 304

alpha channels

about 242

copying channels to 401

creating masks from 248

from Adobe Illustrator 72

Glow effect 525

importing footage containing 72

interpretation methods 72

matted and unmatted 243

matted with color 73, 400

premultiplied 73

premultiplied and straight 243

removing halos from 400

track mattes and 279

viewing 144

Alpha Levels effect 395

alpha matte 463

ambient (expression element) 581

Anamorphic 2:1 setting 98

anchor points

about 206

masks or vertices 253

moving 207

setting 112

text layers 298

anchorPoint (expression

element) 579

Angle Control effect 561

angle of view, camera setting 181

angles, conversion 576

Animate Text command 297

animated GIF format

behavior when rendering 52

animating

3D rotation 176

about 188

anchor point 206

effects 352

with expressions 555

grain 364

mask properties 266

paint strokes 326

paint strokes (Vector Paint) 479

position 205

rotation 205

scale 204

text 295, 296, 302, 303, 534

text, examples 305, 306, 307, 308,

309, 310, 311

animation presets

about 202

expressions 556, 563

saving 203

text 295

animator groups. See text animator

groups

anti-aliasing 93

aperture (expression element) 583

aperture, camera setting 182

Apply Animation Preset

command 202

Arithmetic effect 395

arrays 565

As Details command 29

As Filmstrip command 29

As Versions And Alternates

command 29

Asian text. See CJK text

aspect ratio

about 97

pixel 98

Attach Point Offset property 333

attach points 329, 332

AU format

exporting 592

importing 69

Audiences encoding settings 616

audio

changing volume levels 170

displaying spectrum 442

displaying waveform 443

editing in Adobe Audition 171

importing 68

including and excluding 171

layers 171

level sliders 170

output options 608

previewing 136

remapping pitch 237

removing clicks 237

reversing 385

time-remapping 235

VU meter 170

Audio effects

about 351, 384

Backwards effect 385

Bass & Treble effect 385

Delay effect 385

Flange & Chorus effect 385
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High-Low Pass effect 386

Modulator effect 387

Parametric EQ effect 388

Reverb effect 388

Stereo Mixer effect 389

Tone effect 389

Audio Spectrum effect 442

Audio switch 171

audio tracks

conversion in After Effects 128

audio transitions

conversion in After Effects 127

Audio volume property

conversion in Adobe Premiere

Pro 126

Audio Waveform effect 443

audio/video and layer switches 167

audioActive (expression

element) 579

audioLevels (expression

element) 580

Auto Bezier interpolation 221

Auto Color effect 402

Auto Contrast effect 403

Auto Levels effect 403

automated tasks

online resources 7

running 34

Auto-Orient command (3D) 179

Auto-trace command 248

AVI. See Video for Windows format

Avid formats

output 618

AVR codec options 619

B

background color, Composition

panel 117

backgrounders and online

resources 7

backward previews 135

Backwards effect 385

baking Maya data 107

baseline 283

baseline shift 289

Basic Fill effect. See Paint Bucket

effect

Basic Text effect 531

Basic 3D effect 488

Bass & Treble effect 385

Batch Rename command 34

Beam effect 444

behaviors. See animation presets

Best quality 169, 354

Best Settings template 604

Bevel Alpha effect 489

Bevel Edges effect 489

Bezier interpolation 220

Bezier masks 243, 245

Bezier Warp effect 422

bgColor (expression element) 577

binary keys 271

bit rate encoding 615

bitmap format

exporting 591

importing 69

bits per channel (bpc) 61

See also color depth

black and white, converting to

grayscale 531

Blend effect 396

blending

paint strokes (Vector Paint) 475

RGB colors 66

blending modes

about 259

applying 259

Calculations effect 397

Checkerboard effect 447

Circle effect and 448

Color Link effect 409

experimenting with 264

with Eyedropper Fill effect 448

4-Color Gradient effect 440

Fractal Noise 470

Grid effect and 452

Lightning effect 453

Magnify effect and 427

Modes column 167, 259

for overlapping text 290

Paint Bucket effect and 455

for paint strokes 324

Solid Composite effect 402

Block Dissolve effect 544

bluescreen. See keying

blur

camera effect 181

expression example 588

masks 256

rendering motion blur 605

Blur & Sharpen effects

Box Blur effect 390

Channel Blur effect 390

Compound Blur effect 391

Directional Blur effect 391

Fast Blur effect 391

Gaussian Blur effect 392

Lens Blur effect 392

Radial Blur effect 393

Reduce Interlace Flicker effect 393

Sharpen effect 393

Smart Blur effect 394

Unsharp Mask effect 394

blurLevel (expression element) 583

bookmarks

for Help topics 5

bounding box

free-transform 201, 253

text 284

Box Blur effect 390

bpc (bits per channel) 61

See also color depth

Bridge Center 24

Bridge window

adjusting 26

main components 25

Bridge. See Adobe Bridge

Brightness & Contrast effect 404

Bring Layer Forward command 153

Broadcast Colors effect 404

Browse command 25

brush dynamics 319

Brush Strokes effect 523

brush strokes. See paint strokes

Brush tool 313, 314

See also paint tools

brushes

changing (Vector Paint) 476

color 314

customizing 321

feather setting (Vector Paint) 477

presets 320

properties 321

radius (Vector Paint) 477

selecting 319

tips, customizing 320

types (Vector Paint) 477
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bubbles, creating with Cell Pattern

effect 444

Build Cache For Subfolders

command 28

Bulge effect 423, 589

C

cache

about 28

setting centralized and

distributed 28

caches

RAM and disk 637

Calculations effect 397

calibrating monitors 64

camera data, adding to files 37

camera raw files

cache in Bridge 77

chromatic aberration 85

correcting a color cast 86

cropping and straightening

images 83

database for settings 87

histogram and RGB values 80

importing 69, 78

in Bridge 24

non-neutral colors in 86

preview controls 80

profile adjustments 86

reducing noise 84

rotating 83

saving and restoring settings 86, 87

sharpening 83

sidecar files for settings 87

tonal adjustment controls 82

view controls 80

vignetting 85

white balance 81

cameras

about 173, 180

angle of view 181

aperture 182

blurring 181

choosing 180

Comp Camera attribute 351

creating 181

depth of field 181

expression elements 582

film size 182

focal length 182

focus distance 181

f-stop 182

points of interest 183

preset 181

settings 181

tools 182

wide-angle lens 181

capital letters 289

Caps Lock, preventing panel

updates 606, 640

Card Dance effect 491

Card Wipe effect 545

case, text 289

castsShadows (expression

element) 581

Caustics effect 494

CBR encoding 615

CD-ROM

as output type 52

Cell Pattern effect 444

certification 7

Change Color effect 405

Change To Color effect 406

Channel Blur effect 390

Channel Combiner effect 398

Channel effects

Alpha Levels effect 395

Arithmetic effect 396

Blend effect 396

Calculations effect 397

Channel Combiner effect 398

Compound Arithmetic effect 399

Invert effect 399

Minimax effect 400

Remove Color Matting effect 400

Set Channels effect 401

Set Matte effect 401

Shift Channels effect 402

Solid Composite effect 402

Channel Mixer effect 407

Channel Volume audio filter,

conversion in After Effects 128

channels

copying 401

creating masks from 248

shifting 402

viewing 144

character offset 299, 305

Character panel 286

character value 299

characters. See text

Checkbox Control effect 561

Checkerboard effect 446

checkered color swatch (Vector

Paint) 478

child layers 208

choker, matte 466, 467

chroma keying. See keying

Cineon Converter effect 550

Cineon format

conversion method 105

exporting 591

importing 69, 104

setting options 105

Cinepak compressor 622

Circle effect 447

CJK text

formatting exceptions 292

tate-chuu-yoko 294

tsume 294

clamp (expression element) 573

clip markers, conversion in After

Effects 128

clipping

Color Correction effects 403

Clone Stamp tool 313, 315

See also paint tools

Close Window command 25

closing projects 56

codecs

about 619

Collapse command 596

Collapse Transformations /

Continuously Rasterize

switch 93

collapsing

transformations 131

Collect Files command 598, 628

collections

in Bridge 33, 34

color

adjusting 402, 407, 419

adjusting shadows, midtones,

highlights 407

correcting contrast 404

effects 353

grain 365

labels, setting preferences 159

management 64

palettes 327
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preserving with Linear Color

Key 273

profiles 551

remapping levels 417, 418

selecting 327

selecting (Vector Paint) 477

space 551

text 288

viewing 144

color (expression element) 583

Color Balance (HLS) effect 408

Color Balance effect 407

Color Clone control (Vector

Paint) 477

Color Control effect 561

color conversion, expressions 576

Color Correction effects

Auto Color effect 403

Auto Contrast effect 403

Auto Levels effect 404

Brightness & Contrast effect 404

Broadcast Colors effect 404

Change Color effect 405

Change To Color effect 406

Channel Mixer effect 407

Color Balance (HLS) effect 408

Color Balance effect 407

Color Link effect 408

Color Stabilizer effect 409

Colorama effect 410

common controls 402

Curves effect 413

Equalize effect 414

Exposure effect 414

Gamma/Pedestal/Gain effect 415

Hue/Saturation effect 416

Leave Color effect 417

Levels (Individual Controls)

effect 418

Levels effect 418

Photo Filter effect 419

PS Arbitrary Map effect 419

Shadow/Highlight effect 420

Tint effect 422

color depth

about 61

choosing 62

effects 351

render setting 605

Color Difference Key effect 273, 463

Color Emboss effect 524

Color Key effect 274, 463

color keying. See keying

Color Link effect 408

Color Picker 327

Color Picker effect. See Eyedropper

Fill effect

Color Profile Converter effect 551

Color Range effect 275, 464

Color Stabilizer effect 409

color swatch, checkered (Vector

Paint) 478

Colorama effect 410

colorDepth (expression element) 571

Colorize control, Hue/Saturation

effect 415

colors

User Interface Colors

preference 19

columns 21, 118

comments

in expressions 560

comp (expression element) 571

Comp Camera attribute 174, 351

Comp expression elements 576

Comp Flowchart View command 60

compact mode 26

Compact view, in Adobe Help

Center 5

Composite Paint options (Vector

Paint) 484

compositing

about 242

preserving transparency 280

Composition Cropped Layers

option 90

composition method for text 293

Composition panel

background color 117

layers visible in 122

overview 116

region of interest 118

scrolling and zooming 15

transparency grid 118

compositions

about 109

adding and revealing footage 122

adding to Render Queue 602

considerations for project

planning 50

creating 109, 110

cropped layers 90

custom preset values 112

duration 115

Flowchart View 109

frame size 112

importing layered files as 90

keyboard shortcuts 650

memory requirements 636

offline, with Adobe Dynamic

Link 635

pixel aspect ratio 113

rendering plug-in 116

resolution 114, 115

setting anchor 112

settings 109, 111

start frame 115

timecode 115

composition-time markers 164

Compound Arithmetic effect 398

Compound Blur effect 391

compression

about

QuickTime 621

Video for Windows 621

compressor/decompressor. See

codecs

coneAngle (expression element) 583

coneFeather (expression

element) 583

Consolidate All Footage

command 59

Constant Bit Rate. See CBR encoding

content area 25

context menus 16

continue, keyframe looping

argument 569

Continuous Bezier interpolation 221

Continuously Rasterize switch 131

conversion, angles 576

Convert Audio To Keyframes

keyframe assistant 217

Convert Expression To Keyframes

keyframe assistant 563

Convert To Paragraph Text

command 292

Convert To Point Text command 292

Convert Vertex tool 254

coordinates 23

Copy command 31
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copying

layers and assets between After

Effects and Adobe Premiere

Pro 126

copyright information, adding 37

Corner Pin effect 344, 423

corner pinning, motion tracking 343

corner points

about 246

toggling with smooth 254

Create Outlines 249

Creation Station tablet (Vector

Paint) 475

Crop filter, conversion in After

Effects 127

cropping

movies 597

cross (expression element) 573

cross-platform considerations 53

cross-platform import of projects 93

crystals, creating with Cell

Pattern 444

current-time indicator 120

about 120, 134

moving to keyframe 194

curves

adjusting shape 254

smoothing 216

Curves effect 413

Cut command 31

cycle, keyframe looping

argument 569

D

D1 96

D1/DV NTSC

about 97

pixel aspect ratio 98

D1/DV PAL

about 97

pixel aspect ratio 98

data rates 619

deceleration, fine-tuning 226

Decrease Font Size command 36

Decrease Rating command 33

Default Drag Import As

preference 72

degreesToRadians (expression

element) 576

Delay effect 385

Delete Vertex tool 254

Delete Workspace command 27

deleting

project elements from Flowchart

View 60

depth (3D) 173, 588

Depth Matte effect 382

Depth Of Field effect 382

depth of field, camera setting 181

depthOfField (expression

element) 582

Deselect All command 30

developer resources

scripting guides 7

SDK documentation 7

difference keying 275

difference keying. See keying

Difference Matte effect 275

diffuse (expression element) 581

Digital Disk Recorders (DDRs) 102

Digital Picture Exchange files (DPX)

importing 69, 104

direction handles and lines 223, 229,

246

Directional Blur effect 391

Discreet RLA/RPF formats

importing 70

disk cache 637

Displacement Map effect 424

displayStartTime (expression

element) 577

Distort effects

Bezier Warp effect 422

Bulge effect 423

Corner Pin effect 423

Displacement Map effect 424

Liquify effect 425

Magnify effect 426

Mesh warp effect 427

Mirror effect 428

Offset effect 428

Optics Compensation effect 429

Polar Coordinates effect 430

Reshape effect 431

Ripple effect 432

Smear effect 434

Spherize effect 435

Transform effect 435

Turbulent Displace effect 436

Twirl effect 438

Warp effect 438

Wave Warp effect 439

distributing layers 154

div (expression element) 573

docking workspaces 17

dot (expression element) 573

double-byte text. See CJK text

downloading

updates, plug-ins, and tryouts 7

video 52

Draft 3D preview mode 141

Draft quality 169

drawing

masks 245

drift correction 346

Drop Shadow effect 489

drop zones

about 16

Dry Out, audio 351

Duplicate command 31, 58

duration

about 54

compositions 115

render settings 605

time-stretching 231

duration (expression element) 577,

578

Dust & Scratches effect

about 468

DVCPRO

HD 95, 592

pixel aspect ratio 98

DVD

as output type 52

DVD exporting

Audiences settings 616

audio settings 616

Dynamic Link. See Adobe Dynamic

Link

E

ease (expression element) 575

easeIn (expression element) 575

easeOut (expression element) 576

Easy Ease keyframe assistant 226, 231

Echo effect 539

Edit Original command 125

editing mode, text 285

effect (expression element) 578
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effect control points 353

Effect Controls panel

about 350

modifying property values 352

Effect menu 349

effect properties

conversion in Adobe Premiere

Pro 126

Effect switch 169

effects

about 348

adjustment layers 348

animating 340, 352

applying 348

applying to masks 258

audio 351

cameras and lights 351

changing order 350

color depth 351

copying 349

Expression Controls 348, 561

expression elements 583

galleries 368

improving performance 638

positioning 353

properties 352

removing 349

rendering 348, 350, 605

searching and finding 350

showing and hiding 169

32-bpc 63

turning off and on 349

viewing 350

Effects & Presets panel 349, 350, 351

Eject command 31

elapsed time, rendering 606

See also duration

ElectricImage (EIZ) format

exporting 590

importing 69

Ellipse effect 448

Emboss effect 524

Enable Time Remapping command

audio 238

video 235

enabled attribute 569

encoders 619

EPS format

importing 69

Equalize effect 414

Eraser tool 313, 318

See also paint tools

Eraser tool (Vector Paint) 476

error messages, for expressions 555

errors. See log file

Every-line Composer 293

examples

blur 588

depth 588

effects 589

expressions, pick whip 587, 588

expressions, writing 588, 589

linking properties 559

opacity 587

position 588

propertyGroup and

propertyIndex 569

rotation 587

text animation 305, 306, 307, 308,

309, 310, 311

EXIF 35

exploding a layer or particle 503

Exponential Scale keyframe

assistant 231

Export Cache command 28

Export command 622

export settings

Audio options 616

filters options 614

Video options 614

Export To DVD command 613

exporting

After Effects project to Adobe

Premiere Pro 631

single frame of a movie 623

supported file formats 590

to film 593

to high-definition video 95, 592

using Adobe Media Encoder 614

using QuickTime components 622

Exposure control 145

Exposure effect 414

Expression Controls effects 348, 561

expression field 555, 561

expression graph 562

expression language 564

Expression Language menu 558

Expression selector 302, 310, 311

expressions

about 555

animation presets 556, 563

arrays 565

camera elements 582

color conversion 576

comments 560

Comp elements 576

converting to keyframes 563

copying 562

creating and modifying 556, 557,

558, 559

effect elements 583

elements 570

error messages 555

examples 310, 311, 588, 589

examples with pick whip 587, 588

footage elements 578

global objects 564, 571

indices 566

interpolation methods 575

keyframe (key) elements 586

layer elements 578, 579

layer property elements 579

light elements 583

mask elements 584

math methods 576

pick whip 556, 557

property elements 584

random number methods 574

reference 570

saving 562

Source Text property 560

temporarily disabling 556

3D layer elements 580

time 567

time conversion 572

vector math methods 573

vectors 566

viewing 561

EXR format

importing 69

Extensible Metadata Platform

(XMP) 35

extensions, file-name 53

Extract effect 276, 464

Eyedropper Fill effect 448

Eyedropper tool 273, 327, 353
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F

Fast Blur effect 391

fast motion. See time-stretching

Fast Previews 138

faux styles 287

favorites. See animation presets

Feather control (Vector Paint) 477

feathering mask edges 255

feature regions 329, 331

Feet + Frames time display 54

field order

about 99

determining 100

testing 597

field rendering 100, 605

field separation 99

fields

about 99

file browsing, with Bridge 24

file formats

for export 590

for import 69

File Info command 37

file names, conventions 53

File Navigator command 26

file systems 53

files

batch renaming 34

finding 33

labeling 32

managing 31

navigating 30

opening in Bridge 31

rating 33

selecting in Bridge 30

Fill effect 449

fill layers 279

film size, camera setting 182

film, planning for 51

Filmstrip (FLM) format

exporting 590, 624

guidelines for editing 624

importing 69

rendering 624

Filmstrip Focus command 26

filters. See effects

Find command 33

Find Edges effect 524

finding files and folders, with

Bridge 33

first vertex 266

Flange & Chorus effect 385

Flash (SWF) files. See Macromedia

Flash (SWF)

FLC/FLI format

exporting 591

importing 70

FLM format. See Filmstrip format

flow, paint strokes 313

Flowchart command 60

Flowchart panel 59

Foam effect 496

focal length, camera setting 182

focal plane, specifying 383

focus distance, camera setting 181

focusDistance (expression

element) 582

Fog 3D effect 383

folders

creating 58

finding 33

managing 32

moving files 58

navigating 30

project hierarchy 53

renaming 58

showing and hiding contents 58

working in 58

font size

changing 287

changing in Metadata panel 36

fonts

choosing 287

footage

adding and revealing 122

considerations for project

planning 49

editing in original application 124

editing still-image sequences 125

importing alpha channels 72

interpreting automatically 71

items 68

keyboard shortcuts 643

looping 125

organizing 58

pixel aspect ratio 96

placeholders 128

proxies 128

relinking 93

removing 59

revealing 123

setting frame rate 125

footage (expression element) 571,

578

Footage panel 21, 123

formatting text, characters 286

formatting text, paragraphs 290

forums, online 7

four-point tracking 344

Fractal effect 449

Fractal Noise effect 468

frame aspect ratio 96

frame blending 239, 605

Frame Hold, conversion in After

Effects 128

Frame Mix 239

frame rate

changing for a sequence 76

changing for video and film

footage 96

option in Render Settings 605

setting for footage 125

frame size 112

frameDuration (expression

element) 577, 578

frames

freezing 222, 235

in interlaced video 99

framesToTime (expression

element) 572

Free Transform Points command 253

free-transform bounding box 201

freeze frame 222, 235

Freeze Layer Contents 141

fromComp (expression element) 581

fromCompToSurface (expression

element) 582

fromCompVec (expression

element) 582

fromWorld (expression element) 582

fromWorldVec (expression

element) 582

f-stops, camera setting 182

Full view, in Adobe Help Center 5

G

Gamma/Pedestal/Gain effect 415

garbage mattes 280

Gaussian Blur effect 392



INDEX 666

gaussRandom (expression

element) 574

General preferences

Bridge 28

Generate effects

Advanced Lightning effect 441

Audio Spectrum effect 442

Audio Waveform effect 443

Beam effect 444

Cell Pattern effect 444

Checkerboard effect 446

Circle effect 447

Ellipse effect 448

Eyedropper Fill effect 448

Fill effect 449

4-Color Gradient effect 440

Fractal effect 450

Grid effect 451

Lens Flare effect 452

Lightning effect 452

Paint Bucket effect 454

Radio Waves effect 455

Ramp effect 458

Scribble effect 458

Stroke effect 460

Vegas effect 460

Write-on effect 462

Get Properties For command 620

GIF format

exporting 590

importing 69

GIF format, animated 52

global objects 564, 571

Global Positioning System (GPS)

data 35

Glow effect 525

GPS information in files 35, 36

Gradient Wipe effect 548

gradients

creating with Ramp effect 458

grain

about 354

animating 364

applying grain effects 355

changing sampling source 366

color 365

color-matching mattes 356

grain effects 354

layer mattes 357

masks and mattes 355

noise sampling 365

positioning noise samples 366

previewing grain effects 357

Graph Editor 188, 189

graph overlay 562

graphics tablet and Vector Paint 475

graphics tablets and paint tools 319

grayscale images

converting to black and white 531

creating 407

greenscreen. See keying

Grid effect 451

grids

preferences for 143

viewing and using 142

Group of Pictures. See GOPs

Grow Bounds effect 552

guide layers 149, 161

guides

creating 143

H

H.264 95, 592

halos

removing 400

handheld cameras 341

hand-tinted images 407

hanging punctuation 292

hard disk cache 637

hasAudio (expression element) 579

hasParent (expression element) 568,

579

hasVideo (expression element) 579

HD

pixel aspect ratio 98

HDR (high dynamic range) footage

about 62

effects 63

importing 69

projects 63

using with LDR effects 553

HDR Compander effect 553

HDR Highlight Compression

effect 554

HDV 95, 592

pixel aspect ratio 98

height (expression element) 577, 578,

579

Help system

about 3

navigating 4

printing from 5

searching 4

updating topics 2

Hide Layer Controls command 177

hierarchy, project 53, 60

high-definition video 95, 592

highlights, adjusting 420

High-Low Pass effect 386

History command 57

history information, adding to

files 37

Hold interpolation 221

hold-out matte 281

horizontal scale of text 289

horizontal scan lines 99

horizontal text, converting to

vertical 292

horizontal tracking 339

hslToRgb (expression element) 576

Hue/Saturation effect 415

I

ICB format

importing 70

ID Matte effect 384

IFF format

exporting 590

importing 69

Illustrator. See Adobe Illustrator

image area 23

image noise, defined 84

IMAX frames 74

IMG format

exporting 590

importing 69

importing

After Effects projects 93

audio files 69

DDR-based footage 102

files into projects 71

footage items containing alpha

channel 72

items by dragging 72

multiple footage items 71

preparing footage for 70

projects 93

sequences of still images 75
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supported formats 69

3D files 173, 107

importing. See also individual file

formats

improving performance 638, 639, 640

In column 154

In point 155, 162

Increase Font Size command 36

Increase Rating command 33

indenting paragraphs 291

InDesign. See Adobe InDesign

index (expression element) 579, 586

indices, for expressions 566

influence, keyframe direction

handles 226, 229

Info panel 22

Inner/Outer Key effect 277, 465

inPoint (expression element) 579

installing software 1

Intel Indeo encoder 622

intensity (expression element) 583

inter-character blending 290

interlaced video 99

Internet or intranet playback,

planning for 52

interpolation

about 218

acceleration 226

applying 222

Auto Bezier 219, 221

Bezier 220, 221

changing 222

Continuous Bezier 221

deceleration 226

expressions 575

Hold 221

incoming and outgoing 219

keyframe interaction 218

keying 270

Linear 220

methods 218, 220

mixing methods 219

motion paths 219

none 220

Smart Mask Interpolation 267

spatial 218

temporal 218

types 220

value graphs 219

Interpret Footage

copying settings 125

field order 100, 101

Footage panels 124

frame rate 76

separating fields 100

Interpret Unlabeled Alpha As

preference 72

Interpretation Rules file 71

invert (expression element) 584

Invert effect 399

Invert Selection command 30

inverting masks 257

IPTC (IIM, legacy) 35

IPTC Core 35

IPTC information 36

IPTC metadata, editing 36

Iris Wipe effect 548

isolating layers 160

J

JavaScript, as expression

language 564

JPE format

exporting 590

importing 69

JPEG format

exporting 590

importing 69

JPG format

exporting 590

importing 69

justifying text 291

K

kerning 288

key (expression element) 580, 586

keyboard shortcuts

finding 642

list of 642

keyframe assistants

Convert Audio To Keyframes 217

Convert Expression To

Keyframes 563

Easy Ease 226, 231

Exponential Scale keyframe

assistant 231

RPF Camera Import 107

Sequence Layers 156

Time-Reverse Keyframes 233

Keyframe Interpolation

command 231

keyframe menu 196

keyframe navigator 194

Keyframe Velocity dialog box 229

keyframe-looping methods 569

keyframes

about 192

adding 195

adding to a motion path 212

controlling speed between 225

copying 198

deleting 196

direction handles 193

expression elements 586

freeze frame 236

in Graph Editor 193

icons 193

influence 229

keyboard shortcuts 650

modifying multiple 200, 201

modifying with Pen tool 197

motion path 213

moving 198

pasting 199

roving 230

smoothing 215

time-stretching 231

using 192

value graph 192

values 200

where to set and modify 195

keying

about 243

binary keys 271

color 270

combining keys 271

difference 275

effects 270

for a single frame 270

interpolation 270

linear keys 271

luminance 278

matte tools 270

removing traces of key color 466

spill removal 466

static background 275, 464
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Keying effects

Color Difference Key effect 463

Color Key effect 463

Color Range effect 464

Extract effect 464

Inner/Outer Key effect 465

Linear Color Key effect 465

Luma Key effect 466

Spill Suppressor effect 466

keywords, applying to files, in

Bridge 39

kumimoji text 294

L

Label commands, in Bridge 32

labels

setting preferences for 159

language

assigning in Bridge 28

laser beam, using Beam to create 444

layer (expression element) 576

layer bar mode 188

Layer Control effect 561

layer expression elements 578, 579,

580

layer modes. See blending modes

layer outline 119, 191

Layer panel 21

layer properties

about 188

anchor point 206, 207

animating 192

copying 200

expression elements 579

in Graph Editor 192

keyboard shortcuts 648

keyframes 195

position 205

rotation 205

scale 204

stopwatch 193

viewing 191

viewing modified 191

Layer Switches column 167

layers

about 149

adjustment layers 151, 152

Adobe Photoshop layers 152

aligning and distributing 154

anchor point 206

animating 188

child 208

color labels 158

copying and pasting 157

creating 150

creating from Adobe Premiere

Pro 126

dissolving 503

distributing 154

duplicating 149, 157

exploding 503

flipping 204

guide 149, 161

In point and Out point 155

isolating 160

keyboard shortcuts 646, 647

locking and unlocking 160

moving 205

numbering 149

parent 208

placing in time 154

renaming 158

rendering 2D and 3D 625

selecting 153

sequencing 156

shy 159

solid-color 150, 161

soloing 160, 605

source 68

splitting 157

stacking order 153

updating 61

viewing name 158

layer-time markers

about 164

conversion in Adobe Premiere

Pro 127

leading 287, 294

Leave All Attributes In option 133

Leave Color effect 417

length (expression element) 573

Length Of Composition option 74

Lens Blur effect 392

Lens Flare effect 452

Levels (Individual Controls)

effect 418

Levels effect 417

levels, adjusting with Auto Levels

effect 403

light rays (3D) 183

Lightbox command 26

Lightning effect 452

lights 173, 183

lights, expression elements 583

lightTransmission (expression

element) 581

Line Anchor animator 307

linear (expression element) 575

linear blending 66

Linear Color Key effect 465

Linear interpolation 220

linear keys 271

Linear Wipe effect 549

links

web 166

Liquify effect 425

Live Update preview mode 141

Local Axis mode 182

locking

layers 160

masks 251

log file 606, 631

lookAt (expression element) 574

Loop button 138

loopIn (expression element) 585

loopInDuration (expression

element) 585

looping

footage 125

Fractal Noise effect 471

previews 135

loopOut (expression element) 585

loopOutDuration (expression

element) 585

lower-field first field order 100

low-resolution movies for testing

motion 597

Luma Key effect 466

luminance keying. See keying

M

M frames 615

Macromedia Flash (SWF)

exporting 609

importing 70

Magnify effect 426

magnifying. See zooming

Make Movie command 594, 602

manual preview 136
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margins, safe-zone 142

marker (expression element) 577

markers

about 164

chapter links 164, 166

comments 164

composition-time markers 164

converting 166

keyboard shortcuts 653

layer-time markers 164

synchronizing to audio 166

web links 164

mask (expression element) 578

Mask Expansion property 255

maskExpansion (expression

element) 584

maskFeather (expression

element) 584

maskOpacity (expression

element) 584

masks

about 243

animating 266

applying effects to 258

blending 264

color 252

conversion in Adobe Premiere

Pro 126

creating motion paths from 214

expression elements 584

inverting 257

keyboard shortcuts 652

modes 264

moving 269

3D layers 175

using with grain effects 355, 356,

357

masks, creating

about 244

from channels 248

from motion paths 247

from text 249

masks, modifying

adjusting edges 255

converting to RotoBezier 247

editing 255

feathering 255

fill and stroke 258

Flowchart panel 60

inverting 257

opacity 256

reshaping 254

rotating 253

scaling 253

masks, working with

copying 252

deleting 251

duplicating 252

locking and unlocking 251

motion blur 256

panning 269

replacing 255

saving and reusing 251

selecting 250

setting interactions 264

shape and Pan Behind tool 269

specifying with Target menu 252

viewing 250

Match Grain effect 357, 361, 363, 364

material options (3D) 185, 186

math, expressions 576

Matte Choker effect 282, 466

Matte effects

Matte Choker effect 466

Simple Choker effect 467

matte view 270

matted alpha channels 73, 243

mattes

See also alpha channels

about 242

choking 466, 467

closing holes 282

conversion in Adobe Premiere

Pro 126

refining 270

removing 400

spreading 466, 467

track 279

traveling 279

using with grain effects 355, 356,

357

Maya format

baking 107

exporting 108, 590

importing 107

media, importing and exporting 49

Median effect 471

memory requirements 74, 636

memory, caches 637

menus

context 16

panel 16

Mesh Warp effect 427

metadata

about 35, 618

adding to documents 37

appending 38

applying as templates 38

editing 36

in MPEG-2 files 613

preferences for 37

replacing 38

specifying types to display in

Metadata panel 37, 38

templates 38

viewing 36

Metadata Focus command 26

Metadata panel 35

metadata, specifying types to display

in Metadata panel 38

metal (expression element) 581

Metrics kerning 289

Microsoft RLE compression 622

Microsoft Video encoder 622

Minimax effect 400

Mirror effect 428

mistakes, correcting and undoing 56

mixing

audio 389

Modes column 167

Modulator effect 387

monitors

profiling 64

Monochrome control, Channel

Mixer effect 407

Mosaic effect 526

motion

randomizing 216

smoothing 230

testing 597

motion blur 214, 215, 256

Motion Blur render setting 605

motion paths

about 210

changing defaults 212

changing speed numerically 229

Composition panel controls 210

controlling speed 225

creating 210
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creating from masks 214

Easy Ease keyframe assistant 226

keyframes 210

modifying 210, 213

Motion Sketch 213

moving all points in 213

rotating layers along 206

smoothing 215

spatial interpolation and 219

speed 224

motion paths, tracker

adjusting 342

restricting direction of 339

Motion Sketch 213

motion sources, tracking 335

motion targets 335, 339

Motion Tile effect 527

Motion Tracker Apply Options

dialog box 339

motion tracking

accuracy 343

animating effects 340

applying to a layer 337, 339

confidence 343

corner pinning 343

correcting drift 346

restricting movement 339

setting up 330

types 333

workflow 330

Motion values, conversion in After

Effects 127

motion-picture film 593

MOV format

exporting 590

importing 70

Move All Attributes Into The New

Composition option 133

Move To Recycle Bin command 32

Move To Trash command 31, 32

movies, making from

compositions 594

mp3 format

exporting 610

importing 69

MPEG formats

about 613

exporting 590

importing 70

multiplexer preset options 618

presets 613

MThread multiprocessor plug-in 641

mul (expression element) 573

multiple computers, rendering

with 629

multiple monitors 18

multiplexing 618

multiprocessor plug-in 641

N

N frames 615

name (expression element) 568, 577,

578, 580

names

footage files 53

layers 89

project files 53, 58, 601

nearestKey (expression element) 580,

586

negative light 184

nested compositions

about 60, 130

collapsing transformations 131

common uses for 61

opacity 131

options 131

prerendering 132

synchronizing time displays 131

3D layers 132

network rendering 627

new features in After Effects 8

New Folder command 32, 58

New Project command 54

New Window command 25

No Label command 32

No Rating command 33

noise

about 354

in camera raw images 84

Noise & Grain effects

Add Grain effect 362

Dust & Scratches effect 468

Fractal Noise effect 468

Match Grain effect 361

Median effect 471

Noise Alpha effect 473

Noise effect 472

Noise HLS Auto effect 474

Noise HLS effect 474

Remove Grain effect 358

noise (expression element) 575

Noise Alpha effect 472

Noise effect 472

Noise HLS Auto effect 473

Noise HLS effect 473

noise sampling, grain effects 361, 365

noninterlaced video 99

nonlight 184

nonlinear editing (NLE) systems 590

normalize (expression element) 573

null objects

about 209

using with Expression Controls

effects 561

Numbers effect 532

numKeys (expression element) 580,

586

numLayers (expression element) 577

O

offline compositions 635

Offset effect 428

offset, keyframe-looping

argument 569

OMF (Open Media Framework)

format

AVR codec options 619

exporting 618

importing 70, 105

Onion Skin control (Vector

Paint) 480

online Help 3

online training resources 7

opacity

expression example 587

increasing (Vector Paint) 477

nesting 131

of paint strokes 313

opacity (expression element) 580

Opacity values, conversion in After

Effects 127

Open command

in Bridge 31

Open Project command 54

Open Script Editor command 67

Open With Camera Raw

command 31

Open With command 31
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OpenEXR format

importing 69

OpenGL 138, 140, 595

Opening and closing files, in

Bridge 25

OpenType fonts 286

optical kerning 289

Optics Compensation effect 429

Orbit Camera tool 182

order

of effects, changing 350

stacking, of layers 153

orientation (expression element) 580

orthogonal views 177

Out column 154

Out point 155, 162

out-of-memory alert 636

outPoint (expression element) 579

output modules

adding 607

templates 600

output types

animated GIF 52

CD-ROM 52

considerations 51

DVD 52

film 51

streaming video 52

video 51

web video 52

overflow 631

overscan

about 142

P

paging file 638

Paint Bucket effect 454

paint color (Vector Paint) 477, 478

Paint effect 474

Paint On Transparent option 326

Paint panel 313

paint strokes

about 313, 322

animating 326

applying (Vector Paint) 475

blending (Vector Paint) 475

blending modes for 324

color 314

modifying 322

selecting 323

settings 313

transform properties 325

using current-time indicator with

(Vector Paint) 482

paint tools

keyboard shortcuts 654

options for 313

paint tools (Vector Paint) 475, 476

palettes, color 327

Pan Behind tool 207, 269

panel menus 16

panels

See also individual panel names

closing 18

expanding collapsed items in 21

keyboard shortcuts 644, 645

resizing 18

scrolling and zooming 15

panning

anchor point 207

audio 389

masks 269

3D layer 177

Paragraph panel 290

paragraph text

See also text

converting to point 292

param (expression element) 584

Parametric EQ effect 388

parent (expression element) 579

parent layers 208

Particle Playground effect

about 500

Affects controls 508

containing particles 508

direction and velocity of

particles 502

dissolving or exploding 503

gravity and particles 507

layer maps 512

masking particles 508

modifying properties with layer

map 509

replacing particles with a layer 504

replacing particles with text 505

rotating particles along

trajectories 507

types of particles 502

Paste command

in Bridge 31

patches, Mesh Warp 427

path names 53

Path Options property, text 304

Path Text effect 534

paths, animating text along 303

See also masks

PBM format

importing 69

PCT format

exporting 591

importing 69

PCX format

exporting 591

importing 69

PDF files

importing 69, 89

Pen tool

adding keyframes 212

Bezier masks 245

drawing curves 246

modifying mask shape 254

motion paths 212

Rotobezier masks 246

vertices 254

performance, improving 638, 639,

640

Persistent command 39

Perspective effects

Basic 3D effect 488

Bevel Alpha effect 489

Bevel Edges effect 489

Drop Shadow effect 489

Radial Shadow effect 490

3D Glasses effect 487

perspective, simulating by

tracking 344

Photo Filter effect 419

Photoshop Layers command 623

Photoshop. See Adobe Photoshop

PIC format

exporting 590

importing 69

pick whip

creating expressions 556

parent layers 208

selecting values 557
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PICT format

exporting 591

pingpong, keyframe looping

argument 569

pitch

changing 237

Pixar format

exporting 590

importing 69

pixel aspect ratio

about 96

common ratios for assets 98

correction 117

in Maya files 108

setting for compositions 113

Pixel Motion 239

pixelAspect (expression

element) 577, 578

Place command

in Bridge 31

placeholders 128, 129

platforms and importing 93

playback speed (Vector Paint) 481

playback speed, Motion Sketch 213

playback. See previews

plug-ins

about 66

in Adobe Store 7

rendering effects 629

Plug-ins folder 348

PNG format

exporting 590

importing 69

Point Control effect 561

point text

See also text

converting to paragraph 292

pointOfInterest (expression

element) 582, 583

points of interest 179, 183

Polar Coordinates effect 430

position

animating 205

effects 353

grain and noise samples 366

keyframes 211

Pan Behind tool 269

position (expression element) 580

Posterize Time effect 541

posterizeTime (expression

element) 571

PPJ format

importing 70

precomposing layers 133

Preferences command

in Bridge 27

Premiere Pro. See Adobe Premiere

Pro

premultiplied channels 73, 243

prerendering 132

Preserve Underlying Transparency

option 280

preset brushes 320

preset cameras 181

preset composition settings 112

presets. See animation presets

pressure setting 319

preview modes

about 138

Adaptive Resolution 140

Draft 3D mode 141

Freeze Layer Contents 141

Live Update mode 141

OpenGL 138

Wireframe 140

previews

about 134

alpha and color channels 144

audio 136, 138

backward 135

choosing a viewer 146

direction 135

external video monitors 147

frame rate 147

grain effects 357

Info panel 147

keyboard shortcuts 646

looping 135

manual preview 136

memory requirements 636

multiple viewers 146

performance 638, 639, 640

RAM Preview 135

scrubbing 136

Shift+RAM 135

standard preview 134

3D layers 179

viewers 146

printing

Help topics 5

product certification 7

profiling a monitor 64

progressive scanning 99

Project panel

creating folders in 58

importing footage 71

projects

about 49

closing 56

color depth 62

composition considerations 50

cross-platform 53

file-naming considerations 53

footage considerations 49

hierarchy 53

importing one into another 93

improving performance 639

keyboard shortcuts 643

organizing 49, 59

path names 53

performance considerations 51

reducing 59

saving 57

setting up 54

working color space 65

projects, planning

considerations 49

for file systems 53

for output types 51

rendering considerations 50

properties

See also layer properties

effects 352

expression elements 584

propertyGroup (expression

element) 569, 586

propertyIndex (expression

element) 569, 586

proxies 128, 129, 130, 605

PRPROJ format

exporting 590

importing 70

PS Arbitrary Map effect

about 419

PS format

importing 69
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PSD format

exporting 590

importing 69

pulldown 101

punctuation, hanging 292

purge 636

Purge Cache For This Folder

command 28

Purge Central Cache command 28

PXR format

exporting 591

importing 69

Q

queue status 606

QuickPaint mode (Vector Paint) 482

QuickTime

compression settings 620

encoding presets 616

QuickTime (MOV) format

alpha channel 72

exporting 591, 622

importing 70

quotation marks 287

R

Radial Blur effect 393

Radial Shadow effect 490

Radial Wipe effect 549

Radiance format

importing 69

radiansToDegrees (expression

element) 576

Radio Waves effect 455

RAM (random access memory) 636,

637

RAM format. See RealMedia format

RAM Preview 135

Ramp effect 458

random (expression element) 574

random numbers, expressions 574

randomizing motion 216

Range selector 299, 300, 305, 308

rasterization, continuous 92

rating files, in Bridge 33

RealMedia

encoding settings 616

RealMedia format

exporting 591

rectangular pixels 97

Reduce Interlace Flicker effect 393

Reduce Project command 59

reference link, for imported files 68

reflectivity, 3D layers 186

Refresh command 30

region of interest 118, 608

registration, product 1

relinking footage 93

remap-time marker 234

Remove Color Matting effect 400

Remove From Favorites

command 32

Remove Grain effect 358

Remove Unused Footage

command 59

removing software 1

renaming

files 34

Render Queue panel 602, 604, 606

rendering

about 590

audio 608

considerations for project

planning 50

effects 348

elapsed time 606

field order 100

file naming 603

filmstrip for Adobe Photoshop 624

frame blending 239

log file 606

memory requirements 636

network 627

OpenGL 595

order 350

pausing 603

performance 638, 639, 640

plug-ins 116

render queue information 606

render settings templates 607

re-rendering 603

sequences 624

settings 604

status 606

templates 604

3D 179

watch folders 627

with multiple computers 629

rendering intent, Color Profile

Converter effect 552

renmoji text 294

Replace Footage command 94

Reset To Default Workspace

command 27

Reshape effect 430

reshaping images 422

resizing

movies 595, 596

resolution

compositions 114, 115

and importing 74

maximum 74

Resolution option in Render Settings

dialog box 604

Re-timer controls (Vector Paint) 481

Reveal In Bridge command 31

Reveal In Explorer command 31

Reveal In Finder command 31

Reverb effect 388

reversing audio 385

Revert command 57

RGB format

exporting 590

importing 69

RGB Working Space menu 65

RGBE format

importing 69

rgbToHsl (expression element) 576

Ripple effect 432

RLA format

importing 70

RLE format

exporting 590

importing 69

RM format

exporting 590

Rotate 180˚ command 32

Rotate 90˚ Clockwise command 32

Rotate 90˚ Counterclockwise

command 32

rotating

images 32

rotation

along a motion path 206

animating 205

expression example 587

nudging layer values 206

selected masks 253

3D layers 176

track points 332
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rotation (expression element) 580

rotationX (expression element) 580

rotationY (expression element) 581

rotationZ (expression element) 581

RotoBezier masks

about 244

adjusting tension 254

converting 247

creating 246

rotoscoping 314, 624

See also paint tools, paint strokes

Roughen Edges effect 528

roving keyframes 230

RPF Camera Import keyframe

assistant 107

RSS feeds 3, 7

rulers

and zero points 23, 143

Run Script File command 67

S

safe zones 143

about 142

Save Animation Preset 203

Save Frame As command 623

Save RAM Preview command 598

Save Workspace command 27

scale

exponential 231

masks and points 253

tracking 340

scale (expression element) 580

scan lines 99

Scatter effect 529

Scene Detect option, Color

Correction effects 403

Scribble effect 458

scripting

guides 7

resources 7

scripting guides

Adobe Bridge 34

Script Editor 67

scripts

about 66

installing 67

writing 67

scrolling

in panels 15

scrubbing. See previews

SDK documentation 7

search regions 329, 331

searching for files and folders 33

seedRandom (expression

element) 574

Select All command 30

Select Labeled command 30

Select Unlabeled command 30

selecting

files, in Bridge 30

selectors

adding 300, 303

Expression 302, 310, 311

Range 299, 300, 305, 308

Wiggly 299, 302, 306, 310

Send Layer Backward command 153

Send To Recycle Bin command 31

Separate XYZ Position 563

sepia-tone images 407

Sequence Layers keyframe

assistant 156

sequence markers, conversion in

After Effects 128

sequences

assigning frame rate 76

frame blending 239

import as individual footage

files 76

importing as composition 76

importing sequence of still

images 75

rendering still images 624

Set Channels effect 401

Set First Vertex command 267

Set Matte effect 401

SGI format

exporting 590

importing 69

Shadow/Highlight effect 420

shadowDarkness (expression

element) 583

shadowDiffusion (expression

element) 583

shadows 183, 185

shaky footage, stabilizing 341

shapes, adjusting a curve

segment 254

Sharpen effect 393

Shatter effect 351, 514

Shift Channels effect 402

Shift+RAM preview 135

Shift-Paint Records control (Vector

Paint) 482

shininess (expression element) 581

shortcuts, keyboard 642

Show All Files command 30

Show Camera Raw Files Only

command 30

Show Channel menu 117

Show Folders command 30

Show Graphic Files Only

command 30

Show Hidden Files command 30

Show Layer Controls 177

Show Presets Contents 351

Show Thumbnail Only command 29

Show Vector Files Only command 30

showing and hiding

axes (layer controls) 177

effect points 354

effects 169, 350

expressions 561

folder contents 58

layers 159

safe zones and grids 143

tool tips 22

video 159

shutter angle, render setting 605

shutterAngle (expression

element) 577

shutterPhase (expression

element) 577

shy layers 159

sidecar files 35, 87

silhouette blending modes 263

Simple Choker effect 467

Simulation effects

Card Dance effect 492

Caustics effect 494

Foam effect 497

Particle Playground effect 501

Shatter effect 514

Wave World effect 520

single frame, exporting 623

Single-line Composer 293

skew, simulating by tracking 344

skin, onion skin controls (Vector

Paint) 480

Skip Existing Files option 606

Slider Control effect 561
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Slideshow command 29

slip edit 163

slow motion. See time-stretching and

Timewarp

Smart Blur effect 394

Smart Mask Interpolation 267

Smear effect 433

smooth (expression element) 585

smooth points

creating masks with 246

toggling with corner 254

Smoother command (Vector

Paint) 478

Smoother, The 215

smoothing curves 216

smoothing motion 230

SMPTE

timecode 54

Snap To Grid command 142

snapshots 145

Softimage PIC format

importing 69

software

activating 1

downloads 7

installing 1

registering 1

removing 1

updating 2

Solid Composite effect 402

solid-color layers 150, 161

solo layers 160, 605

Sort command 30

source (expression element) 578

source footage

supported formats 70

source footage. See also individual file

formats, footage

Source Text property 296, 560

spacebar play 134

spatial interpolation and motion

paths 219

specular (expression element) 581

speed

about 226

easing 231

gradual starts and stops 228

graphs 224

motion paths 224

speed (expression element) 584

Speed property, conversion in After

Effects 128

speedAtTime (expression

element) 584

Spherize effect 435

Spill Suppressor effect 277, 466

split-field frames 101

spreading mattes 467

square brush tool (Vector Paint) 476

square pixels 97, 98

stabilizing motion 341

Standard 3D rendering plug-in 626

standard preview 134

stars, rating files with 33

start frame 115

startTime (expression element) 579

stencil blending modes 263

Stereo Mixer effect

about 389

conversion in Adobe Premiere

Pro 126

still images

See also individual file formats

changing duration 74

exporting 590

frame rate 125

importing 73

supported formats 69, 590

Stock Photo accounts

benefits 45

changing information 46, 47

creating 46

signing in 46

Stock Photos. See Adobe Stock

Photos

stopwatch 193

Storage Overflow render setting 605

straight channels 73, 243

streaming video

output considerations 52

rendering 590

stretching a layer in time 232

Strobe Light effect 530

Stroke effect 460

strokes. See paint strokes

Stylize effects

Brush Strokes effect 523

Color Emboss effect 524

Emboss effect 524

Find Edges effect 524

Glow effect 525

Mosaic effect 526

Motion Tile effect 527

Roughen Edges effect 528

Scatter effect 529

Strobe Light effect 530

Texturize effect 530

Threshold effect 531

stylus, configuring for Vector

Paint 479

sub (expression element) 573

subscript text 290

superscript text 290

super-slow motion 239

support documents, in Adobe Help

Center 3

support options. See technical

support

SWF. See Macromedia Flash SWF

Switch 3D View command 178

Switch To Compact Mode button 26

Switch To Full Mode button 26

switches

Audio 171

Collapse Transformations 93, 168

Continuously Rasterize 93, 168

Effect 169

Frame Blending 169

Layer Quality 168

Motion Blur 169, 215

3D 170

Switches/Modes button 279

T

tablets, graphics 319

tangents

Bezier Warp 422

Mesh Warp 427

Targa format

exporting 591

importing 70, 72

Target menu 252

tate-chuu-yoko text 294

technical resources 7

technical support

Adobe Expert Support 2

complimentary and paid 5

on Adobe.com 7
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templates

for output module settings 609

for render settings 607

Temporal Filtering, Remove Grain

effect 360

Temporal Smoothing option, Color

Correction effects 403

temporalWiggle (expression

element) 585

text

aligning on a path 304

baseline 283

bounding box 284

changing direction 292

color 288

composition 293

conversion, paragraph and

point 292

creating 283

creating masks from 249

editing 285

formatting 286, 290

from other applications 283

from version 6.0 project 288

justified 291

kerning and tracking 288

keyboard shortcuts 654

leading 287, 294

offsetting character values 299

paragraph text 283, 284, 292

as particles 505

Path Options 304

point text 283, 292

selecting 285, 299

superscript and subscript 290

text animation presets 295

text animator groups 298, 299

Text effects

Basic Text effect 531

Numbers effect 532

Path Text effect 534

Timecode effect 539

text properties

baseline shift 289

case 289

fill and stroke 287

scaling 289

text, animating

about 295

effects 534

examples 305, 307, 308, 309, 310,

311

on a path 303

with animator groups 296

with expressions 302

Texturize effect 530

thisComp (expression element) 571

thisLayer (expression element) 571

thisProperty (expression

element) 571

three-point tracking 344

Threshold effect 531

TIFF format

exporting 591

importing 72

time

in expressions 567

See also timecode

time (expression element) 571, 586

time conversion, with

expressions 572

Time Difference effect 541

Time Displacement effect 542

Time effects

Echo effect 539

Posterize Time effect 541

Time Difference effect 541

Time Displacement effect 542

Timewarp effect 544

time graph 120, 121

Time Navigator 120

Time Remap graph 235

time ruler

about 134

Time Stretch property, conversion in

Adobe Premiere Pro 127

timecode

about 54

base 55

changing display format 54

compositions 115

display preferences 54, 55

display style 54, 55

Timecode effect 538

Timeline panel

about 118

columns and controls 118

Effect switch in 349

effects 350

keyboard shortcuts 645

time graph 120

timecode display 55

timeRemap (expression element) 580

time-remapping

about 233

audio 237

audio pitch 237

expressions 568

freeze frame 235

in Layer panel 237

Layer panel 234

marker 234

removing audio clicks 237

slow motion 236

Time-Reverse Keyframes keyframe

assistant 233

time-stretching 232

timeToCurrentFormat (expression

element) 572

timeToFeetAndFrames (expression

element) 572

timeToFrames (expression

element) 571

timeToNTSCTimecode (expression

element) 572

timeToTimecode (expression

element) 572

time-vary stopwatch 193

Timewarp effect 239

Tint effect 422

tinted images 407

tips and tricks 6

title-safe zones 142

toComp (expression element) 581

toCompVec (expression

element) 582

Toggle Hold Keyframe 222

tonal adjustments 415

tonal levels, posterizing 417, 418

tonal range, adjusting 413, 420

Tone effect 389

tool tips 28

showing and hiding 22

toolbar, Vector Paint 475

tools

keyboard shortcuts 643

selecting 22

Tools commands, in Bridge 34

Total Training 6

toWorld (expression element) 581
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toWorldVec (expression

element) 582

tracing channels 248

track mattes

about 279

and 3D layers 174

track points 329, 332, 338

Track XY Camera tool 182

Track Z Camera tool 182

Tracker Controls 330, 335

tracking data 334

tracking motion. See motion tracking

tracking text 307

tracking, text 288

training resources 6, 7

transfer modes, conversion in Adobe

Premiere Pro 127

transfer modes. See blending modes

transferring activation 1

Transform effect 435

Transform properties

Anchor Point 206

Auto-Orient 179

conversion in Adobe Premiere

Pro 126

Position 205

Rotation 205

Scale 204

transformations, adding in Flowchart

View 60

Transition effects

Block Dissolve effect 544

Card Wipe effect 545

Gradient Wipe effect 548

Iris Wipe effect 548

Linear Wipe effect 549

Radial Wipe effect 549

Venetian Blinds effect 549

transparency

Adobe Photoshop and 91

alpha channels 242

keying 242

Paint On Transparent 326

of paint strokes 313

preserving during

compositing 280

transparency grid 118

traveling mattes 279, 401

trimming

about 162

in Layer panel 163

methods 162

moving a trimmed layer in

time 163

TrueType fonts 286

tryouts, software 7

tsume text 294

Turbulent Displace effect 436

tutorials, online 6

Tweaking controls, Grain effects 364

tweening. See keyframes

Twirl effect 438

Type 1 fonts 286

type. See text

U

uncompressed high-definition

video 95, 592

Undo command 56

Unfiltered menu 30

Unicode characters 299

uninstalling software 1

unlocking layers 160

unmatted channels 73, 243

Unqueued status 606

Unsharp Mask controls, Remove

Grain effect 360

Unsharp Mask effect 394

unstable footage, stabilizing 341

updates, software 7

updating

software and Help topics 2

Upper Field First option 101

user forums 7

User Stopped status 606

Utility effects

Cineon Converter effect 550

Color Profile Converter effect 551

Grow Bounds effect 552

HDR Compander effect 553

HDR Highlight Compression

effect 554

V

value (expression element) 571, 584,

586

value graphs 192, 220, 235

valueAtTime (expression

element) 584

Variable Bit Rate. See VBR encoding

VBR encoding 615

VDA format

importing 70

Vector Paint effect

about 475

brushes 476, 477

preferences 486

toolbar 478

tools 476

using 475

vectors 566, 573

Vegas effect 460

velocity

controlling 227

direction handles 227

easing 230

randomizing 216

time-remapping 233

velocity (expression element) 584

velocityAtTime (expression

element) 584

Venetian Blinds effect 549

vertical scale of text 289

vertical text

converting to horizontal 292

vertical tracking 339

vertices, mask 254, 266

video

downloading over the web 52

fields and frames 99

high-definition 95, 592

importing from Premiere Pro 126

interlacing 99

progressive scanning 99

removing pulldown 101

training, online 6

video fields, separating 99

Video filter properties, conversion in

After Effects 127

Video for Windows format

compression 621

exporting 591

importing 70

segmenting 631

video output type 51

Video switch 159
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video transitions, conversion in After

Effects 127

videotape

planning for 51

View Axis mode 182

viewing area 134

views

in Adobe Help Center 5

orthogonal 177

3D 177

vignetting, correcting in camera raw

files 85

virtual memory paging file 638

Volume audio filter, conversion in

After Effects 128

VST format

importing 70

W

Wacom tablet

about 319

using with Vector Paint effect 475

Warp effect 438

warping images 422, 428

Watch Folder command 628

watch folders 627, 629

WAV format

importing 69

Wave Warp effect 439

Wave World effect 520

waveforms

animating with Audio

Spectrum 442

animating with Audio

Waveform 443

web

links 166

movies, Windows Media 612

video output type 52

Wet Out, audio 351

white balance for camera raw files 81

wide-angle lens 181

width (expression element) 577, 578,

579

wiggle (expression element) 585

Wiggler, The 216

Wiggly selector 299, 302, 306, 310

Windows Media format

exporting 612

importing 70

specifying codecs 616

Wireframe 140, 169

WM9 HDTV 95, 592

WMV format

importing 70

work area

keyboard shortcuts 651

setting 121

working color space 65, 551

workspaces

about 14, 20

closing panels and windows 18

creating and modifying 19

deleting 19

docking and grouping 17

drop zones 16

in Bridge 26

managing 19

multiple monitors 18

resizing panel groups 18

restoring 19

showing and hiding panels 18

using floating windows 17

World Axis mode 182

Write On option 326

Write-on effect 462

X

x and y coordinates 23

XMP (eXtensible Metadata Platform)

about 35

XMP metadata 618

XYZE format

importing 69

Z

z axis 173, 176

z scale 174

zero point 23

zoom (expression element) 582

zoom lens 231

Zoom slider 120

zooming

in panels 15, 141

keyboard shortcuts 644
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