Geomagic Qualify
Complete Inspection – Turbine Blade
Quick Start Guide
About Geomagic, Inc.

The Company
Geomagic is a software company dedicated to removing the barriers between the physical and digital worlds, and ultimately to changing the way we think and communicate in 3D. From mass customization of consumer products to 3D-enabled web marketing, from replacement of physical inventories by digital inventories to reproduction on demand of human bones and teeth, the 3D information technology pioneered by Geomagic has the potential to touch – and improve – nearly every facet of human life. The company has developed a powerful enabling technology that provides Digital Duplication™ solutions for design and manufacturing today, and a 3D foundation for the future.

Contact Information
Geomagic, Inc.
P.O. Box 12219
Research Triangle Park, NC 27709
Phone: (800) 251-5551 or (919) 474-0122
Fax: (919) 474-0216

Home Page: http://www.geomagic.com
Training Page: http://training.geomagic.com
Technical Support: support@geomagic.com
Licensing Questions: license@geomagic.com
Training Questions: training@geomagic.com

Guide Release History

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
<td>2004-Sep-30</td>
<td>Original Release</td>
</tr>
</tbody>
</table>
# Table of Contents

**Guide Description** .................................................................................................................. 6  
Intended Audience ....................................................................................................................... 6  
Guide Objective ........................................................................................................................... 6  
Prerequisites ............................................................................................................................... 6  
Guide Length ................................................................................................................................ 6  
System Information ....................................................................................................................... 6  
Definition of Terms ...................................................................................................................... 6  

**Introduction** .............................................................................................................................. 7  
Geomagic Qualify Workflow ........................................................................................................... 8  

**Turbine Blade Inspection** ............................................................................................................ 9  
Objective ........................................................................................................................................ 9  
File ............................................................................................................................................... 9  
Defining Datums on Reference Object ............................................................................................... 9  
Auto-Creating Datums on Test Object ............................................................................................... 14  
Aligning the Test Object to the Reference Object .............................................................................. 15  
Creating the Result Model .............................................................................................................. 16  
Creating a 2D Whisker Plot ............................................................................................................. 17  
Determining Blade Twist at a Cross-Section ..................................................................................... 18  
Extract Dimensional Characteristics of a Cross-Section .................................................................. 19  
Editing Dimensioned Cross-Sections ............................................................................................... 21
Guide Description

**Intended Audience**
This guide is suited for any user who will be using the *Geomagic Qualify* product to perform digital inspections.

**Guide Objective**
Provide the user with a working knowledge of the commands and workflows that are used in the *Geomagic Qualify* product. This knowledge will allow the user to develop a process using *Geomagic Qualify* that is suitable for his or her company.

**Prerequisites**
None

**Guide Length**
N/A

**System Information**
All files referred to in this guide are found in the folder specified below.

Folder of downloaded files from training web site.

**Definition of Terms**
N/A
Introduction

This Quick Start Guide will cover the basic commands and workflow used in the Geomagic Qualify product when inspecting a turbine blade.

For more details on each command or function, please consult the on-line help by placing the cursor over the command in question and pressing F1.

For more tutorials on Geomagic products please visit the online training site at http://training.geomagic.com.
Geomagic Qualify – Complete Inspection

Geomagic Qualify Workflow

1. **Test Data** (Point or Polygon) → **Geomagic Qualify**
2. **Create Datums**
3. **Auto Create Datums/Features**
4. **RPS Alignment** → **3D Compare** → **Create Callout** → **Evaluate Callout** → **2D Compare**
   - **Create Annotations**
   - **2D Twist Analysis** → **Section Through Object** → **Blade Section Analysis**
5. **Create Report**
6. **Create Annotations**
7. **Line Target** → **Point Target**

Geomagic, Inc.
Turbine Blade Inspection

Objective
Learn how to align scan data of a turbine blade with a reference model using Line Target Datums and Point Target Datums. Use the Blade Section Analysis command to extract key characteristics of an airfoil cross-section. Determine blade twist at any given section height.

File
| turbine_blade.wrp | Geomagic Qualify file containing all required data. |

Defining Datums on Reference Object
1. Open the sample file.
   a. Click File > Open or click the Open File icon.
   b. Select turbine_blade.wrp from folder that file was saved in.
   c. Click Open. Model is displayed in the Viewing Area.

2. Make Reference object the active object in Model Manager.
   a. Click Model Manager tab so that model objects are available for selection.
b. Select **REF – Turbine_Blade-CAD** with cursor so that gold-colored reference object is displayed in the Viewing Area. Three datum planes have been predefined and saved with the model. These predefined datums will be used to construct the six target datums.

**NOTE:**
The Reference object can be a CAD object or a polygon object

3. Define datums for alignment. This particular blade requires four line target datums and two point target datums for a proper six-point alignment.

   a. Click **Tools > Datums > Create Datums**, or select the icon on the main toolbar.

   b. Under **Datum Type**, click **Line Target**.

   c. Under **Line Target Method**, click **Plane/Direction**.

   d. From the **Section Plane** dropdown menu, select the predefined datum labeled **Plane Z=12.5**.

      **NOTE:** This plane is parallel to XY, at a height of Z=12.5 inches.

   e. From the **Contact Direction** dropdown menu, select **X Axis**.
f. Click **Apply** button. A green line target datum is created *tangent to the surface, perpendicular to the X Axis* and in a plane *parallel to XY* at a *Z height of 12.5 inches*. This datum location and orientation is typically defined on the part drawing.

g. Click **Next** to save this datum and construct another.

![First Line Target](image.png)

**First Line Target**

h. Change the **Contact Direction** dropdown to the predefined plane *Plane XZ Rot10deg Normal*.

**NOTE:** This predefined plane was created parallel to the XZ plane, and then rotated 10 degrees about the Z-axis.

i. Click **Apply**. A green line target datum is created *tangent to the surface, perpendicular to the normal of Plane XZ Rot10deg*, and in a plane *parallel to XY* at a *Z height of 12.5 inches*.

j. Click **Next** to save this datum and construct another.
k. Change **Section Plane** dropdown to **Plane Z=14.5**.

l. Keep **Contact Direction** dropdown set to **Plane XY Rot10deg Normal**.

m. Click **Apply**. A green line target datum is created *tangent to the surface, perpendicular to the normal of Plane XZ Rot10deg*, and in a plane *parallel to XY* at a *Z height of 14.5 inches*.

n. Click **Next**.

o. Keep **Section Plane** dropdown set to **Plane Z=14.5**

p. Set **Contact Direction** dropdown to **X Axis**.

q. Click **Apply**. A green line target datum is created *tangent to the surface, perpendicular to the X Axis*, and in a plane *parallel to XY* at a *Z height of 14.5 inches*.

r. Click **Next**.

s. From the toolbar at the top of the screen, select the **Toggle Datum Planes** icon, or select **Tools > Datums > Toggle Datum Planes**. Your screen should resemble the image below, with four line target datums defined.
t. Under **Datum Type**, select **Point Target**.

u. Enter the following coordinates into the $X,Y,Z$ box: 0.750, -0.050, 12.500.

v. Click **Apply**. A target point is created at this spot on the model with a radius of .005 inches. If desired, change the radius and click Apply again to update.

w. Click **Next**.

x. Enter the following coordinates into the $X,Y,Z$ box: 0.750, 0.500, 12.000.

y. Click **Apply**.

z. Click **OK** to exit the command.
Auto-Creating Datums on Test Object

4. Create a matching set of datums automatically on the Test object.
   
   a. Click **Tools > Auto Create Datums/Features**, or click the icon on the main toolbar.

   b. Toggle *on* **Perform Alignment**, and toggle *off** **Check Symmetry** and **Fine Adjustments Only**.

   c. Click **Apply**. After several minutes, all six datums manually defined on the Reference object will be automatically created on the Test object.

   d. Click **Done** to exit the command.
Aligning the Test Object to the Reference Object

5. Use an iterative alignment technique to align the models.

a. Click Tools > Alignment > RPS Alignment, or click the icon.

b. Click the Auto button to automatically create pairs out of datums with matching names. The Auto button also automatically constrains each pair to only align in the datums’ normal direction.

c. Click the Align button to begin an iterative alignment. After several minutes, the Statistics section of the dialog will update and should show zero deviation for each of the six pairs. The two models are now aligned. This alignment scheme simulates placing a manufactured blade in a physical fixture with four lean bars and two pins.

d. Click OK to exit the command.
Creating the Result Model

6. Create a color-mapped Result model to display deviations between the models.

a. Click **Analysis > 3D Compare**, or click the icon on the toolbar.

b. Click **Apply** to begin the comparison. After a few minutes, a color-mapped model will appear.

c. When calculation is complete, override the default spectrum values by entering **0.020** in the **Max. Positive** field and hitting the **Enter** key on the keyboard. Colored model will update accordingly.

d. Enter **0.005** for the **Min. Positive** field and hit **Enter** on keyboard.

e. Click **OK** to exit the command.
**Creating a 2D Whisker Plot**

7. Create a 2D Compare section.
   a. Click **Analysis > 2D Compare**, or click the icon on the toolbar.
   b. Under **Type**, click **Planar Deviation**.
   c. From the **Align Plane** dropdown menu, select **System Plane**, and then from the dropdown menu beneath that, select **XY-Plane**.
   d. Enter a **Position** value of **13.0 in**. This indicates we are going to section the model at a plane parallel to XY at a Z height of 13 inches.
   e. Click **Compute**.
   f. Move the slider wheel under **Scale** to approximately **10.0**. This will exaggerate the length of the whiskers, enabling a better view of which portions of the cross-section deviate the most.
   g. Click **OK** to exit the command.
Determining Blade Twist at a Cross-Section

8. Select the section to be analyzed in the Model Manager.
   a. In the Model Manager, expand the 2D Comparisons folder under the Result object.
   b. Click on the object called Comparison 1 in the 2D Comparisons folder. This will display the 2D whisker plot view.

9. Determine the amount of twist in the blade at this section.
   a. Click Analysis > 2D Twist Analysis.
      NOTE: You can place the icon for this command on the main toolbar by customizing the interface. See the Help menu to learn how.
   b. Leave the three checkboxes under Constrain Movement unchecked, so that the section will be free to rotate and translate as much as is needed.
   c. Click Apply. After a very brief calculation, the view will update to show the result of best fitting the 2D test section to the reference section. The resulting rotation and translation values appear in a table at the bottom of the view.
   d. Click OK to exit the command. Notice a new view appears in the 2D Comparisons folder called Comparison 1 – Twist.
      NOTE: Once you perform a twist analysis on a 2D section, you cannot edit that section, nor can you add annotations to it.
10. Determine the section where you want to take measurements.

a. Click **Tools > Section Through Object**, or click the icon.

b. Toggle on **Section Reference and Test Objects** checkbox, if not already.

c. From the **Align Plane** dropdown menu, select **System Plane**, and then from the dropdown menu beneath that, select **XY-Plane**.

d. Enter a **Position** value of 14.5 in. This indicates we are going to section the model at a plane parallel to XY at a Z height of 14.5 inches.

e. Click **Compute**. A cross-section is taken through both the Reference and the Test objects.

f. Click **OK** to exit the command.

---

**Extract Dimensional Characteristics of a Cross-Section**

*Result of 2D Twist Analysis*
11. Make the Test object active.
   a. Click Model Manager tab so that model objects are available for selection.
   b. Select the Test object.

12. Extract dimensions from this section.
   a. Click Analysis > Blade Section Analysis.
      *NOTE:* A dashed white line will appear through the airfoil section. This is the mean camber line.
   b. Click the Auto Dimensions button.
   c. Toggle on only the checkboxes for: Max Chord, Axial Chord, Leading Edge Radius, and Max Thickness.
   d. Click Apply. The requested dimensions will appear on the section.
      *NOTE:* If necessary, use the Shift+RMB (Right Mouse Button) to zoom out such that all dimensions are visible in the view.
   e. Click the Trailing Edge Thickness icon to add this dimension to the section.
   f. Click OK to exit the command.
Editing Dimensioned Cross-Sections

13. Edit the previously created dimensioned view.

   a. Click Analysis > Blade Section Analysis again.

   b. From the dropdown menu at the top, select which view you wish to edit (there is only one view in this case, so it is displayed by default).

   c. Click on the Axial Chord (AX_C) dimension.

   d. Click the Delete key on the keyboard to delete the dimension.

   e. Click on the Trailing Edge Thickness (TETHK) dimension.

   f. In the Offset field, enter a value of 0.25 in and click Apply. The dimension will update.

   g. Click on the Leading Edge Radius (LER) dimension and drag it around the leading edge. Notice that while the dimension is active, the arc that was fit to the leading edge points is displayed in gray.

   h. Click the Edit button on the dialog. Here you can modify default dimension names and tolerances. In addition, you can switch between two different methods of chord line calculation: Camber Line Intersection, where the chord line is determined by the intersection of the mean camber line with the LE and TE; and Tangent, where the chord line is determined by the tangency points of the LE and TE, simulated by lying the blade concave side down on a table and drawing a line between the two contact points.
i. Click **OK** to dismiss the **Options** pop-up window.

j. Use **Shift+RMB (zoom)** and **Alt+RMB (pan)** to orient the view how you want it shown in the report.

k. Click the **Save** icon at the top of the dialog under **View Control** to save this view orientation.

l. Click **OK** to exit the command.