Welcome to Ekahau Positioning Engine™ (EPE), the most accurate positioning platform for the Wi-Fi. EPE is a powerful software solution that enables a variety of new location-based applications for Wi-Fi tags, PDAs, laptops, and any 802.11a/b/g-enabled devices. The Positioning Engine includes a standalone Manager application and two ways (a Java SDK and a language-independent YAX™ TCP-protocol) for reading client location (x, y, floor), speed, heading, and logical area information, such as "Conference Room".

This User Guide takes you through software installation and setup, and helps you fully utilize the performance and features of EPE 3.0.
# Getting Started

**Awards-Winning Positioning Concept** .................................................. 3

**Positioning Engine Components** ..................................................... 3

**Evaluation Setup Requirements** ....................................................... 4

**Production Setup Requirements** ..................................................... 5

**Installing Ekaahau Positioning Engine™** ...................................... 6

**Installing Ekaahau Client** ............................................................... 6

**Accessing Ekaahau Technical Support** .......................................... 7

## Chapter 1: Wi-Fi Hardware Setup

**Supported Wi-Fi Adapters** ............................................................. 8

**Access Point Placement and Configuration** ..................................... 9

## Chapter 2: Ekaahau Client™

**Using Ekaahau Client** ................................................................. 11

**Limiting Positioning Engines** ....................................................... 13

## Chapter 3: Ekaahau Manager™

**How to Start Using Ekaahau Manager** ......................................... 14

**Loading and Configuring Your Map** .............................................. 16

**Performing Site Survey with Ekaahau Manager** ............................. 17

**Restricting Networks and Access Points** ....................................... 19

**Restricting Networks and Access Points** ....................................... 19

**Drawing and Editing Tracking Rails™** .......................................... 20

**Performing Site Calibration™** ....................................................... 22

**Using Remote Calibration Client for Higher Accuracy** .................... 24

**Mitigating Adapter Differences with Adapter Models** .................... 25

**Displaying Device Locations and Properties** ................................. 26

**Drawing and Editing Logical Areas** .............................................. 27

**Saving and Loading Positioning Models** ....................................... 28

**Sharing Work by Merging Positioning Models** ................................. 28

**Analyzing Positioning Accuracy** ................................................... 29

## Chapter 4: Ekaahau Manager Visualizations

**Signal Strengths** ........................................................................... 30

**Location Probability** ..................................................................... 32

**Expected Positioning Error** .......................................................... 33

**Accuracy Analysis** ....................................................................... 34

## Chapter 5: Maintenance

**Periodic Accuracy Test** ................................................................ 35

**Positioning Model Maintenance Methods** .................................... 36

## Chapter 6: Configuring Positioning Engine™

**When to Configure Positioning Engine, Manager, and SDK** .......... 37

**Working with Configuration Files** ................................................. 38

**Working with Positioning Engine Log Files** .................................. 47

## Chapter 7: Introduction to Ekaahau SDK™ and YAX™

## Chapter 8: License Upgrade

**How to Upgrade the License** .......................................................... 49
The award-winning concept of Ekahau Positioning Engine™ is to create a unique positioning model for each positioning site (such as a hospital, warehouse, or office), by recording Wi-Fi network data from various network locations. This patented process is called Ekahau Site Calibration™ and it allows significantly higher positioning accuracy than any other method, such as signal propagation or triangulation that does not take the actual radio environment characteristics into account.

Positioning Engine Components

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
<th>Supported Platforms</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ekahau Positioning Engine™</td>
<td>Java-based application server that provides the Ekahau T101 tag, PC, and PDA locations, areas, speed, and heading via Ekahau Java SDK, YAX protocol, or visually in sample applications or Ekahau Manager.</td>
<td>Ekahau supports Windows® XP and 2000</td>
</tr>
<tr>
<td>Ekahau SDK™ and YAX™</td>
<td>Ekahau Software Development Kit contains the SDK Java package, Javadoc, and code examples for quickly connecting to the Positioning Engine and reading location information. Programmers using other than Java language can alternatively use the Ekahau YAX™ protocol to read the location information via TCP socket.</td>
<td>Ekahau supports Windows® XP and 2000</td>
</tr>
<tr>
<td><strong>Ekahau Manager™</strong></td>
<td>Application for creating positioning models, saving them in the Positioning Engine, drawing logical areas, testing live positioning, and analyzing positioning accuracy.</td>
<td>Windows® XP, 2000 (requires a laptop)</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td><strong>Ekahau Client™</strong></td>
<td>Network reader component, which must be installed and running on each PC or PDA device that is to be tracked. Also required by Ekahau Manager laptop.</td>
<td>Windows® XP, 2000 Pocket PC 2002 and 2003</td>
</tr>
</tbody>
</table>

**Evaluation Setup Requirements**

**For quick evaluation, install EPE completely on a light laptop PC.**
You will need the following items for the evaluation setup:

- Light laptop PC with at least Windows® XP or 2000 Professional, 1 GHz processor, 256 MB RAM, and 500 MB HD space
- Ekahau Positioning Engine™ (full installation)
- A supported Wi-Fi adapter and driver (see [http://www.ekahau.com/devices](http://www.ekahau.com/devices) for supported versions)
- At least 3 standard Wi-Fi access points (all 802.11a/b/g models supported) – the test area should provide at least 3, preferably 5 or more access point signals at each location
- Map or floor plan of the area (in PNG, JPG, or BMP format)
- Measuring tape
Production Setup Requirements

For production use, install the Positioning Engine on a dedicated server and use a separate laptop PC for the Manager application.

- Install Ekahau Manager and Ekahau Client on a light laptop PC with at least Windows® 2000 or XP Professional, Pentium III, 256 MB RAM, 500 MB HD
- Install Positioning Engine on a server with at least Windows® XP or 2000, 1 GHz processor, 256 MB RAM, and 500 MB HD space
- Install Ekahau Client on all tracked PC or PDA devices with at least Windows® Pocket PC 2002 or 2003
- Supported Wi-Fi adapters for the Ekahau Manager laptop PC and each client device to be tracked
- At least 3 Wi-Fi access points (all 802.11a/b/g models supported)
- Map or floor plan of the area (in PNG, JPG, or BMP format)
- Measuring tape
Installing Ekahau Positioning Engine™

1. Double-click **Install_Engine_win32.exe**. In case of CD installation, place the CD in the drive.

2. If the installation does not start automatically, browse the CD’s root folder and double-click **Install_Engine_win32.exe**.

3. Follow the on-screen instructions and select the components you wish to install on the target computer (typically Full Install).

Installing Ekahau Client

To locate a wireless PC or PDA, you need to install the Ekahau Client software on the device, and keep the Client running.

1. Fully install a supported Wi-Fi adapter on the device. See [http://www.ekahau.com/devices](http://www.ekahau.com/devices) for supported adapters.

2. In case of Windows XP or 2000 computer, use the Positioning Engine installer or CD as described above, but only install Ekahau Client and the included Wi-Fi drivers.

3. In case of PDA installation (Pocket PC), first install Ekahau Client completely on a PC, then synchronize your PDA with [ActiveSync®](http://www.microsoft.com/activesync) to install the Pocket PC version of Ekahau Client.
Accessing Ekahau Technical Support

If you encounter problems while evaluating Ekahau software, or if you have improvement ideas, contact support@ekahau.com. The Ekahau technical support will respond within 24 hours on business days (Monday through Friday). Please include the following information in your e-mail:

- Detailed description of the problem
- Operating system in use
- Wi-Fi adapter manufacturer, model, and driver version
- Access point manufacturer and models

Ekahau technical support is free during the evaluation and for 30 days after purchasing a commercial license. After this initial period, a support package is required for further support and software updates. Ekahau support packages can be purchased at https://www.ekahau.com/store/
CHAPTER 1: Wi-Fi Hardware Setup

An old driver version of a Wi-Fi adapter is the most common reason for not receiving network data from Ekahau Client. Please update your Wi-Fi adapter driver after installing the adapter:

1. Insert your Wi-Fi adapter to the PC card slot and refer to its user manual to properly install the included drivers and utilities.

2. After installing the Wi-Fi adapter driver, open any adapter utility or diagnostics tool to display the driver version.

3. If the driver version number is lower than the one supported, you need to update the driver. For update instructions, see http://www.ekahau.com/products/client/drivers.

4. After installation, open any adapter utility or diagnostics tool to confirm that the driver was updated properly. If you have trouble updating the driver, please refer to the adapter and driver documentation before contacting Ekahau support.

Supported Wi-Fi Adapters

Ekahau Client and Positioning Engine have been tested on Windows® XP and 2000 with more than 40 leading Wi-Fi adapters, drivers, and PDA devices from Agere, Avaya, Buffalo, Cisco, D-Link, Enterasys, IBM, Nortel Networks, Proxim, and other manufacturers.

Click Start > Programs > Ekahau > Client > Release Notes or visit http://www.ekahau.com/devices for the latest list of supported Wi-Fi adapters, drivers, and devices.

If you find out that an untested adapter works, please send its model and driver version to support@ekahau.com.
Access Point Placement and Configuration

Ekahau Positioning Engine supports all 802.11a/b/g Wi-Fi Access Points. Follow these steps for good positioning results:

1. **Provide at least 3 access point signals at each location**
   - EPE can locate a device with only one AP signal, but a minimum of 3 signals must be detected by the client device in each location for better than 5 meter (15 ft) average accuracy
   - Increasing the number of AP signals increases accuracy. The preferred number of signals per location is 5-10

2. **Install “dummy” access points for additional signals**
   - To increase the number of AP signals per location, you may install additional “dummy” access points without network connection. Just power up the dummies. Channel configuration is not very important as the dummies are not sending data and will not interfere with data networks.

3. **Disable automatic power management features**
   - Disable optional power management and self-healing features for reliable positioning results
   - Enable ESSID broadcasting / probe responses to locate Wi-Fi adapters that do not support passive scanning

4. **Access point placement tips**
   - Start from the corners of the intended coverage area.
   - With 3 access points the test area size can be, for example, 20x20 m (obstructed) – 40x40 m (open).
   - If the area has low-height obstructions, such as office cubicles, attach the access points (using indoor antennas) to ceilings or walls above the height of the obstructions.
   - Do not place the access points (or antennas) in straight lines or near one another (less than 5 meters). Use adhesive tape to secure the antennas for a site survey and testing before installing them permanently.
• Depending on the desired coverage area, refer to your access point manual to adjust the output power levels.

5. **Minimized interference (noise)**

• High interference may decrease data throughput and positioning accuracy. Noise can be minimized by proper channel configuration, for example using 802.11b channels 1, 3, 6, 9, and 11 (for 5 adjacent access points), to keep the channels as separated as possible. Also try to minimize radio interference from other Wi-Fi networks and radio sources.

6. **Strong but diversified AP signals**

• Strong access point signals typically vary less than weaker signals. This is why the best positioning accuracy is usually achieved closer to access points, whereas areas with fewer and weaker signals provide lower accuracy.

• Stronger is better, but moving APs or using directional antennas to provide different RSSI for areas in close proximity will help differentiating the areas and improving accuracy.

7. **Site survey**

• To ensure that your access point placement provides the maximum coverage, perform a site survey with Ekahau Manager or Site Survey. Refer to Chapter 3 of this guide.

8. **Quick positioning demos with Ekahau Manager laptop**

• To quickly test positioning accuracy, use “dummy” access points only. Record a positioning model with Ekahau Manager and click the Ekahau icon in the upper right corner to display your laptop’s location. Walk around to test the accuracy.

| NOTE | If you need to move an access point after recording positioning model, refer to Chapter 3 to disable the moved access points from the positioning model, or re-calibrate the affected area. |
CHAPTER 2: Ekahau Client™

Using Ekahau Client

Ekahau Client allows Ekahau Manager to retrieve network data for site calibration (typically from a Wi-Fi adapter installed on a local computer), and allows the Positioning Engine to retrieve network data from client devices for positioning. This is why Ekahau Client must be installed and running on the Ekahau Manager laptop and on each client device that is to be tracked.

The Windows XP/2000 version of Ekahau Client provides Ekahau Client Controller / Properties dialog that can be used for:

- Viewing the Client status
- Starting and stopping the Ekahau Client service
- Configuring the allowed or restricted Positioning Engines
- Enabling or disabling the writing of an Ekahau Client log file

To access Ekahau Client Properties dialog, click the Ekahau icon in Windows system tray. If the icon is not displayed, start the Client Controller by selecting Start > Programs > Ekahau > Client > Ekahau Client Controller.

If you need to view, start, or stop Windows services manually, right-click My Computer on the desktop, and select Manage > Services and Applications > Services.

**NOTE**

Red Client icon ( ) on system tray means the Client service is not running. A yellow exclamation mark ( ) means an error. Click the icon to view error status.
Ekahau Client Properties dialog’s Status tab in Windows XP/2000

NOTE
Do not install more Ekahau Clients on PC or PDA devices than your EPE license permits (after Ekahau T101 tags). While installing is OK, you might run into tracking problems if the "wrong" client devices happen to register themselves into Positioning Engine before the preferred "right" ones.

NOTE
Ekahau Client’s GPS settings are for Ekahau Site Survey only, and are not supported by Ekahau Manager or Engine 3.0.
Limiting Positioning Engines

Ekahau Client users can limit the Positioning Engines that are allowed to locate them. When using the default Positioning Engine settings (set automatically during the installation), all available Positioning Engines typically appear in the Recently Discovered Positioning Engines listbox. You can then uncheck the Accept checkbox to deny positioning requests from that specific Positioning Engine. To allow requests from known Positioning Engines only, uncheck the Accept by default checkbox.

If you want to save the Positioning Engine settings, click the Add… button, select the name of the Positioning Engine from the drop-down listbox, modify the settings as appropriate, and click OK.

If you have manually modified Positioning Engine communication settings (see Chapter 6 to see why and how to do this), you may need to manually configure the Positioning Engine by clicking the Add… button. Select <custom settings> from the drop-down listbox, fill in or modify the Positioning Engine details, and click OK.
CHAPTER 3: Ekahau Manager™
How to Start Using Ekahau Manager

1. Double-click the Ekahau Manager shortcut.

2. When Ekahau Manager starts you are asked to provide the location and password of the Positioning Engine. If you installed the Positioning Engine on the same computer, click OK. Otherwise, enter the correct name or IP address of the computer that runs the Positioning Engine, and click OK. Use empty value for password unless you have manually configured Positioning Engine to use special password.

3. After Ekahau Manager has started, you can create a new positioning model or open an existing positioning model either from a file or the Positioning Engine database. Select New Positioning Model and click OK.
NOTE

When opening a saved positioning model from the Positioning Engine, make sure that the Positioning Engine is running.

4. Select **View > Signal Strengths**. You should see blue and gray bars indicating access point signal strength (RSSI) values.

5. If you do not see the blue / gray RSSI bars, ensure that your Wi-Fi adapter and driver version are supported (see Chapter 1 for details). Update the driver if necessary and restart the computer. If you still experience problems, contact support@ekahau.com.

6. If you want to change the unit system between Metric and Imperial, select **File > Preferences...**
Loading and Configuring Your Map

You need a map image for creating the positioning model. Supported map formats are PNG, JPG, and BMP.

1. To import a map, select New Map... from the File menu. Alternatively, you can right-click the Maps folder in the left window, and select New Map... from the context menu.

2. Click Browse to select a suitable map image.

3. To ensure that Ekahau Positioning Engine functions accurately, you must define the correct map scale for each map image. If you already know how many map pixels equal the map’s selected distance unit (meter/foot), you can type the value in the Map Scale field and click OK.

4. If you do not know the pixels/map unit ratio of the map, leave the field as zero and click OK. The map should shortly appear.

5. Click the blinking Measure tool ( ) and click a point on the map – for example the corner of a wall or another measurable object. Then click another point on the map, at least 3 meters (10 feet) apart from the starting point. Next, walk to the marked location on site and measure the real-world distance between the two points with a measuring tape. Type the real-world distance in the lower text field, and click Set Map Scale.

Use Measure tool for setting map scale. After setting the scale, you can use the Measure tool for measuring distances on the map.
Performing Site Survey with Ekahau Manager

When setting up a Wi-Fi network, the best access point or antenna locations are typically searched for maximum coverage and data throughput before installing the access points or antennas permanently. This process is often called site survey, and it is also recommended before recording data for a positioning model.

When performing site survey for positioning, you should observe the most important positioning attributes:

- Number of detected access point signals at each location. Accurate positioning requires at least 3, preferably 5-10.

- Signal strength (RSSI) of each AP signal. Stronger is better in general, however, adjusting APs or using directional antennas to provide different RSSI for different areas may help differentiating the areas and improving accuracy.

- Noise level (available separately in Ekahau Site Survey). Significant radio noise will decrease positioning accuracy. Avoid noise with standard channel planning (see Chapter 1).

Performing site survey for positioning use with Ekahau Manager:

1. Display signal strength information in the bottom view by selecting View > Signal Strengths.

2. Take your laptop with you and walk around the area while observing the number of detected signals and their signal strengths (RSSI) in Ekahau Manager. If necessary, move or add “dummy” access points to have at least 3, preferably 5-10 access point signals (blue bars) available in each location.

3. Once you have at least 3 access point signals everywhere, open a map and draw Tracking Rails as described later in this chapter.

4. Take your laptop with you and walk again around the area, stopping on the nearest tracking rail every 5-10m (15-30 ft), and clicking the rail with calibration tool selected. This will associate processed network data to your location.
5. After covering most of the important areas, click Ekahau Manager’s **Visualization** Tab and select **Signal Strength** view. This allows you to observe the 5 strongest access point signals at each location, typically helping network planning. At least the 3 strongest signals should provide average or strong signal strength for good accuracy.

For complete visualization instructions, see Chapter 4.
Restricting Networks and Access Points

All detected access points do not necessarily belong to the network under your control. For example, another company nearby may begin to use Wi-Fi access points that can be observed with Ekahau Manager. This causes problems if you use all detected access points for calibration, and your neighbors change their AP locations.

1. Prevent unwanted or unreliable access points from being used for positioning by de-selecting them in Access Point View below the Browser View, and clicking Apply. Clicking Reset will undo any changes that were made before clicking Apply.

2. When changing your Wi-Fi network, de-select from your positioning model any access points that have been physically moved or uninstalled, and save it back to Positioning Engine.

3. The restrictions apply for each map separately. To define restrictions for other maps, open each map image individually.

Access Point View below the Browser View.

NOTE

Data from all access points is processed and saved in the positioning model, but only the selected access points are used for positioning and accuracy analyses. This makes it possible to quickly test positioning and accuracy analyses with different access point combinations without a need for re-calibration.
Drawing and Editing Tracking Rails™

Before recording data for the positioning model, Tracking Rails must be placed on the map to indicate possible travel paths between rooms, corridors, floors, and other locations. The rails are quick to draw and provide improved positioning accuracy.

1. Activate Rail tool by clicking its icon (rail).  
2. Place the mouse pointer in the center of a walking path, room, or corridor, and click the map once to create a starting point.  
3. Move the pointer as far as you can on the path without crossing any wall or other obstruction. Click the map again to create a curve point, and continue drawing all essential paths in the area.  
4. To end the current rail, click the right mouse button. To continue, click the left mouse button.

| NOTE | You do not need to work on-site while drawing the rails, unless you want to observe the area when placing the rails. |

5. To select a rail or a curve point, activate the Edit tool and click the desired rail or curve point. You can select several objects by holding down the left mouse button. To move a rail, press down the left mouse button and drag the rail to another location. To delete a rail, select it and select Edit > Delete, or right-click the rail and select Delete from the context menu.  
6. To continue on an existing rail, or to create junctions, place the pointer on an existing rail or curve point, and left-click once.  
7. To draw rectangular rails that are always in a 45° angle, hold down the Shift key and left-click once.
8. To connect two adjacent maps or floors, draw a rail curve point for example in front of an elevator door or staircase, but do not end the rail. Select another map by clicking it in the Browser View. When you move the mouse pointer back on the other map, you will notice a round map link icon with a thumbnail map of the starting point. Move the cursor in front of the other floor’s elevator doors and click the map to create a two-way tracking rail between the two floors or adjacent maps.

1. Starting point of a map link in front of an elevator. Do not end the tracking rail but select another map

2. Select another map (another floor or adjacent map) by clicking it in the Browser View. Move the mouse pointer back on map to see a thumbnail of the first map

3. Click the correct location to place the map link’s end point. Continue the rail normally from the end point

NOTE The location estimates depend much on the rails that you place on maps. Be careful in marking only the correct paths that are accessible and used by the tracked devices.
Performing Site Calibration™

By placing Tracking Rails™ on the map, you have successfully created a positioning model. However, before you can use the positioning model for locating devices, it needs to be calibrated, i.e. you need to record network data from various map locations.

NOTE

For the best tracking accuracy use only supported adapters for site calibration and tracking. Ekahau also recommends using similar devices for creating the positioning model and tracking. Please see the next headings for details.

1. Take the Manager laptop with you and walk to a nearby Tracking Rail, making sure that you are standing on it.
2. Activate the Calibration tool by clicking its icon ( ).
3. Move the mouse pointer to your current location on the rail and click the map to record a sample point (SP). **Do not move away from your current location** until the record dialog disappears (in 10–20 s). While you remain in your current location, turn around slowly a full 360° to record the signals from all directions.

4. Walk about 3–5 meters along the rail and repeat Step 3 until you have calibrated the entire area. Please follow the recommended sample point recording principles for maximum positioning accuracy:
   - Record a SP at least every 3–5 meters
   - Record a SP in all Tracking Rail intersections
   - Record a SP in all Tracking Rail ends
   - Record a SP in all locations where the radio environment suddenly changes. For example, record one SP from both sides of a door (typically from a room and corridor).
   - In case of open areas, draw a grid of Tracking Rails and record a SP in the corners of each square. To reach high accuracy, draw and calibrate at least 5x5 – 3x3 meter grid.

5. To remove sample points, select **Edit > Undo**, or alternatively select the **Edit** tool ( ), right-click the unwanted sample point and select **Delete Sample Point** from the context or **Edit** menu.

6. To save the calibrated positioning model in the Positioning Engine, select **File > Save to Positioning Engine**. Type a filename and click **OK**. If the Positioning Engine is not running or cannot be connected, you will receive an error message.
Using Remote Calibration Client for Higher Accuracy

For the best tracking accuracy, Ekahau recommends using similar devices for creating positioning model and tracking.

For example, to locate Ekahau T101 Wi-Fi tags or certain PDA devices only, you should also record the data for your positioning model using a T101 tag or the PDA, not just any Wi-Fi adapter. **Ekahau Card Models** will automatically minimize the differences between any supported Wi-Fi adapters and devices, but using similar adapter or device for calibration and tracking phases is always the best option.

1. Make sure the tag, PDA, or other device can communicate with Wi-Fi network.

2. In case of PDA, make sure you are using a supported Wi-Fi adapter and driver (see [www.ekahau.com/devices](http://www.ekahau.com/devices) for the list).

3. In case of PDA, install Ekahau Client software and make sure it is running properly.

4. In case of T101 tag, open a terminal program and connect to the T101 tag via your laptop’s terminal program (see T101 user guide for instructions), then type in command `calibrate<Enter>`. This makes the T101 send data as fast as possible for site calibration use. If you hit **ESC** or the tag drops off from the calibration mode for some reason (you will see this if the status LED is not blinking every few seconds anymore), just repeat the calibrate command and continue.

5. Open Ekahau Manager, select **File > Preferences > Calibration Client**, and choose the IP address or friendly name of the device. This allows Ekahau Manager to retrieve network data from the selected remote device for creating the positioning model.

6. Attach or hold the tag or PDA similarly to the most typical user, for example using the tag’s belt clip.

7. Take your laptop and perform the site calibration (record data for your positioning model) as described in the previous sections.
Mitigating Adapter Differences with Adapter Models

Wi-Fi adapter manufacturers use different radio hardware and software in Wi-Fi adapters. Even individual adapters from same manufacturer typically have slightly incompatible scales for observing the RSSI values. This can cause positioning inaccuracy if the calibration and tracking steps are performed using different Wi-Fi adapters. The positioning inaccuracy caused by different adapter scales is typically 1-5 meters (3-15 ft) depending on the adapter, without using any mitigation technology.

Ekahau’s patented technology minimizes the positioning inaccuracy caused by RSSI measurement differences. Ekahau Client and Manager use method called Ekahau Adapter Models to automatically apply the correct adapter model to mitigate the differences.

The card models can be found from functions.cfg under Ekahau Manager’s conf directory.

| NOTE | In case of low accuracy for a specific device, open the Devices tab, right-click on the problematic device, and select Properties... from its context menu. Make sure the device’s Wi-Fi adapter and driver are supported. The conversion function for the specific technology should display OK. |
Displaying Device Locations and Properties

After drawing Tracking Rails and calibrating the positioning model, you can easily locate client devices by using Ekahau Manager’s internal positioning test feature.

1. To locate the Ekahau Manager laptop, click the Ekahau icon in the upper right corner.

2. To locate any other device, select Devices tab in the bottom view.

3. Click the Tracking checkbox for each device on the list to test tracking in Ekahau Manager. Make sure Ekahau Client software is installed and running on each PC or PDA to be located. Only devices running Ekahau Client will appear on the device list.

4. Right-click on a device and select from context menu:
   - Properties... to display many device properties such as MAC
   - Show RSSI... to display the device-specific signal strengths
   - Follow to automatically keep the device in map display

NOTE

The device list is retrieved from the Engine. This is why the Engine must be running to let Ekahau Manager display the device list. **Ekahau Manager however uses its local model and location test feature for locating the devices.**
Drawing and Editing Logical Areas

Logical areas are user-drawn areas (polygons) that can have a name and other location-based properties. Logical areas are used to determine whether a client device is within a given area.

1. Activate the Logical Area tool by clicking the icon (ением).  
2. Click the map, move the mouse, and click again until you have drawn the desired area. Use the left mouse button to connect the polygon ends and quit drawing.
3. Right-click the area in Browser View to name the area or to define custom properties for the area, available for application developers via Ekahau Java SDK or YAX protocol.
4. The most probable logical area is displayed for each client device in the Devices Tab when the Tracking checkbox is selected for the device. Logical area information can also be read from the Positioning Engine by using Ekahau SDK or YAX.

| NOTE | Make sure that you place at least one Tracking Rail and record at least one sample point inside each logical area – otherwise the logical area will not function correctly. |
Saving and Loading Positioning Models

Ekahau Manager can save models either as Ekahau Database files (.edb), or directly in the Positioning Engine’s internal database.

Typically, the best positioning model is always saved in the Engine, while test calibrations and exercises are saved as files.

After saving a positioning model in the Positioning Engine, it takes a few seconds before the Engine reads the new model into memory, and starts using it for tracking. As the tracking history queue is emptied, positioning accuracy can slightly decrease for the next 5–20 seconds.

Sharing Work by Merging Positioning Models

Ekahau Positioning Engine supports merging models to share calibration work between multiple users. For example, to calibrate a 10-map building, you can first agree that 3 people will record the data and merge their changes directly in the Positioning Engine.

8. Create and calibrate a positioning model for the floors you agreed to take care of.

9. When done, select File > Merge from Positioning Engine to read and merge any existing positioning model (saved by your colleagues) from the Engine to your model in Ekahau Manager. Nothing is changed in the Engine at this point.

10. The merge function will basically add any new maps, rails, sample points, and logical areas into your local positioning model in Ekahau Manager. However, merge will not update items that you have changed in your model if the same item(s) exist in the Engine and Manager models during the merge operation.

11. After inspecting that the merging was successful, you can save the latest positioning model (now including your changes) in the Positioning Engine, overwriting the existing version.

12. Before using the model, remember to add map links between the adjacent maps or floors.
Analyzing Positioning Accuracy

1. To statistically analyze positioning accuracy, select the Analysis tool by clicking its icon ( anális).

2. Open the map where you are located (inside the calibrated area).

3. Start walking at a constant restful speed across the areas that you wish to include in the accuracy analysis. Stay inside the calibrated area and always click the map in your current location when changing your direction or speed.

4. Right-click the map to end the analysis and display the error vectors in the Map View and statistical analysis on Accuracy Analysis Tab. Each “arrow” on the map describes the difference between the actual (clicked) location and a calculated estimate (constructed from the network data in the open positioning model, recorded for the same clicked location).

5. Right-click the accuracy analysis to access its context menu. You can rename or delete the analysis, update the analysis (to visualize it after opening an existing model), display error charts, or export the analysis data as a text file.

6. Should the average error be worse than 5m in any area, the likely reason is an insufficient number of available access point signals in the area, suboptimal placement of access points (or antennas), or too high radio interference. The placement issues can be resolved by modifying access point (or antenna) locations so that at least 3 access point signals can be detected throughout the area. However, this requires a new calibration.

7. Contact support@ekahau.com in case of consistent low accuracy.

---

**NOTE**
When opening a previously saved model file (.edb) that includes Accuracy Analyses, right-click on the analysis name and select Update Analysis to visualize the analysis results.
CHAPTER 4: Ekahau Manager Visualizations

To display the visualizations, you first need to draw Tracking Rails on a map and record some sample points. The selected/de-selected access points for each map affect the visualizations.

Signal Strengths

1. Select the **Visualization** tab from the bottom view.
2. Select the **Signal Strength** view.
3. Optionally, select **Viewed Signal**.

<table>
<thead>
<tr>
<th>Viewed Signal</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Strongest</strong></td>
<td>Displays the RSSI of the strongest access point (of all recorded) at each map location. This can be any (selected) access point that has the strongest signal at that map location.</td>
</tr>
<tr>
<td><strong>2\textsuperscript{nd} Strongest</strong></td>
<td>Displays the 2\textsuperscript{nd} strongest RSSI at each map location. Useful to see what happened if the strongest access point would crash: Is there a backup and how would it cover the area?</td>
</tr>
<tr>
<td><strong>3\textsuperscript{rd} Strongest</strong></td>
<td>Displays the 3\textsuperscript{rd} strongest RSSI at each map location. Useful to see what happened if the 2\textsuperscript{nd} strongest (typically a backup) would crash: Is there another backup access point and how would it cover the area?</td>
</tr>
<tr>
<td><strong>4\textsuperscript{th} Strongest</strong></td>
<td>See above</td>
</tr>
<tr>
<td><strong>5\textsuperscript{th} Strongest</strong></td>
<td>See above</td>
</tr>
</tbody>
</table>

4. Optionally, select the preferred **color scale** from the drop-down color listbox.
5. Optionally, configure the visualization’s **granularity**. Granularity affects to the edge length of the visualization. Use **coarser** setting when you do not have much sample points, but want to display as wide coverage as possible. Use **finer** level when you have more sample points and need more accurate visualization.

### NOTE
The visualization settings such as Granularity do not affect positioning in any way.

By switching the view between different access points, areas with poor network coverage can be spotted.

Displaying the accuracy analysis error vectors on the coverage areas provides insight to network planning problems that might cause decreased accuracy. For example, poor network coverage typically correlates with decreased positioning accuracy in the area. To solve the problem, change access point locations or antenna directions, or add more access points in the problematic area.
Location Probability

1. Select the **Visualization** tab from the bottom view.
2. Select the **Location Probability** view.
3. Optionally select **Positioning Mode**.

<table>
<thead>
<tr>
<th>Positioning Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Accurate</strong></td>
<td>Displays the probability for any device to be located inside the grid square, using device history of around 5 seconds (location update interval x 2.5 s)</td>
</tr>
<tr>
<td><strong>Real Time</strong></td>
<td>Same as above with 1 s device location history.</td>
</tr>
<tr>
<td><strong>No History</strong></td>
<td>Same as above without device location history. This view is similar to the Expected Error.</td>
</tr>
</tbody>
</table>
Expected Positioning Error

1. Select the **Visualization** tab from the bottom view.
2. Select the **Expected Positioning Error** view.

The Expected Error view is not using devices’ history information, meaning that the accuracy is typically lower than in reality. The Engine utilizes location history by default for higher accuracy.

---

Expected Error displays the estimated location error at each location without using device’s location history.
Accuracy Analysis

1. Select the **Visualization** tab from the bottom view.
2. Select the **Accuracy Analysis** view.

Accuracy Analysis view displays the recorded statistical average positioning error in colors for each location.

You must have at least one analysis case visible and calculated to display the visualization. Click the **Accuracy Analysis** tab, right-click the analysis case, and select **Update** from the context menu, after opening an existing model from a file or Positioning Engine.
CHAPTER 5: Maintenance

Periodic Accuracy Test

Positioning model inconsistency – the difference between recorded calibration data and actual radio environment – increases with changes in the environment, such as new walls, cubicle changes, large containers or furniture, and so on.

Extensive tests in various dynamically changing environments have proved that during a continuous 30-day field testing the average positioning accuracy may decrease up to:

- 5-10% in areas with dynamic changes (manufacturing area)
- 10-20% in areas with significant dynamic changes (shipping & receiving area)

Despite of the good robustness, Ekahau recommends testing active positioning models 3 times a year. Periodic testing can be performed quickly by opening the positioning model from the Positioning Engine, activating the tracking feature, and walking around while comparing the actual location to location estimate.

A more accurate and recommended method is to record new sample points (5–10 % of the number of points in the positioning model) to be analyzed against the original positioning model in Ekahau Manager. For detailed instructions on how to use Ekahau Manager for positioning accuracy analysis, see Chapter 4.
Positioning Model Maintenance Methods

In case of decreased average positioning accuracy, there are three correction methods. Before starting, back up the existing positioning model by saving it in a file under a different filename.

1. **Record more sample points**

   Record more sample points in the areas with decreased accuracy and save the positioning model in the Positioning Engine. This is typically the fastest and easiest solution, if the average accuracy has decreased by less than 20%.

2. **Recalibrate problematic areas**

   If adding new sample points did not help, or the average accuracy has decreased by less than 30%, delete the existing sample points by selecting the **Edit** tool and “dragging a rectangle” over the problem area with the mouse, then right-clicking a sample point, and selecting **Delete Sample Point(s)**. Record new sample points in the deleted areas and save the positioning model in the Positioning Engine. This method is very helpful if the area has changed only partially and neighboring areas do not need to be recalibrated.

3. **Recalibrate the entire positioning site**

   If adding new sample points did not help, or the average positioning accuracy has decreased by more than 50%, create a new positioning model, recalibrate the entire site, and save the positioning model to the Positioning Engine. This method is required if positioning accuracy has decreased due to structural or other major changes in the environment.
Ekahau Positioning Engine runs as a Windows XP/2000 service. All you need to do is keep the service running, thus allowing Ekahau Manager to save positioning models in the Positioning Engine, and location-based applications to query client location coordinates and other information from the Positioning Engine.

1. Ekahau Positioning Engine service starts automatically during the Windows startup.

2. If you need to manually start or stop the Positioning Engine service in Windows XP/2000, right-click My Computer on the desktop, and select Manage > Services and Applications > Services.

3. To save a positioning model in the Positioning Engine, select File > Save to Positioning Engine in Ekahau Manager. It takes about 10 seconds after saving to initialize and start using the new positioning model.

4. After saving a Positioning Model to the Positioning Engine, refer to Chapter 3 to see how to locate devices on map using Ekahau Manager. Refer to the Developer Guide to find out how to use Ekahau SDK or YAX™ protocol to retrieve the location information to your application.

When to Configure Positioning Engine, Manager, and SDK

In most cases, the Positioning Engine default installation works well out-of-the-box. There are times however when you may need to configure some of the Positioning Engine properties. For example, you may need to configure Positioning Engine to use another TCP/UDP port in case another application has already reserved the default port.
Positioning Engine service and Manager Application can be configured by modifying the `engine.conf` and `manager.conf` files with any text editor. The configuration files are located in the `conf` directories under the Ekahau Positioning Engine / Ekahau Manager / SDK installation folders. Save a backup copy of the original file before making changes, and remember to **restart** Positioning Engine, Ekahau Manager, or SDK application to apply the new settings.

The Positioning Engine and Manager Configuration files are in hierarchical XML format. For example, Ekahau Client’s UDP port setting is under the hierarchy `conf > deviceConnector > clientUdpPort`. You can see what the hierarchy looks like in the `engine.conf` example below.

If a configuration file does not exist, or contains incorrect values, the system default values are automatically applied.

If you modify the UDP communication settings between Ekahau Manager, Positioning Engine and Ekahau Client in the configuration files, you will also have to change those accordingly in Ekahau Client.

`engine.conf` and `manager.conf` files can be found under the `conf` folders in the Positioning Engine installation directory.

**Contents of engine.conf configuration file:**

```xml
<?xml version="1.0" encoding="UTF-8"?>
<conf>
  <authentication>
    <password>Llama</password>
  </authentication>
  <technologies>
    <technology name="802.11 a/b/g">
      <accessPoint>
        <band format="X"/>
        <netid format="{0x13:0x05}"/>
        <bsid format="{uppercase(0x13:0x06)}"/>
        <channel term="0x04" voc="0x13"/>
      </accessPoint>
      <dataFields>
        <field term="0x41" voc="0x15"/>
        <field term="0x42" voc="0x15"/>
      </dataFields>
    </technology>
  </technologies>
</conf>
```
<technology>
  <technology name="802.11b">
    <accessPoint>
      <band format="802.11b"/>
      <!-- Assume 802.11b by default -->
      <netid format="{0x13:0x05}"/>
      <bsid format="{uppercase(0x13:0x06)}"/>
      <channel term="0x04" voc="0x13"/>
    </accessPoint>
    <dataFields>
      <field term="0x41" voc="0x15"/>
      <field term="0x42" voc="0x15"/>
    </dataFields>
  </technology>
</technologies>
<deviceIdentity>
  <identifier format="{uppercase(0x13:0x06)}"/>
  <identifier format="{0x13:0x02}"/>
  <identifier format="{0x13:0x03}"/>
  <identifier format="(0x11:0x01)"/>
</deviceIdentity>
<!-- defaults to productionparameters -->
<productionParameters>
  <snapToRail>false</snapToRail>
  <expectedError>false</expectedError>
  <positioningMode>2</positioningMode>
  <!--1 = realtime, 2=accurate -->
  <locationUpdateInterval>2000</locationUpdateInterval>
  <numberOfAreas>5</numberOfAreas>
  <gpsScanInterval>2000</gpsScanInterval>
  <wlanScanInterval>500</wlanScanInterval>
  <wlanScanMode>2</wlanScanMode>
</productionParameters>
<errorCodeTranslations>
  <entry from="-310" to="0"/>
  <entry from="-309" to="7"/>
  <entry from="-300" to="6"/>
  <entry from="-301" to="6"/>
  <entry from="-302" to="6"/>
  <entry from="-303" to="6"/>
  <entry from="-304" to="6"/>
  <entry from="-305" to="1"/>
  <entry from="-306" to="5"/>
  <entry from="-307" to="1"/>
  <entry from="-308" to="1"/>
  <entry from="-1" to="0"/>
  <entry from="-2" to="7"/>
  <entry from="-3" to="5"/>
  <entry from="-4" to="1"/>
</errorCodeTranslations>
<entry from="-5" to="0"/>
<entry from="-6" to="1"/>
</errorCodeTranslations>
<gatekeeper>
  <port>8548</port>
  <timeout>10000</timeout>
</gatekeeper>
<database>
  <path>db</path>
</database>
<devices>
  <default remove-after="2m"/>
  <groups>
    <group name="YAX" remove-after="10m"/>
    <group name="ECLIENT" remove-after="10s"/>
  </groups>
  <sweeper run-interval="10s"/>
</devices>
<access-rights>
  <group name="administrator">
    <member-constraint/>
    <privileges>
      <privilege name="db" value="rw"/>
    </privileges>
  </group>
  <group name="guest">
    <member-constraint/>
    <privileges>
      <privilege name="db" value="r"/>
    </privileges>
  </group>
</access-rights>
<deviceConnector>
  <clientUdpPort>8546</clientUdpPort>
  <serverUdpPort>8545</serverUdpPort>
  <queryAddress>255.255.255.255</queryAddress>
  <queryInterval>10000</queryInterval>
  <deviceListCleanupSweepInterval>10000</deviceListCleanupSweepInterval>
  <deviceListCleanupMaxIdleTime>30000</deviceListCleanupMaxIdleTime>
  <bind>true</bind>
</deviceConnector>
</conf>
The following attributes can be changed or added in the Positioning Engine configuration file. The XML hierarchy is described by dots:

<table>
<thead>
<tr>
<th>Name</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>authentication.password</code></td>
<td>Llama</td>
<td>The password used to authenticate with the Positioning Engine</td>
</tr>
<tr>
<td><code>gatekeeper.port</code></td>
<td>8548</td>
<td>Positioning Engine listens to this TCP port for Ekahau Manager, SDK, and YAX communication</td>
</tr>
<tr>
<td><code>gatekeeper.timeout</code></td>
<td>10000 (ms)</td>
<td>Timeout for the server socket to wait for authentication TALK and HELLO-messages before disconnecting the client socket. You may have to adjust this if you test YAX with a telnet for example</td>
</tr>
<tr>
<td><code>devices.default remove-after</code></td>
<td>2 (min)</td>
<td>Device is removed from the device list after 2 minutes. These devices do not belong to either YAX or ECLIENT group</td>
</tr>
<tr>
<td><code>devices.groups.group name</code></td>
<td>YAX and ECLIENT</td>
<td>These are the default groups of devices. YAX means Ekahau tags and Palm client, while ECLIENT means PC/PDA with Ekahau Client software</td>
</tr>
<tr>
<td>Property</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><code>devices.groups.group remove-after</code></td>
<td>10s for Ekahau Clients, 10min for YAX devices</td>
<td>Devices which belong to this group are removed from the device list after a certain timeout. Use s, m or h postfix. For example 20h means 20 hours.</td>
</tr>
<tr>
<td><strong>Ekahau Clients</strong> (PC, PDA)</td>
<td></td>
<td>have a small timeout because their own timeouts are checked before they end up here. See <code>deviceConnector.deviceList CleanupMaxIdleTime</code>.</td>
</tr>
<tr>
<td><strong>YAX devices</strong> (Tags, Palm)</td>
<td></td>
<td>are not removed before their socket connection is closed. These parameters only affect devices without a new socket connection during the timeout period.</td>
</tr>
<tr>
<td><code>devices.sweeper run-interval</code></td>
<td>10 (s)</td>
<td>The former remove-after-parameters are checked / devices removed between intervals configured here.</td>
</tr>
<tr>
<td><code>deviceConnector.engineName</code></td>
<td>DNS name (leave in comments)</td>
<td>You can set a custom Positioning Engine name here. Maximum length is 128 characters.</td>
</tr>
<tr>
<td><code>deviceConnector.serverUdpPort</code></td>
<td>8545</td>
<td>Positioning Engine UDP port used for receiving data from client devices.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><code>deviceConnector.clientUdpPort</code></td>
<td>8546</td>
<td>Positioning Engine UDP port used for sending data to client devices</td>
</tr>
<tr>
<td><code>deviceConnector.queryInterval</code></td>
<td>10000 (ms)</td>
<td>Client query interval in milliseconds. Positioning Engine sends “AreYouAlive” UDP queries to <code>queryAddress</code> every n milliseconds</td>
</tr>
<tr>
<td><code>deviceConnector.queryAddress</code></td>
<td>255.255.255.255</td>
<td>Engine sends “AreYouAlive” UDP queries to this address</td>
</tr>
<tr>
<td><code>deviceConnector.deviceListCleanupSweepInterval</code></td>
<td>10000 (ms)</td>
<td>Positioning Engine’s device list gets cleaned up from old/not responding clients every n milliseconds</td>
</tr>
<tr>
<td><code>deviceConnector.deviceListCleanupMaxIdleTime</code></td>
<td>30000 (ms)</td>
<td>If the device has been idle n milliseconds, the next device list cleanup will mark Ekahau Client device for removal</td>
</tr>
<tr>
<td><code>database.db</code></td>
<td>db</td>
<td>The engine database path</td>
</tr>
<tr>
<td><code>technologies.XX and deviceIdentity.XX</code></td>
<td>-</td>
<td>Used to format and identify data, for example BSIDs. Usually there is no need to edit these</td>
</tr>
<tr>
<td><code>errorCodeTranslations.XXX</code></td>
<td>-</td>
<td>Internal parameters, no need to edit</td>
</tr>
</tbody>
</table>
| access-rights.XX          | - | By default, all Ekahau Managers with correct password can update the model database. Here you can create read-only managers which can only browse the model and track devices. Take app-id from your manager’s license.xml, for example “manager-42”, and change:  

```xml
<attr name="app-id" value="manager*"/>
```

to:

```xml
<attr name="app-id" value="manager-42"/>
```

After this modification (and restarting Engine) only Ekahau Manager with app-id “manager-42” can save a model in the Engine. |
| productionParameters.XX | - | The production parameters are described in the Developer Guide. These production parameters in engine.conf override the system defaults, but any YAX protocol or Ekahau SDK user can override these with their own values (check the developer guide to see how). |
Contents of manager.conf configuration file:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<conf>
  <authentication>
    <password>Llama</password>
  </authentication>
  <technologies>
    <technology name="802.11 a/b/g">
      <accessPoint>
        <!-- Ignoring the band in EPE
        <band format="{0x13:0x01}"/>
        -->
        <band format="X"/>
        <netid format="{0x13:0x05}"/>
        <bsid format="{uppercase(0x13:0x06)}"/>
        <channel term="0x04" voc="0x13"/>
      </accessPoint>
      <dataFields>
        <field term="0x41" voc="0x15"/>
        <field term="0x42" voc="0x15"/>
      </dataFields>
    </technology>
    <technology name="802.11b">
      <accessPoint>
        <band format="802.11b"/>
        <!-- Assume 802.11b by default -->
        <netid format="{0x13:0x05}"/>
        <bsid format="{uppercase(0x13:0x06)}"/>
        <channel term="0x04" voc="0x13"/>
      </accessPoint>
      <dataFields>
        <field term="0x41" voc="0x15"/>
        <field term="0x42" voc="0x15"/>
      </dataFields>
    </technology>
  </technologies>
  <deviceIdentity>
    <identifier format="{uppercase(0x13:0x06)}"/>
    <identifier format="{0x13:0x02}"/>
    <identifier format="{0x13:0x03}"/>
    <identifier format="(0x11:0x01)"/>
  </deviceIdentity>
  <!-- defaults to productionParameters -->
  <productionParameters>
    <snapToRail>false</snapToRail>
    <expectedError>false</expectedError>
    <positioningMode>2</positioningMode>
    <!-- 1 = realtime, 2=accurate -->
</productionParameters>
</conf>
```
<locationUpdateInterval>2000</locationUpdateInterval>
<!-- milliseconds -->
<numberOfAreas>5</numberOfAreas>
<gpsScanInterval>2000</gpsScanInterval>
<wlanScanInterval>500</wlanScanInterval>
<wlanScanMode>2</wlanScanMode>
</productionParameters>

<!-- These translate the "internal" errorcodes from FlowProblems and DeviceProblems to "external" errorcodes in DeviceStatusConstants. These should be in severity-order meaning that if the first-one is found from the list of errors for the order, then that one is the error sent to client no matter what the other errors are. -->
<errorCodeTranslations>
  <entry from="-310" to="0"/>
  <entry from="-309" to="7"/>
  <entry from="-300" to="6"/>
  <entry from="-301" to="6"/>
  <entry from="-302" to="6"/>
  <entry from="-303" to="6"/>
  <entry from="-304" to="6"/>
  <entry from="-305" to="1"/>
  <entry from="-306" to="5"/>
  <entry from="-307" to="1"/>
  <entry from="-308" to="1"/>
  <entry from="-1" to="0"/>
  <entry from="-2" to="7"/>
  <entry from="-3" to="5"/>
  <entry from="-4" to="1"/>
  <entry from="-5" to="0"/>
  <entry from="-6" to="1"/>
</errorCodeTranslations>

<master>
  <address>127.0.0.1</address>
  <port>8548</port>
</master>
<deviceConnector>
  <clientUdpPort>8546</clientUdpPort>
  <serverUdpPort>8547</serverUdpPort>
  <queryAddress>127.0.0.1</queryAddress>
  <deviceListCleanupSweepInterval>10000</deviceListCleanupSweepInterval>
  <deviceListCleanupMaxIdleTime>30000</deviceListCleanupMaxIdleTime>
  <bind>false</bind>
Here are explanations for only the attributes which differ from engine.conf:

<table>
<thead>
<tr>
<th>Name</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>master.address</td>
<td>127.0.0.1</td>
<td>Positioning Engine’s address</td>
</tr>
<tr>
<td>master.port</td>
<td>8548</td>
<td>Positioning Engine’s port. This must be same as engine.conf file’s gatekeeper.port</td>
</tr>
</tbody>
</table>

**Working with Positioning Engine Log Files**

Positioning Engine logging can be configured by modifying the `log.properties` file in the `conf` folder under the Positioning Engine installation folder.

The log files are by default stored in the `log` folder under the installation folder. To change the default folder, edit this line:

```text
log4j.appender.file.File = log/Ekahau${logfilesuffix}.log
```

For example, if you want the log files to be stored under `c:\log`-directory, the line should look like this:

```text
log4j.appender.file.File = c:/log/Ekahau${logfilesuffix}.log
```

Other important logging parameters are the **maximum file size** and **maximum backup index**:

- The maximum file size means that when the log file has reached a certain size, it will be backed up to another file and a new log file is created.
- The maximum backup index is the maximum amount of the backup log files. When this number is reached, the oldest file is deleted and replaced with the second oldest.
In the example below, we have changed the maximum file size to 2 MB and backup index to 7:

```java
log4j.appender.file.MaxFileSize = 2048KB
log4j.appender.file.MaxBackupIndex = 7
```

If you decide not to include general INFO level messages in your logs at all, change the level to WARN, ERROR or FATAL as follows:

```java
log4j.rootLogger=FATAL, file
```

---

**CHAPTER 7: Introduction to Ekahau SDK™ and YAX™**

Ekahau Positioning Engine (EPE) 3.0 offers two ways for serving location information to local or remote applications:

- **Ekahau SDK™** Java API for Java developers
- Character-based TCP protocol **Ekahau YAX™** for any programming language that supports TCP sockets

Both options utilize TCP sockets to connect to the Positioning Engine. The SDK is just an easy-to-use Java front end for the YAX protocol.

After recording a positioning model and saving it in the Positioning Engine with Ekahau Manager, use Ekahau SDK or YAX Protocol to read client coordinates, logical areas, speed, heading, and other information from Positioning Engine into your application.

For instructions on how to create location-based applications with Ekahau SDK and YAX, see the Developer Guide.
CHAPTER 8: License Upgrade

How to Upgrade the License

The limited Evaluation version of EPE expires after 30 days.

To track up to hundreds of devices without restrictions, visit Ekahau homepage at www.ekahau.com to purchase your full license.

After purchasing your license, you need to upgrade each Manager, Positioning Engine, and SDK installation separately:

- To upgrade Ekahau Manager, click **Start > Programs > Ekahau > Manager 3.0 > License Upgrade**. You may alternatively click **Help > About > Upgrade license**, if you are already running Ekahau Manager. Type the license key exactly as given, browse for the license file, and click **OK**. The **About** window should now display full license information.

- To upgrade the Positioning Engine, select **Start > Programs > Ekahau > Engine 3.0 > License upgrade**. Type the license information exactly as given, browse for the license file, and press **Enter**. The Positioning Engine license is now upgraded.

- To upgrade Ekahau SDK, select **Start > Programs > SDK 3.0 > License upgrade**. Type the license information exactly as given, browse for the license file, and press **Enter**. The SDK license is now upgraded.
Legal Notice

Ekahau, the Ekahau logo, Ekahau Site Survey, Ekahau Positioning Engine, Ekahau Manager, Ekahau T101 and Ekahau Client are trademarks or registered trademarks of Ekahau.

Other product and company names may be trademarks or trade names of their respective owners.

The enclosed software contains implementations of Ekahau’s patent pending inventions.

Under no circumstances shall Ekahau or Ekahau be responsible for any loss of data, income, or any direct, special, incidental, consequential or indirect damages howsoever caused.

Copyright © Ekahau, Inc. 2000–2004. All rights reserved.

Ekahau, Inc.
12930 Saratoga Avenue, Suite B-9
Saratoga, CA 95070
Phone 1-866-4EKAHAU
Fax 1-408-725 8405

Europe
Ekahau Oy
Tammasaarenlaituri 3
00180 Helsinki, Finland
Phone +358 20 743 5910
Fax +358 20 743 5919

www.ekahau.com
email: sales@ekahau.com