The Company
Geomagic is a software company dedicated to removing the barriers between the physical and digital worlds, and ultimately to changing the way we think and communicate in 3D. From mass customization of consumer products to 3D-enabled web marketing, from replacement of physical inventories by digital inventories to reproduction on demand of human bones and teeth, the 3D information technology pioneered by Geomagic has the potential to touch – and improve – nearly every facet of human life. The company has developed a powerful enabling technology that provides Digital Duplication™ solutions for design and manufacturing today, and a 3D foundation for the future.

Contact Information
Geomagic, Inc.
P.O. Box 12219
Research Triangle Park, NC 27709
Phone: (800) 251-5551 or (919) 474-0122
Fax: (919) 474-0216

Home Page: http://www.geomagic.com
Training Page: http://training.geomagic.com
Technical Support: support@geomagic.com
Licensing Questions: license@geomagic.com
Training Questions: training@geomagic.com

Guide Release History

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
<td>2004-Sep-30</td>
<td>Original Release</td>
</tr>
</tbody>
</table>
Table of Contents

Guide Description .............................................................................................................. 6
  Intended Audience ....................................................................................................... 6
  Guide Objective ........................................................................................................... 6
  Prerequisites ................................................................................................................ 6
  Guide Length ................................................................................................................ 6
  System Information .................................................................................................... 6
  Definition of Terms ..................................................................................................... 6

Introduction ..................................................................................................................... 7
  Geomagic Qualify Workflow ......................................................................................... 8

Complete Inspection Workflow ....................................................................................... 9
  Objective ...................................................................................................................... 9
  Files .............................................................................................................................. 9
  Open Data ................................................................................................................... 9
  Create Datums/Features .............................................................................................. 11
  Auto Create Datums/Features .................................................................................... 17
  Alignment ................................................................................................................... 18
  3D Compare ................................................................................................................. 21
  Create Callouts ........................................................................................................... 24
  Evaluate Callouts ......................................................................................................... 28
  2D Compare and Annotation ....................................................................................... 31
  2D Analysis – Section Through Object ....................................................................... 35
  Create 2D Dimensions ............................................................................................... 38
  Create Annotation ....................................................................................................... 46
  Location Set ................................................................................................................ 47
  Generate Report .......................................................................................................... 49
Guide Description

*Intended Audience*
This guide is suited for any user who will be using the Geomagic Qualify product to perform digital inspections.

*Guide Objective*
Provide the user with a working knowledge of the commands and workflows that are used in the Geomagic Qualify product. This knowledge will allow the user to develop a process using Geomagic Qualify that is suitable for his or her company.

*Prerequisites*
None

*Guide Length*
1 Hour

*System Information*
All files referred to in this guide are found in the folder specified below.

Folder of downloaded files from training web site.

*Definition of Terms*
N/A
Introduction

This Quick Start Guide will cover the basic commands and workflow used in the Geomagic Qualify product when inspecting a plastic part.

For more details on each command or function, please consult the on-line help by placing the cursor over the command in question and pressing F1.

For more tutorials on Geomagic products please visit the online training site at http://training.geomagic.com.

Command Lever displayed with Deviation Results
Geomagic Qualify Workflow

Test Data (Point Polygon, or CAD)

Reference Data (CAD or Polygon)

Geomagic Qualify

Create Datums

Create Features

Best Fit Alignment

Auto Create Datums/Features

Alignment

3D Compare

Create Annotations

3D Dimensioning

Auto 3D Dimensions

Create Callout

Evaluate Callout

2D Compare

Create Annotations

Compare Boundary

Create Annotations

Section Through Object

Create 2D Dimensions

Create Report

RPS RPS Alignment

Datum Alignment

Auto Report
Complete Inspection Workflow

Objective
Generate an inspection report for a small plastic part. Learn how to register scan data to the CAD model using a set of datums. Analyze the resulting deviations, create dimensions on cross-sections and prepare views for a report in HTML format.

Files

<table>
<thead>
<tr>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>command_lever-CAD.igs</td>
<td>CAD model of a small, mechanical part, exported as IGES from a CAD package.</td>
</tr>
<tr>
<td>command_lever-scan.asc</td>
<td>Scan data of the manufactured part.</td>
</tr>
<tr>
<td>command_lever-locations.loc</td>
<td>Location set data.</td>
</tr>
</tbody>
</table>

Open Data

1. Open the data that will be used in the inspection. The reference object can be a CAD model or STL model. The test object is the data that comes from the scanner. This can be either a point data file or an STL file. Open both sets of data at the same time with the command New found on the File menu.

   a. Click File > New or select the New icon . The New dialog appears.

   ![New dialog](image)

   b. Define the Reference model, which represents the as-designed condition. Click the Browse button next to the Reference box.

   c. Locate and select the file command_lever-CAD.igs in the specified folder.

   d. Click Open to chose selected file.
e. Define the **Test** model, which represents the *as-built* condition.
   Click the **Browse** button next to the **Test** box.

f. Locate and select the file **command_lever-scan.asc** in the specified folder.

g. Click **Open** to choose the selected file.

h. Click **OK**, to open both files.

2. The user will be prompted to specify the units for the scan data. Set the units to inches.
   a. Select **Inches** from the dropdown menu on the **Units** dialog.

   **NOTE**
   This particular scan data came from a scanner that outputs in inches.

   b. Click **OK**.
   The selected model and scan data will now appear in the Viewing Area.
3. The CAD model was designed in millimeters and exported as an IGES file as such. However for this inspection, the user will use inches. The user will need to change the workspace units to inches from millimeters.
   a. Click **Edit > Units**.
   
   b. Pick **Change Display**.
   
   c. Select **Inches** from the **Units** dropdown menu.
   
   ![Modify Units dialog]
   
   d. Click **OK** to change the units and exit the **Modify Units** dialog. The user is working in inches instead of millimeters.

**Create Datums/Features**

Once the data objects are loaded, the first step in inspecting a part is to align the point cloud (Test) to the CAD model (Reference) so that the user can perform a deviation analysis and compare the *as-built* condition (Test model) to the *as-designed* condition (Reference model).

Upon import, the CAD model is given the designation of **REF**, or **Reference**, in the **Model Manager** and the point cloud is designated as **TEST**. This designation occurs automatically and assists the software in some automated functions downstream.
1. Select the **Reference** object in the **Model Manager** to make active in order to define datums and/or features to be used for alignment.

   a. Click the **Model Manager** tab so that model objects are available for selection.

   b. Click **REF – command_lever-CAD** with cursor so that reference object is displayed in the Viewing Area. The point cloud (Test) will disappear from the Viewing Area and just the CAD model visible in the Viewing Area.

   **NOTE**
   Use **Ctrl+D** to fit the model to the screen.

2. Define a datum axis through the interior of the large cylinder (as shown in red) to be used in the alignment command of the **Reference** and **Test** object.
a. Click **Tools > Datums > Create Datums** or select the **Create Datums** icon.

**TIP**
Since some dialog boxes are wider than others, it may be necessary to expand the size of the **Dialog Manager**. To do so, simply place the mouse cursor over the right side of the dialog box until the arrows appear, then drag it to the right until the entire dialog box is visible.

b. Click **Axis** under the **Datum Type**.

c. Pick the **interior face of the large cylinder** and a datum axis will appear through the cylinder.

**NOTE**
The default method for defining a datum axis on a CAD model is to use the actual CAD geometry to find features such as cylinders and cones.

d. Click **Next** to accept datum axis and to move on to the next datum.

**NOTE**
This will accept the default name **Axis1**, but the user could have changed this name before selecting Next. In this tutorial, we will accept the default names.

3. Rotate the model in order to define a datum plane through the bottom face.
NOTE
To rotate the model use the middle-mouse button or CTRL+right-mouse button.

Face to define datum plane

a. Select A from the Name dropdown menu.

b. Click Plane under the Datum Type.

c. Rotate the part using the middle mouse button so the bottom face is visible for selection.
d. Pick the **bottom face**. A datum plane will be created on this face.

e. Click **Next** to accept datum plane and to move to the next datum. The user has now defined two datums.

4. Rotate the model to define a datum plane on the small angled face.

   a. Rotate the part so the small angled face is visible for selection.
   
   b. Pick the **angled face**. A datum plane will be created on this face.
c. Click **Next** to accept datum plane. This completes the definition of the datums. Check the list box on the *Create Datums* dialog for the three datums, Axis 1, A: Plane 1, and Plane 2.

![Current Datums list box](image)

TIP
The display parameters of the datums, such as the size and transparency, can be changed under **Tools > Datums > Modify Datum Display**.

![Model with Datum Plane](image)

d. Click **OK** to exit command.
**Auto Create Datums/Features**

The next step in the workflow is to define the same three datums on the Test object (point cloud). This will allow the system to “match” these datum pairs to achieve the proper alignment. To help the user, Geomagic Qualify has an innovative command that can automatically detect planes and cylinders in the point cloud and then create the three corresponding datums.

1. Use the **Auto Create Datums/Features** command to automatically generate the datums or features on the Test object.
   a. Click **Tools > Auto Create Datums/Features** or select the **Auto Create Datums/Features** icon.
      
      The dialog is displayed. Listed will be the three datums previously created on the Reference object. These datums will now be automatically generated on the point cloud.
   
   b. Check the **Perform Alignment** checkbox.
      Informs the system that the Reference and Test objects has not been aligned and will be required to compute a best fit alignment to help in defining the locations of the datums/features.
   
   c. Uncheck the **Fine Adjustments Only** checkbox if checked.
      Placing a check in this box would save time if the models were previously aligned, but that is not the case here.
   
   d. Uncheck the **Check Symmetry** checkbox if checked, since the model is not symmetric.
   
   e. Click **Apply** to start the creation of the datums on the Test object.
      
      As each datum is created, the **Automatable Datums/Features** section lists the progress. When complete, the list will display “OK” next to all three datums.
f. Click **Done** to exit the command.
The Test object now has two datum planes and one datum axis.

[Image of a 3D object with datums created]

**Display after Auto Create Datums/Features**

**Alignment**

In this step of the workflow, the user will align the Test object to the Reference object using a datum-based alignment method with the datums created in the previous step. There are multiple commands the user can use to align the data sets, such as **Datum/Feature Alignment**, **RPS Alignment**, **Best Fit Alignment**, **3-2-1 Alignment**, and **Manual Alignment**.

**NOTE**

In order to use **Datum/Feature Alignment** or **RPS Alignment** datums or features must exist in both the Reference and Test objects. Otherwise, one of the other alignment commands must be used.

1. Align the Test object to the Reference object using the datum axis and two datum planes along with the **Datum/Feature Alignment** command.
   a. Click **Tools > Alignment > Datum/Feature Alignment** or select the **Datum/Feature Alignment** icon.

[Diagram showing alignment process]
The Viewing Area is reconfigured to display the **Reference** object (CAD model) as the *Fixed* object, in the upper left frame, and the Test object (scan data) as the *Floating* object in the upper right frame.

2. Align the two-datum axis first, since they were designated as Datum A on the original engineering drawing. In order to align the datum axis, the user will be required to create pairs between the datum on the *Fixed* object (Reference) and the *Float* object (Test).
   a. Click **Axis 1** in the *Fixed* list box.
   b. Click **Axis 1** in the *Float* list box.
   c. Click **Create Pair**.
      The selected pair is added to the *Datum/Feature Pairs* list box and the lower frame in the Viewing Area is updated to show the axes aligned.

      The **Statistics** section of the dialog box tells the user that as a result of this first alignment, 2 of 3 rotational Degrees of Freedom (DOF) are constrained and 2 of 3 translational DOF are constrained. This means the floating data is able to rotate around the axis and still able to slide up and down the axis.
3. Lock the floating data along the datum axis to constrain the last remaining translation DOF. To do this the user will create a pair between the first datum planes.
   a. Click **A: Plane 1** in the *Fixed* list box.
   
   b. Click **A: Plane 1** in the *Float* list box.
   
   c. Click **Create Pair**.
      A second datum pair is created in the *Datum/Feature Pairs* list box. The bottom frame in the Viewing Area is updated as well as the *Statistics* section of the dialog box. The final translation available is now constrained. All that remains is one rotational DOF.

4. Constrain the remaining DOF by creating a pair between the remaining datum planes.
   a. Click **Plane 2** in the *Fixed* list box.
   
   b. Click **Plane 2** in the *Float* list box.
   
   c. Click **Create Pair**.
      A third datum pair is created in the *Datum/Feature Pairs* list box. The bottom frame in the Viewing Area is updated to show the final alignment based on the pairs order.

The final DOF is constrained and the *Statistics* section displays the two models are fully constrained.

<table>
<thead>
<tr>
<th>Statistics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status: Fully constrained.</td>
</tr>
<tr>
<td>Rotation: 3 of 3 constrained.</td>
</tr>
<tr>
<td>Translation: 3 of 3 constrained.</td>
</tr>
<tr>
<td>Datum Deviations:</td>
</tr>
<tr>
<td>Pair 1: 0.000000 mm</td>
</tr>
<tr>
<td>Pair 2: 0.000005 mm</td>
</tr>
<tr>
<td>Pair 3: 0.174991 mm</td>
</tr>
</tbody>
</table>

*Statistics after final Create Pair*
5. Accept the alignment and restore the Viewing Area to a single frame layout.
   a. Click **OK** to accept the alignment and exit the command. The Viewing Area will restore back to a single frame layout showing the models aligned.

   ![Viewing Area after Alignment](image)

   **TIP**
   The **Auto** button on datum-based alignment dialogs (Datum/Feature and RPS) will automatically create the pairs based on their order of creation.

   The user could have used this option in this example, since the datums were created in the same order that they were aligned. Next time, try using **Auto** to save a few steps!

**3D Compare**

Now the models are aligned, the user will perform a series of analyses to determine the deviations between the Reference object (as-designed) and the Test object (as-built).

The first analysis will be to create a colored 3D model showing the deviation between Reference object (CAD) and Test object (scan data). By using the 3D Compare command a new object will be created called a **Result**. This new object will be the colored 3D model.

1. Use 3D Compare to generate a 3D color model of the deviations between the Reference object and the Test object.
a. Select **Analysis > 3D Compare** or select the **3D Compare** icon

The **3D Compare** dialog has options define tolerance values for the colored model. Besides manually inputting these values, the user can use existing saved set of tolerances or let the system determine the average tolerance values.

b. Click **Apply** to use the system determined tolerance values. The system calculates the average and maximum deviations and uses these values to generate a default color map.

![3D Compare – Default settings](image)

2. Modify the display of the color map by changing the **Max. Positive** and **Min. Positive** tolerance values to some known tolerances.
   a. In the **Max. Positive** field, type in **0.020 in.**

   b. Press the **Enter** key on the keyboard.
      By pressing the **Enter** key the **Max. Negative** field will be automatically updated with **–0.020 in.** The color map will update dynamically after pressing Enter.

   c. In the **Min. Positive** field, type in **0.003 in.**

   d. Press the **Enter** key on the keyboard.
      The color map display updates in the Viewing Area.

**NOTE**
The basic information about the deviation between the objects is displayed at the bottom of the **3D Compare** dialog.
3. Change the display in the Viewing Area by turn ON the Test Object or by changing how the color map is displayed.
   a. Check the **Test Object** checkbox to display the scan data along with the color map. This may help in the visualization where some of the deviations may be occurring.

   b. To view just the Reference object with colors applied, toggle **Color Reference**. To view the Test object with colors, toggle **Color Test Points**. If the user would like to see the deviation direction and color, then toggle **Color Deviations**.

4. Accept the current color map and view the new **Result** object in the **Model Manager**.
   a. Click **OK** to exit the command.
      A new object is created called **Result**.

   b. Click the **Model Manager** tab to view objects in the part file.
**TIP**
Change the display of **spectrum bar** by placing the cursor over the spectrum in the Viewing Area and picking right mouse button. A popup menu is displayed which contains various display options.

The **Edit Spectrum** option on the popup menu and at Analysis > Edit Spectrum allows the user to change the color scale in many different ways.

---

**Create Callouts**
Create Geometric Dimensioning and Tolerancing (GD&T) feature control frames on the Reference object based on the information found on the drawing. The following GD&T types are available:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Geometric Characteristic</th>
<th>Symbol</th>
<th>Geometric Characteristic</th>
</tr>
</thead>
<tbody>
<tr>
<td>🂁️</td>
<td>Flatness</td>
<td>🂀️</td>
<td>Cylindricity</td>
</tr>
<tr>
<td>🌿️</td>
<td>Surface Profile</td>
<td>🌿️</td>
<td>Position</td>
</tr>
<tr>
<td>⊥</td>
<td>Perpendicularity</td>
<td>∥</td>
<td>Parallelism</td>
</tr>
<tr>
<td>⤽</td>
<td>Angularity</td>
<td>⤽</td>
<td>Total Runout</td>
</tr>
</tbody>
</table>

This section will not explain the details of what GD&T is; the tutorial will assume the user knows the details of the standard.

**NOTE**
To GD&T default, select **Tools > Options > Operations > GD&T**. Here the user will find the setting for **ISO** or **ANSI** standard.

The user will create two GD&T feature control frames, Cylindricity and Parallelism.

1. Define a Cylindricity feature control frame on the inner face of the large cylinder.
   a. Click **Analysis > GD&T > Create Callout** or click the **Create GD&T Callout** icon.
   b. Click **Cylindricity** under **Type**.
   c. Select **inner face of the large cylinder** and **drag** cursor to place feature control frame in the Viewing Area.
d. Define **Tolerance** under **Cylindricity**, **0.015**.

**NOTE**
The tolerance can be defined before or after the placement of the feature control frame.

e. Define **Outliers Percentage**, as required. In this example leave value at **1.0**.

The **Outliers Percentage** represents the number of points on the Test object that can lie outside the tolerance zone and be neglected during the evaluation.

f. Click **Next** to accept **Cylindricity** feature control frame.

2. Define a Parallelism feature control frame on the flat face (as shown in red) on the handle that references the datum, A: Plane 1.
a. Click **Parallelism** under **Type**.

b. Select **flat face** and **drag** cursor to place feature control frame in the Viewing Area.

c. Define **Tolerance** under **Parallelism**, **.015**.

d. Select datum, **A** from the first **Datum Reference Frame** dropdown menu. This is the datum, **A: Plane 1**, that was defined earlier in the workflow.

e. Define **Outliers Percentage**, as required. In this example leave value at **1.0**.

f. Click **Next** to accept **Parallelism** feature control frame.
g. Click **OK** to accept and exit command.

3. View new GD&T object created in the *Model Manager* under the Reference object.

   a. Click *Model Manager* tab.

   b. Click the plus sign [+] next to the **REF** object to expand and view the sub-objects.

   c. Click the plus sign [+] next to the **GD&T Views** sub-object to expand and see all available views.

   d. Click **GD&T View 1** object.
      Viewing Area displays selected view.

   ![GD&T View 1 with callouts](image)

**NOTE**
To edit an active GD&T view (visible in Viewing Area), click the **Create GD&T Callout** command. Select callout in Viewing Area to edit. Change parameters on dialog as needed. Select **OK** to accept changes.
**Evaluate Callouts**

Evaluate Callouts is only available once a GD&T View is defined with callouts. The Test object is evaluated to the callouts, which is then presented in a Go/No Go display. To better understand why a callout failed, a Color spectrum display is available.

In this step the user will evaluate the callouts defined in the previous step and change the display mode type.

1. Shade the Test object for better viewing of the analysis.
   a. Select **Test** object in **Model Manager** to make active.
   b. Click **View > Shading > Shade Points**
      Test object will be displayed shaded.
      ![Test object Shaded](image)
   c. Click **Analysis > GD&T > Evaluate Callouts** or click **Evaluate GD&T Callouts** icon.
   d. Click **Apply** to start evaluation process.

Once evaluation is complete, the results will be displayed in the Viewing Area. Each callout will have a sub-frame that displays pass/fail and the actual tolerance zone of the Test object.
2. Change the display mode to view how points relate to the tolerance zone.
   a. Toggle *Color Detail* under **Display Mode** to view the Test data in a color map, which helps the user see which points (area) are outside of the tolerance zone causing the failure.

   ![Color Detail](image)

   *Go/No Go display of callout evaluation*

   ![Callout Display Mode](image)

   *Evaluate Callout - Display Mode*

   b. Select **Parallelism callout** in the Viewing Area to make active.

   c. Place a check in the *Edit Spectrum* checkbox to modify the color spectrum.

   d. Define **Max. Positive, 0.015**, press *Enter* to input value. **Max. Negative** will update.
e. Define **Min. Positive, 0.001**, press **Enter** to input value. **Min. Negative** will update.

Using this display, the user can graphically view the areas on the Test data that are causing the callout to fail.

**NOTE**
The table at the bottom of the Viewing Area provides details on the each callout and the results of the point data tested. This information is included in the final report.

f. Select **Apply** to accept.

g. Click **OK** to accept results and exit command.

A new sub-object, **GD&T Views**, will be created under the Test object. The sub-object contains all GD&T views that have been evaluated.
2D Compare and Annotation

Another method of analyzing results is to take cross-sections through the Result model. This will display a whisker plot showing the difference between the Test object (point cloud) and the Reference object (CAD model) at a given 2D cross-section. Once the section has been created, an annotation can be added to the view to provide information about specific location. When defining a cross-section, the user can use existing datum planes, system planes, or user-defined planes.

The user will now create a cross-section called XZ=0.50 which an annotation will be applied to one location on the cross-section.

1. Create a cross-section that is parallel and 0.50 inches from the XZ system plane. Then scale the whiskers on the cross-section to better highlight the areas of greatest deviation.
   a. Select Analysis > 2D Compare or select the 2D Compare icon.

      ![A cutting plane is displayed.]

   b. Enter XZ=0.50 for the View Name.

   c. Toggle 3D Deviation under Type.

   d. Select System Plane from the Align Plane dropdown menu.

   e. Select XZ-Plane from dropdown menu.

      Cutting plane changes orientation in the Viewing Area.

   f. Use the Position slider bar to approximate 0.50 or enter 0.50 in the input field. This is a position one-half of an inch from the Y=0 plane.
g. Click **Compute** to generate the cross-section. The Viewing Area displays the generated cross-section view, which includes both the Test object and the Reference object.

2. Change the display of the cross-section whisker plot and accept the results. Whiskers represent the deviation direction and distance of a Test point when compared to the Reference on the cross-section.
   a. Increase the scale value of the whisker plot by moving **Scale** slider bar to the right.

   As the value increases, the whisker display in the Viewing Area becomes more noticeable. This helps in viewing the various areas of deviation.

   **TIP**
   Experiment by toggling ON/OFF some of the **Display** options, such
as **Whisker Ends** and **Highest Deviation Point**. Try increasing the number of **Whiskers** to see more detail.

b. Click **OK** to accept results and exit command. Click **Next** to create another cross-section.

3. View cross-section object in **Model Manager** and prepare view for annotation.

   a. Click the **Model Manager** tab.

   b. Click the plus sign [+] next to the **Result** object to expand and view the sub-objects.

   c. Click the plus sign [+] next to the **2D Comparisons** object to expand and view all cross-sections generated by the 2D Compare command.

   ![Model Manager View – 2D Comparison object](image)

   d. Select cross-section, **XZ=0.50** in the **Model Manager**. 2D cross-section is displayed in the Viewing Area.

4. Define an annotation on the active cross-section in the Viewing Area.

   a. Click **Result > Create Annotations** or select the **Create Annotations** icon. Viewing Area now displays the cross-section and a table, which maintains all annotation, found within this view.

   b. Pick the **Reference** object (purple object in view) with cursor and drag cursor to place annotation in Viewing Area. Use Zoom In (scroll wheel, with cursor in zoom location) to help in selecting the specified location.
An annotation, or note, is displayed which lists the deviation at that location, as well some additional information such as the XYZ position of the Reference and Test model at that location.

5. Change position of the annotation textbox in the Viewing Area so textbox does not hide portions of the cross-section.
   a. Select the annotation in the Viewing Area with the cursor and hold the left-mouse button. Drag the mouse to reposition the textbox then release left-mouse button to accept position of textbox. (Active textbox is highlighted in red.)

6. Change the items to be displayed in the annotation textbox. The default settings include; Name, Color Box, Deviation Dx, Dy, Dz, and Deviation Magnitude.
   a. Click Edit Display. A new dialog is displayed.
   b. Toggle each checkbox to view the output.
      The Color Box shows the magnitude of deviation relative to your spectrum.
   c. Click OK to accept changes and exit Edit Display dialog and return to Create Annotations dialog.

7. Create a few more annotations on the cross-section. Then accept the annotations and exit the command.
   a. Repeat previous steps to define annotation.
   b. Click OK to accept annotations and exit command.

**NOTE**
If an annotation is created in error, simply pick the annotation to make it active and press the delete key on the keyboard.
2D Analysis – Section Through Object

Until now all analysis has been done to view the deviation of a point or a group of points but has not included dimensions. In this section of the workflow, the user will create two cross-sections of the Test object that can be dimensioned to further analyze the as-built part.

This cross-section analysis differs from the previous cross-section in that it is done on the Test object not the Result object.

1. Define two cross-sections on the Test object.
   a. Click **Tools > Section Through Object** or select the **Section Through Object** icon.

   **TIP**
   To help visualize the Test object, select Test object in the **Model Manager** to make active before entering the **Section Through Object** command. Then choose **View > Shading > Shade Points**.

   ![Test object Shaded](image)

   b. Place a check in the checkbox next to the **Section Reference and Test Objects**, located in the **Options** section of the dialog. This creates the cross-section through both the Reference and Test objects at the same time and allowing this function to be included in Geomagic Qualify’s automation routines.

   c. Leave the default **Thickness** value (0.01 in.) This value defines the thickness of the cross-section. Which is useful when there is very little point data in the area of the cross-section.
d. Select **System Plane** from the *Align Plane* dropdown menu.

e. Select **XZ-Plane** from the dropdown menu. Cutting plane changes orientation in the Viewing Area.

f. Use the *Position* slider bar to approximate 0.25 or enter 0.25 in the input field.

![Cross-section cut plane defined (0.25)](image)

**Cross-section cut plane defined (0.25)**

g. Click **Compute** to generate the cross-section.

![Cross-section (0.25)](image)

**Cross-section (0.25)**

h. Click **Next** to accept current cross-section and proceed to the next cross-section definition.
i. Move the Position slide bar to approximate **1.68** or enter **1.68** in the input field.

![Cross-section cut plane defined (1.68)](image1)

j. Click **Compute** to generate the cross-section.

![Cross-section (1.68)](image2)

k. Select **OK** to accept cross-sections and exit command.
2. View the cross-sections in the Model Manager.
   a. Click the Model Manager tab.
   b. Click the plus sign [+] next to the Test object to expand and view the sub-objects.
   c. Click the plus sign [+] next to the Cross Sections object to expand and view all cross-sections generated by the Section Through Object command.

There are two cross-sections available, Section 1 and Section 2. These objects will be used to create 2D dimensions.

Create 2D Dimensions

The 2D Dimensions command allows the user to create various types of dimensions to measure the size of the Test object. This dimension is then compared to the nominal size. The following dimension types are available:

- **Horizontal**
- **Vertical**
- **Radius**
- **Diameter**
- **Angular**
- **Parallel**
- **2-Point**
- **Text**

Dimension the two cross-sections defined with Section Through Object command, **Section 1** and **Section 2**.
1. Activate the cross-section, **Section 1**.
   a. Select the cross-section, **Section 1** in the *Model Manager*. **Section 1** is displayed in the Viewing Area.

2. Create a parallel dimension on the part extension.
   a. Click *Analysis > Create 2D Dimensions* or select the *Create 2D Dimensions* icon. The *View Name* dropdown menu lists both of the sections, **Section 1** and **Section 2**. Confirm that **Section 1** displayed.
   b. Click **Parallel** under *Dimension Type*.
   c. Use the default *Pick Method, Best Fit*. 
   d. Drag a **rectangle** around the area as shown below. A green box will appear with a gray line fit through the selected points.
e. Drag another **rectangle** around the points roughly parallel to the first, as shown below.

**CAUTION**
Avoid selecting points that line in the fillet areas.

![Second Pick Method - Parallel](image)

f. Define the **placement** of the dimension by picking a location in the Viewing area roughly between the selected areas.

**TIP**
Use the F key on the keyboard to flip the arrows on the dimension. (inside/outside)

The dimension is still active if the arrows are magenta. Place the cursor over the label box and select with the left-mouse button and drag the dimension to the new position. Release the left-mouse button once in the new position.

![Parallel Dimension](image)
NOTE
The Reference object (CAD model) is displayed in the cross-section as a purple curve. As the dimensions are created, the Auto Detect Nominal will display the actual nominal value of the Reference object in the Nominal field if a check exists in the checkbox.

g. Enter a Tolerance value, +/-0.005 inches. Geomagic Qualify will then use this value to determine which dimensions pass or fail when it generates the report.

h. Click Next to accept current dimension, the dimension arrows turn white to indicate that dimension is not longer active.

3. Create a Radius dimension on the inner circle.
   a. Click Edit > Selection Tools > Lasso or select the Lasso icon.
   b. Click the Radius under Dimension Type.
   c. Drag the lasso around the inner circle as shown.

NOTE
Do not to include any other areas of the cross-section in the selection. A light gray circle will be fit through the points, indicating the detected radius.

TIP
The green color of the selected region box indicates that this dimension is automatable.

To deselect an area that has been selected, press and hold the CTRL key while reselecting the area to be removed. To add more to the current selection, press and hold the SHIFT key while selecting the area to add.
d. Define the **placement** of the dimension.

![Lasso Selection](image)

**Placement of Radius dimension**

![Placement of Radius dimension](image)

e. Select the radius dimension textbox and hold the left-mouse button. **Drag** the dimension to its new position.

f. Click **Next** to accept current dimension.
4. Create **Angular** dimension.

![Placement of Radius dimension]

- a. Click **Edit > Selection Tools > Rectangle** or select the **Rectangle** icon.  
- b. Click **Angular** under **Dimension Type**.  
- c. Select **First End**.  
- d. Select **Second End**.  
- e. Define the **placement** of the dimension.  

**TIP**
If the angular dimension is incorrect, press the A key on the keyboard to cycle through the three available angular dimensions based on the selection. Use the I key to invert the angular dimension.

To **Delete** the current dimension, press the delete key on the keyboard.

- f. Click **Next** to accept current dimension.
5. Create a **parallel** dimension from the small linear portion of the cross-section to the center of the circle as dimensioned by the radius dimension.

   a. Click **Parallel** under *Dimension Type*.

   b. Select **First End**, the small linear portion of the cross-section.

   c. Hold **CTRL** key on the keyboard and select the circle center crosshair.

   d. Define the **placement** of the dimension.

   **TIP**
   By holding the CTRL key and picking the selection area of an existing dimension, you can create “stacked” dimensions, or dimensions created off of one another.

   e. Click **Next** to accept current dimension.
6. Activate **Section 2** and create dimensions as shown.

   ![Section 2 dimensions](image)

   **Section 2 dimensions**

   a. Select **Section 2** from the *View Name* dropdown menu.

   b. Create required dimensions. When complete, experiment with the dimension types available.

   **NOTE**
   Remember to select **Next** to proceed to create the next dimension.

   c. Click **OK** to accept dimensions and exit command.

   **NOTE**
   To add or edit dimensions in an existing object, activate the cross-section in the **Cross Sections** sub-object under the **Test** object in the **Model Manager**.
Create Annotation

Annotation is label that contains a color box and other information to describe the deviation at selected points.

1. Create an annotation in the top view to highlight an area of concern.
   a. Click View > Predefined Views > Top or select the Top View icon.
   b. Click Result > Create Annotations or select the Create Annotations icon.
   c. Place cursor over model in the Viewing Area.
   d. Select location on model and drag annotation to a location away from the model.
   e. Create a three more annotations.

   **TIP**
   If the color box is gray, this means the selection is in a location where data does not exist. Increase the Dev. Radius value to increase the number of points found within the selection zone.

   f. Select OK to accept annotations and exit command.
**Location Set**
Create annotations automatically using a set of predefined locations.

Previously the user manually created annotations based on screen picks. If specific locations are required, then using a text file that containing these locations can be imported into the active model and annotated automatically.

1. Import an existing file containing the inspection point locations.
   a. Click **Analysis > Define Location Set**.

   b. Toggle **File** to use an existing .loc file.

   c. Click **Browse**.

   d. Locate the file, **command_lever-locations.loc**, in the folder specified at the beginning of the tutorial.

   **NOTE**
   Location sets are defined by a simple text file with a .loc extension, containing X,Y,Z coordinates. The locations can be points saved from a CAD package, a spreadsheet, or even defined within the Create Annotations dialog. There is no limit to the number of points.

   e. Click **Open**.

   f. Click **Inches** from the dropdown menu on the **Units** dialog.

   g. Click **OK** to import location set data.

   In the Viewing Area temporary colored points are displayed.

   ![Temporary Location Points](image)
The **Statistics** section informs the user the number of locations, or points in the selected files.

h. Click **OK** to create a new location set object. A new object called **Location Set#** is created under the **Datums** sub-object located under the **Result** object.

2. Use the new location set object to generate additional annotations.
   a. Click **Result > Create Annotations** or select the **Create Annotations** icon.

   b. Click **Location** under **Annotation Type**.

   c. Select **Location Set 1** from the **Automatic Placement** dropdown menu. (This is the data just imported.)

   d. Click **Auto Placement** under **Automatic Placement**. The system automatically creates annotations in the standards views, which best displays each location defined in the location set. In total 18 annotations will be created.

   e. Cycle through the different views using the **View Name** drop-down under the **View Control** section. Notice each view has a unique set of annotations and that the annotations were placed on the views according to which views the points were visible in.

   f. Select **OK** to accept annotations and exit command.
**Generate Report**

Generate a user-specified report of previously defined analyses. The generated report will contain the views and tables as specified by the user and be outputted in a format or formats as defined by the user.

Create an HTML report in the C:\temp directory that contains all defined views and a user specified cover page.

1. Generate a final inspection report.
   a. Click **Result > Generate Report** or select **Create Report** icon.

   b. Click ... to specify new **Output Directory**, c:\temp or define a location on the computer hard drive that the user has write access.

   c. Define a **unique name** for the report.
      Default name is current date and time appended to the Test object name. (i.e. command_lever-scan_20040924_163838) If desired, give the report a unique name.

   d. Check only **HTML** under **Formats**.

2. Define information to be included on the cover page.
   a. Click **Customize …**

   b. Click **Cover Page** under **Pages**.

   c. Fill out form with appropriate information.
      This information will be displayed on the cover page of the generated report.

   d. Cycle through the items on the left of the dialog to see what can be included or excluded from the report.

   e. Click **OK** to accept changes.

   **TIP**
   Any changes to this dialog can be saved as a .qtmpl file, or Qualify Template file.

3. Generate the report with the user specified settings.
   a. Click **OK**.
      The system starts the report generation process.

      When complete, a report with the given name will be saved to the specified directory.
4. Open a file manager to access HTML report.
   a. Double-click the *My Computer* icon on the desktop.
   b. Open the directory specific by the **Output Directory**.
   c. Open the report directory as defined by **Report Name**.
   d. Open the directory **html**.
   e. Double-click on the **report.html** file to view the contents of the report.
   f. Use the links on the left of the page to navigate the various pages of the report.